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 Chapter 1
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 Introducing the Munsys Sewer User Manual

Welcome to Munsys Sewer
Munsys Sewer is used to capture and maintain gravity, pressure and vacuum sewer networks. 
It is a user-friendly, easy to use geographic information management tool, which does not 
require GIS expertise to capture and manipulate data.

Munsys Sewer forms part of the Munsys product range, which comprises the following 
applications:

 Munsys Cadastral

 Munsys Cable Route

 Munsys Cable Fiber

 Munsys Drainage

 Munsys Electricity

 Munsys Roads

 Munsys Sewer

 Munsys Water

 Munsys Map Books

 Munsys Spatial Data Manager

 Munsys Management Console

 Munsys Query

 Munsys Lineage

 Munsys Scheduled Tasks



Introducing the Munsys Sewer User Manual 2 








About the Munsys Sewer User Manual
The Munsys Sewer User Manual enables users to easily find their way around Munsys Sewer, 
and provides a conceptual overview of the functionality used in Munsys Sewer. For the purpose 
of this manual, we assume that you are familiar with:

 the business rules of the application

 AutoCAD Map

 common GIS terminology

What’s in this manual
The Munsys Sewer User Manual consists of the following chapters:

 Chapter 1 – Introducing the Munsys Sewer User Manual, gives an overview of this manual, 
and provides links to additional reading material.

 Chapter 2 – Getting acquainted with Munsys Sewer, gives an overview of Munsys Sewer 
and its various components.

 Chapter 3 – Querying sewer data from the database, describes how to query sewer data from 
the database.

 Chapter 4 – Creating sewer data, shows the user how to capture a sewer network, add 
additional sewer objects, and post sewer data to the database.

 Chapter 5 – Maintaining sewer data, describes how to maintain existing sewer data.

Additional reading material
Before you start using this manual, we suggest that you first read the 
Munsys Concepts User Manual, which contains the following information:

 the generic functionality of the various Munsys applications

 the generic query functionality that is used to query spatial data from the Oracle® database 
and how to structure a query through query settings and GSC settings using the Munsys 
Query Palette

 how to view spatial data using the Munsys Info Palette

 how to work with Munsys Objects

 extras such as annotation, reporting and legend options.
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Conventions in this manual
The following table lists the typographical conventions used in this manual.

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

 general issues, select Help from the Munsys menu bar.

 an operation in progress, click the Help button on the dialog box.

 the latest support options, visit http://www.openspatial.com

Text element Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial

Menu paths choose Query > Clear Basemap.

Hypertext links to applicable sections in 
the document/the Web

....see Appendix A

Text displayed/typed on the 
command line

Munsys Sewer

Dialog box/screen names The Sewer Settings dialog box

Application functions The Integrity Check function

http://www.openspatial.com
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 Chapter 2


 Getting acquainted with Munsys Sewer

About Munsys Sewer
Munsys Sewer is used to capture and maintain gravity, pressure and vacuum sewer networks. 
Sewer pipes are placed along cadastral boundaries and broken where nodes are inserted, for 
example manholes, junctions and reducers. 

Service connections are drawn to the land parcels to create connectivity between sewer pipes 
and parcels. 

Sewer basins represent different parts of the sewer network. The basins are shown as polygons 
surrounding a section of the network. The basins represent different networks up to the 
purification works, or even smaller sections up to the primary outfall sewers.

The Munsys Sewer toolbars and menus enable the fast and efficient capture and maintenance 
of sewer data. Munsys Sewer also checks for the integrity of spatial and attribute data before 
the data is posted to the database.
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Launching Munsys and Munsys Sewer
To launch Munsys, do one of the following:

1 Double-click the Munsys Application 15.1 icon on the Windows desktop.

2 Choose Start > Program Files > Open Spatial > Munsys 15.1 > Munsys Applications 15.1

Connecting to the Oracle database
Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator 
technology is that spatial and attribute data are captured and managed in a single database. This 
reduces processing overheads and eliminates the complexity of coordinating and synchronizing 
different sets of data.

The Munsys Applications support multiple Logons which permit users to logon to different 
databases such as Training, Test or Production databases by selecting a Logon Profile from a 
drop-down list. When the Connect function is selected, the logon credentials (excluding the 
password) are pre-populated based on last successful database connection. 

The Logon Profile details are customizable and stored in the Current User’s Registry Keys. By 
default, three Logon Profiles are defined, namely Logon1, Logon2 and Logon3. The Logon 
Profile descriptions can be changed from the default description to be more meaningful one by 
simply clicking in the text box next to the Logon Profile and overwriting the default value. 

Important You have to be connected to the Oracle database before you can start working with Munsys 
Sewer. If you try to launch any application without being connected to the database, you will be prompted 
to connect to the database first.

To connect to the Oracle database

1 For first time connection do one of the following:

 Choose File > Database > Connect....

 Click the Connect to Database button on the Munsys standard toolbar.
The Connect to Database dialog box is displayed.
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Figure 1 The Connect to Database dialog box

2 In the Logon Profile box, select a profile from the drop-down list.

Note The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text 
box and overwriting the default description with a value not exceeding 25 characters, for example: 
TRAINING, TEST, STAGING or PRODUCTION.

3 In the User Name field, enter your user name.

4 In the Password field, enter your password.

5 In the Schema field, enter the schema name.

6 In the Database field, enter the database name.

7 Click OK.

On successful connection to the database, the last Logon Profile, User Name, Schema and 
Database details are saved in your Current User’s Registry Key where they are used to pre-
populate the Connect to Database dialog-box on next logon. Your password is never saved, and 
you will always be prompted to enter your Password.

Figure 2 The Connect to Database dialog box with Logon Profile
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Note The last used Logon Profile details, and the various Logon descriptions are stored in the registry key 
Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 15.1\Applications\Logons, 
whilst the registry key Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 
15.1\Applications\Logons\[Logon1] saves the individual User Name, Schema and Environment Name 
details per Logon Profile. 

The administrator assigns you user rights to log on to the database, and will inform you what 
your user name, password, schema name, and database are. A successful connection to the 
database activates the appropriate functions on the menu bar and toolbars.

To launch Munsys Sewer
When you launch Munsys for the first time, the configured base map automatically loads. 
When you launch Munsys Sewer, the Munsys Sewer functions are loaded onto the menu bar 
and toolbars. 

1 To launch Munsys Sewer, do the following:

 Choose File > Munsys Applications.

 Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Figure 3 The Available Applications dialog box

2 From the list of available applications, select Sewer, and then click OK.

The Munsys Sewer functions become available on the menus and toolbars.
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The Munsys Sewer interface
The Munsys Sewer interface consists of the following:

Figure 4 The Munsys Sewer interface

Munsys menu bar – contains the Munsys and AutoCAD Map menus. Munsys menus are 
defined by a menu file, which automatically loads when the Munsys application is launched.

Standard toolbar – contains frequently used AutoCAD Map buttons, standard Microsoft® 
buttons and Munsys buttons for connecting to the database and launching the various Munsys 
applications.

AutoCAD Map drawing area – this area is used to display Munsys data that is extracted from 
the database and AutoCAD Map drawings.

AutoCAD Map command line – displays prompts and messages.

AutoCAD Map status bar – displays information/drawing aids.

Munsys main toolbar – contains frequently used Munsys functions.
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Munsys Integrity toolbar – contains the Integrity Check and Post to Database functions.

Table 5 The Munsys Sewer Integrity Toolbar

Munsys Sewer toolbars – Munsys Sewer has six application-specific toolbars that are displayed 
when activated. To display the Sewer toolbars, right-click in the grey area on the right-hand side 
of the Munsys Standard toolbar. 

Point to MUNSMS, and then select the toolbars that you want displayed one by one. The 
toolbars are displayed in the drawing area.

Use this button When you want to...

...check sewer object integrity

...check sewer network integrity

...browse integrity markers

...erase integrity markers

...post data to the database
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 The Munsys Sewer Capture toolbar contains the following buttons:

Table 6 The Munsys Sewer Capture toolbar

Use this button When you want to...

...specify sewer capture settings.

...draw an offset gravity pipe.

...draw an offset pressure pipe.

...draw an offset vacuum pipe.

...draw a freehand gravity pipe.

...draw a freehand pressure pipe.

...draw a freehand vacuum pipe.

...place a sewer symbol.

...place a gravity pipe label.

...place a pressure pipe label.

...place a vacuum pipe label.

...place a sewer note.

...place sewer dimensions.
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 The Munsys Sewer Change toolbar contains the following buttons:

Table 7 The Munsys Sewer Change toolbar

 The Munsys Sewer Flow toolbar contains the following buttons:

Table 8 The Munsys Sewer Flow toolbar

 The Place Node toolbar is used to place sewer nodes at the endpoints of sewer pipes. 

 The Insert Node toolbar is used to insert sewer nodes anywhere on sewer pipes.

Use this button When you want to...

...extend a sewer pipe to a boundary.

...extend a sewer pipe by distance.

...extend and break a sewer pipe.

...break a sewer pipe.

...move the endpoint of a pipe to a new location.

...fillet sewer pipes.

...trim sewer pipes.

...move a node.

...rotate a node.

...snap a node to the endpoint of a pipe.

...snap a node to the endpoint of a pipe, breaking the pipe.

...change a sewer note.

Use this button When you want to...

...show sewer flow direction.

...change sewer flow direction.

...clear direction arrows.
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Note The Place Node and Insert Node toolbars vary between the different locales to cater for the unique 
requirements of each geographical region.

 The Munsys Sewer Place SC toolbar contains the following buttons:

Table 9 The Munsys Sewer Place SC toolbar 

In Munsys Sewer, functions are activated by:

 typing the command on the command line

 activating the function from the menu bar

 clicking the appropriate button on the toolbar

Use this button When you want to...

...place a single 45 deg endpoint service connection.

...place a single 45 deg nearest service connection.

...place a single 90 deg endpoint service connection.

...place a single 90 deg nearest service connection.

...place a double 45 deg endpoint service connection.

...place a double 45 deg nearest service connection.

...place a double 90 deg endpoint service connection.

...place a double 90 deg nearest service connection.

...place a freehand service connection.
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About sewer objects
Munsys Sewer caters for the following sewer objects:

Sewer pipes are placed along cadastral boundaries. A sewer network contains the following 
sewer pipes:

 gravity pipes – either street sewers (sewer pipes that run in the road), midblock sewers (pipes 
that run in the middle of land parcels) or outfall sewers (bulk sewer pipes).

 pressure pipes – sewer pipes where sewage is pumped against gravity.

 vacuum pipes – sewer pipes where the flow direction is determined by an induced vacuum.

Sewer nodes indicate where the sewer pipes are connected, or where the sewer pipes terminate.

Sewer notes supply additional information about plans and drawings.

Service connections are the initial connection from the parcel to the rest of the sewer network. 
Service connections usually connect to the pipe at 45 or 90 degrees. Sewer pipes are not broken 
where the service connection ties in to the pipe.

Residential sewers are captured to indicate the sewer pipes running from buildings to service 
connections. Residential sewers do not form part of the network connectivity.

Dimensions supply additional information in terms of the location of a sewer object, relative to 
the cadastral boundary.

Sewer Basins are used to view certain parts of the sewer network up to the purification works, 
or even smaller sections up to the primary outfall sewers. Sewer basins are captured as polygons.

Labels contain dynamic text information that represent a specified column in the database.

Sewer symbols represent additional annotation in the form of a symbol, and do not form part 
of the sewer network.
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

 Querying sewer data from the database

Introduction
This chapter describes how to query sewer data from the database using the Query menu. 
Sewer data is queried from the database as follows:

By Sewer Network – retrieves all sewer objects related to the sewer network, and according to 
the current GSC. This includes sewer nodes and pipes (vacuum, rising and pressure pipes), 
sewer labels, service connections, notes, and dimensions/dimension notes.

Sewer basins and residential sewers do not form part of the network and are queried separately.

You can also query a map page grid, which can be used to locate services based on the map 
page number, and is represented by a layout of polygons.

Should you need to query only a specific sewer object type or define your own query, you can 
use the functionality on the Munsys Query Palette. (The Query Palette is described in the 
Munsys Concepts User Manual.) Sewer data that is queried includes the retrieval of the spatial 
and attribute data.
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Querying a map page grid
This query retrieves a map page grid from the database. The map page grid can be used to locate 
services based on the map page number, and is represented by a layout of polygons similar to 
the sheet layout used in Munsys Map Books. The map page grid can be modified by using the 
Object > Generate MunPolygons and Object > Edit MunPolygon menu items to capture and 
change the map page grid objects. The sewer map page grid is retrieved onto the 
SEWMAPPAGE layer.

To query a map page grid
 Choose Query > Map Page Grid.

The map page grid is retrieved to the extents of the database.

Figure 1 Querying a map page grid
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Querying a sewer network
This query retrieves all the sewer object related to the sewer network according to the current 
GSC, and onto their respective layers. The following objects are retrieved:

To query a sewer network
 Choose Query > Sewer Network.

The objects are retrieved from the database and displayed, and the command line indicates 
how many sewer network objects respectively have been retrieved from the database.

Figure 2 Querying a sewer network

Sewer network object Layer Munsys object type

Sewer dimension SEWDIM MunPoint

Sewer dimension note SEWDIM-
NOTE

MunLabel

Sewer node SEWNODE MunPoint

Sewer pipe: Gravity
Sewer pipe: Vacuum
Sewer pipe: Pressure

SEWGPIPE
SEWVPIPE
SEWRPIPE

MunLine

Service connection SEWSERV MunLine

Sewer label: Gravity
Sewer label: Vacuum
Sewer label: Pressure

SEWGLABEL
SEWVLABEL
SEWRLABEL

MunLabel

Sewer note SEWNOTE MunLabel
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Querying sewer basins
Sewer basins show different parts of a sewer network up to the purification works. Sewer basins 
are retrieved to the SEWBASIN layer according to the current GSC.

To query sewer basins
 Choose Query > Sewer Objects > Sewer Basins.

The command line indicates how many sewer basins were retrieved from the database.

Figure 3 Querying sewer basins

Sewer basins are retrieved onto the 
SEWBASIN layer
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Querying residential sewers
This query retrieves all the residential sewers from the database onto the SEWRESPIPE layer, 
according to the current GSC.

To query residential sewers
 Choose Query > Residential Sewers.

The command line indicates how many residential sewers were retrieved from the 
database.

Figure 4 Query residential sewers

sewer pipe

service connection

residential sewer
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 Chapter 4


 Creating sewer data

Capturing sewer data
This chapter describes how to capture a sewer network and additional sewer objects, and how 
to post the captured data to the database.

Before you start capturing a sewer network, you first need to query the relevant cadastral data 
from the database to make certain that the sewer objects locate geographically correct. Existing 
sewer objects should also be queried to determine the relationship between existing and new 
sewer objects. This will prevent data duplication.

Sewer pipes are captured first. After the sewer pipes have been captured and you have verified 
with the sewer flow direction arrows that pipes converge to the lowest point in the network, 
sewer nodes are placed. 

When you have placed the sewer nodes, you will capture service connections. 

Manholes are placed on sewer pipes to indicate access to the pipes. Pump stations are placed 
on pressure pipes. Valves are inserted between sewer pipes. Vent stacks provide ventilation to 
the sewer network. An end cap is placed at the end of a sewer network. Vacuum stations and 
vacuum chambers are placed on vacuum pipes. 

Next, pipe and node elevations are attached to the spatial data. When you have captured all 
the sewer objects needed to complete the sewer network, you are ready to run the integrity 
check, and then to post the sewer data to the database.
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Sewer capture settings
Each Munsys application has its own default capture settings that are set by the database 
administrator in the Munsys Management Console. 

In Munsys Sewer, default settings are available for: 

 basins – the basin tag height

 dimensions – the dimension note height

 file – the drawing directory

 general – database extents display resolution, include network in object integrity, integrity 
circle size, tag and symbol scale and rotation if coordinate transformation is done, snap 
tolerance, tag angle, font, height and justification

 pipes (gravity, pressure and vacuum) – label height, material, type, diameter and default 
offset distance

 integrity – sewer node, pipe, service connection and search tolerance, short objects

 sewer nodes – the sewer node scale

 sewer notes – the note tag height

 sewer symbols – the sewer symbol scale

 residential sewers – the residential sewer pipe offset distance

 service connections – the default length and service connection type

You can change the current settings on the Sewer Settings dialog box to speed up the capture 
process. Capture settings only apply to new sewer objects, and if you change the default settings, 
the changes are only valid for the current session.

Settings are changed by highlighting the current value, and then entering a new value, or by 
selecting the new value from a drop-down list.

The user cannot change all of the settings. Some settings may only be changed by the database 
administrator to enforce consistency and integrity on a higher level.

Tip A short description of a value is displayed when it is highlighted.

To specify sewer capture settings

1 Do one of the following:

 Choose Capture > Sewer Settings...

 Click the Sewer Settings... button on the Munsys Sewer Capture toolbar.

The Sewer Settings dialog box is displayed, showing the default sewer capture settings.
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Figure 1 The Sewer Settings dialog box

2 To change a value, do one of the following:

 Highlight the current value, and then enter a new value.

 Highlight the current value, and then choose the new value from the drop-down list.

3 Click OK to apply the new settings.

The settings will apply until you change them again, or until the current session is terminated, or 
until you switch to a different application.

Some values are changed by 
selecting a value from a drop-
down list. 

Some values are changed 
by manually entering a 
new value.
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Capturing sewer pipes
A sewer network usually contains the following types of sewer pipes:
 Gravity pipes – street sewers (sewer pipes that run in the road reserve), midblock sewers 

(pipes that run in the middle of land parcels) or outfall sewers (bulk sewer pipes). Gravity 
pipes are captured on the SEWGPIPE layer.

 Pressure pipes – sewer pipes where effluent waste is pumped against gravity. Pressure pipes 
are captured on the SEWRPIPE layer.

 Vacuum pipes – sewer pipes where the flow direction is determined by an induced vacuum. 
Vacuum pipes are captured on the SEWVPIPE layer.

Flow direction in a sewer pipe is determined by either gravity and the natural downhill slope of the 
pipe, by positive pressure through sewer pumps, or by negative pressure through vacuum systems. 
It is therefore important to capture sewer pipes in the correct direction. Always show and correct the 
flow direction before posting the pipes to the database. 

The Munsys Sewer Capture toolbar contains the functions that are used to capture sewer pipes.

Sewer pipes are captured by using one of two methods: 
 In residential areas, the network can be captured at a specific offset distance from cadastral 

boundaries. 

 In other areas, the network can be captured by selecting points (freehand).

To draw an offset gravity pipe
A gravity pipe is drawn as a single line entity between two sewer nodes and is composed of a 
single straight-line segment.

1 Do one of the following:

 Choose Capture > Draw Offset Pipe > Gravity.

 Click the Draw Offset Gravity Pipe button on the Munsys Sewer Capture toolbar.

2 Specify an approximate start point for the pipe.

3 Specify an approximate endpoint for the pipe.

4 Select the segment to offset the pipe from.

5 Specify an offset side.

6 Specify the offset distance, or press ENTER to accept the default offset distance.
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Figure 2 Offset gravity pipe

To draw an offset pressure pipe
A pressure pipe can be drawn as a polyline entity between two sewer nodes and is composed of 
a series of straight-line or arc segments.

Do one of the following:

 Choose Capture > Draw Offset Pipe > Pressure.

 Click the Draw Offset Pressure Pipe button on the Munsys Sewer Capture toolbar.

The command line prompts you to specify points, or to select a segment from which to offset the 
pressure pipe.

7 To draw the pressure pipe by specifying points, do the following:

 Specify the first point 

 Then specify next point of the pressure pipe drawn as a straight-line segment or change to draw 
an arc segment [Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset pressure pipes as 
a series of arcs. If selecting the Arc option, the polyline linear list changes with more selection 
options [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the pressure pipe as series of straight-line segments.

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the pressure pipe.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.

gravity pipespecify offset segment
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8 To draw the pressure pipe by selecting offset segments, do the following:

 On the command line, type O, and then press ENTER.

 Select the segment from which you want to offset the pressure pipe.

 Specify a point on the side to offset the pressure pipe.

 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.

 Continue selecting segments until all the required segments have been selected, and then press 
ENTER.

 Press ENTER to confirm that you have completed selecting segments.

To draw an offset vacuum pipe
A vacuum pipe can be drawn as a polyline entity between two sewer nodes and is composed of 
a series of straight-line or arc segments.

1 Do one of the following:

 Choose Capture > Draw Offset Pipe > Vacuum.

 Click the Draw Offset Vacuum Pipe button on the Munsys Sewer Capture toolbar.

The command line prompts you to specify points, or to select a segment from which to offset the 
vacuum pipe.

2 To draw the vacuum pipe by specifying points, do the following:

 Specify the first point 

 Then specify next point of the vacuum pipe drawn as a straight-line segment or change to draw 
an arc segment [Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset vacuum pipes as 
a series of arcs. If selecting the Arc option, the polyline linear list changes with more selection 
options [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the vacuum pipe as series of straight-line segments.

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the vacuum pipe.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.

3 To draw the vacuum pipe by selecting offset segments, do the following:

 On the command line, type O, and then press ENTER.

 Select the segment from which you want to offset the vacuum pipe.

 Specify a point on the side to offset the vacuum pipe.

 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.
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 Continue selecting segments until all the required segments have been selected, and then press 
ENTER.

 Press ENTER to confirm that you have completed selecting segments.

Figure 3 Offset vacuum pipe drawn by selecting offset segments

To draw a freehand gravity pipe

1 Do one of the following:

 Choose Capture > Draw Freehand Pipe > Gravity.

 Click the Draw Freehand Gravity Pipe button on the Munsys Sewer Capture toolbar.

2 Specify a start point for the pipe, or enter coordinates on the command line.

3 Specify an endpoint for the pipe, or enter coordinates on the command line.

Tip To construct a sequence of gravity pipes, continue to select endpoints.

4 Press ENTER to complete.

select offset segments

vacuum pipe

select offset segments
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To draw a freehand pressure pipe

1 Do one of the following:

 Choose Capture > Draw Freehand Pipe > Pressure.

 Click the Draw Freehand Pressure Pipe button on the Munsys Sewer Capture toolbar.

 Specify the first point for the pipe

 Then specify next point of the pressure pipe drawn as a straight-line segment or change to draw 
an arc segment [Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset pressure pipes as 
a series of arcs. If selecting the Arc option, the polyline linear list changes with more selection 
options [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the pressure pipe as series of straight-line segments.

2 Press ENTER to complete.

To draw a freehand vacuum pipe

1 Do one of the following:

 Choose Capture > Draw Freehand Pipe > Vacuum.

 Click the Draw Freehand Vacuum Pipe button on the Munsys Sewer Capture toolbar.

 Specify the first point for the pipe

 Then specify next point of the vacuum pipe drawn as a straight-line segment or change to draw 
an arc segment [Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset vacuum pipes as 
a series of arcs. If selecting the Arc option, the polyline linear list changes with more selection 
options [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the vacuum pipe as series of straight-line segments.

2 Press ENTER to complete.
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Sewer flow direction
When you have captured and edited all the sewer pipes in the network, you have to check the 
flow direction of the pipes to verify that it is correct. This can be done for both new and existing 
pipes. Sewer flow direction can be changed easily with the Change Flow Direction function. 
Once you have verified that the flow direction is correct, the direction arrows are cleared from 
the drawing.

To show sewer flow direction

1 Do one of the following:

 Choose Capture > Show Flow Direction.

 Click the Show Flow Direction button on the Munsys Sewer Flow toolbar.

2 Select the appropriate sewer pipes, and then press ENTER.

An arrow on each selected pipe indicates the flow direction of the pipe.

Figure 4 Showing sewer flow direction

flow direction arrow
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To change sewer flow direction

1 Do one of the following:

 Choose Capture > Change Flow Direction.
 Click the Change Flow Direction button on the Munsys Sewer Flow toolbar.

2 Select the appropriate sewer pipes, and then press ENTER.

The direction is reversed automatically. (Select Show Flow Direction before altering the direction, 
if the direction arrows are not currently displayed).

Note The integrity check does not verify flow direction; it is therefore very important to make certain that the 
flow direction is correct.

To clear direction arrows

1 Do one of the following:

 Choose Capture > Clear Direction Arrows.

 Click the Clear Direction Arrows button on the Munsys Sewer Flow toolbar.

The direction arrows are cleared from the drawing.
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Capturing sewer nodes
Sewer nodes are captured by placing them either at the endpoint of a sewer pipe (endpoint 
nodes), or by placing them anywhere along the pipe (nearest nodes). When nodes are captured, 
certain placement restrictions apply (for example, manholes can only be placed on gravity pipes, 
while end caps can be placed on gravity, vacuum or pressure pipes). Sewer nodes are attached 
to sewer pipes to complete the sewer network. Attribute information, which provides the user 
with more descriptive information about sewer nodes, is associated with the nodes. The Munsys 
Sewer Place Node and Insert Node toolbars contain all the functions that are used to capture 
different types of sewer nodes. 

Placing endpoint sewer nodes
Endpoint nodes are placed at the endpoint of a sewer pipe, closest to the point where the pipe 
was selected. Endpoint sewer nodes are created on the SEWNODE layer, to be verified when 
the integrity check is run.

To place an endpoint sewer node

1 Do one of the following:

 Choose Capture > Place Endpoint Node > Node Name.

 Click the appropriate button on the Munsys Sewer Place Node toolbar.

Figure 5 The Munsys Sewer Place Node toolbar 

2 Select a point close to the endpoint of the sewer pipe where you want to place the node.

The appropriate node symbol is placed at the end of the sewer pipe.

Inserting nearest sewer nodes
Nearest sewer nodes are placed at any selected point on a sewer pipe, breaking the underlying 
pipe. 

To insert a nearest sewer node

1 Do one of the following:

 Choose Capture > Insert Nearest Node > Node Name.

 Click the appropriate button on the Munsys Sewer Insert Node toolbar.

Figure 6 The Munsys Sewer Insert Node toolbar 

2 Select a nearest point on the sewer pipe where you want to place the node. 

The appropriate node symbol is placed on the pipe at the point that you selected.
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Capturing sewer service connections
Service connections connect land parcels to the sewer network.

The Munsys Sewer Place SC toolbar contains the functions that are used to capture different 
types of service connections.

A service connection is captured as a freehand connection, or at 45° or 90° as a single or double 
service connection, at either the endpoint or a nearest position on a gravity pipe.

Placing single service connections
Single service connections are placed nearest to the selection point, or at the endpoint of a 
gravity pipe, at either 45° or 90° angles to the pipe, using the default service connection length 
and service connection type as defined in the 
Sewer Settings dialog box.

To place a single service connection at the endpoint of a gravity pipe

1 Do one of the following:

 Choose Capture > Place Single SC > 45 Deg Endpoint or > 90 Deg Endpoint.

 Click the Place Single SC 45 Deg Endpoint or 90 Deg Endpoint button on the Munsys Sewer 
Place SC toolbar.

2 Select a point close to the endpoint of the gravity pipe where you want to place the service 
connection.

3 Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the 
service connection vector at angles of 45 or 90 degrees.

The service connection is placed on the SEWSERV layer.

To place a single service connection at a nearest point 
on a gravity pipe

1 Do one of the following:

 Choose Capture > Place Single SC > 45 Deg Nearest or > 90 Deg Nearest.

 Click the Place Single SC 45 Deg Nearest or 90 Deg Nearest button on the Munsys Sewer 
Place SC toolbar.

2 Select a point on the gravity pipe where you want to place the service connection.

3 Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the 
service connection vector at angles of 45 or 90 degrees.

The service connection is captured on the SEWSERV layer.
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Figure 7 Single service connections

Placing double service connections
Double service connections are placed nearest to the selection point on, or at the endpoint of a 
gravity pipe, at either 45° or 90° angles to the pipe, using the default service connection length 
and service connection type as defined in the Sewer Settings dialog box.

To place a double service connection at the endpoint of a gravity pipe

1 Do one of the following:

 Choose Capture > Place Double SC > 45 Deg Endpoint or > 90 Deg Endpoint.

 Click the Place Double SC 45 Deg or 90 Deg Endpoint button on the Munsys Sewer Place SC 
toolbar.

2 Select a point close to the endpoint of the gravity pipe where you want to place the service 
connection.

3 Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the 
service connection vector at angles of 45 or 90 degrees.

4 Repeat Step 3 to place the second segment of the service connection.

The service connection is captured on the SEWSERV layer.

single sc: 
45 deg.

single sc:
90 deg.
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To place a double service connection at a nearest point on a 
gravity pipe

1 Do one of the following:

 Choose Capture > Place Double SC > 45 Deg Nearest or 90 Deg Nearest.

 Click the Place Double SC 45 Deg or 90 Deg Nearest button on the Munsys Sewer Place SC 
toolbar.

2 Select a point on the gravity pipe where you want to place the service connection.

3 Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the 
service connection vector at angles of 45 or 90 degrees.

4 Repeat Step 3 to place the second segment of the service connection.

The service connection is captured on the SEWSERV layer.

Figure 8 Double service connections

Double sc: 
90 deg.



Creating sewer data 32 








Placing freehand service connections
With this function, you can place a single freehand service connection that is longer than the 
default service connection length specified on the Sewer Settings dialog box, and that does not 
tie into a sewer pipe at the standard 45° and 90°. The service connection is captured with the 
default service connection type specified on the Sewer Settings dialog box.

To place a freehand service connection

1 Do one of the following:

 Choose Capture > Place Freehand SC.

 Click the Place Freehand Service Connection button on the Munsys Sewer Place SC toolbar.

2 Select the gravity pipe where the service connection should be connected, and then drag and click to 
place the service connection inside the parcel boundary.

The service connection is captured on the SEWSERV layer.

Figure 9 Freehand service connections

Freehand service connections
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Attaching sewer pipe elevations
This function is used to enter pipe elevations from a long section, by entering cover and invert 
elevations for the start and endpoint of a sewer pipe. The cover and invert elevations are stored 
with the pipe to cater for drop manholes where incoming pipes have a higher invert elevation 
than the outgoing pipes. If pipe elevations are present and there are no elevations on the nodes, 
the node elevations will also be calculated during the integrity check.

To attach sewer pipe elevations

1 Choose Capture > Pipe Elevations...

2 Select the sewer pipe that you want to attach the pipe elevations to.

The Sewer Pipe Information dialog box is displayed.

Figure 10 The Sewer Pipe Information dialog box

3 Enter the following information in the Start Info group:

 Cover Elevation 

 Invert Elevation (bottom of the pipe)

The depth value is calculated automatically.

4 In the End Info group, enter the following information:

 Cover Elevation

 Invert Elevation (bottom of the pipe)

The pipe length and gradient values in the Detail Info group are calculated automatically from 
the Start Info and End Info groups.
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Attaching sewer node elevations
With this function, you can enter the node depth and cover elevation for a sewer node. If an 
existing node is selected, the Sewer Node Information dialog box is populated with existing 
values if they are present.

To attach sewer node elevations

1 Choose Capture > Node Elevations…

2 Select the sewer node that you want to attach the node elevations to.

The Sewer Node Information dialog box is displayed.

Figure 11 The Sewer Node Information dialog box

3 Enter the following node information:

 Node Depth Node Depth (the difference between the cover and invert elevation of the 
node)

 Cover Elevation

4 Click OK.
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Capturing sewer basins
Sewer basins are used to view certain parts of the sewer network up to the purification works, 
or even smaller sections up to the primary outfall sewers. Sewer basins are captured as polygons 
that represent a certain section of the sewer network.

Sewer basins are captured by:

 selecting consecutive points to form a sewer basin polygon

 specifying a tag for the polygon builder to use when creating the sewer basin polygon

 generating a polygon from the lines and tag that were created

To draw a sewer basin boundary

1 Choose Capture > Sewer Basin > Draw Basin Boundary.

2 Specify the first polygon boundary point.

3 Specify the next polygon boundary points, and then press ENTER.

4 Press ENTER to close the polygon boundary, or type N on the command line to specify more points.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a sewer basin tag

1 Choose Capture > Sewer Basin > Place Basin Tag.

2 Specify the insertion point for the tag.

3 On the command line, specify the tag height, or press ENTER to accept the default height.

4 To indicate the tag angle, do one of the following:

 Indicate the tag angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the tag to an object, press ENTER, and then select the 
object to which you want to align the tag.

5 Type the tag value on the command line, and then press ENTER.

The tag is inserted as specified.
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To generate a sewer basin polygon

1 Choose Capture > Sewer Basin > Generate Basin Polygons.

2 Select all the lines that form the sewer basin boundary, and then press ENTER.

3 Select the sewer basin tag, and then press ENTER.

The command line indicates that the polygon has been built successfully.

Figure 12 A sewer basin polygon
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Capturing residential sewers
Residential sewers indicate the sewer pipes running from buildings to service connections. 
Residential sewers do not form part of the network connectivity. Residential sewers can be 
drawn freehand, or captured at a specified offset distance from a selected segment. Residential 
sewers are placed on the SEWRESPIPE layer.

To draw a freehand residential sewer

1 Choose Capture > Residential Sewer > Draw Freehand Pipe.

2 Specify the first point for the pipe, and then specify next points.

3 Press ENTER when you have specified all the points.

The command line displays a message confirming that the residential sewer was created 
successfully.

To draw an offset residential sewer

1 Choose Capture > Residential Sewer > Draw Offset Pipe.

The command line prompts you to specify points, or to select a segment from which to offset the 
residential sewer.

2 To draw the residential sewer by specifying points, do the following:

 Specify the first point, and then specify next points for the residential sewer.

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the residential sewer.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.

The command line displays a message confirming that the residential sewer was created successfully.

3 To draw the residential sewer by selecting offset segments, do the following:

 On the command line, type O, and then press ENTER.

 Select the segment from which you want to offset the residential sewer.

 Specify a point on the side to offset the residential sewer.

 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.

 Continue selecting segments until all the required segments have been selected, and then press 
ENTER.

 Press ENTER to confirm that you have completed selecting segments.
The command line displays a message confirming that the residential sewer was created successfully.
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Placing sewer symbols
This function is used to place sewer symbols in the current drawing. Sewer symbols represent 
additional annotation in the form of a symbol, and do not form part of the sewer network. 
Sewer symbols can be placed anywhere without any restriction. Sewer symbols are captured on 
the SEWSYM layer.

Note The database administrator can add additional sewer symbols to the lookup table LU_SMS_SEWSYM 
as required. This table contains a number of default symbols, but can be customized.

To place sewer symbols

1 Do one of the following:

 Choose Capture > Place Sewer Symbol...

 Click the Place Sewer Symbol button on the Munsys Sewer Capture toolbar.

2 The Sewer Symbols dialog box is displayed, showing a list of available sewer symbols.

Figure 13 The Sewer Symbols dialog box

3 From the list, select the symbol that you want to place, and then click OK.
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4 Specify an insertion point for the symbol.

5 Specify a rotation angle for the symbol by doing one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle of 
zero.

 Indicate the angle with your mouse pointer by picking two points in the drawing.

 On the command line, type AL to align the symbol to an object, press ENTER, and then select 
the object to which you want to align the symbol.

The symbol is placed at the insertion point and angle that you specified.

Tip Press ENTER or the Space Bar to continue placing consecutive symbols of the same type, without having 
to select a symbol type from the list every time.
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Placing sewer labels
With this function, you can place a label on a sewer pipe. The sewer label shows the pipe 
diameter and pipe material. If you change any of the pipe attributes displayed in the label, these 
changes are updated when the changed data is posted to the database. The changes will show 
once the sewer pipe is queried again from the database. The value of the label is determined by 
the tag value setting of the system query of each type of label.

To place sewer labels

1 Do one of the following:

 Choose Capture > Place Sewer Label > Gravity/Vacuum/ Pressure.

 Click the appropriate button on the Munsys Sewer Capture toolbar.

2 Select the sewer pipe to which you want to attach the label.

3 Specify an insertion point for the label.

4 Specify the height for the label, or press ENTER to accept the default height.

5 To indicate the label text angle, do one of the following:

 Indicate the text angle with your mouse.

 On the command line, type A to align the label text to an object, press ENTER, and then select 
the object to which you want to align the text.

The label is placed as specified.

Figure 14 Sewer labels

sewer label toolbar buttons
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Placing a sewer note
For map production purposes, information about a spatial object is added in the form of a note. 
A note may be added, for example, to indicate the start of a pressure pipe, or to label 
distinguishing landmarks.

To place a sewer note

1 Do one of the following:

 Choose Capture > Place Sewer Note.

 Click the Place Sewer Note button on the Munsys Sewer Capture toolbar.

2 Specify the insertion point for the note.

3 On the command line, specify the note height, or press ENTER to accept the default height.

4 To indicate the text angle, do one of the following:

 Indicate the text angle with your mouse.

 On the command line, type A to align the text to an object, press ENTER, and then select the 
object to which you want to align the text.

5 Type the note text on the command line, and then press ENTER.

The note is inserted as specified.

Figure 15 A sewer note
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Placing sewer dimensions
Dimension arrows are used to indicate the offset distance of a sewer pipe from a parcel. (A map 
is a graphical representation of reality and it is therefore almost impossible to capture sewer 
pipes at the true offset distance from a parcel boundary.)

To place dimension arrows

1 Do one of the following:

 Choose Capture > Place Dimension Arrow.

 Click the Place Dimension Arrow button on the Munsys Sewer Capture toolbar.

2 Select the first segment for dimension.

The dimension arrows will be placed perpendicular to this segment.

3 Select the second segment for dimension.

The dimension arrows are aligned to the point selected on this segment.

4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance 
as determined in the Sewer Settings, or press A to place the actual calculated distance.

The dimension text is placed at the dimension arrows, indicating the distance between the two 
dimension lines.

Figure 16 Dimension arrows
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Checking sewer integrity
The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial 
objects have to be verified against integrity rules built into the capture and change routines of 
every application before they can be posted to the database. New and changed objects contain 
an internal status that requires the validation process.

The Integrity Check is run from the Capture menu, or by clicking the appropriate button on 
the Integrity toolbar. The way in which the integrity check is executed depends on the 
preferences/options specified in the Munsys Options dialog box. The various options available 
on this dialog box are discussed in detail in the Munsys Concepts User Manual.

The integrity check is split into two separate functions to facilitate flexibility and ease of use:

 Validate Object Integrity – checks and validates the spatial and/or attribute data of an 
object, according to the options specified in the Munsys Options dialog box:

 When the Validate Geometry: Modified objects option has been selected, the geom-
etry of only new or modified objects will be validated.

 When the Validate Geometry: All objects option has been selected, all the objects in 
the selection set will have their geometry validated. This includes locked, unlocked, 
modified and non-modified objects. 

 When the Validate Attributes: Modified attributes option has been selected, the 
attributes of only new or modified objects will be validated.

 When the Validate Attributes: All attributes option has been selected, all the objects 
in the selection set will have their attributes validated. This includes locked, 
unlocked, modified and non-modified objects. 

When the object integrity check has completed and changes in objects have been 
encountered that may affect network integrity, a warning message to this effect is 
displayed if the option was specified in the Munsys Options dialog box.

 Validate Network Integrity – validates the rules that, together with the objects, make up a 
network, and according to the Network Integrity options specified in the Munsys Options 
dialog box. Network validation includes the topology and connectivity aspects, where 
topology is resembled in the geometry of objects and connectivity by means of attributes 
attached to objects.

This function is dependent on the relationships between objects, and therefore requires 
more objects to be included as part of the validation process than only those that were mod-
ified. The Validate Network Integrity function allows non-validated objects to be selected, 
but does not attempt to reset any integrity flags. It only places integrity markers when errors 
are encountered in the network. If the selection set contains objects that have not been val-
idated by the Validate Object Integrity function, an Object Integrity Warning is displayed, 
recommending that object integrity has to be checked before network integrity.

Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network Integrity 
Check), which is set by the database administrator in the Munsys Management Console, allows a network 
integrity check to be performed automatically whenever an object integrity check is run. The same 
network rules and settings still apply. When the integrity check is completed, the Integrity Results dialog 
box displays a combined list of both object and network validations that were performed during the 
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integrity check. When this setting is enabled, the object integrity check cannot be integrated with the 
database posting function, and the Automatically perform Object Integrity option on the Munsys 
Options dialog box Preferences tab will be unavailable. 

When sewer object integrity is checked, the following is verified:

Table 17 The sewer object integrity check

When sewer network integrity is checked, the following is verified:

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified 
but, because it was unlocked, the integrity check 
failed to rectify the object and it was left as is.

Short spatial objects Applies to any object with a length shorter than 
the Munsys Sewer database tolerance setting.

Duplicate points in spatial objects Applies to redundant coordinates being removed 
from an object. If the coordinates are within 
*SNAP* tolerance, they are discarded.

Objects with incomplete geometry Refers to objects that do not have geometry, for 
example: tags that were placed without using the 
polygon builder process do not have a geometry.

Objects outside database extents Checks if the objects selected are within the con-
fines of the geographic extents of the database.

Attribute rules Checks for the attribute rules as specified in the 
MUNSYS_INTEG_ATTR table, for example 
NULL values, etc.

Attribute data types Checks the data type to be consistent with what 
is in the database; i.e. attached attributes should 
not exceed the limits of the table's column defi-
nition, for example: a tag may not be longer than 
the table's TAG_VALUE column width.

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been 
rectified but, because it was unlocked, the 
integrity check failed to rectify the object 
and it was left as is.

Pipes within snap tolerance Checks for pipes that can snap to other 
pipes that are within the snap tolerance.

Pipes without nodes Checks whether each pipe is connected to 
a node at both ends of the pipe.

Duplicate pipes Checks for two different pipes connected 
to the same nodes.
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Table 18 The sewer network integrity check

Note The integrity check will transfer elevations from a node or pipe, depending on the existence of elevation 
attributes in the object. If the node does not have elevation attributes set but the pipe does contain elevation 
attributes, the node cover elevation and depth will be calculated from the pipe to the node. If the pipe does 
not have elevation attributes set but the node contains elevation attributes, the pipe elevations will be 
calculated from the node to the pipe.

Checking sewer object integrity

1 Do one of the following:

 Choose Capture > Data Integrity > Validate Object Integrity...

 Click the Validate Object Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

The Integrity Results dialog box is displayed, providing summarized information and validation 
results encountered during the object integrity check.

Nodes within snap tolerance Checks for nodes that can be snapped to 
pipes that are within the snap tolerance.

Isolated nodes Checks for nodes that are not connected 
to any pipes.

Nodes with too many pipes Checks for nodes that are connected to 
too many pipes.

Nodes with too few pipes Checks for nodes that are connected to 
too few pipes.

Duplicate nodes Checks for nodes that have been captured 
on top of one another.
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Figure 19 The Integrity Results dialog box

3 If you selected the Notify when objects require network validation option on the Munsys Options 
dialog box, and if objects were encountered during the integrity check that may affect network 
integrity, the following message is displayed:

Figure 20 Network Integrity Warning

Checking sewer network integrity

1 Do one of the following:

 Choose Capture > Data Integrity > Validate Network Integrity...

 Click the Validate Network Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

Note If you selected objects that have not been validated by the Validate Object Integrity function, the 
following message is displayed:
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Figure 21 Object Integrity Warning

3 When the integrity check has completed, the Integrity Results dialog box is displayed, providing 
summarized information and validation results encountered during the network integrity check.

Figure 22 The Integrity Results dialog box

Browsing integrity markers
You can review the integrity markers resulting from the integrity check with the Browse 
Integrity Markers dialog box. This dialog box displays the complete list of errors encountered 
during the integrity check. The list consists of the error type, the object affected, a description 
of the error, and the GID of the spatial object. From this dialog box, you can locate and remove 
specific integrity markers in the drawing.

To browse integrity markers

1 Do one of the following:
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 Choose Capture > Browse Integrity Markers...

 Click the Browse Integrity Markers button on the Integrity toolbar.

 Click the Errors... button on the Integrity Results dialog box. 
The Browse Integrity Markers dialog box is displayed.

Figure 23 The Browse Integrity Markers dialog box

2 To locate an error, select the appropriate integrity marker, and then click the Locate button.

Munsys zooms to the extent of the spatial object to which the integrity marker refers.

3 To remove integrity markers from the list and from the drawing, select one or more integrity markers 
from the list, and then click the Remove button.

The integrity markers are removed from the drawing and from the list of markers.

Erasing integrity markers
With this function, you can erase all the integrity markers. Integrity markers are stored on the 
INTEG layer.

To erase integrity markers

1 Do one of the following:

 Choose Capture > Erase Integrity Markers.

 Click the Erase Integrity Markers button on the Integrity toolbar.
The command line prompts you for confirmation to erase all the integrity markers.

2 Press ENTER to erase the integrity markers.

The integrity markers are erased.
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Posting sewer data to the database
New or modified sewer data that has passed the integrity check is posted to the database. 

To post sewer data to the database

1 Do one of the following:

 Choose Capture > Post to Database...

 Click the Post to Database button on the Integrity toolbar.
The Database Posting Summary dialog box is displayed. 

Figure 24 The Database Posting Summary dialog box

This dialog box displays the following:
 The total number of spatial objects selected for posting.

 The number of new objects created.

 The number of attribute changes made.

 The number of spatial changes made.

 The number of objects marked for deletion.

 The number of objects that have not been validated and that will not be posted to the 
database.

2 Click OK to update the database.

The Database Posting Results dialog box is displayed.
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Figure 25 The Database Posting Results dialog box

This dialog box displays the following:
 The total number of objects selected for posting to the database.

 The total number of spatial objects inserted into the database.

 The total number of spatial objects modified in the database.

 The total number of spatial objects deleted from the database.

 The total number of objects not posted to the database.

3 Click Close to exit the Database Posting Results dialog box.

Note Once you have posted objects to the database, you will not be able to undo this function, which will avoid 
duplicate objects and keep the content of the drawing synchronized with the database.

Validating object integrity and posting data at the same time
If you select the Automatically perform Object Integrity option on the Munsys Options dialog box 
Preferences tab, you can perform an object integrity check and database posting operation at the 
same time. The following rules will be applied when the objects integrity phase of the operation is 
executed:
 Only modified objects will be selected for object integrity

 The integrity flag will be reset automatically if the object passes object integrity

 Integrity markers will be placed accordingly where errors occur, as happens when a normal 
object integrity check is run from the Capture menu

 If an error occurs, the integrity flag will not be reset

 Only objects related to the current application will be included in the object integrity check 
(i.e. if you are working in the Sewer application, only sewer objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:
 Ignore the errors that occurred and continue to post the objects that passed the integrity 

check to the database 

 Cancel the database posting operation and return to the map interface 

 View the errors that occurred with the Browse Integrity Markers dialog box (this option also 
cancels the posting operation, allowing you to correct the errors first before attempting to 
post the objects to the database once again)
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To validate object integrity and post objects at the same time

1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object 
Integrity check box in the Database Posting Preferences group.

2 Choose Capture > Post to Database.

An object integrity check is run on the all the new or modified objects in the drawing.

3 If any errors occurred, the following message is displayed:

Figure 26 Database Posting – Object Integrity Errors

4 Do one of the following:

Click Yes to ignore the errors that have occurred and post the objects to the database that have 
passed the integrity check

Click No to cancel the posting operation and return to the drawing

Click Errors... to view the errors that occurred using the Browsing Integrity Markers dialog box.



Creating sewer data 52 








Sewer network quality reporting
The Network Quality Report function on the Extras menu is used to validate the quality of the 
entire sewer network. The network quality report complements the network integrity check. 
Although it is recommended that a network integrity check is always done before objects are 
posted to the database, some problems might still be present in the quality of a network. This 
could, for example, be due to the fact that the network integrity check might have been done 
on a small area of the network. The network quality check uses all the objects in the database 
to validate the quality of the entire network. The validation is done at attribute level, without 
having to validate the associated spatial data.

Specific columns in each of the spatial tables are used to build up the topology of the network, 
for example the start and end nodes of a sewer pipe. The network quality report will validate 
these values based on sewer-specific rules. 

Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS 
table, together with the appropriate error message related to each spatial object where an error 
occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query, which will 
use this table as a linked table with a condition based on the SP_TABLE column that matches 
the spatial table name of the query.

If a single spatial object contained more than one error, a record will be stored for each error 
that occurred within that object. You can also have the errors populated to the COMMENTS 
column of the object(s) in which errors occurred, if you do not traditionally use this column for 
other purposes. If more than one error has occurred in an object, the COMMENTS column is 
populated with the last error that is found.
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The following table shows the sewer network errors that may occur:

Figure 27 Sewer network quality errors

Spatial Table Error Description

SP_SEWGPIPE 
SP_SEWRPIPE 
SP_SEWVPIPE

NODE MISSING The START_NODE/END_NODE value is 
NULL, or the node ID was not found in the 
SP_SEWNODE table

SP_SEWGPIPE 
SP_SEWRPIPE 
SP_SEWVPIPE

ID NOT UNIQUE The PIPE_ID column contains a non-unique 
value

SP_SEWGPIPE 
SP_SEWRPIPE 
SP_SEWVPIPE

SEQUENCE 
EXCEEDED

The value in the NODE_ID column exceeds 
the current value of the SMS_SEWPIPE 
sequence

SP_SEWGPIPE 
SP_SEWRPIPE 
SP_SEWVPIPE

ID NULL The value of the PIPE_ID column is NULL

SP_SEWNODE ID NULL The value of the NODE_ID column is 
NULL

SP_SEWNODE SEQUENCE 
EXCEEDED

The value in the NODE_ID column exceeds 
the current value of the SMS_SEWNODE 
sequence

SP_SEWNODE ID NOT UNIQUE The NODE_ID column contains a non-
unique value

SP_SEWNODE NODE ISOLATED The node ID was not found in either the 
START_NODE or END_NODE columns 
of the SP_SEWGPIPE, SP_SEWRPIPR or 
SP_SEWVPIPE tables

SP_SEWSERV UNCONNECTED 
SC

The value in the PIPE_ID or PRCL_GID 
column is Null, or the pipe ID was not found 
in the SP_SEWGPIPE table, or the 
PRCL_GID was not found in the SP_PAR-
CEL table
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To validate sewer network quality

1 Choose Extras > Network Quality Report...

The command line displays the message: Generating network quality report

2 If errors were found in the network, the following message is displayed:

Figure 28 Network Quality errors found

3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column 
updated.

The Save Results Summary As dialog box is displayed.

4 Save the report to a location of your choice.

The report is opened in Windows Notepad, and contains the following information:

 The number of objects that were checked

 The number of objects found that violated the network rules

 The number of endpoints that were found in the network

 The number of errors that were found, grouped by error type

Figure 29 A sewer network quality report



Creating sewer data 55 








Generating sewer data status reports
Data status reports provide summarized information about spatial objects that are currently 
stored in the database. Once a report has been generated, it is saved to a comma delimited file, 
and then displayed in Notepad for easy viewing. The following reports can be generated for 
sewer objects:

 a summary of all the sewer objects in the database

 a summary of the length and number of gravity pipes by diameter

 a summary of the length and number of gravity pipes by material

 a summary of the length and number of gravity pipes by type

 a summary of the length and number of vacuum pipes by diameter

 a summary of the length and number of vacuum pipes by material

 a summary of the length and number of vacuum pipes by type

 a summary of the length and number of pressure pipes by diameter

 a summary of the length and number of pressure pipes by material

 a summary of the length and number of pressure pipes by type

 a summary of the number of sewer nodes grouped by type

 a summary of the total length and number of service connections by type

 a summary of the length and number of gravity pipes by diameter and material

 a summary of the length and number of vacuum pipes by diameter and material

 a summary of the length and number of pressure pipes by diameter and material

To generate a sewer data status report

1 Choose Extras > Data Status Report...

The Data Status Report dialog box is displayed, showing a list of all the reports that can be 
generated.

Figure 30 The Data Status Report dialog box
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2 Select one or more reports to generate from the list, and then click OK.

3 Save the file to a location of your choice.

The file is opened in Windows Notepad.

Figure 31 Data status report for sewer pipes
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Converting AutoCAD entities to sewer objects
With Munsys Sewer, you can convert selected AutoCAD entities to sewer objects. Block entities 
can be converted to sewer nodes (manholes, junctions, pump stations, reducers, etc.) or sewer 
symbols (cleanout or direction arrow), line entities can be converted to service connections, 
residential sewers, gravity, pressure or vacuum pipes, text can be converted to sewer basin tags 
or sewer notes, and polygons can be converted to sewer basins.

Although some basic attributes are assigned as part of the conversion process, you will need to 
assign attributes to the objects created with the conversion process.

To convert block entities to sewer nodes
With this function, you can convert AutoCAD block entities to any of the available sewer 
nodes.

To convert block entities to sewer nodes, do the following:

1 Choose Extras > Convert Block to > Node Name.

2 Select the block entities that you want to convert, and then press ENTER.

One sewer node is created for each block entity that you selected, and the drawing is updated 
accordingly.

To convert block entities to sewer symbols
With this function, you can convert AutoCAD block entities to any of the available sewer 
symbols.

To convert block entities to sewer symbols, do the following:

1 Choose Extras > Convert Block to > Sewer Symbol.

2 Select the block entities that you want to convert, and then press ENTER.

The Sewer Symbols dialog box is displayed, showing a list of available sewer symbols.

3 From the list, select the symbol that you want to place, and then click on OK.

One sewer symbol is created for each block entity that you selected, and the drawing is updated 
accordingly.
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To convert line entities to sewer objects
With this function, you can convert line entities to any of the following sewer objects:
 gravity, pressure or vacuum pipes

 service connections

 residential sewers

1 To convert line entities to sewer objects, do one of the following:

 Choose Extras > Convert Line to > Gravity Pipe.

 Choose Extras > Convert Line to > Vacuum Pipe.

 Choose Extras > Convert Line to > Pressure Pipe.

 Choose Extras > Convert Line to > Residential Sewer.

 Choose Extras > Convert Line to > Service Connection.
 When converting a line entity to a service connection (SC), the SC must also be linked to the 

parcel before the PIPE_ID and the PRCL_GID will be added to the respective SC columns. 
To link a SC to a parcel use the menu item: Change > Link SC’s to Parcels.

2 Select the line objects that you want to convert to sewer objects, and then press ENTER.

3 The selected line objects are converted and the drawing is updated accordingly.

To convert text to sewer notes or tags
With this function, you can convert AutoCAD text to sewer basin tags or sewer notes.

1 To to convert text to sewer basin tags or sewer notes, do one of the following:

 Choose Extras > Convert Text to > Sewer Basin Tag.

 Choose Extras > Convert Text to > Sewer Note.

2 Select the objects that you want to convert, and then press ENTER.

The entities are converted to the sewer objects that you specified, and the drawing is updated 
accordingly.

To convert polygons to sewer basins

1 Choose Extras > Convert Polygon to > Sewer Basin.

2 Select the polygons that you want to convert, and then press ENTER.

The polygons are converted to sewer basins, and the drawing is updated accordingly.
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Exporting sewer objects to LandXML
Munsys Sewer provides tools for the engineers and technicians to exchange Munsys sewer data 
with other engineering software that supports LandXML format. With Munsys Sewer, you can 
export sewer nodes and pipe object data to LandXML data format. 

The exported LandXML data includes pipe attributes such as pipe material, diameter, gradient, 
length and unique Pipe ID, while the node attributes include the unique Node ID, node type, 
cover and invert levels and connecting Pipe IDs. 

The XML export function in Munsys Sewer is available for sewer gravity pipes, pressure pipes, 
vacuum pipes and all sewer nodes. The pipe and node spatial and attribute data can then be 
imported into other applications.

LandXML data file Elements
The XML export file consists of 5 main sections, namely:

 Header

 Units

 Project Name

 Application version

 Pipe Networks

 Node Structures

 Pipe Structures

Header
The file header records the LandXML language, version number, the date and time that the 
XML file was created. the file header also references the XML websites displaying XML 
definitions.

<LandXML xmlns="http://www.landxml.org/schema/LandXML-1.1" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://www.landxml.org/schema/LandXML-1.1 http://www.landxml.org/schema/LandXML-
1.1/LandXML-1.1.xsd" date="2024-01-23" time="14:38:43" version="1.1" language="English" readOnly="false">

Units
The Units for the XML export are defined for both Imperial and Metric. If the locale for the 
schema is set to US the Imperial units are applied, whereas if the locale for the schema is set to 
INT, AUS or AUS2, the Metric units are applied. The Imperial units are used as the default if 
no locale is set.

<Units> 

<Imperial areaUnit="squareFoot" linearUnit="foot" volumeUnit="cubicYard" temperatureUnit="fahrenheit" 
pressureUnit="inchHG" diameterUnit="inch" angularUnit="decimal degrees" directionUnit="decimal degrees" /> 

</Units>

Example of Units for US schemas
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<Units> 

<Metric areaUnit="squareMeter" linearUnit="meter" volumeUnit="cubicMeter" temperatureUnit="celsius" 
pressureUnit="mmHG" diameterUnit="millimeter" angularUnit="decimal degrees" directionUnit="decimal degrees" 
/></Units>

Example of Units for INT, AUS or AUS2 schemas

The following table denotes the different Imperial and Metric units referenced in the XML 
export file.

Figure 32 Imperial and Metric Units

Project Name

The Project information in the XML file refers to the folder name and the AutoCAD drawing 
name from which the sewer data was exported.

<Project name="C:\Munsys15.1\Munsys.dwg" />

Application version

The Application data creates information pertaining to the Munsys version used to generate the 
XML file. The Author tag stores the username of the person who created the XML file.

<Application name="Munsys" desc="Munsys" manufacturer="Open Spatial Pty Ltd" version="15.1" 
manufacturerURL="www.openspatial.com" timeStamp="2022-06-10T08:03:03"> 

<Author createdBy="MCITY15US" createdByEmail="" company="" companyURL="" timeStamp="2022-09-
10T08:03:03" /> 

</Application>

Note The application version information is not editable from within Munsys.
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Node Structures

The Sewer Nodes are exported with the following XML data elements:

<Struct name="MUNID-79" desc="MANHOLE_PUB" elevRim="471.728" elevSump="-0.547"> 

<Center>-2882545.083 -76018.056</Center> 

<CircStruct diameter="16.0" thickness="0.5" /> 

<Invert elev="1634.573" flowDir="In" refPipe="MUNID-71" /> 

<Invert elev="1634.573" flowDir="Out" refPipe="MUNID-61" /> 

</Struct>

The following table shows the sewer node attributes exported to LandXML format:

Figure 33 LandXML Node attributes

Elements Example Description

Struct name "MUNID-79" This value refers to the unique node ID 
(NODE_ID) in SP_SEWNODE.

desc "MANHOLE_PUB" This value refers to the node type 
(NODE_TYPE) in SP_SEWNODE.

elevRim "471.728" This value refers to the cover level 
(NODE_COVELEV) in SP_SEWN-
ODE.

elevSump "-0.547" This value is calculated by subtracting the 
node depth value (NODE_DEPTH) 
from the cover level value (NODE_COV-
ELEV) in SP_SEWNODE.

Center 2882545.083
-76018.056

This value refers to the physical insertion 
point of the node (GEOMETRY) in 
SP_SEWNODE.

CircStruct diameter "16.0" This value is the default diameter assigned 
to the node.

thickness "0.5" This value is the default thickness assigned 
to the node.

Invert elev "1634.573" This value is the invert level of the con-
nected pipe. (END_INVELEV from 
SP_SEWGPIPE if flowDir is "IN" or 
START_INVELEV from SP_SEWGPIPE 
if flowDir is "OUT")

flowDir "In" or "Out" This value determines if the pipe is 
incoming or outgoing

refPipe "MUNID-71" This value is the pipe ID of the connected 
pipe (PIPE_ID)
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Pipe Structures

The Sewer Pipes are exported with the following XML data elements:

<Pipes> 

<Pipe name="MUNID-71" refEnd="MUNID-78" refStart="MUNID-79" desc="PVC" length="64.927000" slope="-
0.01005745"> 

<CircPipe diameter="150" thickness="0.08" /> 

</Pipe>

The following table shows the sewer pipe attributes exported to LandXML format:

Figure 34 LandXML Pipe attributes 

Elements Example Description

Pipe name "MUNID-71" This value refers to the unique pipe ID 
(PIPE_ID) in SP_SEWGPIPE, SP_SE-
WRPIPE or SP_SEWVPIPE.

refEnd "MUNID-79" This value refers to the end node ID 
(END_NODE) in SP_SEWGPIPE, 
SP_SEWRPIPE or SP_SEWVPIPE.

refStart "MUNID-71" This value refers to the start node ID 
(START_NODE) in SP_SEWGPIPE, 
SP_SEWRPIPE or SP_SEWVPIPE.

desc "PVC" This value refers to the pipe material 
(PIPE_MATRL) in SP_SEWGPIPE, 
SP_SEWRPIPE or SP_SEWVPIPE.

length "64.927000" This value refers to the length of the pipe 
(GEOM_LENGTH) in SP_SEWG-
PIPE, SP_SEWRPIPE or 
SP_SEWVPIPE.

slope "0.01005745" This value refers to the pipe gradient 
(PIPE_GRADIENT) in SP_SEWG-
PIPE, SP_SEWRPIPE or 
SP_SEWVPIPE.

CircPipe diameter "150" This value is the pipe diameter 
(PIPE_DIA) in SP_SEWGPIPE, SP_SE-
WRPIPE or SP_SEWVPIPE.

thickness "0.08" This value is the default pipe thickness 
used to represent the pipe for US schemas.
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Exporting sewer nodes and pipes to LandXML
Before you export the sewer nodes and pipes to LandXML format you will first query the sewer 
network into the AutoCAD drawing area using the Munsys Query functionality. For more 
information about querying data from the database, please consult the Munsys Concepts User 
Manual. You can select in which projection the data is queried into by selecting the Extras > Set 
Coordinate System menu option. 

To export the sewer network objects, do the following:

1 Choose Extras > Export Objects to > Land XML.

2 Select the sewer entities that you want to export, and then press ENTER.

The command indicates the number of pipes and nodes selected.

3 The Save File As dialog box is displayed.

4 On this dialog box, specify the filename and folder where the .xml file will be saved to. The default 
destination is C:\Munsys15.1\Munsys.xml

Figure 35 Example of the LandXML export file
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Importing sewer objects from LandXML
By importing XML data you can easily update existing sewer objects’ attributes with new values 
that have been calculated from 3rd party design and analysis applications, such as AutoCAD 
Civil 3D.

If the Munsys sewer objects have already been queried into the current drawing when the XML 
file is imported, sewer objects with matching IDs will automatically be updated with the 
attributes from the XML file. The nodes and pipes (gravity, pressure and vacuum) will 
immediately change to the Munsys Integrity color indicating that attribute values have changed 
and must be checked before posting to the database. 

If the objects being imported from the XML file cannot find existing Munsys objects with 
matching IDs in the current drawing, new CAD objects are created. The nodes are imported 
onto a default layer SANITARY-NODE-MUNSYS while the pipes are imported into the 
default layer SANITARY-PIPE-MUNSYS. Using the conversion tools available in Munsys 
Sewer, these new objects can be converted from CAD entities to sewer objects ready for 
checking and posting to the database.

To import sewer objects from LandXML
With this function you can import sewer objects into an AutoCAD drawing as CAD objects.

To import the XML data, do the following:

1 Choose Extras > Import Objects from > LandXML.

2 The Select LandXML to Import dialog box is displayed.

3 On this dialog box, specify the filename and folder where the .xml file will be imported from. The 
default folder is C:\Munsys15.1\

4 Once the filename is selected choose the Open button.

Existing Munsys sewer objects are automatically updated with the XML attribute data, and their 
color is changed to the Munsys Integrity color.

Note It is recommended that the default configuration file be copied from C:\Program Files\Open 
Spatial\MunApps15.1\xtrExportCZML_Def.ini to a folder where the file can be edited and saved for 
future use, such as C:\Munsys15.1
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Exporting sewer objects to CZML
Munsys Sewer provides the tools for users to take the 2 ½D Munsys sewer data and recreate as 
full 3D geospatial data using the pipe and node invert levels and depths to generate accurate, 
open source CZML files.  CZML is a JSON format for describing graphical data in a 3D 
context or primarily for display Digital Twin environments such as Cesium or Terria.io, as well 
as CSIRO’s Data61 open data platform. These 3D data files can then be displayed in Digital 
Twin Environments such as Cesium virtual globe  or Terria.io where global 3D terrain, imagery 
and building infrastructure are used to provide full 3D geospatial visualization in context and 
integrated with active environments. With Munsys Sewer, you can export sanitary sewer node 
and pipe object data to CZML data format.

The way the selected data is displayed in the web browser is defined in the configuration file 
called xtrExportCZML_Def.ini. If you used the default installation path when installing the 
Munsys applications, the .ini file is located in C:\Program Files\Open Spatial\MunApps15.1. It 
is recommended that this file be copied to another folder before it is edited.

The configuration file is also used to specify which attributes to display, to set the color and 
opacity for solid filled objects, to set line widths and colors for line and polyline objects, and to 
define which object type and color to represent node type objects.

The resultant CZML file contains a single JSON array for each object selected in the drawing, 
where each object-literal element in the array is a CZML Packet. A CZML Packet describes the 
graphical properties for a single object in the scene, such as a sewer node and pipe.

The user must first query the sewer nodes and pipes into the drawing that they want to include 
in the CZML file. The definition file must be configured to include the attribute parameters to 
be exported with the spatial object. Sewer gravity pipes and rising mains are both supported for 
the CZML export process.

CZML Export configuration file

The configuration file (xtrExportCZML_Def.ini) is installed as part of the Munsys 
Applications and stores all the parameters and settings required to interpret data which is 
“converted” to a CZML format.

The default configuration file xtrExportCZML.ini resides in the application folder 
C:\Program Files\Open Spatial\MunApps15.1 and is populated with “example” parameters. 
It is recommended that this configuration file be copied to C:\Munsys15.1 before it can be 
edited.

The following parameters are required to export sewer gravity pipes to CZML format:

 ID_DESCRIPTION: Indicates the object is a sewer gravity pipe, i.e., Pipe

 NAME_DESCRIPTION: Populates the Name variable in the CZML packet header 
i.e., Sewer Pipe - Gravity.

 MUN_ID: The Unique identifier (MUN_ID) which references the spatial table within 
the Munsys schema from which the spatial and attribute data is extracted, i.e., 25 = 
SP_SEWGPIPE

 START_HEIGHT: Reads the Start Invert Level value from the column START_IN-
VELEV.
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 END_HEIGHT: Reads the End Invert Level value from the column 
END_INVELEV.

 PIPE_DIA: Reads the pipe diameter value from the column PIPE_DIA.

 COLOR_RGBA: Sets the color used to represent the sewer pipe using the RGBA for-
mat [255,255,255,255] i.e., 255,0,0,255

 ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in 
the CZML export file and there may not be spaces between the comma separators, i.e., 
PIPE_MATRL,START_NODE,START_COVELEV,START_IN-
VELEV,END_NODE,END_COVELEV,END_INVELEV.

 ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions 
must match the order of the column names, and there may not be spaces between the 
comma separators, i.e., Pipe Material,Start Node ID,Start Cover Elevation,Start Invert 
Elevation,End Node ID,End Cover Elevation,End Invert Elevation

 CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. 
Sewer Gravity Pipes can be represented as a PIPEVOLUME output type.

Figure 36 Example of a CZML export file for Sewer gravity pipes

The following parameters are required to export Sewer rising main pipes to CZML format:

 ID_DESCRIPTION: Indicates the object is a sewer rising main pipe i.e., Pipe

 NAME_DESCRIPTION: Populates the Name variable in the CZML packet 
header i.e. Rising Mains.

 MUN_ID: The Unique identifier which references the spatial table within the 
Munsys schema from which the spatial and attribute data is extracted, i.e., 28 = 
SP_SEWRPIPE.

 START_HEIGHT: Reads the Start Invert Level value from the column START_-
INVELEV

 END_HEIGHT: Reads the End Invert Level value from the column END_IN-
VELEV.

 PIPE_DIA: Reads the Pipe Diameter value from the column PIPE_DIA
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 COLOR_RGBA: Sets the color used to represent the sewer pipe rising mains using the 
RGBA format [255,255,255,255] i.e., 255,0,0,255

 ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in the 
CZML export file and there may not be spaces between the comma separators, i.e., 
PIPE_MATRL,START_NODE,START_COVELEV,START_INVELEV,END_NODE,END_-
COVELEV,END_INVELEV

 ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions must 
match the order of the column names, and there may not be spaces between the comma 
separators, i.e., Pipe Material,Start Node ID,Start Cover Elevation,Start Invert Elevation,End Node 
ID,End Cover Elevation,End Invert Elevation

 CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. Sewer 
Rising Mains Pipes can be represented as a PIPEVOLUME output type.

Figure 37 Example of a CZML export file for Sewer rising mains pipes

The following parameters are required to export sewer manholes to CZML format:

 ID_DESCRIPTION: Indicates the object is a sewer node i.e., Node

 NAME_DESCRIPTION: Populates the Name variable in the CZML packet 
header i.e. Manhole.

 MUN_ID: The Unique identifier which references the spatial table within the 
Munsys schema from which the spatial and attribute data is extracted, i.e., 23 = 
SP_SEWNODE

 NODE_TYPE: Filters the selection based on the node type value from the column 
NODE_TYPE i.e., MANHOLE_PUB,MANHOLE_PRV which caters for Public 
and Private Manhole types.

 NODE_HEIGHT: Reads the Ground Level value from the column 
NODE_COVELEV

 NODE_DEPTH: Reads the Node Depth value from the column 
NODE_DEPTH

 COLOR_RGBA: Sets the color used to represent the sewer node using the RGBA 
format [255,255,255,255] i.e., 0,0,255,255
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 ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included 
in the CZML export file and there may not be spaces between the comma separa-
tors, i.e. NODE_ID,NODE_FUNC.

 ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column 
descriptions to be included in the CZML export file. The order of the column 
descriptions must match the order of the column names, and there may not be 
spaces between the comma separators, i.e., Node ID,Node Function

 COLOR_RGBA: Sets the color used to represent the sewer manhole using the 
RGBA format [255,255,255,255] i.e., 0,0,255,255

 CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. 
Manholes can be defined as a TUBE.

 TUBE_RADIUS: Sets the radius for the TUBE object type i.e., 1.5

Figure 38 Example of a CZML export file for Sewer manhole nodes

The following parameters are required to export sewer pump stations to CZML format:

 ID_DESCRIPTION: Indicates the object is a sewer node i.e., Node

 NAME_DESCRIPTION: Populates the Name variable in the CZML packet header i.e. 
Pump Station.

 MUN_ID: The Unique identifier which references the spatial table within the Munsys 
schema from which the spatial and attribute data is extracted, i.e., 23 = SP_SEWNODE

 NODE_TYPE: Filters the selection based on the node type value from the column 
NODE_TYPE i.e: PUMPSTATION_PUB.

 NODE_HEIGHT: Reads the Ground Level value from the column 
NODE_COVELEV

 NODE_DEPTH: Reads the Node Depth value from the column NODE_DEPTH

 COLOR_RGBA: Sets the color used to represent the sewer node using the RGBA for-
mat [255,255,255,255] i.e., 0,0,255,255

 ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in the 
CZML export file and there may not be spaces between the comma separators, i.e. 
NODE_ID,NODE_FUNC
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 ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions must 
match the order of the column names, and there may not be spaces between the comma 
separators, i.e. Node ID, Node Function.

 CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. Pump 
Stations can be defined as a BOX.

 BOX SIZE: Sets a static Length and Width for the box type i.e., 2.5,2.5

Figure 39 Example of a CZML export file for Sewer Pump Stations

Exporting sewer nodes and pipes to CZML

Before you export the sewer nodes and pipes to CZML format you will first query the sewer 
network into the AutoCAD drawing using the Munsys Query functionality. For more 
information about querying data from the database, please consult the Munsys Concepts User 
Manual. When the data is exported to CZML format, the geometry for each object is 
transformed from the database coordinate system to WGS84 (X;Y;Z values).

To export the drainage network objects, do the following:

1 Choose Extras > Export Objects to CZML.

2 The CZML ini File dialog box is displayed.

Note It is recommended that the default configuration file be copied from 
C:\Program Files\Open Spatial\MunApps15.1\xtrExportCZML_Def.ini to a folder where the file can be 
edited and saved for future use, such as C:\Munsys15.1
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Figure 40 Selecting the Sewer Configuration file

3 Select the configuration file to apply to the export, then select OPEN.

4 The Save File As dialog box is displayed and defaults to the folder C:\Munsys15.1.

Figure 41 Entering the Sewer Export File name

5 On this dialog box, specify the file name and folder where the resultant .czml file will be saved to. 
The default destination folder is C:\Munsys15.1.

6 At the AutoCAD command line you are prompted to select the sewer entities to export, and then 
press ENTER.
The command indicates the number of objects selected.

7 At the command line, the date and time stamp of when the export started and ended is displayed.
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8 Opening the CZML file in a text editor displays the file contents which contains a single JSON array 
for each object selected in the drawing where each object -literal element in the array is a CZML 
Packet.

Figure 42 Example of the resultant CZML file for Sewer objects
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 Chapter 5


 Maintaining sewer data

Modifying sewer data
Spatial data is stored in spatial and attribute tables as records. Sewer objects that need to be 
edited are retrieved from the database onto their respective layers, for example, SEWVPIPE, 
SEWNODE or SEWNOTE. 

Once sewer pipes and nodes have been placed, the sewer pipes have to be manipulated to make 
certain that they are joined correctly, for example with no overlaps or undershoots, and each 
pipe has to have a start and end node.

Attribute values linked to sewer objects can be modified easily from the Change menu and 
toolbar, for example pipe diameter, material and type.

Sewer objects that have been changed need to be checked against the sewer business rules 
before they can be posted to the database.
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Changing sewer pipes

To extend a sewer pipe to a boundary
Sewer pipes can be extended to a boundary object by first indicating the boundary object, and 
then selecting the pipe to extend. The pipe must be able to intersect with the boundary object. 
This function is often used to extend pipes to create 
T-junctions during capture. The end point of the pipe is then changed to intersect the boundary 
object.

1 Do one of the following:

 Choose Change > Extend Pipe to Boundary.

 Click the Extend Pipe to Boundary button on the Munsys Sewer Change toolbar.

2 Select the boundary object where the pipe has to extend to.

3 Select the pipe that needs to extend.

The pipe is extended as indicated.

To extend a sewer pipe by distance
This function extends a sewer pipe by a specified distance at the endpoint closest to a selected 
point on the pipe. You are prompted for the distance to extend the pipe with. You can also use 
this function to shorten a pipe by entering a negative distance, for example, -50.

1 Do one of the following:

 Choose Change > Extend Pipe by Distance.

 Click the Extend Pipe by Distance button on the Munsys Sewer Change toolbar.

2 Select the pipe that you want to extend, and then enter a distance on the command line.

The pipe is extended as indicated.
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To extend a sewer pipe and break it at the intersection
This function extends a sewer pipe to a boundary pipe that is then broken at the intersection. 
The pipe to be broken is selected first, and then the pipe to extend. The pipe to be broken must 
be able to intersect with the second pipe.

1 Do one of the following:

 Choose Change > Extend and Break Pipe.

 Click the Extend and Break Pipe button on the Munsys Sewer Change toolbar.

2 Select the pipe that you want to break.

3 Select the pipe that you want to extend.

The pipes are extended and broken respectively, as indicated.

To break a sewer pipe
This function breaks a sewer pipe nearest to a selected point on the pipe.

1 Do one of the following:

 Choose Change > Break Pipe.

 Click the Break Pipe button on the Munsys Sewer Change toolbar.

2 Select the sewer pipe that you want to break.

3 Indicate the break point.

The pipe is broken at the break point that you indicated. 
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To change a sewer pipe
With this function, you can move one or more selected pipe endpoints to a new location. 

1 Do one of the following:

 Choose Change > Change Pipe.

 Click the Change Pipe button on the Munsys Sewer Change toolbar.

2 Select the sewer pipe close to the endpoint that needs to move.

3 Specify the destination point.

The end point of the pipe is moved to the destination point that you specified.

To fillet sewer pipes
This function connects two sewer pipes at an apparent intersection.

1 Do one of the following:

 Choose Change > Fillet Pipe.

 Click the Fillet Pipe button on the Munsys Sewer Change toolbar.

2 Select the first pipe.

3 Select the second pipe.

The pipes are connected as indicated.

To trim a sewer pipe
You can trim a section of a sewer pipe by first selecting the cutting edge, and then selecting the 
section of pipe to be removed. The cutting edge must be a line that intersects the pipe. 

1 Do one of the following:

 Choose Change > Trim Pipe.

 Click the Trim Pipe button on the Munsys Sewer Change toolbar.

2 Select the cutting edge (the pipe that you want to trim to).

3 Select the pipe that needs to be trimmed.

Munsys trims the last indicated pipe to the first one.
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To join sewer pipes
This function is used to join two sewer pipes, creating a single pipe. The attributes from the 
first pipe selected remain the attributes for the joined pipe. If there is a gap between the two 
pipes to be joined, they are joined with a line segment. A joined pipe is created from the 
geometry of the first pipe selected, and the second pipe selected is moved to the DELETED 
layer. The first selected pipe, now the new joined pipe, is flagged as a change to be verified when 
the integrity check is run. The end point cover and invert elevations are not updated 
automatically.

1 Choose Change > Join Pipe.

2 Select the first sewer pipe (the pipe that you want to join to).

3 Select a point close to the endpoint of the second pipe (the pipe that you want to join).

The pipes are joined as indicated, and the attributes from the first pipe selected remain the 
attributes for the joined pipe.

To change the vertex of a sewer pipe
With this function, you can remove, move, add or insert new vertices to segments in a sewer 
pipe.

To add a vertex to a pipe

1 Choose Change > Change Pipe Vertex > Add.

2 Select the applicable sewer pipe.

3 Select the endpoint of the segment where you want to add the vertex.

4 Select the position for the new point.

The vertex is added at the position that you indicated.

To move a pipe vertex

1 Choose Change > Change Pipe Vertex > Move.

2 Select the applicable sewer pipe.

3 Specify a point closest to the vertex that you want to move.

4 Specify a point to move the vertex to.

The vertex is moved to the destination point that you specified.

To remove a pipe vertex

1 Choose Change > Change Pipe Vertex > Remove.

2 Select the applicable sewer pipe.

3 Select the vertex that you want to remove from the sewer pipe.

Note A vertex can only be removed from a segment with more than two vertices.
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To insert a vertex into a pipe

1 Choose Change > Change Pipe Vertex > Insert.

2 Select the applicable sewer pipe.

3 Select the segment for the inserted point.

4 Select the position for the new point.

The vertex is inserted in the position you selected.

Changing sewer nodes
Using the Munsys Sewer Change menu/toolbar, sewer nodes can be moved to a new location, 
rotated manually or snapped to sewer pipes. You can also change the node type of one or more 
selected nodes. These functions are used when the sewer network is cleaned up after the capture 
process.

Moving a sewer node
You can move a sewer node to a new location by first selecting the node, and then specifying 
the point where you want to place it.

To move a sewer node

1 Do one of the following:

 Choose Change > Move Node.

 Click the Move Sewer Node button on the Munsys Sewer Change toolbar.

2 Select the node that you want to move.

3 Specify a new insertion point for the node.

The sewer node is moved to the destination point you indicated.

Figure 1 Moving a sewer node
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Rotating a sewer node
With this function, you can rotate one or more selected sewer nodes. The rotation angle is 
specified by typing the angle on the command line, indicating the angle with the mouse pointer 
or specifying an object to align the node with.

To rotate a sewer node

1 Do one of the following:

 Choose Change > Rotate Node.

 Click the Rotate Node button on the Munsys Sewer Change toolbar.

2 Select the node that you want to rotate.

3 To specify the rotation angle, do one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle.

 Indicate the angle with your mouse pointer by picking two points in the drawing.

 On the command line, type A to align the node to a segment, press ENTER, and then select the 
object to which you want to align the node.

The node is rotated as specified.

Snapping a node to the endpoint of a sewer pipe
With this function, you can snap a node to the endpoint of a sewer pipe. The node is moved to 
the end point closest to the point selected on the pipe.

To snap a node to the endpoint of a sewer pipe

1 Do one of the following:

 Choose Change > Snap Node to Endpoint.

 Click the Snap Node to Endpoint button on the Munsys Sewer Change toolbar.

2 Select the applicable node.

3 Select the pipe close to the endpoint that you want to snap the node to.

The node is snapped to the endpoint of the pipe.
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Snapping a node to the endpoint of a pipe, breaking the pipe
With this function, you can break a pipe and snap a node to the endpoint of the broken pipe.

To snap a node and break a pipe

1 Do one of the following:

 Choose Change > Snap Node and Break Pipe.

 Click the Snap Node and Break Pipe button on the Munsys Sewer Change toolbar.

2 Select the applicable node.

3 Select the pipe that you want to snap the node to.

4 Specify a break point on the pipe.

The node is snapped to the endpoint of the broken pipe.

Opening and closing valves
With this function, you can change the status of an open valve to Closed. The node type of the 
valve does not change; only the valve symbol is changed to a closed valve.

To open or close valves

1 Choose Change > Open/Close Valve.

2 Select the valve(s) that you want to change.

The Valve Status dialog box is displayed.

Figure 2 The Valve Status dialog box

3 Change the status as required, and then click OK to apply.

The valve symbol is changed, as seen in the following figure:
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Figure 3 Opening and closing valves

Changing a node type
With this function, you can change the node type of one or more selected nodes. The new node 
type is selected from a list. The symbol name and the NODE_TYPE column are updated 
according to the new node type selected.

To change a node type

1 Choose Change > Change Node Type...

2 Select the node(s) that you want to change, and then press ENTER.

The Node Types dialog box is displayed.

Figure 4 The Node Types dialog box

3 Select the new node type from the list, and then click OK.

The node type is changed as indicated. It is flagged as a change to be verified with the integrity 
check, and the new node is displayed in the integrity color.

An open valve

When the valve is closed using 
the Open/Close Valve function, 
the valve symbol is changed.
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Changing sewer attribute data
With Munsys Sewer, you can change the physical attributes of sewer objects, for example 
material, diameter and type. You can also change sewer pipe and node elevations. You can also 
change a service connection type and link service connections to their respective parcels.

Editing sewer object attributes
The Edit Attributes function is used to edit the attributes of one or more selected sewer objects 
that belong to the same object type. The current application determines what object types may 
be selected; for example, if you are working in Munsys Sewer, only sewer objects may be 
selected. If you select more than one object type (for example pipes and nodes), you will be 
required to choose a single object type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database). 
Once the objects have been selected and an object type to edit has been specified, the Edit 
Attributes dialog box is displayed. This dialog box contains various options that can be used to 
edit the attributes of the spatial objects:

 Attribute templates – attributes can be edited using an attribute template. The attributes 
that will be displayed when an attribute template has been selected will depend on the 
attributes that have been specified on the template, as well as the formatting parameters that 
apply to each column selected as part of the attribute template. If no attribute template has 
been selected, all the attributes belonging to the spatial object type are displayed.

 Editing multiple objects simultaneously – if you select this option, attributes of multiple 
objects are displayed simultaneously. Where the attributes of all the selected objects are the 
same, a value is displayed. Where attributes of the various objects that were selected differ, 
a value of *VARIES* is displayed. When a change is made to a value, the new value is 
applied to all the selected objects. If you do not select the Edit multiple objects 
simultaneously check box, you can edit the selected objects one by one. The values that are 
changed are only applied to the object that is currently selected.

 AutoZoom – this option is only available when the Edit multiple objects simultaneously 
option is not selected, i.e. when you are going to edit the objects one by one. If the 
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as 
it becomes the current object, and highlight it. The object navigation buttons are used to 
move from one object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column, either by 
typing a new value or by selecting a value from a drop-down list. Changes that are made are 
applied to objects in the drawing. These changes will only be updated in the database when the 
object integrity check has been run and the objects have been posted to the database.

When editing attributes, mandatory fields are displayed with an “!” character prefixing the 
attribute column in the Attributes list on the Edit Attributes dialog box. If the mandatory 
attribute is not captured for new or modified objects, the Object Integrity Check will fail based 
on the attribute rules setup. Using the Browse Integrity Markers option, the Error Info describes 
which column may not be NULL.
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To edit sewer objects

1 Choose Change > Edit Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object 
Identification dialog box is displayed.

Figure 5 The Spatial Object Identification dialog box

3 Select a single spatial object type to edit, and then click OK.

The Edit Attributes: [Object Type] dialog box is displayed.

Figure 6 The Edit Attributes dialog box

4 If you want to edit the objects using an attribute template, select the appropriate attribute template 
from the Attribute Template list. If you do not want to make use of an attribute template, select 
None.
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Figure 7 Edit Attributes: Selecting an attribute template

5 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple 
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*, as 
seen in the following figure:

Figure 8 The Edit Attributes dialog box: Edit multiple objects simultaneously

6 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously 
check box. Select the AutoZoom to object check box to zoom to the objects one by one and 
highlight them. The object navigation buttons are used to move from one object to the next.
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7 To edit an attribute, do one of the following:

 Highlight a value, and then choose a value from the list in the Value column.

 Highlight a value, and then enter a new value in the Value column

Note Mandatory attributes are displayed with an “!” character preceding the Attribute Description. Failure to 
capture mandatory attributes for new or modified objects results in the object failing the Object Integrity 
Check.

8 Click OK to apply the new value(s) to the object(s).

9 The values are applied to the objects, to be verified with the object integrity check.

Editing linked table attributes
This function is used to edit spatial object attributes that exist in linked tables. Linked table 
attributes are updated directly to the database. The current application determines what object 
types may be selected; for example, if you are working in Munsys Sewer, only sewer objects may 
be selected. If you select more than one object type (for example pipes and nodes), you will be 
required to choose a single object type to edit. You can only select objects that have previously 
been posted to the database.

The link tables that can be edited using this function must be defined through an attribute 
template. The applicable attribute template is selected from a list, which is created by filtering 
attribute templates according to the following characteristics:

 Only attribute templates associated with the current spatial object type, being edited are 
included – the primary table in the attribute template is the same table from which the 
spatial objects were queried.

 Only attribute templates that contain linked tables are included

 The linked table specified may not be a Munsys spatial table

 The user must have edit privileges to the linked table

 The link column used to describe the relationship with the primary table must reference a 
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column by typing in 
a new value. Navigation buttons are used to move between the various records that are available 
and to move from one object to the next. You can also insert records into, or delete records from 
a linked table, depending on the privileges you have on the link table.

The procedure for editing linked table attributes is described in detail in the Munsys Concepts 
User Manual.
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Changing sewer pipe elevations
This function is used to change cover and invert elevations for the start and endpoint of a sewer 
pipe during editing. Cover and invert elevations are stored with a pipe to cater for a drop 
manhole, where incoming pipes have a higher invert elevation than the outgoing pipe. During 
the integrity check, node elevations are calculated from pipe elevations if not present.

To change sewer pipe elevations

1 Choose Change > Pipe Elevations...

2 Select the appropriate sewer pipe.

The Sewer Pipe Information dialog box is displayed.

Figure 9 The Sewer Pipe Information dialog box

3 From the Start Info group, change the following:

 Cover Elevation

 Invert Elevation

The Depth value is updated automatically.

4 From the End Info group, change the following:

 Cover Elevation

 Invert Elevation

The Depth value is updated automatically.

The pipe length and gradient values in the Detail Info group are calculated automatically from the 
Start Info and End Info group.

5 Click OK to accept the changes you have made.

The attribute changes are accepted.



Maintaining sewer data 79 








Changing sewer node elevations
With this function, you can change the node depth and cover elevation of a sewer node.

To change sewer node elevations

1 Choose Change > Node Elevations...

2 Select the appropriate sewer node.

The Sewer Node Information dialog box is displayed.

Figure 10 The Sewer Node Information dialog box

3 Enter a new value for one or all of the following:

 Node Depth 

 Cover Elevation

4 Click OK to apply the changes.

The attribute changes are accepted.
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Updating Elevations
There is no direct correlation between the sewer node’s cover level and depth, and the sewer 
pipes’ ground level, invert level and gradient. The association between the nodes and pipes is 
the connectivity, which is defined in the database design.

So when one of the values is changed for either the sewer node or pipe, the associated 
information is not automatically updated to the connected object, for example:

The node depth value stored with the sewer nodes is not automatically updated when the cover 
or ground level or invert levels for the attached pipes are updated.

or

The start and end ground levels are not updated when the connected node’s ground level is 
updated.

For this reason, menu items to update the associated nodes, pipes (including gravity, pressure 
and vacuum pipe) and gradients, based on their connectivity, can be updated or recalculated 
using the following menu items:

 Change > Update Elevations > Node to Pipe - Updates the connecting pipes’ start/end cover 
elevations and the start invert elevation using the connecting nodes’ cover/ground level and 
depth.

 Change > Update Elevations > Pipe to Node - Updates the connecting nodes’ cover 
elevation and depth using the start/end cover elevations and start/end invert elevations from the 
connecting pipes.

 Change > Update Elevations > Recalculate Gradients - recalculates the gradient for selected 
pipes.

Typical Sanitary Sewer As Constructed detail plan
In the typical As Constructed Design plan example below there are sewer pipes running 
downstream between manholes MH23, MH24 and MH25. 

Figure 11 Typical As Constructed Design plan
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To update pipe elevations with connecting nodes 
In the example of updating Node to Pipe, Manholes MH23, MH24 and MH25 have the 
following Node Depth and Cover Elevation values captured in the SP_SEWNODE table:

Table 12 SP_SEWNODE captured values

Figure 13 Sewer nodes Cover Elevations and Depths simplified

To execute the Node to Pipe function, do the following:

1 Choose Change > Update Elevations > Node to Pipe

2 Select the appropriate sewer node(s) and then Enter.

Figure 14 The sewer nodes are selected

Attribute Column Name MH23 MH24 MH25

NODE_REF MH23 MH24 MH25

NODE_DEPTH 10.77 10.67 10.67

NODE_COVELEV 39.24 38.67 38.60
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Figure 15 The sewer pipe attributes are updated

The command line indicates the number of pipe(s) updated.

The sewer pipe color is changed to the Munsys Integrity color, indicating that the Object Integrity 
check is required before posting the updates to the database.

After completing the Node to Pipe update function, the following values are calculated for the 
Sewer Gravity Pipes in the SP_SEWGPIPE table:

Table 16 SP_SEWGPIPE calcualted values

The downstream end invert elevation values of both pipes were intentionally not calcualted 
since they cannot be assumed from the downstream node depth, especially in the case of drop 
manholes. 

Attribute Column Name
Pipe from 
MH23 to MH24

Pipe from 
MH24 to MH25

PIPE_GRADIENT - calculated 2.766 3.241

START_COVELEV - calculated 39.24 38.670

END_COVELEV - calculated 38.67 38.680

START_INELEV - calcualted 28.47 28.00

END_INELEV [not calculated] [not calculated]
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To update node levels with connecting pipes
In the example of updating Pipe to Node, Pipe MH23 to MH24 and Pipe MH24 to MH25 
have the following Cover Elevation and Invert Elevations values captured in the 
SP_SEWGPIPE table:

Table 17 SP_SEWGPIPE captured Elevation values

Figure 18 Sewer Pipe Cover and Invert Elevations simplified

To execute the Pipe to Node function, do the following:

1 Choose Change > Update Elevations > Pipe to Node

2 Select the appropriate sewer pipe(s) and then Enter.

Attribute Column Name
Pipe from 
MH23 to MH24

Pipe from 
MH24 to MH25

START_COVELEV 39.24 38.670

END_COVELEV 38.67 38.680

START_INELEV 28.47 28.00

END_INELEV 26.78 28.10
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Figure 19 The sewer pipes are selected

Figure 20 The sewer node attributes are updated

The command line indicates the number of nodes updated.

The sewer nodes’ color is changed to the Munsys Integrity color, indicating that the Object Integrity 
check is required before posting the updates to the database.

After completing the Pipe to Node update function, the following values are calculated for the 
Sewer Nodes in the SP_SEWNODE table:

Table 21 SP_SEWGPIPE calcualted values

The depth of the node is calcualted form the start Invert Elevation of the downstream pipe and 
not the end Invert Elevation of the upstream pipe.

Attribute Column Name MH23 MH24 MH25

NODE_DEPTH - calculated 10.77 10.67 [not calculated]

NODE_COVELEV - calculated 39.24 38.67 [not calculated]
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To recalculate pipe gradients

1 Choose Change > Update Elevations > Recalculate Gradients

2 Select the appropriate sewer pipes(s) and then Enter.

Figure 22 The sewer pipes are selected

Figure 23 The sewer gradients are recalulated

The command line indicates the number of pipe(s) updated.

3 The Sewer Pipe color is changed to the Munsys Integrity color, indicating that the Object Integrity 
check is required before posting the updates to the database.
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Changing sewer pipe diameter
You can change the default diameter that was assigned to one or more sewer pipes during the 
capture process. The new diameter is selected from a list to ensure data accuracy. 

Tip If you construct the sewer pipes with the default diameter set to the one used most commonly, only pipes 
that have a different diameter need to be changed, reducing the amount of data to be captured.

To change gravity pipe diameter

1 Choose Change > Change Gravity Pipe Attributes > Diameter...

2 Select the appropriate gravity pipe(s), and then press ENTER.

The Select Gravity Pipe Diameter dialog box is displayed, highlighting the diameter of the pipe that 
you selected. If you selected multiple pipes, no current diameter is highlighted.

Figure 24 The Select Gravity Pipe Diameter dialog box$

3 Select the new diameter from the list, and then click OK.

The diameter is changed as specified.

Search for an item by its code or 
description.
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To change pressure pipe diameter

1 Choose Change > Change Pressure Pipe Attributes > Diameter...

2 Select the appropriate pressure pipe(s), and then press ENTER.

The Select Pressure Pipe Diameter dialog box is displayed, highlighting the diameter of the pipe that 
you selected. If you selected multiple pipes, no current diameter is highlighted.

Figure 25 The Select Pressure Pipe Diameter dialog box$

3 Select the new diameter from the list, and then click OK.

The diameter is changed as specified.

Search for an item by its code or 
description.
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To change vacuum pipe diameter

1 Choose Change > Change Vacuum Pipe Attributes > Diameter...

2 Select the appropriate vacuum pipe(s), and then press ENTER.

The Select Vacuum Pipe Diameter dialog box is displayed, highlighting the diameter of the pipe that 
you selected. If you selected multiple pipes, no current diameter is highlighted.

Figure 26 The Select Vacuum Pipe Diameter dialog box

3 Select the new diameter from the list, and then click OK.

The diameter is changed as specified.

Search for an item by its code or 
description.
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Changing sewer pipe material
You can change the default pipe material that was assigned to gravity, pressure or vacuum pipes 
during the capture process.

Tip If you construct the sewer pipes with the default pipe material set to the one used most commonly, only 
pipes that have a different material need to be changed, reducing the amount of data to be captured.

To change gravity pipe material

1 Choose Change > Change Gravity Pipe Attributes > Material...

2 Select the appropriate gravity pipe(s), and then press ENTER.

The Select Gravity Pipe Material dialog box is displayed, highlighting the material of the pipe that 
you selected. If you selected multiple pipes, no current material is highlighted.

Figure 27 The Select Gravity Pipe Material dialog box

3 Select the appropriate pipe material from the list, and then click OK.

The pipe material is changed as specified.

Search for an item by its code or 
description.
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To change pressure pipe material

1 Choose Change > Change Pressure Pipe Attributes > Material...

2 Select the appropriate pressure pipe(s), and then press ENTER.

The Select Pressure Pipe Material dialog box is displayed, highlighting the material of the pipe that 
you selected. If you selected multiple pipes, no current material is highlighted.

Figure 28 The Select Pressure Pipe Material dialog box

3 Select the appropriate pipe material from the list, and then click OK.

The pipe material is changed as specified.

Search for an item by its code or 
description.
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To change vacuum pipe material

1 Choose Change > Change Vacuum Pipe Attributes > Material...

2 Select the appropriate vacuum pipe(s), and then press ENTER.

The Select Vacuum Pipe Material dialog box is displayed, highlighting the material of the pipe that 
you selected. If you selected multiple pipes, no current material is highlighted.

Figure 29 The Select Vacuum Pipe Material dialog box

3 Select the appropriate pipe material from the list, and then click OK.

The pipe material is changed as specified.

Search for an item by its code or 
description.
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Changing a sewer pipe type
You can change the pipe type of gravity, pressure and vacuum pipes from the default that was 
entered when the pipes were captured.

Tip If you construct the sewer pipes with the default type set to the one used most commonly, only pipes that 
have a different type need to be changed, reducing the amount of data to be captured

To change a gravity pipe type

1 Choose Change > Change Gravity Pipe Attributes > Type...

2 Select the appropriate gravity pipe(s), and press ENTER.

The Select Gravity Pipe Type dialog box is displayed, showing the type of the pipe that you selected. 
If you selected multiple pipes, no current type is highlighted.

Figure 30 The Select Gravity Pipe Type dialog box

3 Select the appropriate pipe type, and then click OK.

Search for an item by its code or 
description.
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To change a pressure pipe type

1 Choose Change > Change Pressure Pipe Attributes > Type...

2 Select the appropriate pressure pipe(s), and press ENTER.

The Select Pressure Pipe Type dialog box is displayed, showing the type of the pipe that you selected. 
If you selected multiple pipes, no current type is highlighted.

Figure 31 The Select Pressure Pipe Type dialog box

3 Select the appropriate pipe type, and then click OK.

The pipe type is changed as specified.

Search for an item by its code or 
description.
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To change a vacuum pipe type

1 Choose Change > Change Vacuum Pipe Attributes > Type...

2 Select the appropriate vacuum pipe(s), and press ENTER.

The Select Vacuum Pipe Type dialog box is displayed, showing the type of the pipe that you selected. 
If you selected multiple pipes, no current type is highlighted.

Figure 32 The Select Vacuum Pipe Type dialog box

3 Select the appropriate pipe type, and then click OK.

The pipe type is changed as specified.

Search for an item by its code or 
description.
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Changing a service connection type
With this function, you can change a service connection type from the default that was entered 
when the service connection was captured. The new service connection type is selected from a 
list to ensure data accuracy.

To change a service connection type

1 Choose Change > Change SC Type...

2 Select the appropriate service connection(s), and then press ENTER.

The Select Service Connection Type dialog box is displayed, showing the type of the service 
connection that you selected. If you selected multiple service connections, no current type is 
highlighted.

Figure 33 The Select Service Connection Type dialog box

3 Select the appropriate service connection type from the list, and then click OK.

Linking service connections to parcels / buildings
This function is used to link service connections to their respective parcels or buildings. The 
parcels and buildings have to be queried from the database when running a Building or Property 
Network Trace in order for the LINK_ID column to be populated. 

Search for an item by its code or 
description.
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To link service connections to parcels

1 Choose Change > Link Service Connections...

2 Select the appropriate service connections, and then press ENTER.

The selected service connections are linked to their respective parcels and buildings.

If the endpoint of the service connection falls inside a parcel boundary the PRCL_GID column 
is updated with the GID value from SP_PARCEL.

If the endpoint of the service connection falls inside a parcel boundary and a building polygon 
the PRCL_GID column is updated with the GID value from SP_PARCEL, and the LINK_ID 
column is updated with the GID value from SP_BUILDING.

Note The user should ensure that the value of Property/Building should be populated in 
WMS_WATSERV_LINKMUNID/SMS_SEWSERV_LINKMUNID settings.

By default Building is the default value which allows Service Connections to 
Buildings/Parcels/Property, however if switched to Parcels then Buildings/Property would not 
be allowed.

Changing sewer notes
With this function, you can change the text of a sewer note, using the Sewer Note text box.

To change a sewer note

1 Do one of the following:

 Choose Change > Change Sewer Note...

 Click the Change Sewer Note button on the Munsys Sewer Change toolbar.

2 Select the sewer note that you want to change.

The Sewer Note text box is displayed, showing the current note.

Figure 34 The Sewer Note text box

3 Change the note as required, and then click OK.Adding comments

This function is used to assign descriptive comments to one or more selected objects.
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To add comments

1 Choose Change > Add Comment...

2 Select the sewer object(s) that you want to attach a comment to.

The Sewer Comment text box is displayed.

Figure 35 The Sewer Comment text box

3 In the text box, add the comment, and then click OK.

The comment is assigned to the selected object(s).

Deleting and undeleting sewer objects
With Munsys Sewer, existing sewer objects can be deleted from the database. Multiple objects 
can be selected for deleting. Sewer objects that form part of a redundant network have to be 
deleted. Deleted sewer objects are moved to a frozen layer DELETED, which is removed from 
the database when changes are posted. With the Undelete function, you can restore sewer 
objects that have been moved to the DELETED layer and that are marked for deletion.

To delete sewer objects

1 Choose Change > Delete Sewer Objects.

2 Select the sewer objects that you want to delete.

The command line indicates how many sewer objects you have selected, and how many have been 
filtered out.

3 Press ENTER to delete the selected sewer objects.

The sewer objects are flagged for deletion and moved to the layer DELETED. These changes are 
applied to the database when changes are posted.

To undelete sewer objects

1 Choose Change > Undelete Sewer Objects.

The sewer objects that you deleted are displayed in the drawing.

2 Select the sewer objects that you want to restore.

The Delete flag is no longer set for the selected objects. In the event of spatial or attribute 
changes before the objects were flagged for deletion, these changes are applied.
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