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Chapter 1
Introducing Munsys Query

Welcome to Munsys Query

Munsys Query provides design engineers with the necessary functionality to query and view
both Munsys and external spatial and attribute data in an AutoCAD environment for data
access and planning purposes.

Munsys Query forms part of the Munsys product family, which comprises the following
applications:

Munsys Cadastral

Munsys Cable Route

Munsys Cable Fiber

Munsys Drainage

Munsys Electricity

Munsys Roads

Munsys Sewer

Munsys Water

Munsys Map Books

Munsys Spatial Data Manager
Munsys Management Console
Munsys Query

Munsys Lineage

Munsys Scheduled Tasks



About this manual

The Munsys Query User Manual enables users to easily find their way around Munsys query,
and provides a conceptual overview of the functionality used in Munsys Query. For the purpose
of this manual, we assume that you are familiar with:

The business rules of the application
AutoCAD Map
Common GIS terminology
What’s in this manual
The Munsys Query User Manual consists of the following chapters:

Chapter 1 — Introducing the Munsys Query User Manual, gives an overview of this manual,
and provides links to additional reading material.

Chapter 2 — Getting acquainted with Munsys Query, gives an overview of Munsys Query
and its various components.

Chapter 3 — Querying data from the database, describes how to query data from the
database using Munsys Query.

Additional reading material

Before you start using this manual, we suggest that you first read the
Munsys Concepts User Manual, which contains the following information:

the generic functionality of the various Munsys applications, including the Query Palette
and the Info Palette

the generic query functionality that is used to query spatial data from the Oracle® database
how to structure a query through GSC settings
how to view spatial data

extras such as annotation, reporting and legend options

Introducing Munsys Query



Conventions in this manual

The following table lists the typographical conventions used in this manual.

Text element ‘ Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial\
Menu paths choose Query > Clear Basemap.
Hypertext links to more information http://www.openspatial.com
Text displayed/typed on the Munsys Query

command line

Dialog box/screen names The Create New GSC dialog box
Application functions The Query function

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

m  general issues, select Help from the Munsys menu bar.
® an operation in progress, click the Help button on the dialog box.

m  the latest support options, visit http://www.openspatial.com

Introducing Munsys Query
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Chapter 2
Getting acquainted with Munsys Query

Introducing Munsys Query

Munsys Query gives engineers direct access to the latest GIS information from within a
familiar CAD environment. The same seamless Oracle database that is used by the GIS users
can be accessed directly (read only) to create CAD drawings containing the latest spatial and
attribute information. This information can then be manipulated for design purposes using
standard AutoCAD functionality.

The same easy to use interface that is used by the standard Munsys applications is also used by
Munsys Query. This includes a customizable menu, standard GIS queries, and attribute
templates for viewing related attribute information



Launching Munsys and Munsys Query
To launch Munsys, do one of the following:

1  Double-click the Munsys Applications 15.1 icon on the Windows desktop.

Munsys
Applications
151

2 Choose Start > Program Files > Open Spatial > Munsys 15.1 > Munsys Applications 15.1

Connecting to the Oracle database

Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator
technology is that spatial and attribute data are captured and managed in a single database. This
reduces processing overheads and eliminates the complexity of coordinating and synchronizing
different sets of data.

The Munsys Applications support multiple Logons which permit users to logon to different
databases such as Training, Test or Production databases by selecting a Logon Profile from a
drop-down list. When the Connect function is selected, the logon credentials (excluding the
password) are pre-populated based on last successful database connection.

The Logon Profile details are customizable and stored in the Current User’s Registry Keys. By
default, three Logon Profiles are defined, namely Logon1, Logon2 and Logon3. The Logon
Profile descriptions can be changed from the default description to be more meaningful one by
simply clicking in the text box next to the Logon Profile and overwriting the default value.

Important You have to be connected to the Oracle database before you can start working with Munsys
Drainage. If you try to launch any application without being connected to the database, you will be
prompted to connect first.

To connect to the Oracle database

1  For first time connection do one of the following:
Choose File > Database > Connect...

Click the Connect to Database button on the Munsys standard toolbar.
The Connect to Database dialog box is displayed.

Getting acquainted with Munsys Query



Note

N & VN R W

Logan Prafile: Logon ~
Uzer M ame:
Pazswaord:
Schemna:
D atabase:
QK Cancel Help

Figure 1 The Connect to Database dialog box

In the Logon Profile box, select a profile from the drop-down list.

The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text
box and overwriting the default description with a value not exceeding 25 characters, for example:
TRAINING, TEST, STAGING or PRODUCTION.

In the User Name field, enter your user name.
In the Password field, enter your password.

In the Schema field, enter the schema name.
In the Database field, enter the database name.
Click OK.

On successful connection to the database, the last Logon Profile, User Name, Schema and
Database details are saved in your Current User’s Registry Key where they are used to pre-
populate the Connect to Database dialog-box on next logon. Your password is never saved, and
you will always be prompted to enter your Password.

Lagon Profile: Praduction -
User Mame: MCITTIEINT

Password: e

Schema: MCITT1BINT

Database: E

[n].4 Cancel Help

Figure 2 The Connect to Database dialog box with Logon Profile
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Note

The last used Logon Profile details, and the various Logon descriptions are stored in the registry key
Computer\HKEY CURRENT_USER\Software\Open Spatial\Munsys 15.1\Applications\Logons,
whilst the registry key Computer\HKEY CURRENT_USER\Software\Open Spatial\Munsys
15.1\Applications\Logons\[Logon1] saves the individual User Name, Schema and Environment Name
details per Logon Profile.

The administrator assigns you user rights to log on to the database, and will inform you what
your user name, password, schema name, and database are. A successful connection to the
database activates the appropriate functions on the menu bar and toolbars.

To launch Munsys Query
When you launch Munsys for the first time, the configured base map automatically loads.
When you launch Munsys Query, the Munsys Query functions are loaded onto the menu bar
and toolbars.
To launch Munsys Query, do one of the following:

Choose File > Munsys Applications.

Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Available Applications X

Drainage ~
Electricity

MaE Books

Roads

Sewer

Spatial Data Manager

Water "

Figure 3 The Available Applications dialog box

From the list of available applications, select Query, and then click OK.

To zoom to the database extents
Do one of the following:

Choose Query > DB Extents > Zoom to DB Extents.
Click the Zoom DB Extents button on the Munsys Main toolbar.

The database extent is indicated by a dotted line.

Getting acquainted with Munsys Query



The Munsys Query user interface

The Munsys Query user interface consists of the following:

AutoCAD Map 3D 2010 dwg Tiipe a keyword or phrase ? =]

DEE RARd SR XDBES & - »- QG &5 FUEIm0 ]

El = x
>

Window GSC with the
mask set to Crossin, { [IHE <<Unnamed G5C>>
shown as a solid ¢

Available G5Cs:

Available Queries:

- [J@ Municpaites
[ Parcels

H [[E) Parcels {archived)

> H [ac Strest Addresses

i lkac Street Names
D) TP Density Palygons
[E) TP Land Use Palygans
[CE) TP Zaning Palygens

[J%5 Drainage

1. [1=¥S Flartricity

B3

<

4= QueryPalette

*| Parcels
3
/ blowgd
L o} —
Ll TR s Attributes [ Linked Attributes | Object Info

U A B [ <Defauit Dispiay Template> ¥

J N Column Name: Column Value ~
= Main Object Attributes

] GID 56515
v A PRCL_TYPE P

¥ & LSTATUS R
!
AT M, Moded utl U2

WSTATUS c
Command: '_pan

PRCL_KEY 0006000510220, .
Press ESC or ENTER To Xit, Or right-click to display SROTLCUT MeRu.

GECM_AREA 10275.645000
COMMENTS

= InfoPalette

|~

~
~

Figure 4 The Munsys Query user interface
®  Munsys menu bar — contains the Munsys and AutoCAD menus. Munsys menus are defined
by a menu file, which automatically loads when the Munsys application is launched.

®  Standard toolbar — contains frequently used AutoCAD buttons, standard Microsoft
buttons and Munsys buttons for connecting to the database, disconnecting from the
database and unloading Munsys Query.

Use this button ‘ When you want to...

...connect to the Oracle database.
...disconnect from the Oracle database.
= ...Jaunch Munsys Query

Table 1 Munsys Query Standard toolbar buttons
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®  Munsys Query main toolbar — contains Munsys Geographic Search Criteria, query and
other functions.

Use this button ‘ When you want to...

...specify GSC settings.

F ...create a new GSC.
i3

...create a new GSC Screen Extents.

...show the active GSC.

...zoom to the GSC extents.

...zoom to the database extents.

...run a query.

...Jlaunch the Info Palette.

& & | & &l

Table 2 The Munsys Query main toolbar

= AutoCAD drawing area — this area is used to display Munsys data that is retrieved from the
database, AutoCAD drawings, as well as other external formats imported by Autodesk.

®  AutoCAD command line — displays prompts and messages.

= AutoCAD status bar — displays information and drawing aids.
In Munsys Query, functions can be executed by:

= Typing the command on the command line

= Activating the function from the menu bar

= Clicking the appropriate button on the toolbar

Getting acquainted with Munsys Query



Connecting to the Oracle database

Munsys uses Oracle as its data store. The advantage of using Oracle — particularly its spatial
technology — is that spatial and attribute data are captured and managed in a single database.
This reduces processing overheads and eliminates the complexity of coordinating and
synchronizing disparate sets of data.

When you launch Munsys Query, you first have to connect to the Oracle database in order to
access data.

The database administrator assigns you user rights to log on to the database, and will inform
you what your user name, password, schema name, and database are. A successful connection
to the database activates the appropriate functions on the menu bar and toolbars.

Tip  Youcan use the Change Password function on the File menu to change the password that you use to connect

to the database.

To connect to the Oracle database

Note

Do one of the following:
Choose File > Database > Connect...

Click the Connect to Database... button on the Munsys Standard toolbar.
The Connect to Database dialog box is displayed.

A

Logan Prafile: Logon ~

Uzer Mame:

FPazzward:

Schema:

Database:

ok Cancel Help

Figure 4 The Connect to Database dialog box

In the Logon Profile box, select a profile from the drop-down list.

The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text
box and overwriting the default description with a value not exceeding 25 characters, for example:
TRAINING, TEST, STAGING or PRODUCTION.

In the User Name field, enter your user name.In the Password box, enter your password.
In the Schema box, enter the schema name.

In the Database box, enter the database, and then click OK.

Getting acquainted with Munsys Query
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On successful connection to the database, the last Logon Profile, User Name, Schema and
Database details are saved in your Current User’s Registry Key where they are used to pre-
populate the Connect to Database dialog-box on next logon. Your password is never saved, and
you will always be prompted to enter your Password.

Logon Profile; Praduction w
User Mame: MCITY15IMT

Passwiord: s

Schema: MCITY15IMT

Database: wE

QK. Cancel Help

Figure 5 The Connect to Database dialog box

Note The last used Logon Profile details, and the various Logon descriptions are stored in the registry key
Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 15.1\Applications\Logons,
whilst the registry key Computer\HKEY CURRENT _USER\Software\Open Spatia\Munsys
15.1\Applications\Logons\[Logon1] saves the individual User Name, Schema and Environment Name
details per Logon Profile.

e administrator assigns you user rights to log on to the database, and will inform you wha
The ad trat gns y ghts to log on to the datab d will inform you what
your user name, password, schema name, and database are. A successful connection to the
database activates the appropriate functions on the menu bar and toolbars.

Getting acquainted with Munsys Query 11



To change the password used to connect to the Oracle database

1 Do one of the following:

Choose File > Database > Change Password...

On the command line, type MUNPASSWORD, and then press ENTER.

The Changing password for user [User] dialog box is displayed.

G Changing password for user DAVENDREN *

Old Paszword: | ] |

MNew Password: | |

Fetype New Password: | |

Cancel

Figure 6 The Changing password for user [User] dialog box
2 In the Old password box, type your current password.
In the New password box, type your new password.
4 In the Retype new password box, retype your new password.
Click OK to apply the new password.
To disconnect from the Oracle database
1 Do one of the following:

Choose File > Database > Disconnect...

Click the Connect to Database button on the Munsys standard toolbar.

On the command line, type MUNDISCONNECT, and then press ENTER.
The connection to the database is terminated, and you will only be able to query data once an

active connection has been restored.

Getting acquainted with Munsys Query
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Chapter 3
Querying data from the database

Introduction

In Munsys Query, data is retrieved from the database using the Munsys Query Palette and/or
the Query menu. This chapter provides information about the query options that are available
on the Query menu in the Munsys Query application.

The query options and functions on the Query Palette are discussed in detail in the Munsys
Concepts User Manual.

Other functionality that is discussed in the Munsys Concepts User Manual:
Geographical Search Criteria (GSC) options
The Munsys Info Palette

Browsing Information

11



Querying data from the database from the Query menu

A range of menu items on the Query menu are tailored for querying from a Munsys schema
that has all the predefined spatial tables as used with other Munsys applications like Munsys
Water, Munsys Sewer, etc. These menu items make it easy for users who are querying data that
is captured and maintained by these Munsys applications.

In an environment where the Oracle schema was created using the process distributed with
Munsys Query (a Munsys Query schema) these predefined tables will not exist and therefore
these menu items cannot be used.

The following section explains how to query data from the database using the
pre-defined (default) queries that are available on the Query menu. Customized (user-defined)

queries are formulated on the Query Palette, which is discussed in the Munsys Concepts User
Manual.

Specifying query preferences

The Query Preferences function is used to specify settings that will determine the format and
conditions when spatial data is retrieved from the database. These options are stored in the
registry and do not have to be set every time a new Munsys session is started. The following
options are available:

Use GSC — if this option is selected, the currently active GSC is applied as a spatial filter
when the required objects are retrieved from the database.

Create CAD Objects — if this option is selected, the objects are retrieved from thedatabase
as AutoCAD drawing objects instead of Munsys objects.

Attach Object Data — if this option is selected, attributes will be attached to the objects that
are retrieved from the database. The objects may be Munsys or AutoCAD related. The
attributes are always obtained from the primary spatial table. If the query is associated with
a data group that relates the object(s) to an attribute table, the attribute will also include the
columns from the retrieves all parcels or communities according to their status. (This
option is only available when Munsys is run on AutoCAD Map.)

To specify query preferences, do the following:

1  Click the Query Preferences button on the Query Palette toolbar. (This function is also available
on the Munsys Applications Query menu and the Munsys Main toolbar).

The Query Preferences dialog box is displayed.

Querying data from the database 12



B Query Preferences X

Use GSC
Applies the active GSC as a spatial filter

[]Create CAD Objects
Creates AutoCAD objects instead of Munsys
objects
Attach Object Data

Attaches attributes to each queried object in the
form of AutoCAD Map object data

Figure 1 The Query Preferences dialog box

Select or clear any of the following check boxes:

Use GSC —select this option if you want to apply the currently active GSC as a spatial filter
when the objects are queried from the database.

Create CAD objects — select this option to query the objects from the database as AutoCAD
drawing objects instead of Munsys objects.

Attach Object Data — this option is only available when Munsys is run on AutoCAD Map.
Select this option if you want attributes to be attached to the objects that are queried from
the database. The objects may be Munsys or AutoCAD related. The attributes are always
obtained from the primary spatial table. If the query is associated with a data group that
relates the object(s) to an attribute table, the attribute will also include the columns from
the attribute table.

Click OK to apply the settings.

The settings are saved in the registry under the HKEY_ CURRENT_USERWSoftware\\Open
Spatial\\Munsys 15.1\\ Applications\\ Options key.

Querying data from the database
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Querying communities

Communities (suburbs, townships, municipalities, etc.) are queried from the database
according to the current GSC, or by a selected community name. Suburb boundaries are
displayed as polygons (MUNPOLY objects).

To query communities by name

1 Choose Query > [Suburbs] > By Name...

The Select [Suburb] dialog box is displayed, showing a list of all the available suburbs with their
associated codes. The list can be sorted ascending or descending, according to the code or
description.

2 From the list, select the suburb that you want to query, and then click OK.

Select Municipality

Lookup Table Iformation

Table Name: [LU_CMS_MUNINAME I

Search Ofode  ® Desciption

0500 WESTENBURG

Figure 2 Querying a Municipality by Name

Tip If you want to query more than one suburb, press and hold down the SHIFT key (to select consecutive
suburbs), or press and hold down the CTRL key, and then select each suburb that you want to query.

To query communities by GSC
Choose Query > [Suburbs] > By GSC.

The suburb boundaries are retrieved according to the current GSC.

Querying data from the database 14



Querying Cable Route Objects

Using the functions on the Query menu, you can quickly retrieve cable route objects from the
database according to the current GSC, or retrieve objects per object type.

Query Extras Object  Format View Tools Draw Modify

GSC >
DB Extents > 1&[@|¢-"¢'|»§ff¢q[
Suburbs ¥
Townships ¥

T AT ] This function retrieves all the Cable Route objects from the
P ] " database according to the current GSC.
All Cadastral Objects

All Drainage Objects
All Electricity Objects
All Road Objects
All Sewer Objects
All Water Objects

Cable Route Objects % Links

Cadastral Objects > Nodes With this group of functions, you can query Cable Route
Drainage Objects Notes I objects from the database by object type.

Dimension Arrows

w

Electricity Objects
Road Objects
Sewer Objects
Water Objects

Dimension Notes
Symbols
Labels

voow v

Figure 3 Cable Route Query Menu

Cable Route objects are defined as follows:
Links — cable route runs which are placed, and in which the fiber cables will reside within.

Nodes — cable route nodes to which the fiber cables would affect to connect to, or interact
with.

Notes — user defined notes which was captured and posted to the database.

Dimension Arrows — arrows indicating the distance of the cable route segment in relation
to two cadastal boundaries.

Dimension Notes — text reflecting the distance of the dimension arrows in relation to the
cadastral boundaries.

Symbols — features which are captured for orientation purposes but does not break or
influence the network.

Labels — the cable route default material text, which is defined in the capture settings and
placed on cable routes.

The following example shows cable route objects that have been queried from the database
using the predefined queries on the Query menu:

Querying data from the database 15



Figure 4 Querying Cable Route Objects
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Querying Cable Fiber Objects

Using the functions on the Query menu, you can quickly retrieve cable route objects from the
database according to the current GSC, or retrieve objects per object type.

Query Capture Change Extras  Object Formet View Tocle Draw Mo
GSC > |+
DE Extents >

TR N
Suburbs »

[ENE

e |

Townships ¥
Parcels >
Black Boundaries o
Easements i
Street Mames

Street Addresses
Buildings 0
Cadastral Notes

Cuery Cable Fiber Objects » | Cuery Cable Reube Basernap

17

Cluery Options... Query Al Coble Fiber Dbjects With this group of functions, you can query Cable Fiber
& RunQuery.. Query Fiber Cables b objects from the database by object type.
Browse Info.. Query Fiber Paths

Clear Basemap

+ | Cuery Palette
Infa Palette

Figure 5 Cable Fiber Query Menu

Cable Fiber objects are defined as follows:

Cable Route Basemap — This function retrieves all Cable Route and Building information
from the database.

All Cable Fiber Objects — This function retrieves all Cable Fiber objects from the database
according to the current GSC.

Fiber Cables — This function retrieves all Fiber Cables from the database according to the
current GSC.

Fiber Paths— This function retrieves all Fiber Paths from the database according to the
current GSC.

The following example shows cable fiber objects that have been queried from the database using
the predefined queries on the Query menu:

Querying data from the database 17



Figure 6 Querying Cable Fiber Objects
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Querying cadastral objects

Using the functions on the Query menu, you can quickly retrieve cadastral objects from the
database according to the current GSC.

Using the functions on the Query menu, you can quickly retrieve all the cadastral objects from
the database according to the current GSC, or retrieve objects per object type.

Query
G5C 4
DB Extents 4
Municipality »

This function retrieves all the cadastral objects from the

All Cadastral Objects .
i " database according to the current GSC.

All Drainage Objects
All Electricity Objects
All Road Objects

Al sewer Objects

All Water Objects

Cadastral Objects 4 Parcels

Drainage Chjects 4

Easements
Electricity Objects 4

Street Names
Road Cbjects 4

Street Addresses . . . .
Sewer Objects - dngs With this group of functions, you can query cadastral objects
Water Cbjects ' N from the database by object type.

Cadastral Motes

Density Polygons
Land Use Polygons
Zoning Polygons

Figure 7 Cadastral Query Menu

Cadastral objects are defined as follows:

Parcels — a distinct portion of land, which is captured from a registered plan by means of
coordinates or angles of direction and distance.

Easements — a registered area attached to a parcel for the benefit of the local authority. This
area is used for the installation of services or right of way; the landowner is not allowed any
permanent construction on this area.

Street names and addresses — legal street names are assigned to sections of the road reserve
and display as text. The address information is assigned at a specific point within the parcel
polygon. In some cases, parcels can have more than one point of entry, and are therefore
assigned multiple address points.

Buildings — can be classified as different types according to the default values set up by the
system administrator. New building types can be added to the list of available building

types.

Cadastral notes — additional notes pertaining to cadastral objects.

Zoning, density and land use polygons — zoning classification defines the allowable use of
the property, such as residential, business or commercial. Density classification defines the
number of units (such as houses) that may be constructed on a parcel. Land use is based on
function or activities; the purpose for which the land is being used. A land use type can
include a series of activities that are required to produce one or more goods or services.

The following example shows cadastral objects that have been queried from the database using
the predefined queries on the Query menu:
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mask set to Crossing, and
shown as a solid outline.

Figure 8

Querying Cadastral Objects
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Querying drainage objects
Using the functions on the Query menu, you can either retrieve all the drainage objects from
the database according to the current GSC, or retrieve drainage objects per object type.

G5C
DB Extents

L

-

Suburbs

-

Townships

All Cadastral Ohiects This function retrieves all the drainage objects
All Drainage Objects from the database according to the current GSC.
All Electricity Objects

All Road Objects

All Sewer Objects

All Water Objects

v

Cadastral Objects
Drainage Objects
Electricity Objects
Road Objects
Sewer Objects
Water Objects

Stormwater Network . . .
With this group of functions, you can query

drainage objects from the database by object
type.

Rivers

Floodlines

* v v vBl -

Dams

Catchments

Figure 9 Drainage Query Menu

Drainage objects consist of the following:

Stormwater network — all the drainage objects that contribute to the stormwater network,
including stormwater pipes, culverts and channels, stormwater nodes (manholes, curb
inlets, drop inlets, etc.), service connections, stormwater symbols, labels, notes and
dimensions.

Rivers — can be either polygons (MUNPOLY objects) or lines (MUNLINE objects)

Floodlines — an estimate of the level to which water may rise on average (for example, every

20 or 50 years).
Catchments — an area from which rainfall drains into a river, reservoir or dam.

Dams — are queried as polygons

The following example shows drainage objects that have been queried from the database using
the functions on the Query menu:
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Querying electricity objects
Using the functions on the Query menu, you can either retrieve all the electricity objects from
the database according to the current GSC, or retrieve electricity objects per object type.

Electricity objects can be retrieved as follows:

G5C
DB Extents

* v

-

Suburbs

Townships

-

All Cadastral Objects
All Drainage Objects This function retrieves all the electricity objects

All Electricity Objects » from the database according to the current GSC.
All Road Objects

All Sewer Objects
All Water Objects

Cadastral Objects 4
Drainage Objects 4
EEETTELEEE d  Electrity Network With this group of functions, you can query electricity
j » —] . .
Road Objects Electricity Zones > objects from the database by object type.
Sewer Objects L4
,|  puess

Water Objects

Figure 11 Electricity Query Menu

Electricity objects consists of the following:

Electricity network objects — all the electricity objects that contribute to the electricity
network, including cables, nodes, service connections, notes and dimensions

Electricity zones — transformer supply areas

Electricity ducts — carry electricity cables under the road

The following example shows electricity objects that have been queried from the database using
the predefined queries on the Query menu:

Querying data from the database

23



Each object type is
queried onto
its own layer

Figure 12

Querying Electricity Objects
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Querying road objects

Using the functions on the Query menu, you can either retrieve all the road objects from the
database according to the current GSC, or retrieve road objects per object type.

GsC r
DB Extents L4
Suburbs L4
Townships 4

All Cadastral Objects
All Drainage Objects

All Electricity Objects This function retrieves all the road objects from

Al Road Objects the database according to the current GSC.
All Sewer Objects
All Water Objects

v

Cadastral Objects
Drainage Objects
Electricity Objects
Road Objects
Sewer Objects
Water Objects

Road Metwork
With this group of functions, you can query road

Road Areas i N
objects from the database by object type.

Road Edges
Road Walkways

*+ vBl v v -

Road Int Drawings

Figure 13 Road Query Menu

Road objects can be retrieved as follows:

Road network objects — all the road objects that contribute to the road network, including
road center lines, intersection markers and road notes

Road areas — an area that is designated for the location of constructions within the
composition of a road and for the organization of road management

Road edges — mountable, non-mountable or semi-mountable curbs
Road walkways — pedestrian pathways, which are tarred or paved

Road intersection drawings — AutoCAD drawings that are referenced to specific road
intersection markers

The following example shows road objects that have been queried from the database using the
predefined queries on the Query menu:
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Querying sewer objects

Using the functions on the Query menu, you can either retrieve all the sewer objects from the
database according to the current GSC, or retrieve sewer objects per object type.

G5C ’
DB Extents L4
Municipality L4

All Cadastral Objects

All Drainage Objects

All Electricity Objects

All Road Objects This function retrieves all the sewer objects from
All sewer Objects p the database according to the current GSC.

Al Water Objects

Cadastral Objects
Drainage Chjects
Electricity Objects
Road Chjects

Sewer Objects Map Page Grid

Water Objects

bl Y T v v

-

Sewer Network With this group of functions, you can query sewer

objects from the database by object type.
Sewer Basins

Residential Sewers

Figure 15  Sewer Query Menu

Sewer objects can be retrieved as follows:

Sewer network objects — all the sewer objects that contribute to the sewer network,
including pipes, nodes, service connections, labels, sewer symbols, notes and dimensions

Sewer map page grid — used to locate services based on the map page number, and is
represented by a layout of polygons

Sewer basins — represent different networks up to the purification works, or even smaller
sections up to the primary outfall sewers

Residential sewers — indicate the sewer pipes running from buildings to service connections

The following example shows sewer objects that have been queried from the database using the
predefined queries on the Query menu:
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Sewer Pipes (Gravity)

Figure 16 Querying all Sewer Objects
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Querying water objects

Using the functions on the Query menu, you can either retrieve all the water objects from the
database according to the current GSC, or retrieve water objects per object type.

G5C ’
DB Extents L4
Municipality L4

All Cadastral Objects

All Drainage Objects

All Electricity Objects

All Road Objects

All Sewer Objects This function retrieves all the water objects from

@ » the database according to the current GSC.

Cadastral Objects
Drainage Chjects
Electricity Objects
Road Objects
Sewer Objects
Water Objects

~ L I R

Map Page Grid

Water Network With this group of functions, you can query water
— objects from the database by object type.

Water Zones

Residential Water

Figure 17  Water Query Menu

Water objects can be retrieved as follows:

Water network objects — all the water objects that contribute to the water network,
including pipes, nodes, service connections, labels, water symbols, notes and dimensions

Water map page grid — used to locate services based on the map page number, and is
represented by a layout of polygons

Water zones — provide an overview of the water network layout.
Residential water pipes — indicate the water pipes running from buildings to service

connections

Note The queries on the Query menu shown above retrieve the water objects from all four water categories
(potable, reclaimed, raw and abandoned) from the database. If you want to query water objects by category,
you will have to specify a user-defined query in the Munsys Query Palette.
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The following example shows water objects that have been queried from the database using the
predefined queries on the Query menu:

Figure 18  Querying all Water Objects

Running multiple queries using the Query List dialog box

A selection of one or more predefined queries can be run using the Query List dialog box, which
can be called from the Query Palette toolbar, the Query menu, or the command line. The list
of queries on the dialog box shows the name of the query, the category it belongs to and its
priority, in descending order.

Tip The list can be re-sorted by clicking on the appropriate header.

The list of queries that is displayed on the dialog box is dependent on user privileges. This is
firstly restricted by the roles assigned to the user, since the query categories restrict access to the
queries in the category through roles. Secondly, access to queries is also restricted by the
privileges assigned to the user with regard to the tables referenced in the queries.

The queries that have been selected are run in order of their query priority; queries with a
priority of 0 are run first, followed by queries with a higher number. As the queries are run,
feedback about the number of objects retrieved is provided on the command line.

Tip Use the Query Preferences button on the Query List dialog box to specify query preferences before the
queries are executed.

1 To run multiple queries using the Query List dialog box, do one of the following:
Click the Run Query button on the Query Palette toolbar.
Choose Query > Run Query.
Click the Run Query button on the Munsys Main toolbar.
On the command line, enter MUNQRYRUN.
The Query List dialog box is displayed.
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Query List
Queries
Available Queries: 7% | «—1——Click this button to display the Query
Preferences dialog box.
Category Query Order ~
[][@ Drainage Floodlines 513
[1*, Drainage River Lines En
[][@ Drainage River Polygons 512
I:HE Drainage Stormwater Catchments 50
[N Drainage Stormwater Channel Labels 536
[]*, Drainage Stormwater Channels 522
|:|Ja’nc Drainage Stormwater Culvert Labels 537
[]*, Drainage Stormwater Culverts 523
%k Drainage Stormwater Dimension Notes 532
1% Drainage Stormwater Dimensions 53
[N Drainage Stormwater Labels 534
[][@ Drainage Stormwater Map Page Grid 540
[]%* Drainage Stormwater Nodes 524
[ Drainage Stormwater Motes 533
I:‘;’gc Drainage Stormwater Pipe Labels 535
[]*, Drainage Stormwater Pipes A1
[]*, Drainage Stormwater SCs 521
|:|JG:“ Drainage Stormwater Symbols 524
[I™, Electricity Electricity Cables 1021
Close Help

Figure 19 The Query List dialog box

Select the queries that you want to run from the list of available queries. Use the Query Preferences
button to specify query preferences before the list of queries is run.

Click the Run button to run the selected queries.

The queries are run according to their query preference, and the command line displays the
number of objects that were retrieved from the database for each query.
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Browsing Information

The browse selection opens a resizable modeless browsing window so that the user can view the
queried objects in the drawing while browsing the attribute information in the browsing
window. Multiple Browsing windows can be opened simultaneously to view attribute data for
different spatial objects, for example Sewer Pipes and Sewer Nodes.

Once the sources are identified, the content from the predefined sources is displayed in a table
format that includes a row entry for every record and a column to specify the type of
information available. To browse information, you will do the following:

Define the sources to browse

Browse content ﬁ'O[Il sources

Defining sources to browse

When initiating the browse command from the Query > Browse Info... menu item or from
typing the command MUNBROWSE in the command line, the user is presented with the
Browse Selection dialog box which has the following two tabs:

Queries tab - displays a list of all user and default system queries available to the user
dependent on their roles assigned.

Tables/Views tab - displays a list of table items that are available to the user dependent on
their roles assigned.

On the Queries tab the user is presented with a list of Query Categories which, when expanded,
display a list of User Queries and default System Queries. The availability of query categories
and their associated queries is dependent on the roles assigned to the user. A user with the role

MUNSYS_ALL_QUERY will have access to view all the spatial tables in the database.

If the Browse Info function is initiated from either the Query > Browse Info... menu item or by
typing the command MUNBROWSE at the command line, the Browse Info dialog box with

the Tables/Views tab is displayed. The user must select one of the following items to browse:
All Tables - lists all tables in the database.
Attribute Templates - lists all attribute templates in the database.
Lookup Tables - lists all lookup tables in the database.
Queried Objects - lists the tables for objects queried into the drawing.
Spatial Tables - lists all spatial tables in the database.
Views - lists all spatial views in the database.

Once the user selects one of the items to browse, the Browse Selection window is displayed and
a list of all available tables are populated to the content pane.

To define sources to browse

1  Choose Query > Browse Info...

The Browse Selection dialog box is displayed.
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Figure 20

Browse Selection

Queries  Tables/Views

Select query to browse:

-8 <<User Queries>>

<<Lineage Queries>>

=5 Cadastral

[+-55 Drainage

45 Electricity

=5 Roads

[+-55 Sewer

-3‘51‘ Water

-3‘51‘ Water (Abandoned)
&5 Water (Potable)

[+-555 Water (Raw)

-3‘51‘ Water (Reclaimed)

= <<Uncategorized Queries>>

Cancel

The Browse Selection Dialog box
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Browsing content from sources

Once the source/s have been identified, the result is populated to the Browse Info dialog box.
The result is displayed in table or grid format, including a row for every record and a column
to specify the type of information available. The dialog box is menu driven and is sensitive to
content selection. The result set can be refined by applying filters. The active result set is used
at all times as input to the functions available on the menus.

The following menu items are available on the Browse Info dialog box:

File — generates reports from the active result set, which allows the termination of the
browse using the Close function.

Edit — the user is allowed to copy selected rows to the clipboard, find a specific value or go
to a specific record number.

View — determines the result set by applying various filters and applying formatting of
values. The user also has the option to determine how the relationship between the primary
and linked table is to be interpreted.

Records — this menu is only applicable when the primary table is a spatial table. The user
can determine the spatial objects to query and once queried, can zoom to the spatial objects
in the drawing and/or highlight equivalent objects.

Browsing: Block Boundaries e
File Edit View Records Help
GID GEOM_AREA COMMENTS  TAG_X TAGY X

1 1 28744132 | (nully -72985.203 | -2887163.351

2 2 117151.986 | (null) -72491.952 | -2836350.418

3 3 89454.874 | (null) -70116.127|  -2888958.974

4 6 79153.969 | (null) -79520.211| -2887345.748

5 7 §25.126 | (nully -75374.124 | -2885790.348

6 8 4498187 | (null} -75385.523 | -2885675.596

7 9 1006.787 | (null} -75419.483 |  -2885635.018

3 10 1217.371 | (nully -75470.133|  -2885647578

e 11 2116.287 | (nully -75445.583 | -2885724.238

10 12 132723.776 | (nully -75301.053 | -2885400.380

11 13 5748.031 | (null} -78312.551| -2856486.063

12 17 73257.594 | (null} -73197.761| -2886236.776

13 19 3376.773 | (null} -73995.933 | -2887635.984

14 20 366871.201 | (nully -74069.177 |  -2887114.957

15 21 125467.578 | (null)y 744592489 |  -2887957.520
16 22 224821.438 | (null) -74751.188 | -2886040.088

17 23 124136.778 | (nully -74199.247 |  -2887215.085
13 24 144458.644 | (nully -74407.126 |  -2887216.684

19 25 285698.134 | (null) -74756.375 | -2887436.202

20 26 88163.958 | (null) -75079.016 | -2885770.589 v
< >
Rows: 678 Unfiltered Selected Rows: 2(

Figure 21  The Browse Info dialog box

Copying results

The Edit > Copy menu item allows users to copy a selection from the result set to the clipboard
for pasting in other applications. Column headings are copied with the selected records.
Columns and records are comma delimited text and may be pasted to any application that
accepts text.
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Finding results

The Edit > Find... menu item searches through the entire result set and highlights the matching
record. On the Find dialog box, you must enter the value(s) to search for, as well as indicate the
column in which to search. The columns available from the lookup list includes columns from
linked tables, as well as columns that were not identified as available columns when browsing
the data. The search operation can be refined by applying more search parameters including an
exact or partial match.

The search is affected by the Display Formatted Values option (available on the View menu). If
this option is active the search will ignore the raw values and search for formatted values. The
value in search is case sensitive at all times.

Finding a row number

The Edit > Goto Row Number menu item allows the user to search for a specific row number
within the result set. If the required row number is found, it is displayed and selected. Should
the required row number not be found, the user will be presented with the Browse Goto Error
message box, indicating that the required row number is not found in the current result set.

Filtering by attributes

With the Filtering by attributes function, you can filter the current result set by applying an
attribute filter that is constructed by attribute conditions. Once the attribute conditions are
applied on the current result set, it is refreshed with the new values. The Attribute Condition
dialog box is used to construct the filter that will be used to apply to the initial result set. For
users who are not familiar with SQL statements, Munsys provides drop-down lists in the order
required to easily construct the applicable filter. The Attribute Condition is used to construct
complex filters that contain more than one attribute condition.

Choose View > Filter by Attributes...

The Attribute Condition dialog box is displayed.

Attribute Conditions X
Conditions
Add... Edit. .. Remaove

Figure 22 The Attribute Condition dialog box

Click the Add button to open the Add Condition dialog box.

Querying data from the database

35



3  To define a condition statement, use the drop-down lists from the condition statement group:
From the Column drop-down list, select the appropriate column to determine the criteria.

From the Operator dropdown list, select the operator that best suits the condition that you want
to check. Operators include <=, =, >=, etc. Use these operators to produce the desired spatial
result.

In the Value option, enter the criteria that will be tested against the value of the column and that
qualifies the condition operator.

Or start tying an SQL statement in the SQL Equivalent box to define your own SQL statement
Click the OK button to add the condition to the Condition dialog box group.

4  Click the Add button to add another condition or the OK button to apply the attribute filter.

Note If you do not know the exact value for the SQL condition, you can select the Values... button to display a
list of all unique values in the database for the column selected. The Unique Values dialog box list is limited
to display the first 50 unique records, but the user can tick the Show All check box to display all values.

Filtering by GSC

The View > Filter by GSC menu item filters spatial data according to the current GSC. The
current GSC is zoomed to the extents of the drawing area while the Browse Info dialog box is
still active. This spatial filter is also applied on the current result set that is displayed in the
Browsing Info dialog box.

This function does not replace any previous defined attribute or spatial filters that are active by
complement these.

Filtering by spatial objects

This function applies a spatial filter to the current result set by selecting Munsys objects in the
current drawing. This option is only available when the primary table selected in the Browse
Content dialog box is a spatial table. When activating the option, the user will be requested to
select the appropriate spatial objects that are used as the filter. Once the user selected these
objects, the Browsing Info dialog box is updated accordingly.

This filter criteria will replace all previously defined spatial filters, but complements attribute

and GSC filters.
1  Choose View > Filter by Spatial Objects.
2 Select the appropriate spatial objects, and then press ENTER.
The Browsing Info dialog box is updated accordingly.
3  To reset the Browsing /nfo dialog box, use the Clear All Filters option on the View menu.
Filtering by selected objects
This function allows users to apply an object filter to the current result set by selecting rows in

the Browse Info result set. The user must select rows in the result set and then check the Filter
Selected Objects Only menu option.

1  Select the required rows in the Browse Info result set.

2 Choose View > Filter Selected Objects Only

Querying data from the database 36



the result set is refreshed with only the selected rows.

Clearing all filters

The View > Clear Filters menu item is used to clear all of the previously defined filters, and is
therefore only available when at least one filter has been specified. Once the function is
activated, the result set is refreshed with no filters applied.

Sorting results

The column headers in the result set in the Browsing Info dialog box can be used to sort the
result set. Once a column header is selected, it sorts the values in ascending or descending order.
The column that has been used to sort on displays a small arrow indicating up for ascending,
and down for descending.

Predefined filters remain intact upon activation of this option.

This function sorts the raw data and does not consider any formatted values.

Displaying formatted values

The View > Display Formatted Values menu option is used to display more descriptive
information in the result set, for example, rather display the land use description instead of a
code. Column headings are also affected by this setting, headings are displayed with appropriate
descriptions. If descriptions are not available the column name is prefixed with the table name.

The formatted values affect the data display in the result set, generating of reports, copying of
selected records and the find function.

Setting an object query

This function is used to select a spatial query that will be used when querying spatial objects
from the database. The available spatial queries are determined by the spatial table, identified
on the Browse Content dialog box. The selected spatial query will be used to query the spatial
objects associated with the result set.

Choose Record > Set Object Query...
The Available Queries dialog box is displayed.

Available Queries X

Queries

& <<Lineage Queries>>
=-5 Cadastral
..[0) Block Boundaries
-3 Drainage
-3 Electricity
-5 Roads
-5 Sewer
-5 Water
-85 Water (Abandoned)
35 Water (Potable)
-35 Water (Raw)
-85 Water (Reclaimed)
| <<Uncategorized Queries>>

Cancel Help

Figure 23 The Available Queries dialog box
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2 Select the appropriate system query from the list, and then click OK.

The required system query is set.

Note  The display property settings of the query is used.

Querying objects

The Query Objects function is used to query the associated spatial objects of the selected
records in the result set from the database. The associated Munsys objects are created in the
current drawing. The system query that was identified during the Browse Selection process is
used to determine the formatting parameters when querying spatial objects from the database.

1 On the Browsing /nfo dialog box, select the appropriate record/s from the result set.
2 Choose Records > Query Objects.
The associated spatial record/s is queried into the current drawing onto the appropriate spatial layer.

3  To view the queried spatial objects, see Zooming to objects.

Zooming to objects

This function is used to locate a single or more queried spatial objects. Once the user has
selected the appropriate record in the result set, the Zoom to objects function allows users to
zoom the associate spatial objects in the drawing. The aggregated extents of those objects
encountered, is used to change the zoom state of the drawing,.

1 On the Browsing /nfo dialog box, select the appropriate record/s from the result set.

2 Choose Records > Zoom to Objects.
When a record is selected, the associated spatial objects are zoomed to the extent of the screen.
Highlighting objects
This function is used to select records in the result set, and then highlights the associated spatial
objects in the drawing. This function is only available when the primary table is a spatial table.

You have to select at least one record in the result set for the function to be active. The zoom
state of the drawing remains unchanged during this operation.

1  On the Browsing /nfo dialog box, select the appropriate record/s from the result set.
2 Choose Records > Highlight Objects.
The associated spatial objects are highlighted in the drawing,.

3  To zoom to the highlighted records, refer to Zooming to objects.

Highlighting records

This function is used to select spatial objects in the drawing and then highlights the associated
records in the result set. This function is only available when the primary table is a spatial table.
The user is required to select at least one spatial object in the drawing. The user will only be
ably to select the spatial objects in the drawing associated with the primary table identified.

1 On the Browsing /nfo dialog box, select the appropriate record/s from the result set.

2 Choose Records > Highlight Records.
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The associated records in the result set are highlighted.

3  To clear the highlighted records, simply uncheck the Highlighted Records menu item.
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