.
Open Spatial

Munsys 15.1

DRAINAGE USER MANUAL

i
Copyright © 2025. Open Spatial Pty Ltd. All rights reserved. Open Spatla.l






Munsys® Drainage User Manual
Munsys 15.1 © Copyright 2025 Open Spatial Pty Ltd. All rights reserved.

Open Spatial® makes no warranty, either expressed or implied, including but not limited to any implied
warranties of merchantability or fitness for a particular purpose, regarding these materials and makes such
materials available solely on an “as-is” basis.

In no event shall Open Spatial® be liable to anyone for special, collateral, incidental, or consequential damages
in connection with or arising out of purchase or use of these materials. The sole and exclusive liability to Open
Spatial®, regardless of the form of action, shall not exceed the purchase price of the materials described herein.

Open Spatial® reserves the right to revise and improve its products as it sees fit. This publication describes the
state of this product at the time of its publication, and may not reflect the product at all times in the future.

No part of this book may be reproduced or copied by any graphic, electronic, or mechanical means without prior
written permission of Open Spatial Corporation.

Third Party Trademarks
AutoCAD®, AutoCAD® Map 3D, AutoCAD® Civil 3D® and Autodesk MapGuide® are either registered

trademarks or trademarks of Autodesk, Inc., in the USA and/or other countries.
Oracle® is a registered trademark of Oracle Corporation.

Microsoft®, Windows® and Microsoft® Notepad are registered trademarks of Microsoft Corporation in the
USA and/or other countries.

ARC/INFO, ArcCad, and ArcView are registered trademarks of ESRI Corporation.
MIE/MID is a trademark of Pitney Bowes Incorporated.

All other brand names, product names or trademarks belong to their respective holders.

Visit Open Spatial on the internet: http://www.openspatial.com






Contents

Chapter |  Introducing the Munsys Drainage User Manual

Welcome to MUNSYS DIAINAZE .....ccuvevvierrierieeiieiitiesiieieereeteeeeessestaesssesssesssesseesseessesssesssnes 1
ADOUL thiS MANUAL.......ueiiieiiieitieii ettt et ettt ae st ste et e aesraesrbesaeesssessaessaessessnessees 2
What’s in this ManUal ...........ccuieiiiiiiie ettt er e seareeeae e srb e aaeenes 2
Additional reading Material ...........ccoeiiiiiiiiii e e e 2
Conventions in this MAaNUAL..........cccuevieiiiiiiiriieieie ettt steeeteebeseeeeeas 3
Finding the information YOu NEEd...........cceevuiriiirrerieeiee ettt ee et st esneeeeeseee e 3

Chapter 2 Getting acquainted with Munsys Drainage

Welcome to MUNSYS DIAINAZE .....cceevvieriierieeireiiiiiesiieieeieeeeeseeesaeseaessseseeseesseessaesseenseensens 4
Launching Munsys and Munsys Drainage..........cccecueeveereerieeriesiiesesnesneseesssesseesssesseessesnns 5

Connecting to the Oracle database..........ccccvivviiieiiieiiiiirie et et seve b eressnens 5
The Munsys Drainage iNterface .........cccuiieveerciieceie et ceie et et ste e svaesvae e e eseeaeeeeas 8
About drainage ODJECLS ......covuiireeeiieiiieieeieet ettt ettt sttt se e en e eaeas 12

Chapter 3 Querying drainage data from the database

INEFOAUCTION vttt ettt ettt st sb et et e et e e e seeenteenee 14
Querying all drainage ODJECTS ......eecuieriirriierieeie ettt eette st e e et e sttt enteeaeeeeeeeeseeenee e 15
Querying stormwater NEtWOTK ODJECES ......eccviviiirieeie ettt sttt ere e eeeeeees 17
Querying additional drainage ODJECES .......ccveireriieriieiieieeieeeereeete e srreeeeeesseesraesreesseans 19
Querying a map PAZE GII0.....cccviviiriiriieerieieeie ettt eeieerese e st e estesraestbesteeseassaessaesaesreeans 23

Chapter 4  Creating drainage data

Capturing drainage data ..........cccveeveeieireirienriecieie et steetrestrete et assaesraestesseeesteessaenses 24
Capturing a StOrMWater NEIWOTK........cccvieeeieiiiieiieecieestie et ebe e e e esreeereesereeeebeeenes 25
Drainage Capture SEHINES .....cevueeveeieertirtierieetie et ettt testte st et et e st e e seeenbeembe et e s eeeseesaeeens 26
Capturing stormwater pipes, culverts and channels...........coccoceeeiiiiinnininininceee, 28
Drawing offset stormwater pipes, culverts and channels.............ccccoceieiiiiinnnincineeene 28
Drawing freehand stormwater pipes, culverts and channels............c.ccccoeevevevinienieieennns 31
ShoWINg flOW QITECHION ... .ccuviiiiiiiiiectie ettt ettt et te st e e s aesraeeteesteebaesbaesbaesseesnas 33
Capturing StOIMWALET NOUES .......eeeuiieiiieiiieiiieeeteeeteeseeestaeestaeessveesseessseessseasssesnsseessseessees 35
Placing endpoint NOAES ........ccueeiiriiirieeiie ettt sttt ettt ettt es e eebe e eeas 35
INSErting NEAreSt NOAES........eevvieireireiietierie e eiee et eteestee et et e eessaessaenseanseenseeseessesnseans 36
Capturing stormwater SErvice CONNECTIONS .......cvveeueereeirreerrieseeteesieesseesseeseeseessessseessessenes 37
Placing Single SErvice CONNECLIONS.........eevveeveerirreireeseeerreeeeseeessressaesssesseesseassensseessessneans 37
Placing double Service CONNECHIONS .......ccveruiieiireriieesiieeetiereeseieesereeesseessseeessaessseeesseeenns 38
Placing freehand SErvice CONMECLIONS ........ccueeuiiitiiriiriie ettt sttt et see e ens 40

Capturing rivers, floodlines and dams ..........cceecuireiriinie e 41



DIAWINE TIVETS..1eeuveeitieetieeireetieeesttesstaeesteeereesteeessseassseassssassssesssaesssesessesasseassssnsseessseenes 41

Drawing floOdINes........coouuiiuieiieiiiese ettt sttt s ens 43
DIaWINE AAIMS ...ttt ettt et et sttt sttt sb et et et ebeebae e 44
Capturing stormwater CAtCRIMENTS .........ccevvvervieiieiietirie et eeteeteereeeeeseeseseens 45
Placing StOrMWater SYMDOIS ........cecviiriieriierieceieeiiiteeteetiesereseetestesseesrsesseesseasseessaessessseans 47
Placing drainage 1aDELS .......c.oovuiiiiiiiieie ettt err e rr s 49
Placing draina@e NOLES ........cccviieiieiiieciieeiiecetie et eeeieeetteeet e taesseeestteaestesessaeasaesnsaenseeees 50
Placing diMeNSION AITOWS ......c.ueeutirteriieetiesieeieettesteesteetteeate et ee st eestestbessteseesneesseessaesaeanseans 51
Capturing pipe, channel, culvert and node levels ..........ccooceevieriiiriienienieeece e 52
To attach NOAE IEVEIS. ..c.ueiieiiiiie it et e e 55
Checking drainage INTEZIILY ......ccueeeuieriiirrierieeieererrertesreestaesteeseeesseesseessaessessneassesssesssessseses 56
Checking drainage 0bject INEEEIILY .....eeecuieereiiiieeiiectie et eeeeestieesraeesaeeireesreaessbeeeeseaenns 58
Checking drainage network INtEGIItY .......ocerueeierieiiiirie sttt et e 59
Browsing integrity Markers..........ccoeeieriertiie ettt e et see e ens 60
Erasing integrity Markers .......ccoceevieiieeiiieeiieiieie ettt st st sraen e aeeeees 62
Posting drainage data to the database ..........cceccvvvveeriieiecie et 62
Validating object integrity and posting data at the same time ...........cccevvverrvecreecneernennnen. 64
Drainage network qUality TePOItING ........ceccveiriieeciieeieieieeestierteeeeeereeesteeessaeesseeesreesseeenes 65
Generating drainage data Statlis TEPOTLS .......eeueeeuiiieiriirie ettt et 67
Converting AutoCAD entities to drainage ObJECtS .......cc.eeervrriereeeeienireneeieie e 68
Exporting drainage objects to LandXML ..........cccocirriirieiieeiiiniiniesiiesivee e s ees 71
Importing drainage objects from LandXML .........c.cccveiiiiiiiviiniieie e 77
Exporting drainage objects t0 CZML ........cccoooviiieeiieciee et sve e 78

Chapter 5 Maintaining drainage data

Modifying drainage data ..........ccceecieeiiiriiirie et sre ettt esreen e s e e sere e 84
Changing draiNage ODJECES .......ucvieeuieriiirierieeieereseestesreesraesreesteesseesseesseessessnesssesssenssessseses 85
MOVING @ NOAC ...ttt stie e ettt ee ettt e etbe e et ae st aeseseessaeaesreeessseassaeensseesssaessseesssennn 90
ROtAtING @ NOAE ...ttt et ettt st e e e e e se e seeenteens 91
Snapping a node to the endpoint of a drainage objJect .........cccevevrriieiireniinicnicecieieene 91
Snapping a node to the endpoint of a drainage object, breaking the drainage object....... 91
Changing @ NOAE tYPC.....cuieueiriieriierieeie ettt eeraestaese et e tessaessaestessteessesssesssesssesssessesnnns 92
Changing drainage attribute data..........cc.eevveeieciiiieiiiicie et eae v e seve e 93
Editing drainage object attriDULES .........ccccveeiuiieiiieciie ettt eer e seve e eeae e 93
Editing linked table attribUtes ..........ccovriirrieiie ittt ettt e 96
Changing pipe, culvert, channel and node 1evels..........cocuevieciiiinninniee e 97
UPAALINg LEVEIS ..eouvieiiieie ettt sttt ettt et et et e st sebesnb et esaessaessaeseeennas 101
Changing stormwater PIpe attriDULES ......cceccvereuiirrieriieiecieeteiteetesaeeereeeeseeeraesraeseeenens 106
Changing culVert attriDULES ........ccuiiiiieieiieeiie ettt e e ee e srae st aeeaeennnaeseeee e 109
Changing channel attributes...........coceiiriiiieiie ettt 113
Changing rivVer attTiDULES.......cc.eoueeierentire ettt sttt e seeeens 117
Changing floodling attribULES.........cccveriiriieriieneiee ettt sebe e e e e eeees 118
Changing dam attriDULES .........cceeveeciiriirieriiestiee ettt sreeteete et e s assaesesesseesssasaessees 119
Changing a Service CONNECHION LYPEC....uiruiiriirieieereeeirreieessaesereeresesesseessaessesssesseessens 120
Linking service connections to parcels / buildings ...........ccccueeevieeeiieiiiieniicniie e 121
Changing draiNage NOTES ........ccueruerterieriertie sttt et ettt ee e eateebe st e et eeteeseteeaeeseesneeseees 121
AdAING COMIMEINLS ....c.veruiieeiieiie ittt ettt st sttt sttt et sbe e se et ebeenees 121

Deleting and undeleting drainage 0bJECtS ......ceecivriieriieiieeireiieeceie e s see s 122



Chapter 1

Introducing the Munsys Drainage User Manual

Welcome to Munsys Drainage

Munsys Drainage is used to capture and maintain stormwater networks and drainage objects
such as rivers, floodlines and dams. It is a user-friendly, easy to use geographic information
management tool, which does not require GIS expertise to capture and manipulate data.

Munsys Drainage forms part of the Munsys product range, which comprises the following
applications:

Munsys Cable Route

Munsys Cable Fiber

Munsys Cadastral

Munsys Drainage

Munsys Electricity

Munsys Roads

Munsys Sewer

Munsys Water

Munsys Map Books

Munsys Spatial Data Manager
Munsys Management Console
Munsys Query

Munsys Lineage

Munsys Scheduled Tasks



About this manual

The Munsys Drainage User Manual enables users to easily find their way around Munsys
Drainage, and provides a conceptual overview of the functionality used in Munsys Drainage.
For the purpose of this manual, we assume that you are familiar with:

The business rules of the application
AutoCAD Map
Common GIS terminology
What’s in this manual
The Munsys Drainage User Manual consists of the following chapters:

Chapter 1 — Introducing the Munsys Drainage User Manual, gives an overview of this
manual, and provides links to additional reading material.

Chapter 2 — Getting acquainted with Munsys Drainage, gives an overview of Munsys
Drainage and its various components.

Chapter 3 — Querying drainage data from the database, describes how to query drainage
data from the database.

Chapter 4 — Creating drainage data, shows the user how to capture a stormwater network,
add additional drainage objects, and post drainage data to the database.

Chapter 5 — Maintaining drainage data, describes how to maintain existing drainage data.

Additional reading material

Before you start using this manual, we suggest that you first read the
Munsys Concepts User Manual, which contains the following information:

the generic functionality of the various Munsys applications, including the Query Palette
and the Info Palette

the generic query functionality that is used to query spatial data from the Oracle® database
how to structure a query through GSC settings

how to view spatial data

how to work with Munsys Objects

extras such as annotation, reporting and legend options

Introducing the Munsys Drainage User Manual



Conventions in this manual

The following table lists the typographical conventions used in this manual.

Text element ‘ Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial
Menu paths choose Query > Clear Basemap.
Hypertext links to more information http://www.openspatial.com
Text displayed/typed on the Munsys Drainage

command line

Dialog box/screen names The Drainage Settings dialog box
Application functions The Integrity Check function

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

m  general issues, select Help from the Munsys menu bar.
® an operation in progress, click the Help button on the dialog box.

m  the latest support options, visit http://www.openspatial.com

Introducing the Munsys Drainage User Manual
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Chapter 2
Getting acquainted with Munsys Drainage

Welcome to Munsys Drainage

Munsys Drainage is designed for the capture and maintenance of stormwater networks and
additional drainage objects. Munsys Drainage caters for stormwater objects such as pipes,
channels, and culverts, and for stormwater nodes such as curb inlets, grid inlets, and manholes.
Additional drainage objects that can be captured along with the stormwater network include
rivers, floodlines, dams and catchment areas.

Objects are typically placed along cadastral boundaries and network connectivity is generated
after the objects have been captured. The Drainage toolbars and menus enable fast and
efficient data capture and modification. Munsys Drainage also checks the integrity of spatial
and attribute data before the data is posted to the database.



Launching Munsys and Munsys Drainage
To launch Munsys, do one of the following:

Double-click the Munsys Applications 15.1 icon on the Windows desktop.

Munsys
Applications
151

Choose Start > Program Files > Open Spatial > Munsys 15.1 > Munsys Applications 15.1

Connecting to the Oracle database

Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator
technology is that spatial and attribute data are captured and managed in a single database. This
reduces processing overheads and eliminates the complexity of coordinating and synchronizing
different sets of data.

The Munsys Applications support multiple Logons which permit users to logon to different
databases such as Training, Test or Production databases by selecting a Logon Profile from a
drop-down list. When the Connect function is selected, the logon credentials (excluding the
password) are pre-populated based on last successful database connection.

The Logon Profile details are customizable and stored in the Current User’s Registry Keys. By
default, three Logon Profiles are defined, namely Logon1, Logon2 and Logon3. The Logon
Profile descriptions can be changed from the default description to be more meaningful one by
simply clicking in the text box next to the Logon Profile and overwriting the default value.

Important You have to be connected to the Oracle database before you can start working with Munsys
Cadastral. If you try to launch any application without being connected to the database, you will be prompted
to connect to the database first.

To connect to the Oracle database

1  For first time connection do one of the following:
Choose File > Database > Connect...

Click the Connect to Database button on the Munsys standard toolbar.
The Connect to Database dialog box is displayed.

Getting acquainted with Munsys Drainage



Note

Note

N & N W

Logan Prafile: Logon ~
Uzer M ame:
Pazswaord:
Schemna:
D atabase:
QK Cancel Help

Figure 1 The Connect to Database dialog box

In the Logon Profile box, select a profile from the drop-down list.

The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text
box and overwriting the default description with a value not exceeding 25 characters, for example:
TRAINING, TEST, STAGING or PRODUCTION.

In the User Name field, enter your user name.
In the Password field, enter your password.

In the Schema field, enter the schema name.
In the Database field, enter the database name.
Click OK.

On successful connection to the database, the last Logon Profile, User Name, Schema and
Database details are saved in your Current User’s Registry Key where they are used to pre-
populate the Connect to Database dialog-box on next logon. Your password is never saved, and
you will always be prompted to enter your Password.

Lagon Profile: Praduction -
User Mame: MCITTIEINT

Password: e

Schema: MCITT1BINT

Database: E

[n].4 Cancel Help

Figure 2 The Connect to Database dialog box with Logon Profile

The last used Logon Profile details, and the various Logon descriptions are stored in the registry key
Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 15.1\Applications\Logons,

Getting acquainted with Munsys Drainage



whilst the registry key Computer\HKEY CURRENT_USER\Software\Open Spatial\Munsys
15.1\Applications\Logons\[Logon1] saves the individual User Name, Schema and Environment Name
details per Logon Profile.

The administrator assigns you user rights to log on to the database, and will inform you what
your user name, password, schema name, and database are. A successful connection to the
database activates the appropriate functions on the menu bar and toolbars.

To launch Munsys Drainage
When you launch Munsys for the first time, the configured base map automatically loads.
When you launch Munsys Drainage, the Munsys Drainage functions menu bar and toolbars are

loaded.

1  To launch Munsys Drainage, do one of the following:
Choose File > Munsys Applications.

Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Available Applications X

Cable Fiber ~
Cable Route

Cadastral

Electricity

Map Books

Query

Roads W

Figure 3 The Available Applications dialog box

2 From the list of available applications, select Drainage, and then click OK.

The Munsys Drainage functions are loaded.
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The Munsys Drainage interface

The Munsys Drainage interface consists of the following:
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Figure 4 The Munsys Drainage interface

Munsys menu bar — contains the Munsys and AutoCAD Map menus. Munsys menus are
defined by a menu file, which automatically loads when the Munsys application is launched.

Standard toolbar — contains frequently used AutoCAD Map buttons, standard Microsoft®
buttons and Munsys buttons for connecting to the database and launching the various Munsys

applications.

AutoCAD Map drawing area — this area is used to display Munsys data that is extracted from

the database and AutoCAD Map drawings.

AutoCAD Map command line — displays prompts and messages.
AutoCAD Map status bar — displays information/drawing aids.

Munsys main toolbar — contains frequently used Munsys functions.Munsys Integrity toolbar —
contains the Integrity Check and Post to Database functions.

Use this button ‘ When you want to...

...check drainage object integrity

...check drainage network integrity

...browse integrity markers

Getting acquainted with Munsys Drainage



Use this button ‘ When you want to...

...erase integrity markers

...post drainage data to the database

Table 5 The Munsys Drainage Integrity Toolbar

Munsys Drainage toolbars — Munsys Drainage has six application-specific toolbars that display
when activated. To display the Drainage toolbars, right-click in the grey area on the right-hand
side of the Munsys Standard toolbar.

AutoCAD
MUNCFS
MUNCMS
MUNCRS
MUNDMS
MUNEMS
MUNRMS
MUNSDM
MUNSMS
MUNWMS

Lock Location
Customize...

>

Capture

Change

Flow

Insert Node
v Integrity

Place Node

Place SC

Point to MUNDMS, and then select the toolbars that you want displayed one by one. The

toolbars are displayed in the drawing area.

®  The Munsys Drainage Capture toolbar contains the following buttons:

Use this button ’ When you want to...

...specify drainage capture settings.

...draw an offset pipe.

...draw an offset culvert.

...draw an offset channel.

...draw a freehand pipe.

...draw a freehand culvert.

...draw a freehand channel.

mO0NNNNNR

...place a drainage note.
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Use this button ‘ When you want to...

...place dimension arrows.

Table 6 The Munsys Drainage Capture toolbar

®  The Munsys Drainage Change toolbar contains the following buttons:

Use this button ’ When you want to...

...extend a drainage object to a boundary.

...extend a drainage object by distance.

...extend and break a drainage object.

...break a drainage object.

...change a drainage object.

...fillet a drainage object.

...trim a drainage object.

...move a node.

0 M EEEE N A

...change a drainage note.

=]

Table 7 The Munsys Drainage Change toolbar

®  The Munsys Drainage Flow toolbar contains the following buttons:

Use this button ‘ When you want to...

...show flow direction.

...change flow direction.
...clear direction arrows.

Table § The Munsys Drainage Flow toolbar

Getting acquainted with Munsys Drainage
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®  The Munsys Drainage Place Node toolbar contains the following buttons:

Use this button ’ When you want to...

...place an endpoint curb inlet.

...place an endpoint drop inlet.

...place an endpoint manhole.

...place an endpoint junction.

H | EEE

...place an endpoint wingwall.

Table 9 The Munsys Drainage Place Node toolbar

®  The Munsys Drainage Insert Node toolbar contains the following buttons:

Use this button ’ When you want to...

...insert a nearest curb inlet.
...Insert a nearest drop inlet.
...Insert a nearest manhole.

Table 10 The Munsys Drainage Insert Node toolbar

The Munsys Drainage Label toolbar contains the following buttons:

Use this button ’ When you want to...

...place a pipe label.
...place a culvert label.
...place a channel label.

Table 11 ~ The Munsys Drainage Label toolbar

Getting acquainted with Munsys Drainage
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About drainage objects

The connection of stormwater pipes and nodes are used to build converging stormwater
networks. Stormwater pipes, culverts and channels can be constructed at a specified offset
distance from cadastral boundaries, by coordinate, or freechand. Stormwater pipe diameter
increases as stormwater networks develop, for example, to reservoirs, rivers or dams. Catchment
areas are bounded by a watercourse, draining into a river or dam.

Stormwater networks contain different types of objects:
Stormwater pipes — pipes that run in the road reserves.

Culverts — usually covered channels that carry stormwater below ground level to catchment
areas.

Channels — open waterways that carry stormwater to catchment areas.
Curb inlets — an inlet on the side of the road, which gathers flowing rainwater.
Drop inlets — an inlet that is level with the road surface, also known as a grid inlet.

Manholes — found at every bend point in stormwater pipes and used for access to pipes or
culverts.

Junctions — bend points in the network.

Wingwalls — an extension of a channel or pipe constructed to stop soil erosion around the
inlet or outlet.

With Munsys Drainage, you can also capture the following drainage objects:

Floodlines — an estimate of the level to which water may rise on average (for example, every

20 or 50 years).

Catchments — an area from which rainfall drains into a river, reservoir or dam.
Rivers — captured as lines or polygons.

Dams — captured as polygons.

Drainage notes — supply additional information about plans and drawings.

Dimensions — supply additional information in terms of the location of a drainage object,
relative to the cadastral boundary.

Labels — contain dynamic text information that represent a specified column in the
database.

Getting acquainted with Munsys Drainage
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Figure 12 Drainage objects
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Chapter 3
Querying drainage data from the database

Introduction

This chapter describes how to query drainage data from the database. Stormwater pipes,
culverts, channels, service connections, nodes, notes, labels and dimensions are the stormwater
objects that contribute to a stormwater network. Additional drainage objects include
catchments, rivers, floodlines and dams. In this chapter, you will learn how to retrieve drainage
data from the database with the Query menu. You can also use the Munsys Query Palette to
assist in retrieving drainage objects from the database. The Query Palette is also used to create
custom (user-defined) queries. You can also query a map page grid, which can be used to locate
services based on the map page number, and is represented by a layout of polygons.

For more information about the Munsys Query Palette, refer to the Munsys Concepts User
Manual.
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Querying all drainage objects
This query retrieves all the drainage objects according to the current GSC from all the drainage
tables in the database. The queried objects are formatted according to their system query
settings, and each object is retrieved onto its respective layer, for example stormwater pipes are
retrieved onto the SWPIPE layer. The Query All Drainage Objects function retrieves the
following drainage objects:

Drainage object ‘ Layer ‘ Munsys object type
Stormwater pipe SWPIPE MunlLine
Culvert SWCULVERT MunLine
Channel SWCHANNEL MunlLine
Node SWNODE MunLine
Service Connections SWSERV MunlLine
Symbols SWSYM MunlLine
Pipe label SWLABEL_PIPE MunLabel
Culvert label SWLABEL_CULVERT MunLabel
Channel label SWLABEL_CHANNEL MunLabel
Dimension note SWNOTE_NOTE_TYPE_DIM MunLabel
Dimension arrow SWDIM MunPoint
Stormwater catchment SWCATCH MunPolygon
River — line RIVERLINE MunLine
River — polygon RIVERPOLY MunPolygon
Floodline FLOODLINE MunPolygon
Dam DAM MunPolygon
Drainage note SWNOTE MunLabel

To query all the drainage objects from the database, do the following:

Choose Query > All Drainage Objects.

The command line indicates how many pipes, channels, culverts, rivers, floodlines, dams,
catchments, nodes, service connections, symbols, labels, notes, and dimensions
respectively have been retrieved from the database.

Querying drainage data from the database 15






Querying stormwater network objects

This group of queries retrieves all of the stormwater objects related to the stormwater network
according to the current GSC, and onto their respective layers. Stormwater network objects that
can be retrieved are stormwater:

pipes - retrieves all stormwater pipes that form part of the stormwater network onto the
SWPIPE layer. Stormwater pipes are MunLine objects.

culverts - retrieves all the culverts that form part of the stormwater network onto the

SWCULVERT layer. Culverts are MunLine objects.

channels - retrieves all the channels that form part of the stormwater network onto the
SWCHANNEL layer. Channels are MunLine objects.

nodes - retrieves all the stormwater nodes that form part of the stormwater network onto
the SWNODE layer. The nodes are formatted according to their system query settings,
which are determined by the database administrator.

notes - retrieves all the drainage notes onto the SWNOTE layer.
symbols - this retrieves all the stormwater symbols on the SWSYM layer.
service connections - retrieves all the service connection objects.

dimensions (notes and arrows) - retrieves all the drainage dimension arrows and dimension
notes. Drainage dimension arrows and dimension notes are used to supply additional
information on plans and drawings.

labels - this retrieves all the drainage labels onto the SWLABEL layer.

To query stormwater network objects, do the following:

1 Choose Query > Stormwater Network

The command line displays the number of objects that were retrieved.
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Figure 2

Querying the stormwater network

Querying drainage data from the database
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Querying additional drainage objects

With this query, you can retrieve any of the following drainage objects from the database,
according to the current GSC:

rivers
floodlines
dams
catchments

To query additional drainage objects, do one of the following:

1  Choose Query > Drainage Objects > Rivers.

Rivers (MunLine) are queried onto
the RIVERLINE layer

[River Line (Unlocksd)

Figure 3 Querying rivers

The command line indicates how many rivers have been retrieved from the database.
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Choose Query > Drainage Objects > Floodlines.

Floodlines are queried onto the
FLOODLINE layer

Figure 4 Querying floodlines

The command line indicates how many floodlines have been retrieved from the database.

Querying drainage data from the database
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Choose Query > Drainage Objects > Dams.

Dams are queried onto
the DAM layer

[Dam (Unlacked)

Figure 5 Querying dams

The command line indicates how many dams have been retrieved from the database.
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Choose Query > Drainage Objects > Catchments.
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Figure 6 Querying catchments

The command line indicates how many catchments have been retrieved from the database.

Querying drainage data from the database
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Querying a map page grid

This query retrieves a map page grid from the database. The map page grid can be used to locate
services based on the map page number, and is represented by a layout of polygons similar to

the sheet layout used in Munsys Map Books. The map page grid can be modified by using the
Object > Generate MunPolygons and Object > Edit MunPolygon menu items to capture and

change the map page grid objects. The drainage map page grid is retrieved onto the

SWMAPPAGE layer.

To query a map page grid
Choose Query > Map Page Grid.

The map page grid is retrieved to the extents of the database.
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Figure 7 Querying a map page grid
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Chapter 4
Creating drainage data

Capturing drainage data

This chapter describes how to capture a stormwater network and additional drainage objects,
and how to post the captured data to the database.

A stormwater network gradually converges into watercourses, using natural slopes to allow the
flow of water. The smallest diameter stormwater pipe is at the start of the stormwater network.
As the stormwater pipes start converging, the pipe diameter becomes larger to accommodate
the increase of water flow.

Stormwater pipes, culverts and channels rely on gravity or natural slope to allow the flow of
water.
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Capturing a stormwater network

Before you start capturing a stormwater network, you have to query the related cadastral data
from the database to make certain that existing stcormwater objects locate geographically correct.
Existing stormwater objects need to be retrieved to determine the relationship between existing
and new stormwater objects, to ensure that data is not duplicated.

The capture process is started by first placing all the stormwater pipes, culverts and channels.

In residential areas, the stormwater network starts with the stormwater pipes, which are usually
placed in the road reserves. Stormwater pipe diameter increases as the network develops to the
catchment areas. To ensure that pipes are broken at pipe intersections, they have to be cleaned

up.
After stormwater pipes, culverts or channels have been captured, stormwater nodes are placed
followed by service connections.

Next, the manholes and junctions are aligned onto the stormwater pipes and culverts. Curb and
drop inlets are placed in the road reserve, and wingwalls at the inlet and outlet of channels and
pipes, where appropriate.

The stormwater integrity check must be run to check the stormwater objects against the
business rules built into the capture and modify routines. Stormwater objects that pass the
integrity check can be posted to the database.

A unique GID (Geographic Identifier) is automatically assigned to each stormwater object for
identification purposes.
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Drainage capture settings

Tip

Each Munsys application has its own default capture settings that are set by the database
administrator in the Munsys Management Console.

In Munsys Drainage, default capture settings are available for:

catchments — the catchment tag height

channels — bottom width, depth, label height, material, offset distance, top width and type.

culverts — depth, label height, material, offset distance, tag height, top width and type
dams — tag height and type

dimensions — dimension note height

file — the drawing directory

floodlines — tag height and type

general — construction color, include network in object integrity, database extents display
resolution, integrity circle size, tag and symbol scale and rotation if coordinate
transformation is done, snap tolerance, tag angle, font, height and justification

integrity — short objects, stormwater node, pipe, service connection and search tolerance
nodes — tag height and stormwater symbol scale factor

stormwater symbols — the stormwater symbol scale

notes — tag height

pipes — label height, tag height, diameter, material, type, offset distance

rivers — tag height and type

service connections — the default length and service connection type

You can change the current settings on the Drainage Settings dialog box to speed up the capture
process. Capture settings only apply to new drainage objects, and if you change the default
settings, the changes are only valid for the current session.

Settings are changed by highlighting the current value, and then entering a new value, or by
selecting the new value from a drop-down list.

The user cannot change all of the settings. Some settings may only be changed by the GIS
administrator to enforce consistency and integrity on a higher level.

A short description of a value is displayed when it is highlighted.

Creating drainage data
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To specify drainage capture settings

1 Do one of the following:

Choose Capture > Drainage Settings...

Click the Drainage Settings button on the Munsys Drainage Capture toolbar.

VA RV
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The Drainage Settings dialog box is displayed, showing the default drainage capture settings.

A Drainage Settings

Current Session Settings:

Description
Catchment
Catchment Tag Height
Channel

Channel Baottarn Width
Channel Depth
Channel Label Height
Channel Material
Channel Offset Distance
Channel Taop Width
Channel Type
Culvert

Culvert Depth

Culvert Label Height

Tihsmdt b datavial

<

“alue

10.0000

0.0000 P

0.000a
7.0000
Concrete
3.0000
0.0000

% - Drain

Some values are changed by
manually entering a new
value.

Some values are changed by

Open Drain
Side Drain
|J - Drain

W - Drain

This is the default type assigned when capturing a new channel.

Cancel

Help

Figure 1 The Drainage Settings dialog box

2 To change a value, do one of the following:

Highlight the current value, and then enter a new value.

selecting a value from a drop-
down list.

Highlight the current value, and then choose the new value from the drop-down list.

3  Click OK to apply the new settings.

The settings will apply until you change them again, or until the current session is terminated, or
until you switch to a different application.
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Capturing stormwater pipes, culverts and channels

Stormwater pipes, culverts and channels can be captured using two methods:

In residential areas, the network can be captured at a specified offset distance from the
cadastral boundaries.

In other areas, the network can be captured by selecting points (freechand), or by entering
coordinates on the command line.

Stormwater pipes, culverts and channels are usually placed in the road reserves in residential
areas. As they start converging, the diameter becomes larger to accommodate the increase in
water flow.

Stormwater pipes, culverts and channels are captured on their appropriate layers, to be verified
when the integrity check is run.

Drawing offset stormwater pipes, culverts and channels
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Offset stormwater pipes are drawn by specifying multiple points along a boundary (for example
parcel boundaries), specifying the offset segment, and then specifying the offset distance. Offset
channels and culverts are drawn by specifying points along a boundary, or by selecting segments
to offset the channel or culvert from.

To draw an offset stormwater pipe

Do one of the following:
Choose Capture > Draw Offset > Pipe.
Click the Draw Offset Pipe button on the Munsys Drainage Capture toolbar.
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Specify an approximate start point for the pipe.

Specify an approximate endpoint for the pipe.
Select the segment to offset the pipe from.
Specify the side for offset.

On the command line, specify the offset distance, or press ENTER to accept the default offset
distance.

The command line displays a message confirming that the pipe was created successfully.
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To draw an offset culvert
A culvert can be drawn as a polyline entity between two stormwater nodes and is composed of
a series of straight-line or arc segments.

Do one of the following:
Choose Capture > Draw Offset > Culvert.
Click the Draw Offset Culvert button on the Munsys Drainage Capture toolbar.
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The command line prompts you to specify points, or to select a segment to offset the culvert
from.

To draw an offset culvert by specifying points, do the following:
Specify the first point

Then specify next point of the culvert drawn as a straight-line segment or change to draw an arc
segment [ Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset culverts as a series
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the culvert as series of straight-line segments.

Press ENTER when you have specified all the points.Specify a point on the side to offset the
culvert.

On the command line, specify the offset distance, or press ENTER to accept the default offset
distance.

The command line displays a message confirming that the culvert was created successfully.
To draw an offset culvert by selecting segments, do the following:

On the command line, type O, and then press ENTER.

Select a segment to offset the culvert from.

Specify a point on the side to offset the culvert.

On the command line, specify a multiplication factor for the default offset distance, or press
ENTER to accept the default offset distance.

Continue selecting segments until all the required segments have been selected, and then press
ENTER.

Press ENTER to confirm that you have completed selecting segments.

The command line displays a message confirming that the culvert was created successtully.
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To draw an offset channel

A channel can be drawn as a polyline entity between two stormwater nodes and is composed of
a series of straight-line or arc segments.

Do one of the following:
Choose Capture > Draw Offset > Channel.
Click the Draw Offset Channel button on the Munsys Drainage Capture toolbar.

617 741/ 7 L7 v+ & #]

\

The command line prompts you to specify points, or to select a segment to offset the channel
from.

To draw an offset channel by specifying points, do the following:
Specify the first point

Then specify next point of the channel drawn as a straight-line segment or change to draw an arc
segment [ Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset channels as a series
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options
[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the channel as series of straight-line segments.

Press ENTER when you have specified all the points.Specify a point on the side to offset the
channel.

On the command line, specify the offset distance, or press ENTER to accept the default offset
distance.

The command line displays a message confirming that the channel was created successfully.
To draw an offset channel by selecting segments, do the following:

On the command line, type O, and then press ENTER.

Select a segment to offset the channel from.

Specify a point on the side to offset the channel.

On the command line, specify a multiplication factor for the default offset distance, or press
ENTER to accept the default offset distance.

Continue selecting segments until all the required segments have been selected, and then press
ENTER.

Press ENTER to confirm that you have completed selecting segments.

The command line displays a message confirming that the channel was created successfully.

Creating drainage data
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Drawing freehand stormwater pipes, culverts and channels

Tip

Freehand stormwater pipes, culverts and channels are drawn by selecting points in the drawing,
or by entering coordinates on the command line. The command line prompts you for
endpoints, allowing a sequence of objects to be constructed. Stormwater pipes, culverts and
channels are captured on their respective layers (SWPIPE, SWCHANNEL and
SWCULVERT), to be verified when the integrity check is run.

To draw a freehand pipe

Do one of the following:
Choose Capture > Draw Freehand > Pipe.

Click the Draw Freehand Pipe button on the Munsys Drainage Capture toolbar.
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Specify a start point for the pipe, or enter coordinates on the command line.

Specify an end point for the pipe, or enter coordinates on the command line.

Press ENTER to complete.

To construct a sequence of pipes, continue to specify endpoints, and then press ENTER.

The command line displays a message confirming that the pipe was created successfully.

To draw a freehand culvert

Do one of the following:
Choose Capture > Draw Freehand > Culvert.

Click the Draw Freehand Culvert button on the Munsys Drainage Capture toolbar.
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Specify the first point for the culvert

Then specify next point of the culvert drawn as a straight-line segment or change to draw an arc
segment [ Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset culverts as a series
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the culvert as series of straight-line segments.

Press ENTER to complete.

The command line displays a message confirming that the culvert was created successfully.

Creating drainage data
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To draw a freehand channel

Do one of the following:
Choose Capture > Draw Freehand > Channel.

Click the Draw Freehand Channel button on the Munsys Drainage Capture toolbar.
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Specify the first point for the channel

Then specify next point of the channel drawn as a straight-line segment or change to draw an arc
segment [ Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing offset channels as a series
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options
[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width].

Select L to return to drawing the channel as series of straight-line segments.

Press ENTER to complete.
The command line displays a message confirming that the channel was created successfully.

The following figure gives an example of a stormwater pipe, culvert and channel:

L

Figure 2 Stormwater pipe, culvert and channel
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Showing flow direction

When you have captured and edited all the pipes, culverts and channels in the stormwater
network, you have to check the flow direction of these objects to verify that it is correct. This
can be done for both new and existing objects.

Important Make certain that the OSnap settings are set to None before showing or changing flow direc-
tion.
To show flow direction

1 Do one of the following:
Choose Capture > Show Flow Direction.

Click the Show Flow Direction button on the Munsys Drainage Flow toolbar.

2 Select the appropriate stormwater objects (pipes, channels or culverts), and then press ENTER.

A direction arrow on each selected object indicates the flow direction, as shown in the following

figure:

Figure 3 Showing stormwater flow direction
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To change flow direction
This function is used to reverse the flow direction of stormwater pipes, culverts and channels.
This enables users to construct the network without taking direction into account. Once the
construction is complete, the flow direction can be changed easily.
Do one of the following:

Choose Capture > Change Flow Direction.

Click the Change Flow Direction button on the Munsys Drainage Flow toolbar.
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N

Select the objects (pipes, culverts or channels) of which you want to change the flow direction, and
then press ENTER.

The direction is reversed automatically.

Important The integrity check does not verify flow direction; therefore it is very important to make cer-
tain that the flow direction is correct.

To clear direction arrows
When you are satisfied that the direction of all the stormwater pipes, culverts and channels is
correct, the direction arrows can be cleared from the drawing.
Do one of the following:
Choose Capture > Clear Direction Arrows.

Click the Clear Direction Arrows button on the Munsys Drainage Flow toolbar.
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N

The direction arrows are removed from the drawing.

Creating drainage data
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Capturing stormwater nodes
Stormwater nodes are captured by placing them either at the endpoint, or at a nearest point on
a pipe, culvert or channel. Nodes are captured as MunPoint objects, and are displayed as
symbols.

Attribute information, providing more descriptive information about nodes, is associated with
every node. A stormwater network contains the following types of nodes:

Node ‘ Description

Curb inlet An inlet on the side of the road that gathers flowing rainwater

Drop inlet An inlet that is level with the road surface; also known as a grid inlet.
Manhole Found at every bend point in the stormwater network, and used to gain

access to stormwater pipes and culverts

Junction A bend point in the stormwater network that does not provide access to
pipes or culverts

Wingwall An extension of a channel or pipe, constructed to prevent soil erosion
around the inlet or outlet.

Table 4 Stormwater nodes

Placing endpoint nodes

Endpoint nodes are placed at the end point of a stormwater pipe, culvert or channel, closest to
the point where it was selected. The following endpoint nodes can be placed:

curb inlets

drop inlets

manholes (cannot be placed on channels)
junctions

wingwalls

To place an endpoint node

1 Do one of the following:
Choose Capture > Place Endpoint Node > Node Name.
Click the appropriate button on the Munsys Drainage Place Node toolbar.
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2 Select a point close to the endpoint on the stormwater pipe, culvert or channel where you want to
place the node.

The node is placed on the SWNODE layer, to be verified when the integrity check is run.

Creating drainage data

35



Inserting nearest nodes

With this function, you can insert a manhole, curb inlet, or drop inlet at the nearest selected
point on a pipe, culvert or channel. The underlying object is broken at the selected point when
the node is inserted.

You can use this function when constructing a single long pipe, culvert or channel, inserting the
required nodes at regular intervals. It is also used in cases where new nodes are added to an
existing stormwater network.

To insert a nearest node

1 Do one of the following:
Choose Capture > Insert Nearest Node > Node Name.

Click the appropriate button on the Munsys Drainage Insert Node toolbar.

R

2 Select any nearest point on the stormwater pipe, culvert or channel where you want to insert the
node.

The node is placed on the SWNODE layer, to be verified when the integrity check is run.
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Capturing stormwater service connections

Service connections connect land parcels to the stormwater network.

The Munsys Drainage Place SC toolbar contains the functions that are used to capture different
types of service connections.

A service connection is captured as a freehand connection, or at 45° or 90° as a single or double
service connection, at either the endpoint or a nearest position on a gravity pipe.
Placing single service connections

Single service connections are placed nearest to the selection point, or at the endpoint of a
gravity pipe, at either 45° or 90° angles to the pipe, using the default service connection length
and service connection type as defined in the

Drainage Settings dialog box.

To place a single service connection at the endpoint of a gravity pipe

1 Do one of the following:
Choose Capture > Place Single SC > 45 Deg Endpoint or > 90 Deg Endpoint.

Click the Place Single SC 45 Deg Endpoint or 90 Deg Endpoint button on the Munsys
Drainage Place SC toolbar.

2 Select a point close to the endpoint of the gravity pipe where you want to place the service
connection.

3  Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the
service connection vector at angles of 45 or 90 degrees.

The service connection is placed on the SWSERV layer.

To place a single service connection at a nearest point
on a gravity pipe
1 Do one of the following:
Choose Capture > Place Single SC > 45 Deg Nearest or > 90 Deg Nearest.

Click the Place Single SC 45 Deg Nearest or 90 Deg Nearest button on the Munsys Drainage
Place SC toolbar.
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2 Select a point on the gravity pipe where you want to place the service connection.

3  Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the
service connection vector at angles of 45 or 90 degrees.
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The service connection is captured on the SWSERV layer.
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Figure 5 Single service connections
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Placing double service connections

Double service connections are placed nearest to the selection point on, or at the endpoint of a
gravity pipe, at either 45° or 90° angles to the pipe, using the default service connection length
and service connection type as defined in the Drainage Settings dialog box.

To place a double service connection at the endpoint of a gravity pipe

1 Do one of the following:
Choose Capture > Place Double SC > 45 Deg Endpoint or > 90 Deg Endpoint.

Click the Place Double SC 45 Deg or 90 Deg Endpoint button on the Munsys Drainage Place
SC toolbar.
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2 Select a point close to the endpoint of the gravity pipe where you want to place the service
connection.

3  Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the
service connection vector at angles of 45 or 90 degrees.

4  Repeat Step 3 to place the second segment of the service connection.

The service connection is captured on the SWSERV layer.
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To place a double service connection at a nearest point on a
gravity pipe
1 Do one of the following:
Choose Capture > Place Double SC > 45 Deg Nearest or 90 Deg Nearest.

Click the Place Double SC 45 Deg or 90 Deg Nearest button on the Munsys Drainage Place
SC toolbar.
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2 Select a point on the gravity pipe where you want to place the service connection.

3  Rotate your mouse in a clockwise or counter-clockwise direction, and then click to display the
service connection vector at angles of 45 or 90 degrees.

4  Repeat Step 3 to place the second segment of the service connection.

The service connection is captured on the SWSERV layer.

Figure 6 Double service connections
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Placing freehand service connections

With this function, you can place a single frechand service connection that is longer than the
default service connection length specified on the Drainage Settings dialog box, and that does
not tie into a stormwater pipe at the standard 45° and 90°. The service connection is captured
with the default service connection type specified on the Drainage Settings dialog box.

To place a freehand service connection

1 Do one of the following:
Choose Capture > Place Freehand SC.

Click the Place Freehand Service Connection button on the Munsys Drainage Place SC
toolbar.
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2 Select the gravity pipe where the service connection should be connected, and then drag and click to
place the service connection inside the parcel boundary.

The service connection is captured on the SWSERV layer.
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Figure 7 Freehand service connections
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Capturing rivers, floodlines and dams

Rivers can be drawn freehand, at a specified offset distance from a selected segment, or drawn
as a polygon. Floodlines and dams are captured as polygons. Rivers, floodlines and dams do not
form part of the stormwater network.

Drawing rivers

To draw a freehand river
Freehand rivers are drawn by specifying consecutive points in the drawing, or by entering
coordinates on the command line.

To draw a frechand river, do the following:

1  Choose Capture > River-Line > Draw Freehand River.
2 Specify the start point river by selecting a point, or enter coordinates on the command line.

3 Specify the next points for the river, or select A for Arc[Arc/Halfwidth/Length/Undo/Width], or
enter more coordinates on the command line.

You can construct the river line as a series of straight-line or arc segments. By selecting A, the
polyline linear list allows you to continue capturing river lines as a series of arcs. If selecting the
Arc option, the polyline linear list changes with more selection options

[Angle/ CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]. Select L to

return to drawing the river line as series of straight-line segments.
4  Press ENTER when you have specified all the points to create the river.
The river is created on the RIVERLINE layer, to be verified when the integrity check is run.

To draw an offset river
Offset rivers are captured at a specified offset distance from segments. The default offset
distance can be changed in the Drainage Settings dialog box.

1  Choose Capture > River-Line > Draw Offset River.
The command line prompts you to specify points, or to select a segment to offset the river from.

2 To draw a river by specifying points, do the following:
Specify the first point, and then specify next points for the river.

Then specify next point of the river drawn as a straight-line segment or change to draw an arc
segment [ Arc/Halfwidth/Length/Undo/Width].

By selecting A, the polyline linear list allows you to continue capturing the river as a series of
arcs. If selecting the Arc option, the polyline linear list changes with more selection options

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]. Select L to

return to drawing the river as series of straight-line segments.
Press ENTER when you have specified all the points.
Specify a point on the side to offset the river.

On the command line, specify the offset distance.
The command line displays a message confirming that the river was created successfully.
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To draw a river by selecting segments, do the following:
On the command line, type O, and then press ENTER.
Select a segment to offset the river from.

Specify a point on the side to offset the river.

On the command line, specify a multiplication factor for the default offset distance, or press
ENTER to accept the default offset distance.

Continue selecting segments until all the required segments have been selected, and then press
ENTER.

Press ENTER to confirm that you have completed selecting segments.

The command line displays a message confirming that the river was created successfully.

Drawing a polygon river

A polygon river is created by selecting consecutive points to form a polygon. Next, a tag (the
river name) is assigned to the river. The polygon builder uses the lines and tag of the newly
created river to build the river polygon, and verifies that the polygon forms a closed area. The
integrity check still needs to verify the standard business rules for drainage objects before the
river can be posted to the database. River polygons are generated on the RIVERPOLY layer.
To draw a river boundary

Choose Capture > River-Polygon > Draw River Boundary.

Specify the first polygon point.

Specify the next points, and then press ENTER.

Press ENTER to close the polygon, or type N on the command line to specify more points.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a river tag

Choose Capture > River-Polygon > Place River Tag.

Specify the insertion point for the tag.

On the command line, specify the tag height, or press ENTER to accept the default height.
To indicate the tag angle, do one of the following:

Indicate the tag angle with your mouse.

On the command line, type A to align the tag to an object, press ENTER, and then select the
object to which you want to align the tag.

Type the tag text on the command line, and then press ENTER.

The tag is inserted as specified.
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To generate a river polygon

Choose Capture > River-Polygon > Generate River Polygons.
Select all the lines that form the river polygon, and then press ENTER.
Select the river tag, and then press ENTER.

The command line indicates that the polygon has been built successfully.

Drawing floodlines
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A floodline boundary is drawn by selecting consecutive points to form a polygon. Munsys closes
the polygon automatically by snapping to the first specified point. Next, a tag is assigned to the
floodline. The polygon builder uses the lines and tag of the newly created floodline to build the
floodline polygon.

To draw a floodline boundary

Choose Capture > Floodline Boundary > Draw Floodline Boundary.

Specify the first polygon point.

Specify the next points, and then press ENTER.

Press ENTER to close the polygon, or type N on the command line to specify more points.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a floodline tag

Choose Capture > Floodline Boundary > Place Floodline Tag.

Specify the insertion point for the tag.

On the command line, specify the tag height, or press ENTER to accept the default height.
To indicate the tag angle, do one of the following:

Indicate the tag angle with your mouse.

On the command line, type A to align the tag to an object, press ENTER, and then select the
object to which you want to align the tag.

Type the tag text on the command line, and then press ENTER.

The tag is inserted as specified.

To generate a floodline polygon

Choose Capture > Floodline Boundary > Generate Floodline Polygons.
Select the lines that form the floodline polygon, and then press ENTER.
Select the floodline tag, and then press ENTER.

The command line indicates that the polygon has been built successtully.
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Drawing dams
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A dam is drawn by selecting consecutive points to form a polygon. Munsys closes the polygon
automatically by snapping to the first specified point. Next, a tag (text) is assigned to the dam.
The polygon builder uses the lines and tag of the newly created dam to build the dam polygon.
To draw a dam boundary

Choose Capture > Dam > Draw Dam Boundary.

Specify the first polygon point.

Specify the next points, and then press ENTER.

Press ENTER to close the polygon.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a dam tag

Choose Capture > Dam > Place Dam Tag.

Specify the insertion point for the tag.

On the command line, specify the tag height, or press ENTER to accept the default height.
To indicate the tag angle, do one of the following:

Indicate the tag angle with your mouse.

On the command line, type A to align the tag to an object, press ENTER, and then select the
object to which you want to align the tag.

Type the tag text on the command line, and then press ENTER.

The tag is inserted as specified.

To generate a dam polygon

Choose Capture > Dam > Generate Dam Polygons.
Select the lines that form the dam polygon, and then press ENTER.
Select the dam tag, and then press ENTER.

The command line indicates that the polygon has been built successtully.
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Figure 8 A dam polygon

Capturing stormwater catchments
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A stormwater catchment area is created by selecting consecutive points to form a polygon.
Munsys closes the polygon automatically by snapping to the first specified point. Next, a tag is
assigned to the catchment. The polygon builder uses the lines and tag of the newly created
catchment to build the catchment polygon, and verifies that the polygon forms a closed area.
The integrity check still needs to verify the standard business rules for stormwater before the
catchment can be posted to the database. Catchment polygons are generated on the

SWCATCH layer.

To draw a catchment boundary

Choose Capture > Catchment > Draw Catchment Boundary.

Specify the first polygon point.

Specify the next points, and then press ENTER.

Press ENTER to close the polygon, or type N on the command line to specify more points.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a catchment tag

Choose Capture > Catchment > Place Catchment Tag.

Specify the insertion point for the tag.

On the command line, specify the tag height, or press ENTER to accept the default height.
To specify the tag angle, do one of the following:

Indicate the tag angle with your mouse.

On the command line, type A to align the tag to an object, press ENTER, and then select the
object to which you want to align the tag.
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Type the tag text on the command line, and then press ENTER.

The tag is inserted as specified.

To generate a catchment polygon

Choose Capture > Catchment > Generate Catchment Polygons.
Select all the lines on the catchment polygon, and then press ENTER.
Select the catchment tag, and then press ENTER.

The command line indicates that the polygon has been built successtully.

Figure 9 A stormwater catchment area
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Placing stormwater symbols

Note

3
4

This function is used to place stormwater symbols in the current drawing. Stormwater symbols
represent additional annotation in the form of a symbol, and do not form part of the
stormwater network. Stormwater symbols can be placed anywhere without any restriction.
Stormwater symbols are captured on the SWSYM layer.

The database administrator can add additional stormwater symbols to the lookup table

LU_DMS_SWSYM as required. This table contains a number of default symbols, but can be customized.

To place stormwater symbols

Do one of the following:
Choose Capture > Place Stormwater Symbol...

Click the Place Stormwater Symbol button on the Munsys Drainage Capture toolbar.

The Stormwater Symbols dialog box is displayed, showing a list of available stormwater symbols.

Stormwater Symbols X
Lookup Takble Information

Table Name: |[LU_DMS_SWSYM

Search: | | (OCode (@ Description

Code Description

_SCLNSERY Cleanout

_SFLOWDIR Direction Arrow

< >

Figure 10 The Stormwater Symbols dialog box

From the list, select the symbol that you want to place, and then click OK.

Specify an insertion point for the symbol.
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5  Specify a rotation angle for the symbol by doing one of the following:

Enter the rotation angle on the command line, or press ENTER to accept the default angle of
Zero.

Indicate the angle with your mouse pointer by picking two points in the drawing.

On the command line, type AL to align the symbol to an object, press ENTER, and then select
the object to which you want to align the symbol.

The symbol is placed at the insertion point and angle that you specified.

Tip Press ENTER or the Space Bar to continue placing consecutive symbols of the same type, without having

to select a symbol type from the list every time.
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Placing drainage labels
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In Munsys, labels contain text information that represent a specified column in the database.
These labels are dynamic and change according to the changes in the database. Labels can be
created for stormwater pipes, culverts and channels.

To place drainage labels
The following information is displayed on drainage labels:

pipe — diameter and pipe material

culvert — width, depth and material

channel — top width, bottom width, material and depth

To place a drainage label, do one of the following:

Choose Capture > Place Drainage Label > Label Name.

Click the appropriate button on the Munsys Drainage Label toolbar.

7

2

A

Select the pipe, culvert or channel to which you want to attach the label.
Specify an insertion point for the tag.

Specify the tag height, or press ENTER to accept the default tag height.
To indicate the tag angle, do one of the following:

Indicate the tag angle with your mouse.

On the command line, type A to align the tag to an object, press ENTER, and then select the
object to which you want to align the tag.

|

v v

stormwater pipe

Figure 11

A stormwater pipe label
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Placing drainage notes

For map production purposes, information about a spatial object is added in the form of a note.
Drainage notes are placed on the SWNOTE layer.
To place a drainage note

Do one of the following:
Choose Capture > Place Drainage Note.

Click the Place Drainage Note button on the Munsys Drainage Capture toolbar.

6172 7/177

-
[

&l 7 v v |I§ Ak |

\

Specify the insertion point for the note.
On the command line, specify the note height, or press ENTER to accept the default note height.
To specify the note angle, do one of the following:

Indicate the angle with your mouse.

On the command line, type A to align the note to an object, press ENTER, and then select the
object to which you want to align the note to.

Type the note value on the command line, and then press ENTER.

The note is inserted as specified.

. oy
drainage note,/zhlgned to

") stormwater pipe
o N 7
< stormwater pipe \j\

<
. ,{\(b‘g 4— pe{cél\boundary\
> “
&

N
Figure 12 A drainage note
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Placing dimension arrows

Map production is a reduced version of reality and it is therefore virtually impossible to capture
stormwater pipes at the true offset distance from a parcel boundary. Dimension arrows are used
to indicate the offset distance of a stormwater pipe, culvert or channel from a parcel boundary.

To place dimension arrows

Do one of the following:
Choose Capture > Place Dimension Arrow.

Click the Place Dimension Arrow button on the Munsys Drainage Capture toolbar.

6177 71/7 Jsil7 7 B

Specify the first segment for dimension.

The dimension arrows will be placed perpendicular to this segment.
Specify the second segment for dimension.

The dimension arrows are aligned to the point selected on this segment.

On the command line, enter the offset distance, or press ENTER to accept the default offset distance
as determined in the Drainage Settings, or press A to place the actual calculated distance.

The dimension text is placed at the dimension arrows, indicating the distance between the two
dimension lines.

7 / L
t(imension arrows f\‘j

and text, showing offset
distance.

I

Figure 13 Dimension arrows
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Capturing pipe, channel, culvert and node levels

With Munsys Drainage, you can capture pipe, culvert and channel levels by entering ground
and invert levels for their respective start and end nodes. The length and gradient are calculated
automatically. Node levels (depth, ground level, length and width) can be captured as well.
To attach pipe levels

1  Choose Capture > Pipe Levels...

2 Select the stormwater pipe that you want to attach the information to.

The Pipe Information dialog box is displayed.

Pipe Information *

Start Info End Info

Ground Level:  |LEEZE Ground Level: [1647.16
Invert Level: 1645656 Invert Level: 1645407

IE

Depth: 1.753 Depth: 1.753
Detail Info
Length: 23.4853 Gradient 94.3185

oK Cancel Help

Figure 14  The Pipe Information dialog box

3 From the Start Info group, enter the following information:
Ground level

Invert level
The Depth value is calculated automatically.

4  From the End Info group, enter the following information:
Ground level

Invert level
The Depth value is calculated automatically.

The pipe length and gradient values in the Detail Info group are calculated automatically
from the Start Info and End Info groups.

5 Click OK.

The attribute changes are accepted.
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To attach culvert levels

Choose Capture > Culvert Levels...

Select the culvert that you want to attach the information to.

The Culvert Information dialog box is displayed.

Culvert Information X

Start Info End Info

Ground Level:  |LELEE Ground Level: (1605548
Invert Level: 1604.444 Invert Level: 1603.795

=
@
]

Depth: 1.753 Depth: 1.753
Detail Info
Length: 55.9591 Gradient 86.2236

Cancel Help

Figure 15  The Culvert Information dialog box

In the Start Info group, enter the following information:
Ground level
Invert level

The depth value is calculated automatically.

From the End Info group, enter the following information:
Ground level

Invert level

The Depth value is calculated automatically.

The culvert length and gradient values in the Detail Info group are calculated automatically from

the Start Info and End Info group.
Click OK.

The attribute changes are accepted.
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To attach channel levels

Choose Capture > Channel Levels...

Select the channel that you want to attach the information to.

The Channel Information dialog box is displayed.

Channel Information bt

Start Info End Info

Ground Level: |1607.3
Invert Level: 1610.76 Invert Level: 1606

Ground Level:

Depth: 1.8 Depth: 1.3
Detail Info
Length: 125.7931 Gradient 26.4271

Cancel Help

Figure 16  The Channel Information dialog box

In the Start Info group, enter the following information:
Ground level
Invert level
The Depth value is calculated automatically.
From the End Info group, enter the following information:
Ground level

Invert level

The Depth value is calculated automatically.

The channel length and gradient values in the Detail Info group are calculated automatically from

the Start Info and End Info group.
Click OK.

The attribute changes are accepted.
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To attach node levels

1  Choose Capture > Node Levels...
2 Select the appropriate stormwater node.

The Stormwater Node Information dialog box is displayed.

Stormwater Node Information

MNode Info:

Depth: Size 1:

Ground level: 1611519 Size 2:
Cancel Help

:TJ
IH
II X

Figure 17 The Stormwater Node Information dialog box

3  Enter a value in each of the following fields:
Node Depth (m)
Ground Level
Size 1 — length
Size 2 — width

4  Click OK to attach the node levels for the selected node.
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Checking drainage integrity
The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial
objects have to be verified against integrity rules built into the capture and change routines of
every application before they can be posted to the database. New and changed objects contain
an internal status that requires the validation process.

The Integrity Check is run from the Capture menu, or by clicking the appropriate button on
the Integrity toolbar. The way in which the integrity check is executed depends on the
preferences/options specified in the Munsys Options dialog box. The various options available
on this dialog box are discussed in detail in the Munsys Concepts User Manual: Chapter 4:
Munsys Options.

The integrity check is split into two separate functions to facilitate flexibility and ease of use:

Validate Object Integrity — checks and validates the spatial and/or attribute data of an
object, according to the options specified in the Munsys Options dialog box:

When the Validate Geometry: Modified objects option has been selected, the geome-
try of only new or modified objects will be validated.

When the Validate Geometry: All objects option has been selected, all the objects in
the selection set will have their geometry validated. This includes locked, unlocked,
modified and non-modified objects.

When the Validate Attributes: Modified attributes option has been selected, the attri-
butes of only new or modified objects will be validated.

When the Validate Attributes: All attributes option has been selected, all the objects
in the selection set will have their attributes validated. This includes locked, unlocked,
modified and non-modified objects.

When the object integrity check has completed and changes in objects have been
encountered that may affect network integrity, a warning message to this effect is displayed
if the option was specified in the Munsys Options dialog box.

Validate Network Integrity — validates the rules that, together with the objects, make up a
network, and according to the Network Integrity options specified in the Munsys Options
dialog box. Network validation includes the topology and connectivity aspects, where
topology is resembled in the geometry of objects and connectivity by means of attributes
attached to objects.

This function is dependent on the relationships between objects, and therefore requires
more objects to be included as part of the validation process than only those that were
modified. The Validate Network Integrity function allows non-validated objects to be
selected, but does not attempt to reset any integrity flags. It only places integrity markers
when errors are encountered in the network. If the selection set contains objects that have
not been validated by the Validate Object Integrity function, an Object Integrity Warning
is displayed, recommending that object integrity has to be checked before network
integrity.

Note The *INTEG_ NETWORK AUTCHECK* application setting (Include Object in Network Integrity

Check), which is set by the database administrator in the Munsys Management Console, allows a network
integrity check to be performed automatically whenever an object integrity check is run. The same network
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rules and settings still apply. When the integrity check is completed, the Integrity Results dialog box
displays a combined list of both object and network validations that were performed during the integrity
check. When this setting is enabled, the object integrity check cannot be integrated with the database
posting function, and the Automatically perform Object Integrity option on the Munsys Options

dialog box Preferences tab will be unavailable.

When drainage object integrity is checked, the following is verified:

Validation check/error condition

Unlocked objects not rectified

Description

Indicates that an object could have been rectified
but, because it was unlocked, the integrity check
failed to rectify the object and it was left as is.

Short spatial objects

Applies to any object with a length shorter than
the Munsys Drainage database tolerance setting.

Duplicate points in spatial objects

Applies to redundant coordinates being removed

from an object. If the coordinates are within
*SNAP* tolerance, they are discarded.

Objects with incomplete geometry

Refers to objects that do not have geometry, for
example: tags that were placed without using the
polygon builder process do not have a geometry.

Objects outside database extents

Checks if the objects selected are within the
confines of the geographic extents of the
database.

Attribute rules

Checks for the attribute rules as specified in the
MUNSYS_INTEG_ATTR table, for example
NULL values, etc.

Attribute data types

Checks the data type to be consistent with what
is in the database; i.e. attached attributes should
not exceed the limits of the table's column
definition, for example: a tag may not be longer
than the table's TAG_VALUE column width.

Table 18  The drainage object integrity check

When drainage network integrity is checked, the following is verified:

Validation check/error condition

Unlocked objects not rectified

Description

Indicates that an object could have been
rectified but, because it was unlocked, the
integrity check failed to rectify the object

and it was left as is.

Pipes within snap tolerance

Checks for pipes, culverts and channels
that can snap to other pipes, channels or
culverts that are within the snap
tolerance.
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Pipes without nodes Checks whether each pipe, channel or
culvert is connected to a node at both

ends of the pipe.

Duplicate pipes Checks for two different pipes, culverts or
channels that are connected to the same
nodes.

Nodes within snap tolerance Checks for nodes that can be snapped to

pipes, culverts or channels that are within
the snap tolerance.

Isolated nodes Checks for nodes that are not connected
to any pipes, culverts or channels.

Nodes with too many pipes Checks for nodes that are connected to
too many pipes, culverts or channels.

Nodes with too few pipes Checks for nodes that are connected to
too few pipes, culverts or channels.

Duplicate nodes Checks for nodes that have been captured
on top of one another.

Table 19  The drainage network integrity check

Note The integrity check will transfer pipe levels from a node or pipe, culvert or channel, depending on the
existence of level attributes in the object. If the node does not have level attributes set but the pipe, culvert
or channel does contain level attributes, the node cover level and depth will be calculated from the pipe,
culvert or channel to the node. If the pipe, culvert or channel does not have levels set but the node contains
levels, the pipe, culvert or channel levels will be calculated from the node to the pipe, culvert or channel.

Checking drainage object integrity
1 Do one of the following:

Choose Capture > Data Integrity > Validate Object Integrity...
Click the Validate Object Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

The Integrity Results dialog box is displayed, providing summarized information and validation
results encountered during the object integrity check.
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A Integrity Results Y

Sumrary of Results
Total Number of Objects Selected 7430
Tatal Nurnber of Objects Passed: 7929

Tatal Murnbet of Objects Failed: 1

“alidation Fesults

Description Checked Passed Reclified Failed
Objects with incomplete geometry 1 1 1] 1]
Objects outside database extents 1 1} 0 1
Attribute rules 1 1 ] ]
Attribute data types 1 1 1] 1]

Figure 20  The Integrity Results dialog box

3  Ifyouselected the Notify when objects require network validation option on the Munsys Options
dialog box, and if objects were encountered during the integrity check that may affect network
integrity, the following message is displayed:

Network Integrity Warning *

o Object integrity complete.
Changes have been detected that may influence netwaork
integrity.
It is recommended that network integrity is validated before
changes are posted to the database.

Figure 21  Network Integrity Warning

Checking drainage network integrity

1 Do one of the following:
Choose Capture > Data Integrity > Validate Network Integrity...
Click the Validate Network Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

Note If you selected objects that have not been validated by the Validate Object Integrity function, the
following message is displayed:
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Object Integrity Warning

o You are about to validate network integrity.
objects.

network integrity.

Object integrity has not been validated on some of the selected

It is recommended that object integrity is validated befare

Figure 22 Object Integrity Warning

3 When the integrity check has completed, the Integrity Results dialog box is displayed, providing
summarized information and validation results encountered during the network integrity check.

A Integrity Results

Summary of Results

Total Mumber of Objects Selected: 7929
Total Mumber of Objects Passed: 7929
Total Mumber of Objects Failed: 0

Yalidation Results

Description Checked Passed
Unlocked objects nat rectified 7 i
Pipes within snap talerance 3922 3922
Pipes without nodes 3922 3322
MNodes within snap tolerance 4007 4007
lzolated nodes 4007 4007
MNodes with too many pipes 4007 4007
MNodes with too few pipes 4007 4007
Duplicate nodes 4007 4007

Fectified  Failed
7

i Y e e Y e Y e Y e Y e Y e
oo o0 o oo o

Errors... Help

Figure 23 The Integrity Results dialog box

Browsing integrity markers

You can review the integrity markers resulting from the integrity check with the Browse

Integrity Markers dialog box. This dialog box displays the complete list of errors encountered
during the integrity check. The list consists of the error type, the object affected, a description
of the error, and the GID of the spatial object. From this dialog box, you can locate and remove

specific integrity markers in the drawing.

To browse integrity markers

1 Do one of the following:
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Choose Capture > Browse Integrity Markers...

Click the Browse Integrity Markers button on the Integrity toolbar.

Click the Errors... button on the Integrity Results dialog box.

The Browse Integrity Markers dialog box is displayed.

A Browse Integrity Markers bt
List of Integrity Markers:
Type Ohject Error Info GID
Record Locking Starmwater Pipes  Object not locked - attempt to update attributes failled 202184
Record Locking Stormwater Fipes  Object not locked - attempt to update aftributes failed 113129
Record Locking Stormwater Fipes  Object not locked - attempt to update aftibutes failed 111949
Record Locking Stormwater Pipes  Object not locked - attempt to update attributes failled 111783
Record Locking Starmwater Fipes  Object not locked - attempt to update aftributes failed 111948
Record Locking Stormwater Fipes  Object not locked - attempt to update aftibutes failed 112296
Record Locking Stormwater Pipes  Object not locked - attempt to update attributes failled 111670
Locate Remowe Help
Figure 24 The Browse Integrity Markers dialog box

To locate an error, select the appropriate integrity marker, and then click the Locate button.

Munsys zooms to the extent of the spatial object to which the integrity marker refers.

To remove integrity markers from the list and from the drawing, select one or more integrity markers

from the list, and then click the Remove button.

The integrity markers are removed from the drawing and from the list of markers.
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Erasing integrity markers

With this function, you can erase all the integrity markers. Integrity markers are stored on the
INTEG layer.

To erase integrity markers

1 Do one of the following:
Choose Capture > Erase Integrity Markers.
Click the Erase Integrity Markers button on the Integrity toolbar.
The command line prompts you for confirmation to erase all the integrity markers.
2 Press ENTER to erase the integrity markers.
The integrity markers are erased.

Posting drainage data to the database
New or modified drainage data that has passed the integrity check is posted to the database.

To post drainage data to the database

1 Do one of the following:
Choose Capture > Post to Database...

Click the Post to Database button on the Integrity toolbar.
The Database Posting Summary dialog box is displayed.

A Database Posting Summary x

Projection Informeation
Current Database Projection: RSa-L029

Current Drawing Projection:

Yalidated Objects
The following actions are aboutto be pedormed on the

database:

Tatal Mumber Objects Selected: 3
MNew Ohbjects: 0
Adtribute Changes: 0
Spatial Changes: 0
Ohbjects to be Deleted: 3

Ohbjects Not Validated

The following objects have not been validated and will
not be posted to the database:

Ohjects Mot Validated: 0

Figure 25  The Database Posting Summary dialog box

This dialog box displays the following:
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Note

2

3

The total number of spatial objects selected for posting,.

The number of new objects created.

The number of attribute changes made.

The number of spatial changes made.

The number of objects marked for deletion.

The number of objects that have not been validated and that will not be posted to the

database.

Click OK to update the database.

The Database Posting Results dialog box is displayed.

A Database Posting Results

Total Number Objects Selected: 3
Total Number Ingerted: a
Total Nurmber bModified: a
Total Number Deleted: a
MNumber of Objects not Posted: 3

x

Figure 26 The Database Posting Results dialog box

This dialog box displays the following:

The total number of objects selected for posting to the database.
The total number of spatial objects inserted into the database.
The total number of spatial objects modified in the database.
The total number of spatial objects deleted from the database.

The total number of objects not posted to the database.

Click Close to exit the Database Posting Results dialog box.

Once you have posted objects to the database, you will not be able to undo this function, which will avoid

duplicate objects and keep the content of the drawing synchronized with the database.
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Validating object integrity and posting data at the same time

If you select the Automatically perform Object Integrity option on the Munsys Options dialog box
Preferences tab, you can perform an object integrity check and database posting operation at the
same time. The following rules will be applied when the objects integrity phase of the operation is
executed:

Only modified objects will be selected for object integrity
The integrity flag will be reset automatically if the object passes object integrity

Integrity markers will be placed accordingly where errors occur, as happens when a normal
object integrity check is run from the Capture menu

If an error occurs, the integrity flag will not be reset

Only objects related to the current application will be included in the object integrity check
(i.e. if you are working in the Drainage application, only drainage objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:

Ignore the errors that occurred and continue to post the objects that passed the integrity
check to the database

Cancel the database posting operation and return to the map interface

View the errors that occurred with the Browse Integrity Markers dialog box (this option also
cancels the posting operation, allowing you to correct the errors first before attempting to
post the objects to the database once again)

To validate object integrity and post objects at the same time

1  On the Munsys Options dialog box Preferences tab, select the Automatically perform Object
Integrity check box in the Database Posting Preferences group.

2 Choose Capture > Post to Database.
An object integrity check is run on the all the new or modified objects in the drawing.

3  If any errors occurred, the following message is displayed:

A Database Posting - Object Integrity Errors x

Errors were encountered during object integrity.
Do you wish to continue to post valid objects to the
database?

Yes No Errors...

Figure 27  Database Posting — Object Integrity Errors

4 Do one of the following:

Click Yes to ignore the errors that have occurred and post the objects to the database that have
passed the integrity check

Click No to cancel the posting operation and return to the drawing

Click Errors... to view the errors that occurred using the Browsing Integrity Markers dialog box.
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Drainage network quality reporting

The Network Quality Report function on the Extras menu is used to validate the quality of the
entire drainage network. The network quality report complements the network integrity check.
Although it is reccommended that a network integrity check is always done before objects are
posted to the database, some problems might still be present in the quality of a network. This
could, for example, be due to the fact that the network integrity check might have been done
on a small area of the network. The network quality check uses all the objects in the database
to validate the quality of the entire network. The validation is done at attribute level, without
having to validate the associated spatial data. Specific columns in each of the spatial tables are
used to build up the topology of the network, for example the start and end nodes of a
stormwater pipe. The network quality report will validate these values based on drainage-
specific rules.

Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS
table, together with the appropriate error message related to each spatial object where an error
occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query, which will
use this table as a linked table with a condition based on the SP_TABLE column that matches
the spatial table name of the query.

If a single spatial object contained more than one error, a record will be stored for each error
that occurred within that object. You can also have the errors populated to the COMMENTS
column of the object(s) in which errors occurred, if you do not traditionally use this column for
other purposes. If more than one error has occurred in an object, the COMMENTS column is
populated with the last error that is found. The following table shows the drainage network
errors that may occur:

Spatial Table ‘ Error ‘ Description

SP_SWPIPE NODE MISSING The START NODE/END_NODE value is
NULL, or the node ID was not found in the
SP_SWNODE table

SP_ SWCHANNEL | NODE MISSING The START NODE/END_NODE value is
NULL, or the node ID was not found in the
SP_SWNODE table

SP_SWCULVERT | NODE MISSING The START _NODE/END_NODE value is
NULL, or the node ID was not found in the
SP_SWNODE table

SP_SWNODE ID NULL The value of the NODE_ID column is NULL.
SP_SWNODE SEQUENCE The value in the NODE_ID column exceeds the
EXCEEDED current value of the DMS_SWNODE sequence
SP_SWNODE ID NOT UNIQUE | The NODE_ID column contains a non-unique
value
SP_SWNODE NODE ISOLATED | The node ID was not found in either the

START _NODE or END_NODE columns of
the SP_SWPIPE, SP_ SWCHANNEL or
SP_SWCULVERT tables

Figure 28  Drainage network quality errors
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To validate drainage network quality
Choose Extras > Network Quality Report...
The command line displays the message: Generating network quality report

If errors were found in the network, the following message is displayed:

Network Quality Errors Found *

Network quality errors were found
and have been logged in the MUNSYS_INTEG_RESULTS table

Do you wish to integrate these errors by updating the COMMENTS column?

Yes No

Figure 29  Network Quality errors found

Click Yes if you want the COMMENTS column updated, or No if you do not want the column
updated.

The Save Results Summary As dialog box is displayed.

Save the report to a location of your choice.

The report is opened in Windows Notepad, and contains the following information:
The number of objects that were checked
The number of objects found that violated the network rules
The number of endpoints that were found in the network

The number of errors that were found, grouped by error type

i = (&) X
8 Drainage_Network_Quality_Report X an
File  Edit  View o

Drainage MNetwork Quality Results (MCITY1SINT) ©6/09/2024 Time: 15:59:35

Number of objects checked: 7929
Number of objects found that violated the network rules: (-]
Number of endpoints found in the network: 131

Number of errors grouped by error type

Ln1, Col1 289 characters 1003 Windows (CRLF UTF-8

Figure 30 A drainage network quality report
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Generating drainage data status reports

2

Data status reports provide summarized information about spatial objects that are currently
stored in the database. Once a report has been generated, it is saved to a comma delimited file,
and then displayed in Notepad for easy viewing. The following reports can be generated for

drainage objects:
a summary of all the drainage objects in the database
a summary of the total length and number of stormwater pipes by diameter
a summary of the total length and number of stormwater pipes by material
a summary of the total length and number of stormwater channels by dimension
a summary of the total length and number of stormwater channels by material
a summary of the total length and number of stormwater culverts by dimension
a summary of the total length and number of stormwater culverts by material
a summary of the number of stormwater nodes, grouped by node type
a summary of the total length and number of service connections by type

a summary of length and number of stormwater pipes by diameter and material

a summary of length and number of stormwater channels by dimension and material

a summary of length and number of stormwater culverts by dimension and material

To generate a drainage data status report

Choose Extras > Data Status Report...

The Data Status Report dialog box is displayed, showing a list of all the reports that can be

generated.

Data Status Report K

Data Status Reports:

Summary of all drainage objects

Total length and number of stormwater pipes by diameter

Total length and number of stormwater pipes by material

Total length and number of stormwater channels by dimension
Total length and number of stormwater channels by material

Total length and number of stormwater culverts by dimension

Total length and number of stormwater culvers by material
Number of stormwater nodes grouped by type

Total length and number of service connections by type

Total length and number of stormwater pipes by diameter and mate
Total length and number of stormwater channels by dimension and
Total length and number of stormwater culverts by dimension and

OK Cancel Help

Figure 31  The Data Status Report dialog box

Select one or more reports to generate from the list, and then click OK.
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3  Save the file to a location of your choice.

The file is opened in Windows Notepad.

- = ]

El Drainage_Nodes_By Type.csv Es +

File  Edit  View €3
Drainage Data Status Report (MCITY15INT) 86/89/2024 Time: 16:085:24

#* - Indicates that no matching record was found in the lookup table

Number of stormwater nodes grouped by type

Description,Number of Objects
JUNCTION,19

KERB_INLET,2161

MANHOLE, 1642

WING_WALL,158

DROP_INLET,35

Total number of objects,40@7

Ln1, Col1 373 characters 100% Wwindows (CRLF) UTF-8
Figure 32 Data status report for stormwater nodes

Converting AutoCAD entities to drainage objects

With Munsys, you can convert selected AutoCAD entities to Munsys Drainage objects. Block
entities can be converted to stormwater nodes (curb inlets, drop inlets, manholes, junctions,
and wingwalls) or stormwater symbols (cleanout or direction arrow). Line entities can be
converted to service connections, pipes, culverts, channels or rivers, text can be converted to
tags or drainage notes, and polygons can be converted to rivers, floodlines, dams or catchments.

Although some basic attributes are assigned as part of the conversion process, you will need to
assign attributes to the objects created with the conversion process.

To convert block entities to stormwater nodes
With this function, you can convert AutoCAD block entities to any of the following
stormwater nodes:

curb inlets
drop inlets
manholes
junctions
wingwalls
To convert block entities to stormwater nodes, do the following:
1  Choose Extras > Convert Block to > Node Name.
2 Select the block entities that you want to convert, and then press ENTER.

One stormwater node is created for each block entity that you selected, and the drawing is updated
accordingly.
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To convert block entities to stormwater symbols
With this function, you can convert AutoCAD block entities to any of the available stormwater
symbols.

To convert block entities to stormwater symbols, do the following:

Choose Extras > Convert Block to > Stormwater Symol.

Select the block entities that you want to convert, and then press ENTER.

The Stormwater Symbols dialog box is displayed, showing a list of available stormwater symbols.
From the list, select the symbol that you want to place, and then click on OK.

One stormwater symbol is created for each block entity that you selected, and the drawing is
updated accordingly.

To convert line entities to drainage objects
With this function, you can convert line entities to any of the following drainage objects:

pipes, culverts and channels
rivers

service connections

To convert line entities to drainage objects, do one of the following:
Choose Extras > Convert Line to > Pipe.
Choose Extras > Convert Line to > Culvert.
Choose Extras > Convert Line to > Channel.
Choose Extras > Convert Line to > River.

Choose Extras > Convert Line to > Service Connection.

When converting a line entity to a service connection (SC), the SC must also be linked to the
parcel before the PIPE ID and the PRCL_GID will be added to the respective SC columns. To
link a SC to a parcel use the menu item: Change > Link SC’s to Parcels.

Select the line objects that you want to convert to stormwater objects, and then press ENTER.

The selected line objects are converted and the drawing is updated accordingly.

To convert text to drainage notes or tags
With this function, you can convert AutoCAD text to the following:

floodline tags
dam tags
catchment tags
drainage notes
To to convert text to drainage tags or notes, do one of the following:
Choose Extras > Convert Text to > River Tag.

Choose Extras > Convert Text to > Floodline Tag.

Choose Extras > Convert Text to > Dam Tag.
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Choose Extras > Convert Text to > Catchment Tag.
Choose Extras > Convert Text to > Drainage Note.
Select the objects that you want to convert, and then press ENTER.

The entities are converted to the drainage objects that you specified, and the drawing is updated
accordingly

To convert polygons to drainage objects
With this function, you can convert polygons to any of the following drainage objects:

rivers
floodlines
dams

catchments

Do one of the following:
Choose Extras > Convert Polygon to > River.
Choose Extras > Convert Polygon to > Floodline.
Choose Extras > Convert Polygon to > Dam.
Choose Extras > Convert Polygon to > Catchment.
Select the polygons that you want to convert, and then press ENTER.

The polygons are converted to the drainage objects that you specified, and the drawing is updated
accordingly.

Creating drainage data

70



Exporting drainage objects to LandXML

Munsys Drainage provides tools for the engineers and technicians to exchange Munsys storm
water data with other engineering software that supports LandXML format. With Munsys
Drainage, you can export stormwater node, pipe and culvert object data to LandXML data
format.

The exported LandXML data includes pipe and culvert attributes such as material, diameter,
gradient, length and unique GID, while the node attributes include the unique Node ID, node
type, cover and invert levels and connecting Pipe GIDs.

The XML export function in Munsys Drainage is available for storm water pipes, storm culverts
and all drainage nodes. The pipe, culvert and node spatial and attribute data can then be
imported into other applications.

LandXML data file Elements
The XML export file consists of 5 main sections, namely:

Header

Units

Project Name

Application version

Pipe Networks
Node Structures

Pipe Structures

Header

The file header records the LandXML language, version number, the date and time that the
XML file was created. the file header also references the XML websites displaying XML
definitions.

<LandXML xmlns="http://www.landxml.org/schema/LandXML-1.1"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance”
xsi:schemaLocation="http://www.landxml.org/schema/LandXML-1.1 http://www.landxml.org/schema/LandXML-
1.1/LandXML-1.1.xsd" date="2022-09-11" time="07:45:33" version="1.1" language="English" readOnly="false">

Units

The Units for the XML export are defined for both Imperial and Metric. If the locale for the
schema is set to US the Imperial units are applied, whereas if the locale for the schema is set to
INT, AUS or AUS2, the Metric units are applied. The Imperial units are used as the default if
no locale is set.

<Units>

<Imperial areaUnit="squareFoot" linearUnit="foot" volumeUnit="cubicYard" temperatureUnit="fahrenheit"
pressureUnit="inchHG" diameterUnit="inch" angularUnit="decimal degrees" directionUnit="decimal degrees" />

</Units>
Example of Units for US schemas
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Note

<Units>

<Metric areaUnit="squareMeter" linearUnit="meter" volumeUnit="cubicMeter" temperatureUnit="celsius"

pressureUnit="mmHG" diameterUnit="millimeter" angularUnit="decimal degrees" directionUnit="decimal degrees"

/></Units>

Example of Units for INT, AUS or AUS2 schemas

The following table denotes the different Imperial and Metric units referenced in the XML

export file.

Unit Type Imperial Metric

Area squareFoot squareMeter
Linear foot meter

Volume cubicYard cubicMeter
Temperature fahrenheit celsius

Pressure inchHG mmHG
Diameter inch millimeter
Angular decimal degrees decimal degrees
Direction decimal degrees decimal degrees

Figure 33 Imperial and Metric Units

Project Name

The Project information in the XML file refers to the folder name and the AutoCAD drawing
name from which the storm water data was exported.

<Project name="C:\Munsys15.1\Munsys.dwg" />

Application version

The Application data creates information pertaining to the Munsys version used to generate the

XML file. The Author tag stores the username of the person who created the XML file.

<Application name="Munsys" desc="Munsys" manufacturer="Open Spatial Pty Ltd" version="15.1"

manufacturerURL="www.openspatial.com" timeStamp="2022-09-10T08:03:03">

<Author createdBy="MCITY15US" createdByEmail="" company="" companyURL="" timeStamp="2022-12-

10T08:03:03" />
</Application>

The application version information is not editable from within Munsys.
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Node Structures

The Drainage Nodes are exported with the following XML data elements:

<Struct name="MUNID-1472" desc="MANHOLE" elevRim="482.268" elevSump="481.268">
<Center>415223.28079906 218553.75873292</Center>
<CircStruct diameter="48.0" thickness="0.5" />

<Invert elev="479.807" flowDir="Out" refPipe="MUNID-113158" />

</Struct>

The following table shows the storm water node attributes exported to LandXML format:

Elements

Struct name

‘ Example

"MUNID-1472"

‘ Description

This value refers to the unique node ID
(NODE_ID) in SP_SWNODE.

desc

"MANHOLE"

This value refers to the node type
(NODE_TYPE) in SP_SWNODE.

elevRim

"482.268"

This value refers to the ground level
(NODE_GL) in SP_SWNODE.

elevSump

"481.268"

This value is calculated by subtracting the
node depth value (NODE_DEPTH)
from the ground level value (NODE_GL)
in SP_SWNODE.

Center

415223.28079906
218553.75873292

This value refers to the physical insertion
point of the node (GEOMETRY) in
SP_SWNODE.

CircStruct diameter

"48.0”

This value is the default diameter assigned
to the node.

thickness

"0.5"

This value is the default thickness assigned
to the node.

Invert elev

"479.807"

This value is the invert level of the
connected pipe or culvert. (END_IN-
VELEV from SP_SWPIPE if AowDir is
"IN" or START_INVELEV from
SP_SWPIPE if AlowDiris "OUT").

flowDir

"Inll Or n Out”

This value determines if the pipe or cul-
vertis incoming or outgoing.

refPipe

"MUNID-113158"

This value is the pipe GID of the
connected pipe in SP_SWPIPE or the

GID of the connected culvert in

SP_SWCULVERT.

Figure 34

LandXML Node attributes
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Pipe Structures

The Storm Water Pipes are exported with the following XML data elements:

<Pipe name="MUNID-113158" refEnd="MUNID-4304" refStart="MUNID-1472" desc="CONC"
length="130.946000" slope="0.03758038">

<CircPipe diameter="33.00" thickness="0.25" />

</Pipe>

Example of Storm Water Pipe for US schemas

The following table shows the storm water pipe attributes exported to LandXML format:

Elements ‘ Example ‘ Description

Pipe name "MUNID-113158" | This value refers to the unique pipe GID in
SP_SWPIPE .

refEnd "MUNID-4304" This value refers to the end node ID
(END_NODE) in SP_SWPIPE.

refStart "MUNID-1472" This value refers to the start node ID
(START_NODE) in SP_SWPIPE .

desc "CONC" This value refers to the pipe material
(PIPE_MATRL) in SP_SWPIPE.

length "130.94600" This value refers to the length of the pipe
(GEOM_LENGTH) in SP_SWPIPE.

slope "0.03758038" This value refers to the pipe gradient
(PIPE_GRADIENT) in SP_SWPIPE.

CircPipe diameter | "33.00" This value is the pipe diameter (PIPE_DIA) in
SP_SWPIPE.

thickness "0.25" This value is the default pipe thickness used to
represent the pipe for US schemas.

Figure 35  LandXML Pipe attributes
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Culvert Structures

The Storm Water Culverts are exported with the following XML data elements:

<Pipe name="MUNID-202298" refEnd="MUNID-4388" refStart="MUNID-4387" desc="CONC"
length="360.889000" slope="0.02727154">

<RectPipe height="2.00" width="60.00" thickness="0.25" />

</Pipe>

Example of Storm Water Culvert for US schemas

The following table shows the storm water culvert attributes exported to LandXML format:

Elements ‘ Example ‘ Description

Pipe name "MUNID-202298" | This value refers to the unique culvert GID
SP_SWCULVERT.

refEnd "MUNID-4388" This value refers to the end node ID
(END_NODE) in SP_SWCULVERT.

refStart "MUNID-4387" This value refers to the start node ID
(START_NODE) in SWCULVERT.

desc "CONC" This value refers to the culvert material
(CLVT_MATRL) in SP_SWCULVERT.

length "360.889000" This value refers to the length of the culvert
(GEOM_LENGTH) in SP_SWCULVERT.

slope "0.02727154" This value refers to the culvert gradient
(CLVT_GRADIENT) in SP_SWCULVERT.

RectPipe height "2.00" This value is the culvert depth
(CLVT_DEPTH) in SP_SWCULVERT.

width "60.00" This value is the culvert width
(CLVT_WIDTH) in SP_SWCULVERT.

thickness "0.25" This value is the default culvert thickness used
to represent the culvert for US schemas.

Figure 36 LandXML Culvert attributes
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Exporting drainage nodes, pipes and culverts to LandXML

Before you export the storm water nodes, pipes and culverts to LandXML format you will first
query the drainage network into the AutoCAD drawing area using the Munsys Query
functionality. For more information about querying data from the database, please consult the
Munsys Concepts User Manual. You can select in which projection the data is queried into by
selecting the Extras > Set Coordinate System menu option.

To export the drainage network objects, do the following:

Choose Extras > Export Objects to > Land XML.

Select the drainage entities that you want to export, and then press ENTER.
The command indicates the number of pipes and nodes selected.

The Save File As dialog box is displayed.

On this dialog box, specify the filename and folder where the .xml file will be saved to. The default
destination is C:\Munsys15.1\Munsys.xml

<Pxml versi 1.0 25
"http://www.landxml .org/schema/LandsML-1.1" xmlns:xsi="http://www.w3.org/2001/xMLSchema-instance" x3i:sche:
//www.landxml .org/schema/Land/ML-1.1 http://www.landxml.org/schema/Land/ML-1.1/Land/ML-1.1.xsd" date="2022-12-05" t
'1.1" language="English" r ="false" >

ric a ="meter"

"squareMeter” line "cubicMster" temperaturelnit="celsius" pressureUnit="mmHG" diameterUnit=

"millimeter” ang
</Unita>
<Project name=" C:\MCITY15.O\Mmsys.dwg " />
E<Application name="Munsys" desc="Munsys" manufacturer="Open Spatial Pty Ltd" version="15.0" manufacturerURL="www.openspatial.com" timeStamp
="2022-12-05T16:37:55" >

= "MCITYISINT createdByBmail="" company="" companyURL="* timeStamp="2022-12-05T16:37:55" />

larUnit="decimal degrees" dirscti decimal degrees" />

ipeNetworks>

ipeNetwork name=

Structs>
uet name="MUNID-146" &
ter>-2887745.011 -7236
diameter="16.0
614.546" £1
"1614.546" flowDir="in" refp

elewSump="1614.546" >

MUNID-109268" />
"MUNID-202166" />

</struce>
"}'ZStru:b name="MUNID-137" desc="WING WALL"

ter>-2887747.031 -72365.309</Center>

="MUNID=4354"
"MUNID-130" d

"MUNID-109268"
<CircPipe diameter="900" thick
< pes

" refStart="MUNID-146" desc="CONC" length="2.021000" slope="0.00692726" >

"MUNID-202166"
"MUNID-109267"

"82.309000" sl
"80.151000" sl

0.0017495" >
0.0127135" >

</Pipes>

</PipeNetwork>

</PipeNetworks>
</ LandXML>

Figure 37 Example of the LandXML export file
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Importing drainage objects from LandXML

Note

By importing XML data you can easily update existing drainage objects” attributes with new
values that have been calculated from 3rd party design and analysis applications, such as
AutoCAD Civil 3D.

If the Munsys drainage objects have already been queried into the current drawing when the
XML file is imported, drainage objects with matching IDs will automatically be updated with
the attributes from the XML file. The nodes, pipes and culverts will immediately change to the
Munsys Integrity color indicating that attribute values have changed and must be checked
before posting to the database.

If the objects being imported from the XML file cannot find existing Munsys objects with
matching IDs in the current drawing, new CAD objects are created. The nodes are imported
onto a default layer STORM-NODE-MUNSYS, while the pipes and culverts are imported
onto the default layer STORM-PIPE-MUNSYS. Using the conversion tools available in
Munsys Drainage, these new objects can be converted from CAD entities to drainage objects
ready for checking and posting to the database.

To import drainage objects from LandXML

The XML width and depth attributes are ignored for updates to culverts when the XML data is imported.
To import the XML data, do the following:

Choose Extras > Import Objects from > LandXML.

The Select LandXML to Import dialog box is displayed.

On this dialog box, specify the filename and folder where the .xml file will be imported from. The
default folder is C:\Munsys15.1\

Once the filename is selected choose the Open button.

Existing Munsys drainage objects are automatically updated with the XML attribute data, and their
color is changed to the Munsys Integrity color.
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Exporting drainage objects to CZML

Munsys Drainage provides the tools for users to take the 2 ¥2D Munsys storm water data and
recreate as full 3D geospatial data using the pipe and node invert levels and depths to generate
accurate, open source CZML files. CZML is a JSON format for describing graphical data in a
3D context or primarily for display Digital Twin environments such as Cesium or Terria.io, as
well as CSIRO’s Data61 open data platform. These 3D data files can then be displayed in
Digital Twin Environments such as Cesium virtual globe or Terria.io where global 3D terrain,
imagery and building infrastructure are used to provide full 3D geospatial visualization in
context and integrated with active environments. With Munsys Drainage, you can export
stormwater node and pipe object data to CZML data format.

The way the selected data is displayed in the web browser is defined in the configuration file
called xtrExportCZML_Def.ini. If you used the default installation path when installing the
Munsys applications, the .ini file is located in C:\Program Files\Open Spatial\MunApps15.1. It
is recommended that this file be copied to another folder before it is edited.

The configuration file is also used to specify which attributes to display, to set the color and
opacity for solid filled objects, to set line widths and colors for line and polyline objects, and to
define which object type and color to represent node type objects.

The resultant CZML file contains a single JSON array for each object selected in the drawing,
where each object-literal element in the array is a CZML Packet. A CZML Packed describes the

graphical properties for a single object in the scene, such as a drainage node and pipe.

The user must first query the drainage nodes and pipes into the drawing that they want to
include in the CZML file. The definition file must be configured to include the attribute
parameters to be exported with the spatial object. Drainage culverts and channels are not
supported for the CZML export process.

CZML Export configuration file
The configuration file (xtrExportCZML_Def.ini) is installed as part of the Munsys

Applications and stores all the parameters and settings required to interpret data which is
« »
converted” to a CZML format.

The default configuration file xtrExportCZML.ini resides in the application folder C:|Program
Files|\Open Spatiall MunApps15.1 is populated with “example” parameters. It is recommended
that this configuration file be copied to C:|Munsys15.1 before it can be edited.

The following parameters are required to export storm water pipes to CZML format:
ID_DESCRIPTION: Indicates the object is a drainage pipe i.e., Pipe

NAME_DESCRIPTION: Populates the Name variable in the CZML packet header i.c.
Stormwater Pipe.

MUN_ID: The Unique identifier (MUN_ID) which references the spatial table within
the Munsys schema from which the spatial and attribute data is extracted, i.e., 65 =
SP_SWPIPE

START_HEIGHT: Reads the Start Invert Level value from the column START _IL.
END_HEIGHT: Reads the End Invert Level value from the column END_IL.
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PIPE_DIA: Reads the culvert width value from the column PIPE_DIA.

COLOR_RGBA: Sets the color used to represent the storm water pipe using the RGBA
format [255,255)255)255]

ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in the
CZML export file and there may not be spaces between the comma separators, i.e., PIPE_-
TYPE,PIPE_MATRL,PIPE_DIA,START _GL,END_GL.

ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions must
match the order of the column names, and there may not be spaces between the comma
separators, i.e., Pipe Type,Pipe Material,Pipe Diameter,Start Ground Level,End Ground Level.

CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. Storm
Pipes can be represented as a PIPEVOLUME output type.

[STORMWATER PIPE - Cravity]
ID DESCRIPTION=Pipe
NAME DESCRIPTICN=Stormwater Pipe Gravity
MUN ID=65
START HEIGHT=START IL
END HEIGHT=END IL
PIPE DIA=PIPE DIA
COLOR RGBA=0,255,0,255
ATTRIBUTE COLUMN NAMES=PIPE TYPE,PIPE MATRL,PIPE DIA, START GL,END GL
ATTRIBUTE COLUMN DESCRIPTIONZ=Pipe Type, Pipe Material,Pipe Diameter,Start Ground
Level ,End Ground Level
CEML OUTPUT TYPE=PIPEVOLUME

Figure 38  Example of a CZML export file for Storm water pipes

The following parameters are required to export storm water manholes to CZML format:
ID_DESCRIPTION: Indicates the object is a storm water node i.e., Node
NAME_DESCRIPTION: Populates the Name variable in the CZML packet header i.e.

Stormwater Manhole.

MUN_ID: The Unique identifier which references the spatial table within the Munsys
schema from which the spatial and attribute data is extracted, i.e., 63 = SP_SWNODE

NODE_TYPE: Filters the selection based on the node type value from the column
NODE_TYPE i.e: MANHOLE

NODE_HEIGHT: Reads the Ground Level value from the column NODE_GL.
NODE_DEPTH: Reads the Node Depth value from the column NODE_DEPTH.

COLOR_RGBA: Sets the color used to represent the storm water node using the RGBA
format [255,255,255,255] i.e., 128,255,128,255

ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in the
CZML export file and there may not be spaces between the comma separators, i.e.

NODE_ID,NODE_FUNC,NODE_REFE

ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions must
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match the order of the column names, and there may not be spaces between the comma
separators, i.e. Node ID,Node Function, Node Referrence.

CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. Man-
holes can be defined as a TUBE.

TUBE_RADIUS: Sets the radius for the TUBE object type.

COLOR_RGBA: Sets the color used to represent the storm water manhole using the
RGBA format [255,255,255,255]

[STORMWATEER NODE - Manhole]
ID DESCRIFTICN=Node
NAME DESCRIPTION=StormwWwater Manhole
MUN ID=63
NCDE TYPE=MANHOLE
NODE HEIGHT=NODE GL
NCDE DEPTH=NODE DEPTH
ATTRIBUTE COLUMN NAMES=NODE ID,NODE FUNC,HODE REF
TTRIBUTE COLUMN DESCRIPTICNS=Node ID,Node Function,Node Reference
'OLOR RGB2=0,0,255,255
ZML COUTPUT TYPE=TUEE
UBE RADIUS=1.5

i

H M0

Figure 39 Example of a CZML export file for Storm water manholes

The following parameters are required to export storm water curb/kerb inlets to CZML format:

ID_DESCRIPTION: Indicates the object is a storm water node, i.e. Node

NAME_DESCRIPTION: Populates the Name variable in the CZML packet header i.e.
Stormwater Kerb Inlet.

MUN_ID: The Unique identifier which references the spatial table within the Munsys
schema from which the spatial and attribute data is extracted, i.e., 63 = SP_SWNODE

NODE_TYPE: Filters the selection based on the node type value from the column
NODE_TYPE, i.e: KERB_INLET

NODE_HEIGHT: Reads the Ground Level value from the column NODE_GL.
NODE_DEPTH: Reads the Node Depth value from the column NODE_DEPTH

COLOR_RGBA: Sets the color used to represent the storm water node using the RGBA
format [255,255,255,255] i.e., 128,255,128,255

ATTRIBUTE_COLUMN_NAMES: List of all attribute columns to be included in the
CZML export file i.e., NODE_ID,NODE_FUNC,NODE_REF

ATTRIBUTE_COLUMN_DESCRIPTIONS: List of all attribute column descrip-
tions to be included in the CZML export file. The order of the column descriptions must
match the order of the column names i.e., Node ID,Node Function,Node Reference.

CZML_OUTPUT_TYPE: The Object type used to represent the spatial object. Kerb
Inlets can be defined as a BOX.
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3

BOX_SIZE: Sets the Length and With dimensions for the BOX object type which can
be read from the Node Sizes defined for the Kerb Inlet i.e. NODE_SIZE1,NODE_-
SIZE2

[STORMWATER. HODE - Kerb Inlet]

ID DESCRIPTICN=Node

NAME DESCRIPTION=Kerb Inlet

MUN_ID=63

NODE TYPE=KERE TNLET

DE HEIGHT=NODE_GL

DE DEPTH=NODE DEPTH

COLCOR RGBA=128,255,128,255

ATTRIBUTE ’LL‘;*ﬂ\T_I\TAka.G:NODE_ID,NODE_E‘U‘NC,NODE_REF
ATTRIBUTE COLUMN DESCRIPTIONS=Node ID,Node Function,Node Reference
CEML OUTPUT TYPE=BOX

Bul’_:IZn—NDDE_SIZEl HODE SIZEZ

=

T
VO
T
e

=

Figure 40  Example of a CZML export file for Storm water Kerb inlets

Exporting drainage nodes and pipes to CZML

Before you export the storm water nodes and pipes to CZML format you will first query the
drainage network into the AutoCAD drawing using the Munsys Query functionality. For more
information about querying data from the database, please consult the Munsys Concepts User
Manual. When the data is exported to CZML format, the geometry for each object is
transformed to WGS84 (X;Y;Z values).

To export the drainage network objects, do the following:
Choose Extras > Export Objects to CZML.
The CZML ini File dialog box is displayed.

Navigate to the folder where the modified configuration file was copied to i.e. C:|Munsys15.1, else
navigate to C:|Program Files|Open Spatial|lMunApps15.1.

B czvL ini File
Lok in: | = Munfpps15.1 @ ®emE- =
IS

MName Date modified
Docs 03/04/2025 13:32
Drawings 03/04/2025 13:32
MapARKX 03/04/2025 13:32
Symbols 03/04/2025 13:32
UserDataCache 03/04/2025 13:32

12| wtrExportCZML_Def.ini 03/04/2025 11:31

Fle name: [ xtrExportCZML_Def i v Open

Files of type:  “ini ~ Cancel

Locate Find File. ..

Figure 41  Selecting the Drainage Configuration file

Select the configuration file to apply to the export, then select OPEN.
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4  The Save File As dialog box is displayed and defaults to the folder C:\Munsysi5.1.

B save CZMLas X
Savein: Munsys15.1 «| @ F = Er @ =
Mame . Date modified

Mo items match your search.

File name: Munsys.czml - | [ Sate

Save astype: “.czml ~ Cancel

Figure 42 Entering the Drainage Export File name

5  On this dialog box, specify the file name and folder where the resultant .czml file will be saved to.
The default destination folder is C:\Munsys15.1.

6  In AutoCAD, at the command line, you are prompted to select the drainage entities to export, and
then press ENTER.
The command indicates the number of objects selected.

7 At the command line the date and time stamp of when the export started and ended is displayed.

Select objects:

"28/83/2024 Time: 89:55:38"
/¥ Export Completed...

"28/83/2824 Time: @39:55:31"

Command:

8  Opening the CZML file in a text editor displays the file contents which contains a single JSON array
for each object selected in the drawing where each object-literal element in the array is a CZML
Packet.
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[
{
"id": "document",
"name”: "CZML Geometries: Polyline™,
"version®: "1.0"

.
{
"id": "Pipes",

"name": "Stormwater Pipe Gravity",

"description®: "crable><rr><td>Pipe Diameter</td><rd>€00</td></eracer><td>Pipe Typed/td><rd>D50¢/ed></r><rra<td> Pipe Materiald/ed><td>CONCE/td></Tracer>crd>Stare Ground
[Level</cd><td>1616.484</cd></tr><tr><td>End Ground level</vd><td>1616.293</td></tr></table>",

"polylineVolume®: {

"positions®: {

"cartographicDegrees™: [28.25111955063326,-26.075658594€609501, 1614.731, 28.25122277785745,-26.075644€7872116, 1614.540]

e

"shape™: {

"cartesian2":
[0.283655572€79795,-0.097670446337147,0.2331437884370913,-0.1887961173149511,0.1545114224730162,-0.2571501902106336,0.05724269861296327, -0.2944881550342992,-0.04693033951206
931,-0.2963065021785412,-0.1454428860735012, -0.2623859121418186,-0.2264128740668315,~0.1968177086571522,~-0.2800741279491605,-0.1075103848635801, -0.2995543085469173, -0.005235
721931184958, -0.283655572675795,0.09767044633714696,-0.2331437884370912, 0. 1887961173149512,-0.15451142247301€2,0.2570501902106336, -0, 0572426906129€344, 0.2944881550342592,0.0
4693033951206527,0.2963065021785413,0.145494280860739011,0.2623850121418187,0.2264128740668315,0.1968177086571521,0.2800741279451605,0,10751038486359,0.2509543085465173,0.0052
35721931185053]

be

"cornerType": "SEVELED",

"material®: {

"solidColoz®™: {

"color™: {"rgba": [0, 255, 0, 255]

}
}
}

.
clanpTofround®: true

"Kerb Inlet®,

"description®: "<table>ctr><td>Node ID</td><td>4Sl</td></tr><tr><td>Node Function</td><td></td></tr></table>",
"position”: {

"cartographicDegrees™: [28,251449415448063,-26,07581552020803, 1614.7%¢)
e

"box": {

"dimensiona®: {

"cartesian®: [NODE_SIZEl, NODE SIZE2, 1.753]

b

"material®: {

"solidColoz”™: {

"color®: {"zgba®: [128, 255, 128, 255)

}

'

Figure 43 Example of the CZML export file for a Storm water pipe and node object
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Chapter 5
Maintaining drainage data

Modifying drainage data

Spatial data is stored in spatial and attribute tables as records. Users can edit spatial data by
retrieving it from the database, and then changing characteristics or attributes using the
Change menu and toolbar. Drainage objects are retrieved onto their respective layers, for
example, SWPIPE, SWNODE or SWNOTE. Attribute data can be edited directly in its table

format.

Once stormwater pipes, culverts, channels and nodes have been placed, they have to be
manipulated to make certain that they are joined correctly, for example with no overlaps or
undershoots. Each pipe has to have a start and end node.

Attribute values linked to drainage objects can be modified easily from the Change menu, for
example pipe diameter, width and depth, and river, floodline and dam types.

Drainage objects that have been changed need to be validated against the applicable business
rules before they can be posted to the database.
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Changing drainage objects

To extend a drainage object to a boundary

Drainage objects (stormwater pipes, culverts, channels and rivers) can be extended to a
boundary object by first indicating the boundary object, and then selecting the object to extend.
The boundary object must be able to intersect with the drainage object. This function is often
used to extend pipes, channels or culverts to create Tjunctions during capture. The end point
of the object is then changed to intersect the boundary object.

Do one of the following:
Choose Change > Extend Drainage Object to Boundary.

Click the Extend Drainage Object to Boundary button on the
Munsys Drainage Change toolbar.

2NN YN

\
Select the boundary object where the object has to extend to.

Select the object that needs to extend.

The object is extended as indicated.

To extend a drainage object by distance

This function extends a drainage object (pipe, culvert, channel or river) with a specified distance
at the endpoint closest to a selected point on the object. You are prompted for the distance to
extend the object with. You can also use this function to shorten a drainage object by entering
a negative distance, for example -50.

Do one of the following:
Choose Change > Extend Drainage Object by Distance.

Click the Extend Drainage Object by Distance button on the
Munsys Drainage Change toolbar.

. &

X /k)| AL

Select the object that you want to extend.
Enter a distance on the command line.

The drainage object is extended as indicated.

To extend a drainage object and break it at the intersection

This function extends a drainage object (pipe, culvert, channel or river) to a boundary pipe,
culvert, channel or river that is then broken at the intersection. The object to be broken is
selected first, and then the object to extend. The object to be broken must be able to intersect
with the second object.

Maintaining drainage data
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Do one of the following:
Choose Change > Extend and Break Drainage Object.

Click the Extend and Break Drainage Object button on the
Munsys Drainage Change toolbar.

. |

‘)\/i|u(—/ I
\

Select the drainage object that you want to break.
Select the object that you want to extend.

The objects are extended and broken respectively, as indicated.

To break a drainage object

This function breaks a drainage object (pipe, culvert, channel or river) nearest to a selected

point on the object.

Do one of the following:

Choose Change > Break Drainage Object.

Click the Break Drainage Object button on the Munsys Drainage Change toolbar.

. | &

5?)\/)|n‘k.i""/ i
\

Select the drainage object that you want to break.

Specify a break point on the object that you selected.

The drainage object is broken at the break point that you specified.

Maintaining drainage data
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To change a drainage object
With this function, you can move the endpoint of one or more selected drainage objects (pipes,
culverts or channels) to a new location.

Do one of the following:
Choose Change > Change Drainage Object.
Click the Change Drainage Object button on the Munsys Drainage Change toolbar.

)\ /)|nu uk')“/ nu
\

Select the drainage object that needs to move.

. |

Specify the destination point.

The end point of the object is moved to the destination point that you specified.

To fillet a drainage object
This function connects two drainage objects (pipes, channels, culverts or rivers) at an apparent
intersection.

Do one of the following:
Choose Change > Fillet Drainage Object.
Click the Fillet Drainage Object button on the Munsys Drainage Change toolbar.

. |

F?)\/)|nuui'rk-/ .-
\

The command line will prompt you to indicate the two drainage objects that need to be extended
or trimmed.

Select the first object.
Select the second object.

The objects are connected as indicated.

Maintaining drainage data
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To join drainage objects

This function is used to join two drainage objects (stormwater pipes, culverts or channels),
creating a single object. The attributes from the first object selected remain the attributes for
the joined object. If there is a gap between the two objects to be joined, they are joined with a
line segment. A joined object is created from the geometry of the first object selected, and the
second object selected is moved to the DELETED layer. The first selected object, now the new
joined object, is flagged as a change to be verified when the integrity check is run.

Choose Change > Join Drainage Object.
Select the first drainage object (the object that you want to join to).
Select a point close to the endpoint of the second object (the object that you want to join).

The objects are joined as indicated, and the attributes from the first object selected remain the
attributes for the joined object.

To trim a drainage object
You can trim a section of a drainage object (pipe, culvert, channel or river) by first selecting the
cutting edge, and then selecting the section of the object to be removed. The cutting edge must
be a line that intersects the drainage object.
Do one of the following:

Choose Change > Trim Drainage Object.

Click the Trim Drainage Object button on the Munsys Drainage Change toolbar.

. |

5?)\/)|n‘ - iV‘/kn"
\

Select the object that you want to trim to.
Select a point on the side of a second object that needs to be trimmed.

Munsys trims the last indicated drainage object to the first one.

Maintaining drainage data
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Note

_ W N

- W N

To change the vertex of a drainage object

With this function, you can remove, move, add or insert new vertices to segments in a

stormwater pipe, culvert, channel or river.

To add a vertex to a drainage object

Choose Change > Change Drainage Object Vertex > Add.
Select the applicable drainage object.

Select the segment endpoint.

Select the position for the new point.

A vertex is added at the new point that you selected.

To move a drainage object vertex

Choose Change > Change Drainage Object Vertex > Move.

Select the applicable drainage object.
Specify a point closest to the vertex that you want to move.
Specify the point that you want to move the vertex to.

The vertex is moved to the point that you specified.

To remove a drainage object vertex

Choose Change > Change Drainage Object Vertex > Remove.

Select the applicable drainage object.

Select the vertex that you want to remove from the drainage object.

A vertex can only be removed from a drainage object containing more than two vertices.

To insert a vertex into a drainage object

Choose Change > Change Drainage Object Vertex > Insert.

Select the applicable drainage object.
Select the segment for the inserted point.

Select the position for the new point.

The vertex is inserted in the position you selected.

Maintaining drainage data
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Moving a node

With this function, you can move a node to a new location by first selecting the node, and then
specifying the point where you want to place it. This function is often used to move a node to

a new pipe, channel or culvert endpoint.
To move a node

1 Do one of the following:
Choose Change > Move Node.
Click the Move Node button on the Munsys Drainage Change toolbar.

)\ /)|nu - ')“/ nu

NCd
\

2 Drag-and-click the node to the desired destination point.

The node is moved to the destination point you indicated.

o

(r‘\\/

i .

Figure 1 Moving a node
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Rotating a node

With this function, you can rotate one or more selected nodes. The rotation angle is specified
by typing the angle on the command line, indicating the angle with the mouse pointer or
specifying an object to align the node with.

To rotate a node

1 Do one of the following:
Choose Change > Rotate Node.
Click the Rotate Node button on the Munsys Drainage Change toolbar.

2 Select the node that you want to rotate.

3  To specify the rotation angle, do one of the following:
Enter the rotation angle on the command line, or press ENTER to accept the default angle.
Indicate the angle with your mouse pointer by picking two points in the drawing.

On the command line, type A to align the node to a segment, press ENTER, and then select the
object to which you want to align the node.

The node is rotated as specified.

Snapping a node to the endpoint of a drainage object

With this function, you can snap a node to the endpoint of a drainage object. The node is
moved to the end point closest to the point selected on the drainage object.
To snap a node to the endpoint of a drainage object

1 Do one of the following:

Choose Change > Snap Node to Endpoint.
Click the Snap Node to Endpoint button on the Munsys drainage Change toolbar.

2 Select the applicable node.
3 Select the drainage object close to the endpoint that you want to snap the node to.
The node is snapped to the endpoint of the drainage object.

Snapping a node to the endpoint of a drainage object, breaking the drainage object

With this function, you can break a drainage object and snap a node to the endpoint of the
broken drainage object
To snap a node and break a drainage object

1 Do one of the following:

Choose Change > Snap Node and Break Drainage Object.

Click the Snap Node and Break Drainage Object button on the Munsys drainage Change
toolbar.

Maintaining drainage data
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Select the applicable node.

Select the drainage object that you want to snap the node to.
Specify a break point on the drainage object.
The node is snapped to the endpoint of the broken drainage object.

Changing a node type

With this function, you can change the node type of one or more selected nodes. The new node
type is selected from a list. The symbol name and the NODE_TYPE column are updated

according to the new node type selected.

To change a node type

Choose Change > Change Node Type...

Select the node(s) that you want to change, and then press ENTER.
The Node Types dialog box is displayed.

Node Types

Kerb Inlet

Drop Inlet

Manhaole

Junction

Wingwall

End Cap

Pump Station (Public)
Pump Station (Private)

Figure 2 The Node Types dialog box

Select the new node type from the list, and then click OK.

The node type is changed as indicated. It is flagged as a change to be verified with the integrity

check, and the new node is displayed in the integrity color.

Maintaining drainage data
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Changing drainage attribute data

With Munsys Drainage, you can change the physical attributes of stormwater objects, for
example material, diameter, type, depth, etc. You can also change pipe, culvert, channel and
node levels. You can also change a service connection type and link service connections to their
respective parcels.

Editing drainage object attributes

The Edit Attributes function is used to edit the attributes of one or more selected drainage
objects that belong to the same object type. The current application determines what object
types may be selected; for example, if you are working in Munsys Drainage, only drainage
objects may be selected. If you select more than one object type (for example pipes and nodes),
you will be required to choose a single object type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database).
Once the objects have been selected and an object type to edit has been specified, the Edit
Attributes dialog box is displayed. This dialog box contains various options that can be used to
edit the attributes of the spatial objects:

Attribute templates — attributes can be edited using an attribute template. The attributes
that will be displayed when an attribute template has been selected will depend on the
attributes that have been specified on the template, as well as the formatting parameters that
apply to each column selected as part of the attribute template. If no attribute template has
been selected, all the attributes belonging to the spatial object type are displayed.

Editing multiple objects simultaneously — if you select this option, attributes of multiple
objects are displayed simultaneously. Where the attributes of all the selected objects are the
same, a value is displayed. Where attributes of the various objects that were selected differ,
a value of *VARIES* is displayed. When a change is made to a value, the new value is
applied to all the selected objects. If you do not select the Edit multiple objects
simultaneously check box, you can edit the selected objects one by one. The values that are
changed are only applied to the object that is currently selected.

AutoZoom — this option is only available when the Edit multiple objects simultaneously
option is not selected, i.e. when you are going to edit the objects one by one. If the
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as
it becomes the current object, and highlight it. The object navigation buttons are used to
move from one object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns:
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values
that may not be edited are unavailable. Attributes are edited in the Value column, either by
typing a new value or by selecting a value from a drop-down list. Changes that are made are
applied to objects in the drawing. These changes will only be updated in the database when the
object integrity check has been run and the objects have been posted to the database.

When editing attributes, mandatory fields are displayed with an “!” character prefixing the
attribute column in the Attributes list on the Edit Attributes dialog box. If the mandatory
attribute is not captured for new or modified objects, the Object Integrity Check will fail based
on the attribute rules setup. Using the Browse Integrity Markers option, the Error Info describes
which column may not be NULL.
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To edit drainage objects

Choose Change > Edit Attributes...

Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object

Identification dialog box is displayed.

A Spatial Object Identification X

Select appropriate object type:

Stormwater Nodes
Stormwater Pipes

Figure 3 The Spatial Object Identification dialog box

Select a single spatial object type to edit, and then click OK.
The Edit Attributes: [Object Type] dialog box is displayed.

A Edit Attributes: Stormwater Pipes X
Attribute Template:

None L
[ ] Edit multiple objects simultaneously [ ] AutoZoom to object
Attributes:

Description Value Column Name ~

Pipe Diameter 400 FIFE_DIA

Pipe Type D 25 Stormwater Pipe PIFE_TYFE

Pipe Material Concrete PIPE_MATRL

Start Node 2426 START_NODE

End MNode 2556 END_NODE

Start Ground Level 1648.444 START_GL

End Ground Level 1648.483 END_GL

Start Invert Level 1646.691 START_IL

End Invert Level 1646.730 END_IL

Geometry Length 14.2920 GEOM_LENGTH

Comments COMMENTS

Tag X Coordinate -77474.2450 TAG_X

Tag Y Coordinate -2884113.4920 TAG_Y

Tag Value

]
Tan Hainht 1 _nnnn -
4 1of4 3 Cancel Help

Figure 4 The Edit Attributes dialog box
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Note

Highlight a value, and then choose a new value from the drop-down list in the Value column.

Highlight a value, and then enter a new value in the Value column

Mandatory attributes are displayed with an

To edit an attribute, do one of the following:

@y
.

Click OK to apply the new value(s) to the object(s).

If you want to edit the objects using an attribute template, select the appropriate attribute template
from the Attribute Template list. If you do not want to make use of an attribute template, select
None.

If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*, as
seen in the following figure:

A Edit Attributes: Stormwater Pipes x
Attribute Template:

None L
Edit multiple objects simultaneously AutoZoom to object
Attributes:

Description Value Column Name ~

GID *VARIES™ GID

Pipe ID *VARIES™ FIPE_ID

Pipe Gradient *VARIES™ FIPE_GRADIENT

Fipe Diameter 400 FIFE_DIA

Pipe Type D 25 Stormwater Pipe PIFE_TYPE

Pipe Material Concrete PIPE_MATRL

Start Node *VARIES™ START_NODE

End Mode *VARIES™ END_NODE

Start Ground Level *WVARIES* START_GL

End Ground Level *VARIES™ END_GL

Start Invert Level *VARIES™ START_IL

End Invert Level *WVARIES* END_IL

Geometry Length *VARIES™ GEOM_LENGTH

Comments COMMENTS

Tan ¥ Cnnrdinata F\VARTECH TAC Y e

4 4 Objects Cancel Help
Figure 5 The Edit Attributes dialog box: Edit multiple objects simultaneously

If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously
check box. Select the AutoZoom to object check box to zoom to the objects one by one and
highlight them. The object navigation buttons are used to move from one object to the next.

character preceding the Attribute Description. Failure to
capture mandatory attributes for new or modified objects results in the object failing the Object Integrity
Check.

The values are applied to the objects, to be verified with the object integrity check.
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Editing linked table attributes

This function is used to edit spatial object attributes that exist in linked tables. Linked table
attributes are updated directly to the database. The current application determines what object
types may be selected; for example, if you are working in Munsys Drainage, only drainage
objects may be selected. If you select more than one object type (for example pipes and nodes),
you will be required to choose a single object type to edit. You can only select objects that have
previously been posted to the database.

The link tables that can be edited using this function must be defined through an attribute
template. The applicable attribute template is selected from a list, which is created by filtering
attribute templates according to the following characteristics:

Only attribute templates associated with the current spatial object type, being edited are
included — the primary table in the attribute template is the same table from which the
spatial objects were queried.

Only attribute templates that contain linked tables are included
The linked table specified may not be a Munsys spatial table
The user must have edit privileges to the linked table

The link column used to describe the relationship with the primary table must reference a
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns:
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values
that may not be edited are unavailable. Attributes are edited in the Value column by typing in
a new value. Navigation buttons are used to move between the various records that are available
and to move from one object to the next. You can also insert records into, or delete records from
a linked table, depending on the privileges you have on the link table.

The procedure for editing linked table attributes is described in detail in the Munsys Concepts
User Manual.
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Changing pipe, culvert, channel and node levels

This function is used to change ground and invert levels for the start and endpoint of a
stormwater pipe, channel or culvert during editing. Ground and invert levels are stored with
these objects to cater for a drop manhole, where incoming pipes, channels or culverts have a
higher invert level than the outgoing ones.
To change pipe levels

1  Choose Change > Pipe Levels...

2 Select the appropriate stormwater pipe.

The Pipe Information dialog box is displayed.

Pipe Information X

Start Info End Info

Ground Level:  [LEREE Ground Level: [1648.865
Invert Level: 1646.73 Invert Level: 1647112

IE

Depth: 1.753 Depth: 1.753
Detail Info
Length: 134.9689 Gradient -353.3217

Cancel Help

Figure 6 The Pipe Information dialog box

3  From the Start Info group, change the following:
Ground level
Invert level
The Depth value is updated automatically.
4  From the End Info group, change the following:
Ground level
Invert level

The Depth value is updated automatically.

The pipe length and gradient values in the Detail Info group are calculated automatically from the
Start Info and End Info group.

5  Click OK to accept the changes you have made.

The attribute changes are accepted.
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To change culvert levels
Choose Change > Culvert Levels...

Select the appropriate culvert.

The Culvert Information dialog box is displayed.

Culvert Information *

Start Info End Info

Ground Level:  |LEIES Ground Level: [16125

= (==
(=]
sty
(%)
[#%]

Invert Level: Invert Level: 1611
Depth: 1.3 Depth: 1.5

Detail Info

Length: 109.9992 Gradient 54.9996

Cancel Help

Figure 7 The Culvert Information dialog box

From the Start Info group, change the following:
Ground level
Invert level

The Depth value is updated automatically.

From the End Info group, change the following:
Ground level
Invert level

The Depth value is updated automatically.

The culvert length and gradient values in the Detail Info group are calculated automatically from
the Start Info and End Info group.

Click OK to accept the changes you have made.

The attribute changes are accepted.
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To change channel levels
Choose Change > Channel Levels...

Select the appropriate channel.

The Channel Information dialog box is displayed.

Channel Information bt

Start Info End Info

Ground Level: [16021
Invert Level: 1601 Invert Level: 1600.6

Ground Level:

Depth: 1.5 Depth: 1.5
Detail Info
Length: 1474543 Gradient 368.6358

Cancel Help

Figure 8 The Channel Information dialog box

From the Start Info group, change the following:
Ground level
Invert level

The Depth value is updated automatically.

From the End Info group, change the following:
Ground level
Invert level

The Depth value is updated automatically.

The channel length and gradient values in the Detail Info group are calculated automatically from
the Start Info and End Info group.

Click OK to accept the changes you have made.

The attribute changes are accepted.
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To change node levels
Choose Change > Node Levels...

Select the appropriate stormwater node.

The Stormwater Node Information dialog box is displayed.

Stormwater Node Information

Node Info:

I X

Depth: Size 1: |25

Ground level: |1643.33 Size 2. (025
Cancel Help

Iﬁ

Figure 9 The Stormwater Node Information dialog box

Enter a new value for one or all of the following:
Depth
Ground Level
Size 1 — length
Size 2 — width
Click OK to apply the changes.

The attribute changes are accepted.
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Updating Levels
There is no direct corrulation between the drainage node’s cover level and depth, and the storm
pipes’ ground level , invert level and gradient. The association between the nodes and pipes is
the connectivity, which is defined in the database design.

So when one of the values is changed for either the storm water node or pipe, channel or cluvert,
the associated information is not automatically updated to the connected object, for example:

The node depth value stored with the storm water nodes is not auromatically updated when the
cover or ground level or invert levels for the attached pipes, channels or culverst are updated.

or

The start and end ground levels are not updated when the connected node’s ground level is

updated.

For this reason, menu items to update the associated nodes, pipes, channels, culverts and
gradients, based on their connectivity, can be updated or recalculated using the following menu
items:

Change > Update Levels > Node to Pipe - Updates the connecting pipes’ start/end cover
elevations and the start invert elevation using the connecting nodes’ cover/ground level and

depth.

Change > Update Levels > Pipe to Node - Updates the connecting nodes’ cover elevation
and depth using the start/end cover elevations and start/end invert elevations from the
connecting pipes.

Change > Update Levels > Recalculate Gradients - recalculates the gradient for selected
pipes, channels and culverts.

Typical Drainage As Constructed detail plan

In the typical As Constructed Design plan example below there are drainage pipes running
downstream between manholes MH106, MH107 and MH108.
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Figure 10 Typical As Constructed Design Plan
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To update pipes, culverts or channels levels with connecting nodes
In the example of updating Node to Pipe, Manholes MH106, MH107 and MH108 have the
following Node Depth and Ground Level values captured in the SP_SWNODE table:

Attribute Column Name ‘ MH106 ‘ MH107 ‘ MH108
NODE_REF MH106 MH107 MH108
NODE_DEPTH 11.26 10.22 10.11
NODE_GL 44.00 42.00 41.68

Figure 11 SP_SWNODE captured values

MH108

PIPE MH107 RIM = 4400

DEPTH=1126

NODE TO PIPE

Figure 12 Drainage nodes Cover Elevations and Depths simplified

To execute the Node to Pipe function, do the following:
Choose Change > Update Levels > Node to Pipe

Select the appropriate stormwater node(s) and then press Enter.

MH106
MH107

I".'IHlEEI_/_/_’.’_/_/_,_/—/—”‘1

Figure 13 The storm water nodes are selected

MH106
MH107

MHb_/_//"’

Figure 14 The storm water pipe attributes are updated

The command line indicates the number of pipe(s), channel(s) and culverts updated.
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The storm water pipe, channel and/or culvert color is changed to the Munsys Integrity color,
indicating that the Object Integrity check is required before posting the updates to the database.

After completing the Node to Pipe update function, the following values are calculated for the

Drainage Pipes in the SP_SWPIPE table:

higilbots Collumn Narme %\)/IIIS 1%0611;0 MH107 II\)/II[;; lfg(;nzo MH108
PIPE_GRADIENT - calculated 61.704 362.848
START_GL - calculated 44.00 42.00

END_GL - calculated 42.00 41.680

START_IL - calcualted 32.74 31.780

END_IL [not calculated] [not calculated]

Table 15  SP_SWPIPE calcualted values

The downstream end invert level values of both pipes were intentionally not calcualted since

they cannot be assumed from the downstream node depth, especially in the case of drop

manholes.

To update node levels with connecting pipes, culverts or channels
In the example of updating Pipe to Node, Pipe MH106 to MH107 and Pipe MH107 to

MH108 have the following Ground Level and Invert Level values captured in the SP_SWPIPE

table:
Attribute Column Name ]2 gon
MH106 to MH107 MH107 to MH108
START_GL 44.00 42.00
END_GL 42.00 41.680
START_IL 32.740 31.780
END_IL 31.780 31.570

SP_SWPIPE captured Ground and Invert Levels
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MH106

MH108 MH107 e oo -

PIPE M'r'.]t';" to MH108 .
] RM = 4200 L=3274 Thru
RIM= 41688 s e
IL=IN 31.57 Thru
DEPTH = 0.1 DEPTH = 1022
PIPE TO NODE

Figure 16  Drainage Pipe Ground and Invert Levels simplified

To execute the Pipe to Node function, do the following:
Choose Change > Update Levels > Pipe to Node

Select the appropriate stormwater pipes(s), channel(s) and/or culvert(s) and then press Enter.

MH106
MH107

I".'IH1ES_/_/_’.’_/_/_,_/—/—”‘1

Figure 17 The storm water pipes, channels and/or culverts are selected

MH106
MH107

wioe M

Figure 18  The storm water node attributes are updated

The command line indicates the number of nodes updated.

The stormwater nodes’ color is changed to the Munsys Integrity color, indicating that the Object
Integrity check is required before posting the updates to the database.

After completing the Pipe to Node update function, the following values are calculated for the
Drainage Nodes in the SP_SWNODE table:

Attribute Column Name ‘ MH106 ‘ MH107 ‘ MH108
NODE_DEPTH - calculated 11.26 10.22 [not calculated]
NODE_GL - calculated 44.00 42.00 [not calculated]

Table 19  SP_SEWGPIPE calcualted values

The depth of the node is calcualted form the start Invert Level of the downstream pipe and not
the end Invert Level of the upstream pipe.

Maintaining drainage data



To recalculate pipe, culvert or channel gradients

Choose Change > Update Levels > Recalculate Gradients

Select the appropriate storm water pipe(s), channel(s) and/or culvert(s) and then press Enter.

-

T

Figure 20 The storm water pipes, channels and/or culverts are selected

Figure 21  The storm water gradients are recalculated

The command line indicates the number of pipe(s), channel(s) and/or culvert(s) updated.

The storm water pipe, channel and/or culvert’s color is changed to the Munsys Integrity color,
indicating that the Object Integrity check is required before posting the updates to the database.
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Changing stormwater pipe attributes

You can change the default pipe diameter, material or type that was assigned to a stormwater
g Y g
pipe during the capture process. The new value is selected from a list to ensure data accuracy.

Tip If you construct the stormwater pipes with the default diameter, type or material set to the one used most
commonly, only pipes that have different attributes need to be changed, reducing the amount of data to be
captured.

To change stormwater pipe diameter
1  Choose Change > Change Pipe Attributes > Diameter...
2 Select the appropriate stormwater pipe(s), and then press ENTER.

The Select Stormwater Pipe Diameter dialog box is displayed, highlighting the diameter of the pipe
that you selected. If you selected multiple pipes, no current diameter is highlighted.

Select Stormwater Pipe Diameter K
Lookup Takle Information
Tahle Mame: |LU_DMS_PIPEDIA |
Search for an item by its
S h: fiai 4+— L.
A | | OCode @ Description code or description.
Code Description
200 200
300 300
375 375
400 400
450 450
475 475
heh h2h
675 675
750 750
825 825
475 475
900 00
1050 1050
1200 1200
1350 1350
1375 13758
1500 1500
2000 2000

Figure 22 The Select Stormwater Pipe Diameter dialog box

3 Select the appropriate diameter, and then click OK.
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To change stormwater pipe material

Choose Change > Change Pipe Attributes > Material...

Select the appropriate stormwater pipe(s), and then press ENTER.

The Select Stormwater Pipe Material dialog box is displayed, highlighting the material of the pipe
that you selected. If you selected multiple pipes, no current diameter is highlighted.

Lookup Takle Information

Select Stormwater Pipe Material

Tahle Name: | LU_DMS_FIFEMATREL

Search: |

| (O Code (@) Description

x

‘_

Description

Help

Search for an item by its
code or description.

Figure 23 The Select Stormwater Pipe Material dialog box

Select the appropriate pipe material from the list, and then click OK.
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To change a stormwater pipe type
1  Choose Change > Change Pipe Attributes > Type...
2 Select the appropriate stormwater pipe(s), and press ENTER.

The Select Stormwater Pipe Type dialog box is displayed, highlighting the type of the pipe that you
selected. If you selected multiple pipes, no current type is highlighted.

Select Stormwater Pipe Type *
Lookup Takle Information
Table Name: [LU_DMS_PIPETYPE |
Search for an item by its
Search: | | OCode ® Description ¢ code or description.
Code Description
D100 D 100 Stormwater Pipe
D25 D 25 Stormwater Pipe
D&O D 50 Stormwater Fipe
< >

Figure 24 The Select Stormwater Pipe Type dialog box

3  Select the appropriate pipe type, and then click OK.
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Changing culvert attributes

You may change the default width, depth, material or type that was assigned to a culvert during
the capture process. The new value is selected from a list to ensure data accuracy.

Tip If you construct the culverts in the stormwater network with the default width, depth, material or type set
to the one that is used most commonly, only culverts that have different attributes need to be changed,
reducing the amount of data to be captured.

To change culvert width
1  Choose Change > Change Culvert Attributes > Width...

2 Select the appropriate culvert/s, and then press ENTER.
The Select Culvert Width dialog box is displayed, highlighting the width of the culvert that you

selected. If you selected more than one culvert, no current width is highlighted.

Select Culvert Width X

Lookup Takle Information

Table Name: [LU_DMS_CULYERTWIDTH |

Search for an item by

Search: | | () Code (@ Description 4+— its code or description.
Code Description

1200 1200

1500 1500

1800 1800

2100 2100

2400 2400

3000 3000

300 300

Figure 25  The Select Culvert Width dialog box

3  From the Select Culvert Width dialog box, select the appropriate width, and then click OK.

The attribute changes are accepted.
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To change culvert depth
1  Choose Change > Change Culvert Attributes > Depth...
2 Select the appropriate culvert/s, and then press ENTER.

The Select Culvert Depth dialog box is displayed, highlighting the depth of the culvert that you
selected. If you selected more than one culvert, no current depth is highlighted.

Select Culvert Depth *
Lookup Takle Information
Table Name: [LU_DMS_CULVERTDEPTH |
Search for an item by its
3 h: i <4+— o
sare | | O Cade @® Description code or description.
Code Description
1200 1200
1500 1500
1800 1800
2100 2100
2400 2400
3000 3000
450 450
500 GO0
300 400
< >

Figure 26 The Select Culvert Depth dialog box

3 From the Select Culvert Depth dialog box, select the appropriate depth, and then click OK.

The attribute changes are accepted.
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To change culvert material
Choose Change > Change Culvert Attributes > Material...

Select the appropriate culvert/s, and then press ENTER.

The Select Culvert Material dialog box is displayed, highlighting the material of the culvert that you
selected. If you selected more than one culvert, no current material is highlighted.

Select Culvert Material x
Lookup Table Information
Table Name: [LU_DMS_CULVERTMATRL |
Search for an item by its
3 h: inti — ..
Fare | | O Code ® Description 4 code or description.
Code Description
BRICK. Brickwark
CONC Concrete
METAL hetal
< >

Figure 27 The Select Culvert Material dialog box

From the Select Culvert Material dialog box, select the appropriate material, and then click OK.

The attribute changes are accepted.
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To change a culvert type

Choose Change > Change Culvert Attributes > Type...

Select the appropriate culvert/s, and then press ENTER.

The Select Culvert Type dialog box is displayed, highlighting the type of the culvert that you

selected. If you selected more than one culvert, no current type is highlighted.

Select Culvert Type

Lookup Takle Information

pet

Table Name: |LU_DMS_CUL\»’ER‘I‘I’YPE

Search: | | OcCode @ Description <
Code Description

FORTAL Faortal Culvert

SKEWED Skewed

[8]9

Cancel

Help

Search for an item by
[~ its code or description.

Figure 28  The Select Culvert Type dialog box

From the Select Culvert Type dialog box, select the appropriate type, and then click OK.

The attribute changes are accepted.
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Changing channel attributes

Tip

You may change the following attributes that were assigned to a channel during the capture
process:

top width
bottom width
depth
material

type

If you construct the channels in the stormwater network with the default attributes set to the ones that are
used most commonly, only channels that have different attributes need to be changed, reducing the amount
of data to be captured.

To change the top width of a channel
Choose Change > Change Channel Attributes > Top Width...
Select the appropriate channel/s, and then press ENTER.

The Channel Top Width text box is displayed, showing the top width of the channel that you
selected. If you selected more than one channel, the text box will be empty.

Channel Top Width X

f;lll
Cancel Help

Figure 29  The Channel Top Width text box

In the text box, type the new top width, and then click OK.

The attribute change is accepted.
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To change the bottom width of a channel
Choose Change > Change Channel Attributes > Bottom Width...

Select the appropriate channel/s, and then press ENTER.

The Channel Bottom Width text box is displayed, highlighting the bottom width of the channel
that you selected. If you selected more than one channel, the text box will be empty.

Channel Bottom Width K

(1500
Cancel Help

Figure 30 The Channel Bottom Width text box

In the text box, type the new bottom width, and then click OK.

The attribute changes are accepted.

Changing channel depth
Choose Change > Change Channel Attributes > Depth...
Select the appropriate channel/s, and then press ENTER.

The Select Channel Depth text box is displayed, highlighting the depth of the channel that you
selected. If you selected more than one channel, the text box will be empty.

Channel Depth *
0
Cancel Help

Figure 31  The Select Channel Depth text box

In the text box, type the new depth, and then click OK.

The attribute changes are accepted.
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To change channel material

Choose Change > Change Channel Attributes > Material...

Select the appropriate channel/s, and then press ENTER.

The Select Channel Material dialog box is displayed, highlighting the material of the channel that
you selected. If you selected more than one channel, no current material is highlighted.

Lookup Takle Information

Table Name: |LU_DMS_CHANNELMATRL |

Select Channel Material *

C .
GABION

BRICK. Brickwark

Gahion

GRASS Grass
METAL hetal
UMHLIMED Unlined

Search: | | OCode  @Desciption  €—
Code Description
ARMOLUR Armaourflex

Search for an item by its
code or description.

Figure 32 The Select Channel Material dialog box

The attribute changes are accepted.

From the Select Channel Material dialog box, select the appropriate material, and then click OK.
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To change a channel type
1  Choose Change > Change Channel Attributes > Type...
2 Select the appropriate channel/s, and then press ENTER.

The Select Channel Type dialog box is displayed, highlighting the type of the channel that you
selected. If you selected more than one channel, no current type is highlighted.

Select Channel Type bt

Lookup Takle Information

Table Name: |LU_DMS_CHANNELTYPE |

Search for an item by its

Search: | | O Code @ Descripion 4 code or description.
Code Description

OFEN_DRAIN Open Drain

SIDE_DRAIN Side Drain

U_DRAIN |J - Drrain

W_DRAIN %~ Drain

Figure 33 The Select Channel Type dialog box

3  From the Select Channel Type dialog box, select the appropriate type, and then click OK.

The attribute changes are accepted.
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Changing river attributes

Tip

3

You may change the default type that was assigned to a river during the capture process. The
new river type is selected from a list to ensure data accuracy.

If you capture all the rivers with the default type set to the one that is used most commonly, only rivers that
have a different type need to be changed, reducing the amount of data to be captured.

To change a river type

Choose Change > Change River Attributes > Type...

Select the appropriate river/s, and then press ENTER.

The Select River Type dialog box is displayed, highlighting the type of the river that you selected. If

you selected more than one river, no current type is highlighted.

Select River Type bt

Lookup Takle Information

Table Name: [LU_DMS_RIVERTYPE |

Search for an item by

search: | | OCode @ Description 4 its code or description.
Code Description

MNOM_PEREMNMIAL MNan - Perennial

PEREMMNIAL Perennial

STREAM Stream

Figure 34 The Select River Type dialog box

From the Select River Type dialog box, select the appropriate river type, and then click OK.

The attribute changes are accepted.
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Changing floodline attributes

You may change the default type that was assigned to a floodline during the capture process.
The new floodline type is selected from a list to ensure data accuracy.

Tip If you capture all the floodlines with the default type set to the one that is used most commonly, only
floodlines that have a different type need to be changed, reducing the amount of data to be captured.

To change a floodline type
1  Choose Change > Change Floodline Attributes > Floodline Type...
2 Select the appropriate floodline/s, and then press ENTER.

The Select Floodline Type dialog box is displayed, highlighting the type of the floodline that you
selected. If you selected more than one floodline, no current type is highlighted.

Select Floodline Type bt

Lookup Takle Information

Table Name: [LU_DMS_FLOODTYPE |

Search for an item by

Search: | | (O Code @) Description l [ its code or description.
Code Description

100YEAR 1:100%ear Floodline

20vEAR 1:20%earFloodline

BOYEAR 1:60%earFloodline

Figure 35  The Select Floodline Type dialog box

3  Fromthe Select Floodline Type dialog box, select the appropriate floodline type, and then click OK.

The attribute changes are accepted.
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Changing dam attributes

You may change the default type that was assigned to a dam during the capture process. The
new dam type is selected from a list to ensure data accuracy.

Tip If you capture all the dams with the default type set to the one that is used most commonly, only dams that
have a different type need to be changed, reducing the amount of data to be captured.
To change a dam type
1  Choose Change > Change Dam Attributes > Dam Type...
2 Select the appropriate dam/s, and then press ENTER.

The Select Dam Type dialog box is displayed, highlighting the type of the dam that you selected. If
you selected more than one dam, no current type is highlighted.

Select Dam Type *
Lookup Takle Information
Table Name: |LU_DMS_DAMTYPE |
Search for an item by
Search: intion €———
| | O Code @ Description its code or description.
Code Description
RETARD Fetardation
STORAGE Storage
0K Cancel Help

Figure 36 The Select Dam Type dialog box

3  From the Select Dam Type dialog box, select the appropriate dam type, and then click OK.

The attribute changes are accepted.
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Changing a service connection type

With this function, you can change a service connection type from the default that was entered
when the service connection was captured. The new service connection type is selected from a
list to ensure data accuracy.

To change a service connection type
1  Choose Change > Change SC Type...

2 Select the appropriate service connection(s), and then press ENTER.

The Select Service Connection Type dialog box is displayed, showing the type of the service
connection that you selected. If you selected multiple service connections, no current type is

highlighted.

Select Service Connection Type

Lookup Takle Information

Tahle Mame: |LU_SMS_SERWYPE

bt
| Search for an item
Search: | | @ Cade ® Description>—> by its code or

Code Description
ACTUAL Actual Location
ESTIMATE Estimated Location

[6]:4 Cancel Help

Figure 37 The Select Service Connection Type dialog box

3 Select the appropriate service connection type from the list, and then click OK.
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Linking service connections to parcels / buildings
This function is used to link selected service connections to their respective parcels or buildings.

The parcels and buildings have to be queried from the database.

To link service connections to parcels

1  Choose Change > Link Service connections.
2 Select the appropriate service connections, and then press ENTER.

The selected service connections are linked to their respective parcels.

Note If the endpoint of the service connection falls inside a parcel boundary the PRCL_GID column is
updated with the GID value from SP_ PARCEL.

Note If the endpoint of the service connection falls inside a parcel boundary and a building polygon the
PRCL_GID column is updated with the GID value from SP_ PARCEL, and the LINK ID column is
updated with the GID value from SP_ BUILDING

Changing drainage notes
With this function, you can change the text of an existing drainage note.
To change a drainage note

1 Do one of the following:
Choose Change > Change Drainage Note...
Click the Change Drainage Note button on the Munsys Drainage Change toolbar.

- ||§%

2 Select the drainage note that you want to change.

I~ 7 »

I AR

The Drainage Note text box is displayed, showing the current note.

Drainage Note X

Drainage insufficient, re-plan|
Cancel Help

Figure 38  The Drainage Note text box
3  Change the note as required, and then click OK.

Adding comments
This function is used to assign descriptive comments to one or more selected drainage objects.
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To add comments

1  Choose Change > Add Comment...

2 Select the drainage object(s) that you want to add a comment to.

The Drainage Comment text box is displayed.

Drainage Comment X

Figure 39  The Drainage Comment text box

3 In the text box, add the comment, and then click OK.

The comment is assigned to the selected object(s).

Deleting and undeleting drainage objects

With Munsys Drainage, existing drainage objects can be deleted from the database. Multiple
objects can be selected for deleting. Drainage objects that form part of a redundant network
have to be deleted. Deleted drainage objects are moved to a frozen layer DELETED, which is
removed from the database when changes are posted. With the Undelete function, you can
restore drainage objects that have been moved to the DELETED layer and that are marked for
deletion.

To delete drainage objects
1  Choose Change > Delete Drainage Object.

2 Select the drainage objects that you want to delete.

The command line indicates how many drainage objects you have selected, and how many have
been filtered out.

3  Press ENTER to delete the selected drainage objects.
The drainage objects are flagged for deletion and moved to the DELETED layer. These changes are
applied to the database when changes are posted.
To undelete drainage objects
1  Choose Change > Undelete Drainage Objects.
The drainage objects that you deleted are displayed in the drawing,.

2 Select the drainage objects that you want to restore.

The Delete flag is no longer set for the selected objects. In the event of spatial or attribute changes
before the objects were flagged for deletion, these changes are applied.
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