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 Introducing the Munsys Cable Fiber and Cable Route Concepts User Manual

Welcome to Munsys
The Munsys® product family consists of an integrated set of applications that cater for all the 
spatial information needs of utility and government organizations.

The Munsys products are based on industry leading technologies, utilizing Open Geospatial 
Consortium (OGC) standards for sharing information. Autodesk® design technology is used 
to present the spatial information, while Oracle® database technology is used for the storage 
of both spatial and attribute information. The innovative Munsys applications are the result 
of years of extensive research and development. 

Munsys is a user-friendly, easy to use geographic information management tool, which does 
not require GIS expertise to capture and manipulate data.

The Munsys product family consists of the following applications:

 Munsys Cadastral

 Munsys Cable Route

 Munsys Cable Fiber

 Munsys Drainage

 Munsys Electricity

 Munsys Roads

 Munsys Sewer

 Munsys Water

 Munsys Map Books

 Munsys Spatial Data Manager

 Munsys Management Console

 Munsys Query

 Munsys Lineage

 Munsys Scheduled Tasks
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About this manual
The Munsys Cable Fiber and Cable Route Concepts User Manual provides the following 
information:

 the generic capture functionality in the various Munsys applications

 the generic query functionality that is used to query spatial data from the Oracle database

 how to structure a query

 how to view spatial data

 how to work with Munsys Objects

 extras such as annotation, reporting and legend options, etc.

 how to format layers

What’s in this manual
The Munsys Cable Fiber and Cable Route Concepts User Manual consists of the following 
chapters:

 Chapter 1 – Introducing the Munsys Cable Fiber and Cable Route Concepts User Manual, 
gives an overview of this manual, and provides the typographical conventions used 
throughout the Munsys documentation set.

 Chapter 2 – Getting acquainted with Munsys Cable Fiber and Cable Routes, gives an 
overview of 
Munsys and its various applications, as well as an overview of the Munsys user interface.

 Chapter 3 – Capturing and querying Building data in Munsys, describes how to define 
query options and retrieve existing data from the database.

 Chapter 4 – Creating Cable Fiber and Cable Route data, shows the user how to capture a 
cable fiber and cable route network, add additional cable fiber and cable route objects, and 
post cable fiber and cable route data to the database.

 Chapter 5 – Maintaining Cable Fiber and Cable Route data, describes how to maintain 
existing cable fiber and cable route data.
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Conventions in this manual
The following table lists the typographical conventions used in this manual.

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

 general issues, select Help from the Munsys menu bar.

 an operation in progress, click the Help button on the dialog box.

 the latest support options, visit http://www.openspatial.com

Text element Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial

Menu paths choose Query > Clear Basemap.

Hypertext links to more information http://www.openspatial.com

Text displayed/typed on the 
command line

MUNOBJECT

Dialog box/screen names The Cable Route Settings dialog box

Application functions The Integrity Check function

http://www.openspatial.com
http://www.openspatial.com


4 








 Chapter 2


 Getting acquainted with Munsys Cable Fiber and Cable Routes

Munsys Overview
Munsys, the spatial solution for utilities and government, is a multi-user open GIS system that 
allows users to capture and maintain utility data.

The demand for accurate geo-spatial information for both planning and decision support is 
increasing daily, fostering the need for the implementation of an information system that can 
grow with the needs of the organization. The Munsys system caters for these needs by storing 
spatial data from different departments into a centralized database, allowing it to cater for data 
sharing, integration and duplication problems.

The design of the capture and maintenance functions enforces data standards. Spatial data 
integrity is enhanced with a verification process known as the integrity check, which checks 
the spatial data against the business rules before it is posted to the database.

The Munsys product family simplifies the use of spatial data with predefined queries, which 
retrieve spatial objects onto their appropriate layers. Objects that are changed and new objects 
that are created are changed to a working color. Once the objects pass the integrity check, they 
are moved back to their normal colors, from where they are posted to the database.

Munsys is a user-friendly, easy to use spatial information management tool, which does not 
require GIS expertise to capture and manipulate utility data. The system provides the user with 
Capture and Change toolbars that speed up the capture process.

Munsys caters for enhanced output tools, such as annotations and legends, to simplify map 
production. 
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Munsys Features
The various Munsys features can be listed as follows:

 User-specific application and design – enforcing data standards fulfills the demand for 
accurate spatial data. Engineering spatial data requires standards that adhere to civil 
engineering rules, which are built into the capture and modify routines of the system. 
Munsys provides a user-friendly interface that meets these requirements.

 Munsys is an Enterprise Spatial Solution – Munsys is a multi-user open system that caters 
for the demands of spatial systems. Because of its centralized database and data sharing, 
dynamic information is available. 

 Munsys adheres to Open Geospatial Consortium (OGC) standards – Munsys is designed 
to adhere to the ISO standards for OpenGIS applications.

 Munsys is based on industry standard software – Munsys is designed as a front end on 
AutoCAD Map3D®.
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Introducing the Munsys Applications
The following section provides an overview of the various Munsys applications.

Munsys Cadastral 
Munsys Cadastral is used for the capture and maintenance of cadastral base data from general 
plans and diagrams. The cadastral data forms the foundation of the system because all 
departments use it to locate and position their services.

Using Munsys Cadastral, users can capture and maintain community boundaries (for example 
municipalities, suburbs, townships, etc.), parcels, easements, street names and addresses and 
buildings. In addition, Munsys Cadastral caters for planning aspects such as zoning, density and 
land use polygons.

Users can also define cadastral settings to simplify the capture process. Parcels are classified 
according to their legal and work status as proposed, current, or archived. Conversion of spatial 
objects to cadastral objects extends the capture capabilities within Munsys.

Figure 1 Munsys Cadastral 
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Munsys Cable Route
Munsys Cable Route is designed for the capture and maintenance of cable route networks. 
Munsys Cable Route caters for cable route objects such as ducts and infrastructure such as 
vaults, sites, manholes and other relevant infrastructure polygons, and for cable route nodes 
such as fiber rooms, fiber joints, etc. Objects are typically placed along cadastral boundaries and 
network connectivity is generated after the objects have been captured.

Munsys Cable Route contains various tools to assist with data capture and maintenance that 
will, for example, contain specifications for the ducts in which fiber cables will be housed. This 
then allows for different scenarios, detailed duct information and establishing links for analysis 
and reporting purposes between cable routes and fiber cables.

Figure 2 Munsys Cable Route 
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Munsys Cable Fiber
Munsys Cable Fiber is used for the capture of fiber network data.

Munsys Cable Fiber accurately places cables within the cable routes and building the required 
network integrity as cables are captured. Integrity checks and rules are built into the data 
capture process of the cables as they are placed, thereby eliminating errors such as 
interconnecting networks with incorrect cables.

Cable lengths are calculated along the cable routes and adjusted for slack at each connecting 
node. Important information such as connectivity, type, and size is stored for each cable.

Cables Route Ducts contain specific information pertaining to the fiber cables, the various duct 
sizes, Route ID and Route Type which provides for efficient links between both utilities. 

Figure 3 Munsys Cable Fiber 

Note In the Show Info Palette the values are displayed as Table View by default therefore some column names 
would not be displayed in full. To Change this the user can right-click within the Main Object Attributes 
pane and switch to Show Formatted View to display the columns in full.
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Launching Munsys and Munsys Cable Fiber or Cable Route
To launch Munsys, do one of the following:

1 Double-click the Munsys Application 14.4 icon on the Windows desktop.

2 Choose Start > Program Files > Open Spatial > Munsys 14.4 > Munsys Applications 14.4

Connecting to the Oracle database
Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator 
technology is that spatial and attribute data are captured and managed in a single database. This 
reduces processing overheads and eliminates the complexity of coordinating and synchronizing 
different sets of data.

The Munsys Applications support multiple Logons which permit users to logon to different 
databases such as Training, Test or Production databases by selecting a Logon Profile from a 
drop-down list. When the Connect function is selected, the logon credentials (excluding the 
password) are pre-populated based on last successful database connection. 

The Logon Profile details are customizable and stored in the Current User’s Registry Keys. By 
default, three Logon Profiles are defined, namely Logon1, Logon2 and Logon3. The Logon 
Profile descriptions can be changed from the default description to be more meaningful one by 
simply clicking in the text box next to the Logon Profile and overwriting the default value. 

Important You have to be connected to the Oracle database before you can start working with Munsys 
Cadastral. If you try to launch any application without being connected to the database, you will be 
prompted to connect to the database first.

To connect to the Oracle database

1 Do one of the following:

 Choose File > Database > Connect...

 Click the Connect to Database button on the Munsys standard toolbar.

 On the command line, type MUNCONNECT, and then press ENTER.
The Connect to Database dialog box is displayed.
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Figure 4 The Connect to Database dialog box

2 In the Logon Profile box, select a profile from the drop-down list.

Note The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text 
box and overwriting the default description with a value not exceeding 25 characters, for example: 
TRAINING, TEST, STAGING or PRODUCTION.

3 In the User Name field, enter your user name.

4 In the Password field, enter your password.

5 In the Schema field, enter the schema name.

6 In the Database field, enter the database name.

7 Click OK.

On successful connection to the database, the last Logon Profile, User Name, Schema and 
Database details are saved in your Current User’s Registry Key where they are used to pre-
populate the Connect to Database dialog-box on next logon. Your password is never saved, and 
you will always be prompted to enter your Password.

Figure 5 The Connect to Database dialog box with Logon Profile
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Note The last used Logon Profile details, and the various Logon descriptions are stored in the registry key 
Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 14.4\Applications\Logons, 
whilst the registry key Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 
14.4\Applications\Logons\[Logon1] saves the individual User Name, Schema and Environment Name 
details per Logon Profile. 

The administrator assigns you user rights to log on to the database, and will inform you what 
your user name, password, schema name, and database are. A successful connection to the 
database activates the appropriate functions on the menu bar and toolbars.

Disconnecting from the Oracle database
1 Do one of the following:

 Choose File > Database > Disconnect... 

 Click the Connect to Database button on the Munsys standard toolbar.

 On the command line, type MUNDISCONNECT, and then press ENTER.
The connection to the database is terminated, and you will only be able to manipulate data once an active 
connection has been restored.

Changing the password used to connect to the database
With this function, you can change the password that you use to connect to the database.

1 Do one of the following:

 Choose File > Database > Change Password...
On the command line, type MUNPASSWORD, and then press ENTER.
The Changing password for user [User] dialog box is displayed.

Figure 6 The Changing password for user [User] dialog box

2 In the Old password box, type your current password.

3 In the New password box, type your new password.

4 In the Retype new password box, retype your new password.

5 Click OK to apply the new password.
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To launch the Munsys application of your choice
1 Do one of the following:

 Choose File > Munsys Applications.

 Click the Munsys Applications button on the Munsys standard toolbar.

Figure 7 The Available Applications dialog box

2 From the list of available applications, select the application that you want to work with, and then 
click OK.

The functions of the application that you selected are loaded on the menus and toolbars,

Munsys Menu AutoFix
It is possible that the Munsys Menus may get corrupted for some reason. This is often associated 
with customizations or user experimentation. If this happens, Munsys provides a way to Fix 
such menus.

To fix a corrupt menu do the following

1 Choose File > Restore Munsys Menu...

Your Corrupted Menus should now be repaired. 
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 Capturing and querying building data in Munsys

Introduction
This chapter describes how to capture cadastral building data necessary for Fiber and Cable 
Route connectivity, and how to post the captured data to the database. 

When you start the capture process, existing cadastral data needs to be queried from the 
database first in order to verify the location of existing objects and to determine if these objects 
will influence the capture process of the new cadastral data. Cadastral data usually needs to be 
captured for subdivisions or consolidations of existing cadastral data, or for new developments.

Cadastral data is captured in its native format (coordinate system and units) from registered 
plans and, if needed, converted to different units afterwards. For most accurate data, you need 
to capture data as coordinates, because survey distances are rounded off in some cases.

When building data is queried, it includes the retrieval of the spatial objects, with a link to the 
attribute data in the database.

Note The capture of the cable route can only be done if there are existing Buildings (Cadastral Application) saved 
and posted into the database. If there are no captured buildings in the database the user would have to manually 
capture this within the Cadastral Application, before proceeding to the Cable Route application. 

Once the buildings have been queried out/captured and all required attribute information has been captured 
such as Building Name, Number, Floor and Room Information, the user can then proceed to the Cable Route 
application where the actual Runs/Ducts will be captured.



Capturing and querying building data in Munsys 14 








To launch Munsys Cadastral
When you launch Munsys for the first time, the configured base map automatically loads and 
AutoCAD menus are loaded by default. 
Subsequently, the menus and toolbars of the application that you last worked with are displayed 
when you launch Munsys.

1 To launch Munsys Cadastral, do the following:

 Choose File > Munsys Applications.

 Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Figure 1 The Available Applications dialog box

2 From the list of available applications, select Cadastral, and then click OK.

The Munsys Cadastral menus and toolbars are loaded.
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Querying buildings
Buildings are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects). Buildings are placed on the BUILDING layer.

To query buildings
 Choose Query > Buildings.

The command line shows how many buildings were retrieved from the database according 
to the current GSC.

Figure 2 Querying buildings

To query buildings with the name displayed

1 Ensure that the Building has a Name assigned to it (This can be done via Change > Edit 
Attributes).

2 Navigate to the Query Palette and right click on Buildings > Properties.

3 Click on Tag Properties > Right Click on Tag Properties > Column.

4 Drop-down the available columns and select SP_BUILDING.BLD_NAME.

5 Click OK.

6 Right Click on the Buildings > Run Selected Query without GSC.
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Capturing buildings
Buildings can be classified for different types, for example as business, industrial, educational, 
government, institutional, medical, etc. With Munsys Cadastral, buildings are captured as 
polygons, either by drawing a building polygon, or by first drawing a building boundary and 
then generating a polygon from the boundary lines. You can also create a building by generating 
a polygon from existing lines.

The number of floors in a building are assigned using the Change menu. 

A building that is captured using the Draw Building Polygon function is assigned the default 
building type. This can be altered by changing the default value in the Cadastral Settings dialog 
box, or from the Change menu, or by using the Edit Attributes function on the Change menu.

Note A building type is not assigned by default to a building that is captured using the Draw Building 
Boundary and/or Generate Building Polygons functions. Using the Change menu, you have to assign 
a building type using the Edit Attributes or Change Building Type functions.

Drawing building polygons
With this function, you can create a building polygon by specifying consecutive points in the 
drawing area. The polygon is closed automatically and constructed on the BUILDING layer as 
a MunPolygon object, to be verified when the integrity check is run.

To draw a building polygon

1 Choose Capture > Building > Draw Building Polygon.

2 Specify the start point for the building polygon.

3 Specify the next point(s), and then press ENTER.

The building polygon is closed automatically.

Drawing a building boundary
With this function, you can draw a building boundary by indicating consecutive points in the 
drawing area. The lines are created on the BUILDING_LINES layer and will be used by the 
polygon builder to generate a building polygon.

To draw a building boundary

1 Choose Capture > Building > Draw Building Boundary.

2 Specify the start point for the building boundary by doing one of the following:

 Snap to an existing spatial object.

 Select a point in the drawing.

3 Specify the next points as above, and then press ENTER.

4 Press ENTER to close the building boundary.
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Generating building polygons
With this function, you can generate building polygons from the lines that were created with 
the Draw Building Boundary function. The polygon is generated on the BUILDING layer, to 
be verified when the integrity check is run.

The building type for a building polygon that is created by using the Draw Building 
Boundary/Generate Building Polygons functions, has to be specified using the Change 
Building Type function.

To generate building polygons

1 Choose Capture > Building > Generate Building Polygons.

2 Select the lines that form the closed building boundary, and then press ENTER.

The command line prompts you to select the polygon detection point.

3 Select a point inside the building boundary.

The building polygon is generated.

Figure 3 Building polygons
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Editing building information
This function is used to edit building information. Building information can only be edited by 
users who have been assigned the MUNSYS_CMS_EDIT role. You can change the Building 
Type, Floor Information, Building Name, Building Number and Data Quality.

To edit building information

1 Choose Change> Edit Attributes.

The command line prompts you to select cadastral objects.

2 Select the building polygon, and then press ENTER.

The Edit Attributes Buildings dialog box opens.

Tip The Edit Attribute Buildings dialog box can be resized so that you can easily view all the information.

Figure 4 The Edit Attributes: Buildings dialog box

3 In the Edit Attribute: Buildings dialog box, add a Building Name and Building Number, and then 
click OK.

You can change the building type, number of floors, comments, building name, building 
number and data quality of an existing building.
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Editing building attributes - Continued

To edit building attributes

1 Choose Change> Building> Change Building Type.

The command line prompts you to select objects.

2 Select the building polygon to be changed.

The Select Building Type dialog box opens.

Figure 5 The Select Building Type dialog box

3 In the Select Building Type dialog box, select a building type by Code or Description, and then 
click OK.
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Change Building Floor / Room Information
This function is used to change building floor and room information. You can change, add and 
delete the building floor and building room information of an existing building.

Buildings are required for the placement of Fiber Room Nodes, and these buildings store the 
Floor and Room numbers and descriptions of where the Fiber Room Nodes connect to. 

Note The Floor Information must be captured and posted to the database before the Room Information for that Floor 
can be captured. 

A Building may comprise of multiple Floors, and a Floor may have multiple Rooms, however 
Fiber Room Nodes may only connect to a single Floor and Room combination. Each Floor 
Number must be unique, and each Room Number must be unique.

Tip As an example, a Building may consist of many Floors (1 = First Floor, 2 = Second Floor) and there may be 
more than on Fiber Room on each Floor (101 = IT Room, 201 = IT Room, and 207 = Reception on 2nd Floor)

The Floor and Room details can be viewed by selecting the Floor Number in the Floor 
Information block where the Room Information for that floor is displayed.

Figure 6 Building Floor and Room combination for First floor

Figure 7 Building Floor and Room combination for Second floor
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To Add building Floor / Room information

1 Choose Change> Building> Change Building Floor/Room info.

The command line prompts you to select building.

2 Select the building polygon to be changed.

The Edit Building Information dialog box opens.

Figure 8 The Edit Building Information dialog box

3 In the Edit Building Information dialog box, click the Add a Floor Number.

The New Building Floor dialog box opens.
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Figure 9 The New Building Floor dialog box

4 In the New Building Floor dialog box, add a Floor Number and a Floor Description, and then 
click OK.

Note The Add Room Information will only become available once building floor information was captured/added 
to a building and the floor information is selected.

5 In the Edit Building Information dialog box select the floor, and click the Add a Room Number.

The New Building Room dialog box opens.

Figure 10 The New Building Room dialog box 

6 In the New Building Room dialog box, add a Room Number and a Room Description, and then 
click OK.

7 In the Edit Building Information dialog box, click Commit to save the building information.

Note A Schedule Task has been created to remove Orphan Floor and Room Information from 
AT_BLDG_FLOOR_INFO and AT_BLDG_ROOM_INFO if the corresponding GID does not exist in 
SP_BUILDING. This is done in order for a user to capture a Fiber Room Node in a building where one was 
captured previously.
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To Delete building Floor / Room information

1 Choose Change> Building> Change Building Floor/Room info.

The command line prompts you to select building.

2 Select the building polygon to be changed.

The Edit Building Information dialog box opens.

3 Select the Floor Information record to be deleted and select the Delete button.

4 You will be prompted to Confirm the deletion.

Selecting ‘Yes’ will proceed with the deletion. ‘No’ will cancel and return you to the Edit Building 
dialog box.

Figure 11 Conformation message when deleting a Building’s Floor Information.

Important You will be presented with the below message when attempting to delete any Floor or Room 
Information where Fiber Room Nodes are linked. You will not be able to continue with the deletion of the 
selected Floor / Room Information until the Fiber Room Node is unlinked.

Figure 12 Message preventing deletion of Building Floor / Room Information

5 Select the Commit button to remove the record.

Note It is important to note that when deleting a Building’s Floor Information, the associated Room Information for 
the Floor is also deleted. This is automatically done by means of a database trigger.
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 Chapter 4


 Creating and Maintaining cable route data

Capturing and Modifying cable route data
When you start to capture a cable route network, you will first need to query the cadastral and 
building data into the drawing to make certain that the cable route objects locate 
geographically correct. Existing cable route objects should also be queried to determine the 
relationship between existing and new cable route objects, and will help prevent any data 
duplication.

The cable route default attributes are set up on the Cable Route Settings dialog box before the 
capture process is started. Default layer names are used for each object type per cable route 
category. 

Buildings are required to be captured or queried out first, before the capture of fiber nodes or 
cable routes has commenced. 

Next, the Cable Routes are placed, as the Runs/Ducts connect to the fiber nodes which are 
linked to buildings and infrastructure, and usually align with existing cadastral, however can 
be placed freehand if desired.

Once you have placed all the cable route objects required to complete the cable route network, 
you are ready to run both the object and network integrity checks, and post the data to the 
database.

Then, Fiber Paths and/or Fiber Cables are placed. These are the last components of the Cable 
Fiber Application and will be covered comprehensively in the next chapter.

Spatial data is stored in database tables as records. Cable Route objects that require editing are 
queried onto their respective layers. Attribute data can be edited directly in its table format.

Once the cable route and nodes have been placed, the cable route objects have to be 
manipulated to make certain that they are joined correctly, for example with no overlaps or 
undershoots, and each cable route has to have a start and end node.

Attribute values linked to cable route objects can be modified easily from the Change menu, 
for example infrastructure and route types.

Maintaining cable route data can be done by accessing the Change menu. Cable route objects 
which have been changed need to be validated against the cable route business rules before they 
can be posted to the database again. 
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Cable Route

Cable route capture settings
Each Munsys application has its own default capture settings that are set by the GIS 
administrator in the Munsys Management Console. 

In Munsys Cable Route, default settings are available for:

 Cable Route – cable route default offset distance, label height, owner, state, status, and type

 Cable Route Nodes – cable route nodes alignment, placement, node functions, offset 
distance, node reference and snap to nodes.

 Cable Route Symbols – cable route symbol scale

 Dimensions – dimension note height

 File – the drawing directory

 General – construction color, include network in object integrity, database extents display 
resolution, integrity circle size, tag and symbol scale and rotation if coordinate 
transformation is done, snap tolerance, tag angle, font, height and justification

 Infrastructure – cable route infrastructure height, width, prompt name and default type

 Integrity – short objects, cable route, node and search tolerance

 Nodes – cable route node scale

 Notes – note tag height

You can change the current settings on the Cable Route Settings dialog box to speed up the 
capture process. Capture settings only apply to new cable route objects, and if you change the 
default settings, the changes are only valid for the current session.

Settings are changed by highlighting the current value, and then:

 entering a new value

 selecting the new value from a drop-down list

The user cannot change all of the settings. Some settings may only be changed by the GIS 
administrator to enforce consistency and integrity on a higher level. Settings that cannot be 
changed are “greyed out” on the Capture Settings dialog box.

Tip A short description of a value displays when it is highlighted.
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To specify cable route capture settings

1 Do one of the following:

 Choose Capture > Cable Route Settings...

 Click the Cable Route Settings... button on the Munsys Cable Route Capture toolbar.

2 The Cable Route Settings dialog box is displayed, showing the default cable route capture settings.

The Cable Route settings dialog box opens.

Figure 1 The Cable Route Settings dialog 

3 To change a value, do one of the following:

 Highlight the current value, and then enter a new value.

 Highlight the current value, and then choose the new value from the drop-down list.

4 Click OK to apply the new settings.

The settings will apply until you change them again, or until the current session is terminated.

Some values are changed by 
selecting a value from a drop-
down list. 

Some values are changed by 
manually entering a new 
value.
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Capturing Infrastructure
Infrastructure nodes are used to house the fiber joint nodes. Infrastructures are captured onto 
their appropriate layers, to be verified when the integrity check is run. 

Auto-placement of Fiber Nodes when capturing Cable Route Infrastructure
Munsys caters for the auto-placement of a Fiber Node simultaneously when placing Cable 
Route Infrastructure, for example:

When an Infrastructure Manhole is placed a Fiber Node Junction node is automatically placed 
at the center of the Manhole. The Manhole is captured in the spatial table 
SP_CRTINFSTRUCT, while the Junction node is captured in the spatial table 
SP_CRTNODE and is linked to the Manhole by means of the Link Type (LINK_TYPE) and 
Link ID (LINK_ID) columns. 

These rules exist for Infrastructure Manholes and Pits in the Node Mapping table for Cable 
Route Infrastructure called CRTINF_NODEMAPPING. This table determines which Cable 
Route Node Type and associated Symbol Name is auto-placed when placing specified Cable 
Route Infrastructure. The config is only editable using SQL scripts to add or remove auto-
placement rules.

Placing a vault
When capturing a cable route network, vaults are placed by selecting a point in the drawing or 
inserted anywhere at a selected point on a cable route, allowing a sequence of vaults to be placed. 

To place a vault

1 Choose Capture > Infrastructure > Place Vault.

2 Specify the insertion point for the tag.

3 On the command line, specify the vault size, or press ENTER to accept the default size.

4 To indicate the vault angle, do one of the following:

 Indicate the vault angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the vault to an object, press ENTER, and then select the 
object to which you want to align the vault to.

5 On the command line, specify the vault name, and press ENTER.

6 On the command line, specify the vault number, and press ENTER.

The vault is inserted as specified.
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Placing a site
When capturing a cable route network, sites are placed by selecting a point in the drawing or 
inserted anywhere at a selected point on a cable route, allowing a sequence of sites to be placed. 

To place a site

1 Choose Capture > Infrastructure > Place Site.

2 Specify the insertion point for the site.

3 On the command line, specify the site size, or press ENTER to accept the default size.

4 To indicate the site angle, do one of the following:

 Indicate the site angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the site to an object, press ENTER, and then select the 
object to which you want to align the site to.

5 On the command line, specify the site name, and press ENTER.

6 On the command line, specify the site number, and press ENTER.

The site is inserted as specified.

Placing a drawbox
When capturing a cable route network, drawboxes are placed by selecting a point in the drawing 
or inserted anywhere at a selected point on a cable route, allowing a sequence of drawboxes to 
be placed. 

To place a drawbox

1 Choose Capture > Infrastructure > Place DrawBox.

2 Specify the insertion point for the drawbox.

3 On the command line, specify the drawbox size, or press ENTER to accept the default size.

4 To indicate the drawbox angle, do one of the following:

 Indicate the drawbox angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the drawbox to an object, press ENTER, and then select 
the object to which you want to align the drawbox to.

5 On the command line, specify the drawbox name, and press ENTER.

6 On the command line, specify the drawbox number, and press ENTER.

The drawbox is inserted as specified.
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Placing a pit
When capturing a cable route network, pits are placed by selecting a point in the drawing or 
inserted anywhere at a selected point on a cable route, allowing a sequence of pits to be placed.

To place a pit

1 Choose Capture > Infrastructure > Place Pit.

2 Specify the insertion point for the pit.

3 On the command line, specify the pit size, or press ENTER to accept the default size.

4 To indicate the pit angle, do one of the following:

 Indicate the pit angle with your mouse.

 Type the angle on the command line.

5 On the command line, specify the pit number, and press ENTER. 
This value may not be left blank.

6 On the command line, specify the pit name, and press ENTER.
The pit name defaults to the same value as the entered pit number, however another value can be 
entered. This value may not be left blank.

The pit is inserted as specified on the layer CRTINFSTRUCT, and a cable route JUNCTION node type is 
automatically placed at the center of the pit, and is placed on the layer CRTNODE.

The cable route JUNCTION node is automatically linked to the Infrastructure Node where the 
Infrastructure ID for the Pit is populated into the Node ID column for the JUNCTION.

Placing a manhole
When capturing a cable route network, manholes are placed by selecting a point in the drawing 
or inserted anywhere at a selected point on a cable route, allowing a sequence of manholes to 
be placed. 

To place a manhole

1 Choose Capture > Infrastructure > Place Manhole.

2 Specify the insertion point for the manhole.

3 On the command line, specify the manhole size, or press ENTER to accept the default size.

4 To indicate the manhole angle, do one of the following:

 Indicate the manhole angle with your mouse.

 Type the angle on the command line.

5 On the command line, specify the manhole name, and press ENTER.
This value may not be left blank.

6 On the command line, specify the manhole number, and press ENTER.
This value may not be left blank.

The manhole is inserted as specified on the layer CRTINFSTRUCT, and a cable route JUNCTION node 
type is automatically placed at the center of the manhole, and is placed on the layer CRTNODE. 
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The cable route JUNCTION node is automatically linked to the Infrastructure Node where the 
Infrastructure ID for the Manhole is populated into the Node ID column for the JUNCTION.

Placing a pole
When capturing a cable route network, poles are placed by selecting a point in the drawing or 
inserted anywhere at a selected point on a cable route, allowing a sequence of poles to be placed. 

To place a pole

1 Choose Capture > Infrastructure > Place Pole.

2 Specify the insertion point for the pole.

3 On the command line, specify the pole size, or press ENTER to accept the default size.

4 On the command line, specify the pole name, and press ENTER.

5 On the command line, specify the pole number, and press ENTER.

The pole is inserted as specified.

Draw infrastructure polygons
They are usually drawn to indicate a housing for the fiber joints or junctions. The infrastructure 
polygon is placed by drawing a boundary, and then placing a name and number.The polygon 
builder uses the lines and tag to create an infrastructure polygon.

To draw infrastructure polygons

1 Choose Capture > Infrastructure > Draw Infrastructure Polygon.

2 Specify the starting point for the polygon.

3 Draw consecutive points to form a infrastructure polygon, and press ENTER to finish the polygon.

4 On the command line, specify the polygon name, and press ENTER.

5 On the command line, specify the polygon number, and press ENTER.

The polygon is inserted as specified.
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Draw infrastructure boundary
Infrastructure polygons are captured as polygons that identifies the housing of the fiber joints 
or junctions. They are usually drawn to indicate a certain supply area. The infrastructure 
polygon is placed by drawing a boundary, and then placing a name and number.The polygon 
builder uses the lines, name, and number to create an infrastructure polygon.

To draw a infrastructure boundary

1 Choose Capture > Infrastructure > Draw Infrastructure Boundary.

2 Specify the starting point for the boundary.

3 Draw consecutive points to form a infrastructure boundary, and press ENTER to finish the 
boundary.

4 On the command line, type YES to close the boundary, and press ENTER.

The boundary is inserted as specified.

Generate infrastructure polygons
This function is used to generate a closed polygon from the lines, name, and number that were 
created with the infrastructure boundary. The function verifies that the boundary polygon 
forms a closed area. 

To generate infrastructure polygons

1 Choose Capture > Infrastructure > Generate Infrastructure Polygons.

2 Select the infrastructure boundary lines, and press ENTER.

3 Specify the detection point, and place it within the polygon, and press ENTER.

The polygon is inserted as specified.
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Placing Fiber Room Nodes
Fiber Room nodes are the first cable route objects that are captured and are normally aligned 
with buildings, therefore parcels and buildings need to be queried before any cable fiber and 
cable route data is captured. 

Duplication of cable fiber and cable route objects can be avoided by querying all the existing 
cable fiber and cable route objects from the database before you start capturing cable fiber and 
cable routes.

To place a Fiber Room Node
Before capturing a Fiber Room Node you are required to query the Building data into the 
drawing to be able to select the mandatory Room Information.

1 Do one of the following:

 Choose Capture > Place Fiber Node> Fiber Room Node...

 Click the Fiber Room Node button on the Munsys Cable Route Place Fiber Node toolbar.

The command line prompts you to select building.

2 Select the building polygon, and then press ENTER.

The Select Room Info dialog box opens

Figure 2 The Select Room Info dialog box

3 In the Select Room Info dialog box, select the Floor and Room, and then click OK.

4 You are prompted to specify a point in the drawing where the node insertion point will be placed.

Select a point inside the building.

Note If the user attempts to place more than one Fiber Room Node in the same building floor/room then the system 
will flag an error stating that a fiber room exists within the database. After clicking continue another error will 
flag the user to remove the associated fiber room and try again, if required. 
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Placing Fiber Joint Nodes
This Node is used to connect fiber cables or cable routes, or used as a branch out splicing point 
in cable fiber networks. Fiber joints are placed by selecting points in the drawing or inserted 
anywhere at a selected point on a cable route.

To place a Fiber Joint Node

1 Do one of the following:

 Choose Capture > Place Fiber Node> Fiber Joint Node.

 Click the Fiber Joint Node... button on the Munsys Cable Route Place Fiber Node toolbar.

The command line prompts you to select infrastructure.

2 Select the infrastructure polygon.

The command line prompts you to specify point.

3 Select the insertion point of the fiber joint node in the infrastructure polygon.

The system will prompt the user to enter in a Node Reference.

4 Enter a Node Reference value and press ENTER.

Placing Fiber Termination Boxes
Termination boxes is placed to terminate optical fibers outside a premises.Termination boxes 
are placed by selecting points in the drawing or inserted anywhere at a selected point on a cable 
route.

To place a Fiber Termination Box

1 Do one of the following:

 Choose Capture > Place Fiber Node> Fiber Termination Box.

 Click the Fiber Termination Box... button on the Munsys Cable Route Place Fiber Node 
toolbar.

The command line prompts you to Specify point or [Route , Segment]

2 The Specify point option allows the user to manually select a point in the drawing or to enter a 
specific X;Y coordinate value.

3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection 
point.

4 Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing 
to snap to, and to specify an insertion point and a side to offset from. 
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Placing Fiber Distribution Hubs
Fiber Distribution Hubs (FDH) are enclosures that provides the connection between fiber 
optical cables and passive optical splitters in the outside plant segment of the network. This 
makes it easy and fast to service connections and reconfigurations, and serves as a testing point 
in the outside plant network.

To place a Fiber Distribution Hub

1 Do one of the following:

 Choose Capture > Place Fiber Node> Fiber Distribution Hub.

 Click the Fiber Distribution Hub... button on the Munsys Cable Route Place Fiber Node 
toolbar.

The command line prompts you to Specify point or [Route , Segment].

2 The Specify point option allows the user to manually select a point in the drawing or to enter a 
specific X;Y coordinate value.

3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection 
point.

4 Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing 
to snap to, and to specify an insertion point and a side to offset from. 

Placing Multi Service Access Nodes
A Multi Service Access Node (MSAN) allows for the connection between copper and fiber 
cables thereby allowing for termination.

To place a Multi Service Access Node

1 Do one of the following:

 Choose Capture > Place Fiber Node> Multi Service Access Node.

 Click the Multi Service Access Node... button on the Munsys Cable Route Place Fiber Node 
toolbar.

The command line prompts you to Specify point or [Route , Segment].

2 The Specify point option allows the user to manually select a point in the drawing or to enter a 
specific X;Y coordinate value.

3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection 
point.

Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing 
to snap to, and to specify an insertion point and a side to offset from.
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Placing Fiber Junctions
Junctions are used for fiber cable splicing and joints. Junctions are placed by selecting a point 
in the drawing, or by inserting on a cable route at a selected point, or within an existing 
Infrastructure Manhole or Pit, or as an offset from an existing MunPoly or MunLine Segment.

To place a junction in the drawing 

1 Do one of the following:

 Choose Capture > Place Fiber Node> Junction.

 or Click the Junction... button on the Munsys Cable Route Place Fiber Node toolbar.

2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:

3 Specify a point in the drawing or enter an X;Y coordinate.

The Junction node is placed.

To place a junction on a Cable Route
In order to place a Junction on an existing Cable Route, the Cable Route must not contain any 
fiber cables. If the selected Cable Route contains fiber cables, the user will not be able to place 
a Junction and the Command line will prompt the user with the message “Cannot modify route 
object: Object still in use”

1 Do one of the following:

 Choose Capture > Place Fiber Node> Junction.

 or Click the Junction... button on the Munsys Cable Route Place Fiber Node toolbar.

2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:

3 Select the Route option on the command prompt or type R at the command line.

4 At the command line you are then prompted to select a Cable Route.

The Junction node is placed at the endpoint of the selected Cable Route.



Creating and Maintaining cable route data 33 








To place a junction within an Infrastructure Pit or Manhole

1 Do one of the following:

 Choose Capture > Place Fiber Node> Junction.

 or Click the Junction... button on the Munsys Cable Route Place Fiber Node toolbar.

2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:

3 Select the Infrastructure option or type I at the command line.

4 At the command line you are prompted to Select Infrastructure (PIT/MH)

Select a Pit or Manhole Infrastructure.

5 You are then prompted to Specify point relative to the selected Infrastructure.

The Junction node is placed and linked to the selected Infrastructure. The LINK_ID column 
is updated with the Infrastructure INF_ID value and the LINK_TYPE column is set to 
INFRASTRUCTURE.

To place a junction along a Segment

1 Do one of the following:

 Choose Capture > Place Fiber Node> Junction.

 or Click the Junction... button on the Munsys Cable Route Place Fiber Node toolbar.

2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:

3 Select the Segment option or type S at the command line.

4 At the command line you are prompted to Select segment to snap to

Select a building or parcel segment to snap to.

5 You are then prompted to Specify insertion point

Select a point on the segment

6 You are finally prompted to Specify side for node

Select the side of the segment where the node must be offset from.

The Junction node is placed 



Creating and Maintaining cable route data 34 








Capturing Telecom Nodes
Telecom Nodes are captured on the Cable Route Node layer CRTNODE, to be verified when 
the integrity check is run. The Place Telecoms Node functions are used to place telecom nodes 
(backbone, carrier and local network nodes) independentaly of any other nodes or connections 
that already exist.

The Telecom nodes can be placed using the Capture > Place Telecom Node menu options, or 
by selecting the Telecom Node from the Capture Telecom Nodes toolbar. 

The Place Telecoms Node menu and toolbar caters for the capture of the following Telecom 
nodes:

Backbone Nodes:

 Switch

 Distributed Line Unit (DLU)

 Main Distribution Frame (MDF)

 Multi Service Access Node (MSAN)

 DIGICON Terminal
Carrier Nodes:

 Microwave Tower
Local Network Nodes:

 Primary Joint

 Street Distribution Cabinet (SDC)

 Secondary Joint

 Service Connection Joint

 Distribution Point (DP)

 Distribution Point Building (DPB)

 Distribution Point Stubby (DPS)

 Distribution Point Aerial (DPA)

 Junction

 Pillar

 Stubby
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Placing Telecoms Nodes
Telecom Nodes can be placed on a cable route, as an offset from a selected Segment or in a 
location specified in the drawing. the Cable Route Settings determine the default offset 
distances applied per telecom node type when using the Segment option in the capture routines.

The following table indicates which prompts are displayed per Telecom Node. For those 
Telecom Nodes where an Infrastructure option can be selected, the table indicates the 
permissible Infrastructure which can be selected per Telecom Node

Table 3 Telecom Node Placement options

Telecom Node Type Command Line Prompt
Permissible 
Infrastructure

Switch Specify point or [Route/Segment] n/a

Distributed Line Unit Specify point or [Route/Segment] n/a

Main Distribution Frame Specify point or [Route/Infrastructure/ 
Segment]

(SITE)

Multi Service Access Node Specify point or [Route/Segment] n/a

DIGICON Terminal Specify point or [Route/Segment] n/a

Microwave Tower Specify point or [Route/Infrastructure/ 
Segment]

(SITE)

Primary Joint Specify point or [Route/Infrastructure/ 
Segment]

(VAULT/SITE/PIT / 
MH/POLE)

Street Distribution Cabinet Specify point or [Route/Segment] n/a

Secondary Joint Specify point or [Route/Infrastructure/ 
Segment]

(VAULT/SITE/PIT / 
MH/POLE)

Service Connection Joint Specify point or [Route/Infrastructure/ 
Segment]

(PIT/DBOX)

Distribution Point Specify point or [Route/Segment] n/a

Distribution Point Building Specify point or [Route/Segment] n/a

Distribution Point Stubby Specify point or [Route/Segment] n/a

Distribution Point Aerial Specify point or [Route/Segment] n/a

Juntion Specify point or [Route/Segment] n/a

Pillar Specify point or [Route/Segment] n/a

Stubby Specify point or [Route/Segment] n/a
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Placing Telecoms Node by Specifying point

1 To capture a Telecoms Node using the Specify Point option do one of the following: 

 Choose Capture > Place Telecoms Node> and select the Node to place.

 or Click the required Node icon on the Munsys Cable Route Place Telecoms Node toolbar.

2 The user is prompted to Specify point or [Route/Segment]

3 Specify a point in the drawing or type an X;Y coordinate and select enter

The specified node is placed

Placing Telecoms Node by specifying a Route

1 To capture a Telecoms Node using the Route option do one of the following: 

 Choose Capture > Place Telecoms Node> and select the Node to place.

 or Click the required Node icon on the Munsys Cable Route Place Telecoms Node toolbar.

2 The user is prompted to Specify point or [Route/Segment]

3 Select the Route option or type R at the command line.

4 At the command line you are then prompted to select a Cable Route.

On selection the Telecom node is placed at the end point of the Cable Route closest to the point selected.

Placing Telecoms Node by specifying Infrastructure

1 To capture a Telecoms Node using the Infrastructure option do one of the following: 

 Choose Capture > Place Telecoms Node> and select the Node to place.

 or Click the required Node icon on the Munsys Cable Route Place Telecoms Node toolbar.

2 The user is prompted to Specify point or [Route/Infrastructure/Segment]

3 Select the Infrastructure option or type I at the command line.

4 At the command line you are then prompted to select one of the permitted Infrastructure types from 
the list provided in brackets i.e. (VAULT/SITE/PIT/MH/POLE).

5 You are then prompted to Specify point relative to the selected Infrastructure.

The Telecom node is placed and linked to the selected Infrastructure. The LINK_ID column 
is updated with the Infrastructure INF_ID value and the LINK_TYPE column is set to 
INFRASTRUCTURE.
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Placing Telecoms Node by specifying a Segment

1 Do one of the following:

 Choose Capture > Place Telecoms Node> and select the Node to place.

 or Click the required Node icon on the Munsys Cable Route Place Telecoms Node toolbar.

2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:

3 Select the Segment option or type S at the command line.

4 At the command line you are prompted to Select segment to snap to

Select a building or parcel segment to snap to.

5 You are then prompted to Specify insertion point

Select a point on the segment

6 You are finally prompted to Specify side for node

Select the side of the segment where the node must be offset from.

The Telecom Node node is placed 

Inserting Telecoms Nodes
Telecoms Nodes can be inserted at any selected point on a cable route, breaking the underlying 
route into two new route objects. The attributes for the broken route are carried across to the 
new route objects and new ROUTE_ID values are assigned from the sequence 
CRS_CRTLINK.

The Telecom nodes can be inserted onto Cable Routes using the Capture > Insert Telecoms 
Node or by selecting the Telecom Node to insert from the Insert Telecom Nodes toolbar. 

1 To insert a Telecoms node do one of the following:

 Choose Capture > Insert Telecoms Node> and select the Node to insert.

 or Click the required Node on the Munsys Cable Route Insert Telecoms Node toolbar.
The command line prompts to select a Cable route.

2 Select a nearest point on the Cable Route where you want to insert the Telecoms Node.

The appropriate node symbol is placed on the route at the point selected and the underlying route 
is broken into two Routes with two new ROUTE_ID values.



Creating and Maintaining cable route data 38 








Draw freehand cable routes
Freehand cable routes are drawn by selecting points in the drawing, or by entering coordinates 
on the command line. The command line prompts you for endpoints, allowing a sequence of 
cable routes to be constructed. Cable Routes are captured on their appropriate layers, to be 
verified when the integrity check is run.

To draw a freehand cable route

1 Do one of the following:

 Choose Capture > Draw Freehand Cable Route.

 Click the Draw Freehand Cable Route... button on the Munsys Cable Route Capture toolbar.

The command line prompts you to specify point.

2 Specify the first point for the freehand cable route. 

 Specify the next point of the freehand cable route drawn as a straight-line segment or change to 
draw an arc segment [Arc/Halfwidth/Length/Undo/Width]. 

 By selecting A, the polyline linear list allows you to continue capturing offset culverts as a series 
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options 
[Angle/CEnter/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]. 

3 Press ENTER when you have specified all the points.

The freehand cable route is created as specified.

Draw offset cable routes
Offset cable routes are drawn by either specifying multiple points along a boundary (for 
example parcel or municipality boundaries), specifying the offset side, and then specifying the 
offset distance.

To draw a offset cable route

1 Do one of the following:

 Choose Capture > Draw Offset Cable Route.

 Click the Draw Offset Cable Route... button on the Munsys Cable Route Capture toolbar.

The command line prompts you to specify point.

2 Specify the first point for the offset cable route. 

 Specify the next point of the offset cable route drawn as a straight-line segment or change to 
draw an arc segment [Arc/Halfwidth/Length/Undo/Width]. 
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 By selecting A, the polyline linear list allows you to continue capturing offset culverts as a series 
of arcs. If selecting the Arc option, the polyline linear list changes with more selection options 
[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]. 

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the cable route.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.

The freehand cable route is created as specified.

3 To draw an offset cable route by selecting segments, do the following: 

 On the command line, type O, and then press ENTER. 

 Select a segment to offset the cable route from. 

 Specify a point on the side to offset the cable route.

 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.

 Continue selecting segments until all the required segments have been selected, and then press 
ENTER. 

 Press ENTER to confirm that you have completed selecting segments. 
The freehand cable route is created as specified.

Note When the user captures a Cable Route, a Network Check Notification integrity validation will be performed 
to ensure that the START_NODE, END_NODE and ROUTE_ID information is auto-populated. Once this 
condition is satisfied the user can then post the newly captured Cable Route data to the database.

Show cable route directions
When you have captured and edited all the cable routes, you have to check the cable route 
direction to verify that it is correct. This can be done for both new and existing cable routes.

To show the cable route directions

1 Choose Capture > Show Cable Route Direction.

2 Select the appropriate cable routes, and then press ENTER. A direction arrow on each selected cable 
route indicates the route direction

The cable route direction is shown as specified.

Change cable route directions
This function is used to reverse the direction of cable routes. This enables users to construct the 
network without taking direction into account. Once the construction is complete, the 
direction can be changed easily

To change the cable route direction

1 Choose Capture > Change Cable Route Direction.



Creating and Maintaining cable route data 40 








2 Select the cable routes of which you want to change the direction, and then press ENTER. The 
direction is reversed automatically.

The cable route direction is changed as specified.

Note The integrity check does not verify cable route direction; therefore it is very important to make certain that 
the cable route direction is correct.

Clear direction arrows

To clear direction arrows
When you are satisfied that the direction of all the cable routes is correct, the direction arrows 
can be cleared from the drawing. 

1 Choose Capture > Clear Direction Arrows.

2 Click the Clear Direction Arrows button on the Capture menu.

The cable route direction arrows will be removed.

Place cable route symbols
This function is used to place cable route symbols in the current drawing. Cable route symbols 
represent additional annotation in the form of a symbol, and do not form part of the cable route 
network. Cable route symbols can be placed anywhere without any restriction. 

Note The database administrator can add additional cable route symbols to the lookup table LU_CRS_CRTSYM 
as required. This table contains a number of default symbols, but can be customized. The user or administrator 
will need to create a corresponding symbol drawing file and place this within the Munsys14.x folder.

To place a cable route symbol

1 Do one of the following:

 Choose Capture > Place Cable Route Symbol.

 Click the Place Cable Route Symbol... button on the Munsys Cable Route Capture toolbar.

The Cable Route Symbols dialog box is displayed, showing a list of available cable route symbols.
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Figure 4 The Cable Route Symbols dialog box

2 From the list, select the symbol that you want to place, and then click OK.

3 Specify an insertion point for the symbol.

4 Specify a rotation angle for the symbol by doing one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle of 
zero.

 Indicate the angle with your mouse pointer by picking a point in the drawing.

 On the command line, type A to align the symbol to an object, press ENTER, and then select 
the object to which you want to align the symbol.

The symbol is placed at the insertion point and angle that you specified.

Note Press ENTER or Spacebar to continue placing consecutive symbols of the same type, without having to 
select a symbol type from the list every time.
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Placing cable route labels
With this function, you can place a label on a cable route that has been queried from the 
database. The cable route label shows the current cable route type, for example ‘COND’. If you 
change the cable route type and post the changes to the database, the label will show the new 
value once it is queried again from the database. Cable route labels can therefore not be placed 
on new cable routes, but only cable routes that have been posted to the database.

To place a cable route label

1 Do one of the following:

 Choose Capture > Place Cable Route Label.

 Click the Place Cable Route Label... button on the Munsys Cable Route Capture toolbar.

The command line prompts you to select a cable route to label.

2 Select the cable route to which you want to attach the label.

3 Specify an insertion point for the label.

4 Specify the tag height for the label, or press ENTER to accept the default tag height.

5 To indicate the tag angle, do one of the following:

 Indicate the tag angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the tag to an object, press ENTER, and then select the 
object to which you want to align the tag to.

The label is placed as specified.
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Placing cable route notes
For map production purposes, information about a spatial object is added in the form of a note.

To place a cable route note

1 Do one of the following:

 Choose Capture > Place Cable Route Note.

 Click the Place Cable Route Note... button on the Munsys Cable Route Capture toolbar.

The command line prompts you to select a cable route to label.

2 Specify the insertion point for the note.

3 On the command line, specify the note height, or press ENTER to accept the default note height.

4 To indicate the note angle, do one of the following:

 Indicate the angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the note to an object, press ENTER, and then select the 
object you want to align the note to.

5 Type the note value on the command line, and then press ENTER.

The note is inserted as specified.
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Placing dimension arrows

To place dimension arrows
Map production is a reduced version of reality and it is therefore virtually impossible to capture 
cable routes at the true offset distance from a parcel boundary. Dimension arrows are used to 
indicate the offset distance of a cable route from a parcel boundary.

1 Do one of the following:

 Choose Capture > Place Dimension Arrow.

 Click the Place Dimension Arrow... button on the Munsys Cable Route Capture toolbar.

The command line prompts you to select a cable route to label.

2 Specify the first segment for dimension.

The dimension arrows will be placed perpendicular to this segment.

3 Specify the second segment for dimension.

The dimension arrows are aligned to the point selected on this segment.

4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance 
as determined in the Cable Route Settings, or press A to place the actual calculated distance.

The dimension text is placed at the dimension arrows, indicating the distance between the two dimension 
lines.
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Cable route integrity
The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial 
objects have to be verified against integrity rules built into the capture and change routines of 
every application before they can be posted to the database. New and changed objects contain 
an internal status that requires the validation process.

The Integrity Check is run from the Capture menu, or by clicking the appropriate button on 
the Integrity toolbar. The way in which the integrity check is executed depends on the 
preferences/options specified in the Munsys Options dialog box. The various options available 
on this dialog box are discussed in detail in the Munsys Concepts User Manual.

The integrity check is split into two separate functions to facilitate flexibility and ease of use:

 Validate Object Integrity – checks and validates the spatial and/or attribute data of an 
object, according to the options specified in the Munsys Options dialog box:

 When the Validate Geometry: Modified objects option has been selected, the geome-
try of only new or modified objects will be validated.

 When the Validate Geometry: All objects option has been selected, all the objects in 
the selection set will have their geometry validated. This includes locked, unlocked, 
modified and non-modified objects. 

When the object integrity check has completed and changes in objects have been 
encountered that may affect network integrity, a warning message to this effect is displayed 
if the option was specified in the Munsys Options dialog box.

 Validate Network Integrity – validates the rules that, together with the objects, make up a 
network, and according to the Network Integrity options specified in the Munsys Options 
dialog box. Network validation includes the topology and connectivity aspects, where 
topology is resembled in the geometry of objects and connectivity by means of attributes 
attached to objects.

This function is dependent on the relationships between objects, and therefore requires 
more objects to be included as part of the validation process than only those that were 
modified. The Validate Network Integrity function allows non-validated objects to be 
selected, but does not attempt to reset any integrity flags. It only places integrity markers 
when errors are encountered in the network. If the selection set contains objects that have 
not been validated by the Validate Object Integrity function, an Object Integrity Warning 
is displayed, recommending that object integrity has to be checked before network 
integrity.

Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network Integrity Check), 
which is set by the database administrator in the Munsys Management Console, allows a network integrity 
check to be performed automatically whenever an object integrity check is run. The same network rules and 
settings still apply. When the integrity check is completed, the Integrity Results dialog box displays a 
combined list of both object and network validations that were performed during the integrity check. When 
this setting is enabled, the object integrity check cannot be integrated with the database posting function, 
and the Automatically perform Object Integrity option on the Munsys Options dialog box Preferences 
tab will be unavailable. 



Creating and Maintaining cable route data 46 








When the cable route object integrity is checked, the following is verified:

Table 5 The cable route object integrity check

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified but, 
because it was unlocked, the integrity check failed to 
rectify the object and it was left as is.

Short spatial objects Applies to any object with a length shorter than the 
Munsys Cable Fiber and Cable Route database tolerance 
setting.

Duplicate points in spatial objects Applies to redundant coordinates being removed from an 
object. If the coordinates are within *SNAP* tolerance, 
they are discarded.

Objects with incomplete geometry Refers to objects that do not have geometry, for example: 
tags that were placed without using the polygon builder 
process do not have a geometry.

Objects outside database extents Checks if the objects selected are within the confines of 
the geographic extents of the database.

Attribute rules Checks for the attribute rules as specified in the 
MUNSYS_INTEG_ATTR table, for example NULL 
values, etc.

Attribute data types Checks the data type to be consistent with what is in the 
database; i.e. attached attributes should not exceed the 
limits of the table's column definition, for example: a tag 
may not be longer than the table's TAG_VALUE column 
width.
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When the cable route network integrity is checked, the following is verified:

Table 6 The cable route network integrity check

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified 
but, because it was unlocked, the integrity check 
failed to rectify the object and it was left as is.

Cable Routes within snap tolerance Checks for cable routes that can snap to other cable 
routes that are within the snap tolerance.

Cable Routes without nodes Checks whether each cable route is connected to a 
node at both ends of the cable route.

Nodes within snap tolerance Checks for nodes that can be snapped to cable 
routes that are within the snap tolerance.

Isolated nodes Checks for nodes that are not connected to any 
cable routes.

Nodes with too many cable routes Checks for nodes that are connected to too many 
cable routes.

Nodes with too few cable routes Checks for nodes that are connected to too few 
cable routes.

Duplicate nodes Checks for nodes that have been captured on top 
of one another.



Creating and Maintaining cable route data 48 








Checking cable route object integrity
1 Do one of the following:

 Choose Capture > Data Integrity > Validate Object Integrity...

 Click the Validate Object Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

The Integrity Results dialog box is displayed, providing summarized information and validation results 
encountered during the object integrity check.

Figure 7 The Integrity Results dialog box

3 If you selected the Notify when objects require network validation option on the Munsys Options 
dialog box, and if objects were encountered during the integrity check that may affect network 
integrity, the following message is displayed:

Figure 8 Network Integrity Warning
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Checking cable route network integrity
1 Do one of the following:

 Choose Capture > Data Integrity > Validate Network Integrity...

 Click the Validate Network Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

3 If you selected objects that have not been validated by the Validate Object Integrity function, the 
following message is displayed:

Figure 9 Object Integrity Warning

4 When the integrity check has completed, the Integrity Results dialog box is displayed, providing 
summarized information and validation results encountered during the network integrity check.

Figure 10 The Integrity Results dialog box
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Browsing integrity markers
You can review the integrity markers resulting from the integrity check with the Browse 
Integrity Markers dialog box. This dialog box displays the complete list of errors encountered 
during the integrity check. The list consists of the error type, the object affected, a description 
of the error, and the GID of the spatial object. From this dialog box, you can locate and remove 
specific integrity markers in the drawing.

To browse integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Browse Integrity Markers...

 Click the Browse Integrity Markers button on the Integrity toolbar.

 Click the Errors... button on the Integrity Results dialog box. 
The Browse Integrity Markers dialog box is displayed.

Figure 11 The Browse Integrity Markers dialog box

2 To locate an error, select the appropriate integrity marker, and then click the Locate button.

Munsys zooms to the extent of the spatial object to which the integrity marker refers.

3 To remove integrity markers from the list and from the drawing, select one or more integrity markers 
from the list, and then click the Remove button.

The integrity markers are removed from the drawing and from the list of markers.
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Erasing integrity markers
With this function, you can erase all the integrity markers. Integrity markers are stored on the 
INTEG layer.

To erase integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Erase Integrity Markers.

 Click the Erase Integrity Markers button on the Integrity toolbar.
The command line prompts you for confirmation to erase all the integrity markers.

2 Press ENTER to erase the integrity markers.

The integrity markers are erased.
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Posting cable route data to the database
New or modified cable route data that has passed the integrity check is posted to the database. 

To post cable route data to the database

1 Do one of the following:

 Choose Capture > Post to Database...

 Click the Post to Database button on the Integrity toolbar.
The Database Posting Summary dialog box is displayed. 

Figure 12 The Database Posting Summary dialog box

This dialog box displays the following:

 The total number of spatial objects selected for posting.

 The number of new objects created.

 The number of attribute changes made.

 The number of spatial changes made.

 The number of objects marked for deletion.

 The number of objects that have not been validated and that will not be posted to the database.

2 Click OK to update the database.

The Database Posting Results dialog box is displayed.



Creating and Maintaining cable route data 53 








Figure 13 The Database Posting Results dialog box

This dialog box displays the following:

 The total number of objects selected for posting to the database.

 The total number of spatial objects inserted into the database.

 The total number of spatial objects modified in the database.

 The total number of spatial objects deleted from the database.

 The total number of objects not posted to the database.

3 Click Close to exit the Database Posting Results dialog box.

Once you have posted objects to the database, you will not be able to undo this function, which will avoid 
duplicate objects and keep the content of the drawing synchronized with the database.
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Validating object integrity and posting data at the same time
If you select the Automatically perform Object Integrity option on the Munsys Options dialog 
box Preferences tab, you can perform an object integrity check and database posting operation 
at the same time. The following rules will be applied when the objects integrity phase of the 
operation is executed:

 Only modified objects will be selected for object integrity

 The integrity flag will be reset automatically if the object passes object integrity

 Integrity markers will be placed accordingly where errors occur, as happens when a normal 
object integrity check is run from the Capture menu

 If an error occurs, the integrity flag will not be reset

 Only objects related to the current application will be included in the object integrity check (i.e. 
if you are working in the cable route application, only cable route objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:

 Ignore the errors that occurred and continue to post the objects that passed the integrity check to 
the database 

 Cancel the database posting operation and return to the map interface 

 View the errors that occurred with the Browse Integrity Markers dialog box (this option also 
cancels the posting operation, allowing you to correct the errors first before attempting to post 
the objects to the database once again)

To validate object integrity and post objects at the same time

1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object 
Integrity check box in the Database Posting Preferences group.

2 Choose Capture > Post to Database.

An object integrity check is run on the all the new or modified objects in the drawing.

3 If any errors occurred, the following message is displayed:

Figure 14 Database Posting – Object Integrity Errors

4 Do one of the following:

 Click Yes to ignore the errors that have occurred and post the objects to the database that have 
passed the integrity check

 Click No to cancel the posting operation and return to the drawing

 Click Errors... to view the errors that occurred using the Browsing Integrity Markers dialog 
box.
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Editing cable route object attributes
The Edit Attributes function is used to edit the attributes of one or more selected cable route 
spatial objects that belong to the same object type. The current application determines what 
object types may be selected; for example, if you are working in Munsys Cable Route, only cable 
route objects may be selected. If you select more than one object type (for example 
infrastructure and cable route nodes), you will be required to choose a single object type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database). 
Once the objects have been selected and an object type to edit has been specified, the Edit 
Attributes dialog box is displayed. This dialog box contains various options that can be used to 
edit the attributes of the spatial objects:

 Attribute templates – attributes can be edited using an attribute template. The attributes 
that will be displayed when an attribute template has been selected will depend on the 
attributes that have been specified on the template, as well as the formatting parameters that 
apply to each column selected as part of the attribute template. If no attribute template has 
been selected, all the attributes belonging to the spatial object type are displayed.

 Editing multiple objects simultaneously – if you select this option, attributes of multiple 
objects are displayed simultaneously. Where the attributes of all the selected objects are the 
same, a value is displayed. Where attributes of the various objects that were selected differ, 
a value of *VARIES* is displayed. When a change is made to a value, the new value is 
applied to all the selected objects. If you do not select the Edit multiple objects 
simultaneously check box, you can edit the selected objects one by one. The values that are 
changed are only applied to the current object.

 AutoZoom – this option is only available when the Edit multiple objects simultaneously 
option is not selected, i.e. when you are going to edit the objects one by one. If the 
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as 
it becomes the current object. The object navigation buttons are used to move from one 
object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column, either by 
typing a new value or by selecting a value from a drop-down list. Changes that are made are 
applied to objects in the drawing. These changes will only be updated in the database when the 
object integrity check has been run and the objects have been posted to the database.

When editing attributes, mandatory fields are displayed with an “!” character prefixing the 
attribute column in the Attributes list on the Edit Attributes dialog box. If the mandatory 
attribute is not captured for new or modified objects, the Object Integrity Check will fail based 
on the attribute rules setup. Using the Browse Integrity Markers option, the Error Info describes 
which column may not be NULL.
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To edit cable route spatial objects

1 Choose Change > Edit Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object Identification 
dialog box is displayed.

Figure 15 The Spatial Object Identification dialog box

3 Select a single spatial object type to edit, and then click OK.

The Edit Attributes: Cable Route Links dialog box is displayed.

Figure 16 The Edit Attributes dialog box
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4 If you want to edit the objects using an attribute template, select the appropriate attribute template 
from the Attribute Template list. If you do not want to make use of an attribute template, select 
None.

5 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple 
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*.

Figure 17 The Edit Attributes dialog box: Edit multiple objects simultaneously

6 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously 
check box. Select the AutoZoom to object check box to zoom to the objects one by one and 
highlight them. The object navigation buttons are used to move from one object to the next.

7 To edit an attribute, do one of the following:

 Highlight a value, and then choose a new value from the drop-down list in the Value column.

 Highlight a value, and then enter a new value in the Value column

Note Mandatory attributes are displayed with an “!” character preceding the Attribute Description. Failure to 
capture mandatory attributes for new or modified objects results in the object failing the Object Integrity 
Check.

8 Click OK to apply the new value(s) to the object(s).

9 The values are applied to the objects, to be verified with the object integrity check.
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Editing linked table attributes
This function is used to edit spatial object attributes that exist in linked tables. Linked table 
attributes are updated directly to the database. The current application determines what object 
types may be selected; for example, if you are working in Munsys Cable Route, only cable route 
objects may be selected. If you select more than one object type (for example infrastructure and 
cable route nodes), you will be required to choose a single object type to edit. You can only select 
objects that have previously been posted to the database.

The link tables that can be edited using this function must be defined through an attribute 
template. The applicable attribute template is selected from a list, which is created by filtering 
attribute templates according to the following characteristics:

 Only attribute templates associated with the current spatial object type, being edited are 
included – the primary table in the attribute template is the same table from which the 
spatial objects were queried.

 Only attribute templates that contain linked tables are included

 The linked table specified may not be a Munsys spatial table

 The user must have edit privileges to the linked table

 The link column used to describe the relationship with the primary table must reference a 
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column by typing in 
a new value. Navigation buttons are used to move between the various records that are available 
and to move from one object to the next. You can also insert records into, or delete records from 
a linked table, depending on the privileges you have on the linked table.

To edit linked table attributes

1 Choose Change > Edit Linked Table Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial

Object Identification dialog box is displayed.
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Figure 18 The Spatial Object Identification dialog box

3 Select a single spatial object type to edit, and then click OK.

The Linked Table Attributes dialog box is displayed.

4 Select the attribute template that you want to work with from the Attribute Templates Containing 
Linked Tables list.

Figure 19 The Select Templates Linked Table Attributes dialog box

The Description, Value and Column Name columns are populated according to the template that you 
selected, and the number of records and objects that were selected are displayed.
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Figure 20 The Linked Table Attributes dialog box

5 Select the AutoZoom to object check box to zoom to each object and highlight it as it becomes the 
current object. 

6 Use the navigation buttons to move between records and objects.

7 To insert a new record, click Insert, and then enter the new values in the Value column.

Figure 21 The Insert Linked Table Attributes dialog box

8 To delete the record that is currently displayed, click Delete.

9 Select either the Cable Route Node or Fiber Joint Node which has changed in location. 
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Changing cable routes

To extend a cable route to a boundary
Cable routes can be extended to a boundary object by first indicating the boundary object, and 
then selecting the cable route to extend. The boundary object must be able to intersect with the 
cable route. This function is often used to extend cable routes to create Junctions during 
capture. The end point of the cable route is then changed to intersect the boundary object.

1 Do one of the following:

 Choose Change > Extend Cable Route to Boundary.

 Click the Extend Cable Route to Boundary button on the Munsys Cable Route Change 
toolbar.

2 Select the boundary object where the cable route has to extend to.

3 Select the cable route that needs to extend.

The cable route is extended as indicated.

To extend a cable route by distance
This function extends a cable route by a specified distance at the endpoint closest to a selected 
point on the cable route. You are prompted for the distance to extend the cable route with. You 
can also use this function to shorten a cable route by entering a negative distance, for example, 
-50.

1 Do one of the following:

 Choose Change > Extend Cable Route by Distance.

 Click the Extend Cable Route by Distance button on the Munsys Cable Route Change toolbar.

2 Select the cable route that you want to extend, and then enter a distance on the command line.

The pipe is extended by the distance that you entered.

To extend a cable route and break it at the intersection
This function extends a cable route to a cable route that is then broken at the intersection. The 
cable route to be broken is selected first, and then the cable route to extend. The cable route to 
be broken must intersect with the second cable route.

1 Do one of the following:

 Choose Change > Extend and Break Cable Route.

 Click the Extend and Break Cable Route button on the Munsys Cable Route Change toolbar.
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2 Select the cable route that you want to break.

3 Select the cable route that you want to extend.

The cable routes are extended and broken respectively, as indicated.

Note If a cable route has duct information attached then the system will flag this, asking the user if the duct 
information should be retained and captured to the new cable routes or not. 

To break a cable route
This function breaks a pipe nearest to a selected point on the pipe.

1 Do one of the following:

 Choose Change > Break Cable Route.

 Click the Break Cable Route button on the Munsys Cable Route Change toolbar.

2 Select a point on the cable route where you want to break it.

The cable route is broken at the point that you selected. 

Note If a cable route has duct information attached then the system will flag this, asking the user if the duct 
information should be retained and captured to the new cable routes or not. 

To change a cable route
With this function, you can move one or more selected cable route endpoints to a new location. 

1 Do one of the following:

 Choose Change > Change Cable Route.

 Click the Change Cable Route button on the Munsys Cable Route Change toolbar.

2 Select the endpoint of the cable route that you want to change.

3 Indicate the destination point.

The cable route is changed as indicated.
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To fillet cable routes
This function connects two cable routes at a projected intersection.

1 Do one of the following:

 Choose Change > Fillet Cable Route.

 Click the Fillet Cable Route button on the Munsys Cable Route Change toolbar.

The command line prompts you to indicate the two cable routes that need to be extended or trimmed.

2 Select the first cable route.

3 Select the second cable route.

The cable routes are connected as indicated.

To trim a cable route

1 Do one of the following:

 Choose Change > Trim Cable Route.

 Click the Trim Cable Route button on the Munsys Cable Route Change toolbar.

2 Select the cable route that you want to trim to, as the cutting edge.

3 Select a point on the side of the second cable route that needs to be trimmed.

Munsys trims the last indicated cable route to the first one.

To join cable routes
This function is used to join two cable routes, creating a single cable route. The attributes from 
the first cable route selected remain the attributes for the joined cable route. If there is a gap 
between the two cable routes to be joined, they are joined with a line segment. A joined cable 
route is created from the geometry of the selected cable routes, and the second cable route 
selected is moved to the DELETED layer. The first selected cable route, now the new joined 
cable route, is flagged as a change to be verified when the integrity check is run.

1 Choose Change > Join Cable Route.

2 Select the first cable route (the cable route that you want to join to).

3 Select a point close to the endpoint of the second cable route (the cable route that you want to join).

The cable route are joined as indicated, and the attributes from the first cable route selected remain the 
attributes for the joined cable route.
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To change the vertex of a cable route
With these functions, you can remove, move, add or insert new vertices to segments in a cable 
route.

To add a vertex to a cable route

1 Choose Change > Change Cable Route Vertex > Add.

2 Select the appropriate cable route.

3 Select the endpoint of the cable route to which you want to add a vertex.

4 Select a position for the new point.

A vertex is added at the point you selected

To move a cable route vertex

1 Choose Change > Change Cable Route Vertex > Move.

2 Select the appropriate cable route.

3 Specify a point closest to the vertex that you want to move.

4 Specify a point to move the vertex to.

The vertex is moved to the point that you specified.

To remove a cable route vertex

1 Choose Change > Change Cable Route Vertex > Remove.

2 Select the appropriate cable route.

3 Select the vertex that you want to remove from the cable route.

Note A vertex can only be removed from a segment with more than two vertices.

To insert a vertex into a cable route

1 Choose Change > Change Cable Route Vertex > Insert.

2 Select the appropriate cable route.

3 Select the segment for the inserted point.

4 Select the position for the new point.

The vertex is inserted at the position you selected.
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Changing cable route nodes
Using the Munsys Cable Route Change menu/toolbar, cable routes nodes can be moved to a 
new location, rotated manually or snapped to cable routes. You can also change the node type 
of one or more selected nodes. These functions are used when the  network is cleaned up after 
the capture process.

To move a node
With this function, you can move a single node to a new location.

1 Do one of the following:

 Choose Change > Move Node.

 Click the Move Node button on the Munsys Cable Route Change toolbar.

2 Select the node that you want to move.

3 Specify a new insertion point for the node.

The node is moved as indicated.

To rotate a node
With this function, you can rotate one or more selected nodes.

1 Do one of the following:

 Choose Change > Rotate Node.

 Click the Rotate Node button on the Munsys Cable Route Change toolbar.

2 Select the node that you want to rotate.

3 To specify the rotation angle, do one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle.

 Indicate the angle with your mouse pointer by picking two points in the drawing.

 On the command line, type A to align the node to a segment, press ENTER, and then select the 
object to which you want to align the node.

The node is rotated as specified.
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To snap a node to the endpoint of a cable route
With this function, you can snap a node to the endpoint of a cable route. The node is moved 
to the end point closest to the point selected on the cable route.

1 Do one of the following:

 Choose Change > Snap Node to Cable Route.

 Click the Snap Node to Cable Route button on the Munsys Cable Route Change toolbar.

2 Select the applicable node.

3 Select the cable route close to the endpoint that you want to snap the node to.

The node is snapped to the endpoint of the cable route.
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To edit a route duct
When the user captures a Cable Route (irrespective of freehand or offset) then the user can then 
manually assign duct information to the newly placed Cable Routes (runs). Logically this would 
indicate the number of ducts available for the Fiber Cable to be placed within.

To Add a New Route Duct

1 Choose Change > Edit Route Duct.

Figure 22 Edit Route Duct Menu Item
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2 Select the appropriate Cable Route.

The Edit Duct Info dialog box is displayed.

Figure 23 The Edit Duct Info dialog box 

The user will notice that the Route ID and Route Type will be populated, which therefore 
requires the Cable Route to be posted to the database.

3 Click on the Ducts text within the Ducts dialog box. Click on the Add button within the Duct 
Information dialog. 

The New Route Duct dialog box should open and the user can then fill in the required information:

 Duct Name: The Duct Name is to be populated here and in most cases following the naming 
convention pertaining to a specific organization.

 Duct Description: A simple Description of the duct is to be populated here, considering any 
specific notes to be indicated by the organization.

 Duct Type: The Type of Duct which is being added such as Direct Bury, Duct Bank, Micro 
Duct, Overhead or Sub Duct.

 Duct Size: The Size of the duct, indicating the actual dimensions.

 Duct Color: This refers to the Color intended to be assigned to the Duct, following the 
international color convention used for Fiber Strands.
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Figure 24 The New Route Duct dialog box

4 Once all the information has been populated the user can then click OK to apply.

The user will now notice the Duct Information has been added.

5 This will bring the user back to the default Edit Duct Dialog. The user can also add ducts within a 
duct, paying careful consideration to the Duct Type feature.

6 Click Commit to save changes to the database.

Figure 25 The Database Information dialog box
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To Modify/Delete Existing Duct Information

1 Choose Change > Edit Route Duct.

2 Select the appropriate cable route.

The Edit Duct Info dialog box is displayed.

3 Click on the relevant Duct from the Duct dialog, and then the user should see associated Duct 
Information at the bottom of the Edit Duct Info dialog.

Figure 26 Edit Duct Info Dialog for Modifying Duct Info

When multiple ducts are added across a variety of cables, then it is difficult for the user to sometimes 
navigate to a particular duct. Easily locating duct information can be effectively carried out by using 
the Search button within the Edit Duct Info dialog box. To do this however, the user should ensure 
that the naming convention of the organization is clearly defined within the text-box as this is 
specific information.

4 Click on either Modify or Delete and follow the prompts.

This should carry out the intended function as desired by the user.
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To copy a route duct
With this function you can copy information from one run/duct to another duct which has no 
information assigned. This provides the user with an easy solution when populating multiple 
ducts, using one duct which has information assigned, without having to recapture each time.

1 Choose Change > Copy Route Duct.

Figure 27 Copy Route Duct Menu Item
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2 Select the appropriate Cable Route you wish to copy information From.

Figure 28 Cable Route Duct Information to Copy From

3 Select the appropriate Cable Route you wish to copy information To.

Figure 29 Cable Route Duct Information to Copy To
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4 Press ENTER.

To change a node type
With this function, you can change the node type of one or more selected nodes. The new node 
type is selected from a list. The symbol name and the NODE_TYPE column are updated 
according to the new node type selected.

1 Choose Change > Change Node Type...

2 Select the node(s) that you want to change, and then press ENTER.

The Node Types dialog box is displayed.

Figure 30 The Node Types dialog box

3 Select the new node type from the list, and then click OK.
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Relink Node

The Relink Node functionality allows the user to update the Node information in instances 
where the start/end node location is changed. The Relink Node function focuses particularly 
on the Fiber Room node and Fiber Joint nodes which are placed in Buildings or Infrastructures 
respectively. 

Instances where the location of a Fiber Room node changes in relation to the respective building 
then the LINK TYPE (Building) and LINK ID (Building GID) will be updated accordingly.

When the location of a Fiber Joint node changes in relation the respective infrastructure then 
the LINK TYPE (Infrastructure) and LINK ID (Infrastructure ID) will be updated accordingly.

To use the Relink Node function

1 Choose Change > Relink Node.

Figure 31 Relink Node function
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2 Select either the Cable Route Node or Fiber Joint Node which has changed in location.

Figure 32 Select Cable Route Node to Relink

3 Select the relevant Building or Infrastructure which the Cable Route Node or Fiber Joint Node 
now resides in.

Figure 33 Select Building to Relink with Cable Route Node
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4 Select the associated Building Floor and Room information

Figure 34 Select Building Floor and Room information

5 Click OK or Press ENTER.

Note A Fiber Room Node may only be linked to a single combination of Floor and Room Number.

Important If you attempt to relink the Fiber Room Node to a Floor and Room combination where an 
existing Fiber Room Node is linked, you will be presented with a message indicating that the Fiber room 
already exists. You will be required to either select and Floor and Room combination that does not have 
an existing Fiber Room Node linked, or capture new Floor / Room Information to link the Fiber Room 
Node to.
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Changing cable route owners
This function is used to change cable route owner attributes. Owner attributes can only be 
edited by users who have been assigned the MUNSYS_CRS_EDIT role. You can change the 
owner type of an existing cable route.

To change cable route owners

1 Choose Change> Change Owner.

The command line prompts you to select cable route objects.

2 Select the cable route to be changed.

The Select Owner dialog box opens.

Figure 35 The Select Owner dialog box

3 In the Select Owner dialog box, select a owner type by Code or Description, and then click OK.
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Changing cable route state
This function is used to change the cable route state. Cable route states can only be edited by 
users who have been assigned the MUNSYS_CRS_EDIT role. You can change the state of an 
existing cable route.

To change cable route state

1 Choose Change> Change State.

The command line prompts you to select a cable route objects.

2 Select the cable route to be changed.

The Select State dialog box opens.

Figure 36 The Select State dialog box

3 In the Select State dialog box, select a state type by Code or Description, and then click OK.
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Changing cable route status
This function is used to change the cable route status. Cable route status can only be edited by 
users who have been assigned the MUNSYS_CRS_EDIT role. You can change the status of an 
existing cable route.

To change cable route status

1 Choose Change> Change Status.

The command line prompts you to select a cable route objects.

2 Select the cable route to be changed.

The Select Status dialog box opens.

Figure 37 The Select Status dialog box

3 In the Select Status dialog box, select a status type by Code or Description, and then click OK.
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Changing cable route notes
With this function, you can change the text of an existing cable route note.

To change a cable route note

1 Choose Change> Change Cable Route Note...

The command line prompts you to select a cable route note.

2 Select the cable route note that you want to change.

The Cable Route Note text box is displayed.

Figure 38 The Cable Route Note text box

3 Change the note as required, and then click OK.

The cable route note is changed as specified.

Adding comments
This function is used to assign descriptive comments to one or more selected objects.

To add comments

1 Choose Change > Add Comment...

The command line prompts you to select a cable route object.

2 Select the cable route object(s) that you want to add a comment to.

The Cable Route Comment text box is displayed.

Figure 39 The Cable Route Comment text box

3 In the text box, add the comment, and then click OK.

The comment is assigned to the selected object(s).
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Deleting and undeleting cable route objects
With Munsys Cable Route, existing cable route objects can be deleted from the database. 
Multiple objects can be selected for deletion. Cable route objects that form part of a redundant 
network have to be deleted. Deleted cable route objects are moved to a frozen layer DELETED, 
which is removed from the database when changes are posted. With the Undelete function, you 
can restore cable route objects that have been moved to the DELETED layer which was marked 
for deletion.

To delete cable route objects

1 Choose Change > Delete Cable Route Objects.

The command line prompts you to select objects to be deleted.

2 Select the cable route objects that you want to delete.

The command line indicates how many cable route objects you have selected, and how many have been 
filtered out.

3 Press ENTER to delete the selected  objects.

The cable route objects are flagged for deletion and moved to the DELETED layer. These changes will be 
applied to the database once its posted.

To undelete cable route objects

1 Choose Change > Undelete Cable Route Objects.

The objects that you have deleted will be displayed in the drawing, and the command line prompts you to 
select objects to undeleted.

2 Select the cable route objects that you want to restore.

The Delete flag is no longer set for the selected objects. In the event of spatial or attribute changes before the 
objects were flagged for deletion, these changes are applied.
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Cable cable route network quality reporting
The Network Quality Report function on the Extras menu is used to validate the quality of the 
entire network. The network quality report complements the network integrity check. 
Although it is recommended that a network integrity check is always done before objects are 
posted to the database, some problems might still be present in the quality of a network. This 
could, for example, be due to the fact that the network integrity check might have been done 
on a small area of the network. The network quality check uses all the objects in the database 
to validate the quality of the entire network. The validation is done at attribute level, without 
having to validate the associated spatial data.

Specific columns in each of the spatial tables are used to build up the topology of the network, 
for example the start and end nodes of a cable route. The network quality report will validate 
these values based on cable route-specific rules. 

Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS 
table, together with the appropriate error message related to each spatial object where an error 
occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query, which will 
use this table as a linked table with a condition based on the SP_TABLE column that matches 
the spatial table name of the query.

If a single spatial object contained more than one error, a record will be stored for each error 
that occurred within that object. You can also have the errors populated to the COMMENTS 
column of the object(s) in which errors occurred, if you do not traditionally use this column for 
other purposes. If more than one error has occurred in an object, the COMMENTS column is 
populated with the last error that is found.

The following table shows the cable fiber and cable route network errors that may occur:

Figure 40 Cable cable route network quality errors

Spatial Table Error Description

SP_CRTLINK NODE MISSING The START_NODE/END_NODE value 
is NULL, or the node ID was not found in 
the SP_CRTNODE table

SP_CRTLINK ID NOT UNIQUE The ROUTE_ID column contains a non-
unique value

SP_CRTLINK ID NULL The value of the ROUTE_ID column is 
NULL

SP_CRTNODE ID NULL The value of the NODE_ID column is 
NULL

SP_CRTNODE SEQUENCE 
EXCEEDED

The value in the NODE_ID column 
exceeds the current value of the 
CRS_CRTNODE sequence

SP_CRTNODE ID NOT UNIQUE The NODE_ID column contains a non-
unique value

SP_CRTNODE NODE ISOLATED The node ID was not found in either the 
START_NODE or END_NODE 
columns of SP_CRTLINK tables
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To validate cable route network quality

1 Choose Extras > Network Quality Report...

The command line displays the message: Generating network quality report

2 If errors were found in the network, the following message is displayed:

Figure 41 Network Quality errors found

3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column 
updated.

The Save Results Summary As dialog box is displayed.

4 Save the report to a location of your choice.

The report is opened in Windows Notepad, and contains the following information:

 The number of objects that were checked

 The number of objects found that violated the network rules

 The number of endpoints that were found in the network

 The number of errors that were found, grouped by error type

Figure 42 A cable route network quality report
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Generating cable route data status reports
Data status reports provide summarized information about spatial objects that are currently 
stored in the database. Once a report has been generated, it is saved to a comma delimited file, 
and then displayed in Notepad for easy viewing. The following reports can be generated for 
cable route objects:

 a summary of all the cable route objects in the database

 a summary of the total length and number of cable routes, by type and category

 a summary of the umber of cable route nodes by node type

To generate a cable fiber and cable route data status report

1 Choose Extras > Data Status Report...

The Data Status Report dialog box is displayed, showing a list of all the reports that can be generated.

Figure 43 The Data Status Report dialog box

2 Select one or more reports to generate from the list, and then click OK.

3 Save the file to a location of your choice.

The file is opened in Windows Notepad.
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Figure 44 Data status report for service connections



Creating and Maintaining cable route data 86 








Converting AutoCAD entities to cable route objects
With Munsys, you can convert selected AutoCAD entities to Munsys Cable Route objects. 
Block entities can be converted to cable route nodes (switches, distributed line units, main 
distribution frames, etc.), or line entities can be converted to cable routes, text can be converted 
to a cable route note, and polygons can be converted to cable route infrastructure.

Although some basic attributes are assigned as part of the conversion process, you will need to 
assign attributes to the objects created with the conversion process.

To convert block entities to cable route nodes
With this function, you can convert AutoCAD block entities to any of the available cable route 
nodes. To convert block entities to cable route nodes, do the following:

1 Choose Extras > Convert Block to > Switch / Distributed Line Unit / Main Distribution Frame / 
Multi Service Access Node/ DIGICON Terminal / Microwave Tower/ Fiber Termination Box / 
Fiber Distribution Hub / Primary Joint / Street Distribution Cabinet / Secondary Joint / Service 
Connection Joint / Distribution Point / Distribution Point Building / Distributing Point Stubby / 
Distribution Point Aerial / Junction / Pillar / Stubby.

2 Select the block entities that you want to convert, and then press ENTER.

One cable route node is created for each block entity that you selected, and the drawing is updated 
accordingly.

To convert line entities to cable routes
With this function, you can convert AutoCAD line entities to cable routes. To convert line 
entities to cable routes, do the following:

1 Choose Extras > Convert Line to Cable Route.

2 Select the line objects that you want to convert to cable route objects, and then press ENTER.

The selected line objects are converted and the drawing is updated accordingly.

To convert text to cable route notes
With this function, you can convert AutoCAD text entities to cable route notes.

1 Choose Extras > Convert Text to Cable Route Note.

2 Select the objects that you want to convert, and then press ENTER.

The entities are converted to the cable route objects, and the drawing is updated accordingly.

To convert polygons to cable route infrastructure

1 Choose Extras > Convert Polygon to cable route infrastructure.

2 Select the polygons that you want to convert, and then press ENTER.

The polygons are converted to cable route infrastructure, and the drawing is updated accordingly.



80 








 Chapter 5


 Creating and Maintaining cable fiber data

Capturing and Modifying cable fiber data
Once the capture of cable route data has been executed then the user can proceed with the 
capture of cable fiber data. This is the last component of the Cable Fiber Application and refers 
the actual cable. It comprises of the Cable and Strands which are terminated between buildings 
and in doing so, establishing the connection of services between buildings as per the users 
specifications.

A detailed look at the processes that occur when capturing and modifying cable fiber data is 
outlined in this chapter, together with the Termination of Fiber Room Nodes, adding of 
Equipment and Channels, Connection of fiber cables and addition of Services onto Strands 
and Channels.

Maintaining cable fiber data can occur from accessing the Change menu where these detailed 
processes mentioned above, including ReRouting cables, the management of Equipment and 
managing Fiber Cable Duct Info.

A detailed look at the capture and modification of cable fiber data will be captured in this 
chapter.
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Cable Fiber 

Cable fiber capture settings
Each Munsys application has its own default capture settings that are set by the GIS 
administrator in the Munsys Management Console. 

In Munsys Cable Fiber, default settings are available for:

 Cable Fiber – cable fiber auto terminate, cable fiber auto trace, dimension distance, duct 
prompt, fiber group, label height, and type, Cable Fiber Zoom to Node and Cable Fiber 
Zoom to Node Scale Factor.

 Cable Fiber Symbols – cable fiber symbol scale

 Dimensions – dimension note height

 Fiber Geom Settings – geometry arc distance, geometry tolerance, geometry unit

 File – the drawing directory

 General – construction color, include network in object integrity, database extents display 
resolution, integrity circle size, tag and symbol scale and rotation if coordinate 
transformation is done, snap tolerance, tag angle, font, height and justification

 Notes – note tag height

You can change the current settings on the Cable Fiber Settings dialog box to speed up the 
capture process. Capture settings only apply to new cable fiber objects, and if you change the 
default settings, the changes are only valid for the current session.

Settings are changed by highlighting the current value, and then:

 entering a new value

 selecting the new value from a drop-down list

The user cannot change all of the settings. Some settings may only be changed by the GIS 
administrator to enforce consistency and integrity on a higher level. Settings that cannot be 
changed are “greyed out” on the Capture Settings dialog box.

Tip A short description of a value displays when it is highlighted.
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To specify cable fiber capture settings

1 Do one of the following:

 Choose Capture > Cable Fiber Settings...

 Click the Cable Fiber Settings... button on the Munsys Cable Route Capture toolbar.

2 The Cable Fiber Settings dialog box is displayed, showing the default cable fiber capture settings.

The Cable Fiber settings dialog box opens.

Figure 1 The Cable Fiber Settings dialog 

3 To change a value, do one of the following:

 Highlight the current value, and then enter a new value.

 Highlight the current value, and then choose the new value from the drop-down list.

4 Click OK to apply the new settings.

The settings will apply until you change them again, or until the current session is terminated.

Note The Auto-Terminate function is ticked on by default, however if this is ticked off, then the user would have 
to ensure that the Fiber Room Nodes are manually Terminated before deploying equipment. If both Fiber 
Room Nodes are not terminated, after capturing a Fiber cable, then the deployed equipment would not be 
displayed to the end user.

Some values are changed by selecting a 
value from a drop-down list. 

Some values are changed by 
manually entering a new 
value.

Some values are changed by 
checking/un-checking the 
tick-box
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Note The Cable Fiber Auto Trace setting determines if auto tracing is enabled when capturing a new fiber cable. If 
enabled, it will automatically trace the fiber cable between the two selected two nodes if there is no alternative 
route.

Note The Cable Fiber Zoom to Node setting determines if the fiber cable capture function will automatically zoom 
to the node. The check-box is ticked on by default.

Note The Cable Fiber Zoom to Node Scale Factor setting is the default scale factor used when automatically 
zooming to the node during the fiber cable capture process. The default scale factor is 1500m and can be 
changed by the user for the session by entering a new value, or can be updated for all users in the Munsys 
Management Console by the administrator.

Define New Fiber Cable
This is the last component of the Cable Fiber Application and refers to the actual cable. It 
comprises of the Cable and Strands which are terminated between buildings and in doing so, 
establishing the connection of services amongst these buildings

To define a new fiber cable

1 Choose Capture > Define New Fiber Cable.

The command line prompts you to select a start node.

2 Select the start node.

The command line prompts you to select the end node.

3 Select the end node.

The command line prompts you to select a cable route.

4 Select the cable route/s.

The command line prompts you if you are done selecting cable routes.

Note If the Cable Fiber Auto Trace setting is enabled it will automatically trace the fiber cable between the two 
selected nodes if there is no other fiber cable connected to the selected start node. You may be required to 
select additional cable routes where there is more than one option when tracing.

5 On the command line, specify YES, and press ENTER.

The Fiber Cable Info dialog box opens.
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Figure 2 The Fiber Cable Info dialog box 

The Fiber Cable Info dialog auto-populates the From Node and To Node Information based 
on the Building or Infrastructure selected when defining the Cable Route.

6 Define the fiber cable, do the following:

 Capture a unique reference ID for the fiber cable.

 Enter the Length of the fiber cable, inclusive of any cable slack at either end of the fiber cable.

Note Select the Set Meterage... option to view the Fiber Cable Geometry Length based on the actual fiber cable 
drawn in the drawing. 

 Capture any notes specific to the fiber cable for reference.

 Select the Cable Owner from the Cable Owner list.

 Select the Cable Diameter from the Cable Diameter list.

 Use the date picker to select the Cable Manufacture Date.

 Use the date picker to select the Cable Installation Date.

 Select the fiber cable type from the Cable Type list.

 Select the fiber cable group from the Cable Group list.

 Press OK to confirm that you have completed the fiber cable information. 
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 If Duct information has been defined when the Cable Route was captured, the user will be 
prompted to select the duct in which the fiber cable is routed on the Edit Cable Duct Info dialog.

Figure 3 The Edit Duct Info

The fiber cable is inserted as specified.

If the Set Meterage... option is selected, the Fiber Cable Info dialog is displayed where the Start 
and End meterage values can be entered and the Cable Length is automatically calculated. The 
Splice Length, Start and End Wall lengths can also be manually entered.
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Figure 4 The Fiber Cable Info dialog box for Set Meterage

The user will have the option to place a Single mode fiber cable or a Mixed Mode fiber cable. 
A Single mode fiber cable communicates in only one direction, either a Transmit or Receive. 
Contrary to that, the Mixed Mode fiber cable is thicker but can Transmit and Receive on the 
same strand, however has a lower throughput than a Single mode fiber.

Important When a fiber cable is deleted, this would be removed from within the database immediately, 
thereby making the UNDO function obsolete. The user would then be unable to UNDO the deletion of 
that specific cable.
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Show cable fiber directions
When you have captured and edited all the cable fibers, you have to check the cable fiber 
direction to verify that it is correct. This can be done for both new and existing cable fibers.

To show the cable fiber directions

1 Choose Capture > Show Cable Fiber Direction.

2 Select the appropriate cable fibers, and then press ENTER. A direction arrow on each selected cable 
fiber indicates the direction

The cable fiber direction is shown as specified.

Clear direction arrows

To clear direction arrows
When you are satisfied that the direction of all the cable routes is correct, the direction arrows 
can be cleared from the drawing. 

1 Choose Capture > Clear Direction Arrows.

2 Click the Clear Direction Arrows button on the Capture menu.

The cable fiber direction arrows will be removed.

Place cable fiber symbols
This function is used to place cable fiber symbols in the current drawing. Cable fiber symbols 
represent additional annotation in the form of a symbol, and do not form part of the cable fiber 
network. Cable fiber symbols can be placed anywhere without any restriction and does not 
break the network. 

Note The database administrator can add additional cable fiber symbols to the lookup table LU_CFS_FIBSYM as 
required. This table contains a number of default symbols, but can be customized.

To place a cable fiber symbol

1 Do one of the following:

 Choose Capture > Place Cable Fiber Symbol.

 Click the Place Cable Fiber Symbol... button on the Munsys Cable Fiber Capture toolbar.

The Cable Fiber Symbols dialog box is displayed, showing a list of available cable fiber symbols.
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Figure 5 The Cable Fiber Symbols dialog box

2 From the list, select the symbol that you want to place, and then click OK.

3 Specify an insertion point for the symbol.

4 Specify a rotation angle for the symbol by doing one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle of 
zero.

 Indicate the angle with your mouse pointer by picking a point in the drawing.

 On the command line, type A to align the symbol to an object, press ENTER, and then select 
the object to which you want to align the symbol.

The symbol is placed at the insertion point and angle that you specified.

Note Press ENTER or Spacebar to continue placing consecutive symbols of the same type, without having to 
select a symbol type from the list every time.
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Placing cable fiber notes
For map production purposes, information about a spatial object is added in the form of a note.

To place a cable fiber note

1 Do one of the following:

 Choose Capture > Place Cable Fiber Note.

 Click the Place Cable Fiber Note... button on the Munsys Cable Fiber Capture toolbar.

The command line prompts you to select a cable fiber to label.

2 Specify the insertion point for the note.

3 On the command line, specify the note height, or press ENTER to accept the default note height.

4 To indicate the note angle, do one of the following:

 Indicate the angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the note to an object, press ENTER, and then select the 
object you want to align the note to.

5 Type the note value on the command line, and then press ENTER.

The note is inserted as specified.
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Placing dimension arrows

To place dimension arrows
Map production is a reduced version of reality and it is therefore virtually impossible to capture 
cable fiber at the true offset distance from a parcel boundary. Dimension arrows are used to 
indicate the offset distance of a cable fiber from a parcel boundary.

1 Do one of the following:

 Choose Capture > Place Dimension Arrow.

 Click the Place Dimension Arrow... button on the Munsys Cable Fiber Capture toolbar.

The command line prompts you to select a cable fiber to label.

2 Specify the first segment for dimension.

The dimension arrows will be placed perpendicular to this segment.

3 Specify the second segment for dimension.

The dimension arrows are aligned to the point selected on this segment.

4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance 
as determined in the Cable Fiber Settings, or press A to place the actual calculated distance.

The dimension text is placed at the dimension arrows, indicating the distance between the two 
dimension lines.
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Cable fiber integrity
The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial 
objects have to be verified against integrity rules built into the capture and change routines of 
every application before they can be posted to the database. New and changed objects contain 
an internal status that requires the validation process.

The Integrity Check is run from the Capture menu, or by clicking the appropriate button on 
the Integrity toolbar. The way in which the integrity check is executed depends on the 
preferences/options specified in the Munsys Options dialog box. The various options available 
on this dialog box are discussed in detail in the Munsys Concepts User Manual.

The integrity check is split into two separate functions to facilitate flexibility and ease of use:

 Validate Object Integrity – checks and validates the spatial and/or attribute data of an 
object, according to the options specified in the Munsys Options dialog box:

 When the Validate Geometry: Modified objects option has been selected, the geome-
try of only new or modified objects will be validated.

 When the Validate Geometry: All objects option has been selected, all the objects in 
the selection set will have their geometry validated. This includes locked, unlocked, 
modified and non-modified objects. 

When the object integrity check has completed and changes in objects have been 
encountered that may affect network integrity, a warning message to this effect is displayed 
if the option was specified in the Munsys Options dialog box.

 Validate Network Integrity – validates the rules that, together with the objects, make up a 
network, and according to the Network Integrity options specified in the Munsys Options 
dialog box. Network validation includes the topology and connectivity aspects, where 
topology is resembled in the geometry of objects and connectivity by means of attributes 
attached to objects.

This function is dependent on the relationships between objects, and therefore requires 
more objects to be included as part of the validation process than only those that were 
modified. The Validate Network Integrity function allows non-validated objects to be 
selected, but does not attempt to reset any integrity flags. It only places integrity markers 
when errors are encountered in the network. If the selection set contains objects that have 
not been validated by the Validate Object Integrity function, an Object Integrity Warning 
is displayed, recommending that object integrity has to be checked before network 
integrity.

Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network Integrity Check), 
which is set by the database administrator in the Munsys Management Console, allows a network integrity 
check to be performed automatically whenever an object integrity check is run. The same network rules and 
settings still apply. When the integrity check is completed, the Integrity Results dialog box displays a 
combined list of both object and network validations that were performed during the integrity check. When 
this setting is enabled, the object integrity check cannot be integrated with the database posting function, 
and the Automatically perform Object Integrity option on the Munsys Options dialog box Preferences 
tab will be unavailable. 
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When cable fiber object integrity is checked, the following is verified:

Table 6 The cable fiber object integrity check

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified but, 
because it was unlocked, the integrity check failed to 
rectify the object and it was left as is.

Short spatial objects Applies to any object with a length shorter than the 
Munsys Cable Fiber and Cable Route database tolerance 
setting.

Duplicate points in spatial objects Applies to redundant coordinates being removed from an 
object. If the coordinates are within *SNAP* tolerance, 
they are discarded.

Objects with incomplete geometry Refers to objects that do not have geometry, for example: 
tags that were placed without using the polygon builder 
process do not have a geometry.

Objects outside database extents Checks if the objects selected are within the confines of 
the geographic extents of the database.

Attribute rules Checks for the attribute rules as specified in the 
MUNSYS_INTEG_ATTR table, for example NULL 
values, etc.

Attribute data types Checks the data type to be consistent with what is in the 
database; i.e. attached attributes should not exceed the 
limits of the table's column definition, for example: a tag 
may not be longer than the table's TAG_VALUE column 
width.
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Checking cable fiber object integrity
1 Do one of the following:

 Choose Capture > Data Integrity > Validate Object Integrity...

 Click the Validate Object Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

The Integrity Results dialog box is displayed, providing summarized information and validation results 
encountered during the object integrity check.

Figure 7 The Integrity Results dialog box

3 If you selected the Notify when objects require network validation option on the Munsys Options 
dialog box, and if objects were encountered during the integrity check that may affect network 
integrity, the following message is displayed:

Figure 8 Network Integrity Warning
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Checking cable fiber network integrity
1 Do one of the following:

 Choose Capture > Data Integrity > Validate Network Integrity...

 Click the Validate Network Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

3 If you selected objects that have not been validated by the Validate Object Integrity function, the 
following message is displayed:

Figure 9 Object Integrity Warning

4 When the integrity check has completed, the Integrity Results dialog box is displayed, providing 
summarized information and validation results encountered during the network integrity check.

Figure 10 The Integrity Results dialog box
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Browsing integrity markers
You can review the integrity markers resulting from the integrity check with the Browse 
Integrity Markers dialog box. This dialog box displays the complete list of errors encountered 
during the integrity check. The list consists of the error type, the object affected, a description 
of the error, and the GID of the spatial object. From this dialog box, you can locate and remove 
specific integrity markers in the drawing.

To browse integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Browse Integrity Markers...

 Click the Browse Integrity Markers button on the Integrity toolbar.

 Click the Errors... button on the Integrity Results dialog box. 
The Browse Integrity Markers dialog box is displayed.

Figure 11 The Browse Integrity Markers dialog box

2 To locate an error, select the appropriate integrity marker, and then click the Locate button.

Munsys zooms to the extent of the spatial object to which the integrity marker refers.

3 To remove integrity markers from the list and from the drawing, select one or more integrity markers 
from the list, and then click the Remove button.

The integrity markers are removed from the drawing and from the list of markers.



Creating and Maintaining cable fiber data 96 








Erasing integrity markers
With this function, you can erase all the integrity markers. Integrity markers are stored on the 
INTEG layer.

To erase integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Erase Integrity Markers.

 Click the Erase Integrity Markers button on the Integrity toolbar.
The command line prompts you for confirmation to erase all the integrity markers.

2 Press ENTER to erase the integrity markers.

The integrity markers are erased.
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Posting cable fiber data to the database
New or modified cable fiber and cable route data that has passed the integrity check is posted 
to the database. 

To post cable fiber data to the database

1 Do one of the following:

 Choose Capture > Post to Database...

 Click the Post to Database button on the Integrity toolbar.
The Database Posting Summary dialog box is displayed. 

Figure 12 The Database Posting Summary dialog box

This dialog box displays the following:

 The total number of spatial objects selected for posting.

 The number of new objects created.

 The number of attribute changes made.

 The number of spatial changes made.

 The number of objects marked for deletion.

 The number of objects that have not been validated and that will not be posted to the database.

2 Click OK to update the database.

The Database Posting Results dialog box is displayed.
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Figure 13 The Database Posting Results dialog box

This dialog box displays the following:

 The total number of objects selected for posting to the database.

 The total number of spatial objects inserted into the database.

 The total number of spatial objects modified in the database.

 The total number of spatial objects deleted from the database.

 The total number of objects not posted to the database.

3 Click Close to exit the Database Posting Results dialog box.

Note Once you have posted objects to the database, you will not be able to undo this function, which will avoid 
duplicate objects and keep the content of the drawing synchronized with the database.
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Validating object integrity and posting data at the same time
If you select the Automatically perform Object Integrity option on the Munsys Options dialog 
box Preferences tab, you can perform an object integrity check and database posting operation 
at the same time. The following rules will be applied when the objects integrity phase of the 
operation is executed:

 Only modified objects will be selected for object integrity

 The integrity flag will be reset automatically if the object passes object integrity

 Integrity markers will be placed accordingly where errors occur, as happens when a normal 
object integrity check is run from the Capture menu

 If an error occurs, the integrity flag will not be reset

 Only objects related to the current application will be included in the object integrity check (i.e. 
if you are working in the cable route application, only cable route objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:

 Ignore the errors that occurred and continue to post the objects that passed the integrity check to 
the database 

 Cancel the database posting operation and return to the map interface 

 View the errors that occurred with the Browse Integrity Markers dialog box (this option also 
cancels the posting operation, allowing you to correct the errors first before attempting to post 
the objects to the database once again)

To validate object integrity and post objects at the same time

1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object 
Integrity check box in the Database Posting Preferences group.

2 Choose Capture > Post to Database.

An object integrity check is run on the all the new or modified objects in the drawing.

3 If any errors occurred, the following message is displayed:

Figure 14 Database Posting – Object Integrity Errors

4 Do one of the following:

 Click Yes to ignore the errors that have occurred and post the objects to the database that have 
passed the integrity check

 Click No to cancel the posting operation and return to the drawing

 Click Errors... to view the errors that occurred using the Browsing Integrity Markers dialog 
box.
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Editing cable fiber object attributes
The Edit Attributes function is used to edit the attributes of one or more selected cable fiber 
and cable route spatial objects that belong to the same object type. The current application 
determines what object types may be selected; for example, if you are working in Munsys Cable 
Fiber, only cable fiber objects may be selected. If you select more than one object type (for 
example infrastructure and cable route nodes), you will be required to choose a single object 
type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database). 
Once the objects have been selected and an object type to edit has been specified, the Edit 
Attributes dialog box is displayed. This dialog box contains various options that can be used to 
edit the attributes of the spatial objects:

 Attribute templates – attributes can be edited using an attribute template. The attributes 
that will be displayed when an attribute template has been selected will depend on the 
attributes that have been specified on the template, as well as the formatting parameters that 
apply to each column selected as part of the attribute template. If no attribute template has 
been selected, all the attributes belonging to the spatial object type are displayed.

 Editing multiple objects simultaneously – if you select this option, attributes of multiple 
objects are displayed simultaneously. Where the attributes of all the selected objects are the 
same, a value is displayed. Where attributes of the various objects that were selected differ, 
a value of *VARIES* is displayed. When a change is made to a value, the new value is 
applied to all the selected objects. If you do not select the Edit multiple objects 
simultaneously check box, you can edit the selected objects one by one. The values that are 
changed are only applied to the current object.

 AutoZoom – this option is only available when the Edit multiple objects simultaneously 
option is not selected, i.e. when you are going to edit the objects one by one. If the 
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as 
it becomes the current object. The object navigation buttons are used to move from one 
object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column, either by 
typing a new value or by selecting a value from a drop-down list. Changes that are made are 
applied to objects in the drawing. These changes will only be updated in the database when the 
object integrity check has been run and the objects have been posted to the database.
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To edit cable fiber spatial objects

5 Choose Change > Edit Attributes...

Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object 
Identification dialog box is displayed.

Figure 15 The Edit Attributes dialog box

6 Select the single spatial object type to edit, and then click OK.

The Edit Attributes: Fiber Cable dialog box is displayed.

Figure 16 The Edit Attributes: Fiber Cable dialog box
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7 If you want to edit the objects using an attribute template, select the appropriate attribute template 
from the Attribute Template list. If you do not want to make use of an attribute template, select 
None.

8 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple 
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*.

Figure 17 The Edit Attributes dialog box: Edit multiple objects simultaneously

9 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously 
check box. Select the AutoZoom to object check box to zoom to the objects one by one and 
highlight them. The object navigation buttons are used to move from one object to the next.

10 To edit an attribute, do one of the following:

 Highlight a value, and then choose a new value from the drop-down list in the Value column.

 Highlight a value, and then enter a new value in the Value column

11 Click OK to apply the new value(s) to the object(s).

12 The values are applied to the objects, to be verified with the object integrity check.
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Editing linked table attributes
This function is used to edit spatial object attributes that exist in linked tables. Linked table 
attributes are updated directly to the database. The current application determines what object 
types may be selected; for example, if you are working in Munsys Cable Fiber, only cable fiber 
objects may be selected. If you select more than one object type (for example infrastructure and 
cable route nodes), you will be required to choose a single object type to edit. You can only select 
objects that have previously been posted to the database.

The link tables that can be edited using this function must be defined through an attribute 
template. The applicable attribute template is selected from a list, which is created by filtering 
attribute templates according to the following characteristics:

 Only attribute templates associated with the current spatial object type, being edited are 
included – the primary table in the attribute template is the same table from which the 
spatial objects were queried.

 Only attribute templates that contain linked tables are included

 The linked table specified may not be a Munsys spatial table

 The user must have edit privileges to the linked table

 The link column used to describe the relationship with the primary table must reference a 
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column by typing in 
a new value. Navigation buttons are used to move between the various records that are available 
and to move from one object to the next. You can also insert records into, or delete records from 
a linked table, depending on the privileges you have on the linked table.

To edit linked table attributes

1 Choose Change > Edit Linked Table Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial

Object Identification dialog box is displayed.
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Figure 18 The Spatial Object Identification dialog box

3 Select a single spatial object type to edit, and then click OK.

The Linked Table Attributes dialog box is displayed.

4 Select the attribute template that you want to work with from the Attribute Templates Containing 
Linked Tables list.

Figure 19 The Select Templates Linked Table Attributes dialog box

The Description, Value and Column Name columns are populated according to the template that you 
selected, and the number of records and objects that were selected are displayed.
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Figure 20 The Linked Table Attributes dialog box

5 Select the AutoZoom to object check box to zoom to each object and highlight it as it becomes the 
current object. 

6 Use the navigation buttons to move between records and objects.

7 To insert a new record, click Insert, and then enter the new values in the Value column.

Figure 21 The Insert Linked Table Attributes dialog box

8 To delete the record that is currently displayed, click Delete.

9 Select either the Cable Route Node or Fiber Joint Node which has changed in location.
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Edit Fiber Cable Info
This function is used to edit Fiber Cable information, update Cable Ref ID, add/remove or 
update cable notes, change Owner and Diameter values, and updating the Manufacture and 
Installation Dates. The Fiber Cable Length can be updated, or recalculated by selecting the Set 
Meterage option, removing the existing length, and re-entering Start and End Meterage values. 

The Fiber Cable Type is greyed out and may not be updated. If the Fiber Cable Type requires 
changing, the Fiber Cable must be deleted and recaptured.

To edit Fiber Cable 

1 Choose Change > Edit Fiber Cable...

2 Select the Fiber Cable that you want to edit, and then press ENTER.

The Fiber Cable Info dialog box is displayed.

Important You may only select one Fiber Cable at a time.

Figure 22 Edit Fiber Cable

3 To edit an attribute, do one of the following:

 Highlight a value, and then choose a new value from the drop-down list in the Value column.

 Highlight a value, and then enter a new value in the Value column

4 Click OK to apply the new value(s) to the selected Fiber Cable.

5 The values are applied to the object and posted directly to the database. No Object or network 
integrity checks are required.
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Changing cable fiber objects

To Terminate / UnTerminate a cable fiber object

When the user navigates to the Terminate/UnTerminate dialog, the Terminate at Node 
information will be displayed by default to indicate to the user which node is being Terminated. 
Also there will be a drop-down with the relevant Cable information which the user aims to have 
terminated (inclusive of the strands and equipment).

A Fiber Cable will consist of a Tube and within each Tube will be 12 individual Strands starting 
from 01 Blue to 12 Aqua. 

Based on the type of Fiber Cable being defined by the user, if there is more than one Tube then 
the naming convention will continue from 12 Aqua incrementally as opposed to restarting from 
01 Blue. Equipment can also be added and Connected through to Strands to allow for 
connection and addition of services.

The desired workflow process is outlined below.

1 Do one of the following:

 Choose Change > Terminate / UnTerminate.

 Click the Terminate / UnTerminate button on the Munsys Cable Fiber Change toolbar.

The command line prompts you to select a cable route node.

2 Select the fiber cable node that you want to Terminate / UnTerminate. 

The Terminate Fiber dialog box will appear, requiring the user to enter in information.

Note If more than one cable terminates at the selected node, the user should select the Cable drop-down box and 
select the required cable

Figure 23 Terminate Fiber cable selection when multiple Fiber Cables are terminated
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Figure 24 The Munsys - Terminate Fiber dialog box

The user will notice when the Terminate Fiber dialog box is opened, then the Node information 
will be displayed at the top, informing users which Node is being Terminated.

All Fiber dialogs have the Expand/Collapse All and Check/UnCheck All options which can be 
access via a Right click on an empty space in any of the Fiber dialogs. This ensures that the user 
can easily perform any of the above functions effortlessly when there are many tubes comprising 
of various strands. By holding CNTRL and a Left-Click on a tube will subsequently also select 
all strands within the specified tube.

Within this dialog the user should pay attention to the action being performed as this will cause 
buttons to be greyed out sometimes. This is done to prevent certain actions and potential 
corruption of data workflow which threatens to compromise data quality in violating Munsys 
business principles. 

 Disconnect will only be available if user has equipment channels connected to the strand 
however will be greyed out if a Service is added to this.

 The Mark Damaged will be greyed out if a strand or channels are spliced or a service is added.

Users can also define the Cable Owner and Strand Tenancy information within this dialog.
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To define the parameters for Terminating a Fiber Room Node:

1 Select the Fiber Cable from the drop-down list intended to be Terminated.

2 Tick the relevant Tube to be terminated.

3 Enter in the Location information as required below:

Figure 25 Terminate Fiber Location Information

4 Click on the Terminate button.

5 Click on the Set button. 

Note Notice that now the information will be populated in the Information sub-section of the 
Terminate/UnTerminate dialog. If multiple tubes are selected then the user can simultaneously enter in 
Rack/Cabinet and Enclosure/Sub-Rack, however Tray/Panel will be unique to the tube.The location 
information will be disabled for editing if there is a Commit required within this dialog.
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Fiber Owner / Strand Tenancy

We know that a fiber cable comprises of a number of 12 strands, which carry services to the end 
user. Telecommunications company layout fiber cables and related infrastructure which end up 
in the properties of the end users. These companies are known as the Fiber Owners.

A tenant then rents out these fiber strands within the fiber cables, which essentially carry the 
services to the end user. This information can be captured within the Terminate / UnTerminate 
dialog box to better reflect the details of the owner of the cable and tenant of the strand. To set 
this information the user should:

1 Navigate to Change > Terminate / UnTerminate menu item.

2 Select a Fiber Room Node.

3 Select the Cable drop down arrow & select a fiber cable (1).

4 Select the Cable Owner drop down (2) & select a Fiber Cable Owner from the drop down.

5 Hit the Set button once done (3).

The dialog should look something like this:

Figure 26 Defining fiber owner information
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The user will notice that the cable owner information has been defined.

Figure 27 Fiber owner information defined
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To set the Strand Tenancy the user should:

1 Select the Fiber Strands which the Tenancy is to be defined.

2 Select the Strand Tenancy & select the Strand Tenant from the drop down.

3 Hit the Set button once done.

Figure 28 Defining strand tenancy
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The user will notice that the strand tenancy information has been defined.

Figure 29 Strand tenancy defined
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Mark/UnMark Fiber Strands as Damaged

There is also an option for the user to Mark the Fiber Cable Strand as Damaged, if the strand 
has been damaged in which case would not be able to carry a Service. Conversely if the user 
incorrectly marks the wrong strand as damaged then the user can use the UnMark Damaged 
function.

Figure 30 Terminate Fiber dialog Mark Damaged/UnMark Damaged

To Mark a Strand as Damaged then user should:

1 Click on the strand which is to be marked as Damaged. Multiple strands can be marked as 
Damaged simultaneously.

2 Click on the Mark Damaged button. 

Note Notice that the icon should change to reflect the Strand is Damaged. Hence the user would be unable to 
connect or add a service on that strand.
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To UnMark a Strand as Damaged then the user should:

1 Click on the strand which is to be Unmarked as Damaged. Multiple strands can be selected to 
UnMark as Damaged simultaneously.

2 Click on the UnMark Damaged button. 

The user will then also notice that the icon should change indicating that the strand can now be 
connected and carry a service.

Adding Equipment to Connect through to a Strand
Equipment can also be Connected through to a Strand, to ensure a single Fiber Strand has more 
channels/equipment attached, essentially indicating more services can be carried on a particular 
strand, this is also known as a Multiplexer/Splitter functionality.

To initiate this function the user should:

1 Click on the Edit Equipment button.

Figure 31 Edit Equipment command in Terminate Fiber dialog



Creating and Maintaining cable fiber data 116 








2 The Manage Equipment at Node dialog should open.

Figure 32 Manage Equipment at Node

Note The equipment terminology varies between customers, therefore the system allows for addition, editing and 
deleting of equipment types to cater for greater flexibility between customers.

The left side of the dialog refers to Available Equipment which is populated by default, however 
the user can easily Add/Modify equipment shown in the list.

The right side of the dialog refers to Equipment at Node, together with the Node number being 
displayed to keep the user properly orientated which node is being modified. This list modifies 
equipment from the Available Equipment list on the left hand side of the dialog. Essentially the 
user can add an additional equipment port to the existing list type directly at the node specified. 
When the user places the mouse pointer over a designated equipment type, then the 
Description of the equipment type will be displayed in the form of a tooltip.

When the user adds a specific equipment type Mux or Splitter then those channels from the 
equipment can be connected through to a strand. Single mode channels indicate that either all 
the transmit or all the receive is connected through to the strand. Multi mode channels 
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conversely indicate that a given strand has 1 channel send, and the next channel will be receive. 
This indicates that both the transmit and receive will be on the same strand.

To Edit and Add a New Equipment Type to the List:

3 Click on Edit within the Available Equipment section of the dialog box.

Figure 33 Adding Equipment to the List

4 Click on Add.

5 The Edit Equipment Detail dialog should be displayed, and the user should fill in the required 
parameters.
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Figure 34 Edit Equipment Detail dialog

6 Once all these criteria have been met, then the user can click on OK.

Notice now the new user defined equipment, should now be displayed in the list. Click on OK.

Note The End Frequency will be calculated based on the variables ie. Count, Start, Width and Spacing. The system 
will automatically perform this and can be confirmed by clicking on the Check button.
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Figure 35 Edit Equipment List Dialog

The user will notice the custom equipment being added to the list within the Available 
Equipment section of the dialog box.

7 The user should select the relevant Available Equipment and click on the Add button.
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Figure 36 Manage Equipment at Node dialog

This should now be displayed on the Equipment at Node on the right side of the dialog box.

8 Click on OK.

The Equipment is now added and is ready to be Connected through.
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Figure 37 Available Channels displayed with Green Icon
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Introduction of the Optical Add / Drop Multiplexer (OADM) equipment type

No fiber application can be complete without the ability to cater for an Optical Add / Drop 
Multiplexer (OADM) functionality. With this in mind the design catered for instances 
requiring the OADM functionality and was carefully integrated within the fiber application 
module, together with the existing integrity rules and in line with the Munsys business 
principals.

An OADM essentially allows for the add or drop function where one or more signals can be 
transferred from an input port to either an output port or add / drop port respectively.

An OADM enables the user to have an additional service dropped to a drop channel port, added 
to an add channel port or alternatively passing directly to the output port. In doing so this 
provides the user with a comprehensive fiber solution with associated services across multiple 
cables.

For a more detailed explanation, including capture steps for an OADM network setup, a 
specific document can be made available upon request.
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Equipment added displays in Tree view within Terminate dialog

When the user has equipment added to a node and accesses the Terminate dialog, then by 
default the equipment will be displayed and expanded in the tree view. This makes it easy to 
identify if all channels within the frequency transmitted or received is in use or have some ports 
available. 

Figure 38 Equipment displayed in default Tree View

The colour of the icon next to the frequency band shows the status of the equipment added. If 
it is red on the main indicator, then all channels are in use however if the main indicator is 
green, then some channels are still available for connecting through to strands.



Creating and Maintaining cable fiber data 124 








Connecting Channels through to a Strand

By definition the process of Connecting Channels through to Strands via equipment, initiates 
the Multiplexer/Splitter functionality. This means that many channel ports can be connected 
through to a single strand or across multiple strands depending on the amount of ports 
available.

To Connect an equipment port:

1 Click on a Channel Port to be Connected through to a Strand.

2 Click the Strand that the Channel Port is to be connected to. 

3 Once done the user can then click on the Connect button.

The user can now notice that the icon would change, indicates it is now connected through.

Figure 39 Terminate Fiber Connect Feature

Note When the Commit button is clicked then changes are committed against the database and cannot be Reset or 
rolled-back. Therefore the user should utilize the Commit and Reset buttons with caution.
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The user can then Connect the remainder of the ports of equipment through to the necessary 
Strands and click on OK when done.

Note When new Equipment is added then the equipment displays in Green, this indicates that the equipment is 
available to be Connected to a Strand. When the equipment is Connected to a Strand then it will be displayed 
in Red which indicates that this is in use already.

Figure 40 Multiple Channels Connected to Strands

In this dialog the Commit and OK button perform the same function, however directly clicking 
on the OK button would save the changes against the database and close the dialog. 

The Commit button would save the session changes against the database but keep the dialog 
open for further editing.

Tip To ensure equipment is successfully removed from the node, then the channels need to be 
disconnected from the relevant strands. If already spliced through, then this would need to be 
unspliced first before disconnecting within the Terminate dialog box.
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Adding Additional Channel Ports to Connect through to a Strand

When equipment channels are connected through to strands and if the user aims to add an 
additional port to the equipment channel, then the user can perform this action on an adhoc 
requirement basis.

To achieve this the user should:

1 In the Terminate Fiber dialog, Click on Edit Equipment.

Figure 41 Editing Equipment in Terminate dialog
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Figure 42 Edit Equipment at Node dialog

The user must ensure that the main checkbox next to the equipment name must be checked.

Figure 43 Adding Channel to Connected Equipment
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2 The Edit Equipment at node will appear. Fill in the required fields:

Figure 44 Edit Node Equipment Dialog

3 Click on OK.

Notice this new channel entry should be added to the Channel Details list. 

Note The icons that change between the connected Strands/Equipment is based purely from the naming convention 
of TX/RX. Hence when the user creates a New Equipment at Node, then it should be mandatory to follow the 
proper naming convention of having either TX or RX at the end of the name, thereby ensuring the appropriate 
icon is displayed. This then makes it easier for the user to visualize what is happening in the dialog.
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Figure 45 Edit Node Equipment

4 Click OK.

When the user expands the list, all ports including the newly added one will be listed.

Note The system will not allow the user to Edit or Delete a Channel, whilst it is Connected through to a Strand. The 
following errors will be returned if attempted:

Figure 46 Error when attempting to modify a Connected Channel

Figure 47 Error when attempting to delete a Connected Channel
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Figure 48 New Channel Added to be Connected through to a Strand

This can also be Connected through to a desired Strand.

5 Click on OK.

Once equipment has been Connected through to the Terminated Tube, the user can then 
Connect Strands and Equipment.

Note If the user attempts to UnTerminate a Tube, whilst there is Equipment Connected through to the Strands, then 
the system will display the following error.

Figure 49 UnTerminating a Tube Error Message
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Placement of Equipment at Fiber Room Nodes

Once the user has successfully captured a fiber network, then proceeds to deploy equipment at 
a particular node, and connects through channels of the equipment to desired strands of the 
fiber cable then the possibility of adding multiple services on a strand is available.

When this is done, the user will notice that the equipment id (EQUIP ID) will appear next to 
the strand it is connected through to, at the exact node which the equipment is deployed at. 
However in the case of the Splitter equipment types, if the user navigates back to the Terminate 
/ UnTerminate dialog and clicks on a node before or after the node with the equipment 
deployed on then the user would notice no equipment will be shown at either of those 2 nodes. 
In addition to this, the user will also not be able to see the connected strand and the associated 
equipment id other then at the node to which that equipment was deployed at.

To understand this process:

1 Capture a Cable Route network with associated objects (outlined in CH 4).

2 Define Fiber Cables (outlined at the beginning of CH5).

3 Navigate to Change > Terminate and click on the relevant node.

Figure 50 Node Selection for Terminating

The Terminate Dialog box will appear.

4 Select the appropriate cable from the Cable drop-down list.
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Figure 51 Cable Selection

Once done selecting the cable, all the subsequent strands will appear on the left side of the 
dialog.
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5 Click on Edit Equipment. Tick on the relevant equipment and click on Add.

Notice now the equipment selected and ticked will appear within the Equipment at Node part of 
the dialog box. The user will also find the allocated Equip ID number next to the newly added 
equipment type.

Figure 52 Manage Equipment at Node dialog

6 Click on OK.

The Equipment and associated Channels will be added to the right hand side of the Terminate 
dialog.
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7 Expand the Equipment type and click the channels to be Connected through to the relevant strand. 
Click on the Connected button when done.

Figure 53 Equipment displayed within the Terminate dialog

Notice the Channels have been connected through to the desired Strands and the colour would 
have changed from Green (Available) to Red (Unavailable) for the Connected Channels.
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The user will notice the Equip ID:50 displayed next to the Connected strand ie. 5 Slate (Equip 
ID: 50). Essentially this indicates that an equipment is placed at that specific node: 120-
MH070.

Figure 54 Connected Equipment within the Terminate dialog

If the user clicks on the node before or the node after the node that has equipment deployed at, 
no equipment and equipment id will be displayed. 
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Figure 55 Terminate dialog without any equipment displayed

Note In the case of other Mux or Demux equipment types, these will still be able to be seen on the other end of the 
spliced cable, including the equipment channel ports and Equip ID. It only has a special instance for the 
splitter equipment type that is seen only at the actual node it is deployed at.
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Propagation of Fiber Cables

Data capturing can sometimes consist of repetitive actions which is inevitable to reach a desired 
outcome. The introduction of the Propagation functionality serves to streamline this process by 
carrying changes from the start of propagation to the end of the propagation point.

To mitigate the repetitive action for each fiber cable segment all the way to the end of the cable 
(which also allows for the possibility of human error) the propagate function can be utilized. In 
making the fiber application user friendly whilst maintaining accuracy and increasing efficiency 
the propagation functionality allows the propagation of channel information and services along 
the fiber paths where strands have been spliced through and/or where services have been added.

To Propagate a fiber cable:

1 Commence with the placement of Fiber Room Nodes and FTB as required.

2 Capture Cable Routes along the designated path.

3 Capture > Define New Fiber Cables...

Figure 56 Defined fiber cables



Creating and Maintaining cable fiber data 138 








4 Change > Connect the entire tubes of the both indeed cables for propagation.

Figure 57 Connection of fiber tubes
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Figure 58 Connected fiber tubes
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5 Replication the above step (Connection of tubes between cables) until the end of the network.

6 Place the necessary equipment on the start node of the cable intended for propagation, and connect 
through to the designated fiber strands.

Figure 59 Connecting equipment channel port to fiber strand
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7 Replicate the Connecting of equipment channel ports to the fiber cable strands.

Figure 60 Connecting multiple equipment channel ports to fiber strands

8 Place the necessary services on the start node of the cable intended for propagation, either the fiber 
strands and/or equipment channel ports.

The fiber cables should now be propagated and the changes will be taken across to the end of the 
propagation point.

The propagation of fiber cables comes with its own set of conditions which were established in 
line of the business principals and integrity rules thereby preventing the execution of certain 
actions. Some of the criteria or pre-conditions are outlined below:

 If a fiber cable is propagated and the user attempts to set strands as Marked Damaged at the end 
of the propagated cable, then this would not be possible. The Mark Damaged button would be 
greyed out, preventing the execution of this action. However if the user selects the start of the 
propagated cable, the Marked Damaged button will be available but when clicked the error 
below will be displayed. This is because the end of the cable is spliced through thereby implying 
the start of the cable is unavailable for editing.
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Figure 61 Marking spliced fiber strand as damaged

 If a cable is spliced and the user attempts to connect an equipment channel port to the spliced 
strand, then the system will return the error displayed below:

Figure 62 Connecting equipment channel ports to spliced fiber strands

 When fiber cables are propagated the user Cannot disconnect a strand which has a channel 
connected through to it.

Figure 63 Disconnecting channels connected to fiber strands of propagated fiber cables

 When fiber cables are propagated the user Cannot disconnect channels alone.
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Figure 64 Disconnecting channels of propagated fiber cables

 When fiber cables are propagated the user Can only disconnect a strand which does not have any 
equipment channels connected through.
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To connect / disconnect a cable fiber object
This function is used for connecting cables and strands, each consisting of its own service which 
is attached to it. 

1 Do one of the following:

 Choose Change > Connect / DisConnect.

 Click the Connect / DisConnect button on the Munsys Cable Fiber Change toolbar.

The command line prompts you to select a cable route node.

2 Select the fiber cable node that you want to Connect / Disconnect. 

The Connect Fiber dialog box will be displayed.

Figure 65 Connect Fiber Dialog
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3 Select the specific cables to be connected and press OK. Expand both Cable Tubes to see all 
available Strands for connection.

Figure 66 Connect Dialog box

4 Click on the checkbox next to the Strand/Channel to be Connected from C1 (left side of the dialog 
box) to C2 (right side of the dialog box). 

5 Click on Connect.
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Figure 67 Connecting Channel and Strand

As with the Terminate dialog box, there are many actions which are not allowed to prevent a 
decrement in the data integrity hence have the business rules implemented. 

 If a strand with equipment channel ports are connected to another then the user will be able to 
disconnect these successfully.

 If a strand with equipment channel ports or services are spliced through then the Disconnect 
button will be greyed out and this action is prohibited to eradicate any data issues.
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Figure 68 Displays Connected Channel and Strand

Notice that the icons would now change to indicate that the strands and equipment has been 
connected. There is a different represented icon displayed when a Strand is connected as 
opposed to Equipment.

To Disconnect Strands or Equipment:

1 Tick a specific Strand.

2 Tick a specific Strand or Equipment.

3 Click on the Disconnect button.

To Find Connection between Strands/Equipment

1 Click on the desired Strand or Equipment.

2 Click on the Find Connection button.

This should check the corresponding strand/equipment which is Connected.
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The user should note that only one set of desired connections can be done at a time, the user 
would be unable to execute multiple sets of connections simultaneously. If the user attempts to 
do this then the following error will be returned:

Figure 69 Attempting Multiple Connections Simultaneously

Figure 70 Error Message Displayed

Note When the Commit button is clicked then changes are committed against the database and cannot be Reset or 
rolled-back. Therefore the user should utilize the Commit and Reset buttons with caution.
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Connect Dialog Connection Information

Within the connection dialog when the user splices either strands, channels or strands and 
channels through a fiber cable, irrespective of the combination then upon clicking on the 
feature by highlighting, then the connection information will be populated at the bottom of 
this dialog.

The types of combinations could be:

 Strand and Strand

 Strand and Channel

 Channel and Channel

An example of a Channel to Strand connection is shown below:

Figure 71 Connection Information updated dynamically
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Connecting Equipment Channel Ports to Equipment Channel Ports
In the Connect dialog box if the user attempts to connect equipment channel ports from a 
cable, to another cable consisting of equipment channel ports connected to a strand then this 
would not be possible. If attempted, then an error message will be displayed on the Connect 
dialog box. 

An example of the error message that will be displayed when an attempt to connect a strand 
with channels of a particular equipment ID to another strand of a cable with channels of a 
different equipment ID is displayed below:

Figure 72 Connection of equipment channel ports to other equipment channel ports
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Cascading fiber equipment Channels

The addition of equipment channel ports to fiber cable strands allows for the diversity of a host 
different services along a given fiber network. Along the fiber network in question, the user can 
connect equipment channel ports to the required strand/s, and then move these channel ports 
further along the designated network where the services are to be added. The Cascading of fiber 
equipment channels does just that, adding to the flexibility of the business requirements and 
delivering real world scenarios integrated in an internationally acclaimed easy to use fiber 
application.

To Cascade fiber equipment channels:

1 Placement of Fiber Room Nodes and FTBs.

2 Capture of Cable Route ducts.

3 Capture of Fiber Cables.

Figure 73 Defined fiber cables
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4 Adding of Equipment.

5 Connecting Channels.

Figure 74 Connecting equipment channel ports to fiber strands
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6 Connect dialog > Connect spliced channels and strand to Strand.

Figure 75 Cascading channels and connected strand to fiber strand
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7 The final result of the dialog indicating the cascaded channels will look like the image below.

Figure 76 Cascaded channels to fiber cable

If a user disconnects channels from a strand which has a Mux equipment on one end without 
a Demux on the other end, then the channels being disconnected will disappear from the one 
end. The system will display a warning message prior to this:

Figure 77 Disconnecting channels from MUX without a DEMUX

This is because when a Mux is spliced through it creates the channels within the database tables 
however a Demux does not therefore requires to be plugged into a Mux.
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Note If the user deletes channel ports from a Mux equipment type, at the start of a fiber network, which has a Demux 
plugged into it, then the Demux equipment type will automatically be Disconnected when the Mux is deleted.

Find Connection between Cascaded Equipment Channel Ports

If the user has cascaded channels and attempts to display connection details between the 
equipment channel ports without clicking on the commit button then the following error will 
be displayed:

Figure 78 Finding connection between cascaded equipment channel ports

In order for the user to highlight the channel and have the connection information be displayed 
then the commit button should be clicked first.
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Connecting a connected strand to a MUX

If the user attempts to connect a strand which has a multiplexer equipment channel ports 
connected through to a different strand of a cable then the system will display an error. An 
example of how the error can occur and the meaning behind the logic will be outlined below:

1 Define fiber cables.

Figure 79 Defined fiber cables

2 Connect MUX equipment channel ports to a strand at Node 1 (Start of cable 1).
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Figure 80 Connect MUX channels to fiber strand

3 Connect MUX equipment channel ports to a strand at Node 3 (Start of cable 2).
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Figure 81 Connected channels to strand

Dropdown Cable 1 and Cable 2 on both sides of the dialog box respectively.

4 CNTRL click Strand 7 Red on Cable 1 (left-hand side of the dialog)

5 Click the check-box next to 9 Yellow on Cable 2(right-hand side of the dialog).

6 Click on Connect.

The following error is returned:
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Figure 82 Error connecting strand to a strand which has a MUX



Creating and Maintaining cable fiber data 160 








To add / remove a cable fiber service
This function is used to add the services attached to a particular fiber node

1 Do one of the following:

 Choose Change > Add / Remove Services.

 Click the Add / Remove Services button on the Munsys Cable Fiber Change toolbar.

The command line prompts you to select a cable route node.

2 Select the fiber cable node that you want to Add / Remove a Service to / from. 

The Connected Nodes dialog box is displayed.

Figure 83 The Connected Nodes dialog box

3 Select the specific node, and press OK.

The Munsys - Service Fiber dialog box is displayed.
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Figure 84 The Munsys - Service Fiber dialog box 

4 Click on a Strand or Equipment and then specify the criteria for the Service to be added. 

5 Once done the user should click on the Add Service button.

6 Click OK.

If the user wishes to Remove a Service, then:

7 Select the strand from the Cable list to remove, click Remove Service to remove the service.

8 Click OK to apply.

The fiber cable connection is deleted as specified.
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Figure 85 Multiple Strands and Channels selected for Adding Services

Multiple Strands or equipment can be selected at once to Add a Service on simultaneously.
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Extending Fiber Services

Adding a service to a strand or channel is one of the final desired outcomes of the cable route 
and fiber application, however can sometimes entail repeating a step within a network. To 
alleviate unnecessary repetitions the Extend services when Splicing cables or channels 
functionality was integrated in the fiber module.

To allow for the extension of spliced cables or channels, the following steps should be followed:

1 Define Fiber Cables.

Figure 86 Define fiber cabkes

2 Add Equipment Channel Ports and Connect to Strands on Cable CBL12.
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Figure 87 Connecting equipment channel ports to fiber strands

3 Add Services to the Strand and Channel on Cable CBL12.
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Figure 88 Adding Services on connected channels

4 Navigate to the connect / disconnect dialog box.

5 Select the strand and channel with services on CBL12.

6 Connect to a strand on Cable CBL13 - 9 Yellow.
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Figure 89 Connected strand and channels containing services to strand

The user will notice now that the service from the strand and channel from Cable CBL12 has 
been extended to the strand on Cable CBL13. When services have been extended, a change on 
either side will dynamically update the corresponding record / service type.

This also works from Strand to Strand (excluding channels).

This functionality however does not cater for the extension of services between cables that have 
services attached to it on either end. Hence the system will flag an error as outlined below:

Figure 90 Services on both ends returns an error message
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Manage equipment at node
This function initiates the Manage Equipment dialog, which is the same dialog which is 
accessed from the Cable Fiber application: Change > Terminate > Edit Equipment. This now 
enables the user to access this dialog as a main menu item, without having to primarily navigate 
via the Terminate dialog.

Figure 91 Manage Equipment menu item

To reroute fiber cable
This function is used to reroute a damaged fiber cables to new fiber cables.

1 Do one of the following:

 Choose Change > ReRoute Fiber Cable.

 Click the ReRoute Fiber Cable button on the Munsys Cable Fiber Change toolbar.

The command line prompts you to select a cable route node.

To successfully ReRoute a Fiber cable:

2 Select the desired Fiber Cable which needs to be ReRouted.
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Figure 92 Select the Fiber Cable to be designated

Note The user will notice that once the fiber cable is selected then automatically all other fiber cables will be erased 
from the drawing and will have to be re-queried out if required.

3 Select the Cable Route to ReRoute the Fiber Cable within.

Figure 93 Select the Cable Route to ReRoute Fiber cable into
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4 The system will prompt the user if done selecting the Cable Route Yes/No.

Figure 94 Complete Selecting Cable Route

5 Click YES or alternatively press ENTER.

Figure 95 Cable Route Selected

The user should notice that the Fiber Cable will be ReRouted to the designated Cable Route.
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Figure 96 Fiber Cable has been successfully ReRouted

Note If a fiber cable is Re-Routed, the user will not be able to UNDO the action, as the function will be no longer 
to the user in that session. The user will need to re-route the cable again if it was incorrectly done the first time 
around.
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Break Cable Route (In Use)

When the business is required to make provisions for the extension of an existing fiber network, 
then users must meet the necessary conditions to allow for the integration new networks. One 
of the most basic yet important conditions is the cable route segments, particularly those which 
have fiber cables running within them. For the expansion of fiber networks users need the 
placement of cable routes to cover the area of expansion hence will need to layout more cable 
route segments and in some instances break cable routes that currently house fiber cables. 
During the breaking of the cable route in use, users would have to ensure that an infrastructure 
is placed (Vault, Site, Drawbox, Pit, Manhole or Pole) and that it is posted to the database. This 
is because a Fiber Joint node will be inserted into the break point that the user has indicated. 
The system will then ask the user to select the infrastructure to associate the Fiber Joint Node 
with, thereby allowing for the expansion of the fiber network by breaking an in-use cable route. 

To break an In Use Cable Route:

1 Navigate to Change > Break Cable Route (In Use).

Users should ensure that an infrastructure is placed in a decent proximity to associate the soon 
to be placed Fiber Joint node with.

A warning message will be displayed, the user should read it and press OK.
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2 Select the cable route segment, and then click on it to select it for breaking.
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3 Specify a break point and click at a desired point.

Tip Type “nea” to pick an accurate point, and press ENTER to pick a point.

The user will now notice that a fiber joint node has been inserted in the break location.

4 Select the infrastructure to link to the fiber joint node.

The broken cable route segment colour will be displayed in green indicating it is a new object 
and should have its integrity re-checked within the Cable Route Application.

The In Use cable route segment has now been broken, has a fiber joint node inserted within the 
break point and has been associated with an infrastructure.
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Breaking Fiber Cables

During the data collection process it is sometimes difficult to assume areas which will require 
the fiber network be extended. As the request to switch over to fiber becomes ever-increasing, 
and cannot easily be catered for during the initial development stage, particularity for every 
area. This can then pose as an issue with regards to the fiber cables layout, however with this in 
mind the Break Fiber Cable feature becomes a useful function of this module. 

The Break fiber cable feature simply allows the user to break a fiber cable at a desired 
intermediate node (Fiber Room Node or Fiber Joint Node) whilst maintaining the integrity of 
the network, retaining services etc. This function dynamically updates the start and end nodes 
of the fiber cable within the database, and also prompts if the function should automatically 
splice strands through prior to the breaking of the fiber cable.

To break a fiber cable:

1 Define Fiber Cables.

Figure 97 Defined Fiber Cables
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2 Navigate to Change > Break Fiber Cable

A warning message will be displayed, which the user should acknowledge by pressing OK.

3 Select the fiber cable to be broken.

Figure 98 Select fiber cable to break
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4 Select the break point (node).

Figure 99 Select break node

5 Prompt to Splice Strands Yes or No.

Figure 100 Prompt to splice strands
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The user will notice that the fiber cable has been broken into the relevant segments.

Information such as the Start and End nodes will be updated as per the fiber cable extent.

Figure 101 Newly broken fiber cable segment

Modifying Cable Routes which are In Use
You can insert, move or remove vertices on existing Cable Routes which are set to be In Use by 
using the standard Object > Edit MunLine commands to Insert Vertex, Move Vertex or Remove 
Vertex. 

When modifying any vertex on an existing Cable Route, the underlying Fiber Cables and Paths 
are updated to use the same geometry as the Cable Route. An Oracle trigger updates the Fiber 
Cables and Paths geometry whenever any geometry INSERT or DELETE update is completed 
on the Cable Routes. The trigger is fired once the modified object is posted to the database.

To Insert a Vertex on a Cable Route:

1 Query the Cable Route to be modified into the drawing.

2 Select Object > Edit MunLine > Insert Vertex where you will be prompted to select the object to 
edit. Select the Cable Route object.
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Figure 102 Select MunLine object to edit - Select the Cable Route

3 Select the segment for inserted point to be as close as possible to where the new segment is to be 
inserted.

Figure 103 Select segment for inserted point

4 Specify the position for new point by dragging the crosshair to the desired location.

Figure 104 Select position for new point

5 On completion of the selection, a new vertex will be inserted.

Figure 105 New vertex is inserted
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6 More than one vertex can be inserted using the same process.

Figure 106 More than one vertex can be inserted

7 Complete the Object and Network Integrity checks before posting the changes to the database.

8 If you query the Fiber Cables for the same Cable Route, you will see that it has been updated with 
the same geometry as the modified Cable Route

Figure 107 Fiber Cable has same geometry as modified Cable Route

To move a vertex on a Cable Route:

1 Query the Cable Route into the drawing.

2 Choose Object > Edit MunLine > Move Vertex

3 Select the appropriate object.

4 Specify a point on the vertex that you want to move.

5 Specify the point where you want to move the vertex to.

The vertex is moved to the point specified.

Tip AutoCAD grips can also be used to move a vertex. Grips are only available on locked objects.

To remove a vertex on a Cable Route:

1 Query the Cable Route into the drawing.

2 Choose Object > Edit MunLine > Remove Vertex

3 Select the appropriate object.

4 Select the vertex that you want to remove.

Note A vertex can only be removed from a segment with more than two vertices.
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Changing cable fiber notes
With this function, you can change the text of an existing cable route note.

To change a cable fiber note

1 Choose Change> Change Cable Fiber Note...

The command line prompts you to select a cable fiber note.

2 Select the cable fiber note that you want to change.

The Cable Fiber Note text box is displayed.

Figure 108 The Cable Fiber Note text box

3 Change the note as required, and then click OK.

The cable fiber note is changed as specified.

Adding comments
This function is used to assign descriptive comments to one or more selected objects.

To add comments

1 Choose Change > Add Comment...

The command line prompts you to select a cable fiber object.

2 Select the cable fiber object(s) that you want to add a comment to.

The Cable Fiber Comment text box is displayed.

Figure 109 The Cable Fiber Comment text box

3 In the text box, add the comment, and then click OK.

The comment is assigned to the selected object(s).
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Edit fiber cable duct info

The Edit fiber cable duct info option enables the user to change/alter the cable route duct in 
which the Fiber Cable runs within. On the Edit Cable Duct Info dialog box which is launched 
the user is able to see the current duct in which the fiber cable runs within, and then select the 
appropriate duct to which the fiber cable should run within.

To edit fiber cable duct info

1 Choose Change > Edit Fiber Cable Duct Info.

2 Select the Fiber Cable > press ENTER to open the dialog box.

Figure 110 Dialog showing in which duct the Fiber cable is located

Tip The current duct in which the fiber cable runs within will be indicated with a red dot.

3 Select the desired duct that the cable should run in and press OK.

4 The fiber cable duct should now be changed.
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Delete Fiber Cable Duct Info

The Delete fiber duct info option enables the user to delete the cable route duct info in which 
the fiber cable is placed. Once this fiber cable duct info is deleted it would be a basic duct that 
the fiber cable resides within (without specifications), which can be the case in some instances 
where the duct info is unknown in real life.

To delete fiber cable duct info

1 Choose Change > Delete Fiber Cable Duct Info.

2 Select the Fiber Cable > press ENTER.

3 The Fiber Cable Duct Info should now be removed. Deleting and undeleting cable fiber objects

With Munsys Cable Fiber, existing cable fiber objects can be deleted from the database. 
Multiple objects can be selected for deletion. Cable fiber objects that form part of a redundant 
network have to be deleted. Deleted cable fiber objects are moved to a frozen layer DELETED, 
which is removed from the database when changes are posted. With the Undelete function, you 
can restore cable fiber objects that have been moved to the DELETED layer which was marked 
for deletion.

To delete fiber cables

1 Choose Change > Delete Fiber Cable.

The command line prompts you to select the objects to be deleted.

Note If a fiber cable with any services, paths, connected strands, or connected equipment is selected for deletion 
you will receive an error indicating to remove the services, paths, and connected strands from the fiber cable 
before the fiber cable can be deleted.

The AutoCAD Message box is displayed.

Figure 111 The AutoCAD Message box 

2 Select the fiber cable that you want to delete.

The Fiber Network dialog box is displayed
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Figure 112 The Fiber Network dialog box 

3 Press YES to delete the selected fiber cable.

The fiber cable is permanently deleted from the database.

Note When a fiber cable is deleted, this would be removed from within the database immediately, thereby making 
the UNDO function obsolete. The user would then be unable to UNDO the deletion of that specific cable.

To delete cable fiber objects

1 Choose Change > Delete Fiber Cable Objects.

The command line prompts you to select the objects to be deleted.

2 Select the cable fiber objects that you want to delete.

The command line indicates how many cable fiber objects you have selected, and how many have been filtered 
out.

3 Press ENTER to delete the selected cable fiber objects.

The cable fiber objects are flagged for deletion and moved to the DELETED layer. These changes will be 
applied to the database once its posted.

To undelete cable fiber objects

1 Choose Change > Undelete Fiber Cable Objects.

The objects that you have deleted will be displayed in the drawing, and the command line prompts you to 
select objects to undeleted.

2 Select the cable fiber objects that you want to restore.

The Delete flag is no longer set for the selected objects. In the event of spatial or attribute changes before the 
objects were flagged for deletion, these changes are applied.
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Cable fiber network quality reporting
The Network Quality Report function on the Extras menu is used to validate the quality of the 
entire network. The network quality report complements the network integrity check. 
Although it is recommended that a network integrity check is always done before objects are 
posted to the database, some problems might still be present in the quality of a network. This 
could, for example, be due to the fact that the network integrity check might have been done 
on a small area of the network. The network quality check uses all the objects in the database 
to validate the quality of the entire network. The validation is done at attribute level, without 
having to validate the associated spatial data.

Specific columns in each of the spatial tables are used to build up the topology of the network, 
for example the start and end nodes of a cable route. The network quality report will validate 
these values based on cable route-specific rules. 

Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS 
table, together with the appropriate error message related to each spatial object where an error 
occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query, which will 
use this table as a linked table with a condition based on the SP_TABLE column that matches 
the spatial table name of the query.

If a single spatial object contained more than one error, a record will be stored for each error 
that occurred within that object. You can also have the errors populated to the COMMENTS 
column of the object(s) in which errors occurred, if you do not traditionally use this column for 
other purposes. If more than one error has occurred in an object, the COMMENTS column is 
populated with the last error that is found.

To validate cable fiber network quality

1 Choose Extras > Network Quality Report...

The command line displays the message: Generating network quality report

2 If errors were found in the network, the following message is displayed:

Figure 113 Network Quality errors found

3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column 
updated.

The Save Results Summary As dialog box is displayed.
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4 Save the report to a location of your choice.

The report is opened in Windows Notepad, and contains the following information:

 The number of objects that were checked

 The number of objects found that violated the network rules

 The number of endpoints that were found in the network

 The number of errors that were found, grouped by error type

Figure 114 A cable fiber and cable route network quality report
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Generating cable fiber data status reports
Data status reports provide summarized information about spatial objects that are currently 
stored in the database. Once a report has been generated, it is saved to a comma delimited file, 
and then displayed in Notepad for easy viewing. The following reports can be generated for 
cable route objects:

 a summary of all the cable route objects in the database

 a summary of the total length and number of cable routes, by type and category

 a summary of the umber of cable route nodes by node type

To generate a cable fiber data status report

1 Choose Extras > Data Status Report...

The Data Status Report dialog box is displayed, showing a list of all the reports that can be generated.

Figure 115 The Data Status Report dialog box

2 Select one or more reports to generate from the list, and then click OK.

3 Save the file to a location of your choice.

The file is opened in Windows Notepad.
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Figure 116 Data status report for service connections
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Converting AutoCAD entities to cable fiber objects
With Munsys, you can convert selected AutoCAD entities to Munsys Cable Fiber objects. Texts 
can be converted to a cable fiber notes.

Although some basic attributes are assigned as part of the conversion process, you will need to 
assign attributes to the objects created with the conversion process.

To convert text to cable fiber notes
With this function, you can convert AutoCAD text entities to cable fiber notes.

1 Choose Extras > Convert Text to Cable Fiber Note.

2 Select the objects that you want to convert, and then press ENTER.

The entities are converted to the cable route objects, and the drawing is updated accordingly.
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	Contents
	Chapter 1
	Introducing the Munsys Cable Fiber and Cable Route Concepts User Manual
	Welcome to Munsys
	The Munsys® product family consists of an integrated set of applications that cater for all the spatial information needs of utility and government organizations.
	The Munsys products are based on industry leading technologies, utilizing Open Geospatial Consortium (OGC) standards for sharing information. Autodesk® design technology is used to present the spatial information, while Oracle® database technology ...
	Munsys is a user-friendly, easy to use geographic information management tool, which does not require GIS expertise to capture and manipulate data.
	The Munsys product family consists of the following applications:



	About this manual
	The Munsys Cable Fiber and Cable Route Concepts User Manual provides the following information:
	the generic capture functionality in the various Munsys applications
	the generic query functionality that is used to query spatial data from the Oracle database
	how to structure a query
	how to view spatial data
	how to work with Munsys Objects
	extras such as annotation, reporting and legend options, etc.
	how to format layers


	What’s in this manual
	The Munsys Cable Fiber and Cable Route Concepts User Manual consists of the following chapters:
	Chapter 1 – Introducing the Munsys Cable Fiber and Cable Route Concepts User Manual, gives an overview of this manual, and provides the typographical conventions used throughout the Munsys documentation set.
	Chapter 2 – Getting acquainted with Munsys Cable Fiber and Cable Routes, gives an overview of Munsys and its various applications, as well as an overview of the Munsys user interface.
	Chapter 3 – Capturing and querying Building data in Munsys, describes how to define query options and retrieve existing data from the database.
	Chapter 4 – Creating Cable Fiber and Cable Route data, shows the user how to capture a cable fiber and cable route network, add additional cable fiber and cable route objects, and post cable fiber and cable route data to the database.
	Chapter 5 – Maintaining Cable Fiber and Cable Route data, describes how to maintain existing cable fiber and cable route data.


	Conventions in this manual
	The following table lists the typographical conventions used in this manual.
	Table 1 Munsys typographical conventions


	Finding the information you need
	To get help on
	general issues, select Help from the Munsys menu bar.
	an operation in progress, click the Help button on the dialog box.
	the latest support options, visit http://www.openspatial.com

	Chapter 2
	Getting acquainted with Munsys Cable Fiber and Cable Routes
	Munsys Overview
	Munsys, the spatial solution for utilities and government, is a multi-user open GIS system that allows users to capture and maintain utility data.
	The demand for accurate geo-spatial information for both planning and decision support is increasing daily, fostering the need for the implementation of an information system that can grow with the needs of the organization. The Munsys system caters ...
	The design of the capture and maintenance functions enforces data standards. Spatial data integrity is enhanced with a verification process known as the integrity check, which checks the spatial data against the business rules before it is posted to ...
	The Munsys product family simplifies the use of spatial data with predefined queries, which retrieve spatial objects onto their appropriate layers. Objects that are changed and new objects that are created are changed to a working color. Once the obj...
	Munsys is a user-friendly, easy to use spatial information management tool, which does not require GIS expertise to capture and manipulate utility data. The system provides the user with Capture and Change toolbars that speed up the capture process.
	Munsys caters for enhanced output tools, such as annotations and legends, to simplify map production.



	Munsys Features
	The various Munsys features can be listed as follows:
	User-specific application and design – enforcing data standards fulfills the demand for accurate spatial data. Engineering spatial data requires standards that adhere to civil engineering rules, which are built into the capture and modify routines ...
	Munsys is an Enterprise Spatial Solution – Munsys is a multi-user open system that caters for the demands of spatial systems. Because of its centralized database and data sharing, dynamic information is available.
	Munsys adheres to Open Geospatial Consortium (OGC) standards – Munsys is designed to adhere to the ISO standards for OpenGIS applications.
	Munsys is based on industry standard software – Munsys is designed as a front end on AutoCAD Map3D®.


	Introducing the Munsys Applications
	The following section provides an overview of the various Munsys applications.

	Munsys Cadastral
	Munsys Cadastral is used for the capture and maintenance of cadastral base data from general plans and diagrams. The cadastral data forms the foundation of the system because all departments use it to locate and position their services.
	Using Munsys Cadastral, users can capture and maintain community boundaries (for example municipalities, suburbs, townships, etc.), parcels, easements, street names and addresses and buildings. In addition, Munsys Cadastral caters for planning aspect...
	Users can also define cadastral settings to simplify the capture process. Parcels are classified according to their legal and work status as proposed, current, or archived. Conversion of spatial objects to cadastral objects extends the capture capabi...
	Figure 1 Munsys Cadastral


	Munsys Cable Route
	Munsys Cable Route is designed for the capture and maintenance of cable route networks. Munsys Cable Route caters for cable route objects such as ducts and infrastructure such as vaults, sites, manholes and other relevant infrastructure polygons, and...
	Munsys Cable Route contains various tools to assist with data capture and maintenance that will, for example, contain specifications for the ducts in which fiber cables will be housed. This then allows for different scenarios, detailed duct informati...
	Figure 2 Munsys Cable Route


	Munsys Cable Fiber
	Munsys Cable Fiber is used for the capture of fiber network data.
	Munsys Cable Fiber accurately places cables within the cable routes and building the required network integrity as cables are captured. Integrity checks and rules are built into the data capture process of the cables as they are placed, thereby elimi...
	Cable lengths are calculated along the cable routes and adjusted for slack at each connecting node. Important information such as connectivity, type, and size is stored for each cable.
	Cables Route Ducts contain specific information pertaining to the fiber cables, the various duct sizes, Route ID and Route Type which provides for efficient links between both utilities.
	Figure 3 Munsys Cable Fiber

	Note In the Show Info Palette the values are displayed as Table View by default therefore some column names would not be displayed in full. To Change this the user can right-click within the Main Object Attributes pane and switch to Show Formatted Vi...

	Launching Munsys and Munsys Cable Fiber or Cable Route
	To launch Munsys, do one of the following:
	1 Double-click the Munsys Application 14.4 icon on the Windows desktop.
	2 Choose Start > Program Files > Open Spatial > Munsys 14.4 > Munsys Applications 14.4

	Connecting to the Oracle database
	Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator technology is that spatial and attribute data are captured and managed in a single database. This reduces processing overheads and eliminates the complexity of...
	The Munsys Applications support multiple Logons which permit users to logon to different databases such as Training, Test or Production databases by selecting a Logon Profile from a drop-down list. When the Connect function is selected, the logon cre...
	The Logon Profile details are customizable and stored in the Current User’s Registry Keys. By default, three Logon Profiles are defined, namely Logon1, Logon2 and Logon3. The Logon Profile descriptions can be changed from the default description to...
	Important You have to be connected to the Oracle database before you can start working with Munsys Cadastral. If you try to launch any application without being connected to the database, you will be prompted to connect to the database first.
	To connect to the Oracle database

	1 Do one of the following:
	The Connect to Database dialog box is displayed.
	Figure 4 The Connect to Database dialog box
	2 In the Logon Profile box, select a profile from the drop-down list.
	Note The Logon Profile can be changed to a more meaningful description by clicking in the Logon Profile text box and overwriting the default description with a value not exceeding 25 characters, for example: TRAINING, TEST, STAGING or PRODUCTION.

	3 In the User Name field, enter your user name.
	4 In the Password field, enter your password.
	5 In the Schema field, enter the schema name.
	6 In the Database field, enter the database name.
	7 Click OK.
	On successful connection to the database, the last Logon Profile, User Name, Schema and Database details are saved in your Current User’s Registry Key where they are used to pre- populate the Connect to Database dialog-box on next logon. Your passw...
	Figure 5 The Connect to Database dialog box with Logon Profile

	Note The last used Logon Profile details, and the various Logon descriptions are stored in the registry key Computer\HKEY_CURRENT_USER\Software\Open Spatial\Munsys 14.4\Applications\Logons, whilst the registry key Computer\HKEY_CURRENT_USER\Software\...
	The administrator assigns you user rights to log on to the database, and will inform you what your user name, password, schema name, and database are. A successful connection to the database activates the appropriate functions on the menu bar and too...




	Disconnecting from the Oracle database
	1 Do one of the following:
	The connection to the database is terminated, and you will only be able to manipulate data once an active connection has been restored.

	Changing the password used to connect to the database
	With this function, you can change the password that you use to connect to the database.
	1 Do one of the following:
	On the command line, type MUNPASSWORD, and then press ENTER.

	The Changing password for user [User] dialog box is displayed.
	Figure 6 The Changing password for user [User] dialog box
	2 In the Old password box, type your current password.
	3 In the New password box, type your new password.
	4 In the Retype new password box, retype your new password.
	5 Click OK to apply the new password.


	To launch the Munsys application of your choice
	1 Do one of the following:
	Figure 7 The Available Applications dialog box

	2 From the list of available applications, select the application that you want to work with, and then click OK.
	The functions of the application that you selected are loaded on the menus and toolbars,

	Munsys Menu AutoFix
	It is possible that the Munsys Menus may get corrupted for some reason. This is often associated with customizations or user experimentation. If this happens, Munsys provides a way to Fix such menus.
	To fix a corrupt menu do the following
	1 Choose File > Restore Munsys Menu...
	Your Corrupted Menus should now be repaired.

	Chapter 3
	Capturing and querying building data in Munsys
	Introduction
	This chapter describes how to capture cadastral building data necessary for Fiber and Cable Route connectivity, and how to post the captured data to the database.
	When you start the capture process, existing cadastral data needs to be queried from the database first in order to verify the location of existing objects and to determine if these objects will influence the capture process of the new cadastral data...
	Cadastral data is captured in its native format (coordinate system and units) from registered plans and, if needed, converted to different units afterwards. For most accurate data, you need to capture data as coordinates, because survey distances are...
	When building data is queried, it includes the retrieval of the spatial objects, with a link to the attribute data in the database.

	Note The capture of the cable route can only be done if there are existing Buildings (Cadastral Application) saved and posted into the database. If there are no captured buildings in the database the user would have to manually capture this within th...


	To launch Munsys Cadastral
	When you launch Munsys for the first time, the configured base map automatically loads and AutoCAD menus are loaded by default. Subsequently, the menus and toolbars of the application that you last worked with are displayed when you launch Munsys.
	1 To launch Munsys Cadastral, do the following:
	The Available Applications dialog box is displayed.
	Figure 1 The Available Applications dialog box


	2 From the list of available applications, select Cadastral, and then click OK.
	The Munsys Cadastral menus and toolbars are loaded.


	Querying buildings
	Buildings are queried from the database according to the current GSC, and are displayed as polygons (MUNPOLY objects). Buildings are placed on the BUILDING layer.
	To query buildings
	The command line shows how many buildings were retrieved from the database according to the current GSC.
	Figure 2 Querying buildings
	To query buildings with the name displayed
	1 Ensure that the Building has a Name assigned to it (This can be done via Change > Edit Attributes).
	2 Navigate to the Query Palette and right click on Buildings > Properties.
	3 Click on Tag Properties > Right Click on Tag Properties > Column.
	4 Drop-down the available columns and select SP_BUILDING.BLD_NAME.
	5 Click OK.
	6 Right Click on the Buildings > Run Selected Query without GSC.


	Capturing buildings
	Buildings can be classified for different types, for example as business, industrial, educational, government, institutional, medical, etc. With Munsys Cadastral, buildings are captured as polygons, either by drawing a building polygon, or by first d...
	The number of floors in a building are assigned using the Change menu.
	A building that is captured using the Draw Building Polygon function is assigned the default building type. This can be altered by changing the default value in the Cadastral Settings dialog box, or from the Change menu, or by using the Edit Attribut...
	Note A building type is not assigned by default to a building that is captured using the Draw Building Boundary and/or Generate Building Polygons functions. Using the Change menu, you have to assign a building type using the Edit Attributes or Change...
	Drawing building polygons
	With this function, you can create a building polygon by specifying consecutive points in the drawing area. The polygon is closed automatically and constructed on the BUILDING layer as a MunPolygon object, to be verified when the integrity check is run.
	To draw a building polygon
	1 Choose Capture > Building > Draw Building Polygon.
	2 Specify the start point for the building polygon.
	3 Specify the next point(s), and then press ENTER.
	The building polygon is closed automatically.


	Drawing a building boundary
	With this function, you can draw a building boundary by indicating consecutive points in the drawing area. The lines are created on the BUILDING_LINES layer and will be used by the polygon builder to generate a building polygon.
	To draw a building boundary
	1 Choose Capture > Building > Draw Building Boundary.
	2 Specify the start point for the building boundary by doing one of the following:
	3 Specify the next points as above, and then press ENTER.
	4 Press ENTER to close the building boundary.

	Generating building polygons
	With this function, you can generate building polygons from the lines that were created with the Draw Building Boundary function. The polygon is generated on the BUILDING layer, to be verified when the integrity check is run.
	The building type for a building polygon that is created by using the Draw Building Boundary/Generate Building Polygons functions, has to be specified using the Change Building Type function.
	To generate building polygons
	1 Choose Capture > Building > Generate Building Polygons.
	2 Select the lines that form the closed building boundary, and then press ENTER.
	The command line prompts you to select the polygon detection point.
	3 Select a point inside the building boundary.

	The building polygon is generated.
	Figure 3 Building polygons



	Editing building information
	This function is used to edit building information. Building information can only be edited by users who have been assigned the MUNSYS_CMS_EDIT role. You can change the Building Type, Floor Information, Building Name, Building Number and Data Quality.
	To edit building information
	1 Choose Change> Edit Attributes.
	The command line prompts you to select cadastral objects.
	2 Select the building polygon, and then press ENTER.

	The Edit Attributes Buildings dialog box opens.
	Tip The Edit Attribute Buildings dialog box can be resized so that you can easily view all the information.
	Figure 4 The Edit Attributes: Buildings dialog box

	3 In the Edit Attribute: Buildings dialog box, add a Building Name and Building Number, and then click OK.
	You can change the building type, number of floors, comments, building name, building number and data quality of an existing building.



	Editing building attributes - Continued
	To edit building attributes
	1 Choose Change> Building> Change Building Type.
	The command line prompts you to select objects.
	2 Select the building polygon to be changed.

	The Select Building Type dialog box opens.
	Figure 5 The Select Building Type dialog box
	3 In the Select Building Type dialog box, select a building type by Code or Description, and then click OK.


	Change Building Floor / Room Information
	This function is used to change building floor and room information. You can change, add and delete the building floor and building room information of an existing building.
	Buildings are required for the placement of Fiber Room Nodes, and these buildings store the Floor and Room numbers and descriptions of where the Fiber Room Nodes connect to.
	Note The Floor Information must be captured and posted to the database before the Room Information for that Floor can be captured.
	A Building may comprise of multiple Floors, and a Floor may have multiple Rooms, however Fiber Room Nodes may only connect to a single Floor and Room combination. Each Floor Number must be unique, and each Room Number must be unique.

	Tip As an example, a Building may consist of many Floors (1 = First Floor, 2 = Second Floor) and there may be more than on Fiber Room on each Floor (101 = IT Room, 201 = IT Room, and 207 = Reception on 2nd Floor)
	The Floor and Room details can be viewed by selecting the Floor Number in the Floor Information block where the Room Information for that floor is displayed.
	Figure 6 Building Floor and Room combination for First floor
	Figure 7 Building Floor and Room combination for Second floor


	To Add building Floor / Room information
	1 Choose Change> Building> Change Building Floor/Room info.
	The command line prompts you to select building.
	2 Select the building polygon to be changed.

	The Edit Building Information dialog box opens.
	Figure 8 The Edit Building Information dialog box
	3 In the Edit Building Information dialog box, click the Add a Floor Number.

	The New Building Floor dialog box opens.
	Figure 9 The New Building Floor dialog box
	4 In the New Building Floor dialog box, add a Floor Number and a Floor Description, and then click OK.
	Note The Add Room Information will only become available once building floor information was captured/added to a building and the floor information is selected.

	5 In the Edit Building Information dialog box select the floor, and click the Add a Room Number.

	The New Building Room dialog box opens.
	Figure 10 The New Building Room dialog box
	6 In the New Building Room dialog box, add a Room Number and a Room Description, and then click OK.
	7 In the Edit Building Information dialog box, click Commit to save the building information.
	Note A Schedule Task has been created to remove Orphan Floor and Room Information from AT_BLDG_FLOOR_INFO and AT_BLDG_ROOM_INFO if the corresponding GID does not exist in SP_BUILDING. This is done in order for a user to capture a Fiber Room Node in a...



	To Delete building Floor / Room information
	1 Choose Change> Building> Change Building Floor/Room info.
	The command line prompts you to select building.
	2 Select the building polygon to be changed.
	The Edit Building Information dialog box opens.

	3 Select the Floor Information record to be deleted and select the Delete button.
	4 You will be prompted to Confirm the deletion.
	Selecting ‘Yes’ will proceed with the deletion. ‘No’ will cancel and return you to the Edit Building dialog box.
	Figure 11 Conformation message when deleting a Building’s Floor Information.

	Important You will be presented with the below message when attempting to delete any Floor or Room Information where Fiber Room Nodes are linked. You will not be able to continue with the deletion of the selected Floor / Room Information until the Fi...
	Figure 12 Message preventing deletion of Building Floor / Room Information


	5 Select the Commit button to remove the record.
	Note It is important to note that when deleting a Building’s Floor Information, the associated Room Information for the Floor is also deleted. This is automatically done by means of a database trigger.


	Chapter 4

	Creating and Maintaining cable route data
	Capturing and Modifying cable route data
	When you start to capture a cable route network, you will first need to query the cadastral and building data into the drawing to make certain that the cable route objects locate geographically correct. Existing cable route objects should also be que...
	The cable route default attributes are set up on the Cable Route Settings dialog box before the capture process is started. Default layer names are used for each object type per cable route category.
	Buildings are required to be captured or queried out first, before the capture of fiber nodes or cable routes has commenced.
	Next, the Cable Routes are placed, as the Runs/Ducts connect to the fiber nodes which are linked to buildings and infrastructure, and usually align with existing cadastral, however can be placed freehand if desired.
	Once you have placed all the cable route objects required to complete the cable route network, you are ready to run both the object and network integrity checks, and post the data to the database.
	Then, Fiber Paths and/or Fiber Cables are placed. These are the last components of the Cable Fiber Application and will be covered comprehensively in the next chapter.
	Spatial data is stored in database tables as records. Cable Route objects that require editing are queried onto their respective layers. Attribute data can be edited directly in its table format.
	Once the cable route and nodes have been placed, the cable route objects have to be manipulated to make certain that they are joined correctly, for example with no overlaps or undershoots, and each cable route has to have a start and end node.
	Attribute values linked to cable route objects can be modified easily from the Change menu, for example infrastructure and route types.
	Maintaining cable route data can be done by accessing the Change menu. Cable route objects which have been changed need to be validated against the cable route business rules before they can be posted to the database again.



	Cable Route
	Cable route capture settings
	Each Munsys application has its own default capture settings that are set by the GIS administrator in the Munsys Management Console.
	In Munsys Cable Route, default settings are available for:
	Cable Route – cable route default offset distance, label height, owner, state, status, and type
	Cable Route Nodes – cable route nodes alignment, placement, node functions, offset distance, node reference and snap to nodes.
	Cable Route Symbols – cable route symbol scale
	Dimensions – dimension note height
	File – the drawing directory
	General – construction color, include network in object integrity, database extents display resolution, integrity circle size, tag and symbol scale and rotation if coordinate transformation is done, snap tolerance, tag angle, font, height and justi...
	Infrastructure – cable route infrastructure height, width, prompt name and default type
	Integrity – short objects, cable route, node and search tolerance
	Nodes – cable route node scale
	Notes – note tag height

	You can change the current settings on the Cable Route Settings dialog box to speed up the capture process. Capture settings only apply to new cable route objects, and if you change the default settings, the changes are only valid for the current ses...
	Settings are changed by highlighting the current value, and then:
	entering a new value
	selecting the new value from a drop-down list

	The user cannot change all of the settings. Some settings may only be changed by the GIS administrator to enforce consistency and integrity on a higher level. Settings that cannot be changed are “greyed out” on the Capture Settings dialog box.

	Tip A short description of a value displays when it is highlighted.
	To specify cable route capture settings

	1 Do one of the following:
	2 The Cable Route Settings dialog box is displayed, showing the default cable route capture settings.
	The Cable Route settings dialog box opens.
	Some values are changed by selecting a value from a drop- down list.
	Figure 1 The Cable Route Settings dialog
	3 To change a value, do one of the following:
	4 Click OK to apply the new settings.

	The settings will apply until you change them again, or until the current session is terminated.

	Capturing Infrastructure
	Infrastructure nodes are used to house the fiber joint nodes. Infrastructures are captured onto their appropriate layers, to be verified when the integrity check is run.
	Auto-placement of Fiber Nodes when capturing Cable Route Infrastructure
	Munsys caters for the auto-placement of a Fiber Node simultaneously when placing Cable Route Infrastructure, for example:
	When an Infrastructure Manhole is placed a Fiber Node Junction node is automatically placed at the center of the Manhole. The Manhole is captured in the spatial table SP_CRTINFSTRUCT, while the Junction node is captured in the spatial table SP_CRTNOD...
	These rules exist for Infrastructure Manholes and Pits in the Node Mapping table for Cable Route Infrastructure called CRTINF_NODEMAPPING. This table determines which Cable Route Node Type and associated Symbol Name is auto-placed when placing specif...

	Placing a vault
	When capturing a cable route network, vaults are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of vaults to be placed.
	To place a vault
	1 Choose Capture > Infrastructure > Place Vault.
	2 Specify the insertion point for the tag.
	3 On the command line, specify the vault size, or press ENTER to accept the default size.
	4 To indicate the vault angle, do one of the following:
	5 On the command line, specify the vault name, and press ENTER.
	6 On the command line, specify the vault number, and press ENTER.
	The vault is inserted as specified.

	Placing a site
	When capturing a cable route network, sites are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of sites to be placed.
	To place a site
	1 Choose Capture > Infrastructure > Place Site.
	2 Specify the insertion point for the site.
	3 On the command line, specify the site size, or press ENTER to accept the default size.
	4 To indicate the site angle, do one of the following:
	5 On the command line, specify the site name, and press ENTER.
	6 On the command line, specify the site number, and press ENTER.
	The site is inserted as specified.

	Placing a drawbox
	When capturing a cable route network, drawboxes are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of drawboxes to be placed.
	To place a drawbox
	1 Choose Capture > Infrastructure > Place DrawBox.
	2 Specify the insertion point for the drawbox.
	3 On the command line, specify the drawbox size, or press ENTER to accept the default size.
	4 To indicate the drawbox angle, do one of the following:
	5 On the command line, specify the drawbox name, and press ENTER.
	6 On the command line, specify the drawbox number, and press ENTER.
	The drawbox is inserted as specified.

	Placing a pit
	When capturing a cable route network, pits are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of pits to be placed.
	To place a pit
	1 Choose Capture > Infrastructure > Place Pit.
	2 Specify the insertion point for the pit.
	3 On the command line, specify the pit size, or press ENTER to accept the default size.
	4 To indicate the pit angle, do one of the following:
	5 On the command line, specify the pit number, and press ENTER. This value may not be left blank.
	6 On the command line, specify the pit name, and press ENTER. The pit name defaults to the same value as the entered pit number, however another value can be entered. This value may not be left blank.
	The pit is inserted as specified on the layer CRTINFSTRUCT, and a cable route JUNCTION node type is automatically placed at the center of the pit, and is placed on the layer CRTNODE.
	The cable route JUNCTION node is automatically linked to the Infrastructure Node where the Infrastructure ID for the Pit is populated into the Node ID column for the JUNCTION.

	Placing a manhole
	When capturing a cable route network, manholes are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of manholes to be placed.
	To place a manhole
	1 Choose Capture > Infrastructure > Place Manhole.
	2 Specify the insertion point for the manhole.
	3 On the command line, specify the manhole size, or press ENTER to accept the default size.
	4 To indicate the manhole angle, do one of the following:
	5 On the command line, specify the manhole name, and press ENTER. This value may not be left blank.
	6 On the command line, specify the manhole number, and press ENTER. This value may not be left blank.
	The manhole is inserted as specified on the layer CRTINFSTRUCT, and a cable route JUNCTION node type is automatically placed at the center of the manhole, and is placed on the layer CRTNODE.
	The cable route JUNCTION node is automatically linked to the Infrastructure Node where the Infrastructure ID for the Manhole is populated into the Node ID column for the JUNCTION.

	Placing a pole
	When capturing a cable route network, poles are placed by selecting a point in the drawing or inserted anywhere at a selected point on a cable route, allowing a sequence of poles to be placed.
	To place a pole
	1 Choose Capture > Infrastructure > Place Pole.
	2 Specify the insertion point for the pole.
	3 On the command line, specify the pole size, or press ENTER to accept the default size.
	4 On the command line, specify the pole name, and press ENTER.
	5 On the command line, specify the pole number, and press ENTER.
	The pole is inserted as specified.


	Draw infrastructure polygons
	They are usually drawn to indicate a housing for the fiber joints or junctions. The infrastructure polygon is placed by drawing a boundary, and then placing a name and number.The polygon builder uses the lines and tag to create an infrastructure polygon
	To draw infrastructure polygons
	1 Choose Capture > Infrastructure > Draw Infrastructure Polygon.
	2 Specify the starting point for the polygon.
	3 Draw consecutive points to form a infrastructure polygon, and press ENTER to finish the polygon.
	4 On the command line, specify the polygon name, and press ENTER.
	5 On the command line, specify the polygon number, and press ENTER.
	The polygon is inserted as specified.

	Draw infrastructure boundary
	Infrastructure polygons are captured as polygons that identifies the housing of the fiber joints or junctions. They are usually drawn to indicate a certain supply area. The infrastructure polygon is placed by drawing a boundary, and then placing a na...
	To draw a infrastructure boundary
	1 Choose Capture > Infrastructure > Draw Infrastructure Boundary.
	2 Specify the starting point for the boundary.
	3 Draw consecutive points to form a infrastructure boundary, and press ENTER to finish the boundary.
	4 On the command line, type YES to close the boundary, and press ENTER.
	The boundary is inserted as specified.

	Generate infrastructure polygons
	This function is used to generate a closed polygon from the lines, name, and number that were created with the infrastructure boundary. The function verifies that the boundary polygon forms a closed area.
	To generate infrastructure polygons
	1 Choose Capture > Infrastructure > Generate Infrastructure Polygons.
	2 Select the infrastructure boundary lines, and press ENTER.
	3 Specify the detection point, and place it within the polygon, and press ENTER.
	The polygon is inserted as specified.


	Placing Fiber Room Nodes
	Fiber Room nodes are the first cable route objects that are captured and are normally aligned with buildings, therefore parcels and buildings need to be queried before any cable fiber and cable route data is captured.
	Duplication of cable fiber and cable route objects can be avoided by querying all the existing cable fiber and cable route objects from the database before you start capturing cable fiber and cable routes.
	To place a Fiber Room Node
	Before capturing a Fiber Room Node you are required to query the Building data into the drawing to be able to select the mandatory Room Information.

	1 Do one of the following:
	The command line prompts you to select building.
	2 Select the building polygon, and then press ENTER.

	The Select Room Info dialog box opens
	Figure 2 The Select Room Info dialog box
	3 In the Select Room Info dialog box, select the Floor and Room, and then click OK.
	4 You are prompted to specify a point in the drawing where the node insertion point will be placed.

	Select a point inside the building.
	Note If the user attempts to place more than one Fiber Room Node in the same building floor/room then the system will flag an error stating that a fiber room exists within the database. After clicking continue another error will flag the user to remo...

	Placing Fiber Joint Nodes
	This Node is used to connect fiber cables or cable routes, or used as a branch out splicing point in cable fiber networks. Fiber joints are placed by selecting points in the drawing or inserted anywhere at a selected point on a cable route.
	To place a Fiber Joint Node
	1 Do one of the following:
	The command line prompts you to select infrastructure.
	2 Select the infrastructure polygon.

	The command line prompts you to specify point.
	3 Select the insertion point of the fiber joint node in the infrastructure polygon.
	The system will prompt the user to enter in a Node Reference.

	4 Enter a Node Reference value and press ENTER.


	Placing Fiber Termination Boxes
	Termination boxes is placed to terminate optical fibers outside a premises.Termination boxes are placed by selecting points in the drawing or inserted anywhere at a selected point on a cable route.
	To place a Fiber Termination Box
	1 Do one of the following:
	The command line prompts you to Specify point or [Route , Segment]
	2 The Specify point option allows the user to manually select a point in the drawing or to enter a specific X;Y coordinate value.
	3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection point.
	4 Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing to snap to, and to specify an insertion point and a side to offset from.


	Placing Fiber Distribution Hubs
	Fiber Distribution Hubs (FDH) are enclosures that provides the connection between fiber optical cables and passive optical splitters in the outside plant segment of the network. This makes it easy and fast to service connections and reconfigurations,...
	To place a Fiber Distribution Hub
	1 Do one of the following:
	The command line prompts you to Specify point or [Route , Segment].
	2 The Specify point option allows the user to manually select a point in the drawing or to enter a specific X;Y coordinate value.
	3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection point.
	4 Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing to snap to, and to specify an insertion point and a side to offset from.


	Placing Multi Service Access Nodes
	A Multi Service Access Node (MSAN) allows for the connection between copper and fiber cables thereby allowing for termination.
	To place a Multi Service Access Node
	1 Do one of the following:
	The command line prompts you to Specify point or [Route , Segment].
	2 The Specify point option allows the user to manually select a point in the drawing or to enter a specific X;Y coordinate value.
	3 Selecting the Route option places the Fiber Node at the endpoint of the Route closest to the selection point.
	Selecting the Segment option allows the user to select a MunPoly or MunLine object in the drawing to snap to, and to specify an insertion point and a side to offset from.



	Placing Fiber Junctions
	Junctions are used for fiber cable splicing and joints. Junctions are placed by selecting a point in the drawing, or by inserting on a cable route at a selected point, or within an existing Infrastructure Manhole or Pit, or as an offset from an exist...
	To place a junction in the drawing
	1 Do one of the following:
	2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:
	3 Specify a point in the drawing or enter an X;Y coordinate.
	The Junction node is placed.
	To place a junction on a Cable Route
	In order to place a Junction on an existing Cable Route, the Cable Route must not contain any fiber cables. If the selected Cable Route contains fiber cables, the user will not be able to place a Junction and the Command line will prompt the user wit...

	1 Do one of the following:
	2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:
	3 Select the Route option on the command prompt or type R at the command line.
	4 At the command line you are then prompted to select a Cable Route.
	The Junction node is placed at the endpoint of the selected Cable Route.
	To place a junction within an Infrastructure Pit or Manhole

	1 Do one of the following:
	2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:
	3 Select the Infrastructure option or type I at the command line.
	4 At the command line you are prompted to Select Infrastructure (PIT/MH)

	Select a Pit or Manhole Infrastructure.
	5 You are then prompted to Specify point relative to the selected Infrastructure.
	The Junction node is placed and linked to the selected Infrastructure. The LINK_ID column is updated with the Infrastructure INF_ID value and the LINK_TYPE column is set to INFRASTRUCTURE.
	To place a junction along a Segment

	1 Do one of the following:
	2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:
	3 Select the Segment option or type S at the command line.
	4 At the command line you are prompted to Select segment to snap to

	Select a building or parcel segment to snap to.
	5 You are then prompted to Specify insertion point

	Select a point on the segment
	6 You are finally prompted to Specify side for node

	Select the side of the segment where the node must be offset from.
	The Junction node is placed



	Capturing Telecom Nodes
	Telecom Nodes are captured on the Cable Route Node layer CRTNODE, to be verified when the integrity check is run. The Place Telecoms Node functions are used to place telecom nodes (backbone, carrier and local network nodes) independentaly of any othe...
	The Telecom nodes can be placed using the Capture > Place Telecom Node menu options, or by selecting the Telecom Node from the Capture Telecom Nodes toolbar.
	The Place Telecoms Node menu and toolbar caters for the capture of the following Telecom nodes:
	Backbone Nodes:
	Carrier Nodes:
	Local Network Nodes:
	Placing Telecoms Nodes
	Telecom Nodes can be placed on a cable route, as an offset from a selected Segment or in a location specified in the drawing. the Cable Route Settings determine the default offset distances applied per telecom node type when using the Segment option ...
	The following table indicates which prompts are displayed per Telecom Node. For those Telecom Nodes where an Infrastructure option can be selected, the table indicates the permissible Infrastructure which can be selected per Telecom Node
	Table 3 Telecom Node Placement options

	Placing Telecoms Node by Specifying point
	1 To capture a Telecoms Node using the Specify Point option do one of the following:
	2 The user is prompted to Specify point or [Route/Segment]
	3 Specify a point in the drawing or type an X;Y coordinate and select enter
	The specified node is placed
	Placing Telecoms Node by specifying a Route
	1 To capture a Telecoms Node using the Route option do one of the following:
	2 The user is prompted to Specify point or [Route/Segment]
	3 Select the Route option or type R at the command line.
	4 At the command line you are then prompted to select a Cable Route.

	On selection the Telecom node is placed at the end point of the Cable Route closest to the point selected.
	Placing Telecoms Node by specifying Infrastructure
	1 To capture a Telecoms Node using the Infrastructure option do one of the following:
	2 The user is prompted to Specify point or [Route/Infrastructure/Segment]
	3 Select the Infrastructure option or type I at the command line.
	4 At the command line you are then prompted to select one of the permitted Infrastructure types from the list provided in brackets i.e. (VAULT/SITE/PIT/MH/POLE).
	5 You are then prompted to Specify point relative to the selected Infrastructure.
	The Telecom node is placed and linked to the selected Infrastructure. The LINK_ID column is updated with the Infrastructure INF_ID value and the LINK_TYPE column is set to INFRASTRUCTURE.
	Placing Telecoms Node by specifying a Segment

	1 Do one of the following:
	2 The command line prompts you to Specify point or [Route/Infrastructure/Segment]:
	3 Select the Segment option or type S at the command line.
	4 At the command line you are prompted to Select segment to snap to

	Select a building or parcel segment to snap to.
	5 You are then prompted to Specify insertion point

	Select a point on the segment
	6 You are finally prompted to Specify side for node

	Select the side of the segment where the node must be offset from.
	The Telecom Node node is placed


	Inserting Telecoms Nodes
	1 To insert a Telecoms node do one of the following:
	The command line prompts to select a Cable route.
	2 Select a nearest point on the Cable Route where you want to insert the Telecoms Node.
	The appropriate node symbol is placed on the route at the point selected and the underlying route is broken into two Routes with two new ROUTE_ID values.




	Draw freehand cable routes
	Freehand cable routes are drawn by selecting points in the drawing, or by entering coordinates on the command line. The command line prompts you for endpoints, allowing a sequence of cable routes to be constructed. Cable Routes are captured on their ...
	To draw a freehand cable route
	1 Do one of the following:
	The command line prompts you to specify point.
	2 Specify the first point for the freehand cable route.
	3 Press ENTER when you have specified all the points.

	The freehand cable route is created as specified.
	Draw offset cable routes
	Offset cable routes are drawn by either specifying multiple points along a boundary (for example parcel or municipality boundaries), specifying the offset side, and then specifying the offset distance.
	To draw a offset cable route
	1 Do one of the following:
	The command line prompts you to specify point.
	2 Specify the first point for the offset cable route.

	The freehand cable route is created as specified.
	3 To draw an offset cable route by selecting segments, do the following:

	The freehand cable route is created as specified.
	Note When the user captures a Cable Route, a Network Check Notification integrity validation will be performed to ensure that the START_NODE, END_NODE and ROUTE_ID information is auto-populated. Once this condition is satisfied the user can then post...


	Show cable route directions
	When you have captured and edited all the cable routes, you have to check the cable route direction to verify that it is correct. This can be done for both new and existing cable routes.
	To show the cable route directions
	1 Choose Capture > Show Cable Route Direction.
	2 Select the appropriate cable routes, and then press ENTER. A direction arrow on each selected cable route indicates the route direction
	The cable route direction is shown as specified.

	Change cable route directions
	This function is used to reverse the direction of cable routes. This enables users to construct the network without taking direction into account. Once the construction is complete, the direction can be changed easily
	To change the cable route direction
	1 Choose Capture > Change Cable Route Direction.
	2 Select the cable routes of which you want to change the direction, and then press ENTER. The direction is reversed automatically.
	The cable route direction is changed as specified.
	Note The integrity check does not verify cable route direction; therefore it is very important to make certain that the cable route direction is correct.


	Clear direction arrows
	To clear direction arrows
	When you are satisfied that the direction of all the cable routes is correct, the direction arrows can be cleared from the drawing.

	1 Choose Capture > Clear Direction Arrows.
	2 Click the Clear Direction Arrows button on the Capture menu.
	The cable route direction arrows will be removed.

	Place cable route symbols
	This function is used to place cable route symbols in the current drawing. Cable route symbols represent additional annotation in the form of a symbol, and do not form part of the cable route network. Cable route symbols can be placed anywhere withou...
	Note The database administrator can add additional cable route symbols to the lookup table LU_CRS_CRTSYM as required. This table contains a number of default symbols, but can be customized. The user or administrator will need to create a correspondin...
	To place a cable route symbol

	1 Do one of the following:
	The Cable Route Symbols dialog box is displayed, showing a list of available cable route symbols.
	Figure 4 The Cable Route Symbols dialog box
	2 From the list, select the symbol that you want to place, and then click OK.
	3 Specify an insertion point for the symbol.
	4 Specify a rotation angle for the symbol by doing one of the following:

	The symbol is placed at the insertion point and angle that you specified.
	Note Press ENTER or Spacebar to continue placing consecutive symbols of the same type, without having to select a symbol type from the list every time.



	Placing cable route labels
	With this function, you can place a label on a cable route that has been queried from the database. The cable route label shows the current cable route type, for example ‘COND’. If you change the cable route type and post the changes to the datab...
	To place a cable route label
	1 Do one of the following:
	The command line prompts you to select a cable route to label.
	2 Select the cable route to which you want to attach the label.
	3 Specify an insertion point for the label.
	4 Specify the tag height for the label, or press ENTER to accept the default tag height.
	5 To indicate the tag angle, do one of the following:

	The label is placed as specified.

	Placing cable route notes
	For map production purposes, information about a spatial object is added in the form of a note.
	To place a cable route note
	1 Do one of the following:
	The command line prompts you to select a cable route to label.
	2 Specify the insertion point for the note.
	3 On the command line, specify the note height, or press ENTER to accept the default note height.
	4 To indicate the note angle, do one of the following:
	5 Type the note value on the command line, and then press ENTER.

	The note is inserted as specified.

	Placing dimension arrows
	To place dimension arrows
	Map production is a reduced version of reality and it is therefore virtually impossible to capture cable routes at the true offset distance from a parcel boundary. Dimension arrows are used to indicate the offset distance of a cable route from a parc...

	1 Do one of the following:
	The command line prompts you to select a cable route to label.
	2 Specify the first segment for dimension.

	The dimension arrows will be placed perpendicular to this segment.
	3 Specify the second segment for dimension.

	The dimension arrows are aligned to the point selected on this segment.
	4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance as determined in the Cable Route Settings, or press A to place the actual calculated distance.

	The dimension text is placed at the dimension arrows, indicating the distance between the two dimension lines.

	Cable route integrity
	The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial objects have to be verified against integrity rules built into the capture and change routines of every application before they can be posted to the ...
	The Integrity Check is run from the Capture menu, or by clicking the appropriate button on the Integrity toolbar. The way in which the integrity check is executed depends on the preferences/options specified in the Munsys Options dialog box. The vari...
	The integrity check is split into two separate functions to facilitate flexibility and ease of use:
	Validate Object Integrity – checks and validates the spatial and/or attribute data of an object, according to the options specified in the Munsys Options dialog box:

	When the Validate Geometry: Modified objects option has been selected, the geometry of only new or modified objects will be validated.
	When the Validate Geometry: All objects option has been selected, all the objects in the selection set will have their geometry validated. This includes locked, unlocked, modified and non-modified objects.
	When the object integrity check has completed and changes in objects have been encountered that may affect network integrity, a warning message to this effect is displayed if the option was specified in the Munsys Options dialog box.
	Validate Network Integrity – validates the rules that, together with the objects, make up a network, and according to the Network Integrity options specified in the Munsys Options dialog box. Network validation includes the topology and connectivit...

	This function is dependent on the relationships between objects, and therefore requires more objects to be included as part of the validation process than only those that were modified. The Validate Network Integrity function allows non-validated obj...
	Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network Integrity Check), which is set by the database administrator in the Munsys Management Console, allows a network integrity check to be performed automatically whenever an...
	When the cable route object integrity is checked, the following is verified:
	Table 5 The cable route object integrity check

	When the cable route network integrity is checked, the following is verified:
	Table 6 The cable route network integrity check




	Checking cable route object integrity
	1 Do one of the following:
	2 Select the objects that you want to validate, and then press ENTER.
	The Integrity Results dialog box is displayed, providing summarized information and validation results encountered during the object integrity check.
	Figure 7 The Integrity Results dialog box
	3 If you selected the Notify when objects require network validation option on the Munsys Options dialog box, and if objects were encountered during the integrity check that may affect network integrity, the following message is displayed:
	Figure 8 Network Integrity Warning



	Checking cable route network integrity
	1 Do one of the following:
	2 Select the objects that you want to validate, and then press ENTER.
	3 If you selected objects that have not been validated by the Validate Object Integrity function, the following message is displayed:
	Figure 9 Object Integrity Warning

	4 When the integrity check has completed, the Integrity Results dialog box is displayed, providing summarized information and validation results encountered during the network integrity check.
	Figure 10 The Integrity Results dialog box


	Browsing integrity markers
	You can review the integrity markers resulting from the integrity check with the Browse Integrity Markers dialog box. This dialog box displays the complete list of errors encountered during the integrity check. The list consists of the error type, th...
	To browse integrity markers
	1 Do one of the following:
	The Browse Integrity Markers dialog box is displayed.
	Figure 11 The Browse Integrity Markers dialog box
	2 To locate an error, select the appropriate integrity marker, and then click the Locate button.
	Munsys zooms to the extent of the spatial object to which the integrity marker refers.

	3 To remove integrity markers from the list and from the drawing, select one or more integrity markers from the list, and then click the Remove button.

	The integrity markers are removed from the drawing and from the list of markers.

	Erasing integrity markers
	With this function, you can erase all the integrity markers. Integrity markers are stored on the INTEG layer.
	To erase integrity markers
	1 Do one of the following:
	The command line prompts you for confirmation to erase all the integrity markers.
	2 Press ENTER to erase the integrity markers.

	The integrity markers are erased.

	Posting cable route data to the database
	New or modified cable route data that has passed the integrity check is posted to the database.
	To post cable route data to the database
	1 Do one of the following:
	The Database Posting Summary dialog box is displayed.
	Figure 12 The Database Posting Summary dialog box

	This dialog box displays the following:
	2 Click OK to update the database.

	The Database Posting Results dialog box is displayed.
	Figure 13 The Database Posting Results dialog box

	This dialog box displays the following:
	3 Click Close to exit the Database Posting Results dialog box.
	Once you have posted objects to the database, you will not be able to undo this function, which will avoid duplicate objects and keep the content of the drawing synchronized with the database.



	Validating object integrity and posting data at the same time
	If you select the Automatically perform Object Integrity option on the Munsys Options dialog box Preferences tab, you can perform an object integrity check and database posting operation at the same time. The following rules will be applied when the ...
	If errors occurred during the object integrity check, you can do one of the following:
	To validate object integrity and post objects at the same time
	1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object Integrity check box in the Database Posting Preferences group.
	2 Choose Capture > Post to Database.

	An object integrity check is run on the all the new or modified objects in the drawing.
	3 If any errors occurred, the following message is displayed:
	Figure 14 Database Posting – Object Integrity Errors

	4 Do one of the following:


	Editing cable route object attributes
	The Edit Attributes function is used to edit the attributes of one or more selected cable route spatial objects that belong to the same object type. The current application determines what object types may be selected; for example, if you are working...
	Objects that are selected for editing are locked (if record locking is enabled in the database). Once the objects have been selected and an object type to edit has been specified, the Edit Attributes dialog box is displayed. This dialog box contains ...
	Attribute templates – attributes can be edited using an attribute template. The attributes that will be displayed when an attribute template has been selected will depend on the attributes that have been specified on the template, as well as the fo...
	Editing multiple objects simultaneously – if you select this option, attributes of multiple objects are displayed simultaneously. Where the attributes of all the selected objects are the same, a value is displayed. Where attributes of the various o...
	AutoZoom – this option is only available when the Edit multiple objects simultaneously option is not selected, i.e. when you are going to edit the objects one by one. If the AutoZoom to object option is selected, Munsys will zoom to each object in ...

	The various attributes are displayed on the Edit Attributes dialog box in three columns: Description, Value and Column Name. You can resize the dialog box for easier viewing. Values that may not be edited are unavailable. Attributes are edited in the...
	When editing attributes, mandatory fields are displayed with an “!” character prefixing the attribute column in the Attributes list on the Edit Attributes dialog box. If the mandatory attribute is not captured for new or modified objects, the Obj...
	To edit cable route spatial objects
	1 Choose Change > Edit Attributes...
	2 Select the objects that you want to edit, and then press ENTER.
	If you selected more than one object belonging to different object types, the Spatial Object Identification dialog box is displayed.
	Figure 15 The Spatial Object Identification dialog box
	3 Select a single spatial object type to edit, and then click OK.

	The Edit Attributes: Cable Route Links dialog box is displayed.
	Figure 16 The Edit Attributes dialog box
	4 If you want to edit the objects using an attribute template, select the appropriate attribute template from the Attribute Template list. If you do not want to make use of an attribute template, select None.
	5 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple objects simultaneously check box.

	Similar values are displayed, while values that differ between objects are displayed as *VARIES*.
	Figure 17 The Edit Attributes dialog box: Edit multiple objects simultaneously
	6 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously check box. Select the AutoZoom to object check box to zoom to the objects one by one and highlight them. The object navigation buttons are used to m...
	7 To edit an attribute, do one of the following:
	Note Mandatory attributes are displayed with an “!” character preceding the Attribute Description. Failure to capture mandatory attributes for new or modified objects results in the object failing the Object Integrity Check.

	8 Click OK to apply the new value(s) to the object(s).
	9 The values are applied to the objects, to be verified with the object integrity check.


	Editing linked table attributes
	This function is used to edit spatial object attributes that exist in linked tables. Linked table attributes are updated directly to the database. The current application determines what object types may be selected; for example, if you are working i...
	The link tables that can be edited using this function must be defined through an attribute template. The applicable attribute template is selected from a list, which is created by filtering attribute templates according to the following characteristics
	Only attribute templates associated with the current spatial object type, being edited are included – the primary table in the attribute template is the same table from which the spatial objects were queried.
	Only attribute templates that contain linked tables are included
	The linked table specified may not be a Munsys spatial table
	The user must have edit privileges to the linked table
	The link column used to describe the relationship with the primary table must reference a true column in the linked table. This may not be an expression.

	Attributes are displayed on the Linked Table Attributes dialog box in three columns: Description, Value and Column Name. You can resize the dialog box for easier viewing. Values that may not be edited are unavailable. Attributes are edited in the Val...
	To edit linked table attributes
	1 Choose Change > Edit Linked Table Attributes...
	2 Select the objects that you want to edit, and then press ENTER.
	If you selected more than one object belonging to different object types, the Spatial
	Object Identification dialog box is displayed.
	Figure 18 The Spatial Object Identification dialog box
	3 Select a single spatial object type to edit, and then click OK.

	The Linked Table Attributes dialog box is displayed.
	4 Select the attribute template that you want to work with from the Attribute Templates Containing Linked Tables list.
	Figure 19 The Select Templates Linked Table Attributes dialog box


	The Description, Value and Column Name columns are populated according to the template that you selected, and the number of records and objects that were selected are displayed.
	Figure 20 The Linked Table Attributes dialog box
	5 Select the AutoZoom to object check box to zoom to each object and highlight it as it becomes the current object.
	6 Use the navigation buttons to move between records and objects.
	7 To insert a new record, click Insert, and then enter the new values in the Value column.
	Figure 21 The Insert Linked Table Attributes dialog box

	8 To delete the record that is currently displayed, click Delete.
	9 Select either the Cable Route Node or Fiber Joint Node which has changed in location.

	Changing cable routes
	To extend a cable route to a boundary
	Cable routes can be extended to a boundary object by first indicating the boundary object, and then selecting the cable route to extend. The boundary object must be able to intersect with the cable route. This function is often used to extend cable r...

	1 Do one of the following:
	2 Select the boundary object where the cable route has to extend to.
	3 Select the cable route that needs to extend.
	The cable route is extended as indicated.
	To extend a cable route by distance
	This function extends a cable route by a specified distance at the endpoint closest to a selected point on the cable route. You are prompted for the distance to extend the cable route with. You can also use this function to shorten a cable route by e...

	1 Do one of the following:
	2 Select the cable route that you want to extend, and then enter a distance on the command line.

	The pipe is extended by the distance that you entered.
	To extend a cable route and break it at the intersection
	This function extends a cable route to a cable route that is then broken at the intersection. The cable route to be broken is selected first, and then the cable route to extend. The cable route to be broken must intersect with the second cable route.

	1 Do one of the following:
	2 Select the cable route that you want to break.
	3 Select the cable route that you want to extend.

	The cable routes are extended and broken respectively, as indicated.
	Note If a cable route has duct information attached then the system will flag this, asking the user if the duct information should be retained and captured to the new cable routes or not.
	To break a cable route
	This function breaks a pipe nearest to a selected point on the pipe.


	1 Do one of the following:
	2 Select a point on the cable route where you want to break it.

	The cable route is broken at the point that you selected.
	Note If a cable route has duct information attached then the system will flag this, asking the user if the duct information should be retained and captured to the new cable routes or not.
	To change a cable route
	With this function, you can move one or more selected cable route endpoints to a new location.


	1 Do one of the following:
	2 Select the endpoint of the cable route that you want to change.
	3 Indicate the destination point.

	The cable route is changed as indicated.
	To fillet cable routes
	This function connects two cable routes at a projected intersection.

	1 Do one of the following:

	The command line prompts you to indicate the two cable routes that need to be extended or trimmed.
	2 Select the first cable route.
	3 Select the second cable route.

	The cable routes are connected as indicated.
	To trim a cable route
	1 Do one of the following:
	2 Select the cable route that you want to trim to, as the cutting edge.
	3 Select a point on the side of the second cable route that needs to be trimmed.

	Munsys trims the last indicated cable route to the first one.
	To join cable routes
	This function is used to join two cable routes, creating a single cable route. The attributes from the first cable route selected remain the attributes for the joined cable route. If there is a gap between the two cable routes to be joined, they are ...

	1 Choose Change > Join Cable Route.
	2 Select the first cable route (the cable route that you want to join to).
	3 Select a point close to the endpoint of the second cable route (the cable route that you want to join).

	The cable route are joined as indicated, and the attributes from the first cable route selected remain the attributes for the joined cable route.
	To change the vertex of a cable route
	With these functions, you can remove, move, add or insert new vertices to segments in a cable route.

	To add a vertex to a cable route
	1 Choose Change > Change Cable Route Vertex > Add.
	2 Select the appropriate cable route.
	3 Select the endpoint of the cable route to which you want to add a vertex.
	4 Select a position for the new point.
	A vertex is added at the point you selected
	To move a cable route vertex

	1 Choose Change > Change Cable Route Vertex > Move.
	2 Select the appropriate cable route.
	3 Specify a point closest to the vertex that you want to move.
	4 Specify a point to move the vertex to.

	The vertex is moved to the point that you specified.
	To remove a cable route vertex
	1 Choose Change > Change Cable Route Vertex > Remove.
	2 Select the appropriate cable route.
	3 Select the vertex that you want to remove from the cable route.
	Note A vertex can only be removed from a segment with more than two vertices.
	To insert a vertex into a cable route


	1 Choose Change > Change Cable Route Vertex > Insert.
	2 Select the appropriate cable route.
	3 Select the segment for the inserted point.
	4 Select the position for the new point.

	The vertex is inserted at the position you selected.
	Changing cable route nodes
	Using the Munsys Cable Route Change menu/toolbar, cable routes nodes can be moved to a new location, rotated manually or snapped to cable routes. You can also change the node type of one or more selected nodes. These functions are used when the netwo...

	To move a node
	With this function, you can move a single node to a new location.

	1 Do one of the following:
	2 Select the node that you want to move.
	3 Specify a new insertion point for the node.

	The node is moved as indicated.
	To rotate a node
	With this function, you can rotate one or more selected nodes.

	1 Do one of the following:
	2 Select the node that you want to rotate.
	3 To specify the rotation angle, do one of the following:

	The node is rotated as specified.
	To snap a node to the endpoint of a cable route
	With this function, you can snap a node to the endpoint of a cable route. The node is moved to the end point closest to the point selected on the cable route.

	1 Do one of the following:
	2 Select the applicable node.
	3 Select the cable route close to the endpoint that you want to snap the node to.

	The node is snapped to the endpoint of the cable route.
	To edit a route duct
	When the user captures a Cable Route (irrespective of freehand or offset) then the user can then manually assign duct information to the newly placed Cable Routes (runs). Logically this would indicate the number of ducts available for the Fiber Cable...

	To Add a New Route Duct
	1 Choose Change > Edit Route Duct.
	Figure 22 Edit Route Duct Menu Item

	2 Select the appropriate Cable Route.

	The Edit Duct Info dialog box is displayed.
	Figure 23 The Edit Duct Info dialog box
	The user will notice that the Route ID and Route Type will be populated, which therefore requires the Cable Route to be posted to the database.
	3 Click on the Ducts text within the Ducts dialog box. Click on the Add button within the Duct Information dialog.
	The New Route Duct dialog box should open and the user can then fill in the required information:
	Figure 24 The New Route Duct dialog box


	4 Once all the information has been populated the user can then click OK to apply.
	The user will now notice the Duct Information has been added.

	5 This will bring the user back to the default Edit Duct Dialog. The user can also add ducts within a duct, paying careful consideration to the Duct Type feature.
	6 Click Commit to save changes to the database.
	Figure 25 The Database Information dialog box
	To Modify/Delete Existing Duct Information

	1 Choose Change > Edit Route Duct.
	2 Select the appropriate cable route.
	The Edit Duct Info dialog box is displayed.

	3 Click on the relevant Duct from the Duct dialog, and then the user should see associated Duct Information at the bottom of the Edit Duct Info dialog.
	Figure 26 Edit Duct Info Dialog for Modifying Duct Info
	When multiple ducts are added across a variety of cables, then it is difficult for the user to sometimes navigate to a particular duct. Easily locating duct information can be effectively carried out by using the Search button within the Edit Duct In...

	4 Click on either Modify or Delete and follow the prompts.
	This should carry out the intended function as desired by the user.
	To copy a route duct
	With this function you can copy information from one run/duct to another duct which has no information assigned. This provides the user with an easy solution when populating multiple ducts, using one duct which has information assigned, without havin...


	1 Choose Change > Copy Route Duct.
	Figure 27 Copy Route Duct Menu Item

	2 Select the appropriate Cable Route you wish to copy information From.
	Figure 28 Cable Route Duct Information to Copy From

	3 Select the appropriate Cable Route you wish to copy information To.
	Figure 29 Cable Route Duct Information to Copy To

	4 Press ENTER.
	To change a node type
	With this function, you can change the node type of one or more selected nodes. The new node type is selected from a list. The symbol name and the NODE_TYPE column are updated according to the new node type selected.


	1 Choose Change > Change Node Type...
	2 Select the node(s) that you want to change, and then press ENTER.
	The Node Types dialog box is displayed.
	Figure 30 The Node Types dialog box


	3 Select the new node type from the list, and then click OK.



	Relink Node
	The Relink Node functionality allows the user to update the Node information in instances where the start/end node location is changed. The Relink Node function focuses particularly on the Fiber Room node and Fiber Joint nodes which are placed in Bui...
	When the location of a Fiber Joint node changes in relation the respective infrastructure then the LINK TYPE (Infrastructure) and LINK ID (Infrastructure ID) will be updated accordingly.
	To use the Relink Node function
	1 Choose Change > Relink Node.
	Figure 31 Relink Node function

	2 Select either the Cable Route Node or Fiber Joint Node which has changed in location.
	Figure 32 Select Cable Route Node to Relink

	3 Select the relevant Building or Infrastructure which the Cable Route Node or Fiber Joint Node now resides in.
	Figure 33 Select Building to Relink with Cable Route Node

	4 Select the associated Building Floor and Room information
	Figure 34 Select Building Floor and Room information

	5 Click OK or Press ENTER.
	Note A Fiber Room Node may only be linked to a single combination of Floor and Room Number.
	Important If you attempt to relink the Fiber Room Node to a Floor and Room combination where an existing Fiber Room Node is linked, you will be presented with a message indicating that the Fiber room already exists. You will be required to either sel...


	Changing cable route owners
	This function is used to change cable route owner attributes. Owner attributes can only be edited by users who have been assigned the MUNSYS_CRS_EDIT role. You can change the owner type of an existing cable route.
	To change cable route owners
	1 Choose Change> Change Owner.
	The command line prompts you to select cable route objects.
	2 Select the cable route to be changed.

	The Select Owner dialog box opens.
	Figure 35 The Select Owner dialog box
	3 In the Select Owner dialog box, select a owner type by Code or Description, and then click OK.


	Changing cable route state
	This function is used to change the cable route state. Cable route states can only be edited by users who have been assigned the MUNSYS_CRS_EDIT role. You can change the state of an existing cable route.
	To change cable route state
	1 Choose Change> Change State.
	The command line prompts you to select a cable route objects.
	2 Select the cable route to be changed.

	The Select State dialog box opens.
	Figure 36 The Select State dialog box
	3 In the Select State dialog box, select a state type by Code or Description, and then click OK.


	Changing cable route status
	This function is used to change the cable route status. Cable route status can only be edited by users who have been assigned the MUNSYS_CRS_EDIT role. You can change the status of an existing cable route.
	To change cable route status
	1 Choose Change> Change Status.
	The command line prompts you to select a cable route objects.
	2 Select the cable route to be changed.

	The Select Status dialog box opens.
	Figure 37 The Select Status dialog box
	3 In the Select Status dialog box, select a status type by Code or Description, and then click OK.


	Changing cable route notes
	With this function, you can change the text of an existing cable route note.
	To change a cable route note
	1 Choose Change> Change Cable Route Note...
	The command line prompts you to select a cable route note.
	2 Select the cable route note that you want to change.

	The Cable Route Note text box is displayed.
	Figure 38 The Cable Route Note text box
	3 Change the note as required, and then click OK.

	The cable route note is changed as specified.
	Adding comments
	This function is used to assign descriptive comments to one or more selected objects.
	To add comments
	1 Choose Change > Add Comment...
	The command line prompts you to select a cable route object.
	2 Select the cable route object(s) that you want to add a comment to.

	The Cable Route Comment text box is displayed.
	Figure 39 The Cable Route Comment text box
	3 In the text box, add the comment, and then click OK.
	The comment is assigned to the selected object(s).




	Deleting and undeleting cable route objects
	With Munsys Cable Route, existing cable route objects can be deleted from the database. Multiple objects can be selected for deletion. Cable route objects that form part of a redundant network have to be deleted. Deleted cable route objects are moved...
	To delete cable route objects
	1 Choose Change > Delete Cable Route Objects.
	The command line prompts you to select objects to be deleted.
	2 Select the cable route objects that you want to delete.

	The command line indicates how many cable route objects you have selected, and how many have been filtered out.
	3 Press ENTER to delete the selected objects.

	The cable route objects are flagged for deletion and moved to the DELETED layer. These changes will be applied to the database once its posted.
	To undelete cable route objects
	1 Choose Change > Undelete Cable Route Objects.

	The objects that you have deleted will be displayed in the drawing, and the command line prompts you to select objects to undeleted.
	2 Select the cable route objects that you want to restore.

	The Delete flag is no longer set for the selected objects. In the event of spatial or attribute changes before the objects were flagged for deletion, these changes are applied.

	Cable cable route network quality reporting
	The Network Quality Report function on the Extras menu is used to validate the quality of the entire network. The network quality report complements the network integrity check. Although it is recommended that a network integrity check is always done...
	Specific columns in each of the spatial tables are used to build up the topology of the network, for example the start and end nodes of a cable route. The network quality report will validate these values based on cable route-specific rules.
	Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS table, together with the appropriate error message related to each spatial object where an error occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query,...
	If a single spatial object contained more than one error, a record will be stored for each error that occurred within that object. You can also have the errors populated to the COMMENTS column of the object(s) in which errors occurred, if you do not ...
	The following table shows the cable fiber and cable route network errors that may occur:
	Figure 40 Cable cable route network quality errors

	To validate cable route network quality
	1 Choose Extras > Network Quality Report...
	The command line displays the message: Generating network quality report
	2 If errors were found in the network, the following message is displayed:
	Figure 41 Network Quality errors found

	3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column updated.

	The Save Results Summary As dialog box is displayed.
	4 Save the report to a location of your choice.
	The report is opened in Windows Notepad, and contains the following information:
	The number of objects that were checked
	The number of objects found that violated the network rules
	The number of endpoints that were found in the network
	The number of errors that were found, grouped by error type
	Figure 42 A cable route network quality report





	Generating cable route data status reports
	Data status reports provide summarized information about spatial objects that are currently stored in the database. Once a report has been generated, it is saved to a comma delimited file, and then displayed in Notepad for easy viewing. The following...
	a summary of all the cable route objects in the database
	a summary of the total length and number of cable routes, by type and category
	a summary of the umber of cable route nodes by node type

	To generate a cable fiber and cable route data status report
	1 Choose Extras > Data Status Report...
	The Data Status Report dialog box is displayed, showing a list of all the reports that can be generated.
	Figure 43 The Data Status Report dialog box
	2 Select one or more reports to generate from the list, and then click OK.
	3 Save the file to a location of your choice.

	The file is opened in Windows Notepad.
	Figure 44 Data status report for service connections


	Converting AutoCAD entities to cable route objects
	With Munsys, you can convert selected AutoCAD entities to Munsys Cable Route objects. Block entities can be converted to cable route nodes (switches, distributed line units, main distribution frames, etc.), or line entities can be converted to cable ...
	Although some basic attributes are assigned as part of the conversion process, you will need to assign attributes to the objects created with the conversion process.
	To convert block entities to cable route nodes
	With this function, you can convert AutoCAD block entities to any of the available cable route nodes. To convert block entities to cable route nodes, do the following:

	1 Choose Extras > Convert Block to > Switch / Distributed Line Unit / Main Distribution Frame / Multi Service Access Node/ DIGICON Terminal / Microwave Tower/ Fiber Termination Box / Fiber Distribution Hub / Primary Joint / Street Distribution Cabine...
	2 Select the block entities that you want to convert, and then press ENTER.
	One cable route node is created for each block entity that you selected, and the drawing is updated accordingly.
	To convert line entities to cable routes
	With this function, you can convert AutoCAD line entities to cable routes. To convert line entities to cable routes, do the following:

	1 Choose Extras > Convert Line to Cable Route.
	2 Select the line objects that you want to convert to cable route objects, and then press ENTER.

	The selected line objects are converted and the drawing is updated accordingly.
	To convert text to cable route notes
	With this function, you can convert AutoCAD text entities to cable route notes.

	1 Choose Extras > Convert Text to Cable Route Note.
	2 Select the objects that you want to convert, and then press ENTER.

	The entities are converted to the cable route objects, and the drawing is updated accordingly.
	To convert polygons to cable route infrastructure
	1 Choose Extras > Convert Polygon to cable route infrastructure.
	2 Select the polygons that you want to convert, and then press ENTER.

	The polygons are converted to cable route infrastructure, and the drawing is updated accordingly.
	Chapter 5
	Creating and Maintaining cable fiber data
	Capturing and Modifying cable fiber data
	Once the capture of cable route data has been executed then the user can proceed with the capture of cable fiber data. This is the last component of the Cable Fiber Application and refers the actual cable. It comprises of the Cable and Strands which ...
	A detailed look at the processes that occur when capturing and modifying cable fiber data is outlined in this chapter, together with the Termination of Fiber Room Nodes, adding of Equipment and Channels, Connection of fiber cables and addition of Ser...
	Maintaining cable fiber data can occur from accessing the Change menu where these detailed processes mentioned above, including ReRouting cables, the management of Equipment and managing Fiber Cable Duct Info.
	A detailed look at the capture and modification of cable fiber data will be captured in this chapter.



	Cable Fiber
	Cable fiber capture settings
	Each Munsys application has its own default capture settings that are set by the GIS administrator in the Munsys Management Console.
	In Munsys Cable Fiber, default settings are available for:
	Cable Fiber – cable fiber auto terminate, cable fiber auto trace, dimension distance, duct prompt, fiber group, label height, and type, Cable Fiber Zoom to Node and Cable Fiber Zoom to Node Scale Factor.
	Cable Fiber Symbols – cable fiber symbol scale
	Dimensions – dimension note height
	Fiber Geom Settings – geometry arc distance, geometry tolerance, geometry unit
	File – the drawing directory
	General – construction color, include network in object integrity, database extents display resolution, integrity circle size, tag and symbol scale and rotation if coordinate transformation is done, snap tolerance, tag angle, font, height and justi...
	Notes – note tag height

	You can change the current settings on the Cable Fiber Settings dialog box to speed up the capture process. Capture settings only apply to new cable fiber objects, and if you change the default settings, the changes are only valid for the current ses...
	Settings are changed by highlighting the current value, and then:
	entering a new value
	selecting the new value from a drop-down list

	The user cannot change all of the settings. Some settings may only be changed by the GIS administrator to enforce consistency and integrity on a higher level. Settings that cannot be changed are “greyed out” on the Capture Settings dialog box.

	Tip A short description of a value displays when it is highlighted.
	To specify cable fiber capture settings

	1 Do one of the following:
	2 The Cable Fiber Settings dialog box is displayed, showing the default cable fiber capture settings.
	The Cable Fiber settings dialog box opens.
	Some values are changed by selecting a value from a drop-down list.
	Figure 1 The Cable Fiber Settings dialog
	3 To change a value, do one of the following:
	4 Click OK to apply the new settings.

	The settings will apply until you change them again, or until the current session is terminated.
	Note The Auto-Terminate function is ticked on by default, however if this is ticked off, then the user would have to ensure that the Fiber Room Nodes are manually Terminated before deploying equipment. If both Fiber Room Nodes are not terminated, aft...
	Note The Cable Fiber Auto Trace setting determines if auto tracing is enabled when capturing a new fiber cable. If enabled, it will automatically trace the fiber cable between the two selected two nodes if there is no alternative route.
	Note The Cable Fiber Zoom to Node setting determines if the fiber cable capture function will automatically zoom to the node. The check-box is ticked on by default.
	Note The Cable Fiber Zoom to Node Scale Factor setting is the default scale factor used when automatically zooming to the node during the fiber cable capture process. The default scale factor is 1500m and can be changed by the user for the session by...

	Define New Fiber Cable
	This is the last component of the Cable Fiber Application and refers to the actual cable. It comprises of the Cable and Strands which are terminated between buildings and in doing so, establishing the connection of services amongst these buildings
	To define a new fiber cable
	1 Choose Capture > Define New Fiber Cable.
	The command line prompts you to select a start node.
	2 Select the start node.

	The command line prompts you to select the end node.
	3 Select the end node.

	The command line prompts you to select a cable route.
	4 Select the cable route/s.

	The command line prompts you if you are done selecting cable routes.
	Note If the Cable Fiber Auto Trace setting is enabled it will automatically trace the fiber cable between the two selected nodes if there is no other fiber cable connected to the selected start node. You may be required to select additional cable rou...
	5 On the command line, specify YES, and press ENTER.

	The Fiber Cable Info dialog box opens.
	Figure 2 The Fiber Cable Info dialog box
	The Fiber Cable Info dialog auto-populates the From Node and To Node Information based on the Building or Infrastructure selected when defining the Cable Route.
	6 Define the fiber cable, do the following:
	Note Select the Set Meterage... option to view the Fiber Cable Geometry Length based on the actual fiber cable drawn in the drawing.
	Figure 3 The Edit Duct Info



	The fiber cable is inserted as specified.
	If the Set Meterage... option is selected, the Fiber Cable Info dialog is displayed where the Start and End meterage values can be entered and the Cable Length is automatically calculated. The Splice Length, Start and End Wall lengths can also be man...
	Figure 4 The Fiber Cable Info dialog box for Set Meterage

	The user will have the option to place a Single mode fiber cable or a Mixed Mode fiber cable. A Single mode fiber cable communicates in only one direction, either a Transmit or Receive. Contrary to that, the Mixed Mode fiber cable is thicker but can ...
	Important When a fiber cable is deleted, this would be removed from within the database immediately, thereby making the UNDO function obsolete. The user would then be unable to UNDO the deletion of that specific cable.


	Show cable fiber directions
	When you have captured and edited all the cable fibers, you have to check the cable fiber direction to verify that it is correct. This can be done for both new and existing cable fibers.
	To show the cable fiber directions
	1 Choose Capture > Show Cable Fiber Direction.
	2 Select the appropriate cable fibers, and then press ENTER. A direction arrow on each selected cable fiber indicates the direction
	The cable fiber direction is shown as specified.


	Clear direction arrows
	To clear direction arrows
	When you are satisfied that the direction of all the cable routes is correct, the direction arrows can be cleared from the drawing.

	1 Choose Capture > Clear Direction Arrows.
	2 Click the Clear Direction Arrows button on the Capture menu.
	The cable fiber direction arrows will be removed.


	Place cable fiber symbols
	This function is used to place cable fiber symbols in the current drawing. Cable fiber symbols represent additional annotation in the form of a symbol, and do not form part of the cable fiber network. Cable fiber symbols can be placed anywhere withou...
	Note The database administrator can add additional cable fiber symbols to the lookup table LU_CFS_FIBSYM as required. This table contains a number of default symbols, but can be customized.
	To place a cable fiber symbol

	1 Do one of the following:
	The Cable Fiber Symbols dialog box is displayed, showing a list of available cable fiber symbols.
	Figure 5 The Cable Fiber Symbols dialog box
	2 From the list, select the symbol that you want to place, and then click OK.
	3 Specify an insertion point for the symbol.
	4 Specify a rotation angle for the symbol by doing one of the following:

	The symbol is placed at the insertion point and angle that you specified.
	Note Press ENTER or Spacebar to continue placing consecutive symbols of the same type, without having to select a symbol type from the list every time.



	Placing cable fiber notes
	For map production purposes, information about a spatial object is added in the form of a note.
	To place a cable fiber note
	1 Do one of the following:
	The command line prompts you to select a cable fiber to label.
	2 Specify the insertion point for the note.
	3 On the command line, specify the note height, or press ENTER to accept the default note height.
	4 To indicate the note angle, do one of the following:
	5 Type the note value on the command line, and then press ENTER.

	The note is inserted as specified.

	Placing dimension arrows
	To place dimension arrows
	Map production is a reduced version of reality and it is therefore virtually impossible to capture cable fiber at the true offset distance from a parcel boundary. Dimension arrows are used to indicate the offset distance of a cable fiber from a parce...

	1 Do one of the following:
	The command line prompts you to select a cable fiber to label.
	2 Specify the first segment for dimension.

	The dimension arrows will be placed perpendicular to this segment.
	3 Specify the second segment for dimension.

	The dimension arrows are aligned to the point selected on this segment.
	4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance as determined in the Cable Fiber Settings, or press A to place the actual calculated distance.
	The dimension text is placed at the dimension arrows, indicating the distance between the two dimension lines.



	Cable fiber integrity
	The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial objects have to be verified against integrity rules built into the capture and change routines of every application before they can be posted to the ...
	The Integrity Check is run from the Capture menu, or by clicking the appropriate button on the Integrity toolbar. The way in which the integrity check is executed depends on the preferences/options specified in the Munsys Options dialog box. The vari...
	The integrity check is split into two separate functions to facilitate flexibility and ease of use:
	Validate Object Integrity – checks and validates the spatial and/or attribute data of an object, according to the options specified in the Munsys Options dialog box:

	When the Validate Geometry: Modified objects option has been selected, the geometry of only new or modified objects will be validated.
	When the Validate Geometry: All objects option has been selected, all the objects in the selection set will have their geometry validated. This includes locked, unlocked, modified and non-modified objects.
	When the object integrity check has completed and changes in objects have been encountered that may affect network integrity, a warning message to this effect is displayed if the option was specified in the Munsys Options dialog box.
	Validate Network Integrity – validates the rules that, together with the objects, make up a network, and according to the Network Integrity options specified in the Munsys Options dialog box. Network validation includes the topology and connectivit...

	This function is dependent on the relationships between objects, and therefore requires more objects to be included as part of the validation process than only those that were modified. The Validate Network Integrity function allows non-validated obj...
	Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network Integrity Check), which is set by the database administrator in the Munsys Management Console, allows a network integrity check to be performed automatically whenever an...
	When cable fiber object integrity is checked, the following is verified:
	Table 6 The cable fiber object integrity check




	Checking cable fiber object integrity
	1 Do one of the following:
	2 Select the objects that you want to validate, and then press ENTER.
	The Integrity Results dialog box is displayed, providing summarized information and validation results encountered during the object integrity check.
	Figure 7 The Integrity Results dialog box
	3 If you selected the Notify when objects require network validation option on the Munsys Options dialog box, and if objects were encountered during the integrity check that may affect network integrity, the following message is displayed:
	Figure 8 Network Integrity Warning



	Checking cable fiber network integrity
	1 Do one of the following:
	2 Select the objects that you want to validate, and then press ENTER.
	3 If you selected objects that have not been validated by the Validate Object Integrity function, the following message is displayed:
	Figure 9 Object Integrity Warning

	4 When the integrity check has completed, the Integrity Results dialog box is displayed, providing summarized information and validation results encountered during the network integrity check.
	Figure 10 The Integrity Results dialog box


	Browsing integrity markers
	You can review the integrity markers resulting from the integrity check with the Browse Integrity Markers dialog box. This dialog box displays the complete list of errors encountered during the integrity check. The list consists of the error type, th...
	To browse integrity markers
	1 Do one of the following:
	The Browse Integrity Markers dialog box is displayed.
	Figure 11 The Browse Integrity Markers dialog box
	2 To locate an error, select the appropriate integrity marker, and then click the Locate button.
	Munsys zooms to the extent of the spatial object to which the integrity marker refers.

	3 To remove integrity markers from the list and from the drawing, select one or more integrity markers from the list, and then click the Remove button.

	The integrity markers are removed from the drawing and from the list of markers.

	Erasing integrity markers
	With this function, you can erase all the integrity markers. Integrity markers are stored on the INTEG layer.
	To erase integrity markers
	1 Do one of the following:
	The command line prompts you for confirmation to erase all the integrity markers.
	2 Press ENTER to erase the integrity markers.

	The integrity markers are erased.

	Posting cable fiber data to the database
	New or modified cable fiber and cable route data that has passed the integrity check is posted to the database.
	To post cable fiber data to the database
	1 Do one of the following:
	The Database Posting Summary dialog box is displayed.
	Figure 12 The Database Posting Summary dialog box

	This dialog box displays the following:
	2 Click OK to update the database.

	The Database Posting Results dialog box is displayed.
	Figure 13 The Database Posting Results dialog box

	This dialog box displays the following:
	3 Click Close to exit the Database Posting Results dialog box.
	Note Once you have posted objects to the database, you will not be able to undo this function, which will avoid duplicate objects and keep the content of the drawing synchronized with the database.



	Validating object integrity and posting data at the same time
	If you select the Automatically perform Object Integrity option on the Munsys Options dialog box Preferences tab, you can perform an object integrity check and database posting operation at the same time. The following rules will be applied when the ...
	If errors occurred during the object integrity check, you can do one of the following:
	To validate object integrity and post objects at the same time
	1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object Integrity check box in the Database Posting Preferences group.
	2 Choose Capture > Post to Database.

	An object integrity check is run on the all the new or modified objects in the drawing.
	3 If any errors occurred, the following message is displayed:
	Figure 14 Database Posting – Object Integrity Errors

	4 Do one of the following:


	Editing cable fiber object attributes
	The Edit Attributes function is used to edit the attributes of one or more selected cable fiber and cable route spatial objects that belong to the same object type. The current application determines what object types may be selected; for example, if...
	Objects that are selected for editing are locked (if record locking is enabled in the database). Once the objects have been selected and an object type to edit has been specified, the Edit Attributes dialog box is displayed. This dialog box contains ...
	Attribute templates – attributes can be edited using an attribute template. The attributes that will be displayed when an attribute template has been selected will depend on the attributes that have been specified on the template, as well as the fo...
	Editing multiple objects simultaneously – if you select this option, attributes of multiple objects are displayed simultaneously. Where the attributes of all the selected objects are the same, a value is displayed. Where attributes of the various o...
	AutoZoom – this option is only available when the Edit multiple objects simultaneously option is not selected, i.e. when you are going to edit the objects one by one. If the AutoZoom to object option is selected, Munsys will zoom to each object in ...

	The various attributes are displayed on the Edit Attributes dialog box in three columns: Description, Value and Column Name. You can resize the dialog box for easier viewing. Values that may not be edited are unavailable. Attributes are edited in the...
	To edit cable fiber spatial objects
	5 Choose Change > Edit Attributes...
	Select the objects that you want to edit, and then press ENTER. If you selected more than one object belonging to different object types, the Spatial Object Identification dialog box is displayed.
	Figure 15 The Edit Attributes dialog box


	6 Select the single spatial object type to edit, and then click OK.
	The Edit Attributes: Fiber Cable dialog box is displayed.
	Figure 16 The Edit Attributes: Fiber Cable dialog box
	7 If you want to edit the objects using an attribute template, select the appropriate attribute template from the Attribute Template list. If you do not want to make use of an attribute template, select None.
	8 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple objects simultaneously check box.

	Similar values are displayed, while values that differ between objects are displayed as *VARIES*.
	Figure 17 The Edit Attributes dialog box: Edit multiple objects simultaneously
	9 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously check box. Select the AutoZoom to object check box to zoom to the objects one by one and highlight them. The object navigation buttons are used to m...
	10 To edit an attribute, do one of the following:
	11 Click OK to apply the new value(s) to the object(s).
	12 The values are applied to the objects, to be verified with the object integrity check.


	Editing linked table attributes
	This function is used to edit spatial object attributes that exist in linked tables. Linked table attributes are updated directly to the database. The current application determines what object types may be selected; for example, if you are working i...
	The link tables that can be edited using this function must be defined through an attribute template. The applicable attribute template is selected from a list, which is created by filtering attribute templates according to the following characteristics
	Only attribute templates associated with the current spatial object type, being edited are included – the primary table in the attribute template is the same table from which the spatial objects were queried.
	Only attribute templates that contain linked tables are included
	The linked table specified may not be a Munsys spatial table
	The user must have edit privileges to the linked table
	The link column used to describe the relationship with the primary table must reference a true column in the linked table. This may not be an expression.

	Attributes are displayed on the Linked Table Attributes dialog box in three columns: Description, Value and Column Name. You can resize the dialog box for easier viewing. Values that may not be edited are unavailable. Attributes are edited in the Val...
	To edit linked table attributes
	1 Choose Change > Edit Linked Table Attributes...
	2 Select the objects that you want to edit, and then press ENTER.
	If you selected more than one object belonging to different object types, the Spatial
	Object Identification dialog box is displayed.
	Figure 18 The Spatial Object Identification dialog box
	3 Select a single spatial object type to edit, and then click OK.

	The Linked Table Attributes dialog box is displayed.
	4 Select the attribute template that you want to work with from the Attribute Templates Containing Linked Tables list.
	Figure 19 The Select Templates Linked Table Attributes dialog box


	The Description, Value and Column Name columns are populated according to the template that you selected, and the number of records and objects that were selected are displayed.
	Figure 20 The Linked Table Attributes dialog box
	5 Select the AutoZoom to object check box to zoom to each object and highlight it as it becomes the current object.
	6 Use the navigation buttons to move between records and objects.
	7 To insert a new record, click Insert, and then enter the new values in the Value column.
	Figure 21 The Insert Linked Table Attributes dialog box

	8 To delete the record that is currently displayed, click Delete.
	9 Select either the Cable Route Node or Fiber Joint Node which has changed in location.


	Edit Fiber Cable Info
	This function is used to edit Fiber Cable information, update Cable Ref ID, add/remove or update cable notes, change Owner and Diameter values, and updating the Manufacture and Installation Dates. The Fiber Cable Length can be updated, or recalculate...
	The Fiber Cable Type is greyed out and may not be updated. If the Fiber Cable Type requires changing, the Fiber Cable must be deleted and recaptured.
	To edit Fiber Cable
	1 Choose Change > Edit Fiber Cable...
	2 Select the Fiber Cable that you want to edit, and then press ENTER.
	The Fiber Cable Info dialog box is displayed.
	Important You may only select one Fiber Cable at a time.
	Figure 22 Edit Fiber Cable

	3 To edit an attribute, do one of the following:
	4 Click OK to apply the new value(s) to the selected Fiber Cable.
	5 The values are applied to the object and posted directly to the database. No Object or network integrity checks are required.


	Changing cable fiber objects
	To Terminate / UnTerminate a cable fiber object
	When the user navigates to the Terminate/UnTerminate dialog, the Terminate at Node information will be displayed by default to indicate to the user which node is being Terminated. Also there will be a drop-down with the relevant Cable information whi...
	A Fiber Cable will consist of a Tube and within each Tube will be 12 individual Strands starting from 01 Blue to 12 Aqua.
	Based on the type of Fiber Cable being defined by the user, if there is more than one Tube then the naming convention will continue from 12 Aqua incrementally as opposed to restarting from 01 Blue. Equipment can also be added and Connected through to...
	The desired workflow process is outlined below.

	1 Do one of the following:
	The command line prompts you to select a cable route node.
	2 Select the fiber cable node that you want to Terminate / UnTerminate.
	The Terminate Fiber dialog box will appear, requiring the user to enter in information.
	Note If more than one cable terminates at the selected node, the user should select the Cable drop-down box and select the required cable
	Figure 23 Terminate Fiber cable selection when multiple Fiber Cables are terminated
	Figure 24 The Munsys - Terminate Fiber dialog box
	The user will notice when the Terminate Fiber dialog box is opened, then the Node information will be displayed at the top, informing users which Node is being Terminated.
	All Fiber dialogs have the Expand/Collapse All and Check/UnCheck All options which can be access via a Right click on an empty space in any of the Fiber dialogs. This ensures that the user can easily perform any of the above functions effortlessly wh...
	Users can also define the Cable Owner and Strand Tenancy information within this dialog.



	To define the parameters for Terminating a Fiber Room Node:
	1 Select the Fiber Cable from the drop-down list intended to be Terminated.
	2 Tick the relevant Tube to be terminated.
	3 Enter in the Location information as required below:
	Figure 25 Terminate Fiber Location Information

	4 Click on the Terminate button.
	5 Click on the Set button.
	Note Notice that now the information will be populated in the Information sub-section of the Terminate/UnTerminate dialog. If multiple tubes are selected then the user can simultaneously enter in Rack/Cabinet and Enclosure/Sub-Rack, however Tray/Pane...


	Fiber Owner / Strand Tenancy
	We know that a fiber cable comprises of a number of 12 strands, which carry services to the end user. Telecommunications company layout fiber cables and related infrastructure which end up in the properties of the end users. These companies are known...
	A tenant then rents out these fiber strands within the fiber cables, which essentially carry the services to the end user. This information can be captured within the Terminate / UnTerminate dialog box to better reflect the details of the owner of th...
	1 Navigate to Change > Terminate / UnTerminate menu item.
	2 Select a Fiber Room Node.
	3 Select the Cable drop down arrow & select a fiber cable (1).
	4 Select the Cable Owner drop down (2) & select a Fiber Cable Owner from the drop down.
	5 Hit the Set button once done (3).
	The dialog should look something like this:
	Figure 26 Defining fiber owner information

	The user will notice that the cable owner information has been defined.
	Figure 27 Fiber owner information defined

	To set the Strand Tenancy the user should:

	1 Select the Fiber Strands which the Tenancy is to be defined.
	2 Select the Strand Tenancy & select the Strand Tenant from the drop down.
	3 Hit the Set button once done.
	Figure 28 Defining strand tenancy
	The user will notice that the strand tenancy information has been defined.
	Figure 29 Strand tenancy defined



	Mark/UnMark Fiber Strands as Damaged
	There is also an option for the user to Mark the Fiber Cable Strand as Damaged, if the strand has been damaged in which case would not be able to carry a Service. Conversely if the user incorrectly marks the wrong strand as damaged then the user can ...
	Figure 30 Terminate Fiber dialog Mark Damaged/UnMark Damaged

	To Mark a Strand as Damaged then user should:
	1 Click on the strand which is to be marked as Damaged. Multiple strands can be marked as Damaged simultaneously.
	2 Click on the Mark Damaged button.
	Note Notice that the icon should change to reflect the Strand is Damaged. Hence the user would be unable to connect or add a service on that strand.
	To UnMark a Strand as Damaged then the user should:


	1 Click on the strand which is to be Unmarked as Damaged. Multiple strands can be selected to UnMark as Damaged simultaneously.
	2 Click on the UnMark Damaged button.
	The user will then also notice that the icon should change indicating that the strand can now be connected and carry a service.


	Adding Equipment to Connect through to a Strand
	Equipment can also be Connected through to a Strand, to ensure a single Fiber Strand has more channels/equipment attached, essentially indicating more services can be carried on a particular strand, this is also known as a Multiplexer/Splitter functi...
	To initiate this function the user should:
	1 Click on the Edit Equipment button.
	Figure 31 Edit Equipment command in Terminate Fiber dialog

	2 The Manage Equipment at Node dialog should open.
	Figure 32 Manage Equipment at Node
	Note The equipment terminology varies between customers, therefore the system allows for addition, editing and deleting of equipment types to cater for greater flexibility between customers.
	The left side of the dialog refers to Available Equipment which is populated by default, however the user can easily Add/Modify equipment shown in the list.
	The right side of the dialog refers to Equipment at Node, together with the Node number being displayed to keep the user properly orientated which node is being modified. This list modifies equipment from the Available Equipment list on the left hand...
	When the user adds a specific equipment type Mux or Splitter then those channels from the equipment can be connected through to a strand. Single mode channels indicate that either all the transmit or all the receive is connected through to the strand...
	To Edit and Add a New Equipment Type to the List:


	3 Click on Edit within the Available Equipment section of the dialog box.
	Figure 33 Adding Equipment to the List

	4 Click on Add.
	5 The Edit Equipment Detail dialog should be displayed, and the user should fill in the required parameters.
	Figure 34 Edit Equipment Detail dialog

	6 Once all these criteria have been met, then the user can click on OK.
	Notice now the new user defined equipment, should now be displayed in the list. Click on OK.
	Note The End Frequency will be calculated based on the variables ie. Count, Start, Width and Spacing. The system will automatically perform this and can be confirmed by clicking on the Check button.
	Figure 35 Edit Equipment List Dialog
	The user will notice the custom equipment being added to the list within the Available Equipment section of the dialog box.


	7 The user should select the relevant Available Equipment and click on the Add button.
	Figure 36 Manage Equipment at Node dialog
	This should now be displayed on the Equipment at Node on the right side of the dialog box.

	8 Click on OK.
	The Equipment is now added and is ready to be Connected through.
	Figure 37 Available Channels displayed with Green Icon



	Introduction of the Optical Add / Drop Multiplexer (OADM) equipment type
	No fiber application can be complete without the ability to cater for an Optical Add / Drop Multiplexer (OADM) functionality. With this in mind the design catered for instances requiring the OADM functionality and was carefully integrated within the ...
	An OADM essentially allows for the add or drop function where one or more signals can be transferred from an input port to either an output port or add / drop port respectively.
	An OADM enables the user to have an additional service dropped to a drop channel port, added to an add channel port or alternatively passing directly to the output port. In doing so this provides the user with a comprehensive fiber solution with asso...
	For a more detailed explanation, including capture steps for an OADM network setup, a specific document can be made available upon request.

	Equipment added displays in Tree view within Terminate dialog
	When the user has equipment added to a node and accesses the Terminate dialog, then by default the equipment will be displayed and expanded in the tree view. This makes it easy to identify if all channels within the frequency transmitted or received ...
	Figure 38 Equipment displayed in default Tree View

	The colour of the icon next to the frequency band shows the status of the equipment added. If it is red on the main indicator, then all channels are in use however if the main indicator is green, then some channels are still available for connecting ...

	Connecting Channels through to a Strand
	By definition the process of Connecting Channels through to Strands via equipment, initiates the Multiplexer/Splitter functionality. This means that many channel ports can be connected through to a single strand or across multiple strands depending o...
	To Connect an equipment port:
	1 Click on a Channel Port to be Connected through to a Strand.
	2 Click the Strand that the Channel Port is to be connected to.
	3 Once done the user can then click on the Connect button.
	The user can now notice that the icon would change, indicates it is now connected through.
	Figure 39 Terminate Fiber Connect Feature

	Note When the Commit button is clicked then changes are committed against the database and cannot be Reset or rolled-back. Therefore the user should utilize the Commit and Reset buttons with caution.
	The user can then Connect the remainder of the ports of equipment through to the necessary Strands and click on OK when done.

	Note When new Equipment is added then the equipment displays in Green, this indicates that the equipment is available to be Connected to a Strand. When the equipment is Connected to a Strand then it will be displayed in Red which indicates that this ...
	Figure 40 Multiple Channels Connected to Strands
	In this dialog the Commit and OK button perform the same function, however directly clicking on the OK button would save the changes against the database and close the dialog.
	The Commit button would save the session changes against the database but keep the dialog open for further editing.

	Tip To ensure equipment is successfully removed from the node, then the channels need to be disconnected from the relevant strands. If already spliced through, then this would need to be unspliced first before disconnecting within the Terminate dialo...


	Adding Additional Channel Ports to Connect through to a Strand
	When equipment channels are connected through to strands and if the user aims to add an additional port to the equipment channel, then the user can perform this action on an adhoc requirement basis.
	To achieve this the user should:
	1 In the Terminate Fiber dialog, Click on Edit Equipment.
	Figure 41 Editing Equipment in Terminate dialog
	Figure 42 Edit Equipment at Node dialog
	The user must ensure that the main checkbox next to the equipment name must be checked.
	Figure 43 Adding Channel to Connected Equipment


	2 The Edit Equipment at node will appear. Fill in the required fields:
	Figure 44 Edit Node Equipment Dialog

	3 Click on OK.
	Notice this new channel entry should be added to the Channel Details list.
	Note The icons that change between the connected Strands/Equipment is based purely from the naming convention of TX/RX. Hence when the user creates a New Equipment at Node, then it should be mandatory to follow the proper naming convention of having ...
	Figure 45 Edit Node Equipment


	4 Click OK.
	When the user expands the list, all ports including the newly added one will be listed.
	Note The system will not allow the user to Edit or Delete a Channel, whilst it is Connected through to a Strand. The following errors will be returned if attempted:
	Figure 46 Error when attempting to modify a Connected Channel
	Figure 47 Error when attempting to delete a Connected Channel
	Figure 48 New Channel Added to be Connected through to a Strand
	This can also be Connected through to a desired Strand.


	5 Click on OK.
	Once equipment has been Connected through to the Terminated Tube, the user can then Connect Strands and Equipment.
	Note If the user attempts to UnTerminate a Tube, whilst there is Equipment Connected through to the Strands, then the system will display the following error.
	Figure 49 UnTerminating a Tube Error Message



	Placement of Equipment at Fiber Room Nodes
	Once the user has successfully captured a fiber network, then proceeds to deploy equipment at a particular node, and connects through channels of the equipment to desired strands of the fiber cable then the possibility of adding multiple services on ...
	When this is done, the user will notice that the equipment id (EQUIP ID) will appear next to the strand it is connected through to, at the exact node which the equipment is deployed at. However in the case of the Splitter equipment types, if the user...
	To understand this process:
	1 Capture a Cable Route network with associated objects (outlined in CH 4).
	2 Define Fiber Cables (outlined at the beginning of CH5).
	3 Navigate to Change > Terminate and click on the relevant node.
	Figure 50 Node Selection for Terminating
	The Terminate Dialog box will appear.

	4 Select the appropriate cable from the Cable drop-down list.
	Figure 51 Cable Selection
	Once done selecting the cable, all the subsequent strands will appear on the left side of the dialog.

	5 Click on Edit Equipment. Tick on the relevant equipment and click on Add.
	Notice now the equipment selected and ticked will appear within the Equipment at Node part of the dialog box. The user will also find the allocated Equip ID number next to the newly added equipment type.
	Figure 52 Manage Equipment at Node dialog


	6 Click on OK.
	The Equipment and associated Channels will be added to the right hand side of the Terminate dialog.

	7 Expand the Equipment type and click the channels to be Connected through to the relevant strand. Click on the Connected button when done.
	Figure 53 Equipment displayed within the Terminate dialog
	Notice the Channels have been connected through to the desired Strands and the colour would have changed from Green (Available) to Red (Unavailable) for the Connected Channels.
	The user will notice the Equip ID:50 displayed next to the Connected strand ie. 5 Slate (Equip ID: 50). Essentially this indicates that an equipment is placed at that specific node: 120- MH070.
	Figure 54 Connected Equipment within the Terminate dialog

	If the user clicks on the node before or the node after the node that has equipment deployed at, no equipment and equipment id will be displayed.
	Figure 55 Terminate dialog without any equipment displayed

	Note In the case of other Mux or Demux equipment types, these will still be able to be seen on the other end of the spliced cable, including the equipment channel ports and Equip ID. It only has a special instance for the splitter equipment type that...


	Propagation of Fiber Cables
	Data capturing can sometimes consist of repetitive actions which is inevitable to reach a desired outcome. The introduction of the Propagation functionality serves to streamline this process by carrying changes from the start of propagation to the en...
	To mitigate the repetitive action for each fiber cable segment all the way to the end of the cable (which also allows for the possibility of human error) the propagate function can be utilized. In making the fiber application user friendly whilst mai...
	To Propagate a fiber cable:
	1 Commence with the placement of Fiber Room Nodes and FTB as required.
	2 Capture Cable Routes along the designated path.
	3 Capture > Define New Fiber Cables...
	Figure 56 Defined fiber cables

	4 Change > Connect the entire tubes of the both indeed cables for propagation.
	Figure 57 Connection of fiber tubes
	Figure 58 Connected fiber tubes

	5 Replication the above step (Connection of tubes between cables) until the end of the network.
	6 Place the necessary equipment on the start node of the cable intended for propagation, and connect through to the designated fiber strands.
	Figure 59 Connecting equipment channel port to fiber strand

	7 Replicate the Connecting of equipment channel ports to the fiber cable strands.
	Figure 60 Connecting multiple equipment channel ports to fiber strands

	8 Place the necessary services on the start node of the cable intended for propagation, either the fiber strands and/or equipment channel ports.
	The fiber cables should now be propagated and the changes will be taken across to the end of the propagation point.
	The propagation of fiber cables comes with its own set of conditions which were established in line of the business principals and integrity rules thereby preventing the execution of certain actions. Some of the criteria or pre-conditions are outline...
	Figure 61 Marking spliced fiber strand as damaged
	Figure 62 Connecting equipment channel ports to spliced fiber strands
	Figure 63 Disconnecting channels connected to fiber strands of propagated fiber cables
	Figure 64 Disconnecting channels of propagated fiber cables

	To connect / disconnect a cable fiber object
	This function is used for connecting cables and strands, each consisting of its own service which is attached to it.


	1 Do one of the following:
	The command line prompts you to select a cable route node.
	2 Select the fiber cable node that you want to Connect / Disconnect.

	The Connect Fiber dialog box will be displayed.
	Figure 65 Connect Fiber Dialog
	3 Select the specific cables to be connected and press OK. Expand both Cable Tubes to see all available Strands for connection.
	Figure 66 Connect Dialog box

	4 Click on the checkbox next to the Strand/Channel to be Connected from C1 (left side of the dialog box) to C2 (right side of the dialog box).
	5 Click on Connect.
	Figure 67 Connecting Channel and Strand
	As with the Terminate dialog box, there are many actions which are not allowed to prevent a decrement in the data integrity hence have the business rules implemented.
	Figure 68 Displays Connected Channel and Strand

	Notice that the icons would now change to indicate that the strands and equipment has been connected. There is a different represented icon displayed when a Strand is connected as opposed to Equipment.
	To Disconnect Strands or Equipment:

	1 Tick a specific Strand.
	2 Tick a specific Strand or Equipment.
	3 Click on the Disconnect button.
	To Find Connection between Strands/Equipment

	1 Click on the desired Strand or Equipment.
	2 Click on the Find Connection button.
	This should check the corresponding strand/equipment which is Connected.
	The user should note that only one set of desired connections can be done at a time, the user would be unable to execute multiple sets of connections simultaneously. If the user attempts to do this then the following error will be returned:
	Figure 69 Attempting Multiple Connections Simultaneously
	Figure 70 Error Message Displayed

	Note When the Commit button is clicked then changes are committed against the database and cannot be Reset or rolled-back. Therefore the user should utilize the Commit and Reset buttons with caution.



	Connect Dialog Connection Information
	Within the connection dialog when the user splices either strands, channels or strands and channels through a fiber cable, irrespective of the combination then upon clicking on the feature by highlighting, then the connection information will be popu...
	The types of combinations could be:
	An example of a Channel to Strand connection is shown below:
	Figure 71 Connection Information updated dynamically


	Connecting Equipment Channel Ports to Equipment Channel Ports
	In the Connect dialog box if the user attempts to connect equipment channel ports from a cable, to another cable consisting of equipment channel ports connected to a strand then this would not be possible. If attempted, then an error message will be ...
	An example of the error message that will be displayed when an attempt to connect a strand with channels of a particular equipment ID to another strand of a cable with channels of a different equipment ID is displayed below:
	Figure 72 Connection of equipment channel ports to other equipment channel ports


	Cascading fiber equipment Channels
	The addition of equipment channel ports to fiber cable strands allows for the diversity of a host different services along a given fiber network. Along the fiber network in question, the user can connect equipment channel ports to the required strand...
	To Cascade fiber equipment channels:
	1 Placement of Fiber Room Nodes and FTBs.
	2 Capture of Cable Route ducts.
	3 Capture of Fiber Cables.
	Figure 73 Defined fiber cables

	4 Adding of Equipment.
	5 Connecting Channels.
	Figure 74 Connecting equipment channel ports to fiber strands

	6 Connect dialog > Connect spliced channels and strand to Strand.
	Figure 75 Cascading channels and connected strand to fiber strand

	7 The final result of the dialog indicating the cascaded channels will look like the image below.
	Figure 76 Cascaded channels to fiber cable
	If a user disconnects channels from a strand which has a Mux equipment on one end without a Demux on the other end, then the channels being disconnected will disappear from the one end. The system will display a warning message prior to this:
	Figure 77 Disconnecting channels from MUX without a DEMUX

	This is because when a Mux is spliced through it creates the channels within the database tables however a Demux does not therefore requires to be plugged into a Mux.
	Note If the user deletes channel ports from a Mux equipment type, at the start of a fiber network, which has a Demux plugged into it, then the Demux equipment type will automatically be Disconnected when the Mux is deleted.


	Find Connection between Cascaded Equipment Channel Ports
	If the user has cascaded channels and attempts to display connection details between the equipment channel ports without clicking on the commit button then the following error will be displayed:
	Figure 78 Finding connection between cascaded equipment channel ports

	In order for the user to highlight the channel and have the connection information be displayed then the commit button should be clicked first.

	Connecting a connected strand to a MUX
	If the user attempts to connect a strand which has a multiplexer equipment channel ports connected through to a different strand of a cable then the system will display an error. An example of how the error can occur and the meaning behind the logic ...
	1 Define fiber cables.
	Figure 79 Defined fiber cables

	2 Connect MUX equipment channel ports to a strand at Node 1 (Start of cable 1).
	Figure 80 Connect MUX channels to fiber strand

	3 Connect MUX equipment channel ports to a strand at Node 3 (Start of cable 2).
	Figure 81 Connected channels to strand
	Dropdown Cable 1 and Cable 2 on both sides of the dialog box respectively.

	4 CNTRL click Strand 7 Red on Cable 1 (left-hand side of the dialog)
	5 Click the check-box next to 9 Yellow on Cable 2(right-hand side of the dialog).
	6 Click on Connect.
	The following error is returned:
	Figure 82 Error connecting strand to a strand which has a MUX

	To add / remove a cable fiber service
	This function is used to add the services attached to a particular fiber node


	1 Do one of the following:
	The command line prompts you to select a cable route node.

	2 Select the fiber cable node that you want to Add / Remove a Service to / from.
	The Connected Nodes dialog box is displayed.
	Figure 83 The Connected Nodes dialog box


	3 Select the specific node, and press OK.
	The Munsys - Service Fiber dialog box is displayed.
	Figure 84 The Munsys - Service Fiber dialog box


	4 Click on a Strand or Equipment and then specify the criteria for the Service to be added.
	5 Once done the user should click on the Add Service button.
	6 Click OK.
	If the user wishes to Remove a Service, then:

	7 Select the strand from the Cable list to remove, click Remove Service to remove the service.
	8 Click OK to apply.
	The fiber cable connection is deleted as specified.
	Figure 85 Multiple Strands and Channels selected for Adding Services

	Multiple Strands or equipment can be selected at once to Add a Service on simultaneously.


	Extending Fiber Services
	Adding a service to a strand or channel is one of the final desired outcomes of the cable route and fiber application, however can sometimes entail repeating a step within a network. To alleviate unnecessary repetitions the Extend services when Splic...
	To allow for the extension of spliced cables or channels, the following steps should be followed:
	1 Define Fiber Cables.
	Figure 86 Define fiber cabkes

	2 Add Equipment Channel Ports and Connect to Strands on Cable CBL12.
	Figure 87 Connecting equipment channel ports to fiber strands

	3 Add Services to the Strand and Channel on Cable CBL12.
	Figure 88 Adding Services on connected channels

	4 Navigate to the connect / disconnect dialog box.
	5 Select the strand and channel with services on CBL12.
	6 Connect to a strand on Cable CBL13 - 9 Yellow.
	Figure 89 Connected strand and channels containing services to strand
	The user will notice now that the service from the strand and channel from Cable CBL12 has been extended to the strand on Cable CBL13. When services have been extended, a change on either side will dynamically update the corresponding record / servic...
	This also works from Strand to Strand (excluding channels).
	This functionality however does not cater for the extension of services between cables that have services attached to it on either end. Hence the system will flag an error as outlined below:
	Figure 90 Services on both ends returns an error message



	Manage equipment at node
	This function initiates the Manage Equipment dialog, which is the same dialog which is accessed from the Cable Fiber application: Change > Terminate > Edit Equipment. This now enables the user to access this dialog as a main menu item, without having...
	Figure 91 Manage Equipment menu item

	To reroute fiber cable
	This function is used to reroute a damaged fiber cables to new fiber cables.

	1 Do one of the following:
	The command line prompts you to select a cable route node.
	To successfully ReRoute a Fiber cable:

	2 Select the desired Fiber Cable which needs to be ReRouted.
	Figure 92 Select the Fiber Cable to be designated
	Note The user will notice that once the fiber cable is selected then automatically all other fiber cables will be erased from the drawing and will have to be re-queried out if required.

	3 Select the Cable Route to ReRoute the Fiber Cable within.
	Figure 93 Select the Cable Route to ReRoute Fiber cable into

	4 The system will prompt the user if done selecting the Cable Route Yes/No.
	Figure 94 Complete Selecting Cable Route

	5 Click YES or alternatively press ENTER.
	Figure 95 Cable Route Selected
	The user should notice that the Fiber Cable will be ReRouted to the designated Cable Route.
	Figure 96 Fiber Cable has been successfully ReRouted

	Note If a fiber cable is Re-Routed, the user will not be able to UNDO the action, as the function will be no longer to the user in that session. The user will need to re-route the cable again if it was incorrectly done the first time around.



	Break Cable Route (In Use)
	When the business is required to make provisions for the extension of an existing fiber network, then users must meet the necessary conditions to allow for the integration new networks. One of the most basic yet important conditions is the cable rout...
	To break an In Use Cable Route:
	1 Navigate to Change > Break Cable Route (In Use).
	Users should ensure that an infrastructure is placed in a decent proximity to associate the soon to be placed Fiber Joint node with.
	A warning message will be displayed, the user should read it and press OK.

	2 Select the cable route segment, and then click on it to select it for breaking.
	3 Specify a break point and click at a desired point.
	Tip Type “nea” to pick an accurate point, and press ENTER to pick a point.
	The user will now notice that a fiber joint node has been inserted in the break location.


	4 Select the infrastructure to link to the fiber joint node.
	The broken cable route segment colour will be displayed in green indicating it is a new object and should have its integrity re-checked within the Cable Route Application.
	The In Use cable route segment has now been broken, has a fiber joint node inserted within the break point and has been associated with an infrastructure.

	Breaking Fiber Cables
	During the data collection process it is sometimes difficult to assume areas which will require the fiber network be extended. As the request to switch over to fiber becomes ever-increasing, and cannot easily be catered for during the initial develop...
	The Break fiber cable feature simply allows the user to break a fiber cable at a desired intermediate node (Fiber Room Node or Fiber Joint Node) whilst maintaining the integrity of the network, retaining services etc. This function dynamically update...
	To break a fiber cable:
	1 Define Fiber Cables.
	Figure 97 Defined Fiber Cables

	2 Navigate to Change > Break Fiber Cable
	A warning message will be displayed, which the user should acknowledge by pressing OK.

	3 Select the fiber cable to be broken.
	Figure 98 Select fiber cable to break

	4 Select the break point (node).
	Figure 99 Select break node

	5 Prompt to Splice Strands Yes or No.
	Figure 100 Prompt to splice strands
	The user will notice that the fiber cable has been broken into the relevant segments.
	Information such as the Start and End nodes will be updated as per the fiber cable extent.
	Figure 101 Newly broken fiber cable segment



	Modifying Cable Routes which are In Use
	You can insert, move or remove vertices on existing Cable Routes which are set to be In Use by using the standard Object > Edit MunLine commands to Insert Vertex, Move Vertex or Remove Vertex.
	When modifying any vertex on an existing Cable Route, the underlying Fiber Cables and Paths are updated to use the same geometry as the Cable Route. An Oracle trigger updates the Fiber Cables and Paths geometry whenever any geometry INSERT or DELETE ...
	To Insert a Vertex on a Cable Route:
	1 Query the Cable Route to be modified into the drawing.
	2 Select Object > Edit MunLine > Insert Vertex where you will be prompted to select the object to edit. Select the Cable Route object.
	Figure 102 Select MunLine object to edit - Select the Cable Route

	3 Select the segment for inserted point to be as close as possible to where the new segment is to be inserted.
	Figure 103 Select segment for inserted point

	4 Specify the position for new point by dragging the crosshair to the desired location.
	Figure 104 Select position for new point

	5 On completion of the selection, a new vertex will be inserted.
	Figure 105 New vertex is inserted

	6 More than one vertex can be inserted using the same process.
	Figure 106 More than one vertex can be inserted

	7 Complete the Object and Network Integrity checks before posting the changes to the database.
	8 If you query the Fiber Cables for the same Cable Route, you will see that it has been updated with the same geometry as the modified Cable Route
	Figure 107 Fiber Cable has same geometry as modified Cable Route
	To move a vertex on a Cable Route:

	1 Query the Cable Route into the drawing.
	2 Choose Object > Edit MunLine > Move Vertex
	3 Select the appropriate object.
	4 Specify a point on the vertex that you want to move.
	5 Specify the point where you want to move the vertex to.
	The vertex is moved to the point specified.
	Tip AutoCAD grips can also be used to move a vertex. Grips are only available on locked objects.
	To remove a vertex on a Cable Route:


	1 Query the Cable Route into the drawing.
	2 Choose Object > Edit MunLine > Remove Vertex
	3 Select the appropriate object.
	4 Select the vertex that you want to remove.
	Note A vertex can only be removed from a segment with more than two vertices.


	Changing cable fiber notes
	With this function, you can change the text of an existing cable route note.
	To change a cable fiber note
	1 Choose Change> Change Cable Fiber Note...
	The command line prompts you to select a cable fiber note.
	2 Select the cable fiber note that you want to change.

	The Cable Fiber Note text box is displayed.
	Figure 108 The Cable Fiber Note text box
	3 Change the note as required, and then click OK.

	The cable fiber note is changed as specified.

	Adding comments
	This function is used to assign descriptive comments to one or more selected objects.
	To add comments
	1 Choose Change > Add Comment...
	The command line prompts you to select a cable fiber object.
	2 Select the cable fiber object(s) that you want to add a comment to.

	The Cable Fiber Comment text box is displayed.
	Figure 109 The Cable Fiber Comment text box
	3 In the text box, add the comment, and then click OK.

	The comment is assigned to the selected object(s).


	Edit fiber cable duct info
	The Edit fiber cable duct info option enables the user to change/alter the cable route duct in which the Fiber Cable runs within. On the Edit Cable Duct Info dialog box which is launched the user is able to see the current duct in which the fiber cab...
	To edit fiber cable duct info
	1 Choose Change > Edit Fiber Cable Duct Info.
	2 Select the Fiber Cable > press ENTER to open the dialog box.
	Figure 110 Dialog showing in which duct the Fiber cable is located
	Tip The current duct in which the fiber cable runs within will be indicated with a red dot.

	3 Select the desired duct that the cable should run in and press OK.
	4 The fiber cable duct should now be changed.

	Delete Fiber Cable Duct Info
	The Delete fiber duct info option enables the user to delete the cable route duct info in which the fiber cable is placed. Once this fiber cable duct info is deleted it would be a basic duct that the fiber cable resides within (without specifications...
	To delete fiber cable duct info
	1 Choose Change > Delete Fiber Cable Duct Info.
	2 Select the Fiber Cable > press ENTER.
	3 The Fiber Cable Duct Info should now be removed. Deleting and undeleting cable fiber objects
	With Munsys Cable Fiber, existing cable fiber objects can be deleted from the database. Multiple objects can be selected for deletion. Cable fiber objects that form part of a redundant network have to be deleted. Deleted cable fiber objects are moved...
	To delete fiber cables

	1 Choose Change > Delete Fiber Cable.
	The command line prompts you to select the objects to be deleted.
	Note If a fiber cable with any services, paths, connected strands, or connected equipment is selected for deletion you will receive an error indicating to remove the services, paths, and connected strands from the fiber cable before the fiber cable c...

	The AutoCAD Message box is displayed.
	Figure 111 The AutoCAD Message box
	2 Select the fiber cable that you want to delete.

	The Fiber Network dialog box is displayed
	Figure 112 The Fiber Network dialog box
	3 Press YES to delete the selected fiber cable.

	The fiber cable is permanently deleted from the database.
	Note When a fiber cable is deleted, this would be removed from within the database immediately, thereby making the UNDO function obsolete. The user would then be unable to UNDO the deletion of that specific cable.
	To delete cable fiber objects

	1 Choose Change > Delete Fiber Cable Objects.

	The command line prompts you to select the objects to be deleted.
	2 Select the cable fiber objects that you want to delete.

	The command line indicates how many cable fiber objects you have selected, and how many have been filtered out.
	3 Press ENTER to delete the selected cable fiber objects.

	The cable fiber objects are flagged for deletion and moved to the DELETED layer. These changes will be applied to the database once its posted.
	To undelete cable fiber objects
	1 Choose Change > Undelete Fiber Cable Objects.

	The objects that you have deleted will be displayed in the drawing, and the command line prompts you to select objects to undeleted.
	2 Select the cable fiber objects that you want to restore.

	The Delete flag is no longer set for the selected objects. In the event of spatial or attribute changes before the objects were flagged for deletion, these changes are applied.

	Cable fiber network quality reporting
	The Network Quality Report function on the Extras menu is used to validate the quality of the entire network. The network quality report complements the network integrity check. Although it is recommended that a network integrity check is always done...
	Specific columns in each of the spatial tables are used to build up the topology of the network, for example the start and end nodes of a cable route. The network quality report will validate these values based on cable route-specific rules.
	Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS table, together with the appropriate error message related to each spatial object where an error occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query,...
	If a single spatial object contained more than one error, a record will be stored for each error that occurred within that object. You can also have the errors populated to the COMMENTS column of the object(s) in which errors occurred, if you do not ...
	To validate cable fiber network quality
	1 Choose Extras > Network Quality Report...
	The command line displays the message: Generating network quality report
	2 If errors were found in the network, the following message is displayed:
	Figure 113 Network Quality errors found

	3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column updated.

	The Save Results Summary As dialog box is displayed.
	4 Save the report to a location of your choice.
	The report is opened in Windows Notepad, and contains the following information:
	The number of objects that were checked
	The number of objects found that violated the network rules
	The number of endpoints that were found in the network
	The number of errors that were found, grouped by error type
	Figure 114 A cable fiber and cable route network quality report





	Generating cable fiber data status reports
	Data status reports provide summarized information about spatial objects that are currently stored in the database. Once a report has been generated, it is saved to a comma delimited file, and then displayed in Notepad for easy viewing. The following...
	a summary of all the cable route objects in the database
	a summary of the total length and number of cable routes, by type and category
	a summary of the umber of cable route nodes by node type

	To generate a cable fiber data status report
	1 Choose Extras > Data Status Report...
	The Data Status Report dialog box is displayed, showing a list of all the reports that can be generated.
	Figure 115 The Data Status Report dialog box
	2 Select one or more reports to generate from the list, and then click OK.
	3 Save the file to a location of your choice.

	The file is opened in Windows Notepad.
	Figure 116 Data status report for service connections


	Converting AutoCAD entities to cable fiber objects
	With Munsys, you can convert selected AutoCAD entities to Munsys Cable Fiber objects. Texts can be converted to a cable fiber notes.
	Although some basic attributes are assigned as part of the conversion process, you will need to assign attributes to the objects created with the conversion process.
	To convert text to cable fiber notes
	With this function, you can convert AutoCAD text entities to cable fiber notes.

	1 Choose Extras > Convert Text to Cable Fiber Note.
	2 Select the objects that you want to convert, and then press ENTER.
	The entities are converted to the cable route objects, and the drawing is updated accordingly.
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