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 Introducing the Munsys Water User Manual

Munsys Water is used to capture and maintain water networks. It is a user-friendly, easy to use 
geographic information management tool, which does not require GIS expertise to capture 
and manipulate data.

Munsys Water forms part of the Munsys product range, which comprises the following 
applications:

 Munsys Cadastral

 Munsys Cable Route

 Munsys Cable Fiber

 Munsys Drainage

 Munsys Electricity

 Munsys Roads

 Munsys Sewer

 Munsys Water

 Munsys Map Books

 Munsys Spatial Data Manager

 Munsys Management Console

 Munsys Query

 Munsys Linage

 Munsys Scheduled Tasks
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About this manual
The Munsys Water User Manual enables users to easily find their way around Munsys Water, 
and provides a conceptual overview of the functionality used in Munsys Water. For the purpose 
of this manual, we assume that you are familiar with:

 The business rules of the application

 AutoCAD Map

 Common GIS terminology

What’s in this manual
The Munsys Water User Manual consists of the following chapters:

 Chapter 1 – Introducing the Munsys Water User Manual, gives an overview of this manual, 
and provides links to additional reading material.

 Chapter 2 – Getting acquainted with Munsys Water, gives an overview of Munsys Water 
and its various components.

 Chapter 3 – Querying water data from the database, describes how to retrieve water data 
from the database.

 Chapter 4 – Creating water data, shows the user how to capture a water network, add 
additional water objects, and post water data to the database.

 Chapter 5 – Maintaining water data, describes how to maintain existing water data.

Additional reading material
Before you start using this manual, we suggest that you first read the 
Munsys Concepts User Manual, which contains the following information:

 the generic functionality of the various Munsys applications

 the generic query functionality that is used to query spatial data from the Oracle® database, 
and how to structure a query through query settings and GSC settings using the Munsys 
Query Palette

 how to view spatial data using the Munsys Info Palette

 how to work with Munsys Objects

 extras such as annotation, reporting and legend options.
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Conventions in this manual
The following table lists the typographical conventions used in this manual.

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

 general issues, select Help from the Munsys menu bar.

 an operation in progress, click the Help button on the dialog box.

 the latest support options, visit http://www.openspatial.com

Text element Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial

Menu paths choose Query > Clear Basemap.

Hypertext links to applicable sections in 
the document/the Web

....see Appendix A

Text displayed/typed on the 
command line

Munsys Water

Dialog box/screen names The Water Settings dialog box

Application functions The Integrity Check function

http://www.munsys.com
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 Chapter 2
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 Getting acquainted with Munsys Water

About Munsys Water
Munsys Water is designed to capture and maintain water networks. A water reticulation 
network consists of a series of water pipes that function on pressure and form a circular 
network. Munsys Water caters for potable, reclaimed, raw and abandoned categories.

Potable (treated) water is distributed through the water network for human consumption. 
Reclaimed (recovered water) is waste water (sewer) that has been processed at a sewer plant to 
acceptable quality for irrigation purposes. Raw or untreated water may come from 
groundwater sources or surface water such as lakes and rivers. Although untreated water may 
offer a high quality that could be consumed without disinfection, it almost always goes 
through the disinfectant residual. Utility departments also need to keep records of abandoned 
water networks and equipment because it might cause a health risk (for example, it may 
contain materials like asbestos). Expensive equipment like valves and pumps are normally 
removed, leaving only the pipe abandoned. 

The Munsys Water toolbars and menus enable fast and efficient capturing and maintaining of 
a water network. Munsys Water has built-in rules to ensure that the water network data is 
maintained to engineering standards before it is posted to the database.
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Launching Munsys and Munsys Water
To launch Munsys, do one of the following:

1 Double-click the Munsys Applications 14.2 icon on the Windows desktop.

2 Choose Start > Programs > Munsys 14.2 > Munsys Applications 14.2

Connecting to the Oracle database
Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial or locator 
technology is that spatial and attribute data are captured and managed in a single database. This 
reduces processing overheads and eliminates the complexity of coordinating and synchronizing 
different sets of data.

Important You have to be connected to the Oracle database before you can start working with Munsys 
Water. If you try to launch any application without being connected to the database, you will be prompted 
to connect to the database first.

To connect to the Oracle database

1 Do one of the following:

 Choose File > Database > Connect....

 Click the Connect to Database button on the Munsys standard toolbar.
The Connect to Database dialog box is displayed.

Figure 1 The Connect to Database dialog box

2 In the User Name field, enter your user name.

3 In the Password field, enter your password.

4 In the Schema field, enter the schema name.

5 In the Database field, enter the database name.



Getting acquainted with Munsys Water 6 








6 Click OK.

Note The database administrator will inform you which user name, password, schema name, and database name to 
use.

To launch Munsys Water

When you launch Munsys for the first time, the configured base map automatically loads. 
When you launch Munsys Water, the Munsys Water functions are loaded on the menu bar and 
toolbars. 

1 To launch Munsys Water, do one of the following:

 Choose File > Munsys Applications.

 Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Figure 2 The Available Applications dialog box

2 From the list of available applications, select Water, and then click OK.

The Munsys Water functions are displayed on the menus and toolbars.
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The Munsys Water interface
The Munsys Water interface consists of the following:

Figure 3 The Munsys Water interface

Munsys menu bar – contains the Munsys and AutoCAD Map menus. Munsys menus are 
defined by a menu file, which automatically loads when the Munsys application is launched. 
AutoCAD Map menus are also defined by a menu file, which the user can customize.

Standard toolbar – contains frequently used AutoCAD Map buttons, standard Microsoft® 
buttons and Munsys buttons for connecting to the database and launching the various Munsys 
applications.

AutoCAD Map drawing area – this area is used to display Munsys data that is extracted from 
the database and AutoCAD Map drawings.

AutoCAD Map command line – displays prompts and messages.

AutoCAD Map status bar – displays information/drawing aids.

Munsys main toolbar – contains frequently used Munsys functions.
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Munsys Integrity toolbar – contains the Integrity Check and Post to Database functions.

Table 4 The Munsys Water Integrity Toolbar

Munsys Water toolbars – Munsys Water has eight application-specific toolbars that are 
displayed when activated. To display the Water toolbars, right-click in the grey area on the right-
hand side of the Munsys Standard toolbar. 

Point to MUNWMS, and then select the toolbars that you want displayed one by one. The 
toolbars are displayed in the drawing area.

Use this button When you want to...

...check water object integrity

...check water network integrity

...browse integrity markers

...erase integrity markers

...post data to the database
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 The Munsys Water Capture toolbar contains the following buttons:

Table 5 The Munsys Water Capture toolbar

 The Munsys Water Change toolbar contains the following buttons:

Use this button When you want to...

...specify water capture settings.

...draw an offset water pipe.

...draw a freehand water pipe.

...place a water symbol.

...place a water pipe label.

...place a water note.

...place dimension arrows.

Use this button When you want to...

...extend a water pipe to a boundary.

...extend a water pipe by distance.

...extend and break a water pipe.

...break a water pipe.

...change a water pipe.

...fillet water pipes.

...trim a water pipe.

...move a node.

...rotate a node.

...snap a node to the endpoint of a pipe.

...snap a node to the endpoint of a pipe, breaking the pipe.
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Table 6 The Munsys Water Change toolbar

 The Munsys Water Flow toolbar contains the following buttons:

Table 7 The Munsys Water Flow toolbar

 The Place Node toolbar is used to place water nodes at the endpoints of water pipes. 

 The Insert Node toolbar is used to insert water nodes anywhere on water pipes. 

 The Place Valve toolbar is used to place valves at the endpoints of water pipes. 

 The Insert Valve toolbar is used to insert valves anywhere on water pipes. 

 The Munsys Water Place SC toolbar contains the following buttons:

Table 8 The Munsys Water Place SC toolbar

...change a water note.

Use this button When you want to...

...show water pipe direction.

...change water pipe direction.

...clear direction arrows.

Use this button When you want to...

...place a straight service connection.

...place a branch service connection.

...place a double branch service connection.

...place a freehand service connection.

Use this button When you want to...
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About water objects
Water pipes, nodes and service connections are used to build water networks.

The initial connection from a parcel to the rest of the water network is called a service 
connection. Water pipes are placed along parcel boundaries. Water pipe diameter is the largest 
at the source of water reticulation, becoming smaller as the water network develops to the 
parcels.

Water relies on pressure to flow through the pipes. Networks are classified according to the 
following water categories:

 Potable – also known as treated water. Potable water is distributed through the water 
network for human consumption.

 Reclaimed – also known as recovered or recycled water. Waste water (sewer) is processed at 
a sewer plant to acceptable quality for irrigation purposes. This water is called reclaimed 
water.

 Raw – also known as untreated water. Raw water may come from groundwater sources or 
surface water such as lakes and rivers. Although untreated water may offer a high quality 
that could be consumed without disinfection, it almost always goes through the disinfectant 
residual.

 Abandoned – equipment may no longer be in use (abandoned). Utility departments need 
to keep records of abandoned equipment because it might cause a health risk (for example, 
it may contain materials like asbestos). Expensive equipment like valves and pumps are 
normally removed, leaving only the pipe abandoned.

Water pipes are placed along cadastral boundaries.

Water nodes indicate where water pipes are connected, intersect or terminate. 

Valves maintain the water flow in the water network. 

Water notes are used to supply additional information on plans and drawings.

Dimensions also supply additional information in terms of the location of a water object 
relative to a parcel boundary.

Labels contain dynamic text information that represent a specified column in the database.

Residential water pipes are captured to indicate the water pipes running from service 
connections to buildings. Residential water does not form part of the network connectivity.

Water symbols represent additional annotation in the form of a symbol, and do not form part 
of the water network.

Water Zones are captured to obtain an overview of the network layout.
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Figure 9 A water network
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 Querying water data from the database

Introduction
This chapter describes how to query water data from the database using the Query menu. 
With the exception of residential water, water data is queried from the database by category, 
and according to the current GSC. Water categories are based on the quality of water 
transported by the equipment and the usability of the equipment. Should you need to query 
only a specific water object type or define a customized query, you can use the Munsys Query 
Palette. The Query Palette is discussed in the Munsys Concepts User Manual. You can also 
query a map page grid. Water data that is queried includes the retrieval of the spatial and 
attribute data. 
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Querying a map page grid
This query retrieves a map page grid from the database. The map page grid can be used to locate 
services based on the map page number, and is represented by a layout of polygons similar to 
the sheet layout used in Munsys Map Books. The map page grid can be modified by using the 
Object > Generate MunPolygons and Object > Edit MunPolygon menu items to capture and 
change the map page grid objects.

To query a map page grid
 Choose Query > Map Page Grid.

The map page grid is retrieved to the extents of the database.

Figure 1 Querying a map page grid

A map page grid is que-
ried onto the WATMAP-
PAGE layer
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Querying water objects by category
This group of queries retrieves water objects (pipes, nodes and service connections) from the 
database according to their water category. The water objects are queried onto their respective 
layers, for example WATPIPE_POTABLE, or WATNODE_RAW.

To query all water categories
 Choose Query > Water Category > All.

The command line indicates how many water objects (dimensions, nodes, notes, pipes, 
service connections, labels and dimension notes) in all the water categories were retrieved 
from the database.

Querying water objects by single category
 Do one of the following:
 Choose Query > Water Category > Potable.

 Choose Query > Water Category > Reclaimed.

 Choose Query > Water Category > Raw.

 Choose Query > Water Category > Abandoned.

The objects are retrieved from the database, and the command line indicates how many 
water objects (dimensions, nodes, notes, pipes, service connections, labels and dimension 
notes) in the category that you selected were retrieved from the database.

Figure 2 Querying water objects from all categories
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Querying water zones
Water zones provide an overview of the water network layout, and are queried from the database 
according to the various water categories, and according to the current GSC. Water zones are 
retrieved onto the WATZONE_CATEGORY layer, for example a water zone in the potable 
category layer is retrieved on the WATZONE_POTABLE layer.

To query water zones (all categories)
 Choose Query > Water Zones > All.

The command line indicated how many water zones in all the water categories were 
retrieved from the database.

To query water zones by category
 Do one of the following:
 Choose Query > Water Zones > Potable.

 Choose Query > Water Zones > Reclaimed.

 Choose Query > Water Zones > Raw.

 Choose Query > Water Zones > Abandoned.

The command line indicated how many water zones in the category that you selected were 
retrieved from the database.

Figure 3 Querying water zones

Water zones are retrieved onto the WAT-
ZONE_CATEGORY layer.
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Querying residential water
This query retrieves all the residential water pipes from the database according to the current 
GSC. Residential water pipes are queried onto the WATRESPIPE layer. Residential water pipes 
do not form part of the water network.

To query residential water
 Choose Query > Residential Water.

The command line indicates how many residential water pipes were retrieved from the 
database.

Figure 4 Querying residential water

water pipe

service connection

residential water 
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 Creating water data

Capturing water data
When you start to capture a water network, you will first need to query the cadastral data from 
the database to make certain that the water objects locate geographically correct. Existing water 
objects should also be queried to determine the relationship between existing and new water 
objects. This will prevent data duplication.

All water objects, with the exception of residential water pipes, have a category assigned as part 
of the capture or convert process. The object is moved to the correct layer according to the 
water category. The water category is set on the Capture Settings dialog box before the capture 
process is started. Default layer names are used for each object type per water category. For 
example, a water pipe of the Potable category will be captured on the WATPIPE_POTABLE 
layer. When nodes, service connections, dimensions and labels are captured, they are assigned 
the water category of the associated water pipe.

Water pipes are the first water objects to capture, as they are usually aligned with existing 
cadastral boundaries. Water nodes are placed next. At every intersection of two or more pipes, 
a junction is placed to connect the pipes. If a water pipe does not loop back onto another pipe, 
the network is closed off with an end cap.

Next, service connections are placed. Service connections are the link between the reticulation 
network and the water meter on a parcel. In some cases a branch service connection, which 
connects two parcels to a reticulation simultaneously, is placed.

Residential water pipes show the water supply from service connections to buildings.
Water zones represent different parts of the water network. Water zones are captured as 
polygons and do not affect connectivity; therefore the order of capture for these objects is 
irrelevant.

Once you have placed all the water objects that you need to complete the water network, you 
are ready to run the integrity check, and to post the water data to the database.
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Water capture settings
Each Munsys application has its own default capture settings that are set by the GIS 
administrator in the Munsys Management Console. 

In Munsys Water, default settings are available for:

 dimensions – dimension note height

 file – the drawing directory

 general – construction color, include network in object integrity, database extents display 
resolution, integrity circle size, tag and symbol scale and rotation if coordinate 
transformation is done, snap tolerance, tag angle, font, height and justification, and water 
category

 integrity – short objects, water pipe, node, service connection and search tolerance

 nodes – water node scale

 notes – note tag height

 symbols – water symbol scale

 service connections – length, branch offset, offset distance

 water pipes – label height, diameter, material, type, offset distance from cadastral 
boundaries

 water zones – zone tag height

You can change the current settings on the Water Settings dialog box to speed up the capture 
process. Capture settings only apply to new water objects, and if you change the default settings, 
the changes are only valid for the current session.

Settings are changed by highlighting the current value, and then:

 entering a new value

 selecting the new value from a drop-down list

The user cannot change all of the settings. Some settings may only be changed by the GIS 
administrator to enforce consistency and integrity on a higher level. Settings that cannot be 
changed are “greyed out” on the Capture Settings dialog box.

Tip A short description of a value displays when it is highlighted.
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To specify water capture settings

1 Do one of the following:

 Choose Capture > Water Settings...

 Click the Water Settings... button on the Munsys Water Capture toolbar.

2 The Water Settings dialog box is displayed, showing the default water capture settings.

Figure 1 The Water Settings dialog 

3 To change a value, do one of the following:

 Highlight the current value, and then enter a new value.
 Highlight the current value, and then choose the new value from the drop-down list.

4 Click OK to apply the new settings.

The settings will apply until you change them again, or until the current session is terminated.

Some values are changed by 
selecting a value from a drop-
down list. 

Some values are changed 
by manually entering a 
new value.
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Capturing water pipes
Water pipes are the first water objects that are captured and are normally aligned with parcels; 
therefore parcels need to be queried before any water data is captured. 

Duplication of water objects can be avoided by querying all the existing water objects from the 
database before you start capturing the water network. Pipes are broken at intersections. Water 
pipe diameter is the smallest at the service connection and becomes larger to accommodate the 
flow. Water pipe diameter can be changed on the following conditions:

 at an intersection of water pipes

 at a junction point

 at a water node, such as a valve, etc.

Drawing offset water pipes
Offset water pipes are drawn by either specifying multiple points along a boundary (for example 
parcel or municipality boundaries), specifying the offset side, and then specifying the offset 
distance.

To draw an offset water pipe

1 Do one of the following:

 Choose Capture > Draw Offset Pipe.

 Click the Draw Offset Pipe button on the Munsys Water Capture toolbar.

The command line prompts you to specify points, or to select a segment to offset the pipe 
from.

2 To draw a pipe by specifying points, do the following:

 Specify the first point, and then specify next point for the water pipe or 
[Arc/Halfwidth/Length/Undo/Width].
The Arc option allows you to continue capturing offset water pipes as a series of arcs until you 
select a different option from the polyline linear list
[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the pipe.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.
The command line displays a message confirming that the pipe was created successfully.

3 To draw a pipe by selecting segments, do the following:

 On the command line, type O, and then press ENTER.

 Select a segment to offset the pipe from.

 Specify a point on the side to offset the pipe.
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 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.

 Continue selecting segments until all the required segments have been selected, and then press 
ENTER.

 Press ENTER to confirm that you have completed the segment selection.
The command line displays a message confirming that the pipe was created successfully.

Figure 2 Offset water pipe drawn by selecting offset segments

Drawing freehand water pipes
Freehand water pipes are drawn by selecting points in the drawing, or by entering coordinates 
on the command line. The command line prompts you for endpoints, allowing a sequence of 
pipes to be constructed. Water pipes are captured on their appropriate layers, to be verified 
when the integrity check is run.

To draw a freehand water pipe

1 Do one of the following:

 Choose Capture > Draw Freehand Pipe.

 Click the Draw Freehand Pipe button on the Munsys Water Capture toolbar.

2 Specify the first point for the pipe.

3 Specify the next points for the pipe, and press ENTER when you have specified all the points.

The command line displays a message confirming that the pipe was created successfully.

Note After capturing water pipes, you need to clean up the pipes, for example close all the gaps.

select offset segments

water pipe
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Figure 3 A freehand water pipe

freehand water pipe



Creating water data 24 








Showing pipe direction
When you have captured and edited all the water pipes, you have to check the pipe direction to 
verify that it is correct. This can be done for both new and existing water pipes.

To show pipe direction

1 Do one of the following:

 Choose Capture > Show Pipe Direction.

 Click the Show Pipe Direction button on the Munsys Water Flow toolbar.

2 Select the appropriate water pipes, and then press ENTER.

A direction arrow on each selected pipe indicates the pipe direction, as shown in the following 
figure:

Figure 4 Showing water pipe direction
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To change pipe direction
This function is used to reverse the direction of water pipes. This enables users to construct the 
network without taking direction into account. Once the construction is complete, the pipe 
direction can be changed easily.

1 Do one of the following:

 Choose Capture > Change Pipe Direction.

 Click the Change Pipe Direction button on the Munsys Water Flow toolbar.

2 Select the water pipes of which you want to change the direction, and then press ENTER.

The direction is reversed automatically.
Important The integrity check does not verify pipe direction; therefore it is very important to make 
certain that pipe directions are correct.

To clear direction arrows
When you are satisfied that the direction of all the water pipes is correct, the direction arrows 
can be cleared from the drawing.

Do one of the following:

 Choose Capture > Clear Direction Arrows.

 Click the Clear Direction Arrows button on the Munsys Water Flow toolbar.

The direction arrows are removed from the drawing.
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Capturing water nodes
When capturing a water network, water nodes are placed once the pipes have been captured and 
cleaned, and the direction has been verified and corrected where necessary. Nodes can be placed 
at the end of water pipes (endpoint) or placed anywhere on the pipe (nearest), without breaking 
the underlying pipe. You can also insert nodes into water pipes, breaking the underlying pipe. 
Water nodes are captured on the WATNODE_CATEGORY layer (for example, a hydrant of 
the Potable category will be placed on the WATNODE_POTABLE layer), to be verified when 
the integrity check is run.

Placing endpoint water nodes
Endpoint nodes are placed at the end point of a water pipe, closest to the point where it was 
selected. The Munsys Water Place Node toolbar contains the functions that are used to place 
endpoint nodes.

To place an endpoint water node

1 Do one of the following:

 Choose Capture > Place Endpoint  Node > Node Name.

 Click the appropriate button on the Munsys Water Place Node toolbar.

Figure 5 The Munsys Water Place Node toolbar

2 Select a point close to the endpoint on the water pipe where you want to place the node.

The appropriate symbol is placed at the endpoint of the water pipe.
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Inserting nearest nodes
With this function, you can insert a node on any selected point on a water pipe. The underlying 
pipe is broken, and the node is captured on its appropriate layer, to be verified when the 
integrity check is run. The Munsys Water Insert Node toolbar contains the functions that are 
used to insert nearest nodes.

To insert a nearest water node

1 Do one the following:

 Choose Capture > Insert Nearest Node > Node Name.

 Click the appropriate button on the Munsys Water Insert Node toolbar.

Figure 6 The Munsys Water Insert Node toolbar 

2 Select a point on the water pipe where you want to insert the node.

The underlying pipe is broken, and the appropriate symbol is placed on the water pipe.

Note The original water pipe selected is flagged to be deleted from the database when changes are 
posted. Two new water pipes will be created to replace the original pipe. All the attributes of 
the original pipe are copied to the two new pipes, except for the GID and PIPE_ID columns.

Figure 7 Capturing water nodes
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Capturing valves
In a water network, valves control water flow. Valves are placed either at the endpoint of a water 
pipe, or inserted anywhere at a selected point on a pipe. The pipe is always broken at the point 
where a valve is inserted. All valve angles are aligned with the pipes. Valves are captured on the 
WATNODE_CATEGORY layer (for example, a butterfly valve of the Potable category will be 
placed on the WATNODE_POTABLE layer), to be verified when the integrity check is run.

Placing endpoint valves
Endpoint valves are placed at the endpoint of a water pipe. The Munsys Water Place Valve 
toolbar contains the functions that are used to place endpoint water valves.

To place an endpoint valve

1 To place an endpoint valve, do one of the following:

 Choose Capture > Place Endpoint Valve > Valve Name.

 Click the appropriate button on the Munsys Water Place Valve toolbar.

Figure 8 The Munsys Water Place Valve toolbar 

2 Select a point close to the endpoint on the water pipe where you want to place the valve.

The appropriate valve symbol is placed on the water pipe.

Inserting nearest valves
Nearest valves are inserted at any selected point on a water pipe, breaking the underlying pipe. 
The Munsys Water Insert Valve toolbar contains the functions that are used to insert nearest 
water valves.

To insert a nearest valve

1 Do one of the following:

 Choose Capture > Insert Nearest Valve > Valve Name.

 Click the appropriate button on the Munsys Water Insert Valve toolbar.

Figure 9 The Munsys Sewer Insert Valve toolbar 

2 Select a point on the water pipe where you want to insert the valve.

The underlying pipe is broken, and the appropriate valve symbol is placed on the water pipe.
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Figure 10 Capturing valves
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Capturing service connections
Service connections connect parcels with the rest of the water network. Munsys Water caters for 
the following service connection types:

 straight service connections

 single and double-branched service connections

 freehand service connections

The Munsys Water Place SC toolbar contains all the functions that are used to capture different 
types of service connections. Service connections are placed on their appropriate layers, to be 
verified when the integrity check is run.

To place a straight service connection
Straight service connections are placed perpendicular to the water reticulation network, and end 
within the boundaries of land parcels.

1 To place a straight service connection, do one of the following:

 Choose Capture > Place SC > Straight.

 Click the Place Service Connection Straight button on the Munsys Water Place SC toolbar.

2 Select the water pipe closest to the parcel boundary where you want to place the service connection.

3 Select the parcel boundary where the service connection should be connected to.

The service connection is placed to end within the parcel boundary.

To place a branch service connection
Branch service connections are placed at a specified offset distance from a parcel boundary. The 
default offset distance can be changed on the Water Settings dialog box (see page 4-3).

1 To place a branch service connection, do one of the following:

 Choose Capture > Place SC > Branch.

 Click the Place Service Connection Branch button on the Munsys Water Place SC toolbar.

2 Select the water pipe closest to the parcel boundary where you want to place the branch service 
connection.

3 Select the parcel boundary to which the branch service connection should be connected.

4 Specify the boundary offset distance, and then press ENTER, or press ENTER to accept the default 
offset distance.

5 Specify an alignment point on the parcel boundary, and then press ENTER.

The branch service connection is placed as specified.
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To place a double branch service connection
Double branch service connections are used to connect two parcels to the water reticulation 
network simultaneously.

1 To place a double branch service connection, do one of the following:

 Choose Capture > Place SC > Double Branch.

 Click the Place Service Connection Double Branch button on the Munsys Water Place SC 
toolbar.

2 Select the water pipe closest to the parcel boundary where you want to place the double branch 
service connection.

3 Select the parcel boundary to which the double branch service connection should be connected.

4 Specify the boundary offset distance, and then press ENTER, or press ENTER to accept the default 
offset distance.

5 Specify an alignment point on the parcel boundary, and then press ENTER.

The double branch service connection is placed as specified.
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To place a freehand service connection
With this function, you can customize the length, direction and angle of a service connection. 
A service connection might, for example, be longer than the default service connection length 
specified on the Water Settings dialog box, and it might not tie in to a water pipe at a specified 
angle.

1 To place a freehand service connection, do one of the following:

 Choose Capture > Place SC > Freehand.

 Click the Place Service Connection Freehand button on the Munsys Water Place SC toolbar.

2 Select the water pipe where the service connection should be connected.

3 Specify points within the parcel boundary, and then press ENTER to complete the service 
connection.

The service connection is captured on its appropriate layer.

Figure 11 Service connections

Straight SC

Branch SC

Double branch SC

Freehand SC
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Capturing water zones
Water zones are captured to obtain an overview of the network layout. Water zones are captured 
as polygons that represent a certain section of the water reticulation network.

Water zones are captured by:

 selecting consecutive points to form a water zone polygon

 specifying a tag for the polygon builder to use when creating the water zone polygon

 generating a polygon from the lines and tag that were created

To draw a water zone boundary

1 Choose Capture > Water Zone > Draw Zone Boundary.

2 Specify the first polygon point.

3 Specify the next points, and then press ENTER.

4 Press ENTER to close the polygon.

Munsys closes the polygon automatically by snapping to the first specified point.

To place a water zone tag

1 Choose Capture > Water Zone > Place Zone Tag.

2 Specify the insertion point for the tag.

3 On the command line, specify the tag height, or press ENTER to accept the default height.

4 To indicate the tag angle, do one of the following:

 Indicate the tag angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the tag to an object, press ENTER, and then select the 
object to which you want to align the tag.

5 Type the tag value on the command line, and then press ENTER.

The tag is inserted as specified.
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To generate a water zone polygon

1 Choose Capture > Water Zone > Generate Zone Polygon.

2 Select all the lines that form the water zone polygon, and then press ENTER.

3 Select the polygon tag, and then press ENTER.

The command line indicates that the polygon has been built successfully.

Figure 12 A water zone

water zone boundary

water zone tag
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Capturing residential water pipes
Residential water pipes can be drawn freehand, or captured at a specified offset distance from 
any selected object. Residential water pipes are placed on the WATRESPIPE layer, to be verified 
when the integrity check is run.

To draw a freehand residential water pipe

1 Choose Capture > Residential Water > Draw Freehand Pipe.

2 Specify the first point for the pipe, and then specify next points.

3 Press ENTER when you have specified all the points.

The command line displays a message confirming that the residential water pipe was created 
successfully.

To draw an offset residential water pipe

1 Choose Capture > Residential Water > Draw Offset Pipe.

The command line prompts you to specify points, or to select an offset segment.

2 To draw a pipe by specifying points, do the following:

 Specify the first point, and then specify next points for the pipe.

 Press ENTER when you have specified all the points.

 Specify a point on the side to offset the pipe.

 On the command line, specify the offset distance, or press ENTER to accept the default offset 
distance.
The command line displays a message confirming that the pipe was created successfully.

3 To draw a pipe by selecting segments, do the following:

 On the command line, type O, and then press ENTER.

 Specify a boundary segment to offset the pipe from.

 Specify a point on the side to offset the pipe.

 On the command line, specify a multiplication factor for the default offset distance, or press 
ENTER to accept the default offset distance.

 Continue selecting segments until all the required segments have been selected, and then press 
ENTER.

 Press ENTER to confirm that you have completed the segment selection.
The command line displays a message confirming that the pipe was created successfully.
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Placing water symbols
This function is used to place water symbols in the current drawing. Water symbols represent 
additional annotation in the form of a symbol, and do not form part of the water network. 
Water symbols can be placed anywhere without any restriction. Water symbols are captured on 
the WATSYM layer.

Note The database administrator can add additional water symbols to the lookup table 
LU_WMS_WATSYM as required. This table contains a number of default symbols, but can 
be customized.

To place water symbols

1 Do one of the following:

 Choose Capture > Place Water Symbol...

 Click the Place Water Symbol button on the Munsys Water Capture toolbar.

2 The Water Symbols dialog box is displayed, showing a list of available water symbols.

Figure 13 The Water symbols dialog box
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3 From the list, select the symbol that you want to place, and then click OK.

4 Specify an insertion point for the symbol.

5 Specify a rotation angle for the symbol by doing one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle of 
zero.

 Indicate the angle with your mouse pointer by picking a point in the drawing.

 On the command line, type A to align the symbol to an object, press ENTER, and then select 
the object to which you want to align the symbol.

The symbol is placed at the insertion point and angle that you specified.

Tip Press ENTER or Spacebar to continue placing consecutive symbols of the same type, without 
having to select a symbol type from the list every time.

Placing water labels
With this function, you can place a label on a water pipe that has been queried from the 
database. The water label shows the current pipe diameter and pipe material, for example 8”.If 
you change the pipe diameter or material and post the changes to the database, the label will 
show the new value once it is queried again from the database. Water labels can therefore not 
be placed on new water pipes, but only pipes that have been posted to the database.

To place a water label

1 Do one of the following:

 Choose Capture > Place Water Label.

 Click the Place Water Pipe Label button on the Munsys Water Capture toolbar.

2 Select the water pipe to which you want to attach the label.

3 Specify an insertion point for the label.

4 Specify the tag height for the label, or press ENTER to accept the default tag height.

5 To indicate the tag angle, do one of the following:

 Indicate the tag angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the tag to an object, press ENTER, and then select the 
object to which you want to align the tag to.
The label is placed as specified.
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Figure 14 Water labels, showing pipe material and diameter
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Placing water notes
For map production purposes, information about a spatial object is added in the form of a note.

To place a water note

1 Do one of the following:

 Choose Capture > Place Water Note.

 Click the Place Water Note button on the Munsys Water Capture toolbar.

2 Specify the insertion point for the note.

3 On the command line, specify the note height, or press ENTER to accept the default note height.

4 To indicate the note angle, do one of the following:

 Indicate the angle with your mouse.

 Type the angle on the command line.

 On the command line, type A to align the note to an object, press ENTER, and then select the 
object you want to align the note to.

5 Type the note value on the command line, and then press ENTER.

The note is inserted as specified.
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Placing dimension arrows

To place dimension arrows
Map production is a reduced version of reality and it is therefore virtually impossible to capture 
water pipes at the true offset distance from a parcel boundary. Dimension arrows are used to 
indicate the offset distance of a water pipe from a parcel boundary.

1 Do one of the following:

 Choose Capture > Place Dimension Arrow.

 Click the Place Water Dimension Arrow button on the Munsys Water Capture toolbar.

2 Specify the first segment for dimension.

The dimension arrows will be placed perpendicular to this segment.

3 Specify the second segment for dimension.

The dimension arrows are aligned to the point selected on this segment.

4 On the command line, enter the offset distance, or press ENTER to accept the default offset distance 
as determined in the Water Settings, or press A to place the actual calculated distance.

The dimension text is placed at the dimension arrows, indicating the distance between the two 
dimension lines.

Figure 15 Dimension arrows
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Checking water integrity
The Integrity Check provides a set of rules to validate spatial objects. All new or modified spatial 
objects have to be verified against integrity rules built into the capture and change routines of 
every application before they can be posted to the database. New and changed objects contain 
an internal status that requires the validation process.

The Integrity Check is run from the Capture menu, or by clicking the appropriate button on 
the Integrity toolbar. The way in which the integrity check is executed depends on the 
preferences/options specified in the Munsys Options dialog box. The various options available 
on this dialog box are discussed in detail in the Munsys Concepts User Manual.

The integrity check is split into two separate functions to facilitate flexibility and ease of use:

 Validate Object Integrity – checks and validates the spatial and/or attribute data of an 
object, according to the options specified in the Munsys Options dialog box:

 When the Validate Geometry: Modified objects option has been selected, the geome-
try of only new or modified objects will be validated.

 When the Validate Geometry: All objects option has been selected, all the objects in 
the selection set will have their geometry validated. This includes locked, unlocked, 
modified and non-modified objects. 

When the object integrity check has completed and changes in objects have been 
encountered that may affect network integrity, a warning message to this effect is displayed 
if the option was specified in the Munsys Options dialog box.

 Validate Network Integrity – validates the rules that, together with the objects, make up a 
network, and according to the Network Integrity options specified in the Munsys Options 
dialog box. Network validation includes the topology and connectivity aspects, where 
topology is resembled in the geometry of objects and connectivity by means of attributes 
attached to objects.

This function is dependent on the relationships between objects, and therefore requires 
more objects to be included as part of the validation process than only those that were 
modified. The Validate Network Integrity function allows non-validated objects to be 
selected, but does not attempt to reset any integrity flags. It only places integrity markers 
when errors are encountered in the network. If the selection set contains objects that have 
not been validated by the Validate Object Integrity function, an Object Integrity Warning 
is displayed, recommending that object integrity has to be checked before network 
integrity.

Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Object in Network 
Integrity Check), which is set by the database administrator in the Munsys Management 
Console, allows a network integrity check to be performed automatically whenever an object 
integrity check is run. The same network rules and settings still apply. When the integrity check 
is completed, the Integrity Results dialog box displays a combined list of both object and 
network validations that were performed during the integrity check. When this setting is 
enabled, the object integrity check cannot be integrated with the database posting 
function, and the Automatically perform Object Integrity option on the Munsys Options 
dialog box Preferences tab will be unavailable. 
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When water object integrity is checked, the following is verified:

Table 16 The water object integrity check

When water network integrity is checked, the following is verified:

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified but, 
because it was unlocked, the integrity check failed to 
rectify the object and it was left as is.

Short spatial objects Applies to any object with a length shorter than the 
Munsys Water database tolerance setting.

Duplicate points in spatial objects Applies to redundant coordinates being removed from an 
object. If the coordinates are within *SNAP* tolerance, 
they are discarded.

Objects with incomplete geometry Refers to objects that do not have geometry, for example: 
tags that were placed without using the polygon builder 
process do not have a geometry.

Objects outside database extents Checks if the objects selected are within the confines of 
the geographic extents of the database.

Attribute rules Checks for the attribute rules as specified in the 
MUNSYS_INTEG_ATTR table, for example NULL 
values, etc.

Attribute data types Checks the data type to be consistent with what is in the 
database; i.e. attached attributes should not exceed the 
limits of the table's column definition, for example: a tag 
may not be longer than the table's TAG_VALUE column 
width.

Validation check/error condition Description

Unlocked objects not rectified Indicates that an object could have been rectified 
but, because it was unlocked, the integrity check 
failed to rectify the object and it was left as is.

Pipes within snap tolerance Checks for pipes that can snap to other pipes that 
are within the snap tolerance.

Pipes without nodes Checks whether each pipe is connected to a node 
at both ends of the pipe.

Duplicate pipes Checks for two different pipes connected to the 
same nodes.

Nodes within snap tolerance Checks for nodes that can be snapped to pipes that 
are within the snap tolerance.

Isolated nodes Checks for nodes that are not connected to any 
pipes.
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Table 17 The water network integrity check

Checking water object integrity

1 Do one of the following:

 Choose Capture > Data Integrity > Validate Object Integrity...

 Click the Validate Object Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

The Integrity Results dialog box is displayed, providing summarized information and validation 
results encountered during the object integrity check.

Figure 18 The Integrity Results dialog box

3 If you selected the Notify when objects require network validation option on the Munsys Options 
dialog box, and if objects were encountered during the integrity check that may affect network 
integrity, the following message is displayed:

Nodes with too many pipes Checks for nodes that are connected to too many 
pipes.

Nodes with too few pipes Checks for nodes that are connected to too few 
pipes.

Duplicate nodes Checks for nodes that have been captured on top 
of one another.
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Figure 19 Network Integrity Warning

Checking water network integrity

1 Do one of the following:

 Choose Capture > Data Integrity > Validate Network Integrity...

 Click the Validate Network Integrity button on the Integrity toolbar.

2 Select the objects that you want to validate, and then press ENTER.

Note If you selected objects that have not been validated by the Validate Object Integrity function, 
the following message is displayed:

Figure 20 Object Integrity Warning

3 When the integrity check has completed, the Integrity Results dialog box is displayed, providing 
summarized information and validation results encountered during the network integrity check.
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Figure 21 The Integrity Results dialog box
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Browsing integrity markers
You can review the integrity markers resulting from the integrity check with the Browse 
Integrity Markers dialog box. This dialog box displays the complete list of errors encountered 
during the integrity check. The list consists of the error type, the object affected, a description 
of the error, and the GID of the spatial object. From this dialog box, you can locate and remove 
specific integrity markers in the drawing.

To browse integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Browse Integrity Markers...

 Click the Browse Integrity Markers button on the Integrity toolbar.

 Click the Errors... button on the Integrity Results dialog box. 
The Browse Integrity Markers dialog box is displayed.

Figure 22 The Browse Integrity Markers dialog box

2 To locate an error, select the appropriate integrity marker, and then click the Locate button.

Munsys zooms to the extent of the spatial object to which the integrity marker refers.

3 To remove integrity markers from the list and from the drawing, select one or more integrity markers 
from the list, and then click the Remove button.

The integrity markers are removed from the drawing and from the list of markers.
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Erasing integrity markers
With this function, you can erase all the integrity markers. Integrity markers are stored on the 
INTEG layer.

To erase integrity markers

1 Do one of the following:

 Choose Capture > Data Integrity > Erase Integrity Markers.

 Click the Erase Integrity Markers button on the Integrity toolbar.
The command line prompts you for confirmation to erase all the integrity markers.

2 Press ENTER to erase the integrity markers.

The integrity markers are erased.

Posting water data to the database
New or modified water data that has passed the integrity check is posted to the database. 

To post water data to the database

1 Do one of the following:

 Choose Capture > Post to Database...

 Click the Post to Database button on the Integrity toolbar.
The Database Posting Summary dialog box is displayed. 

Figure 23 The Database Posting Summary dialog box

This dialog box displays the following:
 The total number of spatial objects selected for posting.
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 The number of new objects created.

 The number of attribute changes made.

 The number of spatial changes made.

 The number of objects marked for deletion.

 The number of objects that have not been validated and that will not be posted to the 
database.

2 Click OK to update the database.

The Database Posting Results dialog box is displayed.

Figure 24 The Database Posting Results dialog box

This dialog box displays the following:
 The total number of objects selected for posting to the database.

 The total number of spatial objects inserted into the database.

 The total number of spatial objects modified in the database.

 The total number of spatial objects deleted from the database.

 The total number of objects not posted to the database.

3 Click Close to exit the Database Posting Results dialog box.

Note Once you have posted objects to the database, you will not be able to undo this function, which 
will avoid duplicate objects and keep the content of the drawing synchronized with the 
database.
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Validating object integrity and posting data at the same time
If you select the Automatically perform Object Integrity option on the Munsys Options dialog box 
Preferences tab, you can perform an object integrity check and database posting operation at the 
same time. The following rules will be applied when the objects integrity phase of the operation is 
executed:
 Only modified objects will be selected for object integrity

 The integrity flag will be reset automatically if the object passes object integrity

 Integrity markers will be placed accordingly where errors occur, as happens when a normal 
object integrity check is run from the Capture menu

 If an error occurs, the integrity flag will not be reset

 Only objects related to the current application will be included in the object integrity check 
(i.e. if you are working in the Water application, only water objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:
 Ignore the errors that occurred and continue to post the objects that passed the integrity 

check to the database 

 Cancel the database posting operation and return to the map interface 

 View the errors that occurred with the Browse Integrity Markers dialog box (this option also 
cancels the posting operation, allowing you to correct the errors first before attempting to 
post the objects to the database once again)

To validate object integrity and post objects at the same time

1 On the Munsys Options dialog box Preferences tab, select the Automatically perform Object 
Integrity check box in the Database Posting Preferences group.

2 Choose Capture > Post to Database.

An object integrity check is run on the all the new or modified objects in the drawing.

3 If any errors occurred, the following message is displayed:

Figure 25 Database Posting – Object Integrity Errors

4 Do one of the following:

Click Yes to ignore the errors that have occurred and post the objects to the database that have 
passed the integrity check

Click No to cancel the posting operation and return to the drawing

Click Errors... to view the errors that occurred using the Browsing Integrity Markers dialog box.
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Water network quality reporting
The Network Quality Report function on the Extras menu is used to validate the quality of the 
entire water network. The network quality report complements the network integrity check. 
Although it is recommended that a network integrity check is always done before objects are 
posted to the database, some problems might still be present in the quality of a network. This 
could, for example, be due to the fact that the network integrity check might have been done 
on a small area of the network. The network quality check uses all the objects in the database 
to validate the quality of the entire network. The validation is done at attribute level, without 
having to validate the associated spatial data.

Specific columns in each of the spatial tables are used to build up the topology of the network, 
for example the start and end nodes of a water pipe. The network quality report will validate 
these values based on water-specific rules. 

Any network errors that have been found are populated to the MUNSYS_INTEG_RESULTS 
table, together with the appropriate error message related to each spatial object where an error 
occurred. The MUNSYS_INTEG_RESULTS table can be used to set up a query, which will 
use this table as a linked table with a condition based on the SP_TABLE column that matches 
the spatial table name of the query.

If a single spatial object contained more than one error, a record will be stored for each error 
that occurred within that object. You can also have the errors populated to the COMMENTS 
column of the object(s) in which errors occurred, if you do not traditionally use this column for 
other purposes. If more than one error has occurred in an object, the COMMENTS column is 
populated with the last error that is found.
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The following table shows the water network errors that may occur:

Figure 26 Water network quality errors

To validate water network quality

1 Choose Extras > Network Quality Report...

The command line displays the message: Generating network quality report

2 If errors were found in the network, the following message is displayed:

Figure 27 Network Quality errors found

Spatial Table Error Description

SP_WATPIPE NODE MISSING The START_NODE/END_NODE value 
is NULL, or the node ID was not found in 
the SP_WATNODE table

SP_WATPIPE ID NOT UNIQUE The PIPE_ID column contains a non-
unique value

SP_WATPIPE SEQUENCE 
EXCEEDED

The value in the NODE_ID column 
exceeds the current value of the 
WMS_WATPIPE sequence

SP_WATPIPE ID NULL The value of the PIPE_ID column is 
NULL

SP_WATNODE ID NULL The value of the NODE_ID column is 
NULL

SP_WATNODE SEQUENCE 
EXCEEDED

The value in the NODE_ID column 
exceeds the current value of the 
WMS_WATNODE sequence

SP_WATNODE ID NOT UNIQUE The NODE_ID column contains a non-
unique value

SP_WATNODE NODE ISOLATED The node ID was not found in either the 
START_NODE or END_NODE 
columns of SP_WATPIPE tables

SP_WATSERV UNCONNECTED SC The value in the PIPE_ID or PRCL_GID 
column is Null, or the pipe ID was not 
found in the SP_WATPIPE table, or the 
PRCL_GID was not found in the 
SP_PARCEL table



Creating water data 52 








3 Click Yes if you want the COMMENTS column updated, or No if you do not want the column 
updated.

The Save Results Summary As dialog box is displayed.

4 Save the report to a location of your choice.

The report is opened in Windows Notepad, and contains the following information:

 The number of objects that were checked

 The number of objects found that violated the network rules

 The number of endpoints that were found in the network

 The number of errors that were found, grouped by error type

Figure 28 A water network quality report
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Generating water data status reports
Data status reports provide summarized information about spatial objects that are currently 
stored in the database. Once a report has been generated, it is saved to a comma delimited file, 
and then displayed in Notepad for easy viewing. The following reports can be generated for 
water objects:

 a summary of all the water objects in the database

 a summary of the total length and number of water pipes, by diameter and category

 a summary of the total length and number of water pipes, by material and category

 a summary of the total length and number of water pipes, by type and category

 a summary of the number of water nodes, grouped by type and category

 a summary of the total length and number of service connections by category

 a summary of the length and number of pipes diameter by material

To generate a water data status report

1 Choose Extras > Data Status Report...

The Data Status Report dialog box is displayed, showing a list of all the reports that can be 
generated.

Figure 29 The Data Status Report dialog box

2 Select one or more reports to generate from the list, and then click OK.

3 Save the file to a location of your choice.

The file is opened in Windows Notepad.
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Figure 30 Data status report for service connections
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Converting AutoCAD entities to water objects
With Munsys, you can convert selected AutoCAD entities to Munsys Water objects. Block 
entities can be converted to water nodes (hydrants, junctions, meters, etc.) or water symbols 
(cross over, sample point, cleaning port etc.), line entities can be converted to water pipes or 
service connections, text can be converted to tags or a water note, and polygons can be 
converted to water zones.

Although some basic attributes are assigned as part of the conversion process, you will need to 
assign attributes to the objects created with the conversion process.

To convert block entities to water nodes or valves
With this function, you can convert AutoCAD block entities to any of the available water nodes 
or valves. To convert block entities to water nodes or valves, do the following:

1 Choose Extras > Convert Block to > Water Node/Valve Name.

2 Select the block entities that you want to convert, and then press ENTER.

One water node is created for each block entity that you selected, and the drawing is updated 
accordingly.

To convert block entities to water symbols
With this function, you can convert AutoCAD block entities to any of the available water 
symbols. To convert block entities to water symbols, do the following:

1 Choose Extras > Convert Block to > Water Symbol.

2 Select the block entities that you want to convert, and then press ENTER.

The Water Symbols dialog box is displayed, showing a list of available water symbols.

3 From the list, select the symbol that you want to place, and then click on OK.

One water symbol is created for each block entity that you selected, and the drawing is updated 
accordingly.

To convert line entities to water objects
With this function, you can convert line entities to any of the following water objects:
 water pipes

 service connections

 residential water (pipes)

1 To convert line entities to water objects, do one of the following:

 Choose Extras > Convert Line to > Water Pipe.

 Choose Extras > Convert Line to > Residential Water.

 Choose Extras > Convert Line to > Service Connection.
 When converting a line entity to a service connection (SC), the SC must also be linked to the 

parcel before the PIPE_ID and the PRCL_GID will be added to the respective SC columns. To 
link a SC to a parcel use the menu item: Change > Link SC’s to Parcels.

2 Select the line objects that you want to convert to water objects, and then press ENTER.
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The selected line objects are converted and the drawing is updated accordingly.

To convert text to water notes or tags
With this function, you can convert AutoCAD text entities to water zone tags or water notes.

1 Do one of the following:

 Choose Extras > Convert Text to > Water Zone Tag.

 Choose Extras > Convert Text to > Water Note.

2 Select the objects that you want to convert, and then press ENTER.

The entities are converted to the water objects that you specified, and the drawing is updated 
accordingly.
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To convert polygons to water zones

1 Choose Extras > Convert Polygon to > Water Zone.

2 Select the polygons that you want to convert, and then press ENTER.

The polygons are converted to water zones, and the drawing is updated accordingly.
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 Chapter 5


 Maintaining water data

Modifying water data
Spatial data is stored in database tables as records. Water objects that need to be edited are 
queried onto their respective layers. Attribute data can be edited directly in its table format.

Once the water pipes and nodes have been placed, the water objects have to be manipulated 
to make certain that they are joined correctly, for example with no overlaps or undershoots, 
and each pipe has to have a start and end node.

Attribute values linked to water objects can be modified easily from the Change menu, for 
example pipe diameter, type and material.

Water objects that have been changed need to be checked against the water business rules 
before they can be posted to the database.
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Changing water pipes

To extend a water pipe to a boundary
Water pipes can be extended to a boundary object by first indicating the boundary object, and 
then selecting the pipe to extend. The boundary object must be able to intersect with the pipe. 
This function is often used to extend pipes to create Junctions during capture. The end point 
of the pipe is then changed to intersect the boundary object.

1 Do one of the following:

 Choose Change > Extend Pipe to Boundary.

 Click the Extend Pipe to Boundary button on the Munsys Water Change toolbar.

2 Select the boundary object where the pipe has to extend to.

3 Select the pipe that needs to extend.

The pipe is extended as indicated.

To extend a water pipe by distance
This function extends a pipe by a specified distance at the endpoint closest to a selected point 
on the pipe. You are prompted for the distance to extend the pipe with. You can also use this 
function to shorten a pipe by entering a negative distance, for example, -50.

1 Do one of the following:

 Choose Change > Extend Pipe by Distance.

 Click the Extend Pipe by Distance button on the Munsys Water Change toolbar.

2 Select the pipe that you want to extend, and then enter a distance on the command line.

The pipe is extended by the distance that you entered.

To extend a water pipe and break it at the intersection
This function extends a pipe to a boundary pipe that is then broken at the intersection. The 
pipe to be broken is selected first, and then the pipe to extend. The pipe to be broken must be 
able to intersect with the second pipe.

1 Do one of the following:

 Choose Change > Extend and Break Pipe.

 Click the Extend and Break Pipe button on the Munsys Water Change toolbar.
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2 Select the pipe that you want to break.

3 Select the pipe that you want to extend.

The pipes are extended and broken respectively, as indicated.

To break a water pipe
This function breaks a pipe nearest to a selected point on the pipe.

1 Do one of the following:

 Choose Change > Break Pipe.

 Click the Beak Pipe button on the Munsys Water Change toolbar.

2 Select a point on the pipe where you want to break it.

The pipe is broken at the point that you selected. 

To change a water pipe
With this function, you can move one or more selected pipe endpoints to a new location. 

1 Do one of the following:

 Choose Change > Change Pipe.

 Click the Change Pipe button on the Munsys Water Change toolbar.

2 Select the endpoint of the pipe that you want to change.

3 Indicate the destination point.

The pipe is changed as indicated.

To fillet water pipes
This function connects two pipes at a projected intersection.

1 Do one of the following:

 Choose Change > Fillet Pipe.

 Click the Fillet Pipe button on the Munsys Water Change toolbar.

The command line prompts you to indicate the two pipes that need to be extended or trimmed.

2 Select the first pipe.

3 Select the second pipe.
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The pipes are connected as indicated.

To trim a water pipe

1 Do one of the following:

 Choose Change > Trim Pipe.

 Click the Trim Pipe button on the Munsys Water Change toolbar.

2 Select the pipe that you want to trim to, as the cutting edge.

3 Select a point on the side of the second pipe that needs to be trimmed.

Munsys trims the last indicated pipe to the first one.

To join water pipes
This function is used to join two water pipes, creating a single pipe. The attributes from the 
first pipe selected remain the attributes for the joined pipe. If there is a gap between the two 
pipes to be joined, they are joined with a line segment. A joined pipe is created from the 
geometry of the selected pipes, and the second pipe selected is moved to the DELETED layer. 
The first selected pipe, now the new joined pipe, is flagged as a change to be verified when the 
integrity check is run.

1 Choose Change > Join Pipe.

2 Select the first water pipe (the pipe that you want to join to).

3 Select a point close to the endpoint of the second pipe (the pipe that you want to join).

The pipes are joined as indicated, and the attributes from the first pipe selected remain the 
attributes for the joined pipe.

To change the vertex of a water pipe
With these functions, you can remove, move, add or insert new vertices to segments in a pipe.

To add a vertex to a water pipe

1 Choose Change > Change Pipe Vertex > Add.

2 Select the appropriate water pipe.

3 Select the endpoint of the pipe to which you want to add a vertex.

4 Select a position for the new point.

A vertex is added at the point you selected.
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To move a water pipe vertex

1 Choose Change > Change Pipe Vertex > Move.

2 Select the appropriate water pipe.

3 Specify a point closest to the vertex that you want to move.

4 Specify a point to move the vertex to.

The vertex is moved to the point that you specified.

To remove a water pipe vertex

1 Choose Change > Change Pipe Vertex > Remove.

2 Select the appropriate water pipe.

3 Select the vertex that you want to remove from the pipe.

Note A vertex can only be removed from a segment with more than two vertices.

To insert a vertex into a water pipe

1 Choose Change > Change Pipe Vertex > Insert.

2 Select the appropriate water pipe.

3 Select the segment for the inserted point.

4 Select the position for the new point.

The vertex is inserted at the position you selected.



Maintaining water data 63 








Changing water nodes
Using the Munsys Water Change menu/toolbar, water nodes can be moved to a new location, 
rotated manually or snapped to water pipes. You can also change the node type of one or more 
selected nodes. These functions are used when the water network is cleaned up after the capture 
process.

To move a node
With this function, you can move a single node to a new location.

1 Do one of the following:

 Choose Change > Move Node.

 Click the Move Node button on the Munsys Water Change toolbar.

2 Select the node that you want to move.

3 Specify a new insertion point for the node.

The node is moved as indicated.

Figure 1 Moving a water node
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To rotate a node
With this function, you can rotate one or more selected nodes.

1 Do one of the following:

 Choose Change > Rotate Node.

 Click the Rotate Node button on the Munsys Water Change toolbar.

2 Select the node that you want to rotate.

3 To specify the rotation angle, do one of the following:

 Enter the rotation angle on the command line, or press ENTER to accept the default angle.

 Indicate the angle with your mouse pointer by picking two points in the drawing.

 On the command line, type A to align the node to a segment, press ENTER, and then select the 
object to which you want to align the node.

The node is rotated as specified.

To snap a node to the endpoint of a water pipe
With this function, you can snap a node to the endpoint of a water pipe. The node is moved to 
the end point closest to the point selected on the pipe.

1 Do one of the following:

 Choose Change > Snap Node to Endpoint.

 Click the Snap Node to Endpoint button on the Munsys Water Change toolbar.

2 Select the applicable node.

3 Select the pipe close to the endpoint that you want to snap the node to.

The node is snapped to the endpoint of the pipe.
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To snap a node to the endpoint of a pipe, breaking the pipe
With this function, you can break a pipe and snap a node to the endpoint of the broken pipe.

1 Do one of the following:

 Choose Change > Snap Node and Break Pipe.

 Click the Snap Node and Break Pipe button on the Munsys Water Change toolbar.

2 Select the applicable node.

3 Select the pipe that you want to snap the node to.

4 Specify a break point on the pipe.

The node is snapped to the endpoint of the broken pipe.

To change valve status
With this function, the status (Open or Closed) of selected butterfly or gate valves can be 
changed. The symbol is changed automatically when the status has been changed. The node 
type is not changed.

1 Choose Change > Open/Close Valve.

2 Select the valves of which you want to change the status.

The Valve Status dialog box is displayed.

Figure 2 The Valve Status dialog box 

3 Change the status as required, and then click OK to apply.

Note The node type is used to open or close valves, using the correct symbol according to the 
NODE_TYPE value. There might be exceptions when the NODE_TYPE value is equal to 
CLOSED_VALVE, or is NULL. There might also be exceptions where the NODE_TYPE 
value is not GATE_VALVE or BUTTERFLY_VALVE. In this case, the NODE_TYPE cannot 
be linked to a symbol name. If any of these exceptions occur, a dialog box will be displayed, 
from where you can change the node type of the selected valves to either butterfly or gate 
valves.
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To change a node type
With this function, you can change the node type of one or more selected nodes. The new node 
type is selected from a list. The symbol name and the NODE_TYPE column are updated 
according to the new node type selected.

1 Choose Change > Change Node Type...

2 Select the node(s) that you want to change, and then press ENTER.

The Node Types dialog box is displayed.

Figure 3 The Node Types dialog box

3 Select the new node type from the list, and then click OK.
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Changing the category of water objects
Water objects are classified according to a water category. This function is used to change the 
water category of one or more selected water objects.

To change water category

1 Choose Change > Change Water Category.

2 Select the water objects that you want to change.

The Select Water Category dialog box is displayed. If you selected one object, the current category 
is highlighted. If you selected more than one object of different categories, no current category is 
highlighted.

Figure 4 The Select Water Category dialog box

3 Select the new category from the list, and then click OK.

The water category you selected is assigned to the objects.
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Changing water attribute data
With Munsys Water, you can change the individual physical attributes of water objects. You can 
also link service connections to their respective parcels, and open or close valves.

Editing water object attributes
The Edit Attributes function is used to edit the attributes of one or more selected water objects 
that belong to the same object type. The current application determines what object types may 
be selected; for example, if you are working in Munsys Water, only water objects may be 
selected. If you select more than one object type (for example pipes and nodes), you will be 
required to choose a single object type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database). 
Once the objects have been selected and an object type to edit has been specified, the Edit 
Attributes dialog box is displayed. This dialog box contains various options that can be used to 
edit the attributes of the spatial objects:

 Attribute templates – attributes can be edited using an attribute template. The attributes 
that will be displayed when an attribute template has been selected will depend on the 
attributes that have been specified on the template, as well as the formatting parameters that 
apply to each column selected as part of the attribute template. If no attribute template has 
been selected, all the attributes belonging to the spatial object type are displayed.

 Editing multiple objects simultaneously – if you select this option, attributes of multiple 
objects are displayed simultaneously. Where the attributes of all the selected objects are the 
same, a value is displayed. Where attributes of the various objects that were selected differ, 
a value of *VARIES* is displayed. When a change is made to a value, the new value is 
applied to all the selected objects. If you do not select the Edit multiple objects 
simultaneously check box, you can edit the selected objects one by one. The values that are 
changed are only applied to the object that is currently selected.

 AutoZoom – this option is only available when the Edit multiple objects simultaneously 
option is not selected, i.e. when you are going to edit the objects one by one. If the 
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as 
it becomes the current object, and highlight it. The object navigation buttons are used to 
move from one object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column, either by 
typing a new value or by selecting a value from a drop-down list. Changes that are made are 
applied to objects in the drawing. These changes will only be updated in the database when the 
object integrity check has been run and the objects have been posted to the database.



Maintaining water data 69 








To edit water objects

4 Choose Change > Edit Attributes...

5 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object 
Identification dialog box is displayed.

Figure 5 The Spatial Object Identification dialog box

6 Select a single spatial object type to edit, and then click OK.

The Edit Attributes: [Object Type] dialog box is displayed.

Figure 6 The Edit Attributes dialog box

7 If you want to edit the objects using an attribute template, select the appropriate attribute template 
from the Attribute Template list. If you do not want to make use of an attribute template, select 
None.
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Figure 7 Edit Attributes: Selecting an attribute template

8 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple 
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*, as 
seen in the following figure:

Figure 8 The Edit Attributes dialog box: Edit multiple objects simultaneously
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9 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously 
check box. Select the AutoZoom to object check box to zoom to the objects one by one and 
highlight them. The object navigation buttons are used to move from one object to the next.

10 To edit an attribute, do one of the following:

 Highlight a value, and then choose a value from the list in the Value column.

 Highlight a value, and then enter a new value in the Value column

11 Click OK to apply the new value(s) to the object(s).

The values are applied to the objects, to be verified with the object integrity check.

Editing linked table attributes
This function is used to edit spatial object attributes that exist in linked tables. Linked table 
attributes are updated directly to the database. The current application determines what object 
types may be selected; for example, if you are working in Munsys Water, only water objects may 
be selected. If you select more than one object type (for example pipes and nodes), you will be 
required to choose a single object type to edit. You can only select objects that have previously 
been posted to the database.

The link tables that can be edited using this function must be defined through an attribute 
template. The applicable attribute template is selected from a list, which is created by filtering 
attribute templates according to the following characteristics:

 Only attribute templates associated with the current spatial object type, being edited are 
included – the primary table in the attribute template is the same table from which the 
spatial objects were queried.

 Only attribute templates that contain linked tables are included

 The linked table specified may not be a Munsys spatial table

 The user must have edit privileges to the linked table

 The link column used to describe the relationship with the primary table must reference a 
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column by typing in 
a new value. Navigation buttons are used to move between the various records that are available 
and to move from one object to the next. You can also insert records into, or delete records from 
a linked table, depending on the privileges you have on the link table.

The procedure for editing linked table attributes is described in detail in the Munsys Concepts 
User Manual.
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Changing water pipe attributes
You can change the default pipe diameter, material or type that was assigned to a water pipe 
during the capture process. The new attribute is selected from a list to ensure data accuracy.

Tip If you construct the water pipes with the default diameter, material or type set to the one used 
most commonly, only pipes that have a different diameter, material or type need to be changed, 
reducing the amount of data to be captured.

To change water pipe diameter

1 Choose Change > Change Pipe Attributes > Diameter...

2 Select the appropriate water pipe/s, and then press ENTER.

The Select Water Pipe Diameter dialog box is displayed, highlighting the diameter of the pipe that 
you selected. If you selected multiple pipes, no current diameter is displayed.

Figure 9 The Select Water Pipe Diameter dialog box

3 Select the appropriate diameter, and then click OK.

Search for an item by its code or 
description.
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To change water pipe material

1 Choose Change > Change Pipe Attributes > Material...

2 Select the appropriate water pipe/s, and then press ENTER.

The Select Water Pipe Material dialog box is displayed, highlighting the material of the pipe that 
you selected. If you selected multiple pipes, no current diameter is highlighted.

Figure 10 The Select Water Pipe Material dialog box

3 Select the appropriate pipe material from the list, and then click OK.

To change a water pipe type

1 Choose Change > Change Pipe Attributes > Type...

2 Select the appropriate water pipe/s, and press ENTER.

3 The Select Water Pipe Type dialog box is displayed, highlighting the type of the pipe that you 
selected. If you selected multiple pipes, no current type is highlighted. 

Search for an item by its code or 
description.
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Figure 11 The Select Water Pipe Type dialog box

4 Select the appropriate pipe type, and then click OK.

Linking service connections to parcels / buildings
This function is used to link service connections to their respective parcels or buildings. The 
parcels and buildings have to be queried from the database when running a Building or Property 
Network Trace in order for the LINK_ID column to be populated.

To link service connections to parcels

1 Choose Change > Link Service Connections...

2 Select the appropriate service connections, and then press ENTER.

The selected service connections are linked to their respective parcels and buildings.

If the endpoint of the service connection falls inside a parcel boundary the PRCL_GID column 
is updated with the GID value from SP_PARCEL.

If the endpoint of the service connection falls inside a parcel boundary and a building polygon 
the PRCL_GID column is updated with the GID value from SP_PARCEL, and the LINK_ID 
column is updated with the GID value from SP_BUILDING.

Note The user should ensure that the value of Property/Building should be populated in 
WMS_WATSERV_LINKMUNID/SMS_SEWSERV_LINKMUNID settings.

By default Building is the default value which allows Service Connections to 
Buildings/Parcels/Property, however if switched to Parcels then Buildings/Property would not 
be allowed.

Search for an item by its code or 
description.
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Changing water notes
With this function, you can change the text of an existing water note.

To change a water note

1 Do one of the following:

 Choose Change > Change Water Note...

 Click the Change Water Note... button on the Munsys Water Change toolbar.

2 Select the water note that you want to change.

The Water Note text box is displayed.

Figure 12 The Water Note text box

3 Change the note as required, and then click OK.

Adding comments
This function is used to assign descriptive comments to one or more selected objects.

To add comments

1 Choose Change > Add Comment...

2 Select the water object(s) that you want to add a comment to.

The Water Comment text box is displayed.

3 In the text box, add the comment, and then click OK.

Figure 13 The Water Comment text box

The comment is assigned to the selected object(s), as seen in the following figure.
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Deleting and undeleting water objects
With Munsys Water, existing water objects can be deleted from the database. Multiple objects 
can be selected for deleting. Water objects that form part of a redundant network have to be 
deleted. Deleted water objects are moved to a frozen layer DELETED, which is removed from 
the database when changes are posted. With the Undelete function, you can restore water 
objects that have been moved to the DELETED layer and that are marked for deletion.

To delete water objects

1 Choose Change > Delete Water Object.

2 Select the water objects that you want to delete.

The command line indicates how many water objects you have selected, and how many have been 
filtered out.

3 Press ENTER to delete the selected water objects.

The water objects are flagged for deletion and moved to the DELETED layer. These changes are 
applied to the database when changes are posted.

To undelete water objects

1 Choose Change > Undelete Water Objects.

The objects that you have deleted are displayed in the drawing.

2 Select the water objects that you want to restore.

The Delete flag is no longer set for the selected objects. In the event of spatial or attribute 
changes before the objects were flagged for deletion, these changes are applied.
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A
adding comments 5- 75
additional reading material 1- 2
attributes, editing 5- 68

C
capture settings 4- 19
capture toolbar 2- 9
change toolbar 2- 9
convert block entities to nodes/valves 4- 55
convert block entities to water symbols 4- 55
converting polygons to water zones 4- 57
converting text to water notes or tags 4- 56

D
database

posting water data to 4- 47
database, connecting to 2- 5
deleting water objects 5- 76
dimension arrows, placing 4- 40

F
flow toolbar 2- 10

I
insert node toolbar 2- 10
integrity check

integrity markers 4- 46
integrity check 4- 41
integrity markers, browsing 4- 46
integrity markers, erasing 4- 47
integrity markers, locating errors 4- 46

L
labels 4- 37
launching Munsys 2- 5
launching Munsys Water 2- 5
linked table attributes, editing 5- 71

M
map page grid, modifying 14
map page grid, querying 3- 14
Munsys Water

interface 2- 7
Munsys Water 2- 4

N
node type, changing 5- 66
nodes

changing 5- 63

P
place node toolbar 2- 10
place SC toolbar 2- 10

Q
queries

querying residential water 3- 17
querying water objects by category 3- 15
querying water zones 3- 16

queries 3- 13

R
residential water pipes

drawing freehand 4- 35
drawing offset 4- 35
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residential water pipes 4- 35

S
service connections

linking to parcels 5- 74
placing a straight service connection 4- 30
placing branch 4- 30
placing double branch 4- 31
placing freehand 4- 32

service connections 4- 30

U
undeleting water objects 5- 76

V
valves

changing valve status 5- 65
inserting nearest 4- 28
placing endpoint 4- 28

valves 4- 28

W
water attribute data 5- 68
water capture settings

specifying 4- 20
water capture settings 4- 19
water category, querying objects by 3- 15
water data status report, generating 4- 53
water integrity

browsing integrity markers 4- 46
checking network integrity 4- 44
checking object integrity 4- 43
erasing integrity markers 4- 47

water integrity 4- 41
water labels

placing 4- 37
water labels 4- 37
water network quality reporting 4- 50
water network, capturing 4- 18
water nodes

changing type 5- 66

inserting nearest 4- 27
moving 5- 63
placing endpoint 4- 26
rotating 5- 64
snapping to endpoint and breaking pipe 5-

65
snapping to water pipe endpoint 5- 64

water nodes 4- 26
water nodes, changing 5- 63
water notes

changing 5- 75
placing 4- 39

water notes 4- 39
water objects

changing category 5- 67
water objects, about 2- 11
water pipes

breaking 5- 60
changing 5- 59
changing diameter 5- 72
changing material 5- 73
changing to new location 5- 60
changing type 5- 73
changing vertex 5- 61
drawing freehand 4- 22
drawing offset 4- 21
extending and breaking 5- 59
extending by distance 5- 59
extending to a boundary 5- 59
filleting 5- 60
joining 5- 61
trimming 5- 61

water pipes 4- 21
water symbols, placing 4- 36
water zones

capturing 4- 33
drawing boundaries 4- 33
generating polygons 4- 34
placing a tag 4- 33
querying 3- 16
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