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 Introducing the Munsys Concepts User Manual

Welcome to Munsys
The Munsys® product family consists of an integrated set of applications that cater for all the 
spatial information needs of utility and government organizations.

The Munsys products are based on industry leading technologies, utilizing OpenGIS® 
standards for sharing information. Autodesk® design technology is used to present the spatial 
information, while Oracle® database technology is used for the storage of both spatial and 
attribute information. The innovative Munsys applications are the result of years of extensive 
research and development. 

Munsys is a user-friendly, easy to use geographic information management tool, which does 
not require GIS expertise to capture and manipulate data.

The Munsys product family consists of the following applications:

 Munsys Cadastral

 Munsys Cable Route

 Munsys Cable Fiber

 Munsys Drainage

 Munsys Electricity

 Munsys Roads

 Munsys Sewer

 Munsys Water

 Munsys Map Books

 Munsys Spatial Data Manager

 Munsys Management Console

 Munsys Query

 Munsys Lineage

 Munsys Scheduled Tasks
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About this manual
The Munsys Concepts User Manual provides the following information:

 the generic capture functionality in the various Munsys applications

 the generic query functionality that is used to query spatial data from the Oracle database

 how to structure a query

 how to view spatial data

 how to work with Munsys Objects

 extras such as annotation, reporting and legend options, etc.

 how to format layers

What’s in this manual
The Munsys Concepts User Manual consists of the following chapters:

 Chapter 1 – Introducing the Munsys Concepts User Manual, gives an overview of this 
manual, and provides the typographical conventions used throughout the Munsys 
documentation set.

 Chapter 2 – Getting acquainted with Munsys, gives an overview of 
Munsys and its various applications, as well as an overview of the Munsys user interface.

 Chapter 3 – Using spatial data in Munsys, describes how to define query options and 
retrieve existing data from the database.

 Chapter 4 – Working with Munsys objects, introduces the user to Munsys objects, and 
explains how to maintain these objects.

 Chapter 5 – Munsys utilities, gives an overview of Munsys reporting, annotation and legend 
options, as well as to set a coordinate system for a drawing.

 Chapter 6 – Munsys drawing and capture tools, introduces the various drawing and capture 
tools in Munsys.

 Chapter 7 – Munsys layer formatting options, describes the various layer formatting options 
in Munsys.

 Chapter 8 – Creating Maps, introduces the Munsys utilities that simplify map production.

 Chapter 9 – Munsys Google Tools, provides instructions on how to execute the 
MUNGOOGLEEARTH commands, as well as how to change the way that selected data is 
displayed in Google Earth.
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Conventions in this manual
The following table lists the typographical conventions used in this manual.

Table 1 Munsys typographical conventions

Finding the information you need
To get help on

 general issues, select Help from the Munsys menu bar.

 an operation in progress, click the Help button on the dialog box.

 the latest support options, visit http://www.openspatial.com

Text element Example

Keys you press on the keyboard CTRL, ENTER, DEL

Screen buttons Click Close.

Folder paths C:\Program Files\Open Spatial

Menu paths choose Query > Clear Basemap.

Hypertext links to more information http://www.openspatial.com

Text displayed/typed on the 
command line

MUNOBJECT

Dialog box/screen names The Drainage Settings dialog box

Application functions The Integrity Check function

http://www.openspatial.com
http://www.openspatial.com
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 Getting acquainted with Munsys

Munsys Overview
Munsys, the spatial solution for utilities and government, is a multi-user open GIS system that 
allows users to capture and maintain utility data.

The demand for accurate geo-spatial information for both planning and decision support is 
increasing daily, fostering the need for the implementation of an information system that can 
grow with the needs of the organization. The Munsys system caters for these needs by storing 
spatial data from different departments into a centralized database, allowing it to cater for data 
sharing, integration and duplication problems.

The design of the capture and maintenance functions enforces data standards. Spatial data 
integrity is enhanced with a verification process known as the integrity check, which checks 
the spatial data against the business rules before it is posted to the database.

The Munsys product family simplifies the use of spatial data with predefined queries, which 
retrieve spatial objects onto their appropriate layers. Objects that are changed and new objects 
that are created are changed to a working color. Once the objects pass the integrity check, they 
are moved back to their normal colors, from where they are posted to the database.

Munsys is a user-friendly, easy to use spatial information management tool, which does not 
require GIS expertise to capture and manipulate utility data. The system provides the user with 
Capture and Change toolbars that speed up the capture process.

Munsys caters for enhanced output tools, such as annotations and legends, to simplify map 
production. 
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Munsys Features
The various Munsys features can be listed as follows:

 User-specific application and design – enforcing data standards fulfills the demand for 
accurate spatial data. Engineering spatial data requires standards that adhere to civil 
engineering rules, which are built into the capture and modify routines of the system. 
Munsys provides a user-friendly interface that meets these requirements.

 Munsys is an Enterprise Spatial Solution – Munsys is a multi-user open system that caters 
for the demands of spatial systems. Because of its centralized database and data sharing, 
dynamic information is available. 

 Munsys adheres to Open Geospatial Consortium (OGC) standards – Munsys is designed 
to adhere to the ISO standards for Open Geospatial Consortium (OGC) applications.

 Munsys is based on industry standard software – Munsys is designed as a front end on 
AutoCAD® Suite of Products.
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Introducing the Munsys Applications
The following section provides an overview of the various Munsys applications.

Munsys Cadastral 
Munsys Cadastral is used for the capture and maintenance of cadastral base data from general 
plans and diagrams. The cadastral data forms the foundation of the system because all 
departments use it to locate and position their services.

Using Munsys Cadastral, users can capture and maintain community boundaries (for example 
municipalities, suburbs, townships, etc.), parcels, easements, street names and addresses and 
buildings. In addition, Munsys Cadastral caters for planning aspects such as zoning, density and 
land use polygons.

Users can also define cadastral settings to simplify the capture process. Parcels are classified 
according to their legal and work status as proposed, current, or archived. Conversion of spatial 
objects to cadastral objects extends the capture capabilities within Munsys.

Figure 1 Munsys Cadastral 
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Munsys Drainage
Munsys Drainage is designed for the capture and maintenance of stormwater networks. Munsys 
Drainage caters for stormwater objects such as pipes, channels, and culverts, and for stormwater 
nodes such as manholes, grid inlets, etc. Additional drainage objects that can be captured along 
with the stormwater network include rivers, floodlines, dams and catchment areas. Objects are 
typically placed along cadastral boundaries and network connectivity is generated after the 
objects have been captured.

Munsys Drainage contains various tools to assist with data capture and maintenance that will, 
for example, allow the user to insert a node on a stormwater pipe, culvert or channel without 
having to recalculate all the invert levels.

Figure 2 Munsys Drainage 
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Munsys Electricity
Munsys Electricity is used for the capture of electricity network data.

Munsys Electricity accurately places nodes and cables along cadastral boundaries, building 
network integrity as cables are attached. Integrity checks and rules are applied as cables are 
placed, thereby eliminating errors such as interconnecting networks with incorrect cables.

Cable lengths are calculated along the boundaries and adjusted for slack at each connecting 
node. Important information such as connectivity, type, and size is stored for each cable.

Cables and nodes are grouped into specific categories such as EHV, HV, and LV that enable the 
easy production of working drawings.

Figure 3 Munsys Electricity 



Getting acquainted with Munsys 9 








Munsys Roads
Munsys Roads is used to capture road center lines, road areas, road edges, and traffic 
intersections.

Road center lines are constructed relative to cadastral boundaries between intersections. Road 
names are attached from a list of available names, thereby eliminating errors such as misspelled 
names. Additional information such as road type, width and classification can be attached as 
data is being captured.

Traffic intersections are constructed relative to cadastral data using standard road markings. 
This includes stop lines, pedestrian crossings, channel lines, direction arrows and vehicle 
detectors. Poles are placed and traffic signal faces are attached indicating different phases.

Figure 4 Munsys Roads 
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Munsys Sewer
Using Munsys Sewer, users can capture and maintain sewer networks.

Munsys Sewer automatically generates all associated connectivity and performs data integrity 
checks once the network data is captured or modified. Pipes are placed along cadastral 
boundaries and broken at each node. Service connections are drawn to the land parcels to create 
connectivity between pipes and land parcels.

Munsys Sewer caters for the capture of gravity, pressure and vacuum networks. It also caters for 
the storage of annotation information such as labels, notes and dimensions to allow for more 
detail on working drawings.

Figure 5 Munsys Sewer
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Munsys Water
Munsys Water is used for the capture and maintenance of water networks and related data such 
as water zones. 

Various tools are available for cleaning pipe intersections during capture. Nodes are placed on 
pipes with automatic symbol alignment, while pipes can easily be broken without the need for 
lengthy editing procedures.

Munsys Water also caters for the storage of annotation information such as notes, labels and 
dimensions.

Both spatial and attribute data integrity are checked before objects are posted to the database.

Figure 6 Munsys Water 
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Munsys Map Books
Munsys Map Books is designed for the production of map books. This application generates 
map book pages based on the various spatial layers of data that are available in the database.

The Map Books application allows a single sheet layout to be used for multiple map books with 
different contents. Pages can use standard paper sizes and are automatically numbered as they 
are placed. Tabs indicating the numbers of adjacent pages are automatically generated. Maps 
can be produced at a predefined or user-defined scale.

Indexes can be created to easily locate a page number by community (municipality, suburb or 
township) or street name.

Figure 7 Munsys Map Books 
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Munsys Spatial Data Manager
Munsys Spatial Data Manager has been designed to cater for generic GIS needs, enabling the 
creation of user-defined spatial objects for storage in the Oracle® database.

Spatial Data Manager also allows AutoCAD® drawing data to be converted into Munsys 
objects. Before being posted to the database, all Spatial Data Manager objects go through a data 
cleaning and integrity checking process to ensure data consistency.

Munsys Spatial Data Manager is also used for the creation and maintenance of link templates 
and attribute templates. Link templates are used when attribute information attached to spatial 
objects is edited, browsed, displayed. A link template specifies how one table is related to 
another. Attribute templates customize the view of a table. This is done by selecting appropriate 
columns and setting their display order, displayed name and respective formatting parameters. 
Link templates and attribute templates may only be created by administrators.

Munsys Geo-scan Tools provides Munsys users with a set of functions to capture previously 
scanned images (for example as-built survey plans) as part of the Munsys data model. This is 
done in the AutoCAD environment through the Spatial Data Manager application, where the 
various functions have been added to the Capture and Change menus.

The image content remains in its original location, for example a mapped drive on a central 
server or on the physical hard drive of the user’s pc, but the image boundaries are stored in the 
Oracle database as MUNPOLY objects. Users can query previously captured image boundaries 
from the database using the query palette to view the coverage of images. Also, by changing the 
associated attribute information, an image category can be assigned to an image boundary for 
classification purposes. Geo-scan Tools also allows the user to show hyperlinked images and 
open them in the associated software to view/edit the image.

Figure 8 Munsys Spatial Data Manager
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Munsys Management Console
The Munsys Management Console is a standalone application that has been designed to allow 
users with relevant privileges to manipulate objects and components within a Munsys schema 
in a structured and user-friendly way. The Munsys Management Console can be activated by 
any authorised database user, but the functionality that will be available to a user is dependent 
on the roles that have been assigned to the user. The availability of menu items and components 
in the Console is therefore dependent on the roles that have been allocated to the user.

The following components can be managed from the Munsys Management Console:

 The Munsys Schema — creating, dropping, exporting and validating a schema

 Locks — used to maintain record/object locking

 Query Categories — used to maintain query categories and query privileges

 Security — used to manage users and roles

 Applications — application settings

 Tables/Views — maintenance of Munsys-related tables, lookup tables, attribute tables and 
indexes

 Object Integrity — Manage Check, Node and Attribute integrity

 Lineage — used to manage the monitor and archive operations for selected spatial tables

 Scheduled Tasks — used to maintain Munsys scheduled tasks

Figure 9 The Munsys Management Console
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Munsys Export Administrator
With Munsys Export Administrator, the database administrator can export or publish data 
directly from the Oracle database for use by other applications. The data can be published in 
MapGuide SDF*1, MapInfo MIF/MID, and ArcView SHP formats. The application can also 
be scheduled to automatically perform the data export at regular intervals, ensuring that the 
data is up to date for use by other applications. Although the output file is primarily focused on 
a spatial table, this file can also contain attribute columns. The export files can either be 
generated from running the configuration files from within the Munsys Export Administrator, 
or from running the Export utility as a command-driven application. Both the Munsys Export 
Administrator and the Export Utility provide the user with flexibility in the following areas:

 filtering the data from the source table by means of a SQL expression

 specifying a GSC to use as a spatial filter

 selecting specific columns for output

 renaming of columns in the resulting output files; and

 saving the options for later recall.

 The user sets up a definition file once to identify which data should be exported, and how 
it should be formatted in the output file. Thereafter, the utility can be run repetitively with 
the same definition file, allowing for scheduled batch processing without any user 
interaction. Multiple definition files can be created and are easy maintainable.

Figure 10 The Munsys Export Administrator

Note *1 There is no SDF option for the 64-bit version of Munsys Export Administrator since the Autodesk 
MapGuide Component Toolkit (sdfcomtk.dll) is a 32-bit dll amd cannot be registered in a Windows
64-bit environment.
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Munsys Query
In utility and government organizations, the main focus is on infrastructure management. Not 
every user of the spatial information system is required to capture or update information. 
Munsys Query provides civil engineers who design networks, reticulations and roads access to 
the spatial information using AutoCAD. Civil or electrical engineers usually have to request a 
copy of the spatial information they require to use as a backdrop for their design. Major 
difficulties have been experienced over the past years with this process because the engineer's 
copy of the data is not dynamically updated; it is possibly outdated already during his design 
process.

Munsys Query complements the Munsys utility applications by sharing the same data model, 
therefore engineers may query utility data and then use standard AutoCAD functionality to 
modify the data or manipulate its display properties.

Figure 11 Munsys Query

Window GSC with the 
mask set to Crossing, and 
shown as a solid outline.
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Munsys Lineage
Munsys Lineage provides a user-friendly interface to assist administrators with the 
implementation of triggers in the Oracle® database that will keep track of who made changes 
to records in a specified table, the type of operation that was done and when the changes were 
made and will keep track of deleted records.

Figure 12 Munsys Lineage
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Munsys Reports
Reports can be run to query the database for monitor or usage purposes. Monitor reports can 
be used to provide basic or detailed reporting, based on operation type, user, table name and 
date of the operation. Usage reports can be used to show the license usage of the complete range 
of Munsys applications.The results can be saved to a CSV or text file.

Figure 13 Munsys Reports
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Munsys Cable Route
Munsys Cable Route is used for the capture and maintenance of cable route networks prior to 
the capture of fiber cables.

Many industry standard functions are used within this application to meet the specific criteria 
required before the capture of fiber cables. Cadastral building information such as name, 
number, floor and room information play a crucial role within the Cable Route application for 
the capture of fiber objects within the Munsys fiber application.

Specific duct information such as type and size are specified here which has a bearing on the 
amount of fiber cables which can be placed within the ducts.

Both spatial and attribute data integrity rules are checked before objects are posted to the 
database.

Figure 14 Munsys Cable Route
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Munsys Cable Fiber
Munsys Cable Fiber is used for the capture and maintenance of fiber cable networks and related 
associated services.

Various tools are available for the capture of fiber cables and the unique specifications within a 
larger network. Tools such as the Terminate / UnTerminate, Connect / Disconnect and Add or 
Remove Services allow for a comprehensive fiber application with a user friendly interface.

Figure 15 Munsys Cable Fiber
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About the Oracle database
Munsys uses Oracle as its data store. The advantage of using the Oracle Spatial technology is 
that spatial and attribute data are captured and managed in a single database. This reduces 
processing overheads and eliminates the complexity of coordinating and synchronizing 
different sets of data.

What is spatial data
In Munsys, spatial data consists of MunPoint, MunPoly, MunLine and MunLabel objects that 
represent parcels, boundaries, sewer pipes, electricity cables, road center lines, nodes, etc.

The positions of these objects that exist on the surface of the earth are determined in degrees of 
latitude and longitude, which can be projected to different coordinate systems and stored in the 
database. To enable users to store these spatial objects, they need to be projected to a flat surface. 
Any representation of the earth's surface in two dimensions always distorts one or more of the 
attributes of shape, distance, area, or direction. 

On a flat surface, the locations of spatial objects are measured in a two-dimensional planar 
coordinate system. A planar coordinate system describes distance from an origin (0,0) along two 
separate axes – a horizontal x-axis representing east-west, and a vertical y-axis representing 
north-south.

Munsys utilizes the Oracle database which allows storage, retrieval and updating of spatial and 
attribute data. 

Attribute data is attached to the spatial data for more descriptive information about the spatial 
object, for example pipe types, pipe material and manhole ground levels.

About Oracle Spatial
Oracle Spatial can be defined as an integrated set of functions and procedures that enable the 
user to efficiently store, access and analyze spatial data in an 
Oracle database.

Oracle Spatial simplifies spatial data management for Geographic Information System (GIS) 
users.

Oracle Spatial contains the following components:

 Schema – determines the storage and syntax of supported data types.

 Spatial indexing – quick method for retrieving spatial data from the database.

 Operators – functions for performing area-of-interest queries and spatial join queries.

 Geometry – the spatial attribute of a spatial object is the geometric representation of its 
shape in some coordinate space. This is referred to as its geometry. 
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Indexing of spatial data
Spatial indexing capabilities are one of the key features that differentiate the Oracle database 
from similar databases. Spatial indexing is a mechanism to:

 find objects within an indexed data space that overlap a given point or area of interest 
(window query)

 find pairs of objects from within two indexed data spaces that interact spatially with each 
other (spatial join) 

Spatial indexing in the Oracle database is considered as a logical index. The entries in the spatial 
index are dependent on the location of the geometries in a coordinate space, but the index 
values are in a different domain. 

R-tree indexing or quad tree indexing, or both methods could be used with Oracle Spatial. For 
more information about R-Tree indexing, refer to the Oracle Spatial User’s Guide and 
Reference: Indexing Methods.

About Munsys objects
Munsys objects have been created to cater for the specific needs of the various Munsys 
applications in the AutoCAD environment. A Munsys object is a derivative of an AutoCAD 
entity with additional options for geometry presentation and attribute information.

Munsys objects are presented as the following object types:

 MunPoint – an object containing point information displayed as either a point or symbol, 
for example manholes or pumps. Each MunPoint object may optionally represent multiple 
points (or clusters of points).

 MunLine – an object containing one or more multi-segmented lines (polylines), for 
example roads or water pipes. Each multi-segmented line may be joined by any 
combination of straight or curved lines.

 MunPoly – an object containing one or more polygons, for example parcels or communities 
(suburbs, townships or municipalities). Polygons may be contained as islands within a 
boundary polygon, or may be disjoint in nature.

 MunLabel – an object containing text information representing a specified column in the 
database. This text information is dynamic and changes according to the changes in the 
database.

Regardless of the object type, each Munsys object has the following characteristics:

 Spatial object – the type of spatial data with which the Munsys object is associated.

 MunID – a unique identifier to reference a spatial table within a Munsys schema.

 GID – a unique identifier that identifies a spatial object in a spatial table. This is the index 
key used to retrieve and update relevant changes to an object.

 Tag – a text string used for annotation purposes, displayed at a position using various 
display attributes such as text height, rotation angle and justification.

 Status flags – used to indicate any changes requiring updates to the database. A status flag 
indicates when an object is new or has been modified, or whether it needs to be deleted 
from the database. A list of attributes is attached to the object, used to indicate the 
appropriate modifications.
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Launching Munsys
To launch Munsys, do one of the following:

1 Munsys Applications – on the desktop, double-click the Munsys Applications 14.2 icon.

2 Choose Start > Programs > Open Spatial > Munsys 14.2 > Munsys Applications 14.2

When you log on to Munsys, the configured base map automatically loads.

The Munsys user interface
The Munsys user interface consists of the following:

Figure 16 The Munsys user interface

 Munsys menu bar – contains the Munsys and AutoCAD Map menus. Munsys menus are 
defined by a menu file, which automatically loads when a Munsys application is launched.

 Standard toolbar – contains frequently used AutoCAD Map buttons, the standard 
Microsoft® buttons and Munsys buttons.

 AutoCAD Map drawing area – this area is used to display Munsys data that is retrieved from 
the database and AutoCAD Map drawings.

 Munsys application-specific toolbars – Each Munsys application has its own toolbars that 
display when activated.
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 Drawing Status Bar - displays the connected schema name, the selected application and the 
current GSC Settings

 Munsys main toolbar – contains frequently used Munsys functions. The main toolbar 
contains the following buttons:

Table 1 The Munsys main toolbar buttons

 Munsys Integrity toolbar – contains the integrity check and post to database functions. The 
Integrity toolbar contains the following buttons:

Table 2 The Munsys Integrity toolbar buttons

Use this button When you want to...

...specify GSC settings.

...create a new GSC.

...show the active GSC.

...zoom to the GSC extents.

...zoom to the database extents.

...run a query.

...opens the Munsys Info Palette.

Use this button When you want to...

...validate object integrity.

...validate network integrity (not applicable to the Cadastral 
and Spatial Data Manager applications).

...browse integrity markers.

...erase integrity markers.

...post data to the database.
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Connecting to the Oracle database

1 Do one of the following:

 Choose File > Database > Connect...

 Click the Connect to Database button on the Munsys standard toolbar.

 On the command line, type MUNCONNECT, and then press ENTER.
The Connect to Database dialog box is displayed.

Figure 3 The Connect to Database dialog box

2 In the User Name box, enter your user name.

3 In the Password box, enter your password.

4 In the Schema box, enter the schema name.

5 In the Database box, enter the database.

6 Click OK.

The administrator assigns you user rights to log on to the database, and will inform you what 
your user name, password, schema name, and database are. A successful connection to the 
database activates the appropriate functions on the menu bar and toolbars.

Disconnecting from the Oracle database

1 Do one of the following:

 Choose File > Database > Disconnect... 

 Click the Connect to Database button on the Munsys standard toolbar.

 On the command line, type MUNDISCONNECT, and then press ENTER.
The connection to the database is terminated, and you will only be able to manipulate data once 
an active connection has been restored.

Changing the password used to connect to the database
With this function, you can change the password that you use to connect to the database.

1 Do one of the following:

 Choose File > Database > Change Password...

 On the command line, type MUNPASSWORD, and then press ENTER.



Getting acquainted with Munsys 26 








The Changing password for user [User] dialog box is displayed.

Figure 4 The Changing password for user [User] dialog box

2 In the Old password box, type your current password.

3 In the New password box, type your new password.

4 In the Retype new password box, retype your new password.

5 Click OK to apply the new password.
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Loading the Munsys application of your choice

1 Do one of the following:

 Choose File > Munsys Applications.

 Click the Munsys Applications button on the Munsys standard toolbar.
The Available Applications dialog box is displayed.

Figure 5 The Available Applications dialog box

2 From the list of available applications, select the application that you want to work with, and then 
click OK.

The functions of the application that you selected are loaded on the menus and toolbars,
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About Munsys catalog drawings
The Munsys catalog is defined as a “drawing filing cabinet” that stores extracted data from the 
database in an AutoCAD drawing format. The information about catalog drawings for all the 
users are stored in a central catalog. The drawing is saved in the working directory that was 
specified when the Munsys applications were installed, or can be overwritten by the system 
administrator.

Information about the catalog drawing is stored in the database.

Tip To determine if the system administrator has overwritten the catalog drawing location, open the 
[Application] Settings dialog box. Each application has its own Settings dialog box; for example 
Cadastral Settings, Drainage Settings, etc. The dialog box is accessed by choosing Capture > 
[Application] Settings... 
The location of the drawing directory is shown under the File group in this dialog box.

To write spatial objects to a catalog

1 Choose File > Catalog Drawing > Write...

2 Select the spatial objects that need to be stored as a catalog drawing.

The command line indicates how many objects have been selected to be stored as a drawing.

3 Press ENTER when you are satisfied with your selection – you can add or remove objects from the 
selection set.

The Catalog Drawing dialog box is displayed.

4 Type the catalog drawing description, and then click OK.

Figure 6 The Catalog Drawing dialog box

The command line indicates if the catalog drawing was created successfully. The spatial objects 
stored to the catalog drawing will be removed from the current drawing on your screen.
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To insert spatial objects from the catalog

1 Choose File > Catalog Drawing > Insert...

The Drawing Catalog dialog box is displayed.

Figure 7 The Drawing Catalog dialog box

2 From the list of drawings, select the drawing that you want to insert into the current drawing, and 
then click OK.

The command line indicates if the catalog drawing was inserted successfully.

To browse drawing files in the catalog

1 Choose File > Catalog Drawing > Browse...

The Drawing Browser dialog box is displayed.

Figure 8 The Drawing Browser dialog box

2 From the list of drawings, select the drawing that you want to browse, and then click OK.

3 To delete a catalog drawing, select a drawing, and then click the Delete Highlighted Drawing 
button.

Note The drawing file will not be deleted from the operating system. Only the information about the catalog 
drawing will be deleted from the database.
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About the basemap
When Munsys is launched, a default drawing called Munsys.dwg opens. This drawing is saved 
in the working directory that was specified when the Munsys applications were installed. The 
user can save objects in this drawing to help with orientation when Munsys is launched. The 
drawing can also be used as a template drawing – the AutoCAD unit settings and layer setup 
can be defined in this drawing, as well as other settings such as text styles. These settings will 
therefore not have to be specified each time that Munsys is launched. The same object can be 
saved in the basemap.dwg drawing, which is also saved in the working directory.

The Clear Basemap function can be used to erase all the objects in the current drawing and 
restore the content of the basemap.dwg drawing. 

This function is useful when a set of base information is required after a new drawing is opened, 
or to restore the content of a current drawing. When the Clear Basemap function is executed, 
a confirmation message based on the modified status of the objects in the drawing is displayed.

To clear the basemap

1 Choose Query > Clear Basemap.

The Clear Basemap dialog box is displayed. The content of this dialog box varies according to the 
content of the drawing:

 If the current drawing does not contain any modified or locked objects, the following message 
will be displayed:

Figure 9 Clearing the basemap: no modified objects

 If record locking is enabled in the database and the current drawing contains locked objects or 
objects that have been modified and have not been posted to the database, the following message 
will be displayed:

Figure 10 Clearing the basemap: locked or modified objects

 If record locking is enabled in the database and the current drawing contains locked but not 
modified objects, the following message will be displayed:
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Figure 11 Clearing the basemap: locked or modified objects

 If record locking is disabled in the database, and the current drawing contains objects that have 
been modified and have not been posted to the database, the following message will be 
displayed:

Figure 12 Clearing the basemap: record locking disabled and modified objects

2 Click Yes to clear the basemap.

All objects will be erased and the basemap restored.

3 This function will not automatically zoom to the extent of the basemap.
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Using metadata
Metadata can be described as “data about data”. Metadata plays an important role in industries 
that use information systems and resources. As diverse industries are required to share 
information and eliminate silos of information, it is essential that the critical roles are 
understood that different types of metadata can play in the development of effective, 
interoperable, scalable, and record keeping systems.

With Munsys, metadata is supported at catalogue and collection levels. Users with the 
appropriate edit roles are allowed to edit the metadata for a particular spatial table. A user with 
the MUNSYS_ADMIN role can manage contacts related to metadata records. Metadata for 
spatial tables and database settings can be exported to an XML format.

Managing metadata contacts
This function is used to add new contact detail or manage existing contacts for metadata. The 
MUNSYS_MD_CONTACT table contains the typical contact information that includes 
organization, contact person and address. 

Note The administrator can add more contact information if required. 

To manage metadata contacts

1 Choose File > Metadata > Contacts...

The Metadata Contacts dialog box is displayed.

Figure 13 The Metadata Contacts dialog box

2 To update the Metadata Contacts dialog box, do one of the following:

3 Click the Insert button to add a new contact.

4 From the Contact list, select the appropriate contact to display the details.

5 Click the Delete button to delete an existing contact.

6 Click OK to update the changes.
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Managing spatial tables for metadata
This function is used to update the metadata for spatial tables. The MUNSYS_MD_SPTABLE 
table contains the information that includes the ID for the spatial table, originator of the data 
set, currentness, frequency of updates and the geographical extent of the data set. 

Note Make certain that you have the appropriate editing roles with regard to spatial tables assigned. The user 
requires the appropriate edit roles pertaining to the spatial tables.

To manage spatial tables for metadata

1 Choose File > Metadata > Spatial Table...

The Edit Spatial Table Metadata dialog box is displayed.

Figure 14 The Edit Spatial Table Metadata dialog box

2 To update the metadata for the Edit Spatial Table Metadata dialog box, do one of the following:

 Click the Insert button to add new metadata for a specific spatial table.

 From the Attributes list, select the appropriate metadata to edit.

 Click the Delete button to delete the associated metadata for a specific spatial table.

3 Click OK to update changes.
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Exporting metadata for spatial tables
This function is used to export metadata associated with one or more spatial tables to an XML 
format. The Metadata Export dialog box lists all the spatial tables that contain metadata. This 
function allows the user to export the database extent and tolerance, as well as any number of 
selected spatial tables available in the Select Spatial Table Metadata list.

To export metadata for spatial tables

1 Choose File > Metadata > Export...

The Metadata Export dialog box is displayed.

Figure 15 The Metadata Export dialog box

2 Select the Include Schema Information option to include the schema information in the export 
procedure.

3 Select the appropriate spatial tables from the Select Spatial Table Metadata list.

 Click OK to export the metadata as specified.

Munsys Menu AutoFix
It is possible that the Munsys Menus may get corrupted for some reason. This is often associated 
with customizations or user experimentation. If this happens, Munsys provides a way to Fix 
such menus.

To fix a corrupt menu do the following:

1 Choose File > Restore Munsys Menu...

Your Corrupted Menus should now be repaired. 
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 Chapter 3


 Querying spatial data in Munsys

Introduction
This chapter describes the various query options that are available in Munsys, with particular 
reference to:

 using the Munsys Query palette

 the different objects that can be queried from the database

 specifying and creating a Geographic Search Criteria (GSC)

 adding a spatial view

 querying cadastral data from the database, using both the Query palette and the Query 
menu

 browsing information

 showing information about spatial objects using the Munsys Info palette

 setting different coordinate systems

 creating a Munsys report
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About queries
Queries can be defined as statements or logical expressions that are used to retrieve spatial data 
or records from a database. In Munsys, the data that you work with is queried from spatial tables 
in the database and displayed in the drawing area.

All users accessing the database have query privileges, although they do not necessarily have the 
privileges to update the spatial tables in the database.

Munsys has simplified the query process by providing a list of pre-defined (default) system 
queries for each application on the Query menu and the Query Palette. At least one query for 
every spatial object exists in the MUNSYS_QUERY table in the database.

Users who have the Munsys Query and/or Munsys Edit roles assigned can query data from the 
database using the system queries, and also save their own user-defined queries for re-use. Users 
who have the MUNSYS_ADMIN and MUNSYS_POWER roles assigned can modify the 
system queries for use by all users.

User queries are stored in the MUNSYS_QUERY table in the database. Queried data is 
displayed on AutoCAD layers. When data is queried from the database, Munsys automatically 
generates the required layers, for example sewer nodes are queried onto the SEWNODE layer, 
and residential water pipes are queried onto the WATRESPIPE layer. You don’t have to set up 
any layers before you query data from the database. 

Figure 1 Each object type is displayed on its own layer

Normally, a very large amount of data is stored in the database. In Munsys, data can be 
requested for a specific geographical area, which is formulated by specifying a Geographic 
Search Criteria (GSC). With the GSC and various query functions, Munsys users can retrieve 
relevant data easily in small, “digestible” chunks to ensure a fast processing speed and small, 
workable areas. Before you can retrieve data for a specific area, you first have to specify the GSC. 
Read more about GSC in the following section.

Sewer nodes are queried onto 
the SEWNODE layer.
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Introducing query categories
Query categories are set in the Munsys Management Console and are used to group queries and 
data into an organization’s recognized data categories. The following category types are 
available:

 Uncategorized – by default, any new query (not a user query) is seen as being uncategorized 
until it has been allocated to a category. Queries can be moved to or from the uncategorized 
group, but the category itself is a special case whereby the name may not be changed – only 
the content.

 User – whenever a user creates a new query, it is automatically seen as a personal query, 
hence called a User query. Other users cannot see any other user’s queries until they are 
shared in the pool of Uncategorized or Categorized queries.

 Custom Categories – each category is provided with a unique name. When a new category 
is created, it is automatically granted the MUNSYS_ALL_QUERY role. A category may be 
granted multiple roles.

Munsys provides default custom categories as part of a new schema. The power user has the 
ability to customize these and/or add personal categories. The following categories are created 
in a new schema, synonymous with the Munsys applications and the default roles are granted 
to these categories:

 Cadastral – MUNSYS_CMS_QUERY

 Drainage – MUNSYS_DMS_QUERY

 Electricity – MUNSYS_EMS_QUERY

 Roads – MUNSYS_RMS_QUERY

 Sewer – MUNSYS_SMS_QUERY

 Water – MUNSYS_WMS_QUERY

 Spatial Data Manager - MUNSYS_SDM_QUERY

 Cable Route - MUNSYS_CRS_QUERY

 Cable Fiber - MUNSYS_CFS_QUERY
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Introducing the Munsys Query Palette
The Munsys Query Palette provides a new, alternative interface in which queries, query 
categories and GSCs have been consolidated in order to provide an easy, user-friendly way to 
manipulate these items.

Figure 2 The Munsys Query Palette

The Query Palette is activated in the AutoCAD environment with the MUNQRYPALETTE 
command, or checking the Query Palette item on the Query menu. 

The palette is dockable and remains open until the user closes it. The position and status 
settings of the Query Palette are stored in the registry so that when a new session is started, the 
system restores the palette to the state it was in when the previous session ended.

The Query Palette consists of a toolbar, GSC pane and a Query pane.

Query Palette toolbar

GSC Pane

Query Pane
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The Query Palette toolbar provides access to functions that are common and related to the 
query process.

Figure 3 The Query Palette toolbar

The following buttons are available on the toolbar:

 GSC Settings – used to set properties for the active GSC

 Create New GSC – activates the Unnamed GSC and enables users to create a new GSC.

 Show Active GSC – shows the geometry of the active GSC, relative to its current zoom state

 Zoom GSC Extents – zooms to the extents of the active GSC

 Zoom DB Extents – zooms to the extents of the database

 Query Preferences – provides options to specify settings that will determine the format and 
conditions when spatial data is retrieved from the database

 Run Checked Queries – executes queries that have been checked in the Query pane of the 
Query Palette

 Run Query – displays a list of all the queries that are available to the current user. Queries 
can be selected and then run from this list.

 Browse Info – opens the Browse Info modeless window.
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The GSC pane contains a list of System and user-created GSCs, of which certain properties can 
be manipulated by means of a context-sensitive (right-click) menu. 

Figure 4 Query Palette GSC Pane: Context-sensitive (right-click) menu

You can do the following using the context-sensitive menu:

 Set a selected GSC as the current GSC

 Delete or rename a GSC

 Zoom to and show a selected GSC

 Create CAD objects from a GSC

 Modify certain properties of a GSC

 Add one or more objects to a GSC

 Set the query mask for a GSC
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The Query Palette: Query pane
The Query Palette Query pane contains a tree with a list of queries that have been grouped into 
user queries, categorized queries and uncategorized queries. 

Query categories and queries are manipulated from a context-sensitive (right-click) menu that 
is displayed when a query category or query is selected on the Query Palette.

Figure 5 Query palette: Query context-sensitive menus

You can do the following using the Query and Query Category context-sensitive menus:

 Run all the queries in a query category

 Run checked queries in a query category

 Create a new user query with the Query Details dialog box

 Discard changes that have been made to queries using the Reset and Reset All options. 
Queries that have changed, are marked with a *.

 Run one or more selected queries in a query category.

 Copy, delete or rename a query

 Save a modified query

 Save a query under a different name and in another query category

 Set a filter condition for a query

 Change the properties of a query
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Specifying Geographic Search Criteria (GSC)
GSCs can be created and manipulated from the Query Palette, the Query menu or the 
command line. 

To simplify the retrieval of data from the database, Geographic Search Criteria (GSC) have to 
be defined. A GSC locates spatial objects from the database by their geographical location, 
making use of a polygon, window, fence, radius or object definition. The GSC settings apply 
restrictions on the geographical extent of spatial data extracted from the database.

Multiple GSCs can be created. Where in the past only one set of parameters could be saved to 
be used as a spatial filter, the GSC functionality has now been extended to save these parameters 
under various names. A single GSC is selected as the active GSC, which is used as the spatial 
criteria when spatial objects are retrieved from the database.

One GSC, the Unnamed GSC, is reserved as the default GSC. Whenever a user creates a new 
GSC, the parameters are saved with the Unnamed GSC until it is renamed. When this happens, 
the parameters are saved under the new name, and the Unnamed GSC is left with the last 
parameters used. A user can have as many GSCs saved as is required, but only one GSC can be 
active at a given time. When changing properties of a GSC, this will be applied to the active 
GSC. Whenever changes are made, they are saved directly into the database.

Munsys offers two types of GSCs:

 System GSCs are GSC, created by Systems Administrators, and then saved as System GSC. 
Saving a GSC as a System GSC effectively shares that GSC amongst all users. 

 User GSC are associated with specific users; these GSCs are not shared. The list of GSCs 
presented to the user is filtered by user name. New User GSCs are saved with the currently 
logged on user name.

All GSCs are associated with a user; GSCs may not be shared. The list of GSCs presented to 
the user is filtered by user name. New GSCs are saved with the currently logged on user name.

When a GSC is created, a GSC mask also needs to be specified. The GSC mask determines how 
the GSC is applied as a spatial filter when retrieving data from the database. The following mask 
settings are available:

 Approximate – approximate conditions will retrieve data in the vicinity of the GSC, which 
is a very fast process. The GSC can be defined by means of a polygon, window, circle or 
fence. A GSC with the mask set to approximate is displayed as a dashed line.

 Crossing – retrieves spatial objects within and crossing a GSC. The GSC can be defined by 
means of a polygon, window, circle or fence. A GSC with the mask set to crossing is 
displayed as a dashed line. A point with a buffer can also have a mask of crossing.

 Within – retrieves spatial objects completely within a specified GSC. The GSC can be 
defined by means of a polygon, window or circle. A GSC with the mask set to within is 
displayed as a solid line. A fence and point GSC with a buffer can have a mask of within.
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You can also place a buffer around a GSC. A buffer adds a zone of a specified width around 
the selected GSC, as seen in the following examples:

Figure 6 Buffered GSC

Polygon with islandFencePoint
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Specifying GSC settings
Spatial objects are retrieved from the database using a GSC (Geographic Search Criteria). GSC 
settings apply restrictions on the geographic extent of spatial data retrieved from the database. 
The GSC Settings dialog box is used to specify parameters when a new GSC is created, or to 
change the properties of the current GSC. The GSC Settings dialog box is divided in two tabs: 
GSC Definition and Options. The GSC Definition tab is used to specify the GSC mode 
(whether the GSC is determined by an object or defined manually). The GSC Definition tab 
is only available when the Unnamed GSC is active – the definition of previously saved GSCs 
cannot be changed.

To specify GSC settings

1 Do one of the following:

 Choose Query > GSC > GSC Settings.

 Click the GSC Settings button on the Munsys main toolbar or the Query Palette toolbar.
The GSC Settings dialog box is displayed. 

Figure 7 The GSC Settings dialog box 

2 From the GSC Mode list, select one of the following:

 User-defined – a user-defined geographic search boundary.

 From Object – a selected spatial object is used as the GSC boundary. The command line 
will prompt you to select the spatial object that you want to use as a GSC when creating a 
new GSC. The selected object should exist in the database in order to be used as a GSC.
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3 Select the appropriate GSC type from the GSC Types list if you are creating a user-defined GSC. 
The GSC type could be one of the following:

 Window – a rectangle defined by two points.

 Fence – defined as a polyline consisting of a string of points. You can use the Within mask 
if a buffer is specified. 

 Polygon – a polygon boundary defined by more than two points. The polygon can be any 
shape, but cannot cross or touch itself. Munsys draws the last segment of the polygon so 
that it is closed at all times.

 Circle – a circle defined by a centre point and a radius.

 Point – defined as a single point. You can only use the Within mask option when a buffer 
has been specified around the point.

4 When choosing By Object, the following table explains the type of GSC as a result of selecting an 
AutoCAD object:

5 Next, click the Options tab.

Figure 8 GSC Settings: Options 

AutoCAD object GSC Comment

LWPOLYLINE
LINE
ARC

FENCE LWPOLYLINES with an Open status will result in a fence type 
GSC

MPOLYGON
LWPOLYLINE
CIRCLE

POLYGON LWPOLYLINES with a Closed status will result in a polygon 
type GSC

POINT
BLOCK
TEXT

POINT
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6 From the Object Query Mask group, select the mask type. This will determine the number of spatial 
objects to retrieve from the database.

7 To specify a buffer, do the following:

 From the Buffer Options group, set the Create a Buffered GSC check box.

 Enter the buffer distance in the text box or click the Buffer Options button to specify the buffer 
distance manually in the drawing. This is done by indicating two points in the drawing. The 
straight-line distance between the two points that you specified are populated to the text box.

8 Click OK to save the GSC settings.
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Creating a GSC
A new GSC is created according to the settings that you specified on the GSC Settings dialog 
box. You can create a new GSC from the Query Palette toolbar, the Munsys Main, from the 
Query menu, or from the Munsys main toolbar.

To create a GSC from an object

1 Make certain that you have set the GSC Mode to By Object in the GSC Settings dialog box, and 
that you have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Select the object that you want to use as a GSC, as prompted by the command line. You can use any 
spatial object (both Munsys and CAD objects) in the current drawing to create the GSC from. 

The following figure shows a GSC that has been created using a community (township, 
municipality or suburb) boundary as GSC object, with the mask set to Within. Parcels have 
been queried from the database according to the GSC.

Figure 9 Example of a GSC created by Object

The community boundary has been 
selected as the object to use as a GSC, 
with the mask set to Within. Parcels 
have been queried according to the 
current GSC.
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To create a window GSC

1 Make certain that you have set the GSC type to Window on the GSC Settings dialog box, and that 
you have specified the buffer options (if required) and the appropriate object query mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the first corner of the window.

4 Using the mouse, resize the window, and then click to indicate the second corner.

The following figure shows a window GSC, which has been created with a buffer of 200, and with 
the mask set to Within. The parcels have been queried from the database according to the GSC.

Figure 10 Example of a window GSC

To create a fence GSC

1 Make certain that you have set the GSC type to Fence on the GSC Settings dialog box, and that you 
have specified the buffer options (if required) and the appropriate object query mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the first fence point.

A buffer has been specified 
around the GSC.

A window GSC. 
The GSC outline is 
displayed as a solid 
line, because the 
mask has been set to 
Within.
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4 Indicate the next point(s), and then press ENTER to end the fence definition.

The following figure shows a fence GSC with the mask set to Approximate, and with no buffer 
specified. The parcels have been queried from the database according to the GSC.

Figure 11 Example of a fence GSC

To create a polygon GSC

1 Make certain that you have set the GSC type to Polygon in the GSC Settings dialog box, and that 
you have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

A fence GSC. The GSC outline 
is displayed as a dashed line, 
because the mask has been set 
to Approximate.
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3 Indicate the first polygon point.

4 Indicate the next polygon points, and then press ENTER. 

Munsys automatically closes the polygon by snapping to the first indicated point.

The following figure shows a polygon GSC with the mask set to Within, and with no buffer 
specified. The parcels have been queried from the database according to the GSC.

Figure 12 Example of a polygon GSC

A polygon GSC. The GSC outline is 
displayed as a solid line, because the mask 
has been set to Within.
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To create a circle GSC

1 Make certain that you have set the GSC type to Circle in the GSC Settings dialog box, and that you 
have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the center point of the circle.

4 Using the mouse, resize the circle and then click to apply, or type the radius on the command line.

The following figure shows a circle GSC with the mask set to Crossing, and with no buffer specified. 
The parcels have been queried from the database according to the GSC.

Figure 13 Example of a circle GSC

A circle GSC. The GSC outline 
is displayed as a dashed line, 
because the mask has been set to 
Crossing.
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To create a point GSC

1 Make certain that you have set the GSC type to Point in the GSC Settings dialog box, and you have 
specified the buffer options (if required) and the appropriate mask.

Tip If you do not specify a buffer around the point GSC, the Within mask will be unavailable.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the point that you want to use as a GSC.

The following figure shows a point GSC, with the mask set to Within, and with a buffer of 150 
specified. The parcels have been queried from the database according to the GSC.

Figure 14 Example of a point GSC

A point GSC, with a buffer of 300. 
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To show the active GSC
 Choose Query > GSC > Show Active GSC.

 Click the Show Active GSC button on the Query Palette or Munsys Main toolbar.

The current active GSC is displayed as a dotted outline when the mask has been set to 
Approximate or Crossing, or as a solid outline when the mask has been set to Within. If a 
buffer has been specified, it is showed as a colored outline on the outside of the GSC 
boundary.

Figure 15 Showing the active GSC

To zoom to the GSC extents
 Choose Query > GSC > Zoom to GSC Extents.

 Click the Zoom to GSC Extents button on the Query Palette or Munsys Main toolbar.

This command will zoom to the full extents of the current GSC.



Querying spatial data in Munsys 54 








Converting a GSC to an AutoCAD object
With this function, the current GSC can be converted to an AutoCAD object as a Polyline or 
Point object type, for example if you want to display the GSC in a map. A Munsys point GSC 
will be converted to an AutoCAD point, while all the other GSC types will be converted to 
Polyline objects. If the GSC to be converted was constructed from a Munsys complex object, 
multiple AutoCAD objects will be created for each component of the GSC. For example, if the 
GSC consists of a polygon with an island, the result will be two polyline objects.The AutoCAD 
object is created on the GSC layer. If a buffered GSC is converted, the buffer is stored on the 
GSC_BUFFER layer.

To convert a GSC to an AutoCAD object

1 Do one of the following:

 Choose Query > GSC > Create Object From GSC.

 Choose Query Palette, right-click on the GSC that you want to convert, and then select the 
Create CAD Objects from GSC option on the context-sensitive menu that is displayed.

 On the command line, enter MUNGSCTOCAD.
The current GSC is converted to the appropriate AutoCAD object type and placed on the GSC 
layer. If a buffer was specified, the buffer is placed on the GSC_BUFFER layer.
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GSC functions on the Query Palette
Certain GSC functions can only be performed from the Munsys Query Palette. This section 
discussed these options.

Setting a GSC as current
To set a GSC as the current GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to set as the current GSC, and then 
select the Set as Current GSC option from the context-sensitive menu.

2 The GSC is set as the current GSC and marked as such, as seen below:

Figure 16 Setting a GSC as Current

Deleting a GSC
With this function, you can delete a GSC. The Unnamed GSC or a GSC that has been set to 
Current cannot be deleted.

To delete a GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to delete, and then select the Delete 
option from the context-sensitive menu.

The following message is displayed:

Figure 17 Deleting a GSC

2 Click Yes to delete the GSC.

The GSC entry is deleted from the database.

A GSC set to Current. 
Queries are executed according to 
the current GSC.
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Renaming a GSC
To rename a GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to rename, and then select the 
Rename option from the context-sensitive menu.

Rename the GSC as required.

Figure 18 Renaming a GSC

Save a GSC as System GSC
Power-users and Systems administrators also have the functionality to save an existing GSC as 
a System GSC. A System GSC is any GSC that is shared between all users but can only be edited 
by admin users. To Create a System GSC follow these steps:

 Create any GSC using the functionality explained above.

 On the Query Palette GSC Pane, select the GSC that you just created (or any GSC you 
want to use as System GSC), and then select the select the Save as System GSC option from 
the context-sensitive menu. You will notice that the System GSC is now listed with a 
different icon.

Figure 19 System GSC
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Changing the properties of a GSC
Certain properties of the current GSC (unnamed or saved) can be changed using the GSC 
Settings dialog box. Changes to previously saved GSCs can be made to the query mask and the 
buffer options. The GSC Mode of saved GSCs cannot be changed, and the GSC Definition tab 
of the GSC Settings dialog box will remain unavailable. Changes made to the GSC properties 
are saved directly to the database. 

1 On the Query Palette GSC Pane, select the GSC that you want to modify, and then select the 
Properties... option from the context-sensitive menu.

The GSC Settings dialog box is displayed, showing the Options tab.The name of the GSC that is 
being changed is displayed on the title bar.

Figure 20 The GSC Settings dialog box: Options tab

2 Change Object Query Mask and/or the Buffer Options as required, and then click OK.

Adding objects to a GSC
With this function, you can add objects to the active GSC when the GSC Definition Mode has 
been set to From Object. When objects have been added, they cannot be removed, and a new 
GSC has to be created. This function can also be executed from the command line using the 
MUNGSCADDOBJ command. This function can only be used when 
MUN_DB_SETTINGS table in the Oracle database has the following row set (for Oracle EE 
license): Insert into MUNSYS_DB_SETTINGS the values ('S', 'MUNSYS_EE', 'T', 'Munsys 
Edition').

1 To add objects to a GSC, do one of the following:

 On the Query Palette GSC pane, select the current GSC, and then select the Add Object(s) 
to GSC from the context-sensitive (right-click) menu.

 On the command line, enter MUNGSCADDOBJ.

2 Select the object that you want to add to the GSC (the current GSC is highlighted), and then press 
ENTER.
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3 Repeat Step 2 until you have selected all the objects that you want to add to the GSC.

The object(s) that you have selected are added to the GSC.
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Querying data from the database using the Query Palette
This section describes how to query data from the database using the Query Palette. You can 
do the following:

 Specify query preferences

 Create new queries and specify and change properties for queries

 Run queries

Specifying query preferences
The Query Preferences function is used to specify settings that will determine the format and 
conditions when spatial data is retrieved from the database. These options are stored in the 
registry and do not have to be set every time a new Munsys session is started. The following 
options are available:

 Use GSC – if this option is selected, the currently active GSC is applied as a spatial filter 
when the required objects are retrieved from the database.

 Create CAD Objects – if this option is selected, the objects are retrieved from the database 
as AutoCAD drawing objects instead of Munsys objects.

 Attach Object Data – if this option is selected, attributes will be attached to the objects that 
are retrieved from the database. The objects may be Munsys or AutoCAD related. The 
attributes are always obtained from the primary spatial table. If the query is associated with 
a data group that relates the object(s) to an attribute table, the attribute will also include the 
columns from the retrieves all parcels or communities according to their status. (This 
option is only available when Munsys is run on AutoCAD Map.)

To specify query preferences, do the following:

1 Click the Query Preferences button on the Query Palette toolbar. (This function is also available 
on the Munsys Applications Query menu and the Munsys Main toolbar).

The Query Preferences dialog box is displayed.

Figure 21 The Query Preferences dialog box
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Select or clear any of the following check boxes:

 Use GSC – select this option if you want to apply the currently active GSC as a spatial filter 
when the objects are queried from the database.

 Create CAD objects – select this option to query the objects from the database as AutoCAD 
drawing objects instead of Munsys objects.

 Attach Object Data – this option is only available when Munsys is run on AutoCAD Map. 
Select this option if you want attributes to be attached to the objects that are queried from 
the database. The objects may be Munsys or AutoCAD related. The attributes are always 
obtained from the primary spatial table. If the query is associated with a data group that 
relates the object(s) to an attribute table, the attribute will also include the columns from 
the attribute table.

2 Click OK to apply the settings.

The settings are saved in the registry under the [HKEY_CURRENT_USER\Software\Open 
Spatial\Munsys[version]\Applications\Options key]

Creating a user-defined query
User-defined queries are created with the Query Details dialog box. Specific properties for each 
query are set using the Query Properties dialog box.

To create a user-defined query, do the following:

In the Query Palette Query pane, Select the New Query... option from the context-sensitive 
menu, as seen below:

Figure 22 Create New Query

The Query Details dialog box is displayed.
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Figure 23 The Query Details dialog box

3 Enter the following information:

 Query Name – enter a unique name for the new query. If a similar query already exists, you 
will be notified with an error message.

 Based on Spatial Object – select a spatial object to base the query on.

 Query Priority Order – enter a value between 0 and 100. A low number means that the 
query will be executed before queries with higher numbers. This means that queries with a 
higher number will be executed towards the end of the query process, causing the objects 
with a higher priority to be placed on top of the objects queried from queries with a low 
query priority.

4 Click OK to save the new query.

The query is saved and displayed in the list of available queries.

Specifying or changing query properties
The Query Properties dialog box is used to modify existing queries and to specify settings for 
user-defined queries. Using this dialog box, you can specify the formatting properties and 
informational data that is used as input to the query process. Because queries result in different 
object types, regardless of whether they are Munsys objects or AutoCAD objects, each object 
type has its own unique set of properties that may be changed to influence the outcome of the 
data that is retrieved from the database. These properties primarily include the display 
formatting options, but also allow the user to change the reference to data.

Because each object type has its own unique set of properties that may be modified to influence 
the outcome of the data, the contents of the Query Properties dialog box will vary according to 
the object type of the query that has been selected. These properties primarily include the 
display formatting options, but also allow the user to change the reference to data. Properties 
are changed using the context-sensitive (right-click) menu that is displayed when a property is 
selected.
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The contents of the Query Properties dialog box is displayed two panes:

 Property Category – the left pane contains the names of the various property categories. 
Clicking a category affects the contents that are displayed in the right pane, the Category 
Pane. 

 Property Items – the right pane, the Property pane, contains a list of properties that is 
determined by the property category being selected.

The Query Properties dialog box is displayed:

Figure 24 The Query Properties dialog box

All queries have the following properties:

 Base Properties: the basic properties of the query, for example the layer name, the object 
type, the query category of the query, the query name, the query priority order, etc.

Note The Base Properties option Filter objects by GSC is used to specify whether you want the current GSC 
applied to the query. When this option is set to Yes (the default), the objects will be retrieved from the 
database according to the GSC settings of the Current GSC. If you change the setting to No, all the data 
from the specific spatial table will be retrieved from the database.

Figure 25 Query Properties: Filter by GSC
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 Filter Condition: allows the user to specify criteria that will be used to filter the data during 
the query process 

 Table Information: the Linked Table property may be changed using the context-sensitive 
(right-click) menu, which displays the Linked Table Information dialog box. All other 
tables are inherited when the query was created.

Figure 26 Table Information: Properties

Figure 27 The Linked Table Information dialog box

Depending on the object type, various other query properties are displayed for a selected query, 
for example a MunPoint object will display Symbol Properties and Tag Properties, while a 
MunPoly object will display Polygon Properties and Tag Properties. All properties are changed 
using the context-sensitive (right-click) menu that is displayed when a property is selected, as 
seen in the following example:
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Figure 28 Query Properties: Context-sensitive menu

Querying data as AutoCAD objects - Improvement

When the user requires to query data as plain AutoCAD objects, it is important to ensure this 
is done effectively requiring minimum effort. To ensure the easy transition and querying of 
Munsys objects as AutoCAD objects this feature has been refined thereby removing the “@” 
prefix before the TableName.LayerName. This can be found by Navigating to the Layer > Right 
Click Properties > Symbol Properties > Selecting the relevant field > Right Click > Expression.

Figure 29 Query Properties: Layer
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Figure 30 Symbol Properties: Expression

Specifying a filter condition for a query
A Filter Condition allows users to specify criteria that will be used to filter the data during the 
query process.

A filter is optional and when present, consists of one or more SQL statements that will are sent 
to the database. The conditions are specified using the SQL syntax. The expression syntax 
should be correct, otherwise the query will fail.

The conditions that apply to the query are listed in the Property Pane, as seen below:

Figure 31 Filter condition: Parcels query

Conditions are added or removed using the context-sensitive (right-click) menu. The sequence 
in which the conditions appear (from top to bottom) is the sequence in which they will be 
executed.
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Figure 32 Filter condition: Context-sensitive menu

The first condition must not have a Joiner (AND/OR), but from the second condition on this 
is required. When the query is executed, the conditions are concatenated to form a single 
combined expression. When column names are used, they are prefixed with the table name as 
in: SP_WATPIPE.PIPE_MATRL

This rule applies even if there is only one table associated with the query, because the query may 
eventually be joined with the MUNSYS_GSC table in order to filter on spatial characteristics 
of the data.

The Filter Condition context-sensitive (right-click) menu is used to edit existing conditions, or 
add new conditions.

 Remove Condition – deletes the condition

 Edit Condition – edits the condition as a SQL expression

 Add Condition – allows the user to add a new condition to the end of the list of conditions. 

 Clear All Filter Conditions – removes all conditions

 Check Syntax – verifies the syntax of the combined set of expressions

Adding a condition to a query
To add a condition, do the following:

1 Right-click on the query to which you want to add the condition, and then select the Filter 
Condition... option on the context-sensitive menu.

The Query Properties dialog box is displayed.

2 In the content pane, right-click on Condition List, and then select 
Add Condition... from the context-sensitive menu

The Add Condition dialog box is displayed.
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Figure 33 The Add Condition dialog box

3 Specify the following:

 A Joiner – the joiner is used to join a previous condition to a new condition, and is 
unavailable when the first condition is set for a query. Available values in the down list are 
AND and OR. When the joiner is selected, the other fields become available.

 Column – this list is populated with a list of all the columns from all the tables that may be 
referenced by the query. All the columns are prefixed by the table name.

 Operator – the Operator is used to specify how the value from the column will be compared 
to the value specified in the Value text box. This list is populated with the following values:

 = Equal To

 > Greater Than

 >= Greater Than or Equal To

 < Less Than

 <= Less Than or Equal To

 <> Not Equal To

 Like SQL “LIKE” command (value to be prefixed or suffixed with %)

 In SQL “IN” command (values to be comma delimited as in: ‘A’,’B’,’C’)

 Is Null SQL “IS NULL” command (no value allowed)

 Is Not Null SQL “IS NOT NULL” command (no value allowed)

 Value – select one or more values that will be used as comparison value against all values 
from the specified column. Use the Value button to select the value(s) from the database, 
as seen in the following example:
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Figure 34 Add Condition: Unique values

 SQL Equivalent – this field is populated when the other field have been filled in.

4 Click OK to add the condition to the list of conditions.

The condition is added to the Condition list, and the modified query is marked with a * in the query 
list.

Figure 35 Condition added to the list

5 To save the changes to the query, right-click on the query, and then select the Save or Save As... 
option on the context-sensitive menu.
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Figure 36 Saving changes to a query
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Executing queries from the Query Palette
Queries can be executed from the Query Palette by:

 Selecting the Run All Queries in Category option from the context-sensitive menu that is 
displayed when a query category is selected

 Checking the queries that you want to run (you can select queries from various query 
categories), and then selecting the Run Checked Queries option on the context-sensitive 
menu

 By clicking the Run Query button on the Query Palette toolbar, and then running selected 
queries from the Query List dialog box (this option is also available on the Munsys 
Applications Query menu and Main toolbar)

Figure 37 Query execution options
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Running checked queries from the query list
On the Query Palette Query pane, you can run multiple queries by selecting the check boxes 
adjacent to the relevant queries. You can also use the MUNQRYMULTIPLE command for this 
purpose. Before the queries are executed, they are sorted according to their query priority query 
priority order.

The queries that have been selected are run in order of their query priority; queries with a 
priority of 0 are run first, followed by queries with a higher number. As the queries are run, 
feedback about the number of objects retrieved is provided on the command line.

1 To run multiple checked queries, do one of the following:

 On the Query pane, select the check box(es) adjacent to the query or queries that you want 
to run, and then click the Run Checked Queries button on the Query Palette toolbar or the 
context-sensitive menu.

 On the command line, enter MUNQRYMULTTIPLE, and then follow the prompts.

The objects are retrieved from the database in their query priority order, and the command line 
shows the number of objects that are retrieved from the database for each query.

Running multiple queries using the Query List dialog box
A selection of one or more predefined queries can be run using the Query List dialog box, which 
can be called from the Query Palette toolbar, the Query menu, or the command line. The list 
of queries on the dialog box shows the name of the query, the category it belongs to and its 
priority, in descending order. 

Tip The list can be re-sorted by clicking on the appropriate header. 

The list of queries that is displayed on the dialog box is dependent on user privileges. This is 
firstly restricted by the roles assigned to the user, since the query categories restrict access to the 
queries in the category through roles. Secondly, access to queries is also restricted by the 
privileges assigned to the user with regard to the tables referenced in the queries. 

The queries that have been selected are run in order of their query priority; queries with a 
priority of 0 are run first, followed by queries with a higher number. As the queries are run, 
feedback about the number of objects retrieved is provided on the command line.

Tip Use the Query Preferences button on the Query List dialog box to specify query preferences in the 
Query Preferences dialog box before the queries are executed.

1 To run multiple queries using the Query List dialog box, do one of the following:

 Click the Run Query button on the Query Palette toolbar.

 Choose Query > Run Query.

 Click the Run Query button on the Munsys Main toolbar.

 On the command line, enter MUNQRYRUN.
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The Query List dialog box is displayed.

Figure 38 The Query List dialog box

2 Select the queries that you want to run from the list of available queries. Use the Query Preferences 
button to specify query preferences before the list of queries is run, as seen in the example above.

3 Click the Run button to run the selected queries.

The queries are run according to their query preference, and the command line displays the 
number of objects that were retrieved from the database for each query.

Tip You can use the context-sensitive (right-click) menu on the Query List dialog box to check or uncheck 
all the queries in a specific category.

Figure 39 Query List dialog box: context-sensitive menu
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Adding a spatial view
The Add Spatial View function is used to map an existing external (non-Munsys) spatial table 
so that Munsys may recognize it as a “Munsys table”, and that the data in the table can be 
queried using Munsys Applications.

Important To be able to create a view on a table that resides in another schema, you need the SELECT 
privilege on the view. In order to grant the SELECT privilege on the newly created view to the Munsys 
roles you need to have the SELECT... WITH GRANT OPTION privilege on the original table granted to 
you (not through a role). For more details on granting the correct privileges, consult the appropriate Oracle 
documentation.

To create a spatial view for an external table, the following is required:

 The name of the schema where the existing spatial table resides.

 A spatial table that contains one MDSYS.SDO_GEOMETRY column. The Add Spatial 
View dialog box displays a list of tables that qualify. The qualification filter ensures that the 
table has sufficient user privileges to create a view on the table and to grant the SELECT 
privilege to Munsys roles, contain an SDO_GEOMETRY column and have a unique 
NUMBER ID column as primary index.

 A geometry type (point, symbol, label, line or polygon) that will be used throughout the 
table – this means that the complete set of records encountered in the table must all share 
the same geometry type.

 A unique name and description string used to identify the spatial view within the Munsys 
schema.

When executed, the function creates a view in the Munsys Schema, adds entries to the system 
tables and creates a system query that may be used as the default query. This system query will 
not query any tag information, but can be edited for this purpose, using the query palette. A 
spatial view that is no longer required can be removed using the Remove Spatial View function.

Note If the user doesn't have the required privileges to create a view on the selected table, an error message is 
displayed. This error normally only displays if the user doesn't have the SELECT privileges granted to 
the schema owner directly (not through a role). This error also indicates that the WITH GRANT 
OPTION is required. (The WITH GRANT OPTION is an additional clause that gives the necessary 
privileges to grant privileges on the newly created view to the default Munsys roles.) The following SQL 
statement is an example of the statement that should be used by the database administrator to grant the 
required privilege to the Munsys schema owner: grant select on schema name.sp_tablename to schema 
owner with grant option; 
When this error message is displayed, you will have to cancel the creation of the view, and then reconnect 
to the database after the correct privileges were granted by the database administrator as indicated above.
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To add a spatial view

1 Connect to the Oracle database as the owner of a Munsys schema. This is done by selecting the same 
user name and schema name when logging on to the database using the File > Connect to Database 
menu option, or the Connect to Database toolbar button.

2 On the command line, enter MUNADDSPVIEW.

The Add Spatial View dialog box is displayed.

Figure 40 The Add Spatial View dialog box

3 In the Original Table group, do the following:

 From the Schema Name list, select the schema where the spatial table resides. (Only schema 
names that contain tables with at least one column with a data type of SDO_GEOMETRY 
are displayed in this list.)

Figure 41 Selecting the schema name to create a spatial view

 From the Table Name list, select the name of the spatial table. The table must contain an 
SDO_GEOMETRY column. After selecting the table from the list, a check will be done to 
ensure that a primary index, referencing a NUMBER column, exists on the table. This 
column will automatically be mapped as the GID column to uniquely identify each spatial 
object. If this check fails, the following message is displayed: “This table does not contain 
an appropriate primary key constraint. A primary key constraint must exist on a numeric 
column to uniquely identify each individual spatial object”.
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Figure 42 Selecting a spatial table name from the list

 From the Geometry Column list, select the appropriate columns that you want to use. This 
list only becomes available when there is more than one geometry column in the table. If 
only one column is present in the table, this column will be selected automatically.

4 In the Spatial Characteristics group, do the following:

 In the View Name field, enter the name of the view that you are creating. The name will 
prefixed with SP_ and will have the same restrictions as are applied to a Munsys spatial table 
with regard to naming conventions such as length, etc.

 In the Spatial Object Description field, enter a unique description for the spatial layer. This 
description will be displayed when the spatial data is queried.

 From the Geometry Type list, select the geometry type of the objects that the table will be 
associated with. The options available in the list will depend on the geometry type that is 
currently stored in the table. The following options are available:

 Lines – in the case of lines or polylines this option will be unavailable and will be defaulted 
to lines.

 Polygons – in the case of polygons, two options will be available; Polygon and LW Poly-
gon. The LW Polygon option allows you to query polygon objects as objects that are 
derived from the LWPOLYLINE object, instead of objects that are derived from the 
MPOLYGON object. 

 Points – if the original table contains points, thee options will be available; Point, Symbol 
or Label. The geometry of the SDO_GEOMETRY column will be used to represent a 
point or a label (text). The Point and Symbol options do not differ much, but are named 
this way to cater for both terms, as not all users would want a symbol to represent the 
geometry, but rather a AutoCAD point. The Label option will use the geometry to repre-
sent the insertion point of the text.
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Figure 43 Specifying the spatial characteristics of the view

5 Click OK to create the spatial view as specified.

Munsys creates the view, inserts it into MUNSYS_SP_TABLES, creates the associated system 
query and grants SELECT privileges to the view.

Figure 44 Spatial View Added confirmation message

Note The process that creates the spatial view will use columns in the original table that conform to the default 
Munsys naming convention. All additional columns required that do not exist in the table will be added 
to the view. This will ensure that the structure of the view is based on the required structure as expected 
by Munsys. The structure of the view is determined by the type of geometry selected as explained above. 
The column name and data types of columns in the view are important, but the Oracle database 
administrator can edit the view through another interface to influence the values represented by the 
columns, as long as the column names and data type of the columns above the GEOMETRY column are 
not influenced. The default system query that is created can be modified using the query palette to 
overwrite many of the values in the view, for example Tag Value, Tag Justification, Tag Style, Tag 
Height, Symbol Name, Symbol Scale, etc.
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Removing a spatial view
The Remove Spatial View function is used to remove previously added external spatial tables 
from the Munsys system tables. Entries referencing the view are removed from the 
MUNSYS_SP_TABLES and MUNSYS_QUERY system tables, and the view is dropped. 

Note The function only removes the view, and does not drop the original spatial table to which the view refers.

To remove a spatial view

1 On the command line, enter MUNREMOVESPVIEW.

The Remove Spatial View dialog box is displayed.

Figure 45 The Remove Spatial View dialog box

2 Select the spatial view that you want to remove, and then click the Remove button.

Entries referencing the view are removed from the MUNSYS_SP_TABLES and 
MUNSYS_QUERY system tables, and the view is dropped.
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About cadastral data
The term cadastral refers to a map or survey showing administrative boundaries and property 
“lines”. Cadastral data is defined as an official register of the ownership, extent and assessed 
value of land for a given area, and also as the geographic extent of the past, current, and future 
rights and interests in real property including the spatial information necessary to describe that 
geographic extent. In Munsys, cadastral data is used as the base data set.

Munsys uses the following cadastral base data:
 Communities – a community is a residential area containing one or more legal boundaries, 

and can be a township, suburb or municipality.

 Parcels – a distinct portion of land, which is captured from a registered plan by means of 
coordinates or angles of direction and distance. Parcels are important spatial data in the 
Munsys system, as many of the capture functions rely on the location of parcels.

 Blocks – a block boundary binds a group of parcels with the edges of the road reserve, and 
is used to represent the cadastral data on a higher scale when the detail of the parcels is not 
required.

 Easements – a registered area attached to a parcel for the benefit of the local authority. This 
area is used for the installation of services or right of way; therefore the landowner is not 
allowed any permanent construction.

 Buildings can be classified as different types according to the default values set up by the 
system administrator. New building types can be added to the list of available building 
types.

 Street names and addresses – legal street names are assigned to sections of the road reserve 
and display as text. The address information is assigned at a specific point within the parcel 
polygon. In some cases, parcels can have more than one point of entry, and are therefore 
assigned multiple address points.

 Cadastral notes – additional notes pertaining to cadastral objects.
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Querying cadastral data from the database from the Query menu
The following section explains how to query cadastral data from the database using the pre-
defined (default) queries that are available on the Query menu of each Munsys application. For 
more “refined” queries, you can use the functions on the Query Palette, with which you can 
create customized queries.

Querying suburbs
Communities (suburbs, townships or municipalities) are queried from the database according 
to the current GSC, or by a selected community name. Suburbs are displayed as polygons 
(MUNPOLY objects).

To query communities by name

1 Choose Query > [Suburbs] > By Name...

The Select [Suburb] dialog box is displayed, showing a list of all the available suburbs with their 
associated codes. The list of suburbs can be sorted ascending or descending, according to the 
municipality code or description.

2 From the list of suburbs, select the suburb that you want to query, and then click OK.

Figure 46 Querying a suburb by name

Tip If you want to query more than one suburb, press and hold down the SHIFT key (to select consecutive 
suburbs), or press and hold down the CTRL key, and then select each suburb that you want to query. You 
can also search for a specific suburb by its name by selecting the Description button, and then entering 
the first few letters of the name, or search for a name by its code by selecting the Code button, and then 
entering the applicable code.

The suburb boundary is 
queried onto its own 
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Figure 47 Querying more than one community at a time

To query suburbs by GSC
 Choose Query > [Suburb] > By GSC.

The suburb boundaries are retrieved according to the GSC settings and the current GSC.

Figure 48 Querying suburbs by GSC

Window GSC with the mask 
set to Within, and shown as a 
solid outline.

The Fairview municipality 
boundary, queried according to 
the current GSC.
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Querying parcels
Parcels are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects). Parcels with a legal status of Current are queried onto the 
PARCEL_C layer, and parcels with a legal status of Proposed are queried onto the PARCEL_P 
layer. 

To query parcels
 Choose Query > Parcels.

The command line shows how many parcels were retrieved according to the current GSC. 

Figure 49 Parcels queried from the database according to the current GSC
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Querying block boundaries
Block boundaries are queried from the database according to the current GSC, and are 
displayed as polygons (MUNPOLY objects). Block boundaries are placed on the BLOCK layer.

 Choose Query > Block Boundaries.

The command line shows how many block boundaries were retrieved from the database 
according to the current GSC.

Figure 50 Querying block boundaries

Polygon GSC, with the 
mask set to Within, and 
shown as a solid outline.

Block boundaries are queried onto the 
BLOCK layer.



Querying spatial data in Munsys 83 








Querying easements
Easements are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects) or lines (MUNLINE objects). Easements that are queried from 
the database are placed on layers according to their object type and easement type, for example 
a line-type easement with an easement type of General will be queried onto the 
EASELINE_GENERAL layer, while a easement polygon with an easement type of Reserve will 
be placed on the EASEPOLY_RESERVE layer. Easement text is queried onto either the 
EASEPOLYTXT or EASLINETXT layers, depending on the object type of the easement.

To query easements
 Choose Query > Easements.

The command line shows how many easement lines, polygons and text respectively were 
retrieved according to the current GSC.

Figure 51 Querying easements

Easement line text is queried onto 
the EASELINETXT layer.

An easement line, queried onto its 
appropriate layer
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Querying street names
Street names are queried from the database according to the current GSC, and are displayed as 
labels (MUNLABEL objects). Street names are placed on the STRTXT layer.

To query street names
 Choose Query > Street Names.

The command line shows how many street names were retrieved from the database 
according to the current GSC.

Figure 52 Querying street names

Tip If the insertion point of the text falls outside the current defined GSC, the text item will not be queried 
from the database
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Querying street addresses
Street addresses are queried from the database according to the current GSC, and are displayed 
as labels (MUNLABEL objects). Street addresses are placed on the STRADDR layer.

To query street addresses
 Choose Query > Street Addresses.

The command line shows how many street addresses were retrieved from the database 
according to the current GSC.

Figure 53 Querying street addresses

Tip If the insertion point of the text falls outside the current defined GSC, the text item will not be queried 
from the database

Street addresses are queried 
onto the STRADDR layer
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Querying buildings
Buildings are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects). Buildings are placed on the BUILDING layer.

To query buildings
 Choose Query > Buildings.

The command line shows how many buildings were retrieved from the database according 
to the current GSC.

Figure 54 Querying buildings

Buildings are queried onto the 
BUILDING layer
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Querying cadastral notes
Cadastral notes are queried from the database according to the current GSC, and are displayed 
as labels (MUNLABEL objects). Cadastral notes are queried onto the 
CMSNOTE_NOTE_TYPE_TEXT layer.

To query cadastral notes
 Choose Query > Cadastral Notes.

The command line shows how many cadastral notes were retrieved from the database 
according to the current GSC.

Figure 55 Querying cadastral notes

Cadastral notes are queried onto the 
CMSNOTE_NOTE_TYPE_TEXT layer
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Browsing information
The Browse function is used to browse the contents of one or more tables or views of a currently 
logged on schema. The user privileges and access rights assigned determine the list of tables, 
views and queries that are available for browsing.

The browse selection opens a re-sizable mode-less browsing window so that the user can view 
the queried objects in the drawing while browsing the attribute information in the browsing 
window. Multiple Browsing windows can be opened simultaneously to view attribute data for 
different spatial objects, for example Sewer Pipes and Sewer Nodes.

Using the Browse Info... menu option the user is presented with the Browse Selection dialog 
box with a Queries tab and Table/Views tab as the first step to identifying the source of the 
content to browse. The Queries tab displays all system and user defined queries available to the 
user according to their assigned roles and privileges. The Tables/Views tab allows the user to 
browse information directly from tables, views, lookup tables, attribute templates or queried 
objects in the drawing according to their assigned roles and privileges.

Browse Selection
When initiating the browse command from the Query > Browse Info... menu item or from 
typing the command MUNBROWSE in the command line, the user is presented with the 
Browse Selection dialog box which has the following two tabs:

 Queries tab - displays a list of all user and default system queries available to the user 
dependent on their roles assigned.

 Tables/Views tab - displays a list of table items that are available to the user dependent on their 
roles assigned.

On the Queries tab the user is presented with a list of Query Categories which, when expanded, 
display a list of User Queries and default System Queries. The availability of query categories and 
their associated queries is dependent on the roles assigned to the user. A user with the role 
MUNSYS_ALL_QUERY will have access to view all the spatial tables in the database.

Figure 56 Browse Selection - Queries tab
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Figure 57 Browse Selection - Tables/View tab

Tip The Browse function can also be initiated by typing the command MUNBROWSE on the command line.

Browsing Info using predefined Queries
The user can select a user defined or system defined query to browse attribute information from 
the database. The query properties and filter conditions saved with the query determine what 
information is displayed in the Browse window.

To browse info using a predefined query

1 Do one of the following:

 Choose Query> Browse Info...

 or type MUNBROWSE on the command line
The Browse Selection dialog box is displayed

2 Expand the query category required, highlight the query to browse from the list of queries on the 
Queries tab and then click OK.
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Figure 58 Selecting the table to browse from a list of predefined queries

Once the query has been selected, the result is populated to the Browsing Info window and is 
displayed in a table or grid format, including a row for every record and a column to specify the 
type of attribute information available. The Browsing window is menu driven and is sensitive 
to content selection. The result set can be refined by applying filters. The active result set is used 
at all times as input to the functions available on the menus. 

The following menu items are available on the Browsing Info window:

 File – generates reports from the active result set, which allows the termination of the 
browse using the Close function.

 Edit – the user is allowed to copy selected rows to the clipboard, find a specific value or go 
to a specific record number as well as edit attributes or linked attributes for selected records.

 View – determines the result set by applying various filters and applying formatting of 
values.

 Records – this menu is only applicable when the primary table is a spatial table. The user 
can determine the spatial objects to query and once queried, can zoom to the spatial objects 
in the drawing and/or highlight equivalent objects.

Important This function will not allow a user to browse information from views if the join on the two 
tables does not consist of a primary key on any of the two tables. The user will be presented with Oracle 
error: ORA-01455: cannot select ROWID from, or sample, a join view without a key-preserved 
table. To prevent this error you need to add a primary key constraint or unique index to one of the tables 
used to define the view.
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Figure 59 The Browsing: Info window

Tip All column headers are sortable (toggle between ascending or descending) when selected in the Browsing 
result set.
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The Browsing Info Window

Open queries for Browsing
The user can browse the contents of one or more tables or views without exiting the Browsing 
Info window by selecting the File > Open... menu item where the user will be presented with a 
dialog box of predefined user and system queries to select from. Selecting a query will populate 
the result set in the Browsing Info window and any attribute conditions assigned to the selected 
query will be applied to the result set.

Generating reports
This function allows the user to save the current result set to a Comma Separated Value file 
(CSV). The user is presented with the standard Save As dialog box, and navigates to the required 
path for saving the result set. The output format is a standard text file where the comma 
character (,) usually separates each field of text. Due to the simplicity of a CSV file, it is 
compatible with various other applications.

1 On the Browsing Info window, choose File > Report to file...

The Save As dialog box is displayed.

2 Navigate to the appropriate folder, and then type the file name in the File Name text box.

3 Click Save.

4 The information bar on the dialog box displays the number of records that were saved.

Note The report is set to save as a CSV file by default, but the user has the option to save the report as a TXT 
or HTML file by selecting the Save as type: drop down list.

Editing Attributes
The Edit > Edit Attributes... menu item prompts the user to select one or more spatial objects 
from the drawing to edit. Once the selection has been made the Edit Attributes dialog box is 
displayed allowing the user to edit the spatial object attributes that belong to the same object 
type. (See Chapter 4-32)

The current application determines what object types may be selected; for example, if you are 
working in Munsys Sewer, only sewer objects may be selected. The command line prompts the 
user to select the type of object expected, for example: Select water objects:

If you select more than one object type, for example sewer pipes and sewer nodes, you will be 
required to choose a single object type to edit.

Editing Linked Table Attributes
The Edit > Edit Linked Table Attributes... menu item prompts the user to select one or more 
spatial objects from the drawing to edit. Once the selection has been made the Linked Table 
Attributes dialog box is displayed allowing the user to edit the attributes for the linked table. 
(See Chapter 4-35)

If no linked table has been defined a No Linked Table warning message is displayed 
No attribute templates exist with appropriate linked tables.
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Finding results
The Edit > Find... menu item searches through the entire result set, finds the matching record(s) 
and allows you to select a record from the Find Info results and locate and highlight the record 
in the Browsing Info results set. 

On the Find dialog box, you must enter the value(s) to search for, as well as indicate the column 
in which to search. The columns available from the lookup list includes columns from linked 
tables, as well as columns that were not identified as available columns when browsing the data. 
The search operation can be refined by applying more search parameters including an exact or 
partial match. 

Tip The search is affected by the Display Formatted Values option (available on the View menu). If this 
option is active the search will ignore the raw values and search for formatted values. The value in the 
search is case sensitive at all times.

Figure 60 Finding records by applying search criteria

Finding a row number
The Edit > Goto Row Number menu item allows the user to search for a specific row number 
within the result set. If the required row number is found, it is displayed and selected. Should 
the required row number not be found, a message to this effect will be displayed.

Copying results

The Edit > Copy menu item allows users to copy a selection from the result set to the clipboard 
for pasting into other applications. Column headings are copied with the selected records. 
Columns and records are comma delimited text and may be pasted to any application that 
accepts text.
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Filtering by attributes
With the Filtering by attributes function, you can filter the current result set by applying an 
attribute filter that is constructed by attribute conditions. Once the attribute conditions are 
applied on the current result set, it is refreshed with the new values. The Attribute Condition 
dialog box is used to construct the filter that will be used to apply to the initial result set. For 
users who are not familiar with SQL statements, Munsys provides drop-down lists in the order 
required to easily construct the applicable filter. The Attribute Condition is used to construct 
complex filters that contain more than one attribute condition.

1 Choose View > Filter by Attributes...

The Attribute Conditions dialog box is displayed showing the existing conditions applied to the 
query.

Figure 61 The Attribute Condition dialog box

2 To define a condition statement, the user can either edit or remove the existing attribute conditions 
or add additional attribute conditions. To add attribute conditions select do the following:

 Select the Add button to display the Add Condition dialog box.

Figure 62 The Add Condition dialog box
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 From the Column drop-down list, select the appropriate column to determine the criteria.

 From the Operator drop-down list, select the operator that best suits the condition that you want 
to check. Operators include <=, =, >=, etc. Use these operators to produce the desired spatial 
result.

 In the Value option, enter the criteria that will be tested against the value of the column and that 
qualifies the condition operator.

Tip You can select the Values... button to get a list of unique values from the database for the column selected 
for the criteria. The list is limited to display the first 50 records, but by checking the Show All check box 
all the values in the database for the selected column are displayed.

 Click the OK button to add the condition to the Condition dialog box.

3 To define your own criteria start typing the SQL statement in the SQL Equivalent box.

 Enter a SQL statement, and then click OK.
The condition syntax will be checked and errors reported. A valid condition statement will 
automatically be added to the Condition dialog box.

4 Click OK to apply the attribute filter.

The Browsing Info dialog box is refreshed with the new result set.

Filtering by GSC
The View > Filter by GSC menu item filters spatial data according to the current GSC. The 
current GSC is zoomed to the extents of the drawing area while the Browse Info dialog box is 
still active. This spatial filter is also applied on the current result set that is displayed in the 
Browse Info dialog box.

This function does not replace any previous defined attribute or spatial filters that are active but 
complement these.

Filtering by spatial objects
This function applies a spatial filter to the current result set by prompting the user to select 
Munsys objects in the current drawing. When activating the option, the user will be requested 
to select the appropriate spatial objects that are used as the filter. Once the user has selected these 
objects, the Browse Info dialog box is updated accordingly.

This filter criteria will replace all previously defined spatial filters, but complements attribute 
and GSC filters.

1 Choose View > Filter by Spatial Objects.

2 Select the appropriate spatial objects in the drawing, and then press ENTER.

The Browse Info dialog box is updated accordingly.

3 To reset the Browse Info dialog box, use the Clear All Filters option on the View menu.

Note The filter by spatial objects selection is restricted to 1000 records. If more than 1000 records are selected, 
the user will be presented with a message and will be required to reselect the objects from the drawing. 
Maximum number of selected records exceeded. Please limit the selection to 1000 spatial objects.
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Filter selected objects only
The View > Filter Selected Object Only function allows the user to select records in the Browsing 
window grid and use that record selection to update the results in the Browsing window. The user 
can select the records individually or hold down the Shift key to do a group selection, or hold down 
the Ctrl key to do multiple record selection.
The user highlights the records to filter on in the grid and then selects the menu item to update 
the resultant selection set.

Clearing all filters
The View > Clear Filter menu item is used to clear all of the previously defined filters, and is 
therefore only available when at least one filter has been specified. Once the function is 
activated, the result set is refreshed with no filters applied.

Displaying formatted values
The View > Display Formatted Values menu option is used to display more descriptive 
information in the result set, for example, rather display the land use description instead of a 
code. Column headings are also affected by this setting, headings are displayed with appropriate 
descriptions. If descriptions are not available the column name is prefixed with the table name. 

The formatted values affect the data display in the result set, generating of reports, copying of 
selected records and the find function.

Viewing SQL statements

The View > SQL Windows opens a SQL window at the top of the Browsing window and 
displays the SQL syntax for the current selection set. This SQL statement is updated when ever 
filter conditions are applied. The user can copy the SQL statement from the SQL window for 
use within SQLPlus or for documentation purposes.

Figure 63 View > SQL Window displays the SQL syntax for the current selection set.
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Setting an object query
This function is used to select a spatial query that will be used when querying spatial objects 
from the database. The available spatial queries are determined by the spatial table, identified 
on the Browse Content dialog box. The selected spatial query will be used to query the spatial 
objects associated with the result set.

1 Choose Records > Set Object Query...

The Available Queries dialog box is displayed and the queries relating to the selected spatial 
table are expanded by default.

Figure 64 The Available Queries dialog box

2 Select the appropriate system query from the list, and then click OK.

The required system query is set.

Querying objects
The Query Objects function allows the user to select records in the Browsing list and then query 
them into the drawing. The associated Munsys objects are created in the current drawing. The 
system query that was identified during the Set Object Query... function is used to determine 
the formatting parameters when querying spatial objects from the database.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Query Objects.

The associated spatial record/s is queried into the current drawing onto the appropriate spatial layer.

3 To view the queried spatial objects, see Zooming to objects.
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Zooming to objects
This function is used to locate queried spatial objects. Once the user has selected the 
appropriate record in the result set, the Zoom to objects function automatically zooms to the 
associate spatial object in the drawing. The aggregated extents of the object encountered is used 
to change the zoom state of the drawing.

1 On the Browsing Info dialog box, select the appropriate record from the result set.

2 Choose Records > Zoom to Objects.

The associated spatial object is zoomed to the extent of the screen.

Highlighting objects
This function is used to select a records in the result set, and then highlights the associated 
spatial objects in the drawing. The zoom state of the drawing remains unchanged during this 
operation.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Highlight Objects.

The associated spatial objects are highlighted in the drawing.

3 To zoom to the highlighted record, refer to Zooming to objects.

Highlighting records
This function is used to select spatial objects in the drawing and then highlights the associated 
records in the result set. The user is required to select at least one spatial object in the drawing. 
The user will only be able to select the spatial objects in the drawing associated with the primary 
table identified.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Highlight Records.

The associated records in the result set are highlighted.

3 Use the Records > Clear Highlighted Records menu item to clear the highlighted records.
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Figure 65 Combination of highlighting records and objects when browsing

Browsing Tables and Views
If the Browse Window function is initiated from either the Query > Browse Info menu item of 
by typing the command MUNBROWSE at the command line, Browse Info dialog box with 
the Tables/Views tab is displayed. The user must select one of the following items to browse:

 All Tables - lists all tables in the database.

 Attribute Templates - lists all attribute templates in the database.

 Lookup Tables - lists all lookup tables in the database.

 Queried Objects - lists the tables for objects queried into the drawing.

 Spatial Tables - lists all spatial tables in the database.

 Views - lists all spatial views in the database.
Once the user selects one of the items to browse, the Browse Selection dialog box is displayed 
and a list of all available tables are populated to the content pane.
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Figure 66 Tables/Views: All Tables

To select a table to browse

1 On the Select item to browse list of items, select one of the items from the list.

2 Once selected, the content pane on the right will be populated with a list of available tables and or 
views according to the roles assigned to the user.

3 Select a table from the content pane and then click OK.

The Browsing window will open and the resultant list will display all records in the table. The user 
can then apply filter conditions to refine the number of records in the result set. See The Browsing 
Info Window.
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Showing information about spatial objects
Introducing the Munsys Info Palette

The Munsys Info Palette replaces the Show Info functionality (which showed spatial data and 
attributes connected to a selected spatial object) that was available in previous versions of 
Munsys.

Figure 67 The Munsys Info Palette

The Info Palette is activated in the AutoCAD environment with the MUNINFOPALETTE 
command, or by selecting the Info Palette > On menu item from the Query menu. The palette 
is dockable and remains open until the user closes it.

The Info Palette toolbar contains the following buttons:

 Copy – allows the selection of entire rows, entire columns, or separate cells to copy.

 Edit Spatial Attributes – displays the Edit Attributes dialog box, which is used to edit the 
attributes of the selected object.

 Info Palette Preferences – displays the Info Preferences dialog box, which is used to set the 
default preferences for Modified Attributes, Data Formatting and Link Template Results.
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If the Info Palette is open and a Munsys Object is selected, the palette is updated with the details 
of the selected object. If a non-Munsys object is selected, or more than one object (these may 
or may not include Munsys Objects), the content of the palette is cleared, as the Info palette is 
only populated upon selection of a single Munsys Object.

Important The way that objects are selected on the Info Palette is dependent on the 
MUNINFOSELECT command. This command is used to toggle the behavior of the auto-select option 
in the Info Palette. If the Info Palette auto-select is set to On (the default setting for each session), the Info 
Palette is populated with the properties of any one object that is selected in the drawing while another 
command is not active. If the auto-select is set to Off, the Info Palette is only populated when an object is 
selected using the Select Object button, as seen below:

Figure 68 Show Info: Select Object
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The Info Palette is divided into the following three tabs:

 Attributes – displays the attributes for the selected object. A Display Template is selected 
from the list of available templates.

Figure 69 Info Palette: Attributes tab
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 Linked Attributes – displays  information as defined in a selected Link Template.

Figure 70 Info Palette: Linked Attributes tab
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 Object Info – displays detailed information regarding the selected object, separated into 
predefined groups.

Figure 71 Info Palette: Linked Attributes tab

When you right-click on a value on the Attributes or Linked Attributes tabs, a context-sensitive 
menu becomes available, which is used to copy data and specify formatting options.

Figure 72 Info Palette: Context-sensitive menu
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Specifying Info Palette preferences
The Info Preferences dialog box is used to specify default preferences for certain items on the 
Info Palette.

To specify Info Palette Preferences, do the following:

1 Click the Info Palette Preferences button on the Info Palette toolbar.

The Info Preferences dialog box is displayed, showing the Modified Attributes tab, which is 
used to specify the preferred view the user has on modified values.

Figure 73 Info Preferences: Modified Attributes

2 Select one of the following options:

 Display modified attributes in a separate column – modified attributes are displayed in a 
separate column. 

 Integrate modified attributes – modified attributes will not be displayed separately
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3 Click the Data Formatting tab, which is used to specify the preferred data format options.

Figure 74 Info Preferences: Data Formatting

4 Select one of the following options:

 Display formatted values

 Display unformatted values

5 Select the Link Template Results tab, which is used to set the preferred size for the Link Template 
results.

Figure 75 Info Preferences: Link Template Results

6 Specify the following:
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 Table Size – specify the preferred size for the Link Template results. A value can be entered 
manually, or by using the arrows.

 Table View – select the Table View or Column View option to specify the way in which the 
table data is displayed.

7 Click OK to apply the preferences to the Info Palette.
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Setting a coordinate system
With Munsys, you can set the drawing coordinate system to be different from the database 
coordinate system. By setting the drawing coordinate system, you can query objects from the 
database coordinate system into a drawing coordinate system. The data transformation will be 
done during the query. You have to make certain that the database and drawing coordinate 
system are compatible for the specific area that you are working in. The administrator has the 
option to set the scale and rotation of text and symbols to remain as it is in the database. The 
settings can be verified on the Capture Settings dialog box under the General group (the 
Capture Settings dialog box is accessed from the first menu item of each application’s Capture 
menu, for example Capture > Sewer Settings...). New and changed objects can be posted to the 
database while the drawing coordinate system is set. The data will be transformed to the 
database coordinate system as part of the posting process.

To set a coordinate system

1 Choose Extras > Set Coordinate System...

2 The Set Coordinate System dialog box is displayed.

Figure 76 The Set Coordinate System dialog box

3 From the Coordinate System Selection group, select the category in which the required coordinate 
system is grouped.

4 From the Coordinate Systems in Category list, select the appropriate coordinate system, and then 
click OK.

Once the coordinate system is set, data is queried from the database and is displayed in the 
coordinate system set above.
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Munsys reports
A Munsys report consists of information that is generated from existing attribute data. To 
generate a Munsys report, you have to specify for which spatial objects the report will be created, 
and which attribute data assigned to these spatial objects should be used.

The result of the report is saved in a text file format – CSV (comma delimited). Commas 
separate columns of data, and each row of data ends in a carriage return. The text file can be 
opened in a word processing program or spreadsheet.

A Munsys report contains the following type of information:

 The first line indicates which spatial table is used to create the report.

 The second line contains the date and time that the report was created.

 The third line contains the field names that the user selected when creating the report.

 The body of the report contains information only for the selected spatial objects.

To create a report

1 Choose Extras > Report...

2 Select the spatial objects to create the report from, and then press ENTER.

The Table Names dialog box is displayed.

Figure 77 The Table Names dialog box

The Table Names dialog box contains a list of all the tables of the selected spatial objects.

3 From the list of tables, select a table, and then click OK.

The Column Names dialog box is displayed.



Querying spatial data in Munsys 111 








Figure 78 The Column Names dialog box

4 From the list, select the columns to include in the report, and then click OK.

The Save report as dialog box is displayed.

Figure 79 The Save report as dialog box

5 Enter a file name for the report, and then click Save.

The report opens in Microsoft Notepad® as a text file.



112 








 Chapter 4


 Working with Munsys objects

Introducing Munsys Objects
Munsys objects were created to cater for the specific needs of the various Munsys applications 
in the AutoCAD environment. A Munsys object is a derivative of an AutoCAD entity with 
additional options for geometry presentation and attribute information. Munsys objects are 
presented as the following object types

 MunPoint – A MunPoint may consist of a single point that can be defined as a single set 
of X,Y coordinates. The MunPoint object is normally used to represent symbols like water 
pumps or hydrants.

A MunPoint may also consist of multiple points that can be defined as multiple sets of 
X,Y coordinates that form part of one object. This type of object is normally used to 
represent a cluster of symbols, for example all the mailboxes belonging to a specific post 
office. Selecting any one of the symbols will result in the selection of the whole object, of 
which the properties can be changed.

 MunLine – A MunLine may consist of only a start and endpoint, or a string of points that 
can be seen as bend points. This type of MunLine object is normally used to represent 
network links like road center lines. 

A MunLine may also consist of multiple disjointed sections that form part of the same 
object. An example of this type of object can be a river with the same name that is broken 
into disjointed sections where roads cross over it.

 MunPoly – A MunPoly object is used to represent polygons, and can consist of different 
levels of complexity. A basic MunPoly object can consist of only a polygon, without any 
island. The next level will be a polygon with one or more islands. The third level will be 
two or more disjointed polygons that form part of the same object. The complexity of the 
MunPoly object can also include two or more disjointed polygons, with islands in each 
polygon.

 MunLabel – A MunLabel does not have any levels of complexity. The MunLabel object is 
used to represent text. A MunLabel object uses two columns in the spatial table as the X 
and Y coordinates to determine the position of the insertion point of the text. The 
geometry of the MunLabel object will always be the same as the two columns used as the 
X and Y coordinates, and is only used for purpose of a spatial index.

 MunLWPoly – objects can only be used for display purposes, therefore they will only be 
available for viewing with the Info Palette. The Munsys functions that are used to edit 
attributes and spatial objects do not support MUNLWPOLY object types, therefore no 
posting to the database will be able to take place.
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 Tags – A tag forms part of a Munsys object. If the tag is selected, the whole objects is 
highlighted because it forms part of the object. Each object, regardless of its complexity, has 
only one tag. The value and some of the properties of the tag are stored a spatial table. These 
are defined as a default set of columns in each table. During the capture process, the tag 
position is set to a default position, for example the middle point of a MunLine object.

Regardless of the object type, each Munsys object has the following characteristics:

 Spatial object type– the type of spatial data with which the Munsys object is associated.

 MunID – a unique identifier to reference a spatial table within a Munsys schema.

 GID – a unique identifier that identifies a spatial object in a spatial table. This is the index 
key used to retrieve and update relevant changes to an object.

 Tag – a text string used for annotation purposes, displayed at a position using various 
display attributes such as text height, rotation angle and justification.

 Status flags – used to indicate any changes requiring updates to the database. A status flag 
indicates when an object is new or has been modified, or whether it needs to be deleted 
from the database. A list of attributes is attached to the object, used to indicate the 
appropriate modifications.
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Components of each Munsys object
Each Munsys object has a default set of columns in the Oracle table. The default table structure 
of each object is as follows:

MunPoint

Table 1 MunPoint object table structure

Column name Type Description

GID NUMBER(10) Geometry ID.

SYM_NAME VARCHAR2(40) Contains the string value of the 
symbol name (drawing name).

SYM_SCALE NUMBER Contains the scale factor of the sym-
bol.

SYM_ANGLE NUMBER Contains the symbol angle in radi-
ans.

COMMENTS VARCHAR2(150) Contains optional comments.

TAG_X NUMBER Contains the X ordinate of the tag 
insertion point.

TAG_Y NUMBER Contains the Y ordinate of the tag 
insertion point.

TAG_VALUE VARCHAR2(40) Contains the tag text value. 

TAG_SIZE NUMBER Contains the tag text size.

TAG_ANGLE NUMBER Contains the tag text angle in radi-
ans. 

TAG_JUST CHAR(2) Contains the tag text justification.

GEOMETRY SDO_GEOMETRY Contains the MunPoint data.
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MunLine

Table 2 MunLine object table structure

Column name Type Description

GID NUMBER(10) Geometry ID.

GEOM_LENGTH NUMBER Contains the length of the MunLine 
object. This column s automatically 
maintained by the Munsys system.

COMMENTS VARCHAR2(150) Contains optional comments.

TAG_X NUMBER Contains the X ordinate of the tag 
insertion point.

TAG_Y NUMBER Contains the Y ordinate of the tag 
insertion point.

TAG_VALUE VARCHAR2(40) Contains the tag text value. 

TAG_SIZE NUMBER Contains the tag text size.

TAG_ANGLE NUMBER Contains the tag text angle in radi-
ans. 

TAG_JUST CHAR(2) Contains the tag text justification.

GEOMETRY SDO_GEOMETRY Contains the MunLine data.



Working with Munsys objects 116 








MunPoly

Table 3 MunPoly object table structure

MunLabel

Table 4 MunLabel object table structure

Column name Type Description

GID NUMBER(10) Geometry ID.

GEOM_AREA NUMBER Contains the area of the geometry. 
This column s automatically main-
tained by the Munsys system.

COMMENTS VARCHAR2(150) Contains optional comments.

TAG_X NUMBER Contains the X ordinate of the tag 
insertion point.

TAG_Y NUMBER Contains the Y ordinate of the tag 
insertion point.

TAG_VALUE VARCHAR2(40) Contains the tag text value. 

TAG_SIZE NUMBER Contains the tag text size.

TAG_ANGLE NUMBER Contains the tag text angle in radi-
ans. 

TAG_JUST CHAR(2) Contains the tag text justification.

GEOMETRY SDO_GEOMETRY Contains the MunPoly data.

Column name Type Description

GID NUMBER(10) Geometry ID

COMMENTS VARCHAR2(150) Contains optional comments.

TAG_X NUMBER Contains the X ordinate of the tag 
insertion point.

TAG_Y NUMBER Contains the Y ordinate of the tag 
insertion point.

TAG_VALUE VARCHAR2(40) Contains the tag text value. 

TAG_SIZE NUMBER Contains the tag text size.

TAG_ANGLE NUMBER Contains the tag text angle in radi-
ans. 

TAG_JUST CHAR(2) Contains the tag text justification.

GEOMETRY SDO_GEOMETRY Contains the MunLabel data.
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Munsys record locking
The record locking functionality provides the ability to lock and unlock individual spatial 
objects for editing purposes. The database administrator can enable or disable record locking in 
the Munsys Management Console. When an object is locked, other users are prevented from 
editing the object until the object has been posted back to the database, or the object is 
unlocked. 

Unlocked objects will not show AutoCAD grips when selected. Only locked objects will show 
grips when selected. The AutoCAD grips can be used to modify locked objects in a similar way 
as a normal AutoCAD object, for example a line. Standard AutoCAD functions like Move, 
Rotate, Stretch, etc., can be used for spatial changes on Munsys objects. The modified objects 
will change to the integrity color and flagged as modified.

When an object is locked, the geometry of the object and the tag position are refreshed from 
the database. This ensures that the latest information is available to the user, who obtains 
editing rights on the object by locking it. No other properties will be refreshed. If the query was 
set up to query a different value than the TAG_VALUE column, the tag value remains as 
queried.

If the administrator disables record locking in the database using Munsys Administrator, all 
objects are queried with a status of Locked. This allows multiple users to modify the same 
object. Objects that are posted to the database will retain their status of Locked because locking 
has been disabled in the database.

Objects are locked and unlocked as follows:

 Explicitly – through the Lock Objects and Unlock Objects functions on the Object menu. 
Objects can also be unlocked through the Browse Locked Objects function on the Object 
menu.

 Implicitly – when using any Change function, the object or objects that you select for 
editing are locked automatically until you have posted the changes to the database, after 
which the objects will be automatically unlocked.

 The database administrator can unlock locked objects from the Lock Summary and Lock 
Details tabs in Munsys Administrator. For more information, refer to the Munsys 
Management Console User Manual.

Note Objects that have been locked explicitly are unlocked automatically when changes made to these objects 
are posted to the database.

Before you can lock or unlock objects:

 you must be connected to the database as a user with edit privileges.

 you have to query the relevant objects from the database, except when you are unlocking objects 
from the Current Locked Objects dialog box 
(Object > Browse Locked Objects).

Newly created spatial objects are locked by default, as they do not exist in the database yet.

Note Objects that have been locked in one drawing cannot be locked in a different drawing by the same user in 
the same session. Changes to the object have to be posted to the database from the drawing that the object 
was locked in.
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Locking objects
With this function, you can lock multiple objects, preventing other users from making any 
changes to the objects while you edit them. 

Tip Before you select multiple objects to lock, you can use the Show Locked Objects function on the Object 
menu to determine whether another user has not already locked the objects that you want to work with. If 
you find that another user has locked an object, you can use the Info Palette to see who has locked it, as 
well as the lock duration. 

To lock objects

1 Choose Object > Lock Objects.

2 Select the objects that you want to lock.

Figure 1 Selecting objects in the drawing to be locked

The objects are locked.
If an object that you have selected for locking has already been locked by another user, the 
system zooms to the extent of that object, and the command line prompts you as follows:

 Ignore – ignores the locked object, and proceeds to lock the other objects that you have 
selected.

 Ignore all – ignores the locked object, and will not attempt to lock any other locked objects 
that are encountered.

 Retry – tries again to lock the object. The prompt will appear every time that the lock fails. 
This can be used to reattempt locking after the object was unlocked by another user.

 Exit – stops further locking of objects. Objects that have already been locked will remain 
locked.
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Showing locked objects
With this function, you can select objects, and see whether they have been locked. You can view 
objects that have been locked by other users, or view objects that the current user has locked. 
The locked objects are highlighted for easy reference. This function is useful if you need to 
highlight locked objects in a specific area to determine if someone has locked some of the 
objects.

To show locked objects

1 Choose Object > Show Locked Objects.

The Show Locked Objects dialog box is displayed.

Figure 2 The Show Locked Objects dialog box

2 Select one of the following options:

 Current user – will display the objects locked by the current user.

 All users – will display the objects locked by all the users.

3 Select the objects of which you want to display the lock status.

The locked objects within the selection are highlighted.

Note If the current user is selected on the Show Locked Objects dialog box, the result will select the objects 
that have been locked by the current user, although some objects may be locked in other drawings and not 
in the current drawing. The highlighted objects become part of the last selection set. The Previous (P) 
option on the selection prompt can be used to select the highlighted object again, which can be useful if 
you want to change the color of these objects. This way, all the objects can be identified for unlocking, 
using the Unlock Objects function on the Object menu.
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Browsing locked objects
With this function, you can view a list of the all the objects that have been locked by the current 
user, regardless of the drawing in which these objects reside. The Current Locked Objects dialog 
box displays the following information about each locked object:

 The time and date that the object was locked

 The duration that the object has been locked

 The name of the spatial table where the object resides

 The GID of the locked object

You can also unlock selected objects from the Current Locked Objects dialog box. The objects 
that you want to unlock, do not have to be in the drawing that is currently open.

Important Before you unlock objects from the Current Locked Objects dialog box, you have to make 
certain that these objects do not contain changes that will be lost when the objects are unlocked. Although 
the lock status in the drawing will not be changed, you will not be able to post the changes to the database, 
because the lock status is changed in the database when the objects are unlocked. 

To browse locked objects

1 Choose Object > Browse Locked Objects.

The Current Locked Objects dialog box is displayed, showing details of the locked objects:

Figure 3 The Current Locked Objects dialog box

2 To unlock objects from this dialog box, do the following:

 Select the objects that you want to unlock.

 Click the Unlock button.

A confirmation message is displayed.

3 Click Yes to unlock the selected objects, or No if you do not want to unlock the selected objects.

4 Click Close to exit the dialog box.
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Unlocking locked objects
Locked objects can be unlocked in a number of ways. Firstly, locked objects that are posted to 
the database (objects can only be posted to the database if they have a Modified status and their 
integrity has been verified with the integrity check) are unlocked automatically and do not have 
to be unlocked manually. Other than the database administrator unlocking object using 
Munsys Administrator, there are two ways in which objects can be unlocked:

 Object > Unlock Objects – this function will unlock objects that have been locked in the 
drawing. This will update the status of the object in the drawing and in the database. If an 
object is locked in the database only, only the database will be updated. If an object is locked 
in the drawing only, its status in the drawing only will be updated.

 Object > Browse Locked Objects – this function lists all locked objects in the database, 
irrespective of the drawing in which the object was locked. Unlocking objects from this list 
will only update the database, even if the object was locked in the current drawing. In this 
case, the lock in the drawing has to be updated with the Object > Unlock Objects function.

Important It is recommended that locked objects without changes are unlocked before drawings are 
closed or saved.

To unlock locked objects

1 Choose Object > Unlock Locked Objects.

2 Select the objects that you want to unlock.

The objects that you have selected are unlocked. If an object that you have selected for 
unlocking has been modified, and the changes have not been posted to the database, the system 
zooms to the extent of that object, and the command line prompts you as follows:

 Ignore – does not attempt to unlock the object, retains the status of Locked, and evaluates 
the next selected object for unlocking.

 Ignore all – will not further attempt to unlock any other selected objects that have been 
modified, and will continue to unlock all the other objects without prompting for 
confirmation.

 Unlock – discards the modification to the object, unlocks the object, and evaluates the next 
selected object for unlocking.

 Unlock all – discards modification to all the objects that were selected for unlocking, and 
unlocks all the objects without prompting for confirmation.

 Exit – stops any further unlocking of objects. Remaining objects retain their status as it was 
prior to the start of the operation.
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Refreshing the geometry of spatial objects
This command is used to refresh the geometry of spatial objects. When the applicable objects 
are selected in the drawing, the database is queried for the latest geometry information related 
to the spatial objects and the objects are updated accordingly. If changes were made since the 
initial query of the objects, you will see the differences as these are applied to the objects. All 
display and tag value information is not changed when this command is executed.

To refresh the geometry of spatial objects

1 Do one of the following:

 Choose Object > Refresh Objects.

 On the command line, type MUNQRYREFRESH, and then press ENTER.

2 Select the objects that you want to refresh, as prompted by the command line.

The database is queried for the latest geometry information related to the spatial objects and 
the objects are updated accordingly.
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Converting CAD objects to Munsys objects
This function is used to convert multiple CAD objects to Munsys objects, allowing values from 
the original object to be assigned as attributes on the new objects, for example Map object data 
and object properties such as layer, color, radius, circumference, angle, height, text value, etc. 
Munsys objects can also be selected for conversion to allow the transferal of object data that was 
previously attached to the Munsys object data to a corresponding attribute value. Before the 
AutoCAD objects are selected for conversion to Munsys objects, conversion options are 
specified. These options can be saved and stored for later use.

To convert CAD objects to Munsys objects

1 Do one of the following:

 Choose Object > MunConvert...

 On the command line, enter MUNCONVERT, and then press ENTER.
The Object Conversion dialog box is displayed.

2 From the Spatial Object Type list, select the spatial object to which you want to convert the objects.

The Layer Information and Attribute Assignments groups are populated according to the object 
type that you specified.

Figure 4 The Object Conversion dialog box
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3 In the Layer Information group, specify the layer where you want the objects to be created:

 Selecting the Create on Spatial Layer option will create all the converted objects on the spatial 
layer associated with the spatial object.

 The Create on Sub Layer option is used when objects are to be split over several layers. If you 
select this option, the Assign... button becomes available. Click this button to display the 
Attribute Assignments* dialog box, from where the properties that you specify will be used for 
creating the layer.

4 The Attribute Assignments group contains the attribute columns of the spatial object that has been 
selected for the conversion process. Do the following in this group:

 To assign a value to an attribute, select the attribute, and then click the Assign... button. Use the 
Attribute Assignments* dialog box to specify the values.

 Click the Save... button to save the attributes that you have assigned.

 Click the Load... button to load previously saved conversion options.

 Click the Clear button to clear any assigned values.

5 Click OK to continue.

6 Select the objects that you want to convert, and then press ENTER.

The command line indicates how many objects were converted.

*Using the Attribute Assignments dialog box

The Attribute Assignments dialog box is used to assign a property value to an attribute column. 
The properties specified with this dialog box are assigned to the attributes of the spatial objects 
that are selected for conversion. The dialog box is also used to specify the layer on which the 
spatial object(s) to be converted will be placed.

Figure 5 The Attribute Assignments dialog box
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 Column being Assigned – displays the column that was selected on the Object Conversion 
dialog box.

 From Object Property – select this option to assign a property extracted from an AutoCAD 
object. The property will only be applicable if it can be evaluated at the time of the 
conversion – in other words, if a Circle.Radius property is selected and the object being 
converted is a point (not a circle), the property will be ignored and no value will be assigned 
to the attribute. The properties are selected from a list that is displayed in alphabetic order 
in dot notation form. Each property contains the category followed by a dot then the name 
of the property, for example Object.Layer.

 From Object Data – select this option to assign an object data attribute, which has been 
assigned to an AutoCAD Map object. A complete list of the object data tables available in 
the drawing is displayed. From this list, select one table and the column from the table. This 
identifies the value that will be extracted from the object when it is converted. If the object 
does not have this attribute, nothing will be assigned. The object data string will be prefixed 
with “OD:” to show that this assignment is an Object Data assignment.

 From Application Setting – select this option to assign values from application settings and 
from database sequences. From the lists that become available, you can select the category, 
display group and short description of the application setting.

 By Value – select this option to enter a constant value that is compatible with the column 
type to which the value will be assigned.
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Munsys options
From the Munsys Options dialog box, which is accessed through the MUNOPTIONS 
command or the Extras > Munsys Options menu item, you can specify preferences and integrity 
settings that are used throughout the system and that are not application-dependent. 
Preferences are saved for the current user, while integrity settings that are changed are valid for 
the current session. The Munsys Options dialog box consists of two tabs: Preferences and 
Integrity Settings.

Specifying Munsys options
On the Munsys Options Preferences tab, you can specify the following preferences:

 Tooltip Preferences – options to determine whether tooltips should be displayed when the 
mouse pointer is rested on an object in the drawing area, and which information the 
tooltips should contain.

 Color Preferences – with these options, users can specify the construction color (the color 
used for objects in the process of construction), the integrity color (the color used to display 
objects that have not yet been validated by the integrity check), and the unposted color (the 
color used to display objects that have not yet been posted to the database).

 Integrity Preferences – these are options that influence the behavior of the Integrity Check 
function. Options can be specified to erase existing integrity markers before the integrity 
check is run, to show the Integrity Results dialog box when the integrity check is completed, 
as well to notify users when objects require network validation after object integrity has 
been checked.

 Database Posting Preferences – these are options that are used by the database posting 
function. Options to show the Database Posting Summary and Database Posting Results 
dialog boxes can be specified, as well as the option for the system to automatically unlock 
all locked objects that were not modified in the drawing. You can also choose to 
automatically perform an object integrity check when objects are posted to the database.

Note The *INTEG_NETWORK_AUTCHECK* application setting (Include Network in Object Integrity 
Check), which is set by the database administrator in Munsys Administrator, allows a network integrity 
check to be performed automatically whenever an object integrity check is run. The same network rules 
and settings still apply. When the integrity check is completed, the Integrity Results dialog box displays 
a combined list of both object and network validations that were performed during the integrity check. 
When this setting is enabled, the object integrity check cannot be integrated with the database posting 
function, and the Automatically perform Object Integrity option on the Munsys Options dialog box 
Preferences tab will be unavailable.

On the Munsys Options Integrity Settings tab, you can specify the following integrity settings:

 Object Integrity Options – these are options that are used by the Validate Object Integrity 
menu item and that are used to specify whether geometry and/or attributes should be 
validated when object integrity is checked. The Modified objects and All objects options 
specify whether all the objects in the selection set should be validated, or only the objects 
in the selection set that have been modified.

 Network Integrity Options – these are options that are used by the Validate Network 
Integrity menu item, and that are used to specify whether the topology and/or connectivity 
attributes of a network should be validated when network integrity is checked.
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To specify Munsys options

1 Do one of the following:

 Choose Extras > Munsys Options...

 On the command line, type MUNOPTION, and then press ENTER.
The Munsys Options dialog box is displayed.

Figure 6 The Munsys Options dialog box: Preferences tab

2 Select or clear any of the following check boxes in the Tooltip Preferences group:

 Show object tooltips – displays tooltips when the mouse pointer is rested on an object in 
the drawing area. If this option is not selected, all the sub-options in this group will be 
unavailable.

Note If the Show object tooltips option only is selected (without any of the sub-options), only the object type 
and lock status is displayed in the tooltip window. The lock status only indicates the status of the object in 
the drawing and not in the database. The object may be locked by another user.

 Show object modified status – includes the modified status of the object displayed in the 
tooltip window. Modified status includes the following:

 Geometry – indicates that the object or a vertex of the object was moved (spatial 
change).

 Tag – indicates that the tag of the object was modified; this includes value, justification, 
size, position or angle.

 Symbol – indicates that the symbol scale, angle or name was modified. This status is 
only applied to modified MunPoint objects.

 Attributes – indicates that the attributes of the object has been modified.

 Show object GID – shows the GID of the object displayed in the tooltip window.

 Show modified attributes – shows a list of modified attributes attached to the object 
displayed in the tooltip window.
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Figure 7 Tooltip, showing modified status, GID and modified attributes

 Show integrity marker information – displays integrity information tooltips for integrity 
markers.

Figure 8 Tooltip, showing integrity marker information

3 In the Color Preferences group, change the construction color, or the integrity color, or the unposted 
color by selecting a new color from the list. Changing the integrity color and/or the unposted color 
will not influence existing objects in the drawing. (Changing the integrity color and/or the unposted 
color during capture can aid the user in identifying specific objects based on their color.)

Tip If you do not want new or changed objects to display in another color (the “integrity color”), you can use 
the MUNINTEGMODE command to disable the integrity color. New or changed objects will then 
display in their normal layer color. The same command is used to enable the integrity color mode again.

4 In the Integrity Preferences group, select or clear any of the following check boxes:

 Erase integrity markers at start of operation – erases all previously generated integrity 
markers.

 Show Integrity Results dialog – displays the Integrity Results dialog box after the integrity 
check has been completed. If this option is not selected, the results will only be displayed 
on the command line.

 Notify when objects require network validation – notifies users when objects need network 
validation after object integrity has been checked. It s recommended that the network 
integrity check is used after the object integrity check to ensure that network connectivity 
is maintained.

5 In the Database Posting Preferences group, select or clear any of the following check boxes:

 Show Posting Summary dialog – displays the Database Posting Summary dialog box before 
the database posting operation is started. This dialog box allows users to cancel the posting 
operation; if the dialog box is not displayed, posting will continue automatically.
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Figure 9 The Database Posting Summary dialog box

 Show Posting Results dialog – displays the Database Posting Results dialog box after the 
objects have been posted to the database. If this option is not selected, the posting results 
will be shown on the command line only.

Figure 10 The Database Posting Results dialog box

 Auto-unlock objects after posting – the system will automatically unlock all locked objects 
that were not modified in the drawing. This option ensures that no unnecessarily locked 
objects remain in the drawing after data has been posted to the database.

 Automatically perform Object Integrity – integrates the object integrity check with the 
database posting operation. This option will be unavailable when the Include Network in 
Object Integrity Check application setting has been set in the database.



Working with Munsys objects 130 








6 Select the Integrity Settings tab.

Figure 11 The Munsys Options dialog box: Integrity Settings tab

7 Select or clear any of the following check boxes in the Object Integrity Options group:

 Validate geometry – validates object geometry when object integrity is checked.

 Select the Modified objects button to validate only the modified objects in the selection 
set. 

 Select the All objects button to validate all the objects that were selected. Validating the 
geometry of all selected objects will attempt to rectify the selected objects by removing 
redundant/duplicate points. If an object is not locked, an integrity error will indicate 
that an attempt to rectify the object failed because the object was not locked. If the 
object was locked, it will be rectified and flagged as a geometry change during a posting 
operation.

 Validate attributes – validates attribute information when object integrity is checked.

 Select the Modified objects button to validate only the modified objects in the selection 
set. 

 Select the All objects button to validate all the objects that were selected. Validating the 
attributes of all selected objects will use the integrity check rules to identify objects of 
which required/mandatory attributes are not populated. Attributes attached to the 
object and existing attributes on the objects will be used in this process. This means that 
the integrity check will identify objects that do not adhere to the rules based on existing 
attributes in the database and new attributes attached to the object in the drawing.

8 In the Network Integrity Options group, select or clear the following check boxes:

 Validate topology – validates the topology of a network when the network integrity is 
checked. This process will only work with modified objects and will, for example, snap 
nodes to the endpoint of pipes based on tolerance.
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 Validate connectivity – validates the connectivity attributes of a network when the network 
integrity is checked. This process will also only work with modified objects and will update 
the start and end node attributes of objects that form part of the network.

9 Click OK to apply the options you selected.

The integrity settings are valid for the current session, while the preferences are saved on an 
operating system user level.

10
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Managing link templates
Link templates are used when attribute information attached to spatial objects is edited, 
browsed or displayed. A link template specifies how one table is related to another. Link 
templates are created in the Spatial Data Manager application, and may only be created by 
administrators, and have the following characteristics:

 An ID associated with the template

 A unique name that describes the template

 A primary table

 A linked table

 A relationship type – one-to-one or one-to-many

 A column or expression identified from the primary table, used to define the link with the 
linked table

 A column or expression identified from the linked table, used to define the link with the 
primary table

Creating link templates

1 In Munsys Spatial Data Manager, choose Extras > Manage > Link Templates...

The Link Templates dialog box is displayed, showing a list of the link templates that are currently 
available.

Figure 12 The Link Templates dialog box

2 On the Link Templates dialog box, click the New... button.

The Link Table Information dialog box is displayed.
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3 If you want to use an existing link template as basis for the new template, select a template from the 
Retrieve information from existing template list.

The fields in the Primary Table Information, Linked Table Information and Join Type groups are 
populated with the values from the template you selected.

Figure 13 The Link Table Information dialog box

4 If you want to create a new link template that is not based on any other existing template, enter the 
name for the new template in the Link Name box.

5 To specify the primary table, do the following:

 Click the Set... button.

The Table Selector: Primary Table dialog box is displayed.

Figure 14 The Table Selector: Primary Table dialog box
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 On this dialog box, select the primary table.

 To specify the link information on the primary table, do one of the following:
 Select the Join By Column radio button, and then select the common field that links to 

the secondary table.

 Click the Join By Expression radio button, and then enter an expression that determines 
the common value to link two tables. All column names should be prefixed with the 
table name.

6 To specify the secondary table, do the following:

 Click the Set... button.

The Table Selector: Linked Table dialog box is displayed. 

 On this dialog box, select the linked table.

 To specify the link information on the linked table, do one of the following:
 Click the Join By Column radio button, and then select a common field from a linked 

table. 

 Click the Join By Expression radio button, and then enter an expression that determines 
the common value to link two tables.

7 Specify the join type by selecting one of the following options:

 One-to-one – one record in the primary table matches one record in the linked table

 One-to-many – one record in the primary table matches more than one record in the linked table 

8 Click the Test Join button to verify the number of matches found.

The Link Template Results dialog box shows the number of matching records that were found.

Figure 15 The Link Template Results dialog box

9 Click OK to create the link template.

10 The new link template is displayed in the list on the Linked Table Information dialog box.
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Editing link templates
Link templates can only be edited by users with Administrator privileges.

To edit a link template

1 In Munsys Spatial Data Manager, choose Extras > Manage > Link Templates...

The Link Templates dialog box is displayed, showing a list of the link templates that are 
currently available.

2 Select the link template that you want to edit, and then click the Edit... button.

Figure 16 The Link Templates dialog box

The Link Table Information dialog box is displayed.

3 Change the information as required, and then click OK.

The link template is updated accordingly.
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Deleting link templates
Link templates that are no longer needed can be deleted from the database. Only users with 
Administrator privileges can delete link templates.

To delete a link template

1 In Munsys Spatial Data Manager, choose Extras > Manage > Link Templates...

The Link Templates dialog box is displayed, showing a list of the link templates that are 
currently available.

2 Select the link template(s) that you want to delete from the list, and then click the Delete button.

Figure 17 The Link Templates dialog box

The following message is displayed: 

Figure 18 Deleting a link template

3 Click OK to delete the selected link template(s), or Cancel to exit the function.
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Managing attribute templates
Attribute templates customize the view of a table. This is done by selecting appropriate columns 
and setting their display order, displayed name and respective formatting parameters. Attribute 
templates have the following characteristics:

 ID – a unique identifier to distinguish from any other template

 Name – a reference name. This will be the name that the user sees when asked to select an 
attribute template from a list

 Description – a short description describing what the template is primarily used in context 
with

 Primary Table – the name of the primary table with which the template is associated

 MUNID – if the primary table refers to a Munsys spatial table, which will contain the 
MUNID reference as encountered in MUNSYS_SP_TABLES

 Linked Table Information – parameters required to define a relationship with a linked table.

For each attribute template that is stored, one or more records will be stored in the 
MUNSYS_AT_CONTROL table. One record in this table represents a column that is 
associated with the attribute template. To identify the column, its position and format, the 
following characteristics will be stored:

 Column ID – a unique identifier to distinguish between different columns

 Attribute Template ID – the ID of the attribute template to which the column belongs

 Table Name – table name to which the column belongs

 Column Name – the name of the column

 Description – descriptive name used for display purposes. If no description is given, the 
column name will be used

 Editable Status – informs whether the user may edit this column or not, when the template 
is applied in an editing context

 Table Ordinal Position – this determines the ranking order of a table when multiple tables 
are referenced as part of the attribute template.

 Column Ordinal Position – ranking position for the column. Positions are unique within 
the context of an attribute template and the table to which the column belongs.

 Formatting Information – type of formatting to apply to the column when being displayed 
or edited. The format type determines what formatting parameters need to be entered, for 
example when a lookup table is identified as the format type, the parameters will supply 
information such as the lookup table name, the column to display as value, and the column 
to store as lookup code.



Working with Munsys objects 138 








Creating attribute templates

1 In Munsys Spatial Data Manager, choose Extras > Manage > Attribute Templates...

The Attribute Templates dialog box is displayed, showing a list of the existing attribute templates.

Figure 19 The Attribute Templates dialog box

2 Click New...

The Define Attribute Template dialog box is displayed.

Figure 20 The Define Attribute Template dialog box
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3 In the Template Name box, enter a unique name for the new attribute template that you want to 
create. If you enter a name that already exists, a warning to this effect is displayed.

4 In the Template Description box, enter a description for the new attribute template.

5 To select a primary table, do the following:

 Click the Set... button adjacent to the Primary Table Name box.

 Using the Table Selector, select the primary table.

The primary table that you selected is displayed in the Primary Table Name box.

6 To select a linked table (optional) click the Set... button adjacent to the Linked Table Name box, 
and then use the Linked Table Information dialog box to specify the linked table information.

The primary table columns and linked table columns are displayed in the Column Identification 
list.

7 Do the following to change the columns' display order:

 To move a column up in the display order, select the column, and then click Up.

 To move a column down in the display order, select the column, and then click Down.

8 To add a column, do the following:

 Click Add...

The Column Definition dialog box is displayed.

Figure 21 The Column Definition dialog box 

 Using the From Table list, select the table to which you want to add the column.

 Select the Get value from column option to select a specific column from which to obtain the 
value. If this option has been selected, the Allow editing on this column check box will be 
selected. Clear this check box if the column may not be edited and will be displayed for viewing 
only.
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 Select the Get value from expression option to type a SQL-related expression. When 
referencing columns in an expression, these must be denoted by a table name. (No syntax 
checking is performed and errors will only be displayed when the attribute template is being 
utilized).

When using the Get Value from Expression function, the Column Name from the Linked table 
is used to link with the Primary table. The “@” character must be prefixed to indicate it is a 
column name. The “$” character must be prefixed to indicate it is an expression. Columns or 
Expressions are used to obtain content. A prefix example is @SP_PARCELGID.

 In the Display Information box, enter a name or description that will be used to describe the 
column. If this is not specified, the column name will be used for display purposes.

 To set up formatting parameters, select one of the following options:
 Use Default – applies no formatting and uses the data from the database. A combination 

of data type, Autodesk settings and Windows Regional Settings are used to present the 
value.

 Angle – informs the system that a number is to be displayed as an angle. Autodesk angle 
unit settings are used to determine how this will be presented.

 Lookup Table – defines an alternate value to be displayed instead of the original value 
in the column. Click the Set... button to set these parameters on the Lookup Definition 
dialog box.

Figure 22 The Lookup Definition dialog box

 Click OK to add the column to the attribute template.

9 To edit a column, do the following:

 Select a column, and then click Edit...

 The Column Definition dialog box is displayed.

 On the Column Definition dialog box, change the column as required, and then click OK.

10 To delete a column, select the column, and then click Delete.

You will be asked for confirmation before the column is deleted.

11 When you have completed the definition of the attribute template, click OK to create the attribute 
template.

The new attribute template is saved and displayed in the list of attribute templates on the Attribute 
Templates dialog box.
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Editing attribute templates
This function is used to edit attribute templates. Attribute templates can only be edited by users 
who have been assigned the MUNSYS_ADMIN role. You can change the name, description, 
primary table and linked table information, and column definition of an existing attribute 
template.

To edit an attribute template

1 In Munsys Spatial Data Manager, choose Extras > Manage > Attribute Templates...

The Attribute Templates dialog box is displayed, showing a list of the existing attribute 
templates.

Tip The Attribute Templates dialog box can be resized so that you can easily view all the information.

2 Select the attribute template that you want to change, and then click Edit...

Figure 23 The Attribute Templates dialog box

The Define Attribute Template dialog box is displayed. You can change the name, description, 
primary table and linked table information, and column definition of an existing attribute 
template.
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Figure 24 The Define Attribute Template dialog box

3 On the Define Attribute Template dialog box, change the attribute template as required, and then 
click OK.

The attribute template is changed as specified.
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Deleting attribute templates
Attribute templates that are no longer needed can be deleted from the database. Only users with 
Administrator privileges can delete attribute templates.

To delete attribute templates

1 In Munsys Spatial Data Manager, choose Extras > Manage > Attribute Templates...

The Attribute Templates dialog box is displayed, showing a list of the existing attribute 
templates.

2 Select the attribute template(s) that you want to delete from the list, and then click the Delete button.

Figure 25 The Attribute Templates dialog box

The following message is displayed: 

Figure 26 Delete Attribute Template

3 Click OK to delete the selected attribute templates, or Cancel to exit the function.
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Editing spatial object attributes
The Edit Attributes function is used to edit the attributes of one or more selected spatial objects 
that belong to the same object type. The current application determines what object types may 
be selected; for example, if you are working in Munsys Cadastral, only cadastral objects may be 
selected. If you select more than one object type (for example parcels and easements), you will 
be required to choose a single object type to edit.

Objects that are selected for editing are locked (if record locking is enabled in the database). 
Once the objects have been selected and an object type to edit has been specified, the Edit 
Attributes dialog box is displayed. This dialog box contains various options that can be used to 
edit the attributes of the spatial objects:

 Attribute templates – attributes can be edited using an attribute template. The attributes 
that will be displayed when an attribute template has been selected will depend on the 
attributes that have been specified on the template, as well as the formatting parameters that 
apply to each column selected as part of the attribute template. If no attribute template has 
been selected, all the attributes belonging to the spatial object type are displayed.

 Editing multiple objects simultaneously – if you select this option, attributes of multiple 
objects are displayed simultaneously. Where the attributes of all the selected objects are the 
same, a value is displayed. Where attributes of the various objects that were selected differ, 
a value of *VARIES* is displayed. When a change is made to a value, the new value is 
applied to all the selected objects. If you do not select the Edit multiple objects 
simultaneously check box, you can edit the selected objects one by one. The values that are 
changed are only applied to the current object.

 AutoZoom – this option is only available when the Edit multiple objects simultaneously 
option is not selected, i.e. when you are going to edit the objects one by one. If the 
AutoZoom to object option is selected, Munsys will zoom to each object in the drawing as 
it becomes the current object. The object navigation buttons are used to move from one 
object to the next.

The various attributes are displayed on the Edit Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column, either by 
typing a new value or by selecting a value from a drop-down list. Changes that are made are 
applied to objects in the drawing. These changes will only be updated in the database when the 
object integrity check has been run and the objects have been posted to the database.



Working with Munsys objects 145 








To edit spatial object attributes

1 Choose Change > Edit Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial Object 
Identification dialog box is displayed.

Figure 27 The Spatial Object Identification dialog box

3 Select a single spatial object type to edit, and then click OK.

The Edit Attributes: [Object Type] dialog box is displayed.

Figure 28 The Edit Attributes dialog box
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4 If you want to edit the objects using an attribute template, select the appropriate attribute template 
from the Attribute Template list. If you do not want to make use of an attribute template, select 
None.

5 If you want to edit the attributes of all the selected objects at the same time, select the Edit multiple 
objects simultaneously check box.

Similar values are displayed, while values that differ between objects are displayed as *VARIES*, as 
seen in the following figure:

Figure 29 The Edit Attributes dialog box: Edit multiple objects simultaneously

6 If you want to edit the selected objects one by one, clear the Edit multiple objects simultaneously 
check box. Select the AutoZoom to object check box to zoom to the objects one by one and 
highlight them. The object navigation buttons are used to move from one object to the next.

7 To edit an attribute, do one of the following:

 Highlight a value, and then choose a new value from the drop-down list in the Value column.

 Highlight a value, and then enter a new value in the Value column

8 Click OK to apply the new value(s) to the object(s).

9 The values are applied to the objects, to be verified with the object integrity check.
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Editing linked table attributes
This function is used to edit spatial object attributes that exist in linked tables. Linked table 
attributes are updated directly to the database. The current application determines what object 
types may be selected; for example, if you are working in Munsys Cadastral, only cadastral 
objects may be selected. If you select more than one object type (for example parcels and 
easements), you will be required to choose a single object type to edit. You can only select 
objects that have previously been posted to the database.

The link tables that can be edited using this function must be defined through an attribute 
template. The applicable attribute template is selected from a list, which is created by filtering 
attribute templates according to the following characteristics:

 Only attribute templates associated with the current spatial object type, being edited are 
included – the primary table in the attribute template is the same table from which the 
spatial objects were queried.

 Only attribute templates that contain linked tables are included

 The linked table specified may not be a Munsys spatial table

 The user must have edit privileges to the linked table

 The link column used to describe the relationship with the primary table must reference a 
true column in the linked table. This may not be an expression.

Attributes are displayed on the Linked Table Attributes dialog box in three columns: 
Description, Value and Column Name. You can resize the dialog box for easier viewing. Values 
that may not be edited are unavailable. Attributes are edited in the Value column by typing in 
a new value. Navigation buttons are used to move between the various records that are available 
and to move from one object to the next. You can also insert records into, or delete records from 
a linked table, depending on the privileges you have on the linked table.

To edit linked table attributes

1 Choose Change > Edit Linked Table Attributes...

2 Select the objects that you want to edit, and then press ENTER.

If you selected more than one object belonging to different object types, the Spatial

Object Identification dialog box is displayed.

Figure 30 The Spatial Object Identification dialog box
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3 Select a single spatial object type to edit, and then click OK.

The Linked Table Attributes dialog box is displayed.

4 Select the attribute template that you want to work with from the Attribute Templates Containing 
Linked Tables list.

Figure 31 The Linked Table Attributes dialog box

The Description, Value and Column Name columns are populated according to the template that 
you selected, and the number of records and objects that were selected are displayed.

Figure 32 The Linked Table Attributes dialog box

5 Select the AutoZoom to object check box to zoom to each object and highlight it as it becomes the 
current object. 

6 Use the navigation buttons to move between records and objects.

7 To insert a new record, click Insert, and then enter the new values in the Value column.
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Figure 33 The Linked Table Attributes dialog box

8 To delete the record that is currently displayed, click Delete.

9 Click OK to update the changes to the database.
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The Integrity Check function – an overview
The Integrity Check function provides a set of rules to validate spatial objects. All new or 
modified spatial objects have to be verified against integrity rules built into the capture and 
change routines of every application before they can be posted to the database. New and 
changed objects contain an internal status that requires the validation process. The Integrity 
Check function is run from the Capture menu, or by clicking the appropriate button on the 
Integrity toolbar. The way in which the integrity check is executed depends on the 
preferences/options specified in the Munsys Options dialog box. The integrity check is split 
into two separate functions to facilitate flexibility and ease of use:

 Validate Object Integrity – checks and validates the spatial and/or attribute data of an 
object, according to the options specified in the Munsys Options dialog box:

 When the Validate Geometry: Modified objects option has been selected, the geometry 
of only new or modified objects will be validated.

 When the Validate Geometry: All objects option has been selected, all the objects in the 
selection set will have their geometry validated. This includes locked, unlocked, 
modified and non-modified objects. 

It is also possible to perform certain Compound Validations in Munsys. Compound Validations 
allow administrators to ensure that the selected value in one field limits acceptable values in 
another. Currently available Compound Validations options are provided by the Integrity 
‘Compare’ Rule. This value comparisons are performed during the Object Integrity tests.

Example: Upstream Invert Levels should always be greater than Downstream Invert levels.

When the object integrity check has completed and changes in objects have been 
encountered that may affect network integrity, the following message is displayed if the 
option was specified in the Munsys Options dialog box:$

Figure 34 Network Integrity Warning

 Validate Network Integrity – validates the rules that, together with the objects, make up a 
network, and according to the Network Integrity options specified in the Munsys Options 
dialog box. Network validation includes the topology and connectivity aspects, where 
topology is resembled in the geometry of objects and connectivity by means of attributes 
attached to objects.

This function is dependent on the relationships between objects, and therefore requires 
more objects to be included as part of the validation process than only those that were 
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modified. The Validate Network Integrity function allows non-validated objects to be 
selected, but does not attempt to reset any integrity flags. It only places integrity markers 
when errors are encountered in the network. If the selection set contains objects that have 
not been validated by the Validate Object Integrity function, an Object Integrity Warning 
is displayed, recommending that object integrity has to be checked before network 
integrity.

Figure 35 Object Integrity Warning

Note The procedures for the Integrity Check and Post to Database functions are discussed in detail in the 
various application Training Manuals.

Validating object integrity and posting data to the database at the same time
If you select the Automatically perform Object Integrity option on the Munsys Options dialog 
box Preferences tab, you can perform an object integrity check and database posting operation 
at the same time. The following rules will be applied when the objects integrity phase of the 
operation is executed:

 Only modified objects will be selected for object integrity

 The integrity flag will be reset automatically if the object passes object integrity

 Integrity markers will be placed accordingly where errors occur, as happens when a normal 
object integrity check is run from the Capture menu

 If an error occurs, the integrity flag will not be reset

 Only objects related to the current application will be included in the object integrity check 
(i.e. if you are working in the Cadastral application, only cadastral objects will be checked)

If errors occurred during the object integrity check, you can do one of the following:

 Ignore the errors that occurred and continue to post the objects that passed the integrity 
check to the database

 Cancel the database posting operation and return to the map interface

 View the errors that occurred with the Browse Integrity Markers dialog box (this option also 
cancels the posting operation, allowing you to correct the errors first before attempting to 
post the objects to the database once again)
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Editing Munsys objects
In Munsys, queried data is displayed as Munsys objects. Using the Object menu, these objects 
can be created, changed, deleted, snapped, stored and transformed.

 Create – each application caters for specific spatial objects to be captured, for example 
parcels, easements, cadastral notes, etc., in Munsys Cadastral and sewer pipes, nodes, etc. 
in Munsys Sewer. These objects are captured using the application-specific menu items 
which form part of every Munsys application. Each application also contains menu items 
that enable users to convert AutoCAD entities to Munsys objects related to that 
application. These menu items are available on the Capture and Extras menus of each 
application.

 Change – each application contains menus that enable users to change the geometry and 
attributes of objects related to the specific application. These menu items are available on 
the Change menu. The Object menu caters for generic editing of any object, regardless of 
the application it belongs to.

 Delete – each application caters for deletion of objects related to the specific application. 
The Delete menu item is available on the Change menu of each application.

 Snaps – improves data accuracy when users snap to the closest object as indicated by the 
snap modes.

 Save – store and reload objects to and from DWG and DXF formats.

 Transformation – allows a user to move, scale, rotate, or stretch Munsys objects.

Note This chapter focuses on the generic functionality that is available on the Object menu.
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Editing MunPoint objects
You can add points to a selected MunPoint object or delete points from a selected MunPoint 
object. When adding points to a selected MunPoint object, you need to select existing 
AutoCAD entities or existing MunPoint objects to be added.

Adding points to MunPoint objects
With this function, you can add points to a selected MunPoint object.

To add points to a MunPoint object

1 Choose Object > Edit MunPoint > Add Point.

2 Select the MunPoint object to which you want to add points.

Figure 36 Selecting the MunPoint object to add a point to

3 Select an existing AutoCAD point or an existing MunPoint object that you want to add to the 
MunPoint object.

Figure 37 Selecting a point object to add to the MunPoint object

The change is applied to the appropriate Munsys object, and the object is flagged as a spatial update.

Figure 38 The AutoCAD point is added to the Munpoint (1)

A MunPoint object (stormwater node) is selected

An AutoCAD point object is selected to add to 
the MunPoint object

The AutoCAD point is added to the MunPoint object 
and is displayed in the integrity color, as it has been 
flagged as a spatial change, to be verified with the 
object integrity check.
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Figure 39 The AutoCAD point is added to the Munpoint (2)

Tip AutoCAD points, text or block references are all valid AutoCAD entities that you can add.

Note If an existing MunPoint is added, the original object is flagged to be deleted. This object will be deleted 
from the database when changes are posted. To prevent the object from being deleted, you can explode it 
before adding it to an existing MunPoint object. When a Munsys object is exploded, it loses all the 
properties of a Munsys object and is changed to an AutoCAD entity.

Deleting points from MunPoint objects
With this function, you can delete points from a selected object that contains a cluster of points.

To delete points from MunPoint objects

1 Choose Object > Edit MunPoint > Delete Point.

2 Select the MunPoint object from which you want to delete points, and then select the point that you 
want to delete.

Figure 40 Selecting the object to work with

All changes are applied to the appropriate Munsys objects and are flagged as a spatial update.

Figure 41 Point deleted from the MunPoint object

Tooltip, showing the status of the changed 
MunPoint object

Selecting the point to delete from the MunPoint 
object.

The point that you selected is deleted from the MunPoint 
object, and the object is displayed in the integrity color to 
show that it has been flagged as a spatial change.
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Replace Geometry for MunPoint objects
With this function, you can replace the geometry of a Munpoint object by selecting a CAD 
point, block, circle or text entity. The MunPoint adopts the insertion point of the selected CAD 
entity as its new geometry.

To replace the Geometry for MunPoint objects

1 Choose Object > Edit MunPoint > Replace Geometry.

2 Select the MunPoint object you want to replace.

Figure 42 Selecting the MunPoint object to be replaced

3 Select an existing CAD point, block, circle or text entity that you want to use as the new point 
location.

Figure 43 Selecting the CAD entity to use as the new location

4 The MunPoint is moved to the insertion point of the selected CAD entity.

Figure 44 The Geometry for the MunPoint is sucessfully replaced

A MunPoint object (sewer node) is selected

Select the CAD point, block, circle or text entity 
to use as the new location

The Geometry for the MunPoint is replaced 
with the Geometry from the CAD entity
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Editing MunLine objects
From the Munsys Object menu, you can add, delete, join and merge segments, as well as change 
segment order or direction. The segments should be contained within a MunLine object.

Adding a segment to a MunLine object
With this function, you can add more segments to an existing MunLine object. A segment is a 
disjointed line type object that forms part of the same MunLine object.

To add a segment

1 Choose Object > Edit MunLine > Add Segment.

2 Select the MunLine object to which you want to add a segment.

3 Select the object to add to the MunLine object.

Tip Appropriate entities are lines, arcs, polylines or MunLines. Segments are added separately and attribute 
values of such segments are ignored and inherit the attribute values of the target/existing MunLine.

Note If an existing MunLine object is added, the original object is flagged to be deleted. This object will be 
deleted from the database when changes are posted. To prevent the object from being deleted, you can 
explode it before adding it to an existing MunLine object. When a Munsys object is exploded, it loses all 
the properties of a Munsys object and is changed to an AutoCAD entity.

Deleting segments
This function deletes line segments from a MunLine object that consists of more than one 
segment.

To delete segments

1 Choose Object > Edit MunLine > Delete Segment.

2 Select the MunLine object from which you want to delete a segment.

3 Select the segment that you want to delete.

The selected segment is deleted.

Joining segments
With this function, you can create one segment from two separate segments within a MunLine 
object.

To join segments

1 Choose Object > Edit MunLine > Join Segments.

2 Select the MunLine object that you want to edit.

3 Specify the join mode by doing one of the following:

 Type E, and then press ENTER.

Extended – the indicated endpoints of both objects are extended or trimmed to a 
projected intersection.

 Type L, and then press ENTER.
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Linked – the endpoints of the segments are joined directly from the first endpoint to the 
second endpoint. The positions of the two endpoints become vertices of the new segment.

4 Select the first segment end point to join.

5 Select the second segment end point to join.

The segments are joined as indicated.

Merging segments
With this function, you can merge multiple segments within a MunLine object into fewer 
segments. The merge operation is determined by a merge tolerance. If two endpoints are within 
tolerance, they will be joined directly from one endpoint to the other. The positions of the two 
endpoints become vertices of the new segment.

To merge segments

1 Choose Object > Edit MunLine > Merge Segments.

2 Select the MunLine object that you want to edit.

3 On the command line, type the merge tolerance, and then press ENTER.

Endpoints of segments within the merge tolerance are merged.

Reversing segments
With this function, you can reverse the direction of the start and end coordinates of a MunLine 
object.

To reverse segments

1 Choose Object > Edit MunLine > Reverse Segment.

2 Select the MunLine object that you want to edit.

All the segments within the selected object are highlighted and direction arrows display to indicate 
the current direction for each segment.

3 Select the appropriate segment of which you want to change the direction.

The segment direction is reversed.

Changing segment order
This function is used to specify the order in which multiple segments will be drawn.

To change segment order

1 Choose Object > Edit MunLine > Change Segment Order.

2 Select the MunLine object that you want to edit.

3 Select the segment that will become segment number one, and then select the next segment.

4 Repeat Step 4 until you have selected all the segments in the object.

The segment order is changed accordingly.
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Editing segment vertices
You can add, move, remove or insert new vertices to segments within a MunLine object.

To add a vertex

1 Choose Object > Edit MunLine > Add Vertex.

2 Select the MunLine object that you want to edit.

3 Select the segment end point.

4 Select the position for the new point.

The vertex is added as indicated.

To move a vertex

1 Choose Object > Edit MunLine > Move Vertex.

2 Select the appropriate object.

3 Specify a point on the vertex that you want to move.

4 Specify the point where you want to move the vertex.

The vertex is moved to the point that you specified.

Tip AutoCAD grips can also be used to move a vertex. Grips are only available on locked objects.

To remove a vertex

1 Choose Object > Edit MunLine > Remove Vertex.

2 Select the appropriate object.

3 Select the vertex that you want to remove.

Note A vertex can only be removed from a segment with more than two vertices.

To insert a vertex

1 Choose Object > Edit MunLine > Insert Vertex.

2 Select the appropriate object.

3 Select the segment for the inserted vertex.

4 Select the position for the new vertex.

To replace geometry

1 Choose Object > Edit MunLine > Replace Geometry.

2 Select the MunLine object.

3 Select the new CAD entity.

4 The MunLine geometry has been replaced with the CAD line geometry.
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Deleting multiple vertices on a MunLine object
You can delete multiple vertices from a MunLine object consisting of multiple line segments. 
When prompted, the user selects the MunLine from which the vertices are to be deleted from, 
and draws a polygon around the points to be deleted from the MunLine. The MunLine object 
is then reconstructed excluding the deleted vertices.

To delete multiple vertices on MunLine objects:

1 Choose Object > Edit MunLine > Delete Multiple Vertices.

2 Select the appropriate MunLine object.

 

Figure 45 Selecting the MunLine object 

3 Draw a polygon boundary around the vertices to be deleted.

 

Figure 46 Polygon drawn around vertices to be deleted

4 Select Enter to complete the selection.

5 Confirm that the vertices which have been removed are correct by selecting either Yes or No. 

 

Figure 47 Confirmation of changes to MunLine required

6 The MunLine object is reconstructed excluding the selected deleted vertices, where you are then 
required to complete the Object and Network Integrity checks before posting to the database.

A MunLine object (water pipe) is selected

Polygon drawn around vertices to be deleted

Confirmation of changes to MunLine required 
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Extending an object to a boundary
With this function, you can extend a MunLine object to a boundary by first indicating the 
boundary object, and then selecting the object to extend. The boundary object must be able to 
intersect with the extending object.

To extend an object to a boundary

1 Choose Object > Extend to Boundary.

2 Select the boundary object to extend to.

3 Select the object that needs to extend.

The object is extended to the boundary that you selected.

Extending an object by distance
With this function, you can extend a MunLine object by a specified distance at the endpoint 
closest to a selected point on the object. You will be prompted for the distance to extend the 
object with. You can also use this function to shorten an object by entering a negative distance, 
for example, -50.

To extend an object by distance

1 Choose Object > Extend by Distance.

2 Select the object that you want to extend.

3 Type a distance on the command line, and then press ENTER.

The object is extended as specified.

Extending and breaking an object
With this function, you can extend a MunLine object to a boundary line, which is then broken 
at the intersection. The boundary must be a MunLine object. The MunLine to be broken must 
be able to intersect with the second line. 

To extend and break an object

1 Choose Object > Extend and Break.

2 Select the MunLine object that you want to break.

3 Select the MunLine object that you want to extend.

The first MunLine object is broken, and the second MunLine object is extended to the 
intersection.

Note This function can only be executed if the MunLine object that needs to break consists of more than one 
segment.
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Breaking objects
This function is used to break a MunLine object. You have the option to save both segments to 
the original object as two new segments, or to create two new Munsys objects. If you choose to 
save both segments, the object is flagged with a Change status. If new objects are created, the 
attribute information from the original object is copied to the new objects. The original object 
is flagged with a Delete status and will be deleted when changes are posted to the database.

To break objects

1 Choose Object > Break.

2 Specify the target – to create new segments or objects.

3 Select the MunLine object that you want to break.

4 To select the break point, do one of the following:

 On the command line, type F to indicate a first break point different from the selection point at 
Step 3.

 Select the second break point.
This step removes the section between the first and second indicated points. If you type an @ at the 
second break point, the second break point is a duplicate of the first indicated point and therefore 
there are no sections to be removed.

Note You cannot break a MunLine object that consists of more than one segment.

Chamfering objects
With this function, you can create a beveled edge between two non-parallel MunLine objects. 
You will be prompted with chamfer distances, shorter than the segments to be chamfered. 
Indicated segments do not need to touch, therefore this results in trimmed or extended 
segments.

To chamfer objects

1 Choose Object > Chamfer. 

2 Specify the first chamfer distance.

3 Specify the second chamfer distance.

4 Indicate the first MunLine object to chamfer to.

5 Indicate the second MunLine object to chamfer to.

Note A chamfer distance of 0 extends two objects to a projected intersection. The newly created object will not 
have any attributes; they need to be assigned manually.
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Filleting objects
With this function, you can create a fillet – arc shaped object between two MunLine objects. 
You will be prompted to indicate the points on the two objects that need to extend to the 
intersecting points, and to specify a radius for the fillet.

To create a fillet

1 Choose Object > Fillet.

2 Indicate the first object to fillet.

3 Indicate the second object to fillet.

Note The newly created arc (MunLine) does not have any attributes; they have to be assigned manually.

Trimming MunLine objects
This function trims an object’s start or end point to a point of intersection with another object. 
First, you will be prompted for the cutting edge of the intersection object. Next, you will 
indicate the object(s) that need to be trimmed. Multiple lines can be trimmed using the same 
cutting edge. These objects must be MunLine objects.

To trim MunLine objects

1 Choose Object > Trim.

2 Indicate the cutting edge – object to trim to. The cutting edge object is highlighted.

3 Indicate the object(s) to trim – select the objects to trim individually using the same cutting edge, 
and then press ENTER to end the command.

Weeding objects
This function is used to remove redundant coordinates from selected objects, resulting in more 
smoothed objects. This is achieved by removing coordinates that reside within a smoothing 
tolerance, except if the last coordinate falls within the tolerance.

To weed objects

1 Choose Object > Weed.

2 On the command line, type in the smoothing tolerance, or select two points in the drawing indicating 
the distance between the points to use as the tolerance.

The command line indicates the entered value as the current tolerance, which is set to 1 by default.

3 Select the object(s) that you want to weed, and then press ENTER.

The command line indicates the number of original coordinates and the number of new 
coordinates.

Note Both MunLine and MunPoly objects can be selected with this function. The last used tolerance is retained 
for the AutoCAD session.
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Editing MunPoly objects
A Munsys polygon (MunPoly) is defined as a closed area. When editing a polygon, you can add 
a disjoint boundary to the existing object, add an inner boundary, delete an existing boundary 
or edit a vertex on an existing boundary.

A polygon has to adhere to specific rules in order to be a valid polygon. These rules are defined 
by the OpenGIS standards. An example of one of the rules is that an island may not intersect 
with its outer boundary (the island may touch the outer boundary). For more information 
about these rules, please refer to the documentation available on OpenGIS standards.j

Munsys will prevent users from creating an invalid object based on these rules. If you query an 
invalid MunPoly object from the database, Munsys will construct the invalid object and display 
an error message on the command line. You will be allowed to change the object to a valid 
polygon, but you will be prevented from making changes to the polygon that will render it 
invalid again.

Adding a disjoint boundary to a MunPoly object
With this function, you can add an outer boundary to a MunPoly object by selecting a closed 
AutoCAD polyline (lwpolyline), an AutoCAD polygon (mpolygon) or an existing MunPoly 
object.

To add a disjoint boundary to a MunPoly object

1 Choose Object > Edit MunPolygon > Add Disjoint Boundary.

2 Select the appropriate MunPoly object.

3 Select a new disjoint boundary object.

Munsys adds the new boundary to the MunPoly object.

Note If an existing MunPoly is added, the original object is flagged to be deleted. This object will be deleted 
from the database when changes are posted. To prevent the object from being deleted, you can explode it 
before adding it to an existing MunPoly object. When a Munsys object is exploded, it loses all the 
properties of a Munsys object and is changed to an AutoCAD entity.

Adding an inner boundary
An inner boundary, also known as an island, is attached to a disjoint boundary. When executing 
this function and you select a complex MunPoly object, you will be prompted to indicate the 
disjoint boundary to which the island belongs, and then indicate the inner boundary.

To add an inner boundary

1 Choose Object > Edit MunPolygon > Add Inner Boundary.

2 Select the appropriate MunPoly object.

3 Select the inner boundary.

Munsys assigns the new inner boundary to the selected object.

Note Where more than one disjoint polygon belongs to a MunPoly object, you are prompted to first select the 
object to edit, and then select the disjoint boundary.
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Deleting a boundary
With this function, you can remove islands and/or disjoined boundaries from a MunPoly 
object. The function requires a complex MunPoly object to be executed successfully. When you 
remove a disjoined boundary, all islands attached to the boundary are removed automatically.

To delete a boundary

1 Choose Object > Edit MunPolygon > Delete Boundary.

2 Select the appropriate MunPoly object.

3 Indicate the boundary that you want to delete.

Munsys deletes the boundary.

Editing a MunPoly vertex
With these functions, you can move or remove vertices from MunPoly objects, or insert new 
vertices into segments within MunPoly objects.

To move a MunPoly vertex

1 Choose Object > Edit MunPolygon > Move Vertex.

2 Select the appropriate MunPoly object.

3 Select the vertex that you want to move.

4 Select a new position for the vertex.

The vertex is moved to the new position that you selected.

To remove a MunPoly vertex

1 Choose Object > Edit MunPolygon > Remove Vertex.

2 Select the appropriate MunPoly object.

3 Select the vertex that you want to remove.

The vertex is removed.

Note A vertex can be removed when a polygon contains more than four vertices. The first and last vertices are 
duplicate vertices to close the polygon.

To insert a MunPoly vertex

1 Choose Object > Edit MunPolygon > Insert Vertex.

2 Select the appropriate MunPoly object.

3 Select the boundary where you want to insert the vertex.

4 Indicate the position for the new vertex.



Working with Munsys objects 165 








To replace geometry

1 Choose Object > Edit MunPolygon > Replace Geometry.

2 Select the MunPolygon object.

Figure 48 Selecting the MunPolygon object to be replaced

3 Select the new CAD polygon entity.

Figure 49 Selecting the CAD polygon object 

4 On selection, the MunPolygon geometry is replaced with the CAD polygon geometry.

Figure 50 The MunPolygon object is replaced with the selected CAD polygon

A MunPolygon object (sewer basin) is selected

A CAD Polygon is selected

The MunPolygon object is replaced with the 
selected CAD polygon
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Deleting multiple vertices on a MunPolygon Object
You can delete multiple vertices from a MunPolygon object. When prompted, the user selects 
the MunPolygon from which the vertices are to be deleted from, and draws a polygon around 
the points to be deleted from the MunPolygon. The MunPolygon object is then reconstructed 
excluding the deleted vertices.

To delete multiple vertices on MunPolygon objects:

1 Choose Object > Edit MunPolygon > Delete Multiple Vertices.

2 Select the appropriate MunPolygon object.

 

Figure 51 Selecting the MunPolygon object 

3 Draw a polygon boundary around the vertices to be deleted.

 

Figure 52 Polygon drawn around vertices to be deleted

4 Select Enter to complete the selection.

5 Confirm that the vertices which have been removed are correct by selecting either Yes or No. 

 

Figure 53 Confirmation of changes to MunPolygon required

6 The MunPolygon object is reconstructed excluding the selected deleted vertices, where you are then 
required to complete the Object and Network Integrity checks before posting to the database.

A MunPolygon (Retention Dam) is selected

Polygon drawn around vertices to be deleted

Confirm changes to MunPolygon
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Split Geometry
A lightweight polyline must be used to split an existing MUNPOLY object into two new 
polygons. This can be particularly useful when capturing subdivisions of existing land parcels 
where the user draws the LWPOLYLINE object as the split line, and the function generates two 
new polygon objects from the existing object. 

When splitting polygons, the user has the option to either delete the existing object, or retain 
the existing object. The newly created objects are locked by default and take on all the attributes 
assigned to the original MUNPOLY object, and it is up to the user to use the Change and 
Object menu items to modify the original object and the new objects.

To split geometry
You are required to query the polygon objects into the AutoCAD drawing and draw a 
LWPOLYLINE object to use as the split using the PLINE command. This LWPOLYLINE can 
either be drawn freehand or constructed using coordinates.

1 Choose Object > Edit MunPolygon > Split Geometry.

2 Select the MunPoly object.

Figure 54 A LWPOLYLINE is required to be used as the Split boundary

3 Select the LWPOLYLINE to use for the split.

The command line prompts the user to delete the original MUNPOLY object or not. 

4 Enter Y to delete the original MUNPOLY, or press Enter to accept the default value of No.

Munsys creates two new MUNPOLY objects from the original polygon. All attribute values 
stored with the original polygon are copied across to the new polygons and the objects are 
locked for editing by default.

In the example of splitting a single parcel into two new parcels, the user must use the cadastral 
Change > Parcel > Edit Parcel Info menu item to edit the parcel tag and parcel key values, while 
using the Object > Change Tag menu items to change the position, height and angle of the new 
parcel tags.

Query the original MUNPOLY object and 
create the LWPOLYLINE to use as the split
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Figure 55 Two new MUNPOLY objects are createdt

Figure 56 The Tags are modified using the Change and Object Menu items

Two new MUNPOLY objects are created and 
attributes from the original polygon copied.

Tags are modified and moved using the Change 
and Object menu items.
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Edit MunLabel Objects
A Munsys label (MunLabel) is defined as a object containing text information representing a 
specified column(s) in the database. When editing a MunLabel you can only change the existing 
label geometry with the insertion point of a CAD Point, Block, Circle or Text entity. 

To replace the Geometry for MunLabel objects

1 Choose Object > Edit MunLabel > Replace Geometry.

2 Select the MunLabel object you want to replace.

Figure 57 Selecting the MunLabel object to be replaced

3 Select an existing AutoCAD Point, Circle, Block or Text entity that you want to use as the new label 
insertion point.

Figure 58 Selecting the AutoCAD Entity to use as the new label insertion point.

4 The MunLabel is moved to the selected AutoCAD entity’s insertion point.

Figure 59 The Geometry for the MunLabel is successfully replaced.

A MunLabel object (water pipe label) is 
selected

Select the AutoCAD entity to use as the new 
label insertion point

The Geometry for the MunLabel is replaced 
with the Geometry from the AutoCAD entity
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Generating MunPoly objects
AutoCAD lines can be selected to build MunPoly objects. Munsys uses a reference point to 
search for the lines that will form a closed polygon around this point in order to build the 
polygon boundary. MunPoly objects are built using one of the following as a reference point:

 by picking a point inside a set of closed AutoCAD lines that forms a polygon.

 by selecting AutoCAD text objects as reference – the insertion point of the text is used

 by selecting AutoCAD points as reference

 by selecting AutoCAD blocks as reference – the insertion point of the block is used

To generate a MunPoly object by pick point
This function is used to build polygons by picking a point inside a set of closed lines. Munsys 
uses the existing lines to construct the polygon.

1 Choose Object > Generate MunPolygon > by Pick Point...

The Select Spatial Table dialog box is displayed.

Figure 60 The Select Spatial Table dialog box

2 Select the appropriate table from the list, and then click OK.

3 Select the line objects to generate the polygon from, and then press ENTER.

Figure 61 Selecting lines to generate a polygon from
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4 Specify a detection point inside the polygon, and then press ENTER.

Figure 62 Specifying the detection point inside a polygon

Tip To generate more than one polygon at a time, you can select multiple sets of closed lines (see the following 
figure), and then pick points one after the other within each polygon.

Figure 63 Generating more than one polygon at a time

Polygons are generated and stored on their appropriate layers. The polygons are displayed in the 
integrity color because they have been flagged to be verified by the object integrity check.

Select multiple sets of closed lines
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To generate a MunPoly object from text
This function is used to build MunPoly objects by using an AutoCAD text entity as a reference 
point. When the polygon is built, the text is converted to the polygon tag. With this function, 
multiple polygons can be generated. The content of the text is populated in the TAG_VALUE 
column in the database and the other properties such as text height is populated in the 
TAG_SIZE column. The angle is populated in the TAG_ANGLE column and the justification 
in the TAG_JUST column. 

1 Choose Object > Generate MunPolygon > from Text...

The Select Spatial Table dialog box is displayed.

Figure 64 The Select Spatial Table dialog box

2 If you do not want the reference object to be erased from the drawing once the polygon has been built 
successfully, clear the Erase reference object if polygon created successfully check box.

3 Select the appropriate table from the list, and then click OK.

4 Select the line objects to generate the polygons from, and then press ENTER.

Figure 65 Selecting line objects to generate polygons
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5 Select the text objects inside the lines, and then press ENTER.

Figure 66 Selecting text objects within the set of lines

The polygons are generated and stored on the appropriate layer. The polygons are flagged to be 
checked when the integrity check is run.

To generate a MunPoly object from a point object
This function is used to build MunPoly objects by using a selected AutoCAD point object as a 
reference.

1 Choose Object > Generate MunPolygon > from Point...

The Select Spatial Table dialog box is displayed.

Figure 67 The Select Spatial Table dialog box

2 If you do not want the reference object to be erased from the drawing once the polygon has been built 
successfully, clear the Erase reference object if polygon created successfully check box.

3 Select the appropriate table from the list, and then click OK.

4 Select the line objects to generate the polygons from, and then press ENTER.
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Figure 68 Selecting text objects within the set of lines

5 Select the point objects inside the polygon lines, and then press ENTER.

The polygons are generated and stored on the appropriate layer. The polygons are flagged to be 
checked when the integrity check is run.

To generate a MunPoly object from a block object
This function is used to build MunPoly objects by using a selected AutoCAD block object as a 
reference.

1 Choose Object > Generate MunPolygon > from Block...

The Select Spatial Table dialog box is displayed.

The Select Spatial Table dialog box

2 If you do not want the reference object to be erased from the drawing once the polygon has been built 
successfully, clear the Erase reference object if polygon created successfully check box.

3 Select the appropriate table from the list, and then click OK.

4 Select the block objects to generate the polygons from, and then press ENTER.

The polygons are generated and stored on their appropriate layer. The polygons are flagged to 
be checked when the integrity check is run.
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Rebuilding existing MunPolygon objects
This function is used to rebuild the geometry of a selected polygon, while keeping all the 
existing attributes, for example when more accurate cadastral data becomes available and a 
section needs to be rebuilt. 

You will be prompted to select the lines for the polygon builder. If the geometry consists of arcs, 
you will have to convert the arcs to lines before constructing the new polygons. Once the lines 
have been selected, you will be prompted to select the existing objects. The lines must be 
cleaned using the line integrity tools before polygons can be constructed.

An integrity check must be run on the new polygons before they can be posted to the database.

Note This function does not cater for complex objects.

To rebuild an existing MunPolygon

1 On the command line, enter MUNPOLYREBUILD.

2 Select the appropriate lines, and then press ENTER.

3 Select the existing objects for the polygon builder, and then press ENTER.

The command line indicates how many polygons were rebuilt.

Validating a MunPolygon
This function is used to validate one or more selected MunPoly objects according to OpenGIS 
standards.

1 Choose Object > Validate MunPolygon.

2 Select the MunPoly object(s) that you want to validate.

Crossing polygons are marked by integrity markers.
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Working with tags
Munsys uses a number of default columns in the spatial table as attributes for an object tag. 
Each object can only have one tag. The tag forms part of the object. The default system query 
is set up to query the tag with the object where required. This can be changed on the Spatial 
Query Details dialog box (see Chapter 3-24).Tags are displayed using various attributes such as 
tag value, height, rotation angle, justification and position.

Changes to tag properties are posted to the database based on the following rules:

Tag value change – if the tag value is changed, the TAG_VALUE column will be updated. 
Functions that change the tag value display the value in the TAG_VALUE column in the 
database.

Tag position change – if the tag position is changed, the TAG_X and TAG_Y columns are 
updated. Locking an object will ensure that the current tag position will be updated because the 
tag position is refreshed as part of the locking process.

Tag property change – any change to the tag height, angle or justification will update the 
TAG_SIZE, TAG_ANGLE and TAG_JUST columns with the values in the drawing. This 
means that if the query is changed to query the object with a different value for height, angle 
or justification and only one of these properties is changed, all the properties will be updated in 
the database.

Placing a tag
This function is used to place Munsys tags in the drawing area. Tags are used by the polygon 
builder to build Munsys Polygons (MunPoly objects), for example: a parcel consists of a parcel 
boundary and a parcel tag (usually the parcel number). The tag forms part of the object. Munsys 
polygons can be built by selecting tags and lines.

To place a tag

1 On the command line, type MUNTAG, and then press ENTER.

The following prompt is displayed: Specify spatial object [? For List]:

2 Enter the appropriate MunID on the command line, or enter ? to display a list of the available spatial 
objects.

The following prompt is displayed: 
Specify insertion point of tag or [Justify/eXit]:

3 Specify an insertion point for the tag with your mouse pointer, or enter J on the command line to 
specify a justification:

Enter an option [Left/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]:

4 Enter the justification.

The following prompt is displayed: Specify insertion point of tag: 

5 Specify an insertion point for the tag with your mouse pointer.

The following prompt is displayed: Specify tag height <10.00>: 

6 Enter the tag height on the command line, or indicate the height in the drawing with your mouse 
pointer.
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The following prompt is displayed: Specify tag angle or [Align to segment]:

7 Specify the tag angle with your mouse pointer, or enter A on the command line to align the tag with 
an object:

The following prompt is displayed: Select object to align to: 

8 Select the object to which you want to align the tag.

The following prompt is displayed: Enter tag value: 

9 Enter the tag value on the command line.

The tag is placed as specified.

Finding a tag
This function is used to find a tag. Munsys searches for all occurrences of the required tag.

To find a tag

1 Choose Object > Find Tag...

The Enter Search String: text box is displayed.

2 Enter the appropriate search string, and then click OK. The search string is case sensitive.

Figure 69 Enter Search String

The function zooms to the tag and displays it in the center of the drawing area, as seen in the 
following example:

Figure 70 Finding a tag
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Tip If more than one tag was found, the command line will prompt you to zoom to the next tag, allowing you 
to view the tags one by one.

Changing a tag value
This function is used to change the value of one or more selected tags. The new value is updated 
to the database when changes are posted.

To change tag value

1 Choose Object > Change Tag > Value...

2 Select the tag(s) of which you want to change the value, and then press ENTER.

The Tag Value text box is displayed. If you selected a single tag to change, the current tag value is 
displayed in the text box. If you selected multiple tags to change, the text box will be empty.

Figure 71 The Tag Value text box

3 Type the new value in the text box, and then click OK.

Note The value displayed in the text box is obtained from the TAG_VALUE column in the database. This value 
might differ from the current tag value in the drawing, depending on the value column that was used 
during the query.

Changing a tag angle
This function is used to change the angle of one or more selected tags.

To change a tag angle

1 Choose Object > Change Tag > Angle.

2 Select the object(s) that you want to change, and then press ENTER.

3 To change the angle of a tag, do one of the following:

 On the command line, enter the new tag angle, and then press ENTER.

 On the command line, enter A to align tag with an object, press ENTER, and then select the 
object to align the tag to.

 Indicate the angle by specifying two points.
The angle is changed as specified.

Note This update flags the object for a tag property change and the tag height/justification will also be updated 
when the changes are posted to the database.



Working with Munsys objects 179 








Changing tag height
With this function, you can change the height of one or more selected tags, for example when 
a series of tags need to have the same height.

To change tag height

1 Choose Object > Change Tag > Height.

2 Select the object(s) that you want to edit, and then press ENTER.

3 On the command line, type the new tag height, and then press ENTER.

The tag height is updated and is displayed in the drawing.

Note This update flags the object for a tag property change and the tag angle/justification will also be updated 
when the changes are posted to the database.

Changing tag justification
With this function, you can change the height of one or more selected tags, for example when 
a series of tags need to have the same justification.

To change tag justification

1 Choose Object > Change Tag > Justification.

2 Select the object(s) that you want to edit, and then press ENTER.

3 On the command line, type the appropriate justification, and then press ENTER.

The tag justification is updated accordingly.

Note This update flags the object for a tag property change and the tag height/angle will also be updated when 
the changes are posted to the database.

Changing tag position
This function is used to move the tags of selected objects to a new position.

To change tag position

1 Choose Object > Change Tag > Position.

2 Select the tags that you want to move.

3 Specify a base point.

4 Specify the target point.

The tags are moved to the target point that you specified.

Note The object is flagged as a tag position change only and the TAG_X and TAG_Y columns will be updated 
when changes are posted to the database.
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Aligning tags to a specified angle
With this function, you can select one or more objects and specify a segment to align the tag 
angle to. It is normally used during the cadastral capture procedure to align the angle of parcel 
numbers with cadastral boundaries.

To align a tag to a specified angle

1 Choose Object > Change Tag > Align Angle.

2 Select the appropriate object(s), and then press ENTER.

3 Select the segment to align the tag angle to.

The tag is updated accordingly and the object is flagged for a tag property change.

Aligning tag position
With this function, you can specify the start and end point of alignment for one or more 
selected tags. This is normally used during the cadastral capture procedure to align the position 
of parcel numbers.

To align a tag position

1 Choose Object > Change Tag > Text Align.

2 Select the object(s) to align, and then press ENTER.

3 Specify a first point for alignment.

4 Specify a second point for alignment.

The tag is aligned/moved according to the line that you specified and the object is flagged for 
a tag position change.

Resetting a tag position
This function is used to reset the position of one or more selected tags to their default position. 
The default position is calculated according to the current geometry of the object in the 
drawing.

To reset a tag position

1 Choose Object > Change Tag > Set Default Position.

2 Select the tags that you want to reset, and then press ENTER.

The tags are reset to their default position, for example the tag of a MunPoint object is set to the 
insertion point of the symbol. The tag is flagged for a tag position change.
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Adding a tag prefix
This function is used to change the value of a tag by adding a prefix.

To add a tag prefix

1 Choose Object > Change Tag > Add Prefix.

2 Select one or more objects to edit, and then press ENTER.

3 On the command line, enter the prefix value, and then press ENTER.

The tags are updated on the screen and flagged for a tag value update.

Adding a tag suffix
This function is used to change the value of a tag by adding a suffix.

To add a tag suffix

1 Choose Object > Change Tag > Add Suffix.

2 Select one or more objects to edit, and then press ENTER.

3 On the command line, enter the suffix value, and then press ENTER.

The tags are updated on the screen and flagged for a tag value update.
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Changing symbol properties
Using the following functions, you can change the angle and scale of one or more selected 
MunPoint objects. If you select one symbol to change, the default value for that symbol is 
displayed on the command line. If you select more than one symbol to change, no default value 
is displayed.

The object is flagged for a symbol property change, which means that symbol angle and scale 
will be updated with the value in the drawing, even if only one of the properties was changed.

Changing the angle of a symbol
This function is used to change the angle of one or more selected symbols.

To change the angle of a symbol

1 Choose Object > Change Symbol > Angle.

2 Select the symbol(s) of which you want to change the angle, and then press ENTER.

3 To change the angle, do one of the following:

 Specify the angle with your mouse pointer.

 Type the angle on the command line.
The angle is changed as specified.

Changing the scale of a symbol
With this function, you can change the scale of one or more selected symbols.

To change the scale of a symbol

1 Choose Object > Change Symbol > Scale.

2 Select the symbol(s) of which you want to change the scale, and then press ENTER.

3 To specify a new scale, do one of the following:

 Specify the scale with your mouse pointer.

 Type the scale on the command line.
The scale is changed as specified.
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Editing object display properties
With this function, the display properties of multiple Munsys objects can be set for geometry, 
tag and in the case of a MunPoly object, the fill. Display properties are not stored as attribute 
data of the object; therefore the object status flag is not affected by this change. The changed 
object does not need to be validated by an integrity check, and the object does not need to be 
updated to the database.

To edit object display properties

1 Choose Object > Object Display Properties...

2 Select the objects of which the display properties need to change.

The Object Display Properties dialog box is displayed.

Figure 72 The Object Display Properties dialog box

3 Change the appropriate field values, and then click OK.

The selected values are changed accordingly.
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 Chapter 5


 Munsys line tools

Objectives
This chapter describes the various line tools that are available in the Munsys applications. 
These line tools provide various functions that are used to construct cadastral boundaries from 
registered plans. The line tools are also used to clean new data that has been captured.
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Creating a coordinate file
With this function, you can create a file to enter and store a list of coordinates, for example to 
create parcel boundaries. With the coordinate entry, you can enter a plan number, coordinate 
label, and XY coordinates. A setting is available to automatically change the positive/negative 
signs of the coordinates entered when the local coordinate system is in the opposite quadrant 
to the GIS coordinate system.

These coordinates can then be used to construct the line work required for the boundaries that 
you are creating. The coordinate file is in interchangeable format.

To create a coordinate file

1 Choose Tools > Coordinate File > Enter Coords...

The COORD Filename dialog box is displayed. 

Figure 1 The COORD Filename dialog box

The coordinate files are stored in the Munsys working directory.

2 Enter an appropriate filename, and then click OK.

Note The default file name is Coords.lxy. If you are using an existing file name, the command line will prompt 
you to append the coordinates to the existing file, or overwrite the file.
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The Coord Capture dialog box is displayed.

Figure 2 The Coord Capture dialog box

3 Select the Change coordinate signs check box to update the coordinate list with negative values 
where appropriate.

4 Enter the Plan number, and then press the TAB key.

5 Enter the Label, and then press the TAB key.

6 Enter the Y-Coord, and then press the TAB key.

7 Enter the X-Coord, and then press the TAB key to add the first coordinates to the coordinate list.

8 Repeat Steps 3 to 6 to populate the coordinate list, and then click OK.

Figure 3 A populated coordinate list
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Viewing coordinates
You can display the contents of a coordinate file, should you wish to review it.

To view coordinates

1 Choose Tools > Coordinate File > View Coords...

The COORD Filename dialog box is displayed.

The coordinate files are stored in the Munsys working directory.

2 Select the coordinate file that you want to view, and then click Open.

The filename.LXY dialog box is displayed.

Figure 4 The filename.LXY dialog box

3 Click OK to close the coordinate file.
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Constructing boundaries from a coordinate file
This function is used to construct coordinated boundaries from registered plans. The 
boundaries are then used as the basis for further construction.

When you have selected the file that you are going to use for the construction, you will be 
prompted for the plan name to construct, and then continuously prompted for the start label 
and end label. The lines are constructed between these points. The distance between the points 
are displayed on the command line for checking purposes.

To construct boundaries from a coordinate file

1 Choose Tools > Coordinate File > Construct...

The COORDS Filename dialog box is displayed. 

Figure 5 The COORDS Filename dialog box

The coordinate files are stored in the Munsys default directory.

2 Select the appropriate coordinate file, and then click Open.

3 On the command line, enter the plan reference number as prompted, and then press ENTER.

4 On the command line, enter the start point label as prompted, and then press ENTER.

5 On the command line, enter the end point label as prompted, and then press ENTER.

The entity is constructed in the current drawing.

6 Indicate if the constructed entity is correct, as prompted by the command line.

7 Repeat Steps 4 and 5 until you have constructed all the appropriate labels in the coordinate file, and 
then press ESC.
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Additional capture options
The Tools menu contains several items that can assist with drawing and cleaning up AutoCAD 
entities before they are converted to Munsys objects, or used to build polygons from. All the 
menu items on this menu call functions than only work with AutoCAD entities.

Note You can use the Munsys Line Tools Toolbar as well, which contains some of the Tools menu items.To 
display the Munsys LineTools toolbar, right-click in the grey area on the right-hand side of the Munsys 
Standard toolbar, and then select the toolbar from the AutoCAD menu.

Drawing lines by distance and direction
This function constructs lines by prompting for a start point, and then continuously prompting 
for the distance and direction to the next point.

To draw lines by distance and direction

1 Choose Tools > Draw by Dist/Dir.

2 Press ENTER to select a Munsys angle format.

3 Select a point or type the coordinates on the command line.

4 To specify the distance, do one of the following:

5 On the command line, type the distance, and then press ENTER.

6 On the command line, type the direction in degrees minutes seconds, and then press ENTER. (For 
example 23.2541 where 23=degrees, 25=minutes and 41=seconds.)

7 On the command line, type A to draw an Arc.

8 On the command line, type the distance, and then press ENTER.

9 On the command line, type the radius, and then press ENTER.

10 Press ENTER if the arc is on the correct side.

11 Repeat the above steps to construct more lines/arcs.

12 On the command line, type X to exit the command.

Note If the AutoCAD format is selected, type the direction in any of the formats supported by AutoCAD, for 
example 23d25’41”

Drawing lines by distance and angle
This function is mostly used on plans where lines are shown with distances and internal angles, 
instead of distance and direction.

You are continuously prompted for a distance and internal angle to the next point. 

To draw by distance and angle

1 Choose Tools > Draw by Dist/Angle
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2 Press ENTER to select a Munsys angle format.

3 Select a point or type the coordinates on the command line.

4 To specify the distance, do one of the following:

5 On the command line, type the distance, and then press ENTER.

6 On the command line, type the direction in degrees minutes seconds, and then press ENTER. (For 
example 23.2541 where 23=degrees, 25=minutes and 41=seconds.)

7 On the command line, type A to draw an Arc.

8 On the command line, type the distance, and then press ENTER.

9 On the command line, enter the internal angle.

10 On the command line, type the radius, and then press ENTER.

11 Press ENTER if the arc is on the correct side.

12 Repeat the above steps to construct more lines.

13 On the command line, type X to exit the command.

Note If the AutoCAD format is selected, type the direction in any of the formats supported by AutoCAD, for 
example 23d25’41”

Writing distance and direction on lines
This function is used to annotate the distance and direction of a line. The text is placed on the 
DISTANCE and DIRECTION layers respectively.

To write distance and direction on lines

1 Choose Tools > Write Dist/Dir on Lines.

2 Select the appropriate line objects, and then press ENTER.

Munsys determines distance and direction measurements of spatial objects in the current 
drawing direction setup and annotates these measurements, aligned with the spatial objects.
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Figure 6 Writing distance and direction on lines

Note A standard format is used to display the direction as follows: DDD-MM-SS
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Rotating by reference
This function is mostly used in cases where parcel diagrams contain local angles and need to be 
rotated to match surrounding parcels.

The command line prompts for the selection of the objects to be rotated, after which you have 
to specify the base point for rotation. You are then prompted for a reference point and a 
destination point for the objects.

The objects are rotated based on the indicated reference point.

To rotate by reference

1 Choose Tools > Rotate by Reference.

2 Select the objects that you want to rotate.

3 Select the base point of the object(s) – point of rotation.

4 Indicate the 1st reference point.

5 Indicate the 2nd reference point to complete the rotation.

The selected spatial objects are rotated by the reference angle.

Joining lines
This function joins two lines by prompting you to select the first and second line. This is often 
used to correct lines that were broken in the wrong place during cadastral construction. The 
two endpoints that are furthest apart are used to construct the new line, and the original lines 
are erased.

To join lines

1 Choose Tools > Join lines.

2 Select the first line.

3 Select the second line to join to the first line.

The endpoints of both lines are used as base points to join the two lines.

Changing lines
This function allows you to move multiple line endpoints to a new location. You are prompted 
to select lines, and then indicate the new endpoint location. This is useful for cleaning line 
intersections during the capture process. Standard object snaps can be used to specify an exact 
location. The closest line endpoints are all changed to the new location.

To change lines

1 Choose Tools > Change Lines.

2 Select the line that you want to change, and then press ENTER.

3 Specify the new endpoint for the line, and then press ENTER.

The line is changed to the endpoint that you specified.
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Splitting a single line
During the capture process, a single line can be split into smaller sections. This is done by 
selecting the line, and then entering the length of each segment. The values entered are 
automatically adjusted to equally distribute the difference in distance between the new line 
sections. The remainder value is updated on the command line after every split.

The line is broken into the new lines, and a small circle is placed on the INTEG layer at each 
end point of a segment to assist with capturing lines from the endpoints of the lines.

To split a single line

1 Choose Tools > Split Single Line.

2 Select a point close to the endpoint of the line that you want to split to make certain that splitting 
starts in the correct sequence.

3 Enter the first distance, and then press ENTER.

4 Repeat Step 3 until you get to the last distance, enter the remainder value, and then press * and then 
ENTER to exit the function.

The remaining length is calculated and displayed after each entry. The command line displays the 
result of how the error was dispersed.

Figure 7 Splitting a single line
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Splitting double lines
You can split two parallel lines into smaller sections by selecting each line, and then entering 
the length of the sections. The two lines are split into an equal number of sections, and the 
connecting lines are automatically constructed. The values entered are adjusted to distribute the 
difference in distance equally between the new line segments. The remainder value is updated 
on the command line. This function provides a fast way of distributing the error and 
constructing the cadastral using an automated process.

New lines are created and a small circle is placed at each end point of each for snap endpoints. 
The connecting lines are constructed in the current drawing.

To split double lines

1 Choose Tools > Split Double Lines.

2 Select the first line that you want to split closest to its end point to make certain that splitting starts 
in the correct sequence.

3 Enter the first distance, and then press ENTER.

4 Repeat Step 3 until you get to the last distance, enter the remainder value, and then press * and 
then ENTER to exit the function.

The result of how the error was dispersed is displayed on the command line.

5 Select the second line that you want to split closest to its end point to make certain that splitting starts 
in the correct sequence for the second line.

6 Enter the first distance, and then press ENTER.

7 Repeat Step 3 until you get to the last distance, enter the remainder value, and then press * and 
then ENTER to exit the function.

Note The two lines must have the same number of segments. The endpoints of the two parallel lines will be 
joined.

Figure 8 Splitting double lines
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Splaying corners
This function is used to splay parcel corners at road reserve intersections by selecting the parcel 
boundaries, and then entering the splay distance from the intersection point.

The existing parcel boundaries are shortened by the required distance, and a new splay line is 
constructed in the current drawing.

To splay a corner

1 Choose Tools > Splay Corner.

2 Select the first line to splay.

3 Select the second line to splay.

4 Type the distance by which you want to splay the lines, and then press ENTER.

Extending and breaking lines
This function extends a line to a boundary line, which is then broken at the intersection. The 
line to be broken must be able to intersect with the second line. This function is mostly used 
during data capture to clean the line work. The first line is broken at the intersection and the 
second line endpoint is snapped to the new intersection.

To extend and break lines

1 Choose Tools > Extend and Break.

2 Select the line to break at the intersection of two lines.

3 Select the line to extend to the intersection.

The first line is split into two lines.

Extending lines by distance
This function is used to extend a line at the endpoint closest to the selected point. You are 
prompted for the distance that the line needs to be extended. The line can also be shortened at 
the selected point by entering a negative distance. This function is mostly used during the 
capture process to extend a line a certain distance past a given point. The endpoint of the line 
is moved the specified distance.

To extend lines by distance

1 Choose Tools > Extend by Distance.

2 Select the line to extend.

3 Enter the distance to extend the line with.

The line is updated on the screen.



Munsys line tools 196 








Densifying arcs
With this function, you can convert AutoCAD arcs into line segments. It is typically used before 
building closed polygons using the Munsys polygon builder. 

The function also provides the option to determine the layer of storage for the new line entities, 
and to determine if the original arcs should be removed or retained. Feedback statistics on the 
conversion process are provided.

To densify arcs

1 Choose Tools > Densify Arcs.

The following prompt is displayed:

[Layer (Retain layer)/Erase (No)/Chord (Angle)/Select] <Select>:

To set the Layer option
This option is used to determine the layer on which the lines are stored. Lines are stored on the 
current layer, a user-defined layer or on the original layer.

To set the Layer option, do one of the following:

 Type L to set the layer options.

The following prompt is displayed:

Layer [Retain layer/Current/User defined] <Retain layer>: 

 To determine the layer for the new line segments, do one of the following:
 Type R to retain the layer

 Type C to store entities on the current layer

 Type U, press ENTER, and then enter a layer name.

To set the Erase option.
This option is used to determine if the original arcs should be removed or retained during the 
densifying arc process.

To set the Erase option, do the following:

 On the command line, type E, and then press ENTER.

The following prompt is displayed:

Erase Arcs [Yes/No] <No>:

 To erase or retain entities, do one of the following:
 Type Y to erase the original arcs.

 Type N to retain the original arcs.
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To set the Chord calculation method
This option is used to determine the number of line segments to be created during the 
densifying process. You can determine the number of segments by defining an angle or a length.

 On the command line, type C, and then press ENTER.

The following prompt is displayed:

Chord [Angle/Length] <Angle>:

 To set the chord calculation method, do one of the following:
 Type A to use the angle method for determining the number of segments.

The following prompt is displayed:

Chord angle in degrees <3>: Press ENTER, or type in new value.

 Type L to use the length method for determining the number of segments.

The following prompt is displayed:

Chord length <2>: Press Enter, or type in new value.

2 Type S to select arcs to be converted.

The following prompt is displayed:

Select arcs to convert...

3 Type ALL to select all the arcs, or manually select the arcs that you want to convert.

4 Press ENTER to continue.

5 Once the conversion is completed, the following statistics are displayed:

Number of arcs converted

Number of line segments created

Minimum line segments per arc

Maximum line segments per arc

Note If the chord length is greater than the arcs length or the angle factor is greater than the arcs angle then one 
line will be drawn from the arcs start point to the end point. To undo changes done by the function, type 
U or Undo, and then press ENTER to undo.
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The cadastral cleanup process
The line integrity check breaks line entities at intersections. You can also choose to have lines 
circled that are shorter than a specified length.

Fracturing lines
This function breaks lines at intersections and removes duplicate lines. Line endpoints that are 
outside the snap tolerance are circled. The database administrator sets the snap tolerance.

Errors are marked with a circle to zoom to and correct before redoing the fracture operation. 
Once the fracture operation returns no errors, the polygon builder can use the lines.

The duplicate lines are deleted and errors are marked with circles on the INTEG layer.

To fracture lines

1 Choose Tools > Line Integrity > Fracture Lines.

2 Select the intersecting line entities to break at intersections, and then press ENTER.

The fracture routine breaks the lines at each intersection and circles any integrity errors for cleaning.

Circling short lines
This function checks for any short lines created during the construction and fracture processes 
by specifying a minimum distance, and then selecting the lines to process. The short lines are 
marked with a circle on the INTEG layer.

To circle short lines

1 Choose Tools > Line Integrity > Circle Short Lines.

2 Enter the minimum length by typing a value or indicating two points on the screen.

3 Select the lines to be checked for short lines.

The lines that are too short are circled for correction.

Changing circle size
This function changes the size of the circles indicating the short lines. Often the size needs to 
be changed as the user zooms closer into the lines. The size can be entered on the command 
line or indicated by two points. All the circles on the INTEG layer are then changed to the new 
size. 

Note This function can also be used to change the size of integrity markers.

To change circle size

1 Choose Tools > Line Integrity > Change Circle Size.

2 Indicate two points to determine the new circle size, or type the circle size on the command line.

Existing circles are updated.
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Showing endpoints
This function is often used to check whether lines are broken at the correct positions by 
showing the line endpoints. You need to indicate the lines to process. A blip, which will be 
cleared on the next redraw operation, is shown at the endpoint of each line.

To show endpoints

1 Choose Tools > Line Integrity > Show Endpoints.

2 Select the line objects of which you want to display the endpoints, and then press ENTER.

AutoCAD blips are displayed at the endpoints of all selected line objects.

Weeding polylines
This function is used to remove redundant coordinates from selected polylines, resulting in 
more smoothed objects. This is achieved by removing coordinates that reside within a 
smoothing tolerance, except if the last coordinate falls within the tolerance.

To weed polylines

1 Choose Tools > Weed Polylines.

2 On the command line, type the smoothing tolerance, or select two points in the drawing indicating 
the distance between the points to use as the tolerance, and then press ENTER.

The command line indicates the Current tolerance, which is set to 1 by default.

3 Select the objects that you want to weed, and then press ENTER.

The command line indicates the number of original coordinates and the number of new 
coordinates.

Deleting duplicates
With this function, you can delete duplicate lines from a drawing. This function can be used, 
for example, to remove duplicate inside parcel boundaries after they have been exploded. You 
can delete both duplicates or clean up data, removing one set of the duplicate objects. A 
tolerance distance is specified to determine which objects are identified as duplicates.

To delete duplicates

1 Choose Tools > Delete Duplicates.

2 Select the objects that you want to delete, and then press ENTER.

3 To specify a cleanup option, do one of the following:

 Press ENTER to remove one of the duplicate lines.

 On the command line, type A to remove both duplicate lines.
Duplicate lines are deleted.



Munsys line tools 200 








Generating AutoCAD polygons
This group of functions is used to generate AutoCAD polygons by using one of the following 
as reference:

 by picking a point

 by selecting text objects

 by selecting point objects

 by selecting block objects

To generate a polygon by pick point
This function is used to build polygons by picking a point inside the polygon. Munsys uses the 
existing lines to construct the polygon. With this function, only one polygon can be generated 
at a time.

1 Choose Tools > Generate Polygon > by Pick Point...

2 On the command line, enter the target layer as prompted.

3 Select the objects to generate the polygon from, and then press ENTER.

4 Select the detection point inside the polygon, and then press ENTER.

The polygon is generated and stored on its appropriate layer.

To generate a polygon from text
This function is used to build polygons by using an AutoCAD text entity as a reference point.

1 Do one of the following:

1 Choose Tools > Generate Polygon > From Text...

2 On the command line, enter the target layer as prompted.

3 Specify whether you want to erase the reference object if the polygon is built successfully.

4 Select the line objects to generate the polygon from, and then press ENTER.

5 Select the text inside the polygon, and then press ENTER.

The polygon is generated and stored the layer that you specified.

To generate a polygon from a point object
This function is used to build polygons by using a selected AutoCAD point object as a 
reference.

1 Choose Tools > Generate Polygon > From Point...

2 On the command line, enter the target layer as prompted.

3 Specify whether you want to erase the reference object if the polygon is built successfully.

4 Select the lines to generate the polygon from, and then press ENTER.

5 Select the appropriate point object(s), and then press ENTER.

The polygon is generated and stored on the appropriate layer.
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To generate a polygon from a block object
This function is used to build polygons by using a selected AutoCAD block object as a 
reference.

1 Choose Tools > Generate Polygon > From Block...

2 Specify whether you want to erase the reference object if the polygon is built successfully.

3 On the command line, enter the target layer as prompted.

4 Select the lines to generate the polygon from, and then press ENTER.

5 Select the appropriate block object(s), and then press ENTER.

The polygon is generated and stored on the appropriate layer.
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Data transformation
This function is used to transform selected data from one coordinate system to another. You 
have to specify the category and coordinate system to transform from and to transform to. The 
purpose of this function is to transform CAD entities from one coordinate system to another 
before converting them to Munsys objects, or using them to build polygons. It can be used to 
convert data from a lat long coordinate system, which makes it easier to capture and clean the 
data.

To transform data

6 Choose Tools > Data Transformation...

The Coordinate Transformation dialog box is displayed.

Figure 9 The Coordinate Transformation dialog box

7 From the FROM Coordinate System Selection group, select the coordinate category to transform 
from.

8 Select the current coordinate system from the list.

9 From the TO Coordinate System Selection group, select the coordinate category to transform to.

10 Select the new coordinate system from the list.

11 Click OK.

12 Select the data to transform, and then press ENTER.

Data is transformed to the location of the new coordinate system. Use the AutoCAD zoom 
extent function to view transformed data.
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Helmert transformation
Helmert transformation is a methodology that transforms spatial data and attempts to eliminate 
the distortion of the data. Munsys does not distort the object, but only scales, rotates and moves 
it according to the indicated transformation control points (source and destination points). The 
Helmert Transformation function is usually applied to a complete drawing and all the objects 
in the drawing should be selected before executing the function.

Helmert transformation usually requires a minimum of 2 parameters to perform a 
transformation.However, it will be to the user's benefit to identify more transformation control 
points; at least six. If the user is not satisfied with the delta value (displacement), the control 
points with the largest delta values can be cancelled from the transformation rules.

The source and destination points of the first control points pair have to be indicated. Once all 
the transformation control points have been indicated, the Transformation Control Points 
dialog box, which contains all the control point pairs with the associated delta distance for each 
pair, is displayed. The average delta distance is recalculated when control points are applied or 
deactivated.

To transform Munsys objects using Helmert transformation

1 On the command line, type MUNHELMERT, and then press ENTER.

The Transformation Control Points dialog box is displayed.

2 Click the Add button to indicate the control points.

3 Specify the source control point.

4 Specify the destination control point.

The difference between the source and destination points are displayed in the drawing. For the best 
transformation results, spread the points evenly across the drawing.

5 Repeat Steps 4 and 5 until all the required control points have been indicated, and then press ENTER.

The Transformation Control Points dialog box is displayed.

6 From the Apply column, select or deselect the control point pairs to optimize the Average delta 
distance that is displayed.

7 Click OK to perform the transformation.

8 Select the drawing to be transformed.

The selected drawing is transformed using the active control point pairs.
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Redefining control points

1 On the Transformation Control Points dialog box, click the Redefine button to indicate the control 
points.

The difference between the initial source and destination points is indicated in the drawing. 

2 Specify the source control point.

3 Specify the destination control point.

4 From the Apply column, select or deselect the control point pairs to optimize the Average delta 
distance that is displayed.

5 Click OK to perform the transformation.

6 Select the drawing to be transformed.

The selected drawing is transformed using the active control point pairs.

Removing control points

1 On the Transformation Control Points dialog box, select the appropriate control point pair to 
remove, and then click the Remove button.

The selected control point pair is removed from the list.
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 Chapter 6


 Munsys text tools

Introduction
This chapter describes the various text tools that are available in the Munsys applications. The 
following functions are described:

 finding and replacing text

 placing incremental text

 changing text values and properties
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Finding and replacing text
This function is used to search for occurrences of a specific AutoCAD text string, block 
attribute value, hyperlink description or Munsys tag in the current drawing. Using the Find and 
Replace dialog box, you can refine the search process for a required text string or object. Results 
may be replaced one at a time, or all at once.

To find and replace text

1 Choose Tools > Find

The Find and Replace dialog box is displayed.

Figure 1 The Find and Replace dialog box

2 In the Find what text box, enter the complete or partial text string that you want to find.

3 If you are going to replace the text, enter a text string in the Replace with text box that will replace 
the text string found.

4 To define the search area, do one of the following:

 From the Search In list, select Entire Drawing

 Click the Find where button to specify the search area on the drawing.

5 Click the More Options button to refine the search process.
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The Find and Replace Options dialog box is displayed.

Figure 2 The Find and Replace Options dialog box 

6 On this dialog box, do the following:

 From the Search Options group, set the check box for the option required to filter the search 
process.

 Set the Match Case check box to search for a text string that matches the case of the required 
text.

 Set the Find whole words only check box to search for an exact match for the required text.

 Click OK to apply the options and return to the Find and Replace dialog box.

7 Next, click the Find button to search for the required text or object.

8 The first result is displayed in the context list of the Search results group.

9 To replace results, do one of the following:

 click the Replace button to replace one value at a time

 click the Replace All button to replace all occurrences

10 Click the Zoom to button to view each occurrence. 

11 Click the Close button to close the Find and Replace dialog box.
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Placing incremental text
This function is used to simplify the placement of text, for example street numbers or parcel 
numbers. Munsys automatically increments the text by a user-defined value. You are prompted 
for the line to align the text to, insertion point, text height and angle, and prompted 
continuously to indicate the placing of the text string.

To place incremental text

1 Choose Tools > Place Incremental Text.

2 On the command line, type the incremental text value, and then press ENTER.

3 On the command line, type the text value, and then press ENTER, or press ENTER to accept the 
default text value.

4 Specify the insertion point for the text.

5 Specify the text height.

6 Specify the text angle.

The text is placed on the current layer, and the next text value increments by the predefined 
incremental value.

7 Repeat from Step 3, or press ESC to exit the command.
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Changing text values
You can change text value by adding a prefix, suffix, joining text or editing a text value. These 
functions only work on AutoCAD text entities in the drawing.

Note To display the Munsys Text Tools toolbar, right-click in the grey area on the right-hand side of the Munsys 
Standard toolbar, and then select the toolbar from the AutoCAD menu.

Editing text
This function is used to edit one text string at a time by displaying each text value from a 
number of selected text entities.

To edit text

1 Do one of the following:

 Choose Tools > Change Text Value > Edit Text...

 Click the Edit Text button on the Munsys Text Tools toolbar.

2 Select the text entity(ies) that you want to edit.

3 Change the text in the text box that is displayed, and click OK.

The text string is updated in the drawing.

4 If multiple text entities were selected, the function will continue by displaying the next text value.

 Click Cancel to exit the function, or continue changing the text displayed in the text box until 
the last value has been changed.

 Click OK when you have made all the changes.
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Joining text
This function is used to join multiple text entities. The joined text values are concatenated into 
a continuous value, delimited with a space and aligned with the first selected text value.

To join text

1 Do one of the following:

 Choose Tools > Change Text Value > Join Text.

 Click the Join Text button on the Munsys Text Tools toolbar.

2 Select the first text entity that you want to join to, and then press ENTER.

3 Continue selecting text entities one at a time, and then press ENTER.

The selected text entities are joined into a single text entity.

Adding a prefix to text
With this function, you can select one or more text entities and enter a prefix to be added to 
the text value, for example during data conversion when you want to add a prefix to incomplete 
text values.

To add a prefix to text

1 Do one of the following:

 Choose Tools > Change Text Value > Add Prefix.

 Click the Add Text Prefix button on the Munsys Text Tools toolbar.

2 Select one or more text entities that you want to edit, and then press ENTER.

3 On the command line, enter the prefix value, and then press ENTER.

The text is updated in the drawing.
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Adding a suffix to text
With this function, you can select one or more text entities and enter a suffix to be added to the 
text value, for example during data conversion when you want to add a suffix to incomplete text 
value.

To add a suffix to text

1 Do one of the following:

 Choose Tools > Change Text Value > Add Suffix.

 Click the Add Text Suffix button on the Munsys Text Tools toolbar.

2 Select one or more text entities that you want to edit, and then press ENTER.

3 On the command line, enter the suffix value, and then press ENTER.

The text is updated in the drawing.
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Changing text properties
Using the Munsys Tools menu or Text Tools toolbar, you can change the properties of one or 
more selected text entities.

Changing text angle
With this function, you can change the angle of one or more selected text entities.

To change text angle

1 Do one of the following:

 Choose Tools > Change Text Properties > Angle.

 Click the Change Text Angle button on the Munsys Text Tools toolbar.

2 Select the text entities that you want to change, and then press ENTER.

3 To change text angle, do one of the following:

 On the command line, enter the new angle, and then press ENTER.

 Specify two points to align the text to.
The angle is changed as specified.

Changing text size
With this function, you can change the size of one or more selected text items, for example 
when data is converted and the text size needs to be standardized.

To change text size

1 Do one of the following:

 Choose Tools > Change Text Properties > Size.

 Click the Change Text Size button on the Munsys Text Tools toolbar.

2 Select the text entities that you want to edit, and then press ENTER.

3 To change the text size, do one of the following:

 On the command line, enter the new text size, and then press ENTER.

 Specify two points that indicate the new text height.
The text size is updated in the drawing.
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Changing text style
With this function, you can assign a new text style to one or more selected text entities, for 
example when data is converted and the text style needs to be standardized.

To change text style

1 Do one of the following:

 Choose Tools > Change Text Properties > Style.

 Click the Change Text Style button on the Munsys Text Tools toolbar.

2 Select the text entities that you want to edit, and then press ENTER.

The Text Styles list is displayed.

Figure 3 The Text Styles list box

3 Select the appropriate style, and then click OK.

The text style is updated in the drawing.
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Changing text width
With this function, you can assign a new width to one or more selected text entities, for example 
during data conversion where text width needs to be standardized.

To change text width

1 Do one of the following:

 Choose Tools > Change Text Properties > Width.

 Click the Change Text Width button on the Munsys Text Tools toolbar.

2 Select the text entities that you want to edit, and then press ENTER.

3 On the command line, type a new width factor, and then press ENTER.

The text width is updated in the drawing.

Angling text to a line
With this function, you can select one or more text entities and specify a line to adjust the text 
angle to. It is normally used during the cadastral capture procedure to align parcel numbers with 
cadastral boundaries. 

To angle text to a line

1 Do one of the following:

 Choose Tools > Change Text Properties > Align Angle.

 Click the Align Text Angle button on the Munsys Text Tools toolbar.

2 Select the appropriate text entities, and then press ENTER.

3 The command line prompts you to select the line for alignment.

The text is updated in the drawing.
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Aligning text
With this function, you can align one or more text objects to another text object. 

To align text

1 Do one of the following:

 Choose Tools > Change Text Properties > Text Align.

 On the command line, type TEXTALIGN, and then press ENTER.

 Click the Text Align button on the Munsys Text Tools toolbar.

2 Select text objects to align, and then press ENTER.

3 Select text object to align to (select 'Point'), pick the first point and specify the second alignment 
point. 

The text object(s) is aligned according to the alignment that you have specified.
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 Munsys layer formatting

Introduction
This chapter discusses the following Munsys layer formatting options:

 finding a last object

 setting a current layer

 changing a layer color

 setting the color range for a layer

 freezing layers

 locking and unlocking layers

 erasing objects on a specific layer

 moving objects to another layer

 saving and loading a layer setup

 changing the display order of layers
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Finding the last object
With this function, you can zoom to the last modified or queried object.

To find the last object
 Choose View > Find Last Object.
Munsys zooms to the last modified or queried object.

Setting a layer as current
This function is used as a quick method to set the layer of a selected object as the current layer.

To set a layer as current

1 Choose Format > Set Current Layer.

2 Select the object that determines the current layer, and then press ENTER.

The new current layer is displayed on the Standard Toolbar.

Setting a layer color
This function is used as a quick method to set or change the current color of a layer by selecting 
an object on the layer.

To set layer color

1 Choose Format > Set Layer Color.

2 Select the appropriate object, and then press ENTER.

The Select Color dialog box is displayed.

Figure 1 The Select Color dialog box 

3 Select the required color, and then click OK.

The color of the indicated layer changes to the specified color.
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Setting a layer color range
This function is used to set up a color range for selected layers. It can be used to set up colors 
in order to create thematic maps.

To set a layer color range

1 Choose Format > Set Layer Color Range...

The Layer Color Range dialog box is displayed.

Figure 2 The Layer Color Range dialog box

2 Set the display order of the layers–ascending or descending–using the appropriate radio buttons.

3 From the Layer Names list, select the layers to display in the same color range.

4 From the Range group, use the Pick Color buttons to select a Start Color and an End Color.

5 Click OK.

The color for the selected layers are updated.
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Freezing layers
This function provides a quick way to freeze a layer by selecting an object on that layer.

To freeze a layer

1 Choose Format > Pick Layers to Freeze.

2 Select the object of which the layer needs to be frozen, and then press ENTER.

The selected layer is frozen (hidden). These objects are not taken into account during an 
AutoCAD redraw or regen function.

Locking and unlocking layers
Locking layers is useful when you want to edit objects stored on a particular layer, but also want 
to view objects on other layers. Spatial objects on a locked layer cannot be selected or edited, 
but are still visible. You can make a locked layer current, and you can draw new objects on the 
locked layer. 

Note The Layer Locking/Unlocking functions on the Format menu only work for AutoCAD layers.

To lock or unlock a layer

1 Do one of the following:

 Choose Format > Pick Layer to Lock.

 Choose Format > Pick Layer to Unlock.

2 Select the object of which the layer needs to be locked or unlocked.

The command line indicates the layer name that was locked or unlocked.

Erasing objects on specific layers
This function provides a quick way of erasing all the objects on an indicated layer.

To erase objects on a layer

1 Choose Format > Erase Objects on a Layer.

2 Select an object on the layer to determine the rest of the objects to be erased.

All the objects on the selected layer are erased.

Moving objects to another layer
This function provides a quick way to move selected objects to another layer.

To move objects to another layer

1 Choose Format > Change Layer of Objects...

2 Select all the objects that you want to move, and then press ENTER.
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The Layers list is displayed.

Figure 3 The Layers list box

3 Select the destination layer for the selected objects, and then click OK.

All the selected objects are moved to the new layer, and display with the new layer’s properties.

Saving and loading a layer setup
This function is used to save the current layer settings in a drawing and load them later. An 
organization or department can decide on specific layer properties to be used throughout the 
organization. These settings can be specified and saved to a file, which can be loaded when 
opening new drawings to ensure consistency.

To save and load a layer setup

1 Do one of the following:

 Choose Format > Save Layer Setup.

The Enter Layer Filename: dialog box is displayed.

 Choose Format > Load Layer Setup.

The Select Layer File: dialog box is displayed.

2 Do one of the following:

 To save a layer setup, enter the layer setup name in the File Name text box, and then click 
the Save button.

 To load a layer setup, select the setup name in the list of available files, and then click OK.
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Display order
Using the Format menu, you can change the display order by moving a layer to the front or the 
back. You will be prompted to select the layer to move to the back or front.

To move a layer to the front

1 Choose Format > Display Order > Move Layer to Front.

2 Select an object on the layer that you want to move to the front.

The objects on the selected layers are moved to the front.

To move a layer to the back

1 Choose Format > Display Order > Move Layer to Back.

2 Select an object on the layer that you want to move to the back.

The objects on the selected layers are moved to the back.

To move hatch patterns to the back
 Choose Format > Display Order > Move Hatch Pattern to Back.

The hatch patterns in the drawing are moved to the back.



222 








 Chapter 8


 Creating maps

Introduction
This chapter introduces you to advanced Munsys utilities that simplify map production, and 
describes how to:

 create and manipulate viewports

 generate a north point, scale bar and grid crosses

 create Munsys legends
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Working with viewports
With Munsys, you can create a viewport in the layout space, and set the scale and rotation angle. 
These functions are only available when working on a layout.

Creating a viewport
A viewport can be created in the layout space. The viewport options are displayed on the 
command line, which is the standard AutoCAD option for creating manual viewports.

To set up a layout

1 Select the Layout1 tab at the bottom of the AutoCAD Map drawing area.

2 Choose File > Page Setup Manager.

The Page Setup Manager dialog box is displayed, showing the defined layouts.

3 Select Layout1, and then click the Modify button.

4 Set the printer and paper size, and then click OK.

5 Click the Close button to return to the layout.

To create a viewport

1 Choose Extras > Viewports > Create Viewport.

2 Specify the first corner of the viewport.

3 Specify the opposite corner of the viewport.

The viewport is displayed on the Layout1 tab, containing the drawing.

Setting the viewport scale
With this function, you can change the scale of the spatial objects displayed in the viewport. 
The scale factor is the ratio between the actual size of the object and the representation on paper.

To set a viewport scale

1 Choose Extras > Set Viewport Scale.

2 On the command line, type in the required scale, and then press ENTER.

The drawing is rescaled in the viewport.

Tip Use the Set Viewport Angle function to rotate the drawing if required before you set the scale. Settings 
the angle will also change the scale by zooming to the extents of the drawing.
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Changing the viewport angle
With this function, you can change the viewport angle. This is usually done when it is required 
to rotate the drawing on the paper to get a best fit.

To change a viewport angle

1 Choose Extras > Set Viewport Angle.

2 On the command line, type in the required angle, and then press ENTER.

The drawing is rotated in the viewport.

Tip If you would like to insert a north point, scale bar or grid crosses while on the layout (displaying the 
viewport in model space), change the angle of the drawing.

Munsys mapping tools
The following tools are used to enhance maps:

 North point – a symbol that is placed facing North to indicate how the map is orientated.

 Scale bar – a ruler that indicates the distance proportional to the geographical area.

 Grid crosses – a network of horizontal and vertical lines placed at user- specified intervals. 
A grid cross contains coordinates at the intervals to simplify the location of intersection of 
the grid cross.

Note If you are working in a rotated viewport, you will need to create these objects on the Model tab, because 
the coordinate system in a rotated viewport is not the same as the coordinate system on the Model tab.

Inserting a north point
This function is used to insert a north point into the current drawing. The north point is 
inserted as an AutoCAD block on the NORTH_POINT layer.

To insert a north point

1 Choose Extras > Insert North Point. 

2 Specify an insertion point for the north point.

3 Specify the scale of the north point by entering a value on the command line, or by indicating two 
points in the drawing with your mouse pointer.

The north point is inserted at the insertion point and scale that you specified.

Figure 1 A North Point
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Generating a scale bar
This function is used to generate a scale bar for the current drawing. The scale bar is generated 
on the SCALE_BAR layer. The following figure shows how a scale bar is generated and how the 
default values of each component are calculated:

Figure 2 Generating a scale bar

To generate a scale bar

1 Choose Extras > Generate Scale Bar.

2 Specify the bottom left hand corner of the scale bar, and then specify the top right hand corner of the 
scale bar to create a window from which the width can be determined. 

The default increment value is displayed on the command line. This is calculated by dividing the 
width of the window that you created by five.

3 Press ENTER to accept the default scale bar increment, or specify an increment value on the 
command line.

4 Enter a description for the scale bar.

The scale bar is placed in the drawing area as specified.

window (two corners speci-
fied)

width (the window width)

increment (width divided by 5)

numeric text height (3% of width) 

description text height (10% of width)

division line length (10 % of width)
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Generating grid crosses
This function is used to generate grid crosses for the current drawing. Grid crosses are generated 
as AutoCAD entities on the GRID_CROSS layer. The default spacing is calculated as 20% of 
the length of the window, and the cross length is calculated as 10% of the spacing.

To generate grid crosses

1 Choose Extras > Generate Grid Crosses. 

2 Specify the bottom left hand corner, and then specify the top right hand corner to create a window 
from which the length can be determined. 

3 Enter the grid spacing, or press ENTER to accept the calculated value.

4 Specify the cross length, or press ENTER to accept the calculated value.

5 Press ENTER to annotate the grid crosses, or type N on the command line if you do not want to 
annotate the grid crosses:

6 Enter the text height, or press ENTER to accept the calculated value.

7 On the command line, type a prefix for the X coordinate, or press ENTER.

8 On the command line, type a prefix for the Y coordinate, or press ENTER.

The grid crosses are generated and displayed on the GRID_CROSS layer.

Figure 3 An annotated grid cross
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Annotations
The annotation tool is used to label spatial data. User-defined values are retrieved from spatial 
tables, and represented as text on associated spatial objects. The user selects the spatial objects 
to be annotated before the execution of the function, as well as the values to be displayed. User 
defined annotation settings can be saved per spatial object type, and loaded at a later stage when 
required.

The values for the annotation are retrieved from spatial tables or linked tables (attribute tables 
that are linked with spatial tables). More than one value can be displayed at a time.

The Options tab on the Annotations dialog box determines the display of the text entities. 
Using this tab, you can specify on which layer to store the annotations and the text properties, 
for example height, justification and style.

To annotate spatial objects

1 Choose Extras > Annotate.

2 Select the spatial objects that you want to annotate, and then press ENTER.

The Annotations dialog box is displayed.

Figure 4 The Annotations dialog box

3 Use the Spatial Object tab to specify which spatial table object type to annotate by selecting a 
spatial object type from the list, as seen in the above figure. 

4 Use the Values tab to determine the values to use for the annotation.
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Figure 5 The Annotations dialog box: Values tab

5 To define the annotation values, do the following:

 From the Linked Table Info group, click the Set button.

The Linked Table Information dialog box is displayed.

Figure 6 The Linked Table Information dialog box



Creating maps 229 








 You can select an existing linked template from the Retrieve Information from existing link 
template list.

Figure 7 Selecting a link template

The Primary Table Information and Linked Table Information groups are populated with 
values from the selected link template.

 From the Linked Table Information group, select the table to join from the Table Selector 
dialog box, and then do one of the following:
 Click the Join By Column radio button, and then select a common field from a 

secondary or linked table, which links two tables.

 Click the Join By Expression radio button, and then enter an expression that determines 
the common value to link two tables. Any expression should start with $ to indicate that 
a standard SQL statement will be used. All column names should be prefixed with the 
table name, for example: $SUBSTR(SP_PARCEL.PRCL_KEY,5,4).

 From the Primary Table Information group, do one of the following: 
 Click the Join By Column button, and then select the common field that links to the 

secondary table. 

 Click the Join By Expression radio button, and then enter an expression that determines 
the common value to link two tables. Any expression should start with $ to indicate that 
a standard SQL statement will be used. All column names should be prefixed with the 
table name.

 Click the Test Join button to verify the number of matches found.
 Click OK to close the Link Table Information dialog box.

 Click OK to return to the Values tab.

6 In the Annotation Detail group, do the following:

 In the Prefixed String field, enter a value that prefixes each value from the database.

 In the Suffixed String field, enter a value that suffixes each value from the database.
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 Select the Get From Column radio button to get the annotation value from a column in 
the spatial table, and then select the column from the list, or type the annotation value in 
the Type Value field. 

 Click the Append button to add the annotation detail to the Annotation Values list.

Note To annotate more than one value, append another value.

7 Use the Options tab to determine the properties of the text entities.

Figure 8 Annotations dialog box: Options tab

8 To specify the annotation options, do the following:

 From the Layer option, click the Set button.

 To set the annotation layers, use one of the following:

 Default – the spatial table name with a suffix value of “_ANNOTATION”

 By Column – select a column from the list

 By Value – type in a layer name to be created for queried spatial objects

 To set the text style, do the following:

 From the Text Attributes group, click the Set button from the Style option, and then 
choose one of the following:

 Default Style – the AutoCAD standard style will be used

 By Column – if an attribute column contains a valid text style name that exists in the 
current drawing, this column can be selected

 By Value – specify the annotation text style that exists in the current drawing. If the text 
style does not exist in the drawing, the standard AutoCAD text style will be used.
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 To set the text height, do the following:

 From the Text Attributes group, click the Set button from the Height option, and then 
choose one of the following:

 Object Value – the text height is retrieved from the TAG_SIZE column in the spatial 
table.

 By Column – select a column from the list.

 By Value – type in a constant value or an expression to calculate the value.

 To set the text justification, do the following:

 From the Text Attributes group, click the Set button from the Justification option, and 
then choose one of the following:

 Object Value – the justification value is retrieved from the TAG_JUST column in the 
spatial table.

 By Column – select a column from the list.

 By Value – enter a valid justification value.

 To set the text angle, do the following:

 From the Text Attributes group, click the Set button from the Angle option, and then 
choose one of the following:

 Object Value – the angle value is retrieved from the TAG_ANGLE column in the 
spatial table.

 By Column – this column contains the text size.

 By Value – enter a constant value in radians.

 In the Text Creation Mode group, do the following:

 Select the Create Multiple Lines radio button to create an MTEXT entity where each 
value represents a new line.

 Select the Concatenated radio button to create a single TEXT entity, concatenating all 
values to form one string. If a separator string is specified, this will be used to delimit 
one value from the next.

Note The Text Creation Mode group will only be available when two values were added to the Annotation 
Values list on the Values tab.

9 Click the Run button to annotate the spatial objects.

The annotation values display for the selected spatial objects on the defined layer.

10 Click Close to exit the Annotations dialog box.

11 To save the annotation settings, enter the profile name in the File Name text box, and then click the 
Save... button. The default profile file is stored as Munsys14\Munsys.ini.

12 To load a profile, select the profile name in the list of available files, and then click the Load... 
button.
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Munsys legends
This function is used to generate a legend for selected spatial objects. Munsys determines which 
layers are used for the selected spatial objects, and creates the legend accordingly. The 
component of the legend will be created on different layers.

The user specifies the following:

 Legend layout

 Display properties of the legend title

 Display properties for the legend key labels

 Layers included for the legend.

Note The entities created by the legend are accessible to AutoCAD as normal entities, and can be manipulated 
by AutoCAD in the normal way.

To create a legend

1 Choose Extras > Legend.

2 Select the objects that you want to include in the legend.

Figure 9 Selecting the objects in the drawing to include in the legend
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The Legend Options dialog box is displayed.

Figure 10 The Legend Options dialog box

3 To determine the legend layout, do the following:

 Select the Include Legend Heading check box to display a heading for the legend.

 Set the Include Legend Border check box to display a border for the legend.

 Increase the Number of Legend Columns as required.

 In the Layer Prefix text box, type $in the prefix for the new legend layer name.

4 The Labels tab on the Legend Options dialog box is used to determine the legend labels and their 
order:

Figure 11 The Legend Options dialog box: Labels tab

 Layers that you do not want displayed in the legend are removed by selecting the layer in 
the Legend Labels area, and then clicking the Remove button.

 To modify layer names, select the name from the Legend Labels group, and then click the 
Modify button.

The Legend Label dialog box is displayed.
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Figure 12 The Legend Label dialog box

 In the Label Name field, enter the new label name, and then click OK to return to the 
Labels tab.

 From the Legend Labels group, change the order of the layers, by pressing the Shift up- or 
Shift down button.

The order of the layers in the Legend Labels group determines the order of the labels in the 
legend.

Tip You can order the legend labels alphabetically by clicking the appropriate column heading.

5 Legend properties are changed on the Properties tab:

Figure 13 The Legend Options dialog box Properties tab

 In the Heading Value text box, enter the heading for the legend.

 From the Style drop-down list, select the style for the heading.

 In the Height text box, replace the default height as needed.

 From the Labels group, select the appropriate style from the Style drop-down list.

 From the Labels group, replace the default height as needed.

6 Click the Create button.

7 Indicate an insertion point for the legend.
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The legend is created on the specified layers.

Figure 14 Generating a legend
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 Munsys Google Tools

Introduction
Munsys Google Tools is a set of tools that is used to present spatial objects from a Munsys 
schema in the Google Earth™ mapping services. The Munsys spatial object data and 
associated attribute data are enhanced when viewed in Google Earth, allowing the maps, 
satellite imagery, street views, links, photographs, and 3D terrains to be used as background 
information.

Munsys Google Tools consists of two commands, which are executed from the command line 
in any of the Munsys Applications.

The command that IS used to execute the Google Tools are:

 MUNGOOGLEEARTH – this command enables the user to select previously queried 
objects in the drawing area to be displayed in Google Earth. The command creates a KML 
file, which then displays the selected spatial data in Google Earth.

The way that the selected data is displayed in Google Earth is defined in the defaults file called 
MunsysGoogleTools.def. This file is located in 
C:\Program Files\Open Spatial\MunApps14 (if you used the default installation path when 
installing Munsys Applications). The defaults file is also used to specify which attributes to 
display, to set the opacity for solid filled objects, to set line widths and which symbol to use to 
represent node type objects, etc. 

This chapter explains how to use Munsys Google Tools. This includes changing and/or setting 
up the defaults file that is used to specify the way that data is displayed in Google Earth with 
the Google Tools. The execution of the MUNGOOGLEEARTH command IS also explained in 
this chapter.

To display data in Google Earth, you will need to do the following:

 Query the data that you want to display from the database into the drawing area

 Adjust the defaults file to specify or change parameters for the objects that you want to 
display

 Execute the MUNGOOGLEEARTH command

 View the data in Google Earth according to the command that you executed
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About the defaults file
The defaults (.def ) file is installed as part of the Munsys Applications in the folder C:\Program 
Files\Open Spatial\MunApps14(if you used the default installation path when installing 
Munsys Applications). This file stores all the parameters and settings that are required to 
interpret data so that the data is “converted” to the correct format required for Google Earth. 
The defaults file is populated with “example” parameters, as seen in the figure below.

Figure 1 Munsys Google Tools defaults file: MunsysGoogleTools.def

The defaults (.def ) file is divided into three sections:

 General – contains parameters/settings that apply to both Google Earth and Google Maps.

 Google Earth – contains parameters/settings that apply to Google Earth only

The following section describes the various parameters that are available in the defaults file.
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Google Tools defaults file: General
The General section of the defaults file has the following editable settings/parameters:

 MAIN_TITLE="Munsys Objects" – the main title is the title that will appear in the legend 
in Google Earth. When the MUNGOOGLEEARTH command is executed, you will be 
prompted by the command line to type in this description before you select the objects in 
the AutoCAD drawing. This value is set to Munsys Objects by default.

 MAX_OBJECTS=5000 – this setting specifies the maximum number of objects that can 
be selected. This can be increased, but will have an impact on the time taken to display the 
data. The default number of 5000 is the optimum number and should preferably not be 
exceeded. If you select more than the maximum number of objects as set in this value, an 
error message will be displayed on the command line (“Maximum object limit of 5000 was 
exceeded”), and the function will be terminated.

 PRECISION=6 – this sets the number of decimal places for the coordinates. In 
LAT/LONG (the default coordinate system required for Google Maps) the decimal places 
are extremely important as this sets the exact location of the objects to be displayed.

 ATTRIBUTES=3,USEDISPLAYTEMPLATE,FORMATTED – the user can determine 
which attributes (columns in the spatial table) to display when the objects are selected in 
Google Earth The first value, 3, refers to the MUN_ID of the spatial table which in this 
case is SP_PARCEL (parcels). If the USEDISPLAYTEMPLATE, FORMATTED option is 
selected, Google Earth will use the default template to display attribute values, and all 
columns for that spatial object are displayed.

 ATTRIBUTES – this group of settings specify the attributes of the objects that will be 
displayed. Settings are specified by default and may be modified, as seen in the following 
examples:

 ATTRIBUTES=3,GID, TAG_VALUE – these parameters determine which attri-
butes (columns in the spatial table) will be displayed. In this example, the first value 
(3* in the default example) refers to the MUN_ID of the spatial table which in this 
case is SP_PARCEL (Land parcels). Only the GID (the unique geographic identi-
fier) and the TAG_VALUE column (in this case, the parcel number) will be dis-
played in Google Earth or Maps.

Note *A list of the MunIDs is provided at the end of the chapter for easy reference.

 ATTRIBUTES=23,GID, NODE_TYPE – in this example, Sewer Nodes 
(MUN_ID=23) will display the GID and the NODE_TYPE (node type) columns. 
The other columns in the spatial table SP_SEWNODE will not be displayed.

 ATTRIBUTES=25,GID,PIPE_DIA, PIPE_MATRL, PIPE_TYPE – in this exam-
ple, Sewer Gravity Pipes (Mun_ID =25) will display the GID, PIPE_DIA (pipe 
diameter), PIPE_MATRL (pipe material) and PIPE_TYPE (pipe type) columns 
from the spatial table SP_SEWGPIPE, as these have been specified. The other col-
umns in the spatial table will not be displayed.

 ATTRIBUTES=43,GID, NODE_TYPE,WAT_CATEGORY – in this example, 
Water Nodes (MUN_ID=43) will display the GID, NODE_TYPE (node type) and 
WAT_CATEGORY (water category) columns in the spatial table SP_WATNODE, 
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as these have been specified. The other columns in the spatial table will not be dis-
played.

 ATTRIBUTES=45,GID, PIPE_DIA, PIPE_MATRL, PIPE_TYPE, WAT_CATE-
GORY – in this example, Water Pipes (MUN_ID =45) will display the GID, 
PIPE_DIA (pipe diameter), PIPE_MATRL (pipe material), PIPE_TYPE (pipe 
type) and WAT_CATEGORY (water category) columns from the spatial table 
SP_WATPIPE, as these have been specified. The other columns in the spatial table 
will not be displayed.

 GOOGLE_ACTIVATION="AUTO" – this setting determines if Google Earth is 
automatically opened, and the KML or HTML file displayed. There are 3 options for this 
setting:

 AUTO – this is the default value, which opens Google Earth and displays automat-
ically.

 PROMPT – you will be prompted on the command line whether to open Google 
Earth

 NEVER – will not open Google Earth, but save the KML or HTML file to the spec-
ified folder.

 DEFAULT_SYMBOL="http://maps.google.com/mapfiles/kml/shapes/open-
diamond.png",0.8,50,50 – this setting refers to the default symbol to use for all point 
objects (nodes and labels) that are displayed in Google Earth unless specified in the Google 
Earth sections of the .def default file. The values that appear at the end of the symbol name 
refers to the scale (0.8) that the symbol will be displayed at, as well as the symbol anchor 
point (50,50).

 DEFAULT_LINEWIDTH=1 – objects that are either polygons or lines will be displayed 
in Google Earth with the default line width using this setting. The default for this setting 
is 1. This setting is applied to all line and polygon objects, regardless of layer groups, etc., 
unless specified in the GROUP_LINEWIDTH setting per MUN_ID in the Google Earth 
sections of the defaults file.

 DEFAULT_OPACITY=100 – all solid filled objects, polygons or lines will be displayed in 
Google Earth with the default opacity, using this setting. The default for this setting is 
100% (where 100% is solid and 0% is clear). This setting will be applied to all line and 
polygon objects, regardless of layer groups etc., unless specified in the 
GROUP_LINEWIDTH setting per MUN_ID in the Google Earth sections of the defaults 
file.

 DEFAULT_LABELSCALE=0.6 – this refers to the constant scale that is applied to the label 
next to the symbol. No matter how far you zoom in, the scale of the label will always remain 
the same. The default value applied is DEFAULT_LABELSCALE=0.6 unless specified in 
the GROUP_LABELSCALE setting per MUN_ID in the Google Earth sections of the 
defaults file.
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Google Tools defaults file: Google Earth
The Google Earth section of the defaults file has the following editable settings/parameters:

 GEARTH_KML_PATH="C:\Temp" – This variable sets the default path to save the KML 
file to. The default file name at this stage is: GEARTH_KML_PATH="C:\Temp". This 
path can be pointed to a local drive on a PC, or to a mapped drive on the server to share 
with other users.

 TITLE_LAYOUT="DATALAYER (GID)"
; For Title_layout can use the following keywords: DATALAYER, TAG or GID and 
any string formatting
; For example: "DATALAYER - TAG (GID)" – this is the column name used to display 
the objects in the text box of the Google Earth application. The default value at the 
moment is set to show the GID of each spatial object, for example: For 
TITLE_LAYOUT, you can set the following keywords: DATALAYER, TAG or GID 
and any string formatting for example: "DATALAYER (GID)"  = "SP_PARCEL 
(44923)"

 STYLE_HEADING="Arial",5,"000000",Bold – this applies to the text in the top of the 
attribute text box that is displayed. The first value determines the font name, (Arial is the 
default), the second value determines the font size, (the default is 5), and the third value 
determines the font color (the default is 000000; Black). The fourth value determines the 
font style (the default is Bold)

 STYLE_GROUP_HEADING="Arial",4,"0000FF",Bold – this applies to the text (Group 
Heading) in the attribute text box. The default values assigned are Arial (font name), 5 (font 
size), 0000FF (font color; blue), Bold (font style)

 STYLE_DATA_LEFT="Arial",3,"000000",Bold – this applies to the text for the left hand 
column of the attributes text box. The default values assigned are Arial (font name), 3 (font 
size), 000000 (font color; black), Bold (font style)

 STYLE_DATA_RIGHT="Arial",3,"000000" – this applies to the text for the right hand 
column of the attributes text box. The default values assigned are Arial (font name), 3 (font 
size), 000000 (font color; black)

 GROUP_SYMBOL=23,"http://maps.google.com/mapfiles/kml/shapes/placemark_circle.pn
g",0.8,50,50 – this determines which Google Earth symbol is used to represent the point 
data for that specific group. The number 23 refers to the MUN_ID as defined in 
MUNSYS_SP_TABLES, which is the ID used for Sewer Nodes. Therefore, all sewer nodes 
where MUN_ID = 23 will use the same symbol to denote the nodes. The default value 
assigned for group 23 is: 
"http://maps.google.com/mapfiles/kml/shapes/placemark_circle.png",0.8,50,50 

 GROUP_SYMBOL=30,"http://maps.google.com/mapfiles/kml/shapes/triangle.png",0.3,60
,60 – this determines which Google Earth symbol is used to represent the point data for 
that specific group. The number 30 refers to the MUN_ID as defined in 
MUNSYS_SP_TABLES, which is the ID used for Sewer Labels. Therefore, all sewer labels 
where MUN_ID = 30 will use the same symbol to denote the labels. The default value 
assigned for group 30 is 
"http://maps.google.com/mapfiles/kml/shapes/triangle.png,0.3,60,60" 
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 GROUP_SYMBOL=43,"http://maps.google.com/mapfiles/kml/shapes/placemark_square.p
ng",0.8,50,50 – this determines which Google Earth symbol is used to represent the point 
data for that specific group. The number 43 refers to the MUN_ID as defined in 
MUNSYS_SP_TABLES, which is the ID used for Water Nodes. Therefore, all water nodes 
where MUN_ID = 43 will use the same symbol to denote the nodes. The default value 
assigned for group 43 is 
"http://maps.google.com/mapfiles/kml/shapes/placemark_square.png",0.8,50,50

 GROUP_SYMBOL=48,"http://maps.google.com/mapfiles/kml/shapes/triangle.png",0.3,60
,60 – this determines which Google Earth symbol is used to represent the point data for 
that specific group. The number 48 refers to the MUN_ID as defined in 
MUNSYS_SP_TABLES, which is the ID used for Water Labels. Therefore, all water labels 
where MUN_ID = 48 will use the same symbol to denote them. The default value assigned 
for group 48 is "http://maps.google.com/mapfiles/kml/shapes/triangle.png",0.3,60,60

 GROUP_LABELSCALE=23,0.6, GROUP_LABELSCALE=43,0.6 and 
GROUP_LABELSCALE=48,0.6 – these are the Label scale settings for all objects falling 
within the groups where MUN_ID = 23 (SP_WATNODE; water nodes), MUN_ID = 43 
(SP_SEWNODE; sewer nodes), and MUN_ID=48 (SP_WATLABEL; water labels). For 
all of these node types the label scale has been set to 0.6.

Note This has no bearing on labels associated with symbols. The scale of the symbol determines the scale of 
the label.

 GROUP_OPACITY=12,60, GROUP_OPACITY=13,60 and 
GROUP_OPACITY=19,60 – this is the default opacity setting for all objects falling within 
the Groups where MUN_ID = 12 (SP_TP_ZONING), 13 (SP_TP_DENSITY) and 19 
(SP_TP_LANDUSE). The default opacity is set to 60%.

 GROUP_LINEWIDTH=3,1; GROUP_LINEWIDTH=25,2; 
GROUP_LINEWIDTH=45,2.5– this is the default linewidth setting for all objects falling 
within the Group where MUN_ID = 3 (SP_PARCEL), 25 (SP_SEWGPIPE) and 45 
(SP_WATPIPE).

 GROUP_BALLOON=3 – these parameters define the default configuration for the 
balloon and tooltip styles. The tags <<#GID#>> are editable and can be replaced with the 
required column value in the output.

 BUBBLE_BACKGROUND="D7DDE8" – this setting determines the background color 
of the attribute boxes. The default color is: BUBBLE_BACKGROUND="D7DDE8" 
which is a light blue/grey color.
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Using Munsys Google Tools
Before you execute the command MUNGOOGLEEARTH, you will first query the data that you 
want displayed into the AutoCAD Map drawing area using the Munsys Query functionality. 
For more information about querying data from the database, please consult the Munsys 
Concepts User Manual. You can select in which projection the data is queried into by selecting 
the Extras > Set Coordinate System menu option. It does not matter in which projection or co-
ordinate system the data is queried, as the data will be transformed to LL84 using the Map 
Coordinate files and Google Earth can only display data that is in LL84 (Lat/Long 84). 

Next, you will edit the .def file if you need to change any of the parameters or settings for the 
objects that you are going to display in Google Earth.

Executing the MUNGOOGLEEARTH command
The following example shows data that has been queried from the database:

Figure 2 Querying data from the database

To execute the MUNGOOGLEEARTH command, do one of the following:

 On the command line, type MUNGOOGLEEARTH, and then press ENTER.

 Choose Extras > Export Objects to > Google Earth.
The command line prompts you to enter a new title for the legend that will be displayed in Google 
Earth, or to accept the default title (Munsys Objects).

1 Type a new title, or press ENTER to accept the default title.

The Save File As dialog box is displayed. 
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2 On this dialog box, specify the filename and folder where the .kml file will be saved to. The default 
destination is C:\Temp.
The command line prompts you to select the objects that you want displayed in Google Earth.

3 Select the appropriate objects, and then press ENTER.

The objects are processed according to the parameters that were specified in the .def file. Next, 
Google Earth is launched automatically (if specified as such in the .def file), and the objects that you 
selected are displayed in Google Earth, as seen below:

Figure 3 MUNGOOGLEEARTH: displaying objects in Google Earth
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Spatial table MunIDs
The MunIDs with their associated table name are stored in the MUNSYS_SP_TABLES table. 
The following tables list the different MunIDs, their associated spatial table name and the 
Munsys Object Type for the Cadastral, Drainage, Electricity, Roads, Sewer and Water 
applications.

Munsys supports four basic geometry types to represent a spatial object:

 LABEL = Munsys Object Type 1

 POINT = Munsys Object Type 2

 LINE = Munsys Object Type 3

 POLYGON = Munsys Object Type 4

MunIDs for Cadastral spatial tables

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

1 SP_TOWN - INT locale 4 Townships

3 SP_PARCEL 4 Land Parcels

5 SP_SUBURB - INT locale 4 Suburbs

6 SP_BLOCK - INT locale 4 Block Boundaries

7 SP_WARD - INT locale 4 Wards

8 SP_STRTXT 1 Street Names

9 SP_STRADDR 1 Street Addresses

10 SP_EASELINE 3 Easement Lines

11 SP_EASELINETXT 1 Easement Line Text

12 SP_TP_ZONING 4 TP Zoning

13 SP_TP_DENSITY 4 TP Density

14 SP_EASEPOLY 4 Easement Polygons

15 SP_EASEPOLYTXT 1 Easement Polygon Text

16 SP_BUILDING 4 Buildings

17 SP_CMSNOTE 1 Cadastral Notes

18 SP_MUNICIPALITY - US 4 Municipalities

19 SP_TP_LANDUSE 4 TP Land Use
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MunIDs for Drainage spatial tables

MunIDs for Electricity spatial tables

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

61 SP_SWDIM 2 Stormwater Dimensions

62 SP_SWCATCH 4 Stormwater Catchments

63 SP_SWNODE 2 Stormwater Nodes

64 SP_SWNOTE 1 Stormwater Notes

65 SP_SWPIPE 3 Stormwater Pipes

66 SP_SWCHANNEL 3 Stormwater Channels

67 SP_SWCULVERT 3 Stormwater Culverts

68 SP_RIVERLINE 3 River Lines

69 SP_RIVERPOLY 4 River Polygons

70 SP_FLOODLINE 4 Floodlines

71 SP_DAM 4 Dams

72 SP_SWLABEL 1 Drainage Labels

73 SP_SWSERV 3 Stormwater Service 
Connections

74 SP_SWSYM 2 Stormwater Symbols

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

101 SP_ELCABLE 3 Electricity Cables

102 SP_ELNODE 2 Electricity Nodes

103 SP_ELDUCT 3 Electricity Ducts

104 SP_ELZONE 4 Electricity Zones

105 SP_ELNOTE 1 Electricity Notes

106 SP_ELDIM 2 Electricity Dimensions

107 SP_ELSERV 3 Electricity SCs
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MunIDs for Roads spatial tables

MunIDs for Sewer spatial tables

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

81 SP_RDCL 3 Road Center Lines

82 SP_RDINT 2 Road Intersections

83 SP_RDWALK 3 Road Walkways

84 SP_RDAREA 4 Road Areas

85 SP_RDEDGE 3 Road Edges

86 SP_RDNOTE 1 Road Notes

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

21 SP_SEWDIM 2 Sewer Dimensions

22 SP_SEWBASIN 4 Sewer Basins

23 SP_SEWNODE 2 Sewer Nodes

24 SP_SEWNOTE 1 Sewer Notes

25 SP_SEWGPIPE 3 Sewer Pipes (Gravity)

26 SP_SEWSERV 3 Sewer Service Connections

27 SP_SEWVPIPE 3 Sewer Pipes (Vacuum)

28 SP_SEWRPIPE 3 Sewer Pipes (Pressure)

29 SP_SEWRESPIPE 3 Sewer Residential Pipes

30 SP_SEWLABEL 1 Sewer Labels

31 SP_SEWSYM 2 Sewer Symbols

32 SP_SEWMAPPAGE 4 Sewer Map Page Grids
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MunIDs for Water spatial tables

MunIDs for Cable Route spatial tables

MunIDs for Cable Fiber spatial tables

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

41 SP_WATDIM 2 Water Dimensions

42 SP_WATZONE 4 Water Zones

43 SP_WATNODE 2 Water Nodes

44 SP_WATNOTE 1 Water Notes

45 SP_WATPIPE 3 Water Pipes

46 SP_WATSERV 3 Water Service Connections

47 SP_WATRESPIPE 3 Water Residential Pipes

48 SP_WATLABEL 1 Water Labels

49 SP_WATSYM 2 Water Symbols

50 SP_WATMAPPAGE 4 Water Map Page Grids

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

141 SP_CRTLINK 3 Cable Route Links

142 SP_CRTNODE 2 Cable Route Nodes

143 SP_CRTNOTE 1 Cable Route Notes

144 SP_CRTDIM 2 Cable Route Dimensions

145 SP_CRTSYM 2 Cable Route Symbols

146 SP_CRTLABEL 1 Cable Route Labels

147 SP_CRTINFSTRUCT 4 Cable Route Infrastructure

Mun ID Spatial Table Name
Munsys 
Object 
Type

Description

161 SP_FIBCABLE 3 Fiber Cable
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162 SP_FIBPATH 3 Fiber path

163 SP_FIBNOTE 1 Cable Fiber Notes

164 SP_FIBDIM 2 Cable Fiber Dimensions

165 SP_FIBSYM 2 Cable Fiber Symbols

166 SP_FIBSERV 3 Cable Fiber Service Connection

161 SP_FIBCABLE 3 Qry: Fiber Cable by Type

162 SP_FIBPATH 3 Qry: Fiber Path by Service

161 SP_FIBCABLE 3 Qry: Fiber Strand Count (In 
Use)
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Glossary of terms

annotation – the process whereby user-defined values are retrieved from spatial tables and represented as 
text on associated spatial objects. The values for the annotation are retrieved from spatial tables or linked 
tables.

attribute information/data – information about an object, which is stored in a table in the database and 
which is linked to the object by a unique identifier.

attribute template – used to customize the view of a table. This is done by selecting appropriate columns 
and setting their display order, displayed name and respective formatting parameters.

base map – a base drawing in Munsys serves as a template that automatically loads a configured map 
environment when Munsys is launched. This template includes pre-defined settings, serves as a method to 
enforce standardization in organizations and complements consistent output. 

block boundary *(used in the International version) – a block boundary binds a group of parcels with 
the edges of the road reserve, and is used to represent the cadastral data on a higher scale when parcel detail 
is not required.

buffer (GSC) – adds a zone of a specified width around a selected GSC. See also GSC.

cadastral data – the term “cadastral” refers to a map or survey showing administrative boundaries and 
property “lines”. Cadastral data is defined as an official register of the ownership, extent and assessed value 
of land for a given area, and also as the geographic extent of the past, current, and future rights and interests 
in real property, including the spatial information necessary to describe that geographic extent. In Munsys, 
cadastral data is used as the base data set.

coordinate file – a file containing a list of coordinates that are used to construct boundaries. 

coordinate system – a reference system using latitude and longitude to define the location of points on the 
surface of the earth.

construction color – the color that objects are displayed in the drawing area when they are still in the 
process of construction. See also working color.

customized query – in Munsys, there is least one system query for each spatial object type in the database. 
You can customize an existing system query (using the Define Query function on the Query menu), and 
save it as a “user query” for future use. See also system query.

database posting – the process of sending verified data for storage in the database.

data transformation – the process of transforming selected data from one coordinate system to another.

density – defines the number of units such as houses that may be constructed on a parcel.

easement – a registered area attached to a parcel for the benefit of the local authority. This area is used for 

Munsys concepts
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Glossary–ii

the installation of services or right of way; therefore the landowner is not allowed any permanent 
construction.

GID (Geographic Identifier) – a unique identifier that identifies a spatial object in a spatial table and 
serves as the link between a spatial object in the drawing and the associated data in the database tables.

grid crosses – a network of horizontal and vertical lines placed in a drawing at user- specified intervals. A 
grid cross contains coordinates at the intervals to simplify the location of intersection of the grid cross.

GSC (Geographic Search Criteria) – locates spatial objects from the database by their geographical 
location, making use of a polygon, window, fence, radius or object definition. The GSC settings apply 
restrictions on the geographical extent of spatial data retrieved from the database.

Helmert transformation – the methodology of transforming spatial data, attempting to eliminate the 
distortion of the data. Munsys does not distort the object, but only scales, rotates and moves it according to 
the indicated transformation control points.

integrity check – a set of rules to validate new or modified spatial objects against integrity rules built into 
the capture and change routines of every application before they can be posted to the database.

integrity markers – are placed to indicate where integrity errors have occurred when an integrity check is 
run on new or modified objects.

land use – the purpose for which the land is being used, based on functions and activities.

layer – a resource that references a feature source or a drawing source. The layer contains styling and 
theming information, and optionally a collection of scale ranges.

legend – a reference area on a map that lists and explains colors, symbols, line patterns, annotations, etc. 
used on the map.

link template – specifies how one table is related to another and is used when attribute information 
attached to spatial objects is edited, browsed or displayed. In Munsys, link templates are created in the 
Spatial Data Manager application by the database administrator.

mask (GSC) – determines how a GSC is applied as a spatial filter when retrieving data from the database. 
Mask settings used are Approximate, Crossing or Within. See also GSC.

medadata – a component of data which describes the data; also described as “data about data.” Metadata 
for a geographical data set describes the content, quality, condition, and other characteristics of the data 
(the who, what, when, where, why, and how about a data set).

MunID – a unique identifier to reference a spatial table within a Munsys schema.

Munsys Catalog – a “drawing filing cabinet” that stores extracted data from the database in an AutoCAD 
drawing format. The information about catalog drawings for all the users are stored in a central catalog. A 
catalog drawing is saved in the working directory that was specified when the Munsys applications were 
installed, or can be overwritten by the system administrator. Information about the catalog drawing is 
stored in the database.



Munsys Concepts User’s Manual

Glossary–iii

Munsys Object – a derivative of an AutoCAD entity with additional options for geometry presentation and 
attribute information. Munsys objects have been created to cater for the specific needs of the various 
Munsys applications in the AutoCAD environment.

MunPoly – a Munsys object containing one or more polygons, for example parcels or communities 
(suburbs, townships, municipalities, etc.). Polygons may be contained as islands within a boundary 
polygon, or may be disjoint in nature. See also polygon.

MunLine – a Munsys object containing one or more multi-segmented lines (polylines), for example roads 
or water pipes. Each multi-segmented line may be joined by any combination of straight or curved lines.

MunLabel – a Munsys object containing text information representing a specified column in the database. 
This text information is dynamic and changes according to the changes in the database.

MunPoint – a Munsys object containing point information displayed as either a point or symbol, for 
example manholes or pumps. Each MunPoint object may optionally represent multiple points (or clusters 
of points).

North point – a symbol that is placed facing North to indicate how the map is orientated

network integrity – checks and validates the rules that, together with the spatial objects, make up a 
network in an application. See also Integrity Check.

object integrity – checks and validates the spatial and/or attribute data of a spatial object against the 
integrity rules built into an application. See also Integrity Check.

parcel – a distinct portion of land, which is captured from a registered plan by means of coordinates or 
angles of direction and distance. Parcels are important spatial data in the Munsys system, as many of the 
capture functions rely on the location of parcels.

polygon – a two-dimensional closed figure with at least three sides.

query – a statement or expression that is used to retrieve data from the database.

query settings *(international version) – simplify the retrieval of parcels from the database, because you 
can predefine the format and conditions to retrieve the parcel data. You can also specify whether both 
parcel boundaries and tags (parcel numbers) should be retrieved, or only parcel polygons.

record locking – the locking and unlocking of spatial objects for editing purposes. When an object is 
locked, other users are prevented from editing that object until it has been unlocked or posted back to the 
database.

scale bar – a ruler that indicates the distance proportional to the geographical area.

spatial indexing – a mechanism to find objects within an indexed data space that overlap a given point or 
area of interest (window query), and to find pairs of objects from within two indexed data spaces that 
interact spatially with each other (spatial join).

spatial table – a table in a database containing geometrical representation of objects. In Munsys, a spatial 
table requires the following minimum spatial columns:
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spatial view – the process of mapping an existing external (non-Munsys) spatial table so that Munsys may 
recognize it as a “Munsys table”, and so that the data in the table can be queried using Munsys Applications.

status flag – indicate any changes requiring updates to the database. A status flag indicates when an object 
is new or has been modified, or whether it needs to be deleted from the database.

system query – a predefined query whereby data is extracted from the database. Each Munsys application 
has its own set of system queries. See also customized query.

tag – a text string used for annotation purposes, displayed at a position using various display attributes such 
as text height, rotation angle and justification.

working color – the color that is used to display new or modified objects that have not yet been validated 
by the integrity check.

zoning – the allowable use of the property, such as residential, business or commercial.
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A
adding a segment to a MunLine object 4- 156
aligning text to a position 6- 215
angle text to a line 6- 214
annotating spatial objects 8- 227
annotations 8- 227
arcs, densifying 5- 196
attributes, editing 4- 144

B
basemap, clearing 2- 30
boundaries, constructing from a coordinate file
5- 188
boundary, deleting 4- 164
breaking objects 4- 161
browsing information, 3- 88
browsing locked objects 4- 120

C
chamfering objects 4- 161
changing lines 5- 192
changing segment order 4- 157
changing text properties 6- 212
changing text values 6- 209
Changing the password used to connect to the
database 2- 25
Chapter 2 – Getting acquainted with Munsys 2
circle GSC 3- 51
circle size, changing 5- 198
circling short lines 5- 198
constructing boundaries from a coordinate file
5- 188
Converting a GSC to an AutoCAD object 54
coordinate file, creating 6- 185
coordinates, viewing 6- 187
creating a GSC 3- 47

D
data sources, in Munsys 2- 21
data transformation 5- 202
database, about 2- 21
database, disconnecting from 2- 25
defaults file, about 9- 237
deleting segments 4- 156
densifying arcs 5- 196
disjoint boundary, adding to MunPoly 4- 163
distance and angle, drawing lines 5- 189
distance and direction, drawing lines 5- 189
distance and direction, writing on lines 5- 190
duplicate lines, deleting 5- 199

E
editing segment vertices 4- 158
endpoints, showing 5- 199
extending an object by distance 4- 160
extending an object to a boundary 4- 160
extending and breaking an object 4- 160
extending and breaking lines 5- 195
extending lines by distance 5- 195

F
fence GSC 3- 48
filleting objects 4- 162
find the last object 7- 217
finding and replacing text 6- 206
fracturing lines 5- 198

G
generating MunPoly objects 4- 170
Geographic Search Criteria

buffer 3- 43
creating 3- 47
settings 3- 44
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showing active 3- 53
Geographic Search Criteria 3- 36
Google Tools, using 9- 242
grid crosses, generating 8- 226

H
hatch patterns, moving to the back 7- 221
Helmert transformation 5- 203

I
indexing of spatial data 2- 22
info palette 3- 101
inner boundary, adding 4- 163
Integrity Check, overview 4- 150
integrity toolbar 2- 24
interface 2- 23

J
joining lines 5- 192
joining segments 4- 156
joining text 6- 210

L
launching Munsys 2- 23
layer color range, setting 7- 218
layer setup, saving and loading 7- 220
layer, moving objects to another 7- 219
layer, moving to the back 7- 221
layer, moving to the front 7- 221
layer, setting as current 7- 217
layer, setting color 7- 217
layers 3- 36
layers, erasing objects on 7- 219
layers, freezing 7- 219
layers, locking and unlocking 7- 219
legends, creating 8- 232
link templates, managing 4- 132
linked table attributes, editing 4- 147
locking objects 4- 118

M
main toolbar 2- 24
mapping tools 8- 224
merging segments 4- 157
metadata 2- 32
MUNGOOGLEEARTH command 9- 242
MunIDs for Cadastral spatial tables 9- 244
MunIDs for Drainage spatial tables 9- 245
MunIDs for Electricity spatial tables 9- 245
MunIDs for Roads spatial tables 9- 246
MunIDs for Sewer spatial tables 9- 246
MunIDs for Water spatial tables 9- 247
MunLine objects

editing 4- 156
MunPoint objects

editing 4- 153
MunPoly objects

editing 4- 163
MunPoly vertex, editing 4- 164
Munsys catalog

browsing drawing files 2- 29
inserting spatial objects from 2- 29
writing spatial objects to 2- 28

Munsys catalog 2- 28
Munsys objects, components 4- 114
Munsys options

specifying 4- 126
Munsys reports 3- 110
Munsys user interface 2- 23

N
north point, inserting 8- 224

O
object display properties, editing 4- 183
object locking

browsing locked objects 4- 120
locking objects 4- 118
showing locked objects 4- 119
unlocking locked objects 4- 121
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P
placing incremental text 6- 208
point GSC 3- 52
polygon GSC 3- 49
polylines, weeding 5- 199
prefix, adding to text 6- 210

Q
queries

filter condition 3- 41
querying block boundaries 3- 82
querying buildings 3- 86
querying cadastral data 3- 78
querying cadastral notes 3- 87
querying easements 3- 83
querying parcels 3- 81
querying street addresses 3- 85

query categories 3- 37
query palette

GSC functions 3- 55
GSC pane 3- 38
query pane 3- 38

query palette 3- 38
query properties 3- 61

R
record locking 4- 117
report, creating 3- 110
reversing segments 4- 157
rotating by reference 5- 192

S
scale bar, generating 8- 225
show the active GSC 3- 53
showing endpoints 5- 199
showing locked objects 4- 119
Spatial table MunIDs 9- 244
spatial view, adding 3- 73
splaying corners 5- 195
splitting a single line 5- 193

splitting double lines 5- 194
standard toolbar 2- 23
suffix, adding to text 6- 211
symbols

changing angle 4- 182
changing scale 4- 182

T
tags

adding a prefix 4- 181
adding a suffix 4- 181
aligning position 4- 180
aligning to a specified angle 4- 180
changing angle 4- 178
changing height 4- 179
changing justification 4- 179
changing position 4- 179
changing value 4- 178
finding 4- 177
reset position 4- 180

tags 4- 176
text angle, changing 6- 212
text size, changing 6- 212
text style, changing 6- 213
text width, changing 6- 214
tooltips 4- 127
transforming data 5- 202
trimming MunLine objects 4- 162

U
unlocking locked objects 4- 121
user interface 2- 23

V
viewports, working with 8- 223

W
weeding objects 4- 162
window GSC 3- 48
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Z
zoom to GSC extents 3- 53


	Contents
	Introducing the Munsys Concepts User Manual
	About this manual
	What’s in this manual
	Conventions in this manual
	Finding the information you need

	Getting acquainted with Munsys
	Munsys Features
	Introducing the Munsys Applications
	Munsys Cadastral
	Munsys Drainage
	Munsys Electricity
	Munsys Roads
	Munsys Sewer
	Munsys Water
	Munsys Map Books
	Munsys Spatial Data Manager
	Munsys Management Console
	Munsys Export Administrator
	Munsys Query
	Munsys Lineage
	Munsys Reports
	Munsys Cable Route
	Munsys Cable Fiber

	About the Oracle database
	About Munsys objects
	Launching Munsys
	The Munsys user interface
	Connecting to the Oracle database
	Disconnecting from the Oracle database
	Changing the password used to connect to the database
	Loading the Munsys application of your choice

	About Munsys catalog drawings
	About the basemap
	Using metadata
	Managing metadata contacts
	Managing spatial tables for metadata
	Exporting metadata for spatial tables
	Munsys Menu AutoFix


	Querying spatial data in Munsys
	About queries
	Introducing query categories
	Introducing the Munsys Query Palette
	The Query Palette: Query pane

	Specifying Geographic Search Criteria (GSC)
	Specifying GSC settings

	Creating a GSC
	Converting a GSC to an AutoCAD object
	GSC functions on the Query Palette
	Setting a GSC as current
	Deleting a GSC
	Renaming a GSC
	Save a GSC as System GSC

	Changing the properties of a GSC
	Adding objects to a GSC

	Querying data from the database using the Query Palette
	Specifying query preferences
	Creating a user-defined query
	Specifying or changing query properties
	Querying data as AutoCAD objects - Improvement
	Specifying a filter condition for a query
	Executing queries from the Query Palette

	Adding a spatial view
	Removing a spatial view

	About cadastral data
	Querying cadastral data from the database from the Query menu
	Querying suburbs
	Querying parcels
	Querying block boundaries
	Querying easements
	Querying street names
	Querying street addresses
	Querying buildings
	Querying cadastral notes

	Browsing information
	Browse Selection
	Browsing Info using predefined Queries
	The Browsing Info Window
	Browsing Tables and Views

	Showing information about spatial objects
	Introducing the Munsys Info Palette

	Setting a coordinate system
	Munsys reports

	Working with Munsys objects
	Components of each Munsys object
	Munsys record locking
	Locking objects
	Showing locked objects
	Browsing locked objects
	Unlocking locked objects

	Refreshing the geometry of spatial objects
	Converting CAD objects to Munsys objects
	Munsys options
	Specifying Munsys options

	Managing link templates
	Creating link templates
	Editing link templates
	Deleting link templates

	Managing attribute templates
	Creating attribute templates
	Editing attribute templates
	Deleting attribute templates

	Editing spatial object attributes
	Editing linked table attributes
	The Integrity Check function – an overview
	Validating object integrity and posting data to the database at the same time

	Editing Munsys objects
	Editing MunPoint objects
	Adding points to MunPoint objects
	Deleting points from MunPoint objects
	Replace Geometry for MunPoint objects

	Editing MunLine objects
	Adding a segment to a MunLine object
	Deleting segments
	Joining segments
	Merging segments
	Reversing segments
	Changing segment order
	Editing segment vertices
	Deleting multiple vertices on a MunLine object
	Extending an object to a boundary
	Extending an object by distance
	Extending and breaking an object
	Breaking objects
	Chamfering objects
	Filleting objects
	Trimming MunLine objects
	Weeding objects

	Editing MunPoly objects
	Adding a disjoint boundary to a MunPoly object
	Adding an inner boundary
	Deleting a boundary
	Editing a MunPoly vertex
	Deleting multiple vertices on a MunPolygon Object
	Split Geometry

	Edit MunLabel Objects
	Generating MunPoly objects
	Rebuilding existing MunPolygon objects
	Validating a MunPolygon

	Working with tags
	Placing a tag
	Finding a tag
	Changing a tag value
	Changing a tag angle
	Changing tag height
	Changing tag justification
	Changing tag position
	Aligning tags to a specified angle
	Aligning tag position
	Resetting a tag position
	Adding a tag prefix
	Adding a tag suffix

	Changing symbol properties
	Changing the angle of a symbol
	Changing the scale of a symbol

	Editing object display properties

	Munsys line tools
	Creating a coordinate file
	Viewing coordinates

	Constructing boundaries from a coordinate file
	Additional capture options
	Drawing lines by distance and direction
	Drawing lines by distance and angle
	Writing distance and direction on lines
	Rotating by reference
	Joining lines
	Changing lines
	Splitting a single line
	Splitting double lines
	Splaying corners
	Extending and breaking lines
	Extending lines by distance
	Densifying arcs

	The cadastral cleanup process
	Fracturing lines
	Circling short lines
	Changing circle size
	Showing endpoints

	Weeding polylines
	Deleting duplicates
	Generating AutoCAD polygons
	Data transformation
	Helmert transformation

	Munsys text tools
	Finding and replacing text
	Placing incremental text
	Changing text values
	Editing text
	Joining text
	Adding a prefix to text
	Adding a suffix to text

	Changing text properties
	Changing text angle
	Changing text size
	Changing text style
	Changing text width
	Angling text to a line
	Aligning text


	Munsys layer formatting
	Finding the last object
	Setting a layer as current
	Setting a layer color
	Setting a layer color range
	Freezing layers
	Locking and unlocking layers
	Erasing objects on specific layers
	Moving objects to another layer
	Saving and loading a layer setup
	Display order

	Creating maps
	Working with viewports
	Creating a viewport
	Setting the viewport scale
	Changing the viewport angle

	Munsys mapping tools
	Inserting a north point
	Generating a scale bar
	Generating grid crosses

	Annotations
	Munsys legends

	Munsys Google Tools
	About the defaults file
	Google Tools defaults file: General
	Google Tools defaults file: Google Earth

	Using Munsys Google Tools
	Executing the MUNGOOGLEEARTH command

	Spatial table MunIDs

	Glossary of terms

